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1 FSM Overview 
Introduction 
The amount of traffic in our National Airspace System (NAS) is expected to grow at least 3-5% 
for the next 15 years. The NAS is a static resource and the Federal Aviation Administration 
(FAA) needs to find a balance between the increase in traffic and available resources in the NAS. 
The FAA responded to this issue by developing Free Flight. Free Flight is an innovative concept 
designed to enhance NAS safety and efficiency by transitioning from a centralized command and 
control system to a distributed planning system. 

Collaborative Decision Making (CDM) is one of the five core products in Free Flight Phase I. 
CDM is a joint government/industry initiative aimed at improving air traffic management through 
increased information exchange, common situational awareness, equitable resource allocation, 
and performance analysis. 

Flight Schedule Monitor (FSM) was used in CDM's first major thrust, Ground Delay Program 
Enhancements, and the FAA has continued to use it since it went into Prototype Operations in 
January 1998. FSM fulfills the CDM goal of giving all users common situational awareness. 
FSM does this by displaying a current picture of air traffic demand at airports using real-time data 
culled from CDM participant data and aggregated by Volpe National Transportation Systems 
Center. Using this picture, air traffic specialists and airline operations centers alike make better 
decisions and keep traffic flowing as smoothly as possible. 

When adverse conditions affect an airport, they also affect traffic flow. The airport cannot handle 
a normal amount of arriving and departing aircraft which disturbs operations. One method the 
FAA uses to compensate for reduced capacity at an airport is to delay flights arriving at that 
airport before these flights take off. This is known as a Ground Delay Program (GDP). As part of 
CDM Prototype Operations, all FAA traffic management personnel use FSM to determine the 
necessity for ground delay programs and other traffic management initiatives and to enact them. 

FSM has been continuously enhanced since the early prototype capability to include better 
functionality and support for the ever-expanding user community. FSM was originally designed 
with C++ programming language. To better serve the CDM community, and to keep up with 
improving technology, FSM was completely rebuilt on the Java platform in the fall of 2003. The 
Java FSM architecture can support a large number of concurrent users at a single site. Java FSM 
can also greatly improve threading options and enhance file handling. Additional features include 
built-in cross-platform user interface support. 

Today, traffic management specialists across the NAS and Canada, as well as over 40 CDM-
participant airlines use FSM to monitor and manage airport demand and capacity. 

The FAA Air Traffic Control System Command Center (ATCSCC) uses FSM to: 

• Monitor airports - view the existing demand and constraints at these airports 
• Model and run traffic management initiatives, including airborne holding, 

GDPs, and Ground Stops (GS) 
• Update EDCTs through the use of EDCT Change Request (ECR) 

Traffic Management Units use FSM on a daily basis in more than 80 FAA air traffic control 
(ATC) field facilities to monitor capacity and demand at over 50 airports. 

Airline operations centers (AOCs) use FSM to: 
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• Monitor airports by viewing existing demand and constraints at these airports 
• Analyze the impact of proposed GDPs on their operations 
• Model flight cancellations 
• Send Slot Credit Substitution (SCS) requests to the hub site through the ECR 

component 

Purpose and Scope 
FSM has two major purposes: 

1. Monitoring Airport Capacity/Demand Data 

2. Managing Traffic Flow 

FSM monitors flights arriving at and departing from an airport while tracking demand and 
capacity. When an imbalance exists, traffic management specialists analyze different 
combinations of GDPs, airborne holding, etc. to determine the best way to fix the imbalance. 
Once the traffic management specialists determine an airport needs a traffic management 
initiative (TMI), FSM sends out the parameters to the users and updates its own data accordingly. 
Airline operations' users model the effects of the TMI and decide whether to alter their own 
operations. 

FSM displays both Monitored Live (Online) and Historical CDM data. Traffic management 
specialists use Live data to monitor the current situation at any airport. In Monitor Live data 
mode, FSM updates demand in the flight schedule display approximately every 5 minutes to keep 
the picture current. FSM users can examine historical data to replay a day's events and analyze 
the effects of all traffic management programs. 

Limitations and Contacts 
This document describes FSM as of 9/15/2004. Because FSM is an evolving product, future 
enhancements (i.e.- modifications and additional functions) will be introduced into this guide as 
they become available. 

For information and/or technical assistance with FSM software, contact the following: 

Government Personnel Airline Personnel 

ETMS Hotline 
(703) 904-3343 
 

FSM Support  
(703) 234-0769 
fsm_support@metronaviation.com 

Conventions 
Conventions are the same throughout all FSM components unless otherwise specified. 

Keyboard and Mouse Conventions 

Command  What It Means 

File > 
Open  Choose the Open option from the File menu. 
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Command  What It Means 

Click  Click once with the left mouse button. 

Ctrl + click  Press the Ctrl key while clicking with the left mouse button. 

Double-
Click  Click twice with the left mouse button. 

Ctrl 1  Press and release the Ctrl key; then press and release the number "1" key on the keyboard. 

Checkmark  Select the option with the left mouse button to make a checkmark appear in a checkbox. 

CTRL + A Press the Ctrl key while pressing the A key on your keyboard. Displays arrival data in the 
active component  

CTRL + C Press the Ctrl key while pressing the C key on your keyboard. Command used to close a 
window or component. 

CTRL + D Press the Ctrl key while pressing the D key on your keyboard. Displays departure data in the 
active component. 

CTRL + F Press the Ctrl key while pressing the F key on your keyboard. Finds a particular flight by 
entering the flight’s call sign and origin airport. 

CTRL + L Press the Ctrl key while pressing the L key on your keyboard. Displays a color legend for the 
active component. 

CTRL + P Press the Ctrl key while pressing the P key on your keyboard. Prints the active component on 
your screen. 

CTRL + R 
Press the Ctrl key while pressing the R key on your keyboard. Displays the Rename Window 
dialog box and allows you to change the title bar name of the active component on your 
screen. 

CTRL + S Press the Ctrl key while pressing the S key on your keyboard. Command used to save data. 

CTRL + S Press the Ctrl key while pressing the S key on your keyboard when in Historical Mode, 
allows you to designate which time to view within a set of historical data. 

ALT + F4 Press the Alt key while pressing the F4 key on your keyboard. Shuts down the component 
that you are viewing. 

F1 Press the F1 key on your keyboard to access the web based on-line help for the active 
component. 

 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


FSM Overview 

Version 7.9 1-4 

Note: All keyboard functions work the same in all components unless 
stated otherwise. If you use a particular keyboard command on a 
component where that option is not available, FSM makes no changes to 
the component. Ensure the component you want to submit is “active” 
when executing a command. 

Common Terms Used in This Document 
Component, Window, and Panel – The three terms are used interchangeably throughout this 
document. They refer to the active window on your screen. 

Active - This document uses the term active in two different ways. First, if several windows are 
open, only one window can accept user input from either the mouse or keyboard - that window is 
active. Second, within the active window, only one action button, push button, or text entry field 
is active. 

DAS (Delay Assignment) – The default delay assignment mode, formerly known as FA delay.  

Dialog box - A window that allows the user to enter text and use buttons to make choices. 

Checkbox – A picture of a square box (checked or not checked) appears on the screen. When you 
select the Checkbox, a checkmark appears in the box and the item associated to that checkbox is 
selected. You can select several checkboxes at any one time. 

Radio button - A picture of an analog push button (a circle with or without a dot) appears on the 
screen. When you select a radio button, a dot fills in the circle. You can select exactly one radio 
button in a group of radio buttons at any time. 

Aggregate Demand List (ADL) - When Volpe National Transportation Systems Center receives 
updated flight schedules and other NAS information from participating CDM AOCs, Volpe sends 
the information back to the users in the form of an Aggregate Demand List (ADL). FSM uses the 
ADLs, which Volpe updates approximately every 5 minutes, to process data and display the 
information. The ADL consists of 53 data fields, each of which this document describes in detail 
in Chapter 6. 

Airport Arrival Rate (AAR) - The number of arriving aircraft that an airport can accommodate 
during a certain period of time. 

Airport Departure Rate (ADR) - The number of departing aircraft that an airport can 
accommodate during a certain period of time. 

CDM (Collaborative Decision Making)- One of 5 core products in Free Flight Phase I, 
Collaborative Decision Making is a joint government/industry initiative with the goal of 
improving air traffic management through increased information sharing, common situational 
awareness, and equitable resource allocation. 

Delay - Delay is defined as Estimated Time of Arrival (ETA) - (IGTA - taxi). IGTA is the initial 
gate time of arrival, and taxi (unless otherwise specified by the user in Ground Delay Tools 
(GDT) mode has a default value of 10 minutes. 

GAAP (General Aviation Airport Program) – A delay assignment mode used during a GDP when 
current demand does not meet capacity but it believed that unknown traffic will meet or near 
capacity.  Unassigned slots are allocated for future pop-up demand.  

Ground Delay Operations - Any one of a number of ways to delay flights on the ground. This 
includes GDPs, GSs and Airborne holding. 
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Ground Delay Program (GDP) - A specific Ground Delay Operation, which assigns delay 
(control times) to flights before departure. 

Ground Stop (GS) - A specific Ground Delay Operation, which grounds (holds) flights for a 
specified amount of time at their departure airports. 

EDCT Change Request (ECR) – Use the EDCT Change Request tool to view and update an 
arriving flight’s control times during a GDP. 

Slot Credit Substitution (SCS) - A situation that commonly occurs during GDPs where an 
operator has a flight f0 with a slot at time t0, and flight f0 cannot use its slot because it is delayed 
or cancelled. In these situations, SCS provides a mechanism for an operator to substitute other 
operator’s flights to bridge the slot from an unusable time to a time that the operator can use to 
his/her advantage. SCS is an enhancement to the simplified substitution process implemented in 
ETMS 7.2. 
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2 Understanding FSM Features 
Introduction 
This section provides a brief overview of the three FSM data modes: Monitored Live mode, 
Historical, and Ground Delay Tools (GDT) Mode. Monitored Live mode allows you to monitor 
and display airport capacity and demand. Historical Mode allows you to review past airport 
events through archived data and is an excellent way to conduct post analysis. Ground Delay 
Tools Mode allows you to model and issue Traffic Management Initiatives (TMIs), such as 
Ground Delay Programs (GDPs) and Ground Stops (GSs). The data mode appears after the ADL 
time in the title bar of each component (see Figure 2-1). 

 
Figure 2-1: FSM Bar Graph Component 

For more detailed information on individual components, see Chapter 3: Understanding 
Components. 

Understanding Monitored Live Mode 
In Monitored Live mode, you can monitor airport capacity and demand information for both 
flight arrivals and departures in various FSM components. FSM updates demand data 
approximately every 5 minutes in Monitored Live mode, with every new ADL. FSM provides 
information that supports detailed flight data and various types of demand count lists. If a flight 
violates pre-defined parameters, FSM generates alarms. 

When opening components from the Open Data Set component, the two default Monitored Live 
Mode components are: 

• Bar Graph – Displays demand versus capacity of a specified airport 
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• Time Line – Displays how flights are distributed throughout each hour 

These two components open by default if you do not change the Open With options in the Open 
Data Set component. You can also open the Time Line and Bar Graph components individually 
from the US Map component. You can access the Flight List component using the Open Data Set 
as well, but it is not the default selection. See Chapter 4 for more information on how to open 
FSM. 

Figure 2-2 shows a possible Monitored Live mode windows management. In this example, the 
user selected ATL from the Open Data Set component. The two default components, Time Line 
and Bar Graph, display automatically when the user does not select any other components in the 
Open With selection box of the Open Data Set component. 

 
Figure 2-2: Monitor Mode (Live) 

 
Understanding Historical Mode 
Historical mode allows you to select any data set stored in a database. You can use this data to 
analyze scenarios or replay the day’s air traffic events. From the Open Data Set component with 
the Historical tab active, you can drill down to find the year, month, date, and airport of the 
desired information you want to view. Once you select the date and airport, FSM gives you the 
option of selecting a data time. See the Open Data Set component in Chapter 3 for more 
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information. FSM displays Historical mode data in much the same way as the Monitored Live 
mode, however, the word Historical appears next to the ADL time stamp in each Historical mode 
component. In Historical mode, you can view data in the same 5-minute ADL increments in 
which it originally arrived. Click Update on the Control Panel component to update the data to 
the next historical ADL time (see Figure 2-3). 

You must open the Historical mode data using the Open Data Set component. The two default 
Historical mode windows are: 

Bar Graph component - Displays demand versus capacity of a specified airport. 

Time Line component - Displays flight distribution throughout each hour. 

These two components open by default if you do not change the Open With options in the Open 
Data Set component. You can access the Flight List component using Open Data Set as well, but 
that is not the default selection. 

 
Figure 2-3: Historical Mode 

Understanding Ground Delay Tools 
Although you primarily use Monitored Live mode to monitor airport demand/capacity balance 
and flight information, you use GDT mode to help make air traffic management decisions and 
conduct analysis. You must first select a data set, or airport, in either Monitored Live mode or 
Historical mode to access GDT Mode. Once you select a data set, click GDT Setup on the 
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Control Panel component to open the airport in GDT mode. Four default components initially 
display when you open GDT Mode. For detailed information on the GDT components, see 
chapter 3. 

Note: GDT mode displays flight arrival information since GDPs only affect 
flights arriving at the monitored airport. Departure information is not available in 
GDT mode components. 

The GDT components look similar to Monitored Live mode, with the exception of the GDT 
Setup and GDT Data Graph components (see Figure 2-4). The four default components that 
display when you open GDT mode are: 

GDT Setup – Displays the main TMI setup panel, where you enter the parameters. 

Data Graph – Displays Power Run Statistics for modeled TMIs in graphical format. 

GDT Map – Displays the Tier/Distance scope as well as individual centers and airports for a 
modeled TMI. 

Bar Graph – Displays demand versus capacity into the airport selected. 

 
Figure 2-4: GDT Mode 

Additional components available in GDT data mode: 

• GDT Data Table component – Displays the same data viewed in the Data 
Graph in tabular format. 

• Flight List component – Displays the flight list of the selected airports. 
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• GDT Time Line component – Displays flight distribution throughout each 
hour. 

FSM Software Technical and Visual Cues 
Technical Cues 
As mentioned in Chapter 1, the initial design for FSM used the C++ programming language, but 
to keep up with improving technology and to better server the CDM community; the new design 
for FSM uses Java to completely rebuild the application. You will notice some differences from 
the C++ version when using Java-based FSM. Most programming languages, such as C++, 
compile source code directly into machine code, which is executed in a particular microprocessor 
architecture. Instead, Java runs in a Java Virtual Machine (JVM) and is interpreted, not compiled. 
What this means to you is that commands tend to take a few more seconds to execute. For 
example, if you click Show Open Data Set on the Control Panel, the Open Data Set component 
may take a second longer to appear on your screen. The main advantage of the new Java 
architecture is that it supports a wide range of platforms, this gives Java FSM the same look and 
feel across platforms. 

Java software needs a Java Runtime Environment (JRE) on your computer to execute. FSM 
Version 7.9 requires a JRE version 1.4.1 or higher. Without an available JRE for a given 
environment, it is impossible to run Java software. For more Technical information, please see 
the FSM 7.6+ Technical Guide. 

Visual Cues 
Dropdown menu boxes do not automatically collapse when you move the cursor away from the 
dropdown box. Expanded menu boxes remain open until you click somewhere else on the screen 
(not in the box). Secondary boxes, as shown in Figure 2-5, act slightly different. You must move 
the cursor directly to the left or right, then up or down to select an option from the secondary pop-
up menu. If you try to cut across diagonally, the pop-up menu collapses. 
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Figure 2-5: Java Navigation 

Windows Conventions 
This section provides an overview of the FSM user interface. It describes the windows, the menu 
bars, toolbars, and other important features. Figure 2-6 shows the FSM Control Panel component. 
This panel appears for all FSM modes. 

 

 
Figure 2-6: Control Panel 

Title Bar 
The Title bar contains a control icon, window title, and Windows buttons. 

 
Figure 2-7: Title Bar 

The control icon appears on the left side of the title bar. Click it to open the Control menu, which 
contains commands for positioning, resizing, minimizing, maximizing and closing the window. 
Double-clicking on the control icon closes the window. 

The window title describes the contents of the window. In the Title display you see the window 
name, airport three-letter identifier, date, ADL time and the data mode. Double-clicking the 
window title area is the same as clicking the Window Maximize or Restore buttons. 
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Use the Window buttons located on the right side of the title bar to resize and close the window. 

Table 2-1: Window Buttons 

Minimize  Reduces the window to its windows icon on the taskbar 

Maximize  Enlarges the window to fill the screen 

Restore  Returns the window to its last size and position 

Close  Closes the window 

Menu Bar 
The Menu bar, positioned directly below the title bar, displays the menu headings. 

 
Figure 2-8: Menu Bar 

The menus that are available depend on the window. Click a menu heading to open the menu and 
choose a command. The arrows next to a command indicate another submenu for that command. 
Open the submenu by placing the mouse cursor over the menu command (see Figure 2-9). 

 
Figure 2-9: Submenu Structure 

Toolbar 
The docked toolbar appears directly under the menu bar. 

 
Figure 2-10: Control Panel Toolbar 

 

The toolbar contains shortcut buttons for frequently used commands. The commands that are 
available depend on the window. By default, the Toolbar docks at the top of the window. You can 
undock it and move it to any location on your screen. Move the toolbar to your desired location 
by left-clicking the gray dots next to Show Open Data Set and dragging. When you move the 
Toolbar, the window title displays Core. Close the undocked window to re-dock the Toolbar to 
its original window. 
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Figure 2-11: Moved Toolbar 

Airport Shortcut Keys 
All airports and their respective data modes currently opened by the FSM client are displayed as 
shortcut buttons on the Control Panel component. 

The airport that is active, or in focus, on your screen is listed on the Control Panel component 
next to Data Set text and the active airport butto9n is highlighted in orange (see Figure 2-12). 

 
Figure 2-12: Control Panel 

 

Listed below are the various buttons that are available when an airport is opened in various data 
modes:  

• Live Date Mode –Airport’s three-letter identifier (i.e. ATL) 
• GDT Data Mode – Airport’s three-letter identifier/G (i.e. ATL /G) 
• Historical Mode – Airport’s three-letter identifier/H (i.e. LGA/H) 
• Historical Mode/GDT – Airport’s three-letter identifier/GH (i.e. LGA/GH) 

Hovering the cursor over an airport button on the Control Panel will display a tool tip that 
describes the airports data set in more detail.  GDT tool tips display year/month/day/airport for 
the dataset button.  Historical mode will display the year/month/day/airport/ADL time for the 
dataset button. 

Tabs 
Tabs appear on most FSM components. Selecting a tab makes that tab active. The tab that is 
active is highlighted. Tabs found in the Bar Graph and Time Line are different display options. 
When you select a tab, the coloring option appears in the component. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


FSM Features 

Version 7.9 2-9 

For example, Figure 2-13 shows the Bar Graph with the coloring tab Arrival Status selected. The 
time increment buttons appear as 15, 30, and 60 minute buttons with a blue line underneath each 
number. 

 
Figure 2-13: Component Tabs 

Windows Position and Resizing 
When more than one window appears on your screen, a window must be active to use it. Activate 
the window by clicking anywhere on it. The title bar of an active window is blue, while the title 
bar of an inactive window is gray.  
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Resizing windows allows you to view more windows on your screen at one time. To resize a 
window, position the cursor on any of the borders of the window until your cursor changes to a 
double-sided arrow. When this appears, click and drag in the direction of your choice. When 
placing your cursor over a corner, the double-sided arrow is diagonal. This allows you to move 2 
sides of the window at the same time. 

 
Figure 2-14: Windows Resizing 

Moving a Window 
You can move around the windows in FSM to suit your needs. Left-click the title bar of the 
window and drag it to move it to a desired position on the screen. 

Note: The cursor remains as the normal cursor and not a double-edged arrow. 
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3 Understanding Components 
Monitored Live Mode Components 
Use Monitored Live mode components to monitor airport capacity and demand information for 
both flight arrivals and departures. Demand data updates approximately every 5 minutes in live 
mode, with every new ADL. This section familiarizes you with the main Monitored Live mode 
components: 

• Control Panel 
• Open Data Set 
• US Map 
• Query Manager 
• Bar Graph 
• Time Line 

Control Panel Component 
The first component you see upon opening FSM is the FSM Control Panel. The Control Panel 
component allows you to access all other FSM components for displaying, monitoring, and 
managing traffic flow at any airport. The Control Panel consists of the menu bar and six buttons, 
the explanation for each of these buttons appears below. When you open an airport, an associated 
button appears just above the Connected Servers information (the text beneath the Control Panel 
buttons that identifies the server to which FSM is connected). 

 
Figure 3-1: Control Panel Component 

Control Panel Menu Bar 

The menu bar in the Control Panel Component contains eight options: File, View, Reports, 
Alerts, ETMS Tools, Utilities, Window, and Help. 

1. File Menu 

• File > Open Data Set - Opens the Open Data Set component, which allows 
you to open an airport in both Live and Historical data modes. 

• File > Load Adaptation - Loads a previously saved adaptation with your 
display preferences. For example, on a regular basis you monitor ATL airport 
with the Time Line and Bar Graph components displayed, you can save this 
configuration and select Load Adaptation to view the desired data in that 
format. 

• File > Save Adaptation - Saves your current windows management for an 
airport. You can reopen this adaptation later using File > Load Adaptation. 
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• File > Exit - Closes the Control Panel component and exits the FSM 
application. 

2. View Menu 

• View > Status Map - Opens the US Map component, to view airports 
currently being monitored by FSM. The Map component also shows when 
there is a TMI in place for any particular airport. 

• View > GDT Setup – Opens the GDT Setup components for selected 
airports. 

• View > Flight List – Opens the Flight List for a selected airport. 
3. Reports Menu 

Under the Reports Menu, there are seven Counts Lists: 
• Counts > By Demand – Displays arrival demand in 15-minute interval flight 

counts and totals the flight count for each hour. This is a quick way to check 
the arrival demand for each hour. 

• Counts > By Centers – Provides flight counts according to departure 
centers. There are 27 centers and “ZZZ,” which includes any center not part 
of the initial 27. Again, in Monitored Live mode, FSM bases these counts on 
flights’ ETA times, as displayed in the FSM Time Line. 

• Counts > By Aircraft Type – Displays a count list based on the aircraft 
type. This Count List incorporates the same classifications for aircraft type as 
in the FSM Color By Aircraft Type option. That is, FSM classifies them 
according to the aircraft type as specified by the manufacturer. 

• Counts > By Aircraft Class– Provides flight counts according to the aircraft 
weight. This Count List incorporates the same classifications for aircraft 
weight as FSM’s Color By Aircraft Class menu option. 

• Counts > By Arrival Fix – Provides flight counts according to the arrival fix 
at which each flight is arriving for the monitored airport. Arrival fix names 
for each airport vary. FSM automatically generates the correct Arrival Fix 
names for the monitored airports and uses them in the Count List headings. 

• Counts > By Departure Fix – Provides flight counts according to the 
departure fix at which each flight is arriving for the monitored airport. 
Departure fix names for each airport vary. FSM automatically generates the 
top 11 departure fixes for the monitored airport and uses them in the Count 
List headings. If the departure fix is other than these 11 or is unknown, FSM 
lists the flight under the “Other” column. 

• Counts > By User – Provides a flight count according to the classification of 
the aircraft. Counts By User classifies flights according to their function in 
the NAS. There are 7 user types in FSM: 

o C – Air Carriers 
o T – Air Taxi 
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o F – Freight/Cargo Carriers 
o M – Military 
o G – General Aviation 
o - Other – This class includes flights that do not belong to one of the 

five categories listed above.  
o U – Unknown – This category is for flights which may fall into a 

user category, but the classification for them is not known in FSM. 
• Counts > By Unassigned Slots – Lists all unassigned slots for each 15, 30, 

and 60 minute time-bin. The report is dynamic-it updates with each new 
ADL FSM receives. 

Under the Reports Menu, there are five Compliance reports: 

• Compliance > By CTD – Flights included in a delay program that violate 
departure compliance. By default, flights that violate arrival compliance are 
defined as flights arriving more than 5 minutes before or 5 minutes after their 
Control Time of Departure (CTD). Any flight that has an Actual Runway 
Time of Departure (ARTD) of 5 minutes earlier or 5 minutes later than their 
CTD triggers the CTD Compliance Alarm. 

• Compliance > By ETE – Difference between the Estimated Time En-route 
(ETE) estimated by Enhanced Traffic Management System (ETMS) and 
actual flight time is greater than a specified value, but the flight status is not 
"cancelled."  

• Compliance > By CTA – - Flights included in a delay program that violate 
arrival compliance. By default, flights that violate arrival compliance are 
flights arriving more than 5 minutes before or 5 minutes after their CTA. 

• Compliance > Spurious Flights – Flights submitted as UX Cancellations 
with no corresponding entries in the OAG. 

• Compliance > Cancelled That Flew – Flights submitted with a "Cancelled" 
status that flew at a later time within the program parameters. 

When one of FSM's compliance alarms is triggered for a flight, FSM generates a list of flights 
that have triggered an alarm. Alarms are triggered in accordance with the reasons listed above. 

FSM can generate additional reports upon request when flights do not comply with certain 
criteria. These reports update automatically with every ADL for all airports for which FSM 
collects data via its data collector. 

Note: The Report Lists include flights arriving only at the active 
monitored airport. 

Under the Reports Menu, there are seven additional reports: 

• Reports > Surface Delay – This report indicates the ground delay imposed 
on flights and contains departure information for arrival and departure 
flights. 
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• Reports > Priority Flights - This report is similar to an FSM Flight List, but 
lists flights specifically tagged as Lifeguard (LFG) or Diversion Recovery 
(DVT) flights. 

• Reports > Time Out Delay - This report quickly provides a picture for you 
of which flights from your operation are contributing to the Time Out delay 
problem. Easier access to this information should help you assess and resolve 
the problem. The format of this report is the same as the FSM Flight Lists 
which include all flights with a delay status marked as `TO’ (Time Out). 
Figure 3-2 illustrates a Time Out Delayed Flight List. All the TOD column 
checkboxes are marked, indicating that all flights on the list are Time Out 
Delayed. 

Note: When you initially open a Flight List, you may need to reposition 
the ADL data columns for easier viewing. 

 
Figure 3-2: Time Out Delayed Flight List 

• Reports > Time Out Cancel - This report quickly provides a picture of 
which flights from the operation are contributing to the Time Out cancel 
problem. Easier access to this information should help you review and 
resolve the problem. This report is in the same format as the FSM Flight 
Lists and includes all flights with cancellation status of TO. 
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• Reports > Slot Hold - This report is similar to an FSM Flight List, but only 
lists flights with their slot hold flag set to Y. 

• Reports > Sub Opportunities – Provides a flight list to assist airlines and 
general aviation customers in identifying subbing opportunities. 

• Reports > Slot List- Provides a slot list for a specified airport or an airline 
and its sub-carriers at a specified airport in the exact format that goes to the 
airlines. 

• Reports > Carrier Statistics - Opens a report displaying delay statistics for 
all carriers with flights operating at the specified airport. Only flights with 
arrival slots are calculated in the report metrics. That is, flights with a CTA 
appear in the carrier statistics. If a carrier operates at the airport, but has no 
flights with a CTA, the Carrier Statistics report displays “0” or “N/A” in 
those rows. You can choose the type of delay to view in the report by 
clicking ABS Delay (absolute delay) or ATC Delay (delay imposed only by 
the FAA) at the top of the report. 

For more information on Reports see Chapter 19, Reports. 
4. Alerts Menu 

FSM uses the Alerts option to notify you when new parameters are available for any 
airport you are currently monitoring. The Alert menu option is highlighted in red 
when new or unviewed parameters are received for airports currently being 
monitored. In addition, the airports and the type of parameters that FSM updates are 
also highlighted in red. The Alert menu remains highlighted in red until you view all 
updated parameters. 

Note: If you select an airport with the letters GDP in the Open Data Set 
window, the Control Panel Alerts menu is highlighted in red for that 
airport. 

• Alerts > FADT Parameters Available – This alert does not actually give 
you program parameters. However, you can view a listing of all the FADTs 
generated during each TMI. FADTs are reports generated when you run a 
GDP, GS, Blanket or Compression operation. FSM lists FADTs in 
chronological order. 

• Alerts > SCS Bridge – This alert indicates when a new SCS update occurs. 
Selecting SCS Bridge displays the current subbing status and may contain the 
following keywords: 

o SUBS: Indicates whether all substitutions are enabled (ON) or 
disabled (OFF). 

o SCS: Indicates whether slot credit substitutions for all operators are 
enabled (ON) or disabled (OFF). 

o BRIDGING: Indicates whether bridging subs are disabled (OFF) for 
a particular operator (airline name, GA, or MILITARY). If bridging 
is off for an airline, any flight which has a MAJOR field or carrier 
code (from ACID) that matches the airline name is not used for an 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Understanding Components 

 Version 7.9 3-6 

SCS bridge. If bridging is enabled (ON) for an operator, no line 
appears, in other words, the only allowed value for this keyword is 
OFF. 

• Alerts > Actual GDP Parameters Available – This alert occurs when FSM 
receives actual GDP Parameters through the ADL. First-time GDP 
Parameters, new GDP Parameters and deleted GDP Parameters trigger this 
Alert. Select this to view these parameters in a static window. 

• Alerts > Proposed GDP Parameters Available - This alert turns red when 
parameters for a Proposed GDP arrive through the ADL. Select this to view 
the newly proposed parameters in a static window. 

• Alerts > GS Parameters Available – This alert turns red when a Ground 
Stop (GS) is issued and FSM receives its parameters through the ADL. First-
time GS Parameters, new GS Parameters and deleted GS parameters, all 
trigger this Alert. Select this to view the parameters in a static window. 

• Alerts > Compression Parameters Available – This alert turns red when 
FSM receives parameters for the compression function through the ADL. 
Select this to view the new parameters in a static window. 

• Alerts > Blanket Parameters Available – This alert turns red when FSM 
receives parameters for a Blanket function through the ADL. Select this to 
view the new parameters in a static window. 

5. ETMS Tools 

The ETMS Tools dropdown menu contains seven core options: EDCT Commands, 
Command Line, Weather Request, ADL Request, ADL Arrival Rate, ADL Departure 
Rate, and Delete GDP Parameters. 

• ETMS Tools > EDCT Command options: 
o > EDCT CHECK – Displays the current status of a single flight 

controlled by an EDCT program. When you issue this command, you 
get a one-line response showing the controlled departure time and 
whether the ETMS has issued a Control Time (CT) message to 
implement the control for this flight. 

o > EDCT CNX – Creates a report of all flights cancelled in EDCT 
programs for selected airports or a report listing only cancelled 
flights for specified airlines for selected airports. 

o > EDCT CTA LIST – Creates a report of all controlled and 
cancelled flights for an airport and/or an airline at an airport, as well 
as open slots. 

o > EDCT HOLD – Holds all slots in a GDP for all flights or only the 
flights belonging to a specified airline and its sub-carriers at a 
specified airport. 

o > EDCT LIST – Creates a report containing a list of all airports 
currently controlled by EDCT programs. 

o > EDCT LOG – Creates a report of all EDCT files, cancellation 
messages, Simplified Substitution (SS) processing messages, and 
EDCT updates processed by the system in the order they were 
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received. Only traffic management specialists at the Air Traffic 
Control System Command Center (ATCSCC) can use this command. 

o > EDCT PURGE – Purges EDCT flight controls for a specified 
airport or for all airports. 

o > EDCT RELEASE – Releases all slots in a GDP for all flights or 
only the flights belonging to a specified airline and its sub-carriers at 
a specified airport. 

o > EDCT SCS OFF – Suspends slot credit substituting for flights 
controlled by EDCT programs at a specified airport or at all airports. 
To allow slot credit processing after suspending slot credit 
substituting, you must activate processing with the EDCT SCS ON 
command. Only traffic management specialists at the Air Traffic 
Control System Command Center (ATCSCC) can use this command. 

o > EDCT SCS ON – Allows slot credit substituting for flights 
controlled by EDCT programs at a specified airport or at all airports. 
To prohibit slot credit substituting, you must suspend processing 
with the EDCT SCS OFF command. Only traffic management 
specialists at the Air Traffic Control System Command Center 
(ATCSCC) can use this command. 

o > EDCT SHOW – Creates a report that contains detailed 
information on all flights controlled by EDCT programs for a 
specified airport, or for all airports. 

o > EDCT SLIST – Provides a slot list (using the same format that 
goes to the airlines) for a specified airport or an airline and its sub-
carriers at a specified airport. 

o > EDCT SLOTS – Creates a report list of all open slots for airlines 
at specified airports. 

o > EDCT SUB OFF – Suspends Substitution processing (SI) 
messages for flights controlled by EDCT programs at a specified 
airport or at all airports. 

o > EDCT SUB ON – Allows Substitution processing (SI) for any 
flights controlled by EDCT programs at a specified airport or at all 
airports where substitution processing was previously suspended. 

o > EDCT SUB SHOW – Generates a report that shows the status of 
simplified substitution processing (SS) messages for all airports. 
Only traffic management specialists at the Air Traffic Control System 
Command Center (ATCSCC) can use this command. 

o  > EDCT UPDATE – Allows you to update a controlled flight with 
new departure and arrival times. After you issue this command, you 
get a one-line response stating that the update was successful. Only 
traffic management specialists at the Air Traffic Control System 
Command Center (ATCSCC) can use this command. 

o > EDCT REMOVE – Allows you to remove flights from the ETMS 
database, as if they never existed. Using this command can eliminate 
a duplicate flight or remove a specific incorrect flight. Only 
Computer System Analysts (CSA) at the Air Traffic Control Systems 
Command Center (ATCSCC) can use this command. 

o > EDCT RESTORE – Allows you to “undo” the effects of the 
Remove command. It allows some or all of the flights that you did 
not want to remove from the database to be restored. Only Computer 
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System Analysts (CSA) at the Air Traffic Control Systems Command 
Center (ATCSCC) can use this command. 

o > EDCT UNASSIGNEDSLOTS – Allows you to request, by 
airport identifier, an updated unassigned slots list generated by the 
hub site. 

• ETMS Tools > Command Line – Displays a dialogue box which allows the 
user to enter any EDCT FAA commands. Only the FAA uses this feature and 
provides additional information about controlled flights and airports. 

• ETMS Tools > Weather Request – Allows you to request current airport 
weather (METAR and TAF) for one or more airports (use the three letter 
airport identifiers separated by commas or spaces). 

• ETMS Tools > ADL Request – Allows you to request a new ADL 
generated from the hub site. 

• ETMS Tools > ADL AAR > Modify - Allows you to modify ADL Arrival 
Rates including the ability to assign several different Airport Arrival Rates 
(AARs) within the same hour (see Figure 3-3). 

• ETMS Tools > ADL AAR> Reset – Resets the Arrival Rate to the ETMS 
default arrival rate. 

• ETMS Tools > ADL ADR> Modify - Allows you to modify ADL 
Departure Rates including the ability to assign several different Airport 
Departure Rates (ADRs) within the same hour. 

• ETMS Tools > ADL ADR> Reset – Resets the Departure Rate to the ETMS 
default departure rate. 

You have the option to model an AAR/ADR from the Bar Graph, the Modify 
AAR/ADR window automatically reflects the modeled rates displayed in the 
Bar Graph. Then you can send the model rates from the Modify AAR/ADR 
window to ETMS. The rates appear in the next ADL update. Use this method 
of changing the AAR or ADR when there is no GDP being sent.   

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Understanding Components 

 Version 7.9 3-9 

 

 
Figure 3-3: Specify Model AAR Window 

 
• ETMS Tools > Delete GDP Parameters – Opens the Delete GDP 

Parameter dialogue box (see Figure 3-4). Select the airport for which you 
want to delete GDP parameters from the For Data Set drop down menu. 

 
Figure 3-4: Delete GDP Params Window 
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6. Utilities Menu 

• Utilities > Query Manager – Opens the Query Manager component. 
• Utilities > Search By Call sign – Opens the Search By Call sign window. 
• Utilities > Model Arrival Rates > Specify – Opens the Specify Model AAR 

window allowing you to specify the model Arrival Rates and the ability to 
assign several different AARs within the same hour. 

• Utilities > Model Arrival Rates > Reset – Resets the model Arrival Rate to 
equal the current ADL AAR> 

• Utilities > Model Departure Rates > Specify – Opens the Specify Model 
ADR window allowing you to specify the Model Departure Rates and to 
assign several different ADRs within the same hour. 

• Utilities > Model Departure Rates > Reset – Resets the model Departure 
Rate to equal the current ADL ADR. 

• Utilities > View File – This option allows you to view previously saved 
Analysis Reports, Coversheets, and Flight Data, as shown in Figure 3-8. 

 
Figure 3-5: View File Window 

• Utilities > Set Time – Allows you to set a specified time for Historical data 
sets only (see Figure 3-9). 

 
Figure 3-6: Set Time Dialog Box 

• Utilities > Update – Updates the active historical mode components with the 
next historical ADL file. 
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• Utilities > ECR – Opens the ECR component to update a controlled flight’s 
control times. 

7. Window Menu 

• Window > Hide All Windows - Hides all open FSM components. 
• Window > Hide All Iconified Windows - Hides all FSM iconified bars 

displayed in the Task bar. 
• Window > LIVE (+ airport abbreviation), GDT yyyy/mm/dd/Airport, or 

HIST yyyy/mm/dd/airport – Click the data mode and airport selection to 
open the active components for that airport. Each individual component 
appears under the Window menu. Select a checkbox to display and bring to 
the front of your monitor the subsequent airport component. Airport and Data 
selections are consecutively numbered in the order they were opened. 

8. Help Menu 

• Help > FSM – Accesses the web-based FSM on-line help. 
• Help > ADL Data Elements – Accesses the ADL Data Elements page from 

the web-based FSM on-line help. 
• Help > Show Configuration – Displays current FSM configuration in use 

(see Figure 3-10). 

 
Figure 3-7: Configuration Setting Window 

• Help > About FSM - Displays information about the FSM version running 
including the FSM Version and Copyright Information– The version of FSM 
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currently running (i.e. FSM 7.9), Metron Aviation, Inc. copyright notice, the 
software build-date and Product License information. 

Modify and Specify Model AAR/ADR Window Menu 

• File > Open- Opens previously saved AAR/ADR parameters. 
• File > Save - Saves the AAR/ADR parameters to a text file (can be opened 

later and used again). 
• File > Print - Prints the Modify AAR/ADR window. 
• File > Close - Closes the Modify AAR/ADR window. 
• Help > Demand Rates – Opens the online help information specific to the 

modifying demand rates. 

Depending on the AARs you assign within an hour, that hour’s AAR background 
color changes.  

• Green indicates that you distributed the AAR unevenly among the 15-minute 
increments in that hour.  

• Blue indicates that the 15-minute AARs do not differ from each other by 
more than a value of “1.”  

• White indicates that the AAR for that hour is the same as the ADL AAR.  
• Red indicates that the AAR is more than twice the value of the default AAR. 

Once you finish entering your AAR/ADR information: 

• Click Send from the Modify Rates window to send the modified rates to 
ETMS. The next ADL update will reflect the new rates.  Click Send from the 
Specify Model Rates window to change your local machines rates.  

• Click Cancel to close the modify AAR/ADR rates without taking any action. 
• Click ADL AAR/ADR at the top right of the Modify window to reset the rates 

back to what the original AAR/ADR rate when you first opened the window. 
• Click Help at anytime to give you a description of both the Send and Cancel 

buttons. 

Reset AAR and Reset ADR Components 

The ETMS Tools > Reset AAR/ADR components have identical setup features. 
The figure below is an example of the Reset AAR component. 

 
Figure 3-8: Reset AAR Window 

Reset AAR/ADR Window Menu 
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• File > Close - Closes the Reset AAR/ADR window. 
• Help > Demand Rates – Opens the online help information specific to the 

modifying demand rates. 

In Monitored Live mode: 

• Click Send to reset AAR/ADR values to the default setting and send the 
information to ETMS. The reset AAR/ADR is reflected in the next ADL 
update.  

• Clicking Cancel closes the Reset AAR/ADR window without taking any 
actions. 

• Click Help to display a pop-up screen with additional information on the 
Send and Cancel buttons. 

Control Panel Buttons 

You can use the buttons from the Control Panel component to open other FSM components. 

• Open Data Set opens the Open Data Set component in which the user may 
select various operating modes and available airports. See Open Data Set 
component overview for more detail. 

• US Map opens the US Map Component, which displays airports currently 
being monitored and their status in their respective geographical locations. 
See US Map component for more detail. 

• Query Manager opens the Query Manager component that lists Built-in and 
User-defined filters. See the Query Manager component information below 
for more detail. 

• GDT Setup opens four GDT components: GDT Setup, GDT Map, GDT Bar 
Graph, and GDT Data Table components. An airport must already be opened 
for the GDP Setup component to be activated. If there is no data set selected, 
the GDT Setup button displays an error message (by default). See Chapter 4 
for detailed information on Ground Delay Tool Components. 

• Update allows you to update the Time Line and Bar Graph with the next 
ADL update only in Historical Mode. You must open an airport in Historical 
Mode for the Update button to operate. If there is no Historical data set 
selected, clicking Update causes an error message: “Not a historical data 
set”. 

• ECR opens the ECR components. Use ECR to update EDCTs for flights 
arriving into a controlled airport. See Chapter 13 for detailed information on 
the ECR component functionality. 

Note: When in Historical Mode, clicking Send resets the historical data to 
the first ADL update time.  
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Open Data Set Component 
Clicking Open Data Set on the Control Panel opens the Open Data Set component. This 
component allows you to choose an FSM data mode and data set for monitoring and managing air 
traffic flow. A data mode is the type of data you want to use: historical or live. Live data is fed 
from ETMS to the FSM client on a real-time basis, while historical data is archived data that FSM 
can pull to allow you to review airport events in the past. A data set is the airport and the 
components which you would like to display. 

• Monitored Live - Monitored Live mode provides a list of airports currently 
monitored by the FSM server and readily available for viewing by the user. 
This data mode runs real-time data and receives ADL updates every 5 
minutes while running FSM. 

• Historical - This data mode uses historical data that has been stored by your 
FSM server database. Historical data is available for recall to analyze 
scenarios or replay a day’s air traffic events. 

• All Live - All Live provides a list of airports that you can view (not currently 
being monitored by the server, but available). 

• Active Historical – The Active Historical tab provides a list of airports' 
historical data currently opened and monitored by the user. 

Note: All times displayed in and used by FSM are Zulu times unless 
otherwise specified. 

 
Figure 3-9: Open Data Set Component 

Open Data Set Menu Bar 

The Menu Bar in the Open Data Set component contains two options: File and Help. 
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• File > Close – Closes the Open Data Set component. 
• Help > Open Data Set – Accesses the web-based on-line help for the Open 

Data Set component. 

Open With Options 

The Open With portion of the Open Data Set component contains three component options with 
which to open and view an airport: 

• Time Line – opens the Time Line component of the selected airport, 
displaying regular Time Line options for each airport. 

• Flight List – opens the Flight List component of the selected airport. 
• Bar Graph – opens the Bar Graph component of the selected airport. 

Select the components you want to open for a selected airport by placing a checkmark in the 
associated checkbox of the Open With section(see Figure 3-10). If you do not make any changes 
in the Open With section, the Time Line and Bar Graph components for the selected airport open 
by default. 

 
Figure 3-10: Open With Component Selection 

Open Data Set Tab Options 
The Tab Options in the Open Data Set window consist of four tab selections, Monitored Live, 
Historical, All Live, and Active Historical. 

1. Monitored Live Tab 

The Monitored Live tab provides a list of airports currently monitored by the FSM server 
and readily available for you to view. GDP Actual or GS Actual along with the program 
times appear next to airports with a TMI in place. Select the desired data set by clicking 
the airport information in the scrolling area of the window. See Chapter 4 Opening FSM, 
for more information on using the Open Data Set component. For example, Figure 3-11 
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shows ATL airport, which has a GDP in place, with the Time Line and Bar Graph 
selected; this opens the Time Line and Bar Graph components for ATL in Monitored 
Live mode. 

 
Figure 3-11: Open Data Set - Monitored Live Tab 

2. Historical Tab 

When you first open the Open Data Set component, the Monitored Live tab is the default 
tab. To select the Historical data display, click on the Historical tab. This display 
provides you with the available historical data archived in FSM. You can select your 
historical data by drilling down from the server from which you want to pull data. FSM 
arranges the drill down order by Server>Year>Month>Day>Airport (see Figure 3-13). If 
the FSM Client is connected to two servers, both servers appear. 
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Figure 3-12: Open Data Set - Historical Tab 

3. All Live 

The All Live tab provides a list of airports that you can view. When you select an airport 
dataset from the All Live tab, it initially takes slightly longer to open than from the 
Monitored Live tab. When selected, the airport’s 3-letter code is highlighted in light 
purple. 

 
Figure 3-13: Open Data Set - All Live Tab 
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4. Active Historical 

The Active Historical tab provides a list of airports, currently open in Historical Mode, 
that you are monitoring. You can open additional components or toggle from one 
historical data set to another from this Tab. 

 
Figure 3-14: Open Data Set - Active Historical Tab 

Open Data Set Buttons 

1. Apply keeps the Open Data Set component active in addition to opening the selected 
airport components. 

2. OK closes the Open Data Set component when opening the selected airport 
components. 

3. Cancel closes the Open Data Set component without making any selections. 
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Figure 3-15: Open Data Set Button Option 

4. Default returns the Open With selections to the previously checked (default) items, 
the Time Line and Bar Graph. 

Map Component 
You can view the US Map component by clicking US Map on the Control Panel component. The 
US Map displays North America with an overlay of all US and Canadian centers and an outline 
of the 48 contiguous states. Airports currently being monitored by the server appear with the 
airport three-letter identifier (US) or four-letter identifier (Canada) and a colored dot indicating 
the status of each airport. The number of monitored airports listed on the US Map appears in the 
title bar-monitored data sets: XX where XX is the number of airports currently monitored and 
displayed on the Map (see Figure 3-18). 
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Table 3-1: Airport Status 

Color Status 

Green No Traffic Management Initiatives (TMIs) are in effect for the airport. 

Red A Ground Delay Program (GDP) or Ground Stop (GS) is in effect. 

Yellow There is either a proposed GDP or GS. 

 
Figure 3-16: US Map component 

Map Zoom Capabilities 
There are several different ways to zoom in or zoom out on the US Map or GDT Map 
components. 

1. Quick Key Method – Pressing Z on your keyboard incrementally zooms in to the 
center of your screen. Pressing U on your keyboard incrementally zooms out from the 
center of your screen. To move the center focus of your screen to another focal point 
or to zoom in on a particular airport, move the cursor to the desired location and press 
M on the keyboard. Quick key M moves the central focus of the map to the cursor 
location. To zoom in or out from that point, continue to use Z or U quick keys. In 
addition, pressing X on the keyboard undoes the last command (up to 25 commands). 

Table 3-2: Quick Key Commands 

Quick Key  Description 

M Move 

Z Zoom in 
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Quick Key  Description 

U Zoom out 

X Undo Move/Zoom 

2. Drag and Drop Method – To zoom out, hold down the left mouse button and drag the 
curser up and left. To zoom in, hold down the left mouse button and drag any 
direction, besides up and left, around the area you want to zoom in on. 

3. Right Click Method – After using either method listed above, right-clicking the 
cursor anywhere within the Map component gives you two options: Default zoom 
and undo zoom. Default zoom returns the Map zoom to the initial zoom setting. 
Undo zoom, undoes the last zoom command– same as using the X quick key. 

Note: The Drag and Drop Method is not precise, it is recommended that 
you use the Quick Key Method. 

Viewing Airport Parameters 

From the US Map, you can view the scope of an airport’s TMI parameters. Left-click an airport 
that has either proposed or active parameters in place and FSM displays the parameters (see 
Figure 3-17). The maroon overlay and red airports indicates the area and airports included in the 
airport’s TMI. 

In addition to the graphical parameters display, white text shows the airport ID, date, ADL time, 
the type of program, and the program time range. To return to the normal Map display, click 
anywhere on the map. 

 
Figure 3-17: View Airport Parameters 
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Opening Components from the US Map 

You can access an airport’s Time Line, Bar Graph, and Flight List components directly from the 
US Map component. Left-click the airport, this turns the airport white in color and if the airport is 
running a TMI, the parameters appear in the Map, similar to the GDT Map display. Once you 
select an airport, right-click on the airport to display the pop-up selection menu, which includes 
the zoom option described above. The pop-up menu also allows you to view the Time Line, Bar 
Graph, or Flight List components for the selected airport in Monitored Live mode only. For 
example, selecting Open Time Line opens up the Time Line live component for ATL. For more 
information see Chapter 4 Opening FSM. 

 
Figure 3-18: Component Selection 

US Map Menu Bar 
The US Map menu bar contains four options: File, View, Map and Help. 

 
Figure 3-19: US Map Menu Bar 

1. File Menu 

• File > Save as - Saves the US Map as a .jpg image in a directory that you 
specify. 

• File > Print - Prints the active US Map on the monitor. 
• File > Close - Shuts down the US Map component. 

2. View Menu 
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• View > Rename Window…- Displays the Rename Window dialog box and 
allows you to change the title bar name. Type in the desired name then click 
OK to change the title bar heading. Click Cancel to close the Rename 
Window dialog box without making any changes (see Figure 3-22). 

 
Figure 3-20: Rename Window Dialog Box 

3. Map Menu 

• Map > Zoom In – Allows you to enlarge the Map. 
• Map > Zoom Out - Allows you to reduce the Map size. 
• Map > Default Zoom – Returns the Map to the original default zoom. 

4. Help Menu 

• Help > Map- Accesses the web-based on-line help for the US Map 
component. 

Query Manager Component 
You can view the Query Manager component by clicking Query Manager (see Figure 3-21) or 
by selecting Utilities > Query Manager from the Control Panel component. The Query Manager 
component enables you to query flights and create a Flight List that contains flights that meet 
only your selected criteria. 

 
Figure 3-21: Opening Query Manager Component 

The Query Manager component gives you the option of selecting between Built–in Filters or 
User-defined Filters as shown in Figure 3-24.  

Built-in Filters are pre-defined, read-only filters designed from criteria that are frequently used 
for viewing flight information. Double-click on the BUILT_IN Built-in Filters folder or click on 
the Expand/Collapse icon to view/hide all contents in the folder. When you expand the Built-in 
Filters folder, you see a number of filters from which to choose. You may continue to drill down 
to view more detail by double-clicking on the folders or by clicking on their respective 
Expand/Collapse icons. 

The AND filters list consists of filters that FSM compares to find a match in the data set. An OR 
filter consists of a list of filters that FSM compares to find matching flights in the data set. A 
CONSTRAINT is an attribute, operator, or value. For more information on filters see Chapter 20 
Query Manager. 

User Defined Filters are active filters you create and customize based on your Flight List needs. 
There are two methods of creating user-defined filters:  
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• Creating a New Filter 
• Editing a Built-in filter 

For more information on filters see Chapter 20 Query Manager. 

 
Figure 3-22: Query Manager Component 

Opening a Flight List 
You must be monitoring an airport before you can query for a Flight List. 

1. Click Query Manager to open the Query Manager Component. 
The Query Manager window appears. 

2. Select any one of the Built-in or User-Defined Filters. 
3. Click Flight List. 

• If you are only monitoring one airport, the Flight List automatically opens, in 
table format, with the information generated from the selected filter criteria. 

• “No Active Data Sets” error messages pop-up if the FSM Client is not 
monitoring any airports. 

• If you are monitoring more than one airport, the Set Data Set window 
appears. 

4. Select the desired airport for which you want to view the queried flight list. 
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5. Click OK to open the Flight List (see Figure 3-23). See Chapter 6: Viewing Flight 
Information for detailed information on Flight Lists. 

 
Figure 3-23: Set Data Set Window 

 

Query Manager Menu Bar 

The menu bar of the FSM Query Manager component contains four options: File, Edit, View, and 
Help. 

1. File Menu 

• File > Save - Saves the User-Defined Filters into the user_filter.ini file. In 
the FSM Client ini file, you can specify the name and location of where the 
user_filter.ini file is stored. The saved filters are available every time you 
open a Query Manager. 

• File > Close – Closes the Query Manager window - taking no action. 
2. Edit Menu 

• Edit > Cut– Deletes selected User Defined Filters from the Query Manager. 
• Edit > Copy– Copies selected filters to the clipboard. 
• Edit > Paste– Pastes selected filters from the clipboard to the User-Defined 

Filters folder. 
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3. View Menu 

• View > Rename Window… - Displays the Rename Window dialog box and 
allows you to change the component name in the title bar. Enter the desired 
component name then click OK to change the title bar heading. Click Cancel 
to close the Rename Window dialog box without making any changes (see 
Figure 3-32). 

 

 
Figure 3-24: Rename Window Dialog Box 

 

• View > Flight List - Displays the Flight list if the FSM client is monitoring 
only one airport, or the Set Data Set window when the FSM client is 
monitoring multiple airports.  

4. Help Menu 

• Help > Query Manager – Accesses the web-based on-line help for the 
Query Manager Component. 
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Bar Graph Component 
The Bar Graph component allows you to view the overall demand of the airport being monitored. 
Airport demand consists of the total flights using the airport for arrivals and departures. The FSM 
Dynamic Graph displays airport demand information as it is received through ADLs. There are 
12 different color options to view this demand. The Arrival Status Tab is the default view when 
you first open the Bar Graph component. The airport, date, last ADL update time, and data mode 
also appear in the Bar Graph title bar. 

 
Figure 3-25: Bar Graph Component 

The Bar Graph component displays data according to which “Color” tab option you select. For 
example, the default color tab is Arrival Status, which displays the bars in the graph colored 
according to the percentage of flights that represent each respective arrival status. If half of the 
flights for one time period are scheduled to depart, while the other half are airborne (flight 
active), the bar for that hour is half red (flight active) and half lime green (departing [No EDCT]). 
If every flight for the hour has arrived, the bar for that hour is black. 

The graph is dynamic and changes according to the information from each ADL update. 
Likewise, the graph automatically updates itself when you select a different “Color” tab. To view 
a flight count for any hour, place the cursor over any bar within the Bar Graph, the respective 
number/count appears for the bar the cursor is hovering over. If you place the cursor near the top 
of a bar, the total number of flights for that hour appears. You can use the same method to find 
out the Airport Arrival Rate (AAR). Place the cursor over the AAR and the rate appears. Double-
clicking any bar displays a Flight List for flights contained in that hour bar. See Chapter 6: 
Viewing Flight Lists for more detailed information on viewing flight list information. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Understanding Components 

 Version 7.9 3-28 

Bar Graph Legend 

To view the color legend check the View > Show Legend checkbox from the Bar Graph’s main 
menu. The Legend displays the color scheme for the color tab currently displayed and allows you 
to toggle the coloring options on and off by using the checkbox next to each color. 

Clicking Synchronize Legend from the legend gives you a drop down box to select other opened 
components (see Figure 3-26). Selecting a checkbox next to any other components dynamically 
synchronizes the current component with the selected component from the dropdown menu. 

 
Figure 3-26: Synchronize Legend 

Note: Figure 3-26 is a good example of why you may want to rename 
your component windows when monitoring several airports. Instead of 
time line: 16, renaming the Time Line component to ATL Time Line 
would make component identification easier. Use View > Rename 
Window…when available to rename the title bars. 

Bar Graph Menu Bar 

The menu bar of the FSM Bar Graph component contains four options: File, View, Bar Graph 
and Help. 

1. File Menu 

• File > Save as - Saves the Bar Graph as a .jpg image to a directory you 
specify. 

• File > Print - Prints the Bar Graph currently viewed on your screen. 
• File > Close Group – Closes all the components associated with the open 

component. This function removes the airport button from the Control Panel 
for the selection airport and data mode. 

• File > Close – Shuts down the Bar Graph component for that particular 
airport. 

2. View Menu – consists of 12 checkboxes. Check the box to view the information and 
uncheck the box to hide the information. 

• View > Rename Window - Displays the Rename Window dialog box that 
allows you to change the component name of the title bar. Enter the desired 
component name then click OK to change the title bar heading. Click Cancel 
to close the Rename Window dialog box without making any changes. 

• View > Arrival Data - Displays all arrival data for the monitored airport. 
The bars of the graph are solid only when you are viewing arrival data in 
FSM. 
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• View > Departure Data - Displays all departure data for the monitored 
airport. The only time when the bars of the graph appear hashed, as shown in 
Figure 3-27, is when you view departure data in FSM. When you view both 
arrival and departure data in FSM, you see two bars for each time increment. 
Bars that represent arrival data are solid, whereas bars that represent 
departure data are hashed. 

 
Figure 3-27: Normal View with Arrival and Departure Data Displayed 
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• View > Stack Departures - Displays departing flights in the same bars as 
arriving flights, (see Figure 3-28). The bars on the graph become solid, with 
both arriving and departing flights included in the bar for their departure or 
arrival time. To differentiate between departing and arriving flights, use the 
Arrival/Departure tab to color your flights. Using Arrival/Departure displays 
(by default) arriving flights in green and departing flights in blue. 

 
Figure 3-28: Arrival and Departure Data displayed in stacked format 

• View > Show Cancellations – Displays cancelled flights in the color cyan. 
Cancelled flights do not automatically appear in the graph. Showing 
cancelled flights is useful to compare the original airport demand with the 
demand after the cancellations. To differentiate between cancelled and 
regular flights, use the Arrival Status tab to color your flights. 

• View>Unassigned Slots – Displays all unassigned slots in the color white 
for a GAAP GDP. 

• View > Show Legend – Displays the appropriate color legend associated 
with the tab option you are viewing. 

• View > Time Indicator – Displays an orange vertical line that remains fixed 
at the current time. Like the FSM Time Line, the Bar Graph Component also 
tracks time. 

• View > GDP Indicators – Displays brown vertical lines to indicate the start 
time and end time of a current GDP. The program time indicators appear 
automatically when a program goes into effect at the monitored airport. 
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• View > GS Indicators - Displays yellow vertical lines to indicate the start 
time and end time of a current GS. The GS time indicators appear 
automatically when a GS goes into effect at the monitored airport. 

• View > Arrival Flow Rate – Displays a thin, dark gray line that represents 
the arrival flow rate independently of the time-bin convention, enabling you 
to visualize arrivals as a dynamic flow rate. 

• View > Departure Flow Rate – Displays a thin, cyan line that represents the 
departure flow rate independently of the time-bin convention, enabling you 
to visualize departures as a dynamic flow rate. 

• View > ADL AAR Line – Displays a white horizontal line that runs through 
the graph representing the current Airport Arrival Rate (AAR) for the 
monitored airport. The ADL AAR (shown by default) is a fixed AAR sent by 
the FAA Air Traffic Control System Command Center (ATCSCC)to advise 
of the number of arriving aircraft an airport can accommodate at any given 
interval of time. The AAR changes according to the interval of time being 
displayed. For example, an AAR of 60 per hour = AAR of 15 per quarter 
hour. Only ATCSCC users can change the ADL AAR. 

• View > ADL ADR Line – Displays a cyan horizontal line that runs through 
the graph. The line represents the Airport Departure Rate (ADR) for the 
monitored airport. The ADL ADR, (shown by default when Departures is 
checked), is a fixed value sent by the FAA ATCSCC to specify the number 
of departing aircraft an airport can accommodate at any given interval of 
time. The ADR also changes according to the time increment used in the 
graph display. For example, an ADR of 60 per hour is equal to an ADR of 15 
every quarter hour. 

• View > Model AAR Line – Displays a user-specified AAR as a dashed 
white line. You use the Model AAR for modeling and analysis; you can 
change this according to program needs. 

• View > Model ADR Line - Displays a dashed blue line and is useful for 
modeling traffic scenarios and analysis. 

• View > Hours Shown > 2/3/4/5/6/8/10/12/14/16/18/20 Hours - The default 
data display is 10 hours. You can specify the number of hours displayed in 
the bar graph to see more or less flight data. For example, you may want to 
view the AAR in 15-minute increments, which is difficult to see on a graph 
with 10 hours’ worth of data. To change the number of hours in the graph, 
select View > Hours Shown > X Hours (X = number of hours). The graph 
automatically updates to show the number of hours specified. 

3. Bar Graph Menu 

• Bar Graph > Track Time - Makes the graph move as the time changes. 
When you track time in this way, the second bar on the graph is always the 
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current time. When you uncheck the box, the bars do not move, but you can 
still use the Time Indicator to determine the current time on the graph. 

• Bar Graph > Set Time – This option is functional only while in Historical 
mode. Selecting this causes the Set Time dialog box to appear. You can 
select the day and time for which you would like to view the historical data. 

• Bar Graph > Model Arrival Rates > Specify – You must select View > 
Model AAR Line to see the Model AAR Line (a dashed white line) on the 
Bar Graph. If the ADL AAR appears on the graph, the dashed line (for 
modeling) is hidden behind the solid white ADL line. You can adjust the 
Model AAR by: 

o Selecting Bar Graph > Model Arrival Rates > Specify. This option 
displays the Specify Model AAR window. Fill in the necessary 
information and the new AAR appears on the graph. See Chapter 7 
for more information on changing the AAR. 

o Dragging the white line in the graph to the desired AAR. The dashed 
line moves to the AAR specified. Only the portion of the line to the 
right of the cursor moves. Any portion of the line to the left of your 
cursor should remain in the same position as you drag the line to a 
new AAR. 

• Bar Graph > Model Arrival Rates > Reset – Restores the Model AAR to 
its original value. The Model AAR disappears. 

• Bar Graph > Model Departure Rates > Specify –You must select View > 
Model ADR Line to see the Model ADR Line (a dashed blue line). If the 
ADL ADR appears on the graph, the dashed line (for modeling) is hidden 
behind the solid blue line. You can adjust the Model ADR by: 

o Selecting Bar Graph > Model Departure Rates > Specify. This 
option displays the Specify Model ADR window. Fill in the 
necessary information and the new ADR appears on the graph. See 
Chapter 7 for more information on changing the ADR. 

o Dragging the blue line in the graph to the desired ADR. The dashed 
line moves to the ADR specified. Only the portion of the line to the 
right of the cursor moves. Any portion of the line to the left of your 
cursor should remain in the same position as you drag the line to a 
new ADR. 

• Bar Graph > Model Departure Rates > Reset – Restores the Model ADR 
to its original value. The Model ADR disappears. 

Note: Modeling the AAR or ADR rates from the Bar Graph only changes 
the local model rate for modeling purposes. To send a new AAR/ADR to 
ETMS, without issuing a TMI, use Demand Rates > Modify AAR/ADR 
from the Control Panel and click Send. 
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4. Help Menu 

• Help > Bar Graph – Accesses the web-based on-line help for the Bar Graph 
component. 

Shortcut Keys 
15, 30, and 60 – Clicking the 15, 30, or 60 time-bin buttons displays bar graph capacity and 
demand information based on the time-bin value selected. The default time increment is 60-
minutes. 

Bar Graph Tab Options 

The screen resolution determines the arrangement of the 12 tabs in the Bar Graph. You have the 
option to color flights according to several variables available in FSM. The default tab setting 
colors flights according to their Arrival Status; however FSM offers the flexibility to view flights 
according to different criteria. This allows for effective analysis of which flights make up the 
demand at an airport. Each of the 12 pre-defined color tabs of the Bar Graph window displays 
different information with a corresponding color scheme and legend. See Table 3-3 below for the 
default color settings for all 12 tabs. 

Table 3-3: Bar Graph Coloring Tabs 

Tab Option Bar Color  Description 

Light Green Departing (No CTD) 

Red Flight Active 

Black  Arrived 

Brown Departing (EDCT Issued) 

Dark Green Departing (Past EDT) 

Yellow Ground Stopped 

Cyan (optional)  Cancelled 

Blue (optional) Removed 

Pink (optional) Priority 

Arrival Status (Default View): 

White (optional) Unassigned Slot 

Light Green Arriving Arrival/Departures 

Blue Departing 

Light Green Turbo  

Red Jet 

Black Propeller 

Aircraft Category 

Yellow Unknown 

Aircraft Class Light Green Large 
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Tab Option Bar Color  Description 

Red Heavy 

Black Small 

 

Yellow Unknown 

Various Colors All Majors Carrier 

White Single Airline (User 
input) 

AFIX Various Colors The Arrival Fixes 
associated with the 
monitored airport 

DFIX Various Colors The Departure Fixes 
associated with the 
monitored airport 

Red Flights Exempted 

Black  Flight Excluded 

Exemption 

Light Green Flight Not Exempted 

Blue Air Cargo 

Magenta Carrier 

Light Green General Aviation 

Brown  Military 

Orange Air Taxi 

Cyan Other 

User 

Red Unknown 

Red Flights With Alarm Alarm Status 

Black Other Flights 

Centers Red All Centers 

Distance Red All Distances 

Time Line Component 
The Time Line component is a timetable that displays airport arrival and departure rates and 
demand in one-minute hash marked increments in the hour columns Figure 3-29. The number of 
hours displayed is based on the size of your Time Line component. You can change the number 
of hours viewed on the screen at one time by dragging the edge of the window in or out to 
increase/decrease the window size. You can also use the scroll bar to scroll forward or backwards 
in time. You can resize the CNX (cancelled flights) column as well. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Understanding Components 

 Version 7.9 3-35 

The large numbers at the top of each column represent the date/hour (i.e. 27/1600 indicates that 
this display is for the 1600 hour for the 27th day of the month). Directly below the date/hour 
information is the AAR and/or ADR versus the demand at the airport (the number of flights 
projected to arrive) for the hour shown. For example, 70/65 at the top of a column indicates that 
the AAR is 70 for that hour and 65 flights are expected to arrive within that hour. The ADR 
versus demand appears in parentheses when FSM displays departure data. For example, (60/40) 
indicates that 60 flights can depart the airport in that hour, but only 40 are projected to depart. 
The last data update time is highlighted in orange. 
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Figure 3-29: Time Line Component 

 

From the Time Line, you can view flights arriving and departing from a monitored airport, as 
well as open arrival slots, unassigned slots, and cancellations. The airport, date, last ADL time, 
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and data mode appear in the Time Line title bar. The Time Line displays the airport being 
monitored, the date, and the time directly above the coloring tabs. 

Each flight arriving at the monitored airport appears to the left of the minute hash marks, which 
correspond to the ETA of the flight. A pop-up window displays the flight’s ACID, Departure 
airport, arrival airport, ETD, and ETA when you place your cursor over a flight (see Figure 3-30). 

 
Figure 3-30: Pop-up Flight information 

Viewing Time Line Flight Information 
Right-clicking on a flight icon gives you four additional options for that flight: Flight Info, 
Flight Detail, EDCT Check, EDCT Update, and ECR. 

• Selecting Flight Info displays the Flight Info component, which contains 
general ADL information for a flight including ADIC, status, origin airport, 
destination airport, ETD, ETE, ETA, CTD, CTA, Delay Flag, and Cancel 
Flag when applicable. 

• Selecting Flight Detail displays more detailed flight information. The Flight 
Detail window contains all the ADL information for that flight. 

• Selecting EDCT Check opens the EDCT Check dialog box giving ATCSCC 
specialists the ability to send a message to the Hubsite requesting the flight’s 
EDCT time as opposed to getting the ECDT time from the ADL.  

• Selecting EDCT Update opens the EDCT Command Line dialog box, which 
allows ATCSCC specialists to send an EDCT update request to the Hubsite. 

• Selecting the ECR option opens the ECR component for the selected flight. 
Opening ECR in this manner automatically fills the ACID, ORIG, and flight 
information into the ECR component for the flight. 

Note: EDCT Check and EDCT Update are ATCSCC only options. 

FSM displays cancelled flights under the CNX column. Cancelled flights have the same hover 
and right-click capabilities as all other flights. FSM keeps and displays flight data compiled by 
Volpe National Transportation Systems Center, which includes data for up to 20 hours after the 
current time. 
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You can also access flight lists and flight counts from the Time Line component. For more 
information on viewing flight information in the Time Line, see Chapter 6 Viewing Flight 
Information. 

 
Figure 3-31: Flight Count 

 

Icons in the Time Line 

• Airplane Icons represent flights arriving at or departing from the monitored 
airport. Arriving flights face left while departing flights face right. Clicking 
an arrival flight icon highlights the flight by putting a white square around 
the icon. If the flight is delayed, the open arrival slot that resulted from its 
delay is also highlighted. 

• A filled square icon appears only when a GDP is in effect. The filled square 
represents an arrival slot left open by a cancelled flight. The arrival slot is 
open and available for use by other flights. Cancelled flights appear on the 
Time Line under the CNX heading and are highlighted when you select their 
associated slot. 

• An empty square icon also corresponds to a cancelled flight. However, this 
arrival slot is not available for use by other flights. Clicking this icon 
highlights its associated cancelled flight, displayed under CNX in the Time 
Line. 

• A filled triangle icon appears only when a GDP is in effect. The filled 
triangle indicates an open arrival slot due to a delayed flight. The arrival slot 
is open and available for use by other flights. Clicking this icon also 
highlights the delayed flight that caused the slot to open up. 

• An empty triangle icon also corresponds to a delayed flight. However, this 
arrival slot is not available for use by other flights. Clicking this icon also 
highlights the associated delayed flight. 
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• A white diamond represents an unassigned slot. No right- or left-click 
capabilities exist for this icon. It is simply a place holder during a GAAP 
GDP with GAAP until filled by a pop-up flight. 

Note: You can find an explanation for any of the Time Line icons by 
selecting Help > Legend in the FSM Control Panel component. 

Table 3-4: Time Line Icons 

Time Line Icon Description 

 Indicates the latest or current ADL file data update 
time in the Time Line component. 

 A flight arriving at the monitored airport by ETA 
in the Time Line component and colored by the 
current color scheme. 

 A flight departed from the monitored airport by 
ETD in the Time Line component and colored by 
the current color scheme. 

 An open slot due to a cancelled flight, which is 
included in a GDP. It is positioned at its arrival 
slot time and colored by carrier. 

 An open slot due to a cancelled flight, which is not 
included in a GDP. It is positioned at its (IGTA-
taxi) and colored by carrier. 

 An open slot due to a delayed flight that is 
included in the GDP. It is positioned at its arrival 
slot time and colored by carrier. The 
corresponding flight is positioned at a later time 
matching the ETA. 

 An open slot due to a delayed flight that is not 
included in the GDP. It is positioned at its (IGTA – 
taxi) and colored by carrier. The corresponding 
flight is positioned at a later time matching the 
ETA 

 An unassigned slot. These appear in the Monitored 
Live mode, Historical mode, and GDT mode time 
lines for GAAP GDPs. 

Time Line Menu Bar 

The menu bar in the FSM Time Line component contains four options: File, View, Time Line and 
Help. 

1. File Menu 

• File > Save as - Saves the Time Line as a .jpg image in a directory that you 
specify. 
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• File > Print - Prints the Time Line that is currently on the screen. 
• File > Close Group – Closes all the components associated with the open 

component. This function removes the airport button from the Control Panel 
for the selected airport and data mode. 

• File > Close - Shuts down the Time Line component for that particular 
airport. 

2. View Menu 

• View > Rename Window…– Displays the Rename Window dialog box and 
allows you to change the component name in the title bar. Enter the desired 
name then click OK to change the title bar heading. Click Cancel to close 
the Rename Window dialog box without making any changes. 

 
Figure 3-32: Rename Window 

There are six additional display options to choose from under the View menu. Select the 
checkbox to view the information. 

• View > Arrival Data – Displays all arrival data for that airport. 
• View > Departure Data – Displays all departure data for that airport. 
• View > Show Cancellations – Displays all cancelled flights under the 

column marked CNX, to the right of the active flight information. 
• View > Show Color Legend – Displays the appropriate color legend 

associated with the current view. 
• View > Open Slots in Carrier Color – Displays all open slots due to 

cancelled or delayed flights in the associated carriers color. 
• View>Show Unassigned Slots – Displays all unassigned slots during a 

GAAP GDP. 
• View > Auto Icons - Displays flights in the TSD icon format. The TSD 

format displays different icons based on the flight aircraft weight. When you 
select Auto Icons, the classic FSM Time Line icons, which display the same 
icon for all aircraft weights, appear. 

Table 3-5: Auto Icons 

Classic 
View 

New (TSD) 
Icon Format Description 

  Jet  
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  Heavy  

  Prop (Includes 
Turbo and Piston) 

• View > Flight Info - Displays the Flight Info window for a quick reference 
on the flight. 

• View > Flight Detail - Displays the Flight Detail window for more in-depth 
information on the flight. 

• View > Flight List - Displays the FSM Flight List. 

Note: View > Arrival Data, Show Cancellations, and Open Slots in Carrier 
Color checkboxes are selected by default. 

3. Time Line Menu 

• Time Line > Track Time –Allows you to turn Track Time on and off. To 
force the Time Line component to update when the current hour changes, 
select Track Time. When the hour changes, the Time Line moves forward 
one hour. If you uncheck the Track Time box, you can scroll forward or back 
in time and at the next update time the Time Line does not return to the 
current time. 

• Time Line > Set Time – This option is available only under Historical Data 
Mode and allows you to choose the time to view within a set of historical 
data. 

• Time Line > Search By Callsign - Allows you to find a particular flight by 
entering the flight’s call sign and original airport. The flight icon in the Time 
Line is highlighted with a white box. 

 
Figure 3-33: Search By Call Sign 

4. Help Menu 

• Help > Time Line - Accesses the web-based on-line help for the Time Line 
component. 

• Help > Legend – Accesses the web-based on-line help for the Time Line 
icon legend. 

Time Line Color Tab Options 

The 12 tabs are arranged in the Time Line based on the screen resolution. The picture below is 
based on Windows default settings. 
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Figure 3-34: Time Line Coloring Tabs 

The default value colors the flights according to their arrival status. FSM gives you the flexibility 
to view flights according to different criteria. This allows for effective analysis to determine 
which flights make up the demand at an airport. There are 12 pre-defined Color tabs in the Time 
Line component. Each color tab option displays different information with a corresponding color 
scheme and legend (see Table 3-6). 

Table 3-6: Color Tab Options 

Tab Option Color Display Options 

Arrival Status 
(Default View): 

Priority, Removed, Departing (CTD Issued), 
Ground Stopped, Departing (Past EDT), Departing 
(No CTD), Flight Active, and Arrived Flights 

Arrival/Departure 
Status: 

Arriving and Departing Flights 

Aircraft Category Propeller, Turbo, Jet, and Unknown 

Aircraft Class Small, Large, Heavy, and Unknown 

Carrier All Major carrier and option to enter a single 
carrier 

Afix Color by arrival fix for that airport 

Dfix Color by departure fix for that airport 

Exemption Flts Excluded, Flts Not Exempted, and Flts 
Exempted 

User Air Cargo, Carrier, G/A, Military, Air Taxi, Other, 
and Unknown 

Alarm Status Flights with Alarm Set and Other flights 

Centers ZAB, ZAU, ZBW, ZDC, ZDV, ZFW, ZHU, ZID, 
ZJX, ZKC, ZLA, ZLC, ZMA, ZME, ZMP, ZNY, 
ZOA, ZOB, ZSE, ZTL, ZZZ and manual input.  

Note: Center options may change for Canadian 
airports. 

Distance Distance ranges from <200 to <2400 in increments 
of 200 miles and >=2400. 
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Ground Delay Tools Components 
Ground Delay Tools (GDT) Components aid users in looking at various operational or traffic 
scenarios. You can use modeling tools to analyze existing operations and previous days’ events. 
The actual running and issuing of Traffic Management Initiatives is not covered in this section. 
This section familiarizes you with all the GDT components: 

• GDT Setup 
• GDT Map 
• GDT Bar Graph 
• GDT Data Graph 
• GDT Data Table (Optional) 
• GDT Time Line (Optional) 
• GDT Coversheet 
• GDT Advisory 
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You can open any monitored airport in Ground Delay Tools mode by choosing a monitored 
airport and then clicking GDT Setup on the Control Panel component. There are four default 
GDT components that automatically display for the selected airport. All GDT components are 
interactive; any change in one component dynamically reflects in all other components where 
applicable. 

 
Figure 3-35: GDT Default Components 

GDT Setup Component 
You use the GDT Setup component to issue and send Traffic Management Initiatives (TMIs). 
The GDT Setup component consists of a menu bar, four action buttons, Program Type selection 
box, and five tabs that focus on different areas of information. You must select the type of TMI 
you want to issue from the Program Type selection box: 

1. GDP RBS++ - The default Program Type. This program runs the Ration By Schedule 
Algorithm plus Compression. 

2. GDP RBS – The original Ration By Schedule Algorithm. RBS is based on IGTA 
wheel arrival time (IGTA – Taxi). 

3. Compression – Run this program to decrease delay on flights involved in an existing 
GDP. If there are a number of slots for cancelled flights in the stack hours, you can 
use compression to move these flights to a later slot without needing to extend the 
GDP. 
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4. GS Immediate - Unlike ground delay programs, which delay flights because of a 
reduced AAR, the Ground Stop function prevents flights from departing until further 
notice. GS Immediate issues a Ground Stop Immediately. 

5. GS Future - Similar to GS Immediate, although the Ground Stop is issued at a 
specified time in the future. 

6. Blanket – Run this program type to revise any ground delay operation. This option 
adds or subtracts a fixed number of minutes to or from FAA-imposed delay. You 
should not use Blanket in conjunction with a GS. 

7. Airborne Holding - Used by traffic management specialists to determine the necessity 
of a GDP. In certain situations, putting delay on flights en route may be a better 
option than delaying flights on the ground. The airborne holding algorithm in FSM 
produces the amount of expected airborne holding delay, defined as [ASLOT – ETA] 
that would result from running a program. 

8. Purge - Cancels a GDP or GS, releasing all delay on included flights. This program 
type requires no input on any tab option. 

The GDP Setup component tab options and features change based on the Program Type selection. 
The five GDT Setup tabs are General (default selection), AAR, Tier/Distance, GS Modifications, 
and Power Run. 
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This section discusses the Setup Panel based on each tab option. Closing the GDT Setup 
component closes all the GDT components for the airport. The GDT Setup panel displays the 
substitution status for the airport: SUBS: ALL ON, ALL OFF, or SCS OFF. 

Note: The Program Type Purge is not mentioned in any of the tab panels, since 
Purge requires no parameter modifications. 

 
Figure 3-36: GDT Setup Component 

GDT Setup Panel Menu Bar 
The menu bar (shown below) in the GDT Setup component contains three options: File, View, 
and Help. 

1. File Menu 

• File > Load Proposed Parameters – Opens a secondary dropdown menu to 
select from specific parameter options: 

o > Ground Delay Program – Loads the proposed GDP parameters. 
o > Ground Stop - Loads the proposed Ground Stop parameters. 
o > Blanket - Loads the proposed Blanket parameters. 
o > Compression - Loads the proposed Compression parameters. 

• File > Load Actual Parameters - Opens a secondary dropdown menu to 
select from specific parameter options: 

o > Ground Delay Program - Loads the actual GDP parameters. 
o > Ground Stop - Loads the actual Ground Stop parameters. 
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o > Blanket - Loads the actual Blanket parameters. 
o > Compression - Loads the actual Compression parameters. 

• File > Open Coversheet – Opens the Coversheet file exploder that contains 
all the Coversheet files. Select the coversheet you want to open and click 
Open. All coversheet files are named covr.xxx, where xxx is the airport 
three-letter identifier. The file names also include the Date and ADL time 
followed by the type of coversheet (GS, GDP, or CNX). 

• File > Open Parameters File – Opens the PARAM_DIRECTORY File in 
file explorer. Select the parameters file and click Open to view the 
Parameters Files. 

• File > Save as – Saves the Setup component as a .jpg image to a directory of 
your choice. 

• File > Close – Shuts down the Setup component and all the complimentary 
GDT components for that particular airport. 

2. View Menu 

• View > Rename Window… – Displays the Rename Window dialog box and 
allows you to change the component name in the title bar. Enter the desired 
name then click OK to change the title bar heading. Click Cancel to close 
the Rename Window dialog box without making any changes. 

 
Figure 3-37: Rename Window Dialog Box 

There are five additional display options to choose from under the View menu. If you close a 
component and want to reopen it, use the View menu options to select and reopen the desired 
component. 

• View > Data Graph – Displays the Data Graph component 
• View > GDT Map – Displays the GDT Map component 
• View > Demand Graph – Displays the GDT Bar Graph component 
• View > Time Line – Displays the GDT Time Line component 
• View > Data Table – Displays information found in the Data Graph 

component, but in tabular format. 
• View > Flight List – Displays the Flight List for the monitored airport. The 

default Flight List includes AC, ID, ETD, ETA, DEST, ORIG, and ARTA-
CTA data elements. 

3. Help Menu 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Understanding Components 

 Version 7.9 3-48 

• Help > GDT Setup – Accesses the web-based on-line help for the GDT 
Setup component. 

GDT Setup Panel Buttons 

The three action buttons are Reload, Model, and Run. These buttons are active when the feature 
is available. 

• Clicking Reload causes FSM to load the latest ADL data into the GDT 
mode. You then can model the program using the latest data and make any 
adjustments you think are necessary. 

• Clicking Model models and reflects your changes in all GDT components for 
analysis and review. After you make any modification to any portion of the 
GDT Setup component, which FSM indicates by highlighting the tab window 
area with a red border, the Model button becomes active. After clicking 
Model, your GDT Setup component also resets and the red border disappears 
until you make an additional change. 

• Clicking Run displays the GDP/GS coversheet, which then gives you the 
option to send an Advisory or Autosend this initiative to ETMS. 

General Tab 
The General Tab is active for all program types and is the default tab that opens when you open 
the GDT Setup component. Within this panel you can enter the Program Time, Include Arrival 
Fix and Aircraft Types, select Initial GDP or Last Revision End Time, Adjust Delay, select Slot 
Hold Override, etc. Options which are not features for certain program types are disabled. 

You can edit Start and End time parameters in the Program Time section for all program types. 
You can populate the times in the text box to the right of the time field or use the slide bars, 
which automatically fill the time into the text box. Set the Duration of the program by entering 
the time in the corresponding textboxes using the format [ddhhmm] or by clicking and dragging 
the pointers on the Start Time and End Time for the desired hours. 

• Start Time – Enter the date and time when the GDP should begin. 
• End Time – Enter the date and time when the GDP should end. 

Once you select a Start Time, you can either select the End Time or enter the Duration of the 
program in the Hr and Min text boxes. The End Time of the program adjusts automatically based 
on the Start Time if you enter a duration time. 

• Lock – This functionality will “fix” the duration time of the program. This is 
helpful when you want to change the Start Time, but not decrease or increase 
the program length. 

• Compress to End – This functionality is only available during a 
Compression. When checked, all flights that have control times are eligible 
for compression. 

• Data Time – This functionality is the ADL time on which you are modeling 
and analyzing your TMI. Set the time you want to use as the current time. 
You can set this time forward or back without changing the data. If you 
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change the Data Time, a warning box appears letting you know the “Data 
Time changed from default,” and the time is highlighted in red. Changing the 
Data Time back to the default ADL time puts the Data text field back to 
normal. You cannot edit Data Time for an Airborne Holding program. 

Note: The default ADL time always appears in the GDT Setup Title bar. 

You can select parameters for Arrival Fix, Aircraft Types, and Carrier for all program types 
except Compression and Airborne Holding in the Include section. The default is set to All for the 
three parameters listed below. 

• Arrival Fix – Use the dropdown menu to determine which Arrival Fixes to 
include in the operation. You can select All or one individual fix. 

• Aircraft Types – Select All, Jet Only, or Prop Only from the Aircraft Types 
dropdown menu to specify the aircraft types included in the GDP operation. 

• Carriers – Select All to include all carriers at that airport. If you want to 
include only a single airline, type the carrier’s 3-letter code into the text box. 
The application does not allow you to include only one carrier without 
including its sub-carriers. Likewise, you cannot include one sub-carrier. 
Typing a carrier code into this field always includes the major and its sub-
carriers. 

• Initial GDP and Last Revision End Time – Available for only GDP RBS++ 
and RBS. If the program in place is the initial program (there is not a 
program currently running for that airport) you should select the Initial GDP 
checkbox. If you are running a revision, the Last Revision End Time is filled 
out and the Initial GDP checkbox should be unchecked. It is important that 
you do not select Initial GDP during a revision. 

• Adjust Delay – This parameter is available only when using the Blanket 
Program Type. You can use Adjust Delay to add or release a specified 
amount of time from selected criteria. You should only use Blanket during a 
GDP. For example, if you had a hole in the traffic flow, you could select 
centers, distance, fixes, or aircraft types and enter in a negative number to 
release some delay or release all delay by clicking Release. Release fills in 
the Adjust Delay text field with –999, which is equivalent to releasing all 
delay. Alternatively, you can add delay to the selected criteria by entering the 
amount of extra delay in minutes. 

• Slot Hold Override – You can change parameters only for RBS++, RBS, and 
Compression. The Slot Hold Override field allows you to override an 
airline’s slot holding status by either typing an airlines’ three-letter identifier 
directly in the text field next to Slot Hold Override or click Select to open 
the Select Slot Holding window as shown in Figure 3-38. 

The Select Slot Holding window lists the airlines currently holding slots at 
the airport and allows you to select which airline(s) to override. Select the 
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box next to each airline to override its slot holding status and include the slot 
in compression. When you check a box, that airline can no longer hold slots. 

 
Figure 3-38: Slot Holding Override Window 

• Sched/User Exemptions – You can select exemptions for any program type. 
Valid values for this field are: 

o Schedule Status – Any flight with SGTD and/or SGTA populated. 
o Air Carrier – ADL User field C. 
o Freight/Cargo Carrier – ADL User field F. 
o General Aviation – ADL User field G. 
o Military – ADL User field M. 
o Air Taxi – ADL User field T. 
o Other – ADL User field null or other than listed. 

• Delay Assignment Mode – Allows you to select either DAS (Delay 
Assignment) or GAAP (General Aviation Airport Program). DAS is the 
default setting. Most GDP programs use a DAS delay. A GAAP delay allows 
for the management of heavy pop-up traffic at an airport where current 
demand does not meet capacity. 

• Delay Limit – Allows you to set the amount of delay (in minutes) for flights 
controlled by a GAAP GDP. The default Delay Limit is 60 minutes. If an 
ADL contains GDP parameters that include a Delay Limit, that limit appears 
when you use the Load Parameters feature. 

AAR Tab 

The AAR tab is active for all Program Types except Compression and Blanket. The AAR Tab 
panel is almost identical to the Modify AAR Rates window. 
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Figure 3-39: GDT Setup - AAR Tab 

Fill in the program rates using the method described in the Control Panel Menu Bar, ETMS Tools 
menu, subsection above. There are two additional features to the GDT AAR tab, which are not 
included in Modify AAR Rates; the Auto Button and the GA Factor field. You can click Auto to 
fill the From Hr and Through Hr fields to match the Program Time specified in the General Tab. 
If you click Fill after entering the AAR rate and hours, the AAR automatically fills in the 
appropriate hour rows. The GA Factor is not available in GS Immediate or GS Future Program 
Types. The GA Factor accounts for potential “pop-up” flights. For example, if you change the 
AAR for a certain number of hours to 40 with a GA Factor of 5, the AAR that FSM uses to run 
the GDP is 35. This leaves room for any unknown flights that show up in that hour because the 
actual capacity of the airport is 40. 

Note: Changing AARs for fixes is not a functional option. The Fill dropdown has 
only Airport as a valid entry. Assigned AARs for certain fixes are a future 
enhancement. 

Tier/Dist Tab 

The Tier/Dist tab is active for all Program Types except Compression and Airborne holding. The 
Tier/Dist Tab has two types of exemption criteria, Tier based and Distance based. In the Exempt 
By dropdown box, select either a Tier or Distance based initiative. 

Tier/Distance Tab with Exempt By Tier Selected 

When you select Exempt By Tier, the panel illustrated below appears. The panel contains three 
sections where you can modify parameters: Centers, Airports, and Flights. 
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Figure 3-40: GDT Setup – Tier Tab 

Centers: You can select the centers you want to include in the program or select a Tier level from 
the Included dropdown menu: 

• Scope: Select a tier option from the dropdown menu. Selecting a Tier, 
automatically selects the associated centers. The total number of centers 
selected appears to the right of the Tier selection. Click Clear to erase all 
centers with checkmarks and return the included tier selection back to 
Manual. 

• Manual Center Selection: Click on the checkbox to select or unselect 
individual centers to include in the program. 

Airports: This section of the panel allows you to include and exempt airports: 

• Non-Exempt: You can include certain departure airports from a TMI that 
were not originally included based on the Center section criteria. Enter the 3 
or 4-letter airport code to include that airport. Separate airports with a 
space or a comma. 

• Exempt: You can exempt certain departure airports from a TMI. Enter the 3 
or 4-letter airport code to exempt that airport. Separate airports with a space 
or a comma. 
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Flights: This section of the panel allows you to exempt, i.e. give no delay, to priority flights as 
well as select Exempt by Departure Status or Time. 

• Exempt: Enter a flight’s ACID to exempt priority flights from the Ground 
Stop. 

• Exempt by Departure: To exempt flights based on their Departure Time or 
Departure Status, click the dropdown menu to select the desired option. 
When exempting a flight based on departure time, enter a value in within 
Data Time + (min). The value should equal the number of minutes relative to 
the data time to exempt flights that depart within that time. For example, to 
exempt flights departing within 20 minutes of the current time, enter 20 in 
the within Data Time + (min) (default value is 45). If you base your 
exemptions on Departure Status, you do not need to fill out any further 
parameters in this field.  

• Exempt GS by Status: Checking this box exempts GS flights according to 
their departure status. GS flights that have not departed (are on the ground 
and not airborne) are included in the GDP. This checkbox is selected by 
default. 

Tier/Distance Tab with Exempt By Distance Selected 

When you select Exempt By Distance, the panel illustrated below in Figure 3-41 appears. The 
Distance panel contains four sections in which you can modify the parameters: Distance, Centers, 
Airports, and Flights. 
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Figure 3-41: GDT Setup - Distance Tab 

 

Distance:  When the Distance Panel first appears, the default distance is 200 nautical miles. You 
can enter your distance range directly into the Distance textbox or click and drag the sliding bar 
for the desired distance; this automatically fills in the distance. Remember, anything changed in 
the Setup panel is reflected in the GDT Map. You can change the distance range from the Setup 
panel and simultaneously view the range ring and what centers/airports are affected from the 
GDT Map. 

Centers:  You can enter centers to be Exempt (receive no delay) or Non Exempt (receive delay). 

• Exempt: You can exempt certain centers from a TMI that were originally 
partially, or entirely, included based on the Distance criteria. Enter the 3 or 4-
letter center identifier to exempt a particular center. Separate multiple centers 
with a space or a comma. 

• Non-Exempt: You can include certain centers from a TMI that were not 
included originally based on the Distance criteria. Enter the 3 or 4-letter 
center identifier to include a particular center. Separate multiple centers 
with a space or a comma. 

Airports: This section of the panel allows you to include and/or exempt airports. 
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• Exempt: You can exempt certain departure airports from a TMI. Enter the 3 
or 4-letter airport code to exempt that airport. Separate multiple airports with 
a space or a comma. 

• Non Exempt: You can include certain departure airports from a TMI that 
were not included originally based on the Distance criteria. Enter the 3 or 4-
letter airport code to include that airport. Separate multiple airports 
with a space or a comma. 

• Non Exempt if Distance: Use this field to include Canadian airports. If you 
select a Canadian airport, FSM includes that airport if it falls within the 
selected distance parameter. 

Flights: This section of the panel allows you to exempt, i.e. give no delay, to priority flights as 
well as select Exempt by Departure Status or Time. 

• Exempt: You may choose to exempt certain flights from a TMI. Enter a 
flight’s call sign in the text field. Separate multiple flights with a space or a 
comma. 

• Exempt by Departure: Use the dropdown menu to Exempt flights based on 
their Departure Time or Departure Status. When exempting a flight based on 
departure time, enter a value in the within Data Time + (min) text field. The 
value should equal the number of minutes relative to the data time to exempt 
flights that depart within that time. For example, to exempt flights departing 
within 20 minutes of the current time, enter 20 next to Data Time + (min) 
[default value is 45]. If you base your exemptions on Departure Status, you 
do not need to fill out any further parameters in this field. 

• Exempt GS by Status: Checking this box exempts GS flights according to 
their departure status. GS flights that have not departed (are on the ground 
and not airborne) are included in the GDP. This checkbox is selected by 
default. 

GS Modifications Tab 

The GS Modifications Tab is available only for GS Immediate and GS Future Program Types. 
Use this Tab to input additional information/parameters for Ground Stops. 
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Figure 3-42: GDT Setup - GS Modifications Tab 

Late Start/Early Release: Using this option you can specify an additional center or airport at 
which to run a GS. The GS parameters set in this field can have start and end times that differ 
from the main GS. All other parameters in the GS initiative remain the same. You can edit or 
delete the statements you add to this field. To edit, select the center or airport then click Modify. 
To delete, select the center/airport and then click Delete at the bottom of the Panel. 

• GS Start and GS End: For the selected Centers/Airports, you can specify 
time parameters that differ from the main GS. All other parameters in the GS 
remain the same. 

• Centers: You can add additional centers to run a GS. Enter the 3 or 4-letter 
center name and then click Add. Separate multiple centers with a space or a 
comma. 

• Airports: You can add additional airports to run a GS. Enter the 3 or 4-letter 
airport code and then click Add. Separate multiple airports with a space or a 
comma. 

Power Run 

The Power Run tab is available only for GDP RBS++, GDP RBS, GS Immediate, and GS Future 
Program Types. Once the parameters are set, you may want to determine which parameters run 
the best GDP. In this case, you can take advantage of FSM’s powerful analysis capabilities to 
view the results of the parameters you have selected before actually running the operation. 
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You can use the Power Run tab in the GDT Setup component as an analysis tool. There are four 
GDP and three GS Power Run operations, which analyze the results for any program. You can 
select these options from the dropdown menu that appears next to Power Run By. You use the 
Power Run function to determine whether you need to modify the parameters. When any Power 
Run is generated, FSM automatically saves the Power Run to a file. 

Once you have clicked Run on the GDT Setup component, you still have the option to analyze 
the parameters used. FSM generates a post-operation evaluation, called the Analysis Report, 
when you click Run. The Analysis Report is an option on the Reports menu in any delay 
operation Coversheet. 

To view a scenario, select the type of program to model in the Power Run By dropdown menu 
and click Model. Model displays the effects of potential operation parameters and how traffic at 
the airport would be affected by using these parameters for an actual program in all GDT 
components. Review the program statistics in the Data Graph. To preview the effects of running a 
Power Run scenario as an actual program, move the black line on the Data Graph component to 
other options displayed on the X-axis. This is discussed in more detail below in the Data Graph 
Component Section. 

With the exception of Power Run for Decision Time, you can preview the proposed parameters 
and their effect on the airport’s traffic. 

Note: After you click Model, the Setup Panel no longer contains a red border, 
which indicates that all the components reflect the information in the GDT Setup 
component. 

Power Run Options 

The different options when using Power Run By describe what data appear on the X-axis of the 
Data Graph and the headers in the Data Table (see Figure 3-43). The Program Type you select 
determines which options appear in the Power Run By dropdown menu. All GDP functions have 
“GDP” listed before the Power Run Type and all GS functions have “GS” listed before the Power 
Run Type. 

Table 3-7 Power Run Options by Program Type 

Program Type Power Run By Options 

GDP Center Group 

GDP Data Time 

GDP Distance 

GDP Decision Time 

GDP Center Group & Data Time 

GDP RBS++  
GDP RBS 

GDP Data Time & Distance 

GS Center Group 

GS Time Period 

GS Immediate 
GS Future 

GS Center Group & Time Period 
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Figure 3-43: GDT Setup - Power Run Tab 

Note: Distance variables are only editable when you model a Distance based 
Program. 

• Center Group: Available for both GDP and GS Program types, this option 
allows you to view the effect of the “proposed parameters” on the different 
center groups. The post-operation demand rate for each hour for a specific 
group of centers appears in the Data Graph. Other information displayed, 
includes average delay, number of affected flights and total delay. 

• GDP Data Time: From the Setup Panel, select GDP Data Time in the Power 
Run By dropdown menu. This option is available only for GDP program 
types. This option allows you to view the effects of the proposed GDP 
according to the time the GDP is issued. Using the display, you can 
determine how far in advance you need to issue the GDP. Any hour whose 
demand still exceeds the AAR is highlighted in red. 

• GS Time Period: From the GDT Setup component, select GS Time Period in 
the Power Run By dropdown menu. This option is available only for GS 
program types. This function shows you the effect of running a ground stop 
for various lengths of time. When you select GS Time Period, two text fields 
become active:  Number of Start Times and Number of End Times. The 
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default for both is set to 2, but you can manually enter in another value to 
meet your analysis needs. 

Note: If you decide to run a GS for longer than one hour, FSM provides a 
warning message to ensure you want the ground stop to last for that duration. 

• Distance: From the GDT Setup component, select Distance from the Power 
Run By dropdown menu when modeling either a GDP or GS. This function 
shows you the effect of running a GDP or GS for various distance 
parameters. When Distance is selected from the Power Run By dropdown 
menu, three text fields become active in the Power Run Tab: Start Distance, 
End Distance, and Step Size (distance increment). The default is set to start at 
200 nautical miles and End at 2000 nautical miles with a Step Size of 200 
nautical miles. You can manually input your desired distance and increment 
range into the appropriate text fields. 

• GDP Decision Time: From the GDT Setup component, select GDP Decision 
Time from the Power Run By dropdown menu. Decision Time is available 
only with GDP operations. This function displays the optimum time to run 
the proposed GDP including specific Center Groups. The optimum GDP time 
is defined as the latest “half hour” in which running a GDP does not cause 
the demand in the first hour of the GDP to exceed the AAR. Power Run for 
Decision Time displays each center group with the optimum GDP Time. If a 
center group cannot benefit from a GDP, “NA” appears below that center 
group. 

• GDP Center Group & Data Time: From the GDT Setup component, select 
GDP Center Group & Data Time from the Power Run By dropdown menu. 
This option is available only for GDP program types. This function combines 
Power Run by Center Group and Power Run by Data Time. When you 
perform Power Run by Center Group & Data Time, you can view all 
available options to run a GDP using a particular center group at various data 
times. 

• GDP Data Time & Distance: From the GDT Setup component, select GDP 
Data Time & Distance from the Power Run By dropdown menu. This option 
is available only for GDP program types. This function combines Power Run 
by Data Time and Power Run by Distance. When you perform Power Run by 
Center Group & Data Time, you can view all available options to run a GDP 
using a particular distance at various data times. Just as in the Distance set 
up, three text fields become active in the Power Run Tab: Start Distance, 
End Distance, and Step Size (distance increment). The default is set to start at 
200 nautical miles and End at 2000 nautical miles with a Step Size of 200 
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nautical miles. You can manually input your desired distance and increment 
range into the appropriate text fields. 

• GS Center Group: This Power run allows you to see different statistics for all 
center groups. The Data Graph’s X-axis and the Data Table’s column header 
display the various center groups. This option is available only for GS 
program types. 

• GS Time Period: This Power Run allows you to see different statistics for 
different Time Periods. You can specify the number of Time Periods by 
typing a number in the Number of Start times and Number of End times’ 
textboxes on the Power Run Tab. The Data Graph’s X-axis and the Data 
Table’s column headers show the various Time Periods. This option is 
available for only GS program types. 

• GS Center Group & Time Period: This Power Run allows you to see which 
combination of center groups and time periods put in the GS parameters 
would produce the best program. The Data Graph’s X-axis and the Data 
Table’s column headers show the various Time Periods and Center Group 
combinations. This option is available only for GS program types. 

GDT Map Component 
The GDT Map component is one of four components that automatically open when you click 
GDT Setup on the Control Panel. The GDT Map component is similar to the display of the US 
Map component in monitor mode, however the functionality is different. Selections made in the 
GDT Setup component reflect automatically in all the other GDT components. Airports the server 
is currently monitoring appear with the airports’ three-letter identifier and a colored dot that 
indicates the GDT status of each airport. The title bar displays the normal component labeling 
conventions. GDT appears at the end of the title bar label to indicate that you are looking at the 
Map in GDT mode. 
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When you initially open GDT mode, the GDP Setup component has the exempt by tier with 
internal centers selected by default on the Tier/Dist Tab. Therefore, the GDT map initially has 
only the airport’s Internal center selected. When a center is included, it is colored with a maroon 
overlay and the airports that are within the centers are colored red as shown in Figure 3-44. The 
color red for an airport indicates that a Traffic Management Initiative includes the airport. A 
green colored airport indicates that the airport is exempt from delay. 

 
Figure 3-44: GDT Map Component 

The GDT Map component allows you to design a TMI visually by selecting/deselecting airports 
and/or centers. Selecting/Deselecting airports, centers, and adjusting the distance range 
interactively updates other GDT components. 

GDT Map Zoom Capabilities 
GDT Map contains the same zoom capabilities at the US Map in Live mode, for more detail refer 
to Map Component section of this chapter. 

Distance Based GDPs 
When you select a distance based GDP in the GDP Setup component, a maroon colored “range 
ring” appears on the GDT Map component. The default distance is set to 200 nautical miles. The 
range distance is indicated on the GDT Map just outside the top of the ring. In addition to 
adjusting the range from the GDT Setup component, you can alter the distance directly from the 
GDT Map. Put your cursor on the edge of the distance ring until the cursor turns into direction 
arrows, then hold down the left mouse button and drag and drop the edge of the ring to increase 
or decrease the distance. All airports within the range limit are included automatically into the 
program and colored red. To exclude an airport from within the distance range, just click on the 
dot for that particular airport. Clicking on an airport within the distance ring turns the dot to green 
and excludes that airport from program delay. Any additional airports you select appear in the 
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GDP Setup component in the Airports: Non Exempt or Exempt field in the Tier/Dist Tab. 
Likewise you can select/deselect centers to include in a program from the GDT Map. Clicking 
once on a center includes the center in the program. The color of the selected center changes to 
maroon and the airports within that center change color indicating that the program includes them 
as well. The selected center appears in the GDP Setup component in the Centers: Non Exempt 
field in the Tier/Dist Tab. ZFW in Figure 3-45 and Figure 3-46 is an example of a user selected 
non-exempt center. 

Note: Clicking only once on a center that is already included within the 
program selection does not reflect any visual difference on the screen. 

If you click twice on a selected center, that center is exempt from the program. The selected 
center turns to black and the airports within the center turn green to indicate that they are exempt 
from delay. The center selected appears in the GDP Setup component in the Centers: Exempt 
field in the Tier/Dist Tab. Figure 3-45 is an example of a user selected exempt center (ZAU). If 
you click on a center a third time, the center selection returns to the distance based default 
selection. 

Mouse Action  Description 

Click on Airport Toggle an airport from 
Exempt/Non-exempt 

Click on center once Includes Center in program 

Click on center twice Exempts center from program delay 

Click on center three 
times 

Default selection by distance 
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Figure 3-45: GDT Map Setup 

Figure 3-46 is the GDT Setup component which corresponds with the GDT Map component 
setup in Figure 3-45. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Understanding Components 

 Version 7.9 3-64 

 

 
Figure 3-46: GDT Setup reflected GDT Map component 

Tier based GDPs 
The initial default setting when you open GDT Mode components is an ALL Tier based GDP. 
When you select a tier based GDP from the GDP Setup component, FSM colors all centers 
included in a TMI maroon on the map and colors all airports included red. For example, the next 
figure illustrates a 1st Tier GDP with user selected airport, ATL, as an additional Non-Exempt 
airport. The method of selecting/deselecting airports and/or centers is the same as described 
above in the distance based GDP. 
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Figure 3-47: ATL 1st Tier Program 

Figure 3-48 displays the GDT setup component that corresponds with the GDT Map component 
in Figure 3-47. 
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Figure 3-48: GDT Setup Component ATL 1st Tier 

GDT Map Menu Bar 
The GDT Map component menu bar contains four options: File, View, Map and Help.  The menu 
selections are the same for the GDT Map as they are for the Status Map—see the Map 
Component section in this chapter for more information. 

GDT Bar Graph Component 
The GDT Bar Graph component is one of four components that open automatically when you 
click GDT Setup on the Control Panel component. The Bar Graph allows you to view arrival 
demand at the airport being monitored and compares actual data with proposed parameters. Click 
Model on the GDT Setup component to view the modeled parameter results in the Bar Graph as 
well as the Data Graph component. The GDT Bar Graph menu and Tab options are almost 
identical to that of the Monitored (Live) Graph. Please review the Bar Graph Component section 
above for more detail. There are some minor differences in the GDT Graph. In GDT mode, only 
arrival information appears, therefore under the View menu no ADL ADR Line or Model ADR 
Line option appears. 

One of the key differences of GDT Bar Graph is that it always displays both solid and hashed 
bars. Solid bars represent the original data, while hashed bars represent modeled data (see Figure 
3-49. 
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Figure 3-49: GDT Bar Graph Display 

GDT Data Graph Component 
The GDT Data Graph component is one of the four components that automatically opens when 
you click GDT Setup on the Control Panel component. You have the option to review, or model 
your ground delay parameters before actually running the program or revising any parameters. 
Click Model on the GDT Setup component to view the initiative’s results with your current 
parameters in the Data Graph. 

From the Power Run Tab on the GDT Setup component, you can choose the type of data you 
want to view on the Data Graph’s X-axis. When you click Model, you can view the results of 
various scenarios. You have the option to change your parameters, analyze the program further, 
or, if satisfied with the result, run the program (see Figure 3-50). 
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Figure 3-50: Data Graph Component 

Selecting Different Scenarios 
You can view all the available scenarios based on the Power Run selection from the GDT Setup 
component. For example, selecting Power Run By > GDP Center Group from the Power Run 
tab on the GDT Setup and then clicking Model, displays all the available tiers for the monitored 
airport on the Data Graph component’s X-axis. Your modeled scenario statistics are displayed in 
the Legend Table. Using your cursor to drag the black vertical line to a center group, or just move 
the cursor over the desired center group and click to move the line. The delay statistics to the 
right of the Data Graph reflect the line of scenario delineation. In addition, changing the center 
option automatically updates all GDT components to reflect the new parameters. The Data Graph 
component includes a roll-over feature. Rolling your cursor over any line in the Data Graph gives 
you the delay statistics for the colored line that reflects the results of the center group. From the 
Data Graph, it is easy to visualize what center groups give the best results.  

Delay Statistics 

The Legend Table displays the delay statistics. By default the Legend Table appears when you 
open the Data Graph component. You can hide the legend by un-checking the View > Show 
Legend box from the Data Graph Menu. In the Legend Table, you can view a desired delay 
statistic several ways. Selecting the All checkbox selects and displays all the delay statistics. 
Selecting the Default checkbox displays the default delay statistics, which are Max Delay, Avg 
Delay, Max Air Hold, Avg Air Hold, and Delay Var. You can select/deselect any of the delay 
statistic checkboxes that you want to view in the Data Graph. To view one delay statistic in more 
detail, select the desired radio button option, located to the left of the checkboxes. The radio 
button option displays only one delay statistic at a time, but gives a more refined looked at the 
numbers. The Data Graph includes the following Delay Statistics: 
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• Total # Flts:  The total number of flights included in the TMI (cancelled and 
exempt flights) for each particular power run scenario. Default color is pink. 

• Affected Flts:  The total number of flights included in and affected by the 
TMI for each particular power run scenario (non-exempt and non-cancelled 
flights only). 

• Total Delay:  The total amount of delay that would occur if you ran that 
particular scenario. Default color is maroon. 

• Max Delay:  The maximum amount of delay (in minutes) that any one flight 
would receive if you ran that particular scenario . Default color is white. 

• Avg Delay:  The average amount of delay (in minutes) flights would receive 
if you ran that particular scenario. Default color is black. 

• Max Air Hold:  The maximum amount of airborne holding delay (in minutes) 
that would be placed on any one flight if you ran that particular scenario. 
Default color is lavender. 

• Avg Air Hold:  The average amount of airborne holding (in minutes) that 
would be placed on flights if you ran that particular scenario. Default color is 
orange. 

• Stack:  The amount of flights that would be left in the “stack” hour following 
the end of the initiative if you ran that particular scenario. Default color is 
hunter green. 

• Unrec Delay: Unrecoverable delay is the amount of delay that remains on 
flights even if you release the TMI right before the start time for the selected 
scenario. FSM determines this value by setting the time to the TMI start time 
and performing the release delay function. Default color is lime green. 

• % Unrec: Percentage of Unrecoverable delay is a value that FSM calculates 
by taking the Unrecoverable Delay and dividing it by Total Delay 
(Unrecoverable Delay/Total Delay). This is the percentage of delay that 
remains even if you release all delay at the start time for the selected 
scenario. Default color is yellow. 

• Delay Var: Delay Variability is the standard deviation of the carriers’ 
average delay. FSM determines this value by taking the average delay of all 
carriers to see if they are similar. If the average delay is similar for all 
carriers, the delay variability is a small value. Larger deviation, or increased 
dissimilarity of average delay for all carriers, results in larger delay 
variability values. Default color is red. 

• EMA: The Equity Metric for Airlines (EMA) is a metric that indicates (as a 
whole) how equitable, or fair, the proposed initiative is for the airlines. 
Equity is determined by comparing the delay assigned in a proposed 
initiative to that which results if you use the airborne holding model. You 
must view any deviation from the airborne holding model as decreased 
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equity. The values shown in this field are integers rounded from the 
calculated values. A value of 1 indicates that the initiative option results in 
delays that are exactly the same as those for airborne holding. A value from 2 
to 8 indicates an option that still exhibits good equity, though the one with 
the lower value is still preferred. A value from 9 to 16 indicates an option 
with increasingly significant deviation from the standard. A value above 16 
indicates an option with poor equity. Default color is cyan. 

• EMF: The Equity Metric for Flights is a metric that indicates (as a whole) 
how equitable, or fair, the proposed initiative is for all the flights. Equity is 
determined by comparing the delay assigned in a proposed initiative to that 
which results from using the airborne holding model. You must view any 
deviation from the airborne holding model as decreasing equity. The values 
shown in this field are integers rounded from the calculated values. A value 
of 1 indicates that the initiative option results in delays that are exactly the 
same as those for airborne holding. A value from 2 to 8 indicates an option 
that still exhibits good equity, though the one with the lower value is still 
preferred. A value from 9 to 16 indicates an option with increasingly 
significant deviation from the standard. A value above 16 indicates an option 
with poor equity. Default color is blue. 

GDT Data Graph Menu 
The menu bar (shown below) in the GDT Data Graph component contains three options: File, 
View, and Help. 

1. File Menu 

• File > Save as – Saves the Data Graph as a .jpg image in a directory that you 
specify. 

• File > Print – Prints the Data Graph that is currently active on your screen. 
• File > Close – Closes the Data Graph component only. 

2. View Menu 

• View > Show Legend – By default the checkbox is selected and the color 
legend of the delay statistics appear. Unselect the checkbox to hide the 
legend and the delay statistics. 

3. Help Menu 

• Help > Data Graph – Opens a web-based on-line help system. 

GDT Data Table Component 

The GDT Data Table component is an optional component in GDT Mode. To open the 
GDT Data Table, select View > Data Table from the GDT Setup component menu bar. 
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The Data Table is an exact representation of the Data Graph, but in tabular format (see 

 
Figure 3-51). The column headings display the same information that appears on the X-axis of the 
Data Graph, which is based on the Power Run selection type. The top scroll area displays the 
hours of the proposed initiative along with the current AAR for each hour. Under each heading, 
the [# of flight/Open Slots/Stack] values appear for each hour/heading combination. Below the 
Hour rows are the various statistics. You can sort the Delay Statistic rows by clicking on the 
statistic labels beneath the Program Hour rows.  This sorts the best scenarios from left to right for 
the selected statistic. 
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Figure 3-51: Data Table Component 

The Data Table component and the Data Graph Component are dynamically interactive. 
You can move the model line in the Data Graph component and the Data Graph 

highlights the corresponding column or you can select a column header from the Data 
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Table to dynamically move the selection line in the Data Graph. 

 
Figure 3-52 illustrates how both the Data Graph and Data Table display the same statistics but in 
different formats. 
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Figure 3-52: Data Graph Reflected the Data Table selection for 1st Tier 

GDT Data Table Menu 
The menu bar in the GDT Data Graph component contains two options: File and Help. 

1. File Menu 

• File > Save as – Saves the Data Table as a .jpg image in a directory that you 
specify. 

• File > Print – Prints the Data Table that is currently active on your screen. 
• File > Close – Closes the Data Table component only. 

2. Help Menu 

• Help > Data Table – Opens a web-based on-line help for the Data Table 
component. 

GDT Time Line Component 
The GDT Time Line component is an optional component in GDT Mode. To open the GDT Time 
line, select View > Time Line from the GDT Setup component menu bar. The Time Line in GDT 
Mode is almost identical to the Time Line in Monitored Live mode. 

There are two differences to the GDT Time Line that should be noted. First, GDT Mode uses 
only arrival data, the GDT Time Line displays only arriving flights where as the Live Time Line 
can display both arrival and departure data. The View > Departure Data option that appears in 
the Monitored Live Time Line is not an option in GDT Mode. 

Second, there is an extra menu option, Display, available in the GDT Time Line. The Display 
Menu option contains 6 additional radio button choices for how you can view flights in the GDT 
Time Line component, shown in Figure 3-53 below. 
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Figure 3-53: GDT Time Line Component 

You can display the flights in the Time Line based on various ADL arrival data fields. By default, 
the GDT Time Line displays based on ETA. 

GDT Time Line Menu Bar 
The menu bar in the GDT Time Line component contains five options: File, View, Time Line, 
Display and Help. 

1. File Menu – the GDT Time Line File menu is exactly the same as the Monitored Live 
Time Line File menu except that it has no Close Group option. See the Time Line 
Menu Bar section above for more information. 

2. View Menu – the GDT Time Line View menu is exactly the same as the Monitored 
Live Time Line View menu except that it has different default selections. See the 
Time Line Menu Bar section above for more information. 
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Note: Show Cancellations and Open Slots in Carrier Color checkboxes are 
selected by default. 

3. Time Line Menu – the GDT Time Line component Time Line menu is exactly the 
same as the Monitored Live Time Line component Time Line menu. See the Time 
Line Menu Bar section above for more information. 

4. Display Menu 

• Display > ETA – Display flights based on their Estimated Time of Arrival 
(ETA). 

• Display > BETA – Displays flights based on their Base Estimated Time of 
Arrival (BETA). The BETA matches the ETA and is frozen when the flight 
becomes active or when the flight becomes controlled.  

• Display > IGTA – taxi – Displays flights based on their Initial Gate Time of 
Arrival (IGTA) minus taxi time (IGTA Wheel Time). The IGTA is based on 
the OAG times or flight plan times and never changes. Taxi time default is 
10 minutes, but you can change it in the GDT Control window. 

• Display > OCTA – Displays flights based on their Original Controlled 
Times of Arrival (OCTA), Original ETA, OGTA Wheel Time, or ETA 
position, depending on the available information. For example, if the 
Original CTA is not available, FSM uses Original ETA and so on.. This time 
never changes. 

• Display > CTA – Displays flights based on their current Controlled Time of 
Arrival (CTA). 

• Display > EAFT – Displays flights based on their Estimated Arrival Fix 
Time (EAFT), which is the time at which the flight crosses its designated 
arrival fix. 

5. Help Menu – the GDT Time Line Help menu is exactly the same as the Monitored 
Live Time Line Help menu. See the Time Line Menu Bar section above for more 
information. 

GDT Coversheet 
Each GDT program generates a coversheet when you run the program. The GDT Coversheet 
contains all the GDT parameters, depending on Program Type selected, including the text fields 
for specific parameters. This section describes each type of Coversheet, the Coversheet menu, and 
Coversheet buttons. 

Coversheet Menu 

There are three file menu options available on the GDT Coversheet: File, View, and Help. 

1. File Menu 

• File > Save As… – Saves a coversheet in FSM. The default format is 
fsmc.<airport> followed by the date, time, and program information. 
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• File > Save Web Coversheet As… – Saves the Coversheet information to a 
file for later use. The default format is covr.<airport> followed by the date, 
time, and program information. 

Note: The Coversheet saves itself in a pre-defined file format that may not 
exactly match the software display on your computer monitor. 

• File > Close – Closes the Coversheet window. 
2. View Menu 

• View > FADT – Displays the FADT Report. 
• View > Analysis – Displays the Analysis Report. 
• View > Carrier Statistics – Displays the Carrier Statistic report 

3. Help Menu 

• Help > Coversheet – Displays web-based on-line help information about the 
FSM Coversheet. 

General Parameters 

Field Name Description Applicable Program 
Types 

Airport  The affected arrival airport 
where the program is issued. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, Purge 

Program Time  The program time period 
(Start Time/End Time). 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, Purge 

Data Time  Current date and time (in 
Zulu time). 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, Purge 

Update Time  Last ADL time that passed 
before running the program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, Purge 

Minimum moveup time The minimum time that the 
Compression algorithm tries 
to move up a flight. If it 
cannot find a flight with at 
least 10 minutes of benefit, 
the algorithm with decrease 
the minimum move up time 
by 1-minute increments until 
it can assign a flight to a 
better slot time. 

Compression 

Priority Compression gives priority 
to CDM members and then 

Compression 
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Field Name Description Applicable Program 
Types 

non-CDM members. 

EQP Type  The Equipment Type 
selected for the program. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future, Purge 

Arrival Fix  The arrival fixes of the 
affected airport being 
included in the program. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future, Purge 

Carrier  Carriers that operate at that 
airport appear in the 
program. This can be “All” 
or a single major carrier and 
its sub-carriers. A 3-letter 
airline code indicates that the 
program includes only one 
major carrier. A single 
carrier included in the 
program is always a major 
carrier and its sub-carriers. It 
is never truly a “single” 
airline. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future, Purge 

Last GDP End Time  If this is not the first GDP of 
the day for the airport, the 
ending time of the last GDP 
run appears here. 

GDP RBS, GDP RBS++ 

Program Type  The type of program you ran. 
Either RBS, RBS++, or 
compression when you run a 
GDP. 

GDP RBS, GDP RBS++ 

Delay assignment mode  The type of delay assignment 
mode selected for the GDP, 
DAS or GAAP. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future 

Delay limit  The maximum number of 
minutes a pop-up flight can 
be delayed during a GAAP 
GDP. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future 

Sched/User Exemptions  The type of flights exempt 
from departure delay during 
a GDP. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future 

WX Metar  FSM automatically fills in 
Metar information. 

GDP RBS, GDP RBS++, 
Blanket 
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Field Name Description Applicable Program 
Types 

WX TAF  FSM automatically fills in 
TAF information. 

GDP RBS, GDP RBS++, 
Blanket 

Slot override carriers Some carriers have the 
option to hold slots, or 
exclude their slots from 
compression, at an airport for 
future use. Overriding this 
option means that the 
algorithm includes any 
carriers’ slots that the carrier 
held in the compression at 
that airport. 

Compression 

 

Tier/Dist Parameters 

Field Name Description Applicable Program 
Types 

Exempt by  Lists if the program is either 
Tier or Distance based. For 
Distance based GDPs, the 
distance of the range ring 
appears in nautical miles. 

GDP RBS, GDP RBS++, 
GS Immediate, GS Future 

Exempt by  Lists if flights are exempt by 
Departure Time or Departure 
Status. 

GDP RBS, GDP RBS++, 
GS Immediate, GS Future 

Exempt GS flights  GS Stopped flights are 
exempted by status, even when 
you select Exempt by 
Departure Time on the 
Tier/Dist setup tab, when you 
select the Exempt by GS 
Flights checkbox. 

GDP RBS, GDP RBS++ 

Plus time  Flights that are exempt from 
the program because their 
departure time is within the 
current time + the value in the 
(min) field. This field has a 
default value of 45 minutes 
when you select Exempt by 
Departure Time. 

GDP RBS, GDP RBS++ 

Center Keyword  The center grouping keyword GDP RBS, GDP RBS++, 
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Field Name Description Applicable Program 
Types 

is an abbreviated term to 
describe the scope of the 
initiative.  For example, the 
Center Keyword 2ndTie refers 
to a strictly second tier-based 
program. 

Blanket, GS Immediate, GS 
Future 

Airport Keyword  The airport grouping keyword 
is used to list what Canadian 
airports are receiving departure 
delay.   

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future 

Included Centers  This is a list of the centers 
affected by the GDP operation. 
If there are too many centers to 
fit in the space provided, you 
see “...” and can click the 
arrow at the end of the field to 
pull down a menu with a 
complete listing of the facilities 
involved. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future 

Included Airports  Airports affected by the GDP 
operation. If there are too many 
airports to fit in the space 
provided, you see “...” and can 
click the arrow at the end of the 
field to pull down a menu with 
a complete listing of the 
facilities involved. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future 

If-distance airports  Canadian Airports that are 
included if they fall within the 
distance range. This field is 
only applicable during 
distance-based programs. 

GDP RBS, GDP RBS++, 
GS Immediate, GS Future 

Exempted centers  Centers that are within the 
scope of the GDP but exempt 
from delay. 

GDP RBS, GDP RBS++, 
GS Immediate, GS Future 

Exempted airports  Airports that are within the 
scope of the GDP but exempt 
from delay. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future 

Exempted flights  List of flights by call sign 
exempted from the GDP 
operation. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future 
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Field Name Description Applicable Program 
Types 

Last Start/Var Releas… Additional Centers or airports 
at which to run a GS. The 
parameters in this field can 
have a GS start and stop time 
that differs from the main GS. 

GS Immediate, GS Future 

 

Program Results Summary 

Field Name Description Applicable Program 
Types 

Minimum delay before  The minimum delay given to 
any one flight included in the 
parameters before you ran the 
program. 

GDP RBS, GDP RBS++, 
Blanket, GS Immediate, GS 
Future, Purge 

Minimum delay after  The minimum delay given to 
any one flight included in the 
parameters after you ran the 
program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Total Affected Flights  Total number of flights 
included in the GDP operation 
(including cancelled flights) 
and the number of flights 
actually affected (non-exempt) 
by the GDP (excluding 
cancelled flights). (Max [0, 
CTA - BETA]) determines 
Any ATC Delay statistics. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Average delay before  Total delay of flights in the 
GDP operation divided by the 
Total Affected Flights in the 
operation before you ran the 
program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Average delay after  Total delay of flights in the 
GDP operation divided by the 
Total Affected Flights in the 
operation after you ran the 
program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Total Flights  The total numbers of flights 
arriving at the monitored 
airport within the program start 
and end time. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 
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Field Name Description Applicable Program 
Types 

Maximum delay before  The longest delay assigned to 
any one flight in the GDP 
before you ran the program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Maximum delay after  The longest delay assigned to 
any one flight in the GDP after 
you ran the program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Stack value  Number of flights pushed out 
of the GDP period as a result of 
running the GDP. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Total delay before  The sum of all delays resulting 
from this GDP operation in 
minutes before you ran the 
program. Determined by CTA - 
OETA.. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Total delay after The sum of all delays resulting 
from this GDP operation in 
minutes after you ran the 
program. Determined by CTA - 
OETA.. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Stack AAR The AARs that occur in the 
hours after the end time of the 
GDP, but that still have CTA 
flights in them because of GDP 
delay. 

GDP RBS, GDP RBS++, 
Compression, Blanket, GS 
Immediate, GS Future, 
Purge 

Report Time The current date and time in 
DDHHMM format. The time is 
according to the 24-hour clock 
in Zulu time. 

GDP RBS, GDP RBS++, 
Compression, Purge 

 

Scrolling Window Statistics 

Field Name Description Applicable Program 
Types 

ETA  Estimated Time of Arrival 
broken into 15-minute 
increments. 

GDP RBS, GDP RBS++ 
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Average Delay  Average delay for each 15-
minute increment. 

GDP RBS, GDP RBS++ 

Original Demand  Number of arrival flights for 
each 15-minute increment 
before running the GDP. 

GDP RBS, GDP RBS++ 

Unassigned Slots  Number of unassigned slots 
for each 15-minute increment 
during a GAAP GDP. 

GDP RBS, GDP RBS++ 

Quarterly AAR  The Airport Arrival Rate set 
for each 15-minute increment 
after running the GDP. 

GDP RBS, GDP RBS++ 

Hourly AAR  The Airport Arrival Rate for 
each hour during the GDP. 

GDP RBS, GDP RBS++ 

 

Coversheet Buttons 

• Advisory – When you click Advisory, the Advisory Window appears, which 
allows you to send either a Proposed or an Actual Advisory to all FSM users. 

• Autosend –When you click AutoSend the FADT files are sent to Volpe, 
which are then distributed in the next ADL. 

• Close – When you click Close, no action is taken from the GDP Coversheet 
window. 

Coversheet examples 

This section provides examples of coversheets. 
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Figure 3-54: GDP Coversheet 
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Figure 3-55: GS Coversheet 

 
Figure 3-56: Purge Coversheet 

Note:  Blanket and Compression Coversheets contain similar information as the 
examples illustrated above.  
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GDT Advisory 
This window contains all the GDT parameters that you set and some fields in the Remarks section 
that you must fill in before sending an advisory. 

Advisory Menu 

1. File Menu 

• File>Save As – Saves an advisory in FSM. The default format is 
adzy.<airport> followed by the date, and time. 

• File>Print – Prints the information from the Advisory window. 
• File>Close – Closes the Advisory window without taking any action. 

2. Help Menu 

• Help>[Program Type] Advisory – Displays web-based on-line help 
information about the Advisory window for the Program Type. 

Program Parameters Summary 

Field Name Description Applicable Program 
Types 

Airport  The airport for which you are 
issuing a program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, 
GS Immediate, GS 
Future, Purge 

Center  The center that includes the 
affected airport. 

GDP RBS, GDP RBS++, 
Compression, Blanket, 
GS Immediate, GS 
Future, Purge 

Program Time  The times at which the 
program starts and ends. 

GDP RBS, GDP RBS++, 
Compression, Blanket, 
GS Immediate, GS 
Future, Purge 

ADL Time  The time of the last ADL used 
before you ran the program. 

GDP RBS, GDP RBS++, 
Compression, Blanket, 
GS Immediate, GS 
Future, Purge 

Delay assignment mode  The type of delay assignment 
mode selected for the GDP, 
DAS or GAAP. 

GDP RBS, GDP RBS++, 
Compression, Blanket, 
GS Immediate, GS 
Future, Purge 

Delay limit  The maximum number of 
minutes a pop-up flight can be 
delayed during a GAAP GDP. 

GDP RBS, GDP RBS++, 
Compression, Blanket, 
GS Immediate, GS 
Future, Purge 
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Program Results Summary 

The Program Results summary on the Advisory window contains the exact same information as 
the Coversheet Results Summary excluding any scroll window information. 

Remarks 

You must fill out the remarks section before sending an Advisory. 

• Respond By – The time by which users must respond to a Proposed GDP. It 
is normally defined as the current time plus 30 minutes. That time is then 
rounded up to the next 15-minute time increment. For example, if the current 
time is 1812, the Respond By time is 1845 (1812 + 30 = 1842. Round up to 
the nearest 15-minute increment is 1845). 

• Valid Until – The time at which the Advisory message expires. This is 
normally defined as the Respond By time plus 30 minutes and rounded up to 
the end of the hour. For example, if the Respond By time is 1845, the 
message is valid until 1959. The message could also expire at the same time 
the program ends. 

• Proposed – One of the two types of advisories available to send. A Proposed 
Advisory lets users know about a potential GDP and allows users to send 
comments about the parameters before the program is enacted. 

• Actual – One of the two types of advisories available to send. An Actual 
Advisory lets users know that a program has been issued and does not allow 
users to comment on the parameters. 

• Reason – Select a reason for running the GDP from the available pull down 
menu. Select Weather, Volume, Runway, Equipment, or Other. 

• Explanation – If you select “Other” in the Reason field, you must type a 
reason or other commentary in the Explain field before you can send an 
Advisory. 

• Probability of Extension – Likelihood a Ground Stop will be extended past 
its current end time (Ground Stop Advisory only) 

• Comments – This field is available for any additional comments about the 
program you feel are necessary. 

Advisory Buttons 

• Send – Emails the program parameters to all parties involved, including the 
Hub site. If the parameters are for a Proposed Advisory, the Hub site sends 
out the parameters immediately in the next ADL. When you send parameters 
for an Actual Advisory, the Hub site ensures that it has received the 
associated FADT file with flight control times for the program before 
sending any parameters through the ADL. 

• Close – Click this and FSM takes no action from the GDP Advisory 
window. 
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Advisory examples 
This section provides examples of Advisories. 

 

 
Figure 3-57: GDP Advisory 

 
Figure 3-58: GS Advisory 
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Note:  Blanket, Compression, and Purge Advisories contain similar information 
as the examples illustrated above.  
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4 Opening FSM 
The Control Panel component, shown below, is the first component displayed when you start the 
FSM application. You can open FSM in three different data modes: 

1. Monitored Live –Monitor airports in real-time. 
2. Historical – View, recall or analyze previous airport air traffic events. 
3. GDT- Model, analyze, and/or create Traffic Management Initiatives (TMIs) for 

airports depending on air traffic variables. 

 
Figure 4-1: Main Control Panel Component 

Opening an Airport 
Click Open Data Set on the Control Panel component to open the Open Data Set Component. 
The Open Data Set component displays four data Tabs that you use to access both live and 
historical data. The four Tabs available in the Open Data Set components are listed below and 
shown in Figure 4-2: 

1. Monitored Live – Provides a list of airports currently monitored by the FSM server 
and readily available for viewing by the user. Live data mode runs real-time data and 
receives ADL updates approximately every 5 minutes. 

2. Historical – Displays historical data that has been stored in a database. Historical data 
can be recalled to analyze scenarios or replay a day's air traffic events. 

3. All Live – Provides a list of airports that can be viewed by the user (not on the server 
but will only take a minute to bring up). 
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4. Active Historical – Provides a list of historical airport data currently opened and 
monitored by the user. 

 
Figure 4-2: Open Data Set Component 

To open an airport you must select a Data mode, a Data set, and choose the display components 
to view the information. 

• Data Mode – From the Open Data Set component you can open an airport in 
either Live or Historical Data Modes. To open an airport in Live Data Mode, 
use either the Monitored Live or All Live data tabs. To open an airport in 
Historical Data Mode, use either the Historical or Active Historical (if you 
have already opened an airport in historical mode) data tabs. You can access 
GDT mode by clicking GDT Setup on the Control Panel. 

• Data Set – The Data Set is the airport you want to view. When opening an 
airport in Historical data mode, you must select a date from the Historical 
tab’s menu structure and enter a time (optional). 

• Display Components – From the Open With selection box you can open data 
sets in three components: Time Line, Flight List, and Bar Graph 
components. By default, both Time Line and Bar Graph components are 
selected. 

Opening FSM in Monitored Live Mode 
From the Open Data Set component, you can open FSM in Monitored Live mode. The Monitored 
Live tab is active when the Open Data Set component initially opens and provides a list of 
airports currently monitored by the FSM server readily available for viewing. 
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To open an airport in Monitored Live mode 
1. Click Open Data Set. 
2. Select the desired data set (airport) from the Monitored Live tab. 

3. Select the components you want to view for the data set in the Open With panel. 
4. Click Apply or OK to display the data set in the components that you selected in the 

Open With box. By default, FSM displays both Time Line and Bar Graph 
components if you do not change anything in the Open With component selections. 

Figure 4-3 shows ATL airport selected with the Time Line and Bar Graph 
components checkmarked in the Open With selection box. This opens the Time Line 
and Bar Graph components for ATL in Live data mode. 

 
Figure 4-3: Monitored Live Tab 

Note: If an airport currently has a GDP or GS in place, the Open Data Set 
component displays “GDP ACTUAL” or “GS Actual” followed by the 
date and times of the TMI next to the airport. 

Note: Double-clicking an airport or selecting the airport and then clicking Apply 
leaves the Open Data Set component open. Selecting the airport and then clicking 
OK opens the airport in the selected components but closes the Open Data Set 
window. 
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Figure 4-4 shows FSM opened in Monitored Live mode for ATL. 

 
Figure 4-4: ATL Monitored Live Mode 

Using the US Map to Open Components in Monitored Live 
Click US Map on the Control Panel component to view all the airports currently being monitored 
on the US Map. 

 
Figure 4-5: US Map Button 
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Figure 4-6 shows green airports that indicate normal operations, while red airports indicate that 
there is an actual TMI. Yellow airports indicate there is a proposed TMI. 

 
Figure 4-6: US Map Component 

To open a data set from the US Map component 
1. Click on the airport you want to open. 
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The selected airport turns white and displays the three-letter airport ID followed by 
the current ADL time (ddhhmm) for that airport. 

 
Figure 4-7: Selected Airport turns White 

2. Right-click the selected airport to display a pop-up menu. 
3. Select the desired component with which you want to view the airport: Time Line, 

Bar Graph, or Flight List component (see Figure 4-8). You can open only one 
component at a time from the US Map. 

 
Figure 4-8: Opening Components from the US Map 

Note: If you select an airport with actual or proposed parameters in place, 
the airport’s parameters appear (see Figure 4-7). 

Note:  From the US Map component you can open Monitored Live mode 
only. 
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Opening FSM in Historical Mode 
The Historical tab on the Open Data Set component opens archived data that you can use to 
review and analyze past airport events. The Open Data Set component defaults to the Monitored 
Live tab when you first open it. Click on the Historical tab to view archived data. You can drill 
down to the desired data set by clicking on the drill down icons or by double-clicking the file 
name. 

Historical file structure is organized as follows:  Server, Year, Month, Day and Airport. 

 
Figure 4-9: Historical Tab 

The default settings for Historical mode are the same as in Monitored Live mode-Time Line and 
Bar Graph components appear selected by default for the selected Data set. The Flight List 
component does not open unless you select the corresponding checkbox in the Open With 
selection box. Once you select the desired data set, you have the option to set the data set time 
before opening the data set. When you specify a data time, the components open the ADL data 
time closest to, but not after, the specified time. 

You can open the data set in several ways after you select the desired airport, components, and 
data time. Double-clicking on a desired airport or clicking Apply opens the Historical mode data 
and leaves the Open Data Set component open. Clicking OK also opens the Historical mode data 
in FSM, but closes the Open Data Set component. 

Begin Monitoring an Airport 
The All Live tab on the Open Data Set component provides a list of airports that the server is not 
currently monitoring but are readily available for viewing (see Figure 4-10). 

Note: If the client connects to multiple servers, both servers are listed. 

Note:  FSM displays in and uses Zulu times unless otherwise specified. 
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Figure 4-10: All Live Tab 

To begin monitoring an airport from the All Live tab 
1. Click Open Data Set. 
2. Select the All Live tab. 
3. Select the airport. 
4. Select the components you want to view for the airport in the Open With panel. 
5. Click Apply or OK to open the airport. 

 
Figure 4-11: FSM information message 

6. Click OK to close the FSM information message. After opening an airport from the 
All Live tab, FSM places the airport on the Monitored Live tab. 

Note: The All Live tab opens airports in Live mode only. Opening an 
airport from the All Live tab may take a few moments longer than opening 
an airport from the Monitored Live tab and an FSM information message 
may appear to indicate the airport takes a moment to collect the first set of 
data (see Figure 4-11). 
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Managing Historical Data 
The Active Historical tab on the Open Data Set component provides a list of opened Historical 
data you are viewing and monitoring. The Active Historical tab has an empty display window 
unless you have already opened a data set from the Historical tab. 

 
Figure 4-12: Active Historical Tab 

To open the historical data 
1. Click Open Data Set. 
2. Select the Active Historical tab. 
3. Select the desired data set. 
4. Click Apply. This opens the airport with the components selected in the Open With 

selection box. The Active Historical tab opens airports in Historical mode that you 
have already opened. 
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Opening FSM in GDT Mode 
When you open GDT mode below, four GDT components open by default (see Figure 4-13): 
GDT Setup, GDT Map, GDT Data Graph, and GDT Bar Graph. You can open additional 
components, such as Flight List, Data Table, and Time Line components, from the GDT Setup 
component in GDT mode. See Chapter 3, Ground Delay Tools Component for more detail. 

 
Figure 4-13: GDT Mode 

To open an airport in GDT mode 

Open FSM in Ground Delay Tools (GDT) Mode to analyze air traffic management options and 
implement TMIs. 

1. Select an airport that is open in either Live or Historical mode. 
2. Click GDT Setup on the Control Panel component. 

 
Figure 4-14: GDT Setup Button 

The GDT Setup panel, GDT Data Graph, GDT Map and GDT Bar Graph for the 
airport appear as shown in Figure 4-13. 
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5 Viewing Airport Demand 
You already know that FSM displays flight information in several ways. But to make traffic 
management decisions, you must also be able to view the overall demand on the airport. Airport 
demand is made up of the total flights using the airport for arrival and departure. The main 
utilities to view total airport demand are the FSM Bar Graph components and Count List Reports 
from the Control Panel component. The FSM Bar Graphs constantly display airport demand 
information as FSM receives it through ADLs. The Count List Reports are broken down into 
seven different options, depending on your needs. 

Dynamic Graphs 
The Current Demand "stacks" its data according to the coloring tab currently displayed. For 
example, if the tab option opened is Arrival Status, the bars in the graph are colored according to 
the percentage of flights that represent each respective arrival status. If half of the flights for one 
time period have not departed (light green), while the other half are in the air (red), the bar for 
that hour is half red/half green. If every flight for the hour has landed, the bar for that hour is 
black. 

The graph is dynamic and changes according to the information in each ADL update. The graph 
also automatically updates itself when you choose a different color tab option. 

 
Figure 5-1:  Bar Graph displaying Color by Arrival Status Tab 

About the Display 
There are 12 different coloring options to view the demand. The Arrival Status tab is the default 
view when you first open a Bar Graph component. The airport, date, time, and data mode appear 
in the title bar. The airport, date, and last ADL update time also appears just below the color tabs. 
Flight color is a feature in FSM that assists the user in distinguishing between the varying statuses 
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of each displayed flight. The bar graph displays the arrival flow rate by default. This thin, white 
line represents the airport arrival flow independent of the time-bin convention. For more 
information on the Bar Graph component, see Chapter 3, Understanding Components. 

Arrival vs. Departure Bars on the Graph 
The Bar Graph defaults to only arrival data in the Monitored Live mode. When you are viewing 
arrival data in FSM, the bars on the graphs are solid. You can toggle both Arrival and Departure 
data on and off using the Arrival Data and Departure Data options from the Bar Graph View 
menu. To view Departure Data select View > Departure Data checkbox (see Figure 5-2 below). 

 
Figure 5-2: Toggle Arrival and Departure Data on/off 

When you select both the Arrival Data and Departure Data checkboxes from the View menu, the 
Bar Graph displays arrival and departure data simultaneously. When viewing both arrival and 
departure data, you see two bars for each time increment. Bars that represent arrival data are 
solid, while bars that represent departure data are hashed.  
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Selecting View > Stack Departures stacks departure data on top of the arrival data. The Stack 
Departures option creates one bar on the graph for each time increment that represents the sum of 
both the arriving and departing flights. The departing flights are hashed while the arriving flights 
are solid in color, as shown in Figure 5-3 below. 

 
Figure 5-3: Stacked Arrival/Departure Information 

Original vs. Modeled Data Bars on the Graph 
In GDT Mode the Bar Graph always displays both solid and hashed bars. Solid bars represent the 
original data, while hashed bars represent modeled data. 

Show Cancelled Flights 
Cancelled flights do not appear by default in the Graph. To view cancelled flights in the Bar 
Graph, select the View > Show Cancellations checkbox. Cancelled flights appear in cyan at the 
top of each hour bar. Showing cancelled flights is useful to compare the original airport demand 
with the demand after cancellations. To hide cancelled flights, uncheck the View > Show 
Cancellations checkbox. 

Show Unassigned Slots 
Unassigned Slots do not appear by default in the Graph. To view unassigned slots during a GAAP 
GDP in the Bar Graph, select the View > Show Unassigned Slots checkbox. Unassigned Slots 
appear in white at the top of each hour bar. Unassigned Slots can only be viewed from the Arrival 
Status tab. To hide unassigned slots, uncheck the View > Show Unassigned Slots checkbox. 
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Show Legend 
The Bar Graph Legend indicates the color key according to each respective flight status for each 
color tab. To view/hide the legend, select View > Show Legend checkbox. 

Changing the Time Increments Display 
When the Bar Graph component opens, the default time increment to display capacity and 
demand information is 60-minutes. To view this information in 15-minute or 30-minute time 
increments, click the associated button from the Bar Graph (see Figure 5-4 below). 

When you change the time increment on the Bar Graph, the demand numbers listed on the Y-axis 
of the graph change accordingly. For example, if the AAR of 32 displays for 60-minute time 
increments, a 30-minute time increment for the same information displays an AAR of 16. 

 
Figure 5-4: 15-Minute increment display 

Tracking Time 
Like the FSM Time Line, the Bar Graph component also tracks time. The Time Indicator is an 
orange vertical line that remains fixed at the current time. To show/hide the time indicator click 
the View > Time Indicator checkbox. 

By default, the Bar Graph updates with each hour. Keeping the Bar Graph > Track Time 
checkbox checked moves the bar at the turn of each hour. When you do not check the box, the 
bars do not move, but the orange Time Indicator still displays the current time on the graph. 

Track GDP/GS Hours 
You can view the hours of a GDP or GS in effect at the airport you are monitoring by using the 
Bar Graph. The Bar Graph has optional program indicators that work like the Time Indicator to 
show the start and end times of a current GDP or Ground Stop. The GDP Time indicators are 
colored brown and the GS Time indicators are colored yellow. The program time indicators 
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appear automatically when a program goes into effect at the monitored airport. To view or 
remove the program indicators, select View > GDP Indicators or > GS Indicators. 

Arrival/Departure Flow Rate 
The flow rates operate independently of the time-bin convention, enabling users to visualize 
arrival and departure demand as dynamic flow rates.  A gray line represents the Arrival Flow 
Rate and a cyan line represents the Departure Flow Rate. To view or remove the arrival or 
departure flow rate from the Bar Graph toggle the View > Arrival Flow Rate or View > 
Departure Flow Rate checkboxes.   The Arrival Flow Rate is displayed by default. 

Show More/Less Hours 
The FSM default displays 10 hours of data in the Bar Graph. You can specify the number of 
hours displayed in the bar graph to view more or less flight data. For example, you may want to 
view the demand in 15-minute time increments, which is difficult to see on a graph with 10 hours 
worth of data. To change the number of hours in the Bar Graph, select View > Hours Shown > X 
(where X = number of hours). The graph automatically updates itself to show the amount of hours 
you specify. Use the scroll bars at the bottom of the component to view more hours. 

View the AAR and ADR 
The white horizontal line that runs through the graph represents the Airport Arrival Rate (AAR) 
for the monitored airport. The ADL AAR, which appears by default, is a fixed AAR sent by the 
FAA Air Traffic Control System Command Center (ATCSCC) to advise of the number of 
arriving aircraft an airport can accommodate at any given interval of time. The AAR changes 
according to the interval of time displayed. For example, an AAR of 60 per hour is equal to an 
AAR of 15 per quarter hour. To toggle the ADL AAR Line on/off select the View > ADL AAR 
Line checkbox from the Bar Graph menu. 

A cyan horizontal line runs through the Bar Graph representing the Airport Departure Rate 
(ADR) for the monitored airport. The ADL ADR is a fixed value sent by the FAA ATCSCC to 
specify the number of departing aircraft an airport can accommodate at any given interval of time. 
FSM does not display the ADL ADR by default. To view the ADL ADR Line, select the View > 
ADL ADR Line checkbox. The ADR also changes according to the time increment used in the 
graph display. For example, an ADR of 60 per hour is equal to an ADR of 15 per quarter hour. 

Note: Departure information is not available in GDT Mode; therefore ADR 
options are removed from the GDT Bar Graph. 

Changing the AAR/ADR 
Only ATCSCC users can change the actual ADL AAR or ADL ADR (the rate used in Volpe 
ADLs which reflects real operational data). For ATCSCC users, see Chapter 3: Control Panel 
component for details on how to modify AAR/ADR rates. Other users can model the effects of 
various AARs and ADRs by using the Model function. 

Before modeling the AAR or ADR, ensure that you select the View > Model AAR Line or 
View>Model ADR Line checkbox, otherwise your modeled rates are hidden from view. If the 
ADL AAR/ADR appears on the Bar Graph, the dashed line (for modeling) appears in the same 
position as the ADL AAR. 

There are two methods to change your modeled AAR/ADR: 

1. Use your cursor to drag the dashed line in the graph to the desired rate. The dashed 
line moves to the AAR/ADR you specified. Only the portion of the line to the right of 
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the cursor moves. Any portion of the line to the left of your cursor should remain in 
the same position as you drag the line to a new AAR. Moving the AAR/ADR from 
the graph also automatically fills in the Specify AAR/ADR window. 

2. Select Bar Graph > Model Arrival Rates > Specify or Bar Graph >Model 
Departure Rates > Specify. The Specify Model AAR window appears with the 
modified AAR/ADR filled in, and the new rates appear on the Bar Graph.  

 
Figure 5-5: Specify Model AAR Window 

To restore the Model AAR/ADR rates to their original values, select Bar Graph > Model 
Arrival Rates > Reset or Bar Graph > Model Departure Rates > Reset. You can also click 
ADL AAR from the Specify Model AAR/ADR window to reset the rates to the current ADL 
value. The Model line should disappear behind the ADL AAR/ADR rates. 
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Demand Counts 
Count Lists give you the option to check the flights that make up arrival and/or departure demand 
for each hour. You can open all Count Lists from the FSM Control Panel component. There are 7 
count list reports:  

• By Demand 

• By Center 

• By Aircraft Type 

• By Aircraft Class 

• By Arrival Fix 

• By Departure Fix 

• By User 

To view a demand count for a particular monitored airport, first select the airport to view the 
demand count that you want to view, and then select Reports > Counts > By report type. If you 
have not selected an airport, FSM displays an error message that indicates “No Current Data Set” 
is selected (see Figure 5-6). For more information on Count List reports see Chapter 19: Reports. 

 
Figure 5-6: Count List By Demand 

 

 

 

 

 

 

 

 

 

 

Note: Count Lists in GDT Mode only show counts for arriving flights. 
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6 Viewing Flight Information 
FSM allows you to monitor flights arriving at and departing from an airport. You can view 
general traffic flow into an airport using several different components. The most obvious sources 
to view general traffic flow are the FSM Time Line and Bar Graph components. In addition to 
viewing the overall traffic flow of an airport, you can access individual flight information using 
FSM. This chapter takes a look at the various ways that FSM allows you to view general traffic 
flow and flight information when making traffic management and operational decisions. 

The FSM Time Line and Bar Graph components open by default to the Arrival Status tab for the 
monitored airport that you open. The Arrival Status tab shows flights colored by arrival status. To 
view departure information, select the Arrival/Departure Status tab in Time Line and Bar Graph 
components. FSM displays arrival and departure information depending on whether you select 
the Arrival and/or Departure Data checkboxes from the View menu. 

Roll-Over Events 
The roll-over feature is active in the Monitored Live mode Time Line and Bar Graph 
components, and the GDT mode Data Graph component. Where available, rolling your cursor 
over various features, gives you additional pop-up information. 

1. Time Line –Rollig your cursor over a flight icon, causes a pop-up window to display the 
flight’s ACID, ORIG, DEST, ETD, and ETA (see Figure 6-1). 

 
Figure 6-1: Rollover Flight Icons in the Time Line Component 
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2. Bar Graph – To view a flight count for any hour, roll your cursor over any bar within the 
Bar Graph and the respective number of flights appears for the status color your cursor is 
over (see Figure 6-2). When you bring the cursor to the top of each column, the total 
number of flights for that column or hour appears in the Bar Graph. If you roll the cursor 
near the top of a bar, the total number of flights for that hour appears. You can use the 
same method to find the set Airport Arrival Rate (AAR). Roll the cursor over the AAR 
and the rate appears. 

 
Figure 6-2: Bar Graph Count Rollover 
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3. GDT Data Graph –Rolling your cursor over any line in the Data Graph shows you the 
delay statistic count for the colored line. This line reflects the selected criteria of the 
scenario being monitored or modeled. Figure 6-3 illustrates the 2nd tier option selected 
with all the corresponding delay statistics in the legend. The roll-over shows a maximum 
delay of 246 minutes if you select a 1st Tier program. 

 
Figure 6-3: Data Graph Delay Statistic Rollover 

 

Right-Click Capabilities 
The right-click feature is active in Time Line, US Map, GDT Data Graph, and GDT Setup 
components. 

1. Time Line – Right-clicking on a flight icon in the Time Line shows you five additional 
options for that flight: Flight info, Flight detail, EDCT Check, EDCT Update, and 
ECR. 

 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Viewing Flight Information 

Version 7.8 6-4 

Figure 6-4: Time Line Right-Click Feature 

• Selecting Flight info displays the Flight Info panel (see Figure 6-5), which 
contains some general ADL information for a flight, including ADID, status, 
origin airport, destination airport, ETD, ETE, ETA, CTD, CTA, Delay Flag, 
and Cancel Flag when applicable. Double-clicking on a flight icon in the 
Time Line also opens the flight’s Flight Info window. 

 
Figure 6-5: Flight Info Window 
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• Selecting Flight detail displays the Flight Detail window as shown in Figure 
6-6. The Flight Detail window contains all the ADL information for that 
flight.  

 
Figure 6-6: Flight Detail Window 
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• Selecting EDCT Check or EDCT Update displays the EDCT Check or 
EDCT Update windows. These EDCT widows allow you to check a flight’s 
EDCT or Update a flight’s EDCT. 

   
Figure 6-7EDCT Check and Update Windows 

Note: The EDCT Check and EDCT Update options are available only for 
specialists at the ATCSCC. 

• Selecting ECR displays the EDCT Change Request (ECR) component. If the 
selected flight from the time is a controlled flight, the flight information 
automatically fills in the ECR window. Refer to Chapter 13 for more 
information. 
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2. US Map – Right-clicking anywhere within the US Map component gives you two 
options: Default Zoom or Undo Zoom.  

• Default Zoom takes you back to the initial or default zoom setting for the 
Map. Undo Zoom, undoes the last zoom command. The GDT Map right-
click functionality is the same as the US Map. 

 
Figure 6-8: GDT Map Right-click zoom pop-up menu 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Viewing Flight Information 

Version 7.8 6-8 

• In addition, after you select an airport on the US Map, you can right-click on 
the selected airport to view more options to open the airport in other 
components. You have the option of showing flights in the Time Line, Bar 
Graph, or Flight List components (see Figure 6-9). You can open only one 
component at a time from the US Map component. 

 
Figure 6-9: US Map Right-Click selected airport 

FSM Flight Coloring 
Display information by Flight color is a feature in FSM that assists the user in distinguishing 
between the varying statuses of multiple flights. Flight color options appear as tabs on the Time 
Line and Bar Graph components in all data modes. The following 12 coloring options are 
available in FSM: 

1. Arrival Status 
2. Arrival/Departure 
3. Centers 
4. Aircraft Category 
5. Aircraft Class 
6. Carrier 
7. Arrival Fix 
8. Departure Fix 
9. Exemption Status 
10. User 
11. Alarm Status 
12. Distance 

The following sections provide a brief description of the 12 coloring options. The coloring 
schemes are documented based on FSM’s default settings. You can configure all coloring 
schemes. Within the components you can select View > Show Legend at any time to display the 
color legend associated with the active color tab (see Figure 6-10). 

You can view cancelled flights by selecting View > Show Cancellations. Cancelled flights are 
colored Cyan. The examples below show the Bar Graph component, but the Time Line 
component works in the same manner. 
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Figure 6-10: Bar Graph with Legend 
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Color By Arrival Status 
The Arrival Status tab colors flights in the Time Line and Bar Graph according to their arrival 
status at their destination airport. To remove a color associated with a flight status in the Time 
Line or Bar Graph uncheck that status color checkbox in the component legend. The status data 
remains grayed-out until you select the checkbox again to restore the status color back to the 
graph (see Figure 6-11). 

 
Figure 6-11: Bar Graph with departing flights not displayed 

Table 6-1 displays FSM default coloring for Arrival Status. 

Table 6-1: Arrival Status Tab Coloring 

Flight Status Definition Default Color  

Departing (No CTD) Flights waiting to take off without delay. No Estimated 
Departure Clearance Time issued. Light Green 

Departing (CTD Issued) Waiting to take off without delay. Estimated Departure 
Clearance Time issued. Brown 

Departing (Past EDT) Flights which have passed their Estimated Departure 
Time and remain on the ground. Dark Green 

Arrived Flights have arrived at their destination airport. Black 

Flight Active Flights currently en route to their destination airport Red 

Cancelled Flights that do not fly because they are cancelled. Cyan 
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Flight Status Definition Default Color  

Ground Stopped The flight is currently in a Ground Stop program. Yellow 

Removed The ATCSCC CSA removed the flights. Blue 

Priority 

Flights designated as Lifeguard (LFG) or Diversion 
Recovery (DVT) flight. This coloring applies only to 
flights that are not active and overrides all other colors 
when selected. 

Pink 

Unassigned Slots Unassigned slots allocated by ETMS during a GAAP 
GDP. White 

Color By Arrival/Departure 
The Arrival/Departure tab allows you to quickly view flights that are arriving at the monitored 
airport versus flights that are departing the monitored airport. Arriving flights are colored Light 
Green while departing flights are Blue. 
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Color By Centers 
The Centers tab allows you to quickly locate flights that departed from one or several centers. By 
default, FSM shows all centers. To color flights departing from a specific group of centers, you 
can either select a tier level from the legend’s dropdown menu or you can select a center or group 
of centers. When you select one of the options from the dropdown menu, the centers not 
associated with that particular group are disabled, leaving only the selected centers colored in red. 
You can also enter a center in the Manual text box if it is not already a center choice. Selecting 
the All option in the dropdown menu restores all centers back to the graph. The figure below in 
an example of 1st Tier centers plus SFO selected for ATL. 

 
Figure 6-12: Bar Graph Colored by Centers 

Color By Aircraft Category 
The Aircraft Category tab colors flights according to their equipment classification.  

 displays FSM default coloring for Aircraft Category. 

Table 6-2: Aircraft Category Coloring 

Equipment Type Default Color 

Propeller Black  

Turbo Green 

Jet Red 

Unknown Yellow 
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Note: FSM colors flights based on their equipment types. FSM does not classify 
equipment types. 

Color By Aircraft Class 
The Aircraft Class tab colors flights according to their standardized weight class, determined by 
the FAA. Table 6-3shows FSM default coloring for Aircraft Class. 

Table 6-3: Aircraft Class Coloring 

Equipment Type Color 

Small Black 

Large Green 

Heavy Red 

Unknown Yellow 
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Color By Carrier 
The Carrier tab colors flights by airline carrier. In the Carrier tab, select View > Show Legend to 
show the color assigned to each carrier. 

 
Figure 6-13: Bar Graph Color by Carrier 

Uncheck the carrier checkbox in the color legend if you do not want to view a particular carrier in 
the component. The carrier data remains grayed-out until you select the checkbox again to restore 
the carrier color back to the component. 

Typing a single airline identifier into the Single Airline textbox lets you view the flights of a 
major carrier without viewing its sub-carrier flights. Selecting All selects and colors all listed 
carriers. The Carrier tab shows a maximum of 12 carriers. Table 6-4 explains FSM default 
coloring by Carrier. 

Table 6-4: Carrier Coloring 

Flight Carrier Default Color  

COA Magenta 

USA Yellow 

NWA Brown 

AWE Dark Green 

AAL Blue 

MEP Dark Pink 
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UAL Red 

DAL Light Green 

TWA Cyan 

SWA Orange 

Single Airline White 

Other Black 

If you are an airline user, when you select the Carrier tab, the FSM default color is for the flights 
of your carrier. Your carrier abbreviation appears in the Single Airline text box so that you 
immediately view your carrier's flights. For major carriers, the box next to the carrier name is 
selected and the carrier abbreviation appears in the Single Airline box. This allows you to 
differentiate between the major and any of your sub carriers. Because of flight filtering, non-FAA 
operators cannot view any other carriers' flights other than those belonging to their own major or 
sub-carriers. All other flights are colored black. 

If you are an FAA user, the FSM default is to have no carriers selected for coloring. You select 
which carriers to color by putting a checkmark next to the carrier abbreviation or entering a 
carrier code in the Single Airline text box in the Carrier legend. When you select a major carrier 
to color, the major carrier and its sub-carriers are all the color of its Major. 

Color by Arrival Fix 
The Arrival Fix (AFIX) tab colors flights according to which arrival fix the flight is approaching 
for the arrival airport. Arrival Fix names vary for each airport. FSM automatically generates the 
monitored airport's arrival fix names and assigns a color to each fix in the legend. For those 
flights with an unknown arrival fix, FSM assigns that fix a value of "Other."  

Note: All flights departing the monitored airport are colored as "Other" because 
their arrival fix is at another airport. 

Color by Departure Fix 
The Departure Fix (DFIX) tab colors flights according to which departure fix the flight has 
departed over at its origin airport. Departure fix names vary for each airport. FSM automatically 
generates the monitored airport's top departure fix names and assigns a color to each fix in the 
legend. For those flights with a departure fix that is other than the top departure fix names listed 
or that is unknown, FSM assigns that flight a value of "Other." 

Color by Exemption Status 
The Exemption tab colors flights according to their status in any GDT operation. By default, 
flights are Non Exempt, meaning that the flight is subject to any GDT operation. However, in 
running a GDT operation, you may decide to exclude certain flights from the operation. This 
changes the Non Exempt status on some flights to either excluded or exempted. The ADL 
contains the exemption status for all flights. Table 6-5 shows FSM default coloring for 
Exemption Status. 

Table 6-5: Exemption Status Coloring 

Exemption Status Default Color 
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Flts Excluded  Black 

Flts Not Exempted Green 

Flts Exempted Red 

Color By User 
The User tab colors flights according to their user status. User status describes the primary 
function of that flight. This information is sometimes masked from airline users because of flight 
filtering. For example, military flights are not listed as such. Table 6-6 shows FSM default 
coloring for User status. 

Table 6-6: User Coloring 

User Status Color 

Air Cargo (F) Blue 

Carrier (C) Magenta 

General Aviation (G/A) Green 

Military (M) Brown 

Air Taxi (T) Orange 

Other (O) Cyan 

Unknown (U) Red 

Color By Alarm Status 
The Alarm Status tab colors all flights red that have at least one non-compliant alarm triggered. 
You can also view these flights by selecting individual compliance reports from the Reports > 
Compliance menu from the Control Panel. Compliant flights are colored black. 
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Color By Distance 
The Distance tab colors all flights within a certain distance of the airport. The Distance tab 
displays all flight distances in red and allows you to view/select distance ranges of up to 2,400 
miles in 200-mile increments. 

 
Figure 6-14: Bar Graph by Distance 
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Viewing Information in the Time Line Component 
From the Time Line, you can view flights arriving at and departing from the monitored airport, as 
well as open arrival slots, unassigned slots, and cancellations. The selected tab in the Time Line 
indicates the type of data displayed. The tab coloring options are the same as described above in 
Flight Coloring options. Directly above the tab options, the Time Line lists the airport being 
monitored, as well as the date and ADL time as shown in Figure 6-15. For more information on 
the Time Line component, see Chapter 3, Understanding Components. 

 
Figure 6-15: Time Line Component with Color Legend Displayed 

 The AAR and/or ADR versus the demand on the airport (the number of flights projected to 
arrive) for that hour appears directly below the date/hour information. The Airport Departure Rate 
versus demand appears in parentheses when you select View > Departure Data. For example, if 
the Time Line displayed (90/85), this would indicate that 90 is the Airport Departure Rate and 85 
flights are projected to depart for that hour. 
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Each flight arriving at the monitored airport appears beside the minute hash mark, which 
corresponds to the ETA of the flight. Cancelled flights appear under the CNX column. You can 
show or hide icons for cancelled flights by selecting View > Show Cancellations from the Time 
Line component. FSM keeps and displays flight data compiled by Volpe National Transportation 
Systems Center, which includes data for up to 24 hours after the current time. 

View Open Arrival Slots 
To view open arrival slots that resulted from delayed or cancelled flights, select the View > Open 
Slots in Carrier Color checkbox from the Time Line. Slots appear on the Time Line as square 
(cancelled) or triangle (delayed) icons. Note that airline users see only their own slots in the color 
that FSM designates for their airline. Any slot left open from another carrier's cancelled or 
delayed flight is colored black. 

Time Line Flight Count 
If you need to determine a flight count for a particular time span, you can use the Time Line to 
retrieve the information quickly. 

1. Select the hour number for the beginning time. 
2. Press and hold Ctrl as you select the last hour number for the time span. This counts all 

flights in the selected area that are colored according to a "Color By" criterion. 

A message box appears. 

 
Figure 6-16: Flight Count List 

Note: You must select at least two minutes worth of flight data. 
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When you select a group of flights to count on the Time Line, FSM returns information 
about the count. This information includes the total number of flights, how many flights 
are arrivals and how many are departures, the time period and the equivalent AAR and/or 
ADR. FSM derives the AAR and ADR values using: AAR = (#flts/#minutes) x 60. 

3. Click OK to close the message box. 

Time Line Flight List 
If you need to determine a flight list for a particular time span, you can use the Time Line to 
retrieve the list quickly. 

1. Select the first flight icon. 
2. Press Shift as you select the last flight icon. This creates a flight list in the selected area 

that is colored according to a "Color By" criterion(see Figure 6-17). 

The Flight List window appears. 

Note: You must select at least two minutes worth of flight data. 
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Figure 6-17: Flight List 

3. Select File>Close from the Flight List window to close the flight list. 

GDT Time Line Display Options 
The GDT Time Line gives you the option to display flights according to different flight data. 
When you choose different criteria to use in the FSM Flight display, your changes affect both the 
FSM Time Line and Bar Graph components. For a description of each menu option on the Time 
Line Display menu, see Chapter 3, Understanding Components. 
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To Change the GDT Time Line Flight Display 

To change the display in the GDT Time Line, use the Display menu options. For a description of 
each menu item, see Chapter 3, Understanding Components. For example, you want to see all 
flights by their Controlled Time of Arrival (CTA) and colored by Exemption Status. 

1. Select Display>CTA in the GDT Time Line component. 
2. The Time Line displays flights by their CTA. 

 
Figure 6-18: GDT Time Line Display by CTA 

3. Select the Exemption Status tab. 

The Exemption Status tab shows all flights colored by Exemption Status and by their 
CTA. 

4. Select Display>ETA to return the flight display to its default appearance. 
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Flight Lists 
FSM generates Flight Lists automatically when it performs certain functions. You can generate 
one for a specific group of flights that you select. Flight Lists allow you to view what flights 
contribute to the arrival demand at an airport and how many flights fall into specific categories. 
You can open an FSM Flight List in a variety of ways from all FSM modes and several FSM 
components. You can obtain Flight Lists from the Bar Graph, Time Line, Status Map, Open Data 
Set, Query Manager, and GDT Setup components. 

The way FSM generates a Flight List differs depending upon the type of information you need. 

Note: Report Flight Lists vary in the initial default information displayed, but the 
functionality described below is the same. For more information on Report Lists, 
see Chapter 19. 

When you want to see only flights that meet certain criteria, you can generate a Flight List from 
the Query Manager component. From a Flight List, you can also select a single flight and view 
the Flight Info or Flight Details for that flight by right-clicking on the selected flight, or by 
highlighting the flight and using the View menu options. All Flight Lists are dynamic and are 
updated along with every ADL update. 

 
Figure 6-19: Flight List 

Flight List Menu 
The menu bar in the Flight List component contains four menu options: File, View, Flight List, 
and Help. 

1. File Menu 

• File > Save as - Saves the Flight List to a text file, which can be opened later 
and used again. 
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• File > Print – Prints the Flight List information viewed on the monitor 
screen. 

• File > Close - Closes the Flight List component. 
• File > Close Group – Closes the all the data set components associated with 

the Flight List component. 
2. View Menu 

• View > Rename window – Displays the Rename Window dialog box and 
allows you to change the title bar name. 

• View > Add/Remove Columns – Allows you to add or delete ADL data 
fields as columns to the Flight List. 

• View > Group Flights – Allows you to group ADL data fields to the Flight 
List in ascending or descending order. 

• View > Sort Flights – Allows you to sort ADL data fields to the Flight List 
in ascending or descending order. 

• View > Apply Filter – Allows you to apply a filter to the data fields in the 
Flight List component. 

• View > Clear Filter – Allows you to clear a filter from the data fields in the 
Flight List component. 

• View > Flight Info - Opens the Flight Info window. 
• View > Flight Detail - Opens the Flight Detail window. 

3. Flight List Menu 

• Flight List > Freeze Data – When checked, prevents the Flight List from 
updating when new ADLs arrive. 

• Flight List > Set Time – Sets the time for the Flight List component in 
Historical mode only. 

• Flight List > Search By Callsign – Opens the Search by Callsign 
component. 

4. Help Menu 

• Help > Flight List – Accesses the web-based on-line help for Flight Lists. 

Opening Flight Lists 
You can open flight lists from multiple components in FSM.  This section explains how to open 
Flight Lists from the: 

• Open Data Set component 
• Bar Graph component 
• Time Line component 
• US Map component 
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To open a Flight List from the Open Data Set component 

You can open Flight Lists directly from the Open Data Set component. For example, you want to 
see the flight list for ORD, as well as the Time Line and Bar Graph components, that FSM is 
currently monitoring. 

1. Click Open Data Set from the Control Panel. 
2. Select the ORD data set in the Monitored Live tab. 
3. Select Flight List in the Open With section of the screen (Time Line and Bar Graph 

appear selected by default). 
4. Click Apply or OK. 

The Time Line, Bar Graph, and current Flight List for ORD appear. 

To open a Flight List from the Bar Graph component 

You can open Flight Lists directly from the Bar Graph component. For example, you want to see 
a flight list for the Arrival Status of all flights, including cancelled flights, between the 1700 and 
1800 hours for BOS. 

1. Click Open Data Set from the Control Panel. 
2. Select the BOS data set in the Monitored Live tab. 

The Time Line and Bar Graph for BOS appear 

3. Select View > Show Cancellations from the Bar Graph to include cancelled flights in the 
flight list. 

4. Ensure the Bar Graph displays in 60 minute increments. If it is not, click 60. 

5. Double-click the bar between 1700 and 1800 to generate the Flight List (For more 
information on Bar Graphs, see Chapter 3). 

To open a Flight List from the Time Line component 
See the Time Line Flight List section above for information on how to open a flight list from the 
Time Line. 

To open a Flight List from the US Map component 
You can open Flight Lists for a monitored airport directly from the US Map component. For 
example, you want to view a flight list for MCI. 

1. Click US Map on the Control Panel. 
2. Select MCI. 

The dot for the airport turns white in color when selected. In addition to turning white, 
the airport’s last ADL time also appears-day then time. 

3. Right-click on the airport to display a pop-up menu, which includes the zoom options as 
well as the options to view the Time Line, Bar Graph, or Flight List components for that 
airport in Monitor Live mode. 

4. Select Open Flight List… to view the Flight List for MCI. 

The Flight List appears. 

5. Select File>Close to close the Flight List window. 

Note: If the Bar Graph displays in 15 or 30 minute increments, clicking on 
a bar gives you only the flights for that increment. 
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Flight List Format 
Although there are many ways to generate an FSM Flight List, the lists are always in the same 
format. Flight List characteristics include: 

• Spreadsheet format – you can manage the lists in the same way you manage 
spreadsheets. 

• You can resize the Flight List and scroll through it. 
• The default sort order for Flight List is by ETA. 
• The Component information appears in the Flight List title bar: Three-letter 

airport code and mode in which the data was retrieved. 
• The number of flights contained in the list appears in the bottom left corner 

of the component. 

 
Figure 6-20: Flight List 

Selecting Flight List Information 
There are certain default values for Flight List information categories (the default information is 
configurable). When you first open a Flight List, the default information appears. 

• ACID – The air carrier (AC) and aircraft identification number (ID). This is a 
three letter carrier code followed by the flight’s identification number. For 
example, UAL1234 indicates a United Airlines flight with ID number 1234. 
Airline users see only their own carrier and sub-carriers ACIDs; FSM masks 
all other flights. 

• ETD – The flight’s Estimated Time of Departure 
• ETA – The flight’s Estimated Time of Arrival 
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• DEST – The airport from which the flight is departing 
• ORIG – The airport at which the flight is arriving. 
• ARTA – ARTD – Actual Runway Time of Arrival minus Actual Runway 

Time of Departure. This gives an accurate calculation of the flight’s ETE. 

You can configure the information in the Flight List to suit your needs by using the Add/Remove 
Columns window. The Add/Remove Columns window allows you to add columns by: 

• Field – Allows you to select individual ADL data elements. 
• Group – Allows you to select logical groups of ADL elements. 
• FSM Calculated value – Allows you to select values that are the result of 

operations on times listed in the ADL. 

You can also remove columns using the Add/Remove Columns window with the following 
exceptions: 

• AC 
• ID 

This section explains how to add, remove, and move columns on the flight list. 

To add data column information to a Flight List 

1. Select View > Add/Remove Columns from the Flight List component. 

The Add/Remove Columns window appears showing all possible informational 
categories that you can view in FSM's Flight Lists. The categories correspond to the 
available data fields in the ADL, groups of available data fields, and calculations that you 
can specify. The data elements that currently appear in the Flight List, also appear in the 
Fields Displayed scroll box (see Figure 6-21). 

2. Select any data fields you want to add from the By Field section of the window. 
3. Click the bottom arrow button to move the fields to the Fields Displayed scroll box. 
4. Select any groups of data fields that you want to add from the By Group section of the 

window. 
5. Click the bottom arrow button to move the groups to the Fields Displayed scroll box. 
6. Specify the calculation you would like to add from the By Calculation section of the 

window. 
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Figure 6-21: Add/Remove Columns Window 

7. Click the bottom arrow button to move the calculations to the Fields Displayed scroll 
box. 

8. Click OK. 

To add multiple calculations to a Flight List 

1. Select View > Add/Remove Columns from the Flight List component. 

The Add/Remove Columns window appears. 

2. Select the data fields you want to use for first the calculation. 
3. Click the bottom arrow button to move the category to the Fields Displayed scroll box. 
4. Select the data fields you want to use for the next calculation. 
5. Click the bottom arrow button to move the category to the Fields Displayed scroll box. 
6. Continue adding calculations in this way until all of your calculations appear in the 

Shown Fields section of the window. 
7. Click OK. 

All of the calculations appear in the Flight List window. 

To remove data column information from a Flight List 
1. Select View > Add/Remove Columns from the Flight List component. 

The Add/Remove Columns window appears. The data elements that currently appear in 
the Flight List, are in the Fields Displayed scroll box (see Error! Reference source not 
found.). 

 
Figure 6-22: Add/Remove Columns Window 
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2. To remove a Shown data field, you can double-click the field you want to remove or 
select the field and click the top arrow button to move the data field back to the 
appropriate scroll box. 

3. Click OK. 

To rearrange columns in a Flight List 

You can arrange the order in which your columns appear with two different methods. The easiest 
and most convenient method is to do it directly from the Flight List itself, by dragging and 
dropping the column header to the desired position in the list. The second method, discussed 
below, uses the Add/Remove Columns window. 

1. Select View > Add/Remove Columns from the Flight List component. 

The Add/Remove Columns window appears. 

2. Select the ADL data field (column header) from the Shown scroll box. 
3. Move it up or down the list using the Up or Down buttons located to the right of the 

Fields Displayed scroll box. Moving a data element to the top of the Add/Remove 
Columns window positions the data element header to the left most column on the Flight 
List. 

4. Once you move the data fields to the positions you want, click OK. 

Grouping Information in the Flight List 
Once you create a Flight List, you can group the information according to your own needs. To 
group a flight list select View > Group Flights on the Flight List component. The Group window 
enables either individual or multi-level grouping of all data fields that currently appear in the 
Flight List. 

 
Figure 6-23: Flight List Grouping Window 

The Group window has the following buttons: 

• Help – Displays information about the component version currently running 
in the Group window. 

• Apply – Keeps the Group window open after FSM updates the flight list. 
• OK – Closes the Group window after FSM updates the flight list. 
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• Cancel – Cancels any selections made, closes the Group window, and 
restores the default selections. 

Figure 6-24 below, shows the flights grouped by ETA, then Carrier, then Origin Airport. The 
Flight list appears in a split screen and FSM puts grouped flights into folders that you can expand 
for more detail. This grouped flight list corresponds with the Group window parameters shown in 
Figure 6-23. 

 
Figure 6-24: Flight List Grouped 

To group flights by one data field 
1. Select a data field in the Group By dropdown. 
2. Select either Ascending or Descending. 
3. Click OK or Apply in the Group window and the Flight List groups flights according to 

the parameters you set. 

To group flights by multiple data fields 
You can also group according to multiple categories in the Flight List. For example, you want to 
group your filtered Flight List by the Initial Gate Time of Arrival (IGTA), Airline, and Origin 
Airport (OrigAp) respectively. 

1. Select the IGTA data field in the Group By dropdown. 

2. Select Ascending. 
3. Select the AC data field in the Then By dropdown. 
4. Select Ascending. 

Note: You can specify time increments of 15, 30, and 60 minutes for data 
fields that are time based by selecting the corresponding radio buttons. 
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5. Select ORIG data field in the Then By dropdown. 
6. Select Ascending. 
7. After you select all the grouping parameters, click Apply or OK to generate the grouped 

Flight List. 
8. You can expand a group by double-clicking on the group or clicking on the 

expand/collapse icon. Drilling down shows individual flights within each group set. The 
grouping parameters appear above the grouped flights section. 

To remove grouping from a Flight List 

You can easily return to the normal Flight List display. 

1. Select View > Group Flights to access the Group Window.  
2. Select None in the Group By field. 
3. Click OK. 

Sorting Information in the Flight List 
Once you create a Flight List, you can sort the information and arrange it according to your own 
needs. You can sort the list one column category at a time by double-clicking the column 
heading. The arrow at the top of the column indicates that ascending or descending order for that 
category sorts the Flight List column. 
To sort by multiple categories select View > Sort Flights from the Flight List component. The 
Sort window shows the data fields that are currently listed in the Flight List. The data fields 
correspond to the available data fields in the ADL.  You can also sort multiple categories by 
pressing Ctrl on your keyboard and then selecting up to three categories. The arrow at the top of 
the column indicates that ascending or descending order for that category and the size of the 
arrow indicates was level the sort is.   sorts the Flight List column. 

 
Figure 6-25: Sort Window 

The Sort Window has the following buttons: 

• Help - Displays information about the component version currently running 
in the Sort window. 

• Apply - Keeps the Sort window open after FSM updates the flight list. 
• OK - Closes the Sort window after FSM updates the flight list. 
• Cancel - Cancels any selections made and closes the Sort window. 
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Figure 6-26 shows flights sorted by Destination, then AC, and then ETA. This sorted Flight List 
corresponds with the Sort window parameters shown in Figure 6-25. 

 
Figure 6-26: Sorted Flight List 

Multi-level Sorting 
You can use the Sort window to sort a flight list by multiple data fields. For example, you want to 
sort your Flight List by Destination (DEST), Carrier (AC), and Estimated Time of Arrival (ETA) 
respectively. 

1. Select View > Sort Flights from the Flight List component. 

The Sort window appears. 

2. Select the DEST data field in the Sort By dropdown menu. 
3. Select Ascending. 
4. Select the AC data field in the Then By dropdown menu. 
5. Select Ascending. 
6. Select the ETA data field in the Then By dropdown menu. 
7. Select Ascending. 
8. Click OK or Apply in the Sort window to generate the sorted Flight List. 
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Flight Filtering in Flight Lists 
The Apply Filter window displays a pre-determined list that allows you to arrange the data in the 
Flight List according to your selection.  

1. Select View > Apply Filter from the Flight List component. 
2. Select a filter option from the Apply Filter window. 
3. Click OK. This applies the filter to the flight list. For example, when you select the 

Arrived filter option, FSM arranges the data according to the arrived flights in the Flight 
List. 

4. To cancel the applied filter and return to the original Flight List settings, select View > 
Clear Filter from the Flight List menu. 

 
Figure 6-27: Apply Filter Window 
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Viewing a Single Flight 
You can view information for a single flight by: 

• Searching By Callsign for the flight 
• Viewing the Flight Information window 
• Viewing the Flight Detail window 

This section describes how to access and use each of these methods to obtain information on a 
specific flight. 

Search By Callsign 
You can use the Search By Callsign component when you know the call sign for the flight you 
want to view. In FSM, the uniqueness of a flight relies on the call sign, origin, and destination. In 
performing the search, if you enter only the call sign, leaving Origin blank, FSM finds the first 
flight with that call sign regardless of the origin airport. There may be other flights with the same 
call sign, but different origin airports that you cannot see. 

 
Figure 6-28: Search By Call sign Dialog Box 

After entering the search criteria, you have three options on the Search By Call Sign dialog box: 

1. OK - Performs the search and closes the Search By Call Sign window (if the search 
returns only one flight). 

2. Cancel - Closes the window without performing the search. 
3. Find Next - Locates the next flight that has the same call sign and/or original airport and 

leaves the Search By Call Sign dialog box open for you to perform another search. If the 
flight is unique, FSM tells you that it cannot find another flight. 

To use Search By Callsign 
1. Ensure you have a data set open. 
2. From the Time Line component select Time Line > Search By Callsign (or select 

Utilities>Search By Callsign if the Time Line is not open). 

The Search By Callsign dialog box appears. 

 
3. Enter the flight's Callsign and Origin Airport. 

Note: The origin airport field is optional. 
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4. Click OK. 
5. The Flight Info window for that flight appears. 

 
If more than one flight has the call sign you entered, you receive a message box. 

 
6. Click OK. 
7. Click Find Next on the Search By Callsign dialog box to see the next flight with that call 

sign. 
8. Once you have finished viewing the flights, click Cancel on the Search By Callsign 

dialog box to exit from the search. 

Using wildcards to search for a flight 
You can use the * and ? wildcards to search for flights for which you have incomplete call sign or 
origin airport information. For example, you have call sign SWA13 but are missing the last two 
digits and the origin airport starts with a D. 

1. Ensure you have an airport data set open. 
2. From the Time Line component select Time Line > Search By Callsign (or select 

Utilities>Search By Callsign if the Time Line is not open). 

The Search By Callsign dialog box appears. 

3. Enter the flight's Callsign and Origin Airport using the wildcards. 

 
4. Click OK. 

The Flight Info window for that flight appears. If more than one flight meets these 
criteria, a Flight List appears displaying all matching flights. The Flight List operates in 
the same way as any other Flight List. 

5. Click Cancel on the Search By Callsign dialog box to exit the search. 

Flight Info Window 
You can access individual flight information by right-clicking on any flight icon in the Time Line 
component or by right-clicking on a single flight in a Flight List and selecting View flight info 
from the pop-up menu (see Flight Lists). The Flight info window appears. The Flight Info 
window gives you some general ADL information for the selected flight.  

Note: The wildcard ‘?”stands in for one character (i.e. SWA1?? returns all 
SWA flights with two ID numbers).  The wildcard ‘*’ stands for multiple 
characters (i.e. UAL* returns all UAL flights with any length ID number. 
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  Figure 6-29: Flight Information Window 

Flight Information Data 
The Flight Info window contains the following information: 

• Date/Time – The date and time at which you are viewing the flight. In 
Monitored Live mode, this is always the current date and time. 

• Flight ID – The aircraft call sign (a combination of airline code and flight 
number). FSM filters this information for airline users. 

• Status – Flight Status describes the current status of a flight.  For example, a 
flight can be Delayed, In Program, or Unknown.  

• Orig – Origin airport of the flight, with the corresponding center in 
parentheses. 

• Dest – Destination airport of the flight, with the corresponding center in 
parentheses. 

• ETD – Most recent Estimated Departure Time for the flight. 
• ETE – When available, FSM gives the actual time en route for the flight. 

Otherwise, FSM gives an estimated time en route. 
• ETA – Most recent Estimated Arrival Time for the flight. 
• CTD – The Control Time of Departure for the flight, if it has one. 
• CTA – The Control Time of Arrival for the flight, if it has one. 
• Delay – If the flight is delayed, one of the delay codes is highlighted. ALD 

indicates that the carrier imposed a delay on the flight. GDP indicates that the 
flight is delayed because of a ground delay program. FAD indicates that the 
flight is delayed because of a fuel advisory. GSD indicates that the flight is 
delayed because of a ground stop. TOD indicates the flight is delayed 
because its EDT timed out in ETMS; the flight passed its ETD without taking 
off. 
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• Cancel – If the flight is cancelled, one of the cancellation codes is 
highlighted. UX indicates that the flight was cancelled due to an EDCT 
update, which a traffic manager may use to cancel a flight. FX indicates that 
the flight was cancelled using an FX message, which is the CDM message 
used by the airlines to indicate a cancelled flight. RZ indicates that the flight 
was cancelled using an RZ message, which is a NAS flight plan cancellation 
message. RS indicates that the flight was cancelled using an RS message, 
which is an internal ETMS message generated when a specialist takes an 
OAG flight out of the database. TO indicates that ETMS considers the flight 
time out cancelled because no activation message has been received within a 
certain time of the predicted departure time. The amount of time out delay 
appears in parentheses. DV indicates that the flight was cancelled and 
diverted to an alternate destination. RM indicates that the flight has been 
removed from the ETMS database. 

Flight Info buttons 

• View Flight Details Button – Clicking this button brings up the Flight 
Detail window. This window provides more detailed information of the 
flight. 

Flight Info Menu 

The menu bar in the Flight Info window contains three options: File, View, and Help. 

1. File Menu 

• File > Save as – Saves the flight information to a text file, which you can 
open later and use again. 

• File > Print – Prints the flight information you see on the screen. 
• File > Close – Closes the Flight Info window. 

2. View Menu 

• View > Flight Detail – Displays the Flight Detail window. 
3. Help Menu 

• Help > Flight Information – Accesses the web-based on-line help 
information for the Flight Info window. 

Flight Detail Window 

Use Flight Detail to obtain more detailed information for a specific flight than appears in the 
Flight Info window. There are four ways to access the Flight Detail window: 

1. Right-click any flight icon in the FSM Time Line and select Flight Detail. 
2. Right-click a flight in any FSM Flight List and select Flight Detail. 
3. Click Flight Detail from the Flight Information window. 
4. Select View > Flight Detail in the Flight Information window. 
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Figure 6-30: Flight Details Window 

Flight Detail ADL Data Elements 
The Flight Details window contains the following information: 

• Flight ID – The code that identifies the airline and flight number. 
• Date/Time – The date and time at which you are viewing the flight. In 

Monitored Live mode, this is always the current date and time. 
• Aircraft Type – Indicates the type of aircraft being used for the flight. 
• AC_CAT – Indicates the equipment type: propeller, jet, turbo, or unknown. 
• Class – The class to which the aircraft belongs. Classes are: heavy, large, or 

small. 
• Major – The airline carrier that controls substitutions for the flight. 
• CDM_Participant – Indicates whether the flight belongs to an airline that 

participates in the FAA's Collaborative Decision Making program. 
• User – The user class to which the aircraft belongs. User Classes are: air 

carrier, air taxi, air cargo, military, general aviation, and other. 
• Departure Information – This column contains the flights Departure 

information. 
• GCD – This field indicates the Great Circle Distance (GCD), which is the 

distance between the origin airport and arrival airport. 
• Arrival Information – This column contains the flights Arrival 

information.. 
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• ADL Element – This column indicates which ADL elements FSM used to 
derive the information in each column. For example, to display the flight's 
departure fix time, FSM uses the ADL element marked DFIX. 

• Airport Center – Includes the flights origin and destination Airport and 
Center (Airport/Center). This row also contains the flight’s GCD. 

• Fix Estimate – Departure Fix (DFIX) and Estimated Departure Fix Time 
(EDFT) and the arrival Fix (AFIX) and Estimated Arrival Fix Time (EAFT). 

• Procedure – Departure Procedure (DP), Departure Procedure Transition 
(DTRSN), Standard Terminal Arrival Route (STAR) and Standard Transition 
(STRSN) 

• Gate, Runway, and En Route Times – This section of the Flight Details 
window displays estimated, controlled, scheduled, proposed, airline, and 
actual times for several fields that allow you to track the flight's progress 
from the departure gate and runway to the destination runway and gate. The 
information includes the various times given for: 

• ETD/ETE/ETA – Estimated Wheel Times 
• CTD/ETE/CTA – Control Times 
• SGTD/SGTA – Scheduled Gate Times 
• PGTD/ETE/PGTA – Proposed Gate Times 
• LGTD/LRTD/LRTA/LGTA – Airline Gate and Runway Times 
• IGTD/IGTA – Initial Estimated Gate Times 
• ARTD/ETE/ARTA – Actual Runway Times 
• OUT/OFF/ON/IN – Time that the flight was out of the departure gate, off 

the departure runway, on the arrival runway, and in the arrival gate. 
• ERTD/ERTA – Earliest Runway Times 
• OETD/ETE/OETA – Original Estimated Wheel Times 
• BETD/BETA – Beginning Estimated Wheel Times 
• OCTD/OCTA – Original Control Times 
• Control Exempt/ Control Type/ Control Element – Displays the type of 

controls on the flight resulting from a program. 
• Slot ID/Slot Hold – The Slot ID is the currently assigned slot for the flight. 

Slot Hold indicates whether the slot is being held so that it is not used in 
compression. A "Y" indicates the slot is being held. A dash (-) indicates the 
slot is not being held. 

• Diversion Recovery (Div Recovery) – Indicates whether the flight is a 
diversion recovery leg of a previous flight. 

• Delay Status (ALD GDP FAD GSD TOD) – Indicates the type of delay, if 
any, on a flight. 

• LTOD – If a flight is time out delayed, the length of time out delay appears 
here. 
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• CNX Status (UX FX RZ RS TO DV RM) – Indicates the cancellation 
status of the flight. The codes indicate how or why the flight was cancelled. 

• Remark (NRP LFG III ATV SWP DVT ADC FCA WXR) – These codes 
indicate important information about the flight. NRP is National Route 
Program flight. LFG is Lifeguard flight. III is Category III flight. ATV is 
Altitude reservation. SWP is SWAP flight. DVT is Diversion recovery flight. 
ADC is Advise customs. FCA is Flow Constrained Area. WXR is Severe 
weather route. 

• Alarm Status (CC EC EA SF CF) – Indicates the type of alarm criteria, if 
any, that the flight meets. 

• Absolute Delay (Max [0, ETA - (IGTA - Taxi)]) – FSM calculates the 
Absolute Delay to include all types of delay on a flight. This includes FAA 
and airline-imposed delay due to traffic management initiatives, mechanical 
delays, etc. Please note that delay can be only a positive integer. Therefore, if 
the flight is running as scheduled or is early, Absolute Delay is a value of 
zero (0). 

• Schedule Variation (ETA - [IGTA - Taxi]) – Schedule variation is almost 
identical to absolute delay with the exception that schedule variation can 
include negative values. A negative value in the Schedule Variation field 
indicates that the flight is running earlier than scheduled. 

• ATC Delay (Max [0, CTA - BETA]) – ATC Delay includes only that delay 
that results from an FAA traffic management initiative and any action taken 
by the airline as a result of the traffic management initiative. This does not 
include airline-imposed delay, such as mechanical failures, crew delay, etc. 
ATC Delay can be only a positive integer. If the flight is running ahead of its 
schedule, ATC delay is a value of zero (0). 

Note: For a description of each of the flight data fields contained in the Flight 
Details window. See ADL Data Format or select Help>ADL Data Elements 
from the FSM Control Panel component. 

Flight Detail Menu 
The menu bar in the Flight Detail component contains two options: File and Help. 

1. File Menu 

• File > Save as – Saves the Flight Detail to a text file, which you can open 
later and use again. 

• File > Print – Prints the Flight Detail information you see on the screen. 
• File > Close – Closes the Flight Detail window. 

2. Help Menu 

• Help > Flight Details – Accesses the web-based on-line help for Flight 
Details information. 
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Viewing Problem Flights 
In the air traffic community, operators need to identify which flights from their own operations 
may be contributing to delay and cancellation problems. Delays and cancellations, caused by 
Time Outs, occur when no activation message has been received within a certain time of the 
predicted departure time. Time Outs can be problematic when trying to manage air traffic. To 
help, FSM includes two reports for problem flights: Time Out Delay Report and Time Out Cancel 
Report. See chapter 19: Reports for more information about these reports. You can group and sort 
Report Lists using the same methods described in the Flight List section. You can access all 
reports lists from the Reports menu on the Control Panel component. 

Other Flight Reports 
Flight reports in FSM are a good way to view a set of flights arriving at an airport that meet 
specific criteria. You can access the following reports from the Reports menu on the Control 
Panel component: 

• Surface Delay Report 
• Priority Flight Report 
• Slot Hold Report 
• Sub Opportunities Report 

See chapter 19: Reports for more information about these reports. 

Compliance Flight Lists 
When any flight becomes noncompliant, FSM generates a flight list, called a compliance report, 
that includes these flights. You can access the compliance reports from the Reports > 
Compliance > option from the Control Panel component. There are five possible compliance 
reports: 

• By CTD 
• By ETE 
• By CTA 
• Spurious Flight 
• Cancelled That Flew Compliance 

See chapter 19: Reports for more information about these reports. 

Query Manager Flight Lists 
The Query Manager component can query an airport and generate a Flight List that contains only 
flights that meet certain criteria. You can access the Query Manger by clicking Query Manager 
on the FSM Control Panel component. From the Query Manger, select any one of the Built-in or 
User-defined Filters then click Flight List or select View > Flight List. 

Note: If you do not have a data set (airport) selected, FSM displays a “No Active 
Data Sets” error message. 

The generated Flight List contains only those flights that meet the selected criteria. For more 
detail on how to view and use flight filters in Query Manager, see Chapter 3: Query Manager. 
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7 Decision Support Tools 
Decision support or modeling tools are functions in FSM that aid you in looking at various 
operational or traffic scenarios. You can use modeling tools to analyze existing operations and 
previous days' events. This chapter reviews some of the utilities in FSM specifically set up to help 
you model various air traffic scenarios. You can use these tools at any time during your FSM 
session. 

Adverse weather or any other significant airport event can decrease the airport’s capacity, which 
lowers the AAR. When the airport’s arriving flight demand exceeds the airport’s AAR capacity, 
then you may need a Traffic Management Initiative (TMI). 

FSM allows you to model different scenarios in Ground Delay Tools (GDT) mode to help you 
determine what type of TMI would be most effective. Either a Ground Delay Program or Ground 
Stop, or in some cases both may be necessary. 

Evaluating Demand Versus Capacity 
Bar Graph 
The Bar Graph serves as a quick look to see if demand exceeds the airport’s capacity. The arrival 
flow rate displays the airports’ demand independently of the time-bin conventions. Therefore, you 
can view where the fluctuations in demand are located within each hour. If there are several hours 
where demand is significantly greater than the AAR, you may need a TMI to control the traffic 
flow into the airport. 

The Bar Graph component is colored according to the tab option currently in use. For example, if 
the Arrival Status tab is active, the bars in the graph are colored according to the percentage of 
flights that represent each respective arrival status. If half of the flights for one time period have 
not departed (light green), while the other half are in the air (red), the bar for that hour is half 
red/half green. If every flight for the hour has already landed, the bar for that hour is black. The 
Bar Graph is dynamic and changes according to the information in each ADL update. The Bar 
Graph also automatically updates itself when you choose a different tab option. See Chapter 3: 
Bar Graph for more information. 

Time Line 
The Time Line component is colored according to the tab option currently in use. You can view 
the default colors from the Time Line’s legend. See Chapter 3: Time Line for more information. 
At the top of each hour column in the Time Line, the airport’s AAR and expected demand 
appears for that hour. For example, 72/86 indicates that the AAR is 72 and the demand expected 
for that hour is 86 (see Figure 7-1). There are situations where demand exceeds capacity in one 
hour but the next hour has plenty of room to accommodate the spill over from the previous hour. 
In these instances, a TMI would be unlikely. Figure 7-1 shows an AAR of 72 for an airport. At 
1600z, the demand expected is 86; therefore, the demand exceeds the capacity by 14 flights. At 
first glance this seems excessive, but looking into the next hour, the expected demand is only 58. 
The airport can accommodate the 16 flights from the 1600z hour in the 1700z hour. A TMI is 
more likely when demand exceeds capacity for several hours. 
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Figure 7-1: Time Line AAR vs. Demand counts 

Deciding when a TMI is necessary is not always this simple, but the ATCSCC works closely with 
all participants through telcons to decide when a TMI is essential. 

TMI Evaluation Using Carrier Statistics Report 
When you run a TMI, FSM generates a Carrier Statistics report. You can view this report from 
the Control Panel component by selecting Reports > Carrier Statistics or from View > Carrier 
Statistics on any TMI Coversheet. Ensure the desired airport is active to review the correct 
airport’s carrier statistics. From the Carrier Statistics report you can view ATC delay or ABS 
(total delay including airline delay). The Carrier Statistics report is based on flight’s ETA and 
displays specific delay information for each carrier’s flights. The Carrier Statistics report is 
particularly helpful to airlines. Airlines can view how the TMI affects them. 
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Figure 7-2 is an example of the ATCSCC personnel view of the carrier statistic report. Airlines 
would only see their own call sign and any sub-carriers. For more information on the Carrier 
Statistics report, see Chapter 19: Reports. 

 
Figure 7-2: Carrier Statistics 

Changing Airport Arrival Rates (AAR) 
Changing the AAR on the Bar Graph is helpful to visually determine how a lowered AAR affects 
the balance between capacity and demand. If demand exceeds the reduced AAR, then a TMI may 
be necessary. 

Specify Model AAR 
The Bar Graph > Model Arrival Rates > Specify allows you to change the Model AAR for a 
specific amount of time. You can set the Model AAR for up to 15 hours beyond the current time. 
The new Model AAR appears in the Bar Graphs. The Time Line only displays actual ADL AAR 
rates. 

Changing the Rate 
There are several ways to change the model AAR using the Specify Model AAR window, 
including the ability to assign several different AARs within the same hour. 

Note:  Although FSM displays Fixes; you can only specify an AAR for an 
airport. Arrival Fix based programs are a future enhancement. 

To modify rates, enter the new value in the With text box. Then, fill in the hours in the From Hr 
and Through Hr text boxes to reflect the duration of the new AAR. Click Fill to automatically fill 
those hours. This is a good option when you need to fill a block of hours with one rate. 

To fill several hours, each with different rates, you can enter new values directly into the Airport 
column cells next to the appropriate Time row cells that you want to change. 
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Figure 7-3: Specify Model AAR Window and 15 Min AAR Dialog Box 

To fill a single hour with multiple AARs, click on the airport cell you want to modify and then 
click Edit 15 in the lower right-hand corner of the rates table or right-click on an active cell in the 
Airport column. The 15 Min AAR dialog box appears. This window allows you to assign AARs 
in 15-minute increments for that hour. For example, Figure 7-3 illustrates an AAR of 80, but for 
the first fifteen minutes the airport can take only 10 flights. Therefore, you need to assign an 
AAR of 23 or 24 for the other 15-minute time increments. You can assign any value in each 15-
minute increment as long as the total equals the overall AAR/ADR value for that hour. Click OK 
to change the 15-minute increments for that hour or Cancel to close the window. When an hour 
increment is not evenly distributed in the 15-minute increments, the cell is colored green. 

After changing your Model AAR information, click OK from the Specify Model AAR window to 
reflect the changes in your local Bar Graph component. Ensure the View > Model AAR Line 
checkbox is checked so that you can view the modeled rates. 
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View Model AAR Line 
The dashed, white line represents the modeled AAR. To view the modeled AAR line, you must 
ensure that you select the View > Model AAR Line checkbox. In all FSM Modes, Model AAR 
initially appears in the same position as the ADL AAR in the Demand Graph. If the ADL AAR 
appears on the graph, the dashed line (for modeling) is hidden behind the white solid line. In 
addition to changing the model AAR rate from the Bar Graph > Model Arrival Rates > Specify 
feature, you can change the AAR by placing your cursor over the AAR line and dragging the 
model line to your desired model rate.  

Note:  Only the portion of the line to the right of the cursor moves. 

Any portion of the line to the left of your cursor should remain in the same position as you drag 
the line to a new AAR. The Bar Graph Component and the Specified Modeled AAR Rates 
component dynamically sync; therefore when you alter an AAR rate from one component, the 
changes also are reflected in the other. For more information on AAR Rate see Chapter 5: View 
Airport Demand. 

Apply or Clear AAR Changes 
After you enter new AAR information, there are three options available on the Specify Model 
AAR panel: 

• OK – Applies the newly modeled AAR to the Bar Graphs and closes the 
Specify Model AAR window. 

• Cancel – Closes the Specify Model AAR window without taking any action. 
• Help – Defines the function of the component. 

Specify Model AAR Menu Options 
1. File Menu 

• File > Open – Opens previously saved AAR parameters. 
• File > Save As – Saves the AAR parameters to a text file which you can 

open later and use again. 
• File > Print – Prints the Specify Model AAR window. 
• File > Close – Closes the Specify Model AAR window. 

2. Help Menu 
• Help > Demand Rates… – Accesses the web-based on-line help for 

Specifying demand rates. 

Changing Airport Departure Rates (ADR) 
Changing the ADR on the Bar Graph is helpful to visually determine how a lowered ADR affects 
the balance between capacity and demand on the monitored airport. 

Specify Model ADR 
The Bar Graph > Model Departure Rates > Specify allows you to change the Model ADR for 
a specific amount of time. You can set the Model ADR for up to 15 hours beyond the current 
time. The new Model ADR appears in the Bar Graph component. 
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Changing the Rate 
You can change the model ADR in several ways using the Specify Model ADR window, 
including assigning several different ADRs within the same hour (see Figure 7-4). 

To modify rates, enter the new value in the With text box, then fill in the hours in the From Hr 
and Through Hr text boxes to reflect the duration of the new ADR. Click Fill to automatically fill 
those hours with the new ADR. This is a good option when you need to fill a block of hours with 
one rate. 

To fill several hours, each with different rates, you can enter new values directly into the Airport 
column cells. Click OK to change the ADR rates. Click Cancel to close the window, or click 
Help to see a definition of the function of the component. Click ADL ADR to reset airport values. 

 
Figure 7-4: Specify Model ADR Window and 15 Min ADR Dialog Box 

To fill a single hour with multiple ADRs, click the cell you want to modify and then click Edit 15 
at the lower right-hand corner of the rates table or right-click on the active cell in the Airport 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Decision Support Tools 

Version 7.9 7-7 

column. This brings up the 15-minute ADR window that allows you to assign the ADR in 15-
minute increments for that hour. For example, Figure 7-4 illustrates an ADR of 75, but for the 
first fifteen minutes the airport can only take 10 flights. Therefore, you should assign an ADR of 
21 or 23 for the other 15-minute time increments. You can assign any value in each 15-minute 
increment as long as the total equals the overall ADR value for that hour. Click OK to change the 
hour or Cancel to close the window. When an hour increment is not evenly distributed in the 15-
minute increments, the cell is colored green. 

After changing your Model ADR information, click OK from the Specify Model ADR main 
window to reflect the changes in your local Bar Graph component. Check the View > Model 
ADR Line checkbox to view the modeled rates. 

View Model ADR Line 
The dashed, cyan line represents the modeled ADR. To view the model ADR line you must check 
the View > Model ADR Line checkbox. In all FSM modes, the model ADR initially appears in 
the same position as the ADL ADR in the Demand Graph. If the ADL ADR appears on the graph, 
the dashed line (for modeling) is hidden behind the solid cyan line. In addition to changing the 
model ADR rate from the Bar Graph > Model Arrival Rates > Specify feature; you can change 
the AAR by placing your cursor over the AAR line and dragging the model line to your desired 
model rate. Only the portion of the line to the right of the cursor moves. Any portion of the line to 
the left of your cursor should remain in the same position as you drag the line to a new ADR. The 
Bar Graph Component and the Specified Modeled AAR component are dynamically synced; 
therefore, when you alter an AAR rate from one component, the changes also appear in the other. 
For more information on ADR rates see Chapter 5: View Airport Demand. 

Apply or Clear ADR Changes 
After you enter new ADR information, there are three buttons available on the Specify Model 
ADR panel: 

• OK – Applies the newly modeled ADR to the Bar Graph and closes the 
Specify Model ADR window. 

• Cancel – Closes the Specify Model ADR window without taking any action. 
• Help – Defines the function of the component. 

Specify Model ADR Menu Options 
1. File Menu 

• File > Open – Opens previously saved ADR parameters. 
• File > Save – Saves the ADR parameters to a text file, which you can open 

later and use again. 
• File > Print – Prints the Specify Model ADR window. 
• File > Close – Closes the Specify Model ADR window. 

2. Help Menu 
• Help > Demand Rates… – Accesses the web-based on-line help for the 

Demand Rates Window. 

Reset AAR/ADR Model Rates 
You can reset the AAR/ADR data to the original data in several ways during your FSM session.. 
In the Bar Graph, you can select Bar Graph > Model Arrival Rates > Reset in the Monitored 
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Live, Historical or GDT mode. You can select Utilities > Model Arrival Rates > Reset from the 
Control Panel. 

You can also reset the AAR Rates from the Specify AAR Rates window. Select Bar Graph > 
Model Arrival Rates > Specify and click ADL AAR to reset the AAR rates to the original values. 
The steps to reset ADR Rates are identical to those for the AAR rates with the exception of the 
GDT mode. The ADR rates are not available in GDT Mode. 

Manipulating Data Time 
Set Time (Historical Mode) 
When working in Historical Mode, you have the ability to specify the time you would like to 
view. You can specify the data time from the Open Data Set component when you first open an 
airport in historical mode (See Chapter 3: Open Data Set for more information) or at any time 
while you are in historical mode for an airport. To change the data time when viewing an airport 
in historical mode, select Bar Graph > Set Time (Historical Mode Only). This feature is 
available only in Historical Mode. The Set time dialog box appears and allows you to specify the 
time at which to view airport data (see Figure 7-5). Select the day from the dropdown box and 
time in “hhmm” format. 

Note: Time in FSM is always in Zulu time unless otherwise specified. 

Click OK to update flights’ data to the closest, but no later than, the entered time. Click Cancel to 
close the Set Time dialog box without changing the data time. 

 

 
Figure 7-5: Set Time Dialog Box 
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Modify Data Time (GDT Mode only) 
You can select the Data Time from the General tab on the GDT Setup component. The data time 
allows you to change the data time without making any modifications to the data itself. In the 
Data Time textbox, enter a time in “hhmm” format to change the time. Valid times are from 0- 
2359. When you change the Data Time to a value other than the current time, the Data Time text 
box, as well as the GDT tab border, is highlighted in red. 

 
Figure 7-6: GDT Setup Component 

Update Data Time (Historical Mode Only) 
You can only use Update on the Control Panel component when in Historical mode. Click 
Update to receive the next historical ADL updates. If you click Update within any other mode 
except the historical mode, the following error message appears: “Not a historical data set”. 

Remove and Restore Flights (CSA Only) 
Remove Flights 
You can remove flights from the ETMS database using FSM. You can use this feature to remove 
an airline that goes on strike, eliminate duplicate flights, or remove erroneous flights listed in the 
OAG. To remove a flight, ensure the airport from which you want to remove the flight is active, 
and then select ETMS Tools > EDCT Commands > EDCT Remove from the Main Control 
Panel (see Figure 7-7). The EDCT Remove dialog box prompts you to type in the flight number 
and date. To remove the flights from the database, click Send. FSM prompts you to decide 
whether you really want to remove the flight. Click YES to remove the flight. Click NO to cancel 
the action. Click Cancel to close the dialog box without taking any action. Help defines and 
explains the Remove Flights feature. 
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Figure 7-7: EDCT Remove Dialog Box 

Restore Flights 

To restore a flight, select ETMS Tools > EDCT Commands > EDCT Restore from the Control 
Panel, as shown in Figure 7-8. The EDCT Restore dialog box prompts you to type in the flight 
number and date. To restore the flight to the database, click Send. FSM prompts you to decide 
whether you really want to restore the flight. Click YES to restore the flight. Click NO to cancel 
the action. Click Cancel to close the dialog box without taking any action. Help defines and 
explains the Restore Flights feature. 

 
Figure 7-8: EDCT Restore Dialog Box 
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8 Modeling a Traffic Management Initiative 
Due to unexpected events, such as bad weather at an airport, the FAA delays flights scheduled to 
arrive at the affected airport. The FAA examines flights to determine whether to include them in a 
Traffic Management Initiative (TMI) based on the time period of the operation. The FAA checks 
those flights eligible for inclusion in the operation against the various exemption criteria 
specified. 

Generally, a TMI is necessary where arrival demand excessively surpasses the airport capacity. 
The AAR defines airport capacity. You can raise the AAR rates, or lower them, due to weather, 
runway closures, or any other significant event. FSM helps determine what kind of Program Type 
would be necessary to adequately control the traffic flow into the airport. 

One important function of FSM GDT Mode is that it allows you to view "what-if" scenarios. That 
is, FSM analyzes the effects of a TMI operation using different parameters you set. FSM's 
analysis capabilities help you determine the best parameters for a TMI operation-one that 
minimizes impact on air carrier operations and maximizes efficiency during adverse conditions. 
This chapter discusses modeling any TMI in GDT Mode. 

You can use the GDT Setup Panel component to model, issue, and send TMIs. You can manage 
the TMI parameters from the GDT Setup Panel. When you model a TMI, you can use parameters 
that you specify or you can use proposed parameters. 

Modeling a TMI Using Parameters You Specify 
To model a TMI, you need to set the parameters you want to use for the TMI. You can do this by 
opening any monitored airport in GDT mode and selecting the TMI parameters there. The 
parameters you can set for the TMI are different depending on which program type you select.  
For more information on what parameters are available for each program type, see Chapter 3: 
Understanding Components. 

To Model a TMI using parameters you specify 

For example, you want to model a GDP RBS++ program type for ATL. 

1. Click Open Data Set. 
The Open Data Set window appears. 

2. Select ATL from the Live tab. 
3. Click OK. 

The Time Line and Bar Graph components for ATL appear. 
4. Click GDT Setup. 

The GDT Setup Panel, GDT Time Line, GDT Bar Graph, and GDT Map 
appear, as shown in Figure 8-1. 

Note: If there is no airport in focus when you click GDT Setup, an FSM 
error message indicates that “No current data set” is selected. 

Note: All GDT components interact with one another; The GDT Setup 
and GDT Map dynamically reflect one another, whereas clicking Reload 
or Model on the GDT Setup panel reflects changes in all components.  
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Figure 8-1: Initial Default GDT Display 

5. Enter the appropriate values for the GDP RBS ++ into the General tab of the 
GDT Setup panel. For this example, enter the following: 
o Start Time – 1300 
o End Time – 1759 
o Arrival Fix – All 
o Air Craft Type – All 
o Carrier – All 
o Initial GDP – Checked by default 
o Sched/User Exemptions – Click Select and select Military 
o Delay Assignment Mode – DAS 

Note: Enter the appropriate additional (positive number) or decreased 
(negative number) delay time in Adjust Delay when using the Blanket 
Program Type. Clicking Release fills in the Adjust Delay text field with  
–999, which is equivalent to releasing all delay from your specified 
criteria. 
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Figure 8-2: GDT Setup General Tab 

6. Enter the appropriate values for the program into the AAR tab of the GDT 
Setup panel. For this example, enter an AAR of 75. 

Note: When you select the Lock checkbox option, it locks the duration of 
the program. Changing either the start time or the end time changes both 
times according to the TMI duration time. 
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Figure 8-3: GDT Setup Panel AAR Tab 

Note: Changing AARs for fixes is not an option. The Fill dropdown has 
only Airport as a valid entry. Assigned AARs for certain fixes is a future 
enhancement. 

7. Enter the appropriate values for the program into the Tier/Dist tab of the 
GDT Setup panel. For this example, enter the following: 
o Exempt By – Tier 
o Scope – 2ndTier - ZAB 
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Figure 8-4: Exempt By Tier selected 

8. Select GDP Center Group & Data Time on the Power Run tab. 
9. Click Model. 

FSM models the program using the parameters you provided. The red border 
inside the GDT Setup Panel disappears. FSM updates the Data Graph, Bar 
Graph, and Map with your parameters. 
You can use these components to determine how this program affects SFO. 

10. If you want to load the latest ADL and analyze the data before issuing the 
program, click Reload. 
The border inside the GDT Setup Panel turns red. 

11. Click Model to see the updated data reflected in the GDT components. 

Modeling a TMI Using Proposed Parameters 
When the ATCSCC sends out proposed parameters for a TMI, you can model those parameters to 
determine how they affect your situation. This can help you to plan before the ATCSCC 
implements the actual TMI. 

Note: Any changes you make to the GDT Map dynamically reflect in 
the GDT Setup component’s Tier/Dist Tab. 

Note: You can retrieve additional components from the View menu. 

Note: You can use the same steps to model actual parameters except that 
you select File>Load Actual Parameters>[Program Type]. 
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To Model a TMI using proposed parameters 

For example, the ATCSCC sends out proposed parameters for GDP RBS++ program type for 
MCI and you want to model it. 

1. Click Open Data Set. 
The Open Data Set window appears. 

2. Select MCI from the Live tab. 
3. Click OK. 

The Time Line and Bar Graph components for MCI appear. 
4. Click GDT Setup. 

The GDT Setup Panel, GDT Time Line, GDT Bar Graph, and GDT Map 
appear. 

5. Select File>Load Proposed Parameters>Ground Delay Program. 
FSM loads the proposed parameters into the GDT Setup Panel. 

6. Click Model. 
FSM models the program using the parameters you loaded. The red border 
inside the GDT Setup Panel disappears. FSM updates the Data Graph, Bar 
Graph, and Map with the proposed parameters. 
You can now determine how the program affects you. 

Modeling Analysis 
Preview Your Work  
After clicking Model on the GDT Setup component, all FSM GDT components change to reflect 
the modeled TMI. Viewing these components can help you decide if the TMI you have modeled 
is the best scenario for the traffic flow problems at an airport. All of the following components 
are based on an ATL modeled GDP program. 

Note: You can only load parameters for the airport you are modeling. 
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GDT Time Line Component 

To open the GDT Time Line, select View > Time Line from the GDT Setup component. You can 
preview the changes made in the Time Line as a result of running the TMI model. A quick glance 
at the Time Line shows you the number of canceled flights (squares) and the number of delayed 
flights (triangles). 

 
Figure 8-5: Modeled ATL GDP: Time Line View 

Note: If you modeled a GDP with a GAAP delay limit, you would also 
see the number of Unassigned Slots (white diamonds). 
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GDT Bar Graph Component 
The bar graph always displays both solid and hashed bars. Solid bars represent the original data, 
while hashed bars represent modeled data. Select View > Model AAR Line from the GDT Bar 
Graph to view the modeled AAR (dashed white line). The bar graph can indicate if the stack at 
the end of the program is a potential problem and allows you to view the overall impact of the 
program (see Figure 8-6). 

 
Figure 8-6: Modeled ATL GDP: Bar Graph View 

Note: If you model a GDP with a GAAP delay limit, white sections of 
bars represent the Unassigned Slots. 
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GDT Data Graph Component 
The GDT Data Graph provides a visual statistical representation of the modeled TMI. The Power 
Run option that you ran appears on the X-axis. Using your mouse, drag the black vertical line to 
the desired Power Run option or just click the mouse over the desired option to move the line. 
The delay statistics to the right of the Data Graph reflect the line of delineation of the scenario. 
Additionally, changing the Power Run option automatically updates all GDT components to 
reflect the new parameters. Rolling your mouse over any line in the Data Graph gives you the 
delay statistic count for the colored line that reflects the results of the option. 

 
Figure 8-7: Modeled ATL GDP: Data Graph View 

For more information on the Data Graph component, see Chapter 3: Understanding Components. 
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GDT Data Table Component 
You can access the GDT Data Table by selecting View > Data Table in the GDT Setup 
component. The Data Table component contains all the same statistics as the Data Graph, only in 
tabular format (see Figure 8-8). Use the Data Table to look across a row for a particular statistic 
to find the best scenario. The same options that appear on the X-axis on the Data Graph are 
column headers in the Data Table. 

 
Figure 8-8: Modeled ATL GDP: Data Table View 
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The Analysis Report 
FSM generates the Analysis Report after you click Run from the GDT Setup component. To 
evaluate the effects of any delay operation, select View > Analysis Report from the Coversheet, 
as shown in Figure 8-9. 

 
Figure 8-9: Coversheet 
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FSM automatically opens the spreadsheet application that you have indicated in your 
configuration files to display the Analysis Report. 

 
Figure 8-10: Analysis Report for ATL GDP 

The Analysis Report contains pertinent information for the Ground Delay Operation that has just 
run, including detailed slot information for individual airlines, delay statistics for before and after 
the operation, and arrival and departure information for individual flights (see Figure 8-10). The 
report contains two sections. One section reflects changes that occur as a result of RBS; the other 
section reflects changes that occur as a result of Compression. Included in the analysis are 
statistics for bridge-only carriers. 

Reload the Data 
If you have been developing a TMI for a while, you may have missed some incoming ADLs. 
Before sending out the final TMI parameters, you may want to update the data for your proposed 
TMI. To do this, click Reload on the GDT Setup component. The Reload button is active only 
when the actual data time is more recent than the data available in GDT mode. Clicking Reload 
also models the TMI event. 
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9 Issuing an Initial Ground Delay Program  
This chapter assumes that you have already modeled your Ground Delay Program (GDP) and you 
have decided that a GDP is the best Traffic Management Initiative (TMI) to control the demand at 
the airport you are monitoring. See Chapter 9 for more information on how to set and model your 
parameters. 

Run to Generate the GDP Coversheet 
Click Run after you complete and model your GDP setup from the GDT Setup component. 
Clicking Run saves the parameters to a file specified in FSM’s configuration file and causes the 
GDP Coversheet to appear on the screen. Clicking Run also generates three reports, the FADT, 
Analysis, and Carrier Statistics Reports, which you can view by selecting View > FADT, 
Analysis Report, or Carrier Statistics from the Coversheet menu. See Coversheet Reports 
below for more information on reports. 

Note: If you modeled your GDP, the red border around the GDT Setup 
Panel no longer appears and the Run button is enabled. If you change any 
parameter in the GDT Setup component, you must click Model first, and 
then Run. Clicking Reload retrieves the most current parameters and 
models at the same time. 

The GDP Coversheet contains all the GDP parameters including the text fields for specific 
parameters. After reviewing the GDP parameters, send an Advisory and use Autosend from the 
GDP Coversheet to issue the GDP, as shown in Figure 9-1. 
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Figure 9-1: GDP Coversheet 

For more information on the Coversheet component, see Chapter 3: Understanding Components. 

Reviewing Program Parameters 
Reviewing the program parameters is important before issuing the GDP. Ensure that the General 
Parameters, Tier/Dist, Program Results, and scrolling window sections accurately reflect all of 
the information you entered for the GDP. 

Once you complete the GDP Coversheet and mark all of the checkboxes, you can either send out 
an Advisory or Autosend the GDP to the Hub site. 

When you click Advisory, the Advisory Window appears, which allows you to send either a 
Proposed or an Actual Advisory to all FSM users. See below on page 4 for more information. 

Using Autosend 
From the GDP Coversheet, click Autosend. Clicking Autosend sends the entire FADT file to all 
users, including airlines. During the Autosend process the Autosend Progress bar appears (see 
Error! Reference source not found.). The Hub site does not send out any actual program 
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information through the ADL unless there is an Actual Advisory with parameters matching the 
FADT. 

Note: If you choose Advisory or Autosend more than 15 minutes after 
switching to GDT Setup, FSM warns you to return to Monitor Live mode 
and get the most recent data from an updated ADL before continuing with 
the Ground Delay Operation. 

 
Figure 9-2: Autosend Progress bar 

 

Click Close and no action is taken from the GDP Coversheet window. 

Re-Opening the Coversheet 
If you want to review previous Coversheets for the airport, or if you accidentally closed the 
Coversheet before sending out the advisory, you can re-open it for review to continue sending out 
your program. Select File > Open from the GDT Setup component. This opens a file selection 
window for the Reports directory. You should see all Coversheets generated for that airport. 

Note:  The Coversheet files appear in the reports directory until you 
choose to delete them. 

FSM generates Coversheet files when you run a new or revised GDP, GS, Compression, or 
Substitution. FSM also generates Coversheets when you purge (cancel) a program. You can 
differentiate between the different Coversheet files by looking at the last few letters in the file 
name: 

• GDP indicates a GDP Coversheet. 
• GS' indicates a Ground Stop Coversheet. 
• COMP' indicates a Compression Coversheet. 
• SUBS' indicates a Substitution Coversheet. 

FSM names a typical Coversheet file by:  

• Type of file (for Coversheets, it is always covr) 
• Airport 
• 2-character date (just the day) 
• Time generated (HHMMSS) 
• Rate used 
• Type of Coversheet (gdp, gs, comp, subs) 
• Center group included 

For example, a file named "covr.SFO.28150808.3030.GDPNew.ALL" indicates a New GDP 
(first GDP of the day) Coversheet generated for SFO airport on the 28th at 1508Z with a 30 rate 
that includes all centers in the program. 

Once you find the appropriate Coversheet file, click on the file name to select it and click Open. 
The Coversheet opens in FSM exactly as it appeared the first time FSM generated it. If the 
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Coversheet is still valid to send out a program, the buttons at the bottom of the Coversheet are 
enabled. If the Coversheet is no longer valid, the buttons are grayed out.  

Note: Even if the Coversheet is still valid, enough time may have passed 
that it would be better to generate a new program and Coversheet. 

Creating an Advisory 
To compose either an Actual or Proposed GDP Advisory, click Advisory on the GDP 
Coversheet. The GDP Advisory window appears (see Figure 9-3). This window contains all the 
GDP parameters, which you set, and some fields in the Remarks section that you must enter 
before sending an advisory. 

 
Figure 9-3: Send an Advisory 

Sending an Advisory 
Once you complete the GDP Advisory, you can either save that Advisory to a specified directory 
on another computer or actually send it to the appropriate parties via email. 

Click Send to email the program parameters to all parties involved, including the Hub site. A 
checkmark appears next to the Send button on the Advisory window and next to the Advisory 

label  on the GDP Coversheet to indicate that you have sent the advisory. 

If the parameters are for a Proposed Advisory, the Hub site sends out the parameters immediately 
in the next ADL. When you send parameters for an Actual Advisory, the Hub site ensures that it 
has received the associated FADT file with flight control times for the program before sending 
any parameters through the ADL. 
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Click Close and no action is taken from the GDP Advisory window. 

Purging a GDP 
To purge (cancel) and release all delay on flights included in the GDP, use the Purge function 
from the GDT Setup Component. Selecting the Program Type Purge option on the GDT Setup 
Component is the same as using the Release Delay option for the Blanket Program Type-See 
Chapter 16 for more details on the Program Type Blanket. 

The Purge option requires no user input. Once the Purge option is selected, all the features in the 
setup panel are grayed out. Click Run to generate the GDP Purge Coversheet (See Figure 9-4). 

 
Figure 9-4: Purge Coversheet 

The information included in the Purge Coversheet is pre-defined-you cannot change it. 
Information on the Purge Coversheet includes: 

• Program Input parameters 
• Program Results 

For more information on the Coversheet component, see Chapter 3: Understanding Components. 

Purge Coversheet 
From the Purge Coversheet, click Purge to purge any control times from the ETMS system. 
Purge works the same as the Autosend function to send new operation parameters and 
cancellation messages to the Hub site for inclusion in the ADLs.  

Note: The Hub site waits for an Advisory for the cancelled GDP before 
sending the new parameters. 

Finish the GDP cancellation by clicking Advisory and sending a Purge advisory. 

Viewing Flight Information before Purging a Program 
When you model a purge for a program, ETMS sets the minimum notification time to the value of 
the minimum notification time for flights in a ground delay parameter. For the controlled flight 
affected by the PURGE, FSM determines the minimum notification time based on the type of 
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control and taxi status of the flight. If a controlled flight is in a taxi status, without regard to the 
type of control, then FSM sets the minimum notification time to the value of the minimum 
notification time for flights in a taxi status. 

ETMS models a new estimated departure time based on the flight’s control departure time and the 
minimum notification time based on the following criteria: 

• If the flight is active or completed, ETMS sets the ETD to the actual 
departure time. 

• If the CTD of the flight is within the minimum notification time from the 
current time, the estimated departure time remains set to the CTD. 

• If the CTD of the flight is greater than the minimum notification time plus 
the current time, then ETMS calculates a candidate ETD selected from the 
following values in order of priority: 

1. Earliest Runway Departure Time 
2. Earliest Runway Arrival Time minus the Estimated Time Enroute 
3. Original Estimated Departure Time 
4. Initial Gate Departure Time plus the taxi time for the flight 
• If this candidate time is greater than the current time plus the minimum 

notification time, then ETMS sets the ETD to this candidate time. 
• If the candidate time is less than the current time plus the minimum 

notification time, then ETMS sets the ETD to the current time plus the 
minimum notification time. 

 

Example 
The section below is an example of how to issue a GAAP GDP. When the known demand does 
not exceed the capacity at an airport but you think that the unknown demand will exceed 
capacity, you can use a GDP with a Delay Assignment Mode of GAAP to control traffic flow into 
the airport. This situation usually occurs at airports that serve large numbers of General Aviation 
(GA) flights. The General Aviation Airport Program (GAAP) was designed for this situation. As 
usual, scheduled flights receive a slot, but ETMS also generates unassigned slots for unknown 
demand. As flights become known, ETMSassigns them to one of the open slots or gives them an 
FA delay. The FA delay time also differs in that it is one set value for all flights. No flight at a 
GAAP airport receives a delay longer than the maximum delay limit.  

To issue a GAAP GDP 

1. Click Open Data Set. 

The Open Data Set window appears. 

2. Select the airport for which you want to issue the GAAP GDP. 
3. Click OK. 

The Time Line and Bar Graph components for the airport appear. 

4. Click GDT Setup. 

The GDT components for the airport appear. 

5. Select RBS++ for the Program Type. 
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6. Select the appropriate values for the Program Time and Include sections of 
the General tab on the GDT Setup Panel. 

7. If the GAAP GDP is an initial GDP for the airport, ensure the Initial GDP 
box is checked. Otherwise, enter a Last Revision End Time. This should be 
done by default. 

8. Select any Slot Hold Override that is necessary for the GAAP GDP. This 
only applies during a revision. 

9. Select any Sched/User Exemption that is necessary for the GAAP GDP. 
10. Select GAAP for the Delay Assignment Mode. 
11. Enter the Delay Limit appropriate for the GAAP GDP. The default value is 

60. 
12. Enter the appropriate AAR for the GAAP GDP on the AAR tab. 
13. Set the Scope for the GAAP GDP on the Tier/Dist tab. 
14. Select the Power Run you want FSM to use for this GAAP GDP. 
15. Click Model. 

The red border in the GDT Setup Panel disappears and all the GDT 
components reflect the modeled GAAP GDP. 

16. If the program appears to deal with the traffic flow in the manner you want, 
click Run to generate the Coversheet. 

The Coversheet window appears. 

17. Carefully examine each section of the Coversheet. If the data is correct, 
select the General checkbox and the Tier/Dist checkbox. 

18. Click Autosend on the Coversheet to send the parameters to the Hub site.  

19. Click Advisory on the Coversheet. 
      The Advisory window appears. 

20. Select either Proposed or Actual. 
21. Modify the Respond By time if Proposed was selected. 
22. Modify the Valid Until time if Proposed was selected. 
23. Select the Reason for the GAAP GDP. 
24. Enter the Explanation and any Comments as needed. 
25. Click Send. 

The unassigned slots for the GAAP GDP appear in the Time Line and Bar Graph components for 
the airport, an Unassigned slots block appears in the ADL, and an UNASSIGNED_SLOTS block 
appears in the FADT. 
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10 Monitoring GDP Delivery 
Introduction 
When a Ground Delay Program (GDP) is in effect, you want to monitor the progress of the 
program to ensure the program is affecting NAS operations in the intended manner. You also 
want to ensure that flights included in the program are complying with the program parameters. 
FSM generates various reports and statistics for monitoring a program’s progress.  

Monitoring GDP Delivery using the Time Line and Bar Graph 
Time Line Component 
During a GDP, it is easy to view the Time Line to get a general idea of how evenly the flights are 
distributed throughout an hour and of how many cancelled or delayed flights are in the program. 
Filled triangles represent delayed flights. Filled triangles appear on the Time Line only when a 
GDP is in effect. The filled triangle indicates an open arrival slot due to a delayed flight. ETMS 
leaves the arrival slot open and makes it available for use by other flights. Clicking this icon also 
highlights the associated delayed flight. 

The filled square icon appears only when a GDP is in effect and represents an arrival slot left 
open by a cancelled flight. Cancelled flights appear on the Time Line under the CNX heading and 
are highlighted when you click their associated slot. If there are numerous open slots, or solid 
triangles and squares, you may need to use a compression or revision to use the empty slots (see 
Error! Reference source not found.). 

The white diamond icon appears on the Time Line when a GDP with a GAAP delay limit is in 
place. This icon represents Unassigned Slots. As pop-up flights become known, EDCT assigns 
them to one of the unassigned slots or gives them an FA delay. 

Bar Graph Component 
During a GDP, use the Bar Graph component to view the distribution of flights, within each hour. 
To view how flights are distributed in smaller time increments, click on the 15 or 30-minutes bin 
selection buttons located below the Bar Graph menu bar. The thin, greu line displays the arrival 
flow rate, which illustrates the fluctuations of demand within the time-bins (see Figure 10-1). The 
default time increment is set to 60 minutes. In addition to viewing the flight distribution, you can 
view how many cancelled flights and unassigned slots are in the program. Select View > Show 
Cancellations to display the cancelled flights in cyan on the Bar Graph. Select View > Show 
Unassigned Slots to display unassigned slots in white during a GAAP GDP. 
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Figure 10-1: Bar Graph displayed in 15 minute Time Increments 

White sections of bars appear when a GDP with a GAAP delay limit is in place. These sections 
represent Unassigned Slots. As pop-up flights become known, EDCT assigns them to one of the 
unassigned slots or gives them an FA delay. 

Monitoring Effects on NAS Users 
You can open several reports from the Reports menu on the main Control Panel component. You 
can use these reports to monitor the affects of the GDP on NAS users. 

Surface Delay Report 
Select Reports> Surface Delay to generate a report that indicates the ground delay imposed on 
flights. The report contains departure information for both arriving and departing flights. This 
report is very similar to an FSM Flight List and allows you to view histograms of both Absolute 
Delay and ATC Delay. See Chapter 6 for more information on Flight Lists. 

Priority Flight List 
Select Reports > Priority Flights to view this report. This report identifies priority flights. It is 
similar to an FSM Flight List, but lists only those flights tagged as Lifeguard (LFG) or Diversion 
Recovery (DVT) flights. 

Time Out Delay List (Airline Only and General Aviation Users Only) 
Select Reports > Time Out Delay to view this report. The Time Out Delay Report quickly 
provides a picture of which flights from your operation are contributing to the Time Out delay 
problem. Easier access to this information should help you review and resolve the problem. The 
report is in the same format as FSM Flight Lists and includes all flights whose delay status is 
`TO.' 
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Time Out Cancel List (Airline Only and General Aviation Users Only) 
Select Reports > Time Out Cancel to view this report. The Time Out Cancel Report quickly 
provides a picture of which flights from your operation are contributing to the Time Out cancel 
problem. Easier access to this information should help you review and resolve the problem. The 
report is in the same format as FSM Flight Lists and includes all flights whose cancellation status 
is `TO.' 

Slot Hold 
Select Reports > Slot Hold to view this report. This report generates a flight list of all flights that 
are currently holding their cancelled slots. 

Sub Opportunities (Airline and General Aviation Users Only) 
Select Reports > Sub Opportunities to view this report. This report generates a flight list to 
assist airlines and general aviation customers in identifying subbing opportunities. Two columns, 
ERTA-CTA and SchedVar, have been added to illustrate the most eligible flights to be subbed. 

 
Figure 10-2: Sub Opportunities Report 

Slot List 
Select Reports > Slot List to view this report. The Slot List report generates the second part of 
the FADT List that FSM generates after a program runs. Included in the Slot List are the Aircraft 
Identification number (ACID), assigned slot time (ASLOT), departure center (DEP), controlled 
time of departure (CTD), controlled time of arrival (CTA), aircraft type (TYPE), exemption status 
(EX), cancellation status (CX), slot hold status (SH), earliest runway time of arrival (ERTA), and 
initial gate time of departure (IGTD). 
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When you select this report, a file selection window appears. Ensure the opened directory in the 
file selection window is the Reports directory. Enter a name for the file you want to generate and 
click Save. You can then use Utilities > View a File to open your saved slot list (see Figure 10-3). 

 
Figure 10-3: Reports > Slot List 

Carrier Statistics 
Select Reports > Carrier Statistics to view this report. The report shows delay statistics for all 
carriers with flights that operate at that particular airport. FSM calculates flights only with 
assigned arrival slots in the report metrics. That is, flights with a Control Time of Arrival (CTA) 
appear in carrier statistics. If a carrier operates at the airport, but has no flights with a CTA, the 
Carrier Statistics report displays “0” or “N/A” in those rows. You can choose the type of delay to 
view in the report by selecting the Delay Type of ATC or ABS at the top of the report. FSM 
selects the ATC delay type by default. ABS Delay is the absolute delay on a flight, including 
FAA and airline delay imposed on the flights. FSM calculates absolute delay using Max (0, ETA 
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- [IGTA - Taxi]). ATC Delay is the delay imposed only by the FAA on flights. FSM calculates it 
using Max (0, CTA - BETA). 

The report displays delay statistics for all carriers that operate at an airport. Carriers with no 
presence at the monitored airport do not show up in Carrier Statistics. 

 
Figure  10-4: Carrier Statistics 

For more information on the Carrier Statistics Report, See Chapter 19: Understanding and Using 
FSM Reports. 

Unassigned Slots Report 
The Unassigned Slots report shows all unassigned slots available for a GDP with a GAAP delay. 
You can use this report to track the availability of unassigned slots during the program. 

ETMS Unassigned Slots Report 
You can access the ETMS Unassigned Slots report from ETMS Tools>ETMS 
UNASSIGNEDSLOTS on the Control Panel and enter the airport identifier. This allows you to 
track the availability of unassigned slots in ETMS during a GDP with a GAAP delay limit. 

Monitoring Flight Compliance 
FSM generates Compliance List reports for monitored airports currently in a GDP. Under the 
Reports > Compliance > menu option on the main Control Panel you find five compliance 
reports: 

• By CTD 
• By ETE 
• By CTA 
• Spurious Flight 
• Cancel That Flew 

 
See Chapter 19: Reports for more information on Compliance Reports. 
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FSM updates the compliance reports automatically with every ADL for all airports for which 
FSM collects data. Compliance reports include only those flights arriving at the currently 
monitored airport. The list you generate is for the airport that you were last viewing, therefore 
ensure that the desired airport is active before selecting the Compliance report. The Compliance 
reports appear in the same format as all FSM Flight Lists, see Chapter 6 for more information on 
Flight Lists. 

Monitoring Program Parameters 
You can find the program parameter alerts for all monitored airports under the Alerts menu on 
the main Control Panel component. All monitored airports appear in alphabetical order under the 
Alerts menu. When ETMS updates an airport’s parameters, the Alerts menu is highlighted in red 
as well as the monitored airport and its corresponding updated parameters. Figure 10-5 shows 
ATL airport with FADT Parameters, SCS Bridge parameters, and Ground Stop Parameters 
updated. DTW has no updated parameters. Once you read the updated parameters, the parameter 
color returns to its original state. FSM lists the parameters of the airport currently active, on the 
main Alerts menu. Clicking on the other airports activates a pop-up box that displays the 
parameters for the selected airport. If you select another airport, the Alerts menu changes 
accordingly. 

 
Figure 10-5: Alerts Menu 

FADT Parameters Updated 
The Alerts > FADT Parameters Available menu option is highlighted in red when there is a 
new FADT. Selecting FADT Parameters Updated displays a pop-up window that lists the 
FADTs generated during the day for the selected airport in [ddhhmmss] format (see Figure 10-6). 
This option does not actually give you program parameters. FADTs are reports generated when 
you run a GDP, GS, Blanket, or a Compression operation. During a GDP with a GAAP Delay 
Assignment Mode, the FADT displays an Unassigned Slots block. 

Note: FSM does not always list the FADTs in chronological order. 

 
Figure 10-6: FADT Parameters Window 
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SCS Bridge 
Alerts > SCS Bridge is highlighted red in color when there is a new SCS update. Selecting SCS 
Bridge displays the Substitution Flag Block window, which displays the current subbing status 
(see Figure 10-7). The Substitution Flag Block may contain the following keywords: 

• SUBS: Indicates whether all substitutions are enabled (ON) or disabled (OFF) 
• SCS: Indicates whether slot credit substitutions for all operators are enabled (ON) or 

disabled (OFF) 
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• BRIDGING: Indicates whether bridging subs are disabled (OFF) for a particular 
operator (airline, GA, or MILITARY). If bridging is off for an airline, any flight that 
has a MAJOR field or carrier code (from ACID) that matches the airline name is not 
used for an SCS bridge. If bridging is enabled for an operator, no line appears, that is, 
the only allowed value for this keyword is OFF. 

 
Figure 10-7: SCS Flag Block Window 

Note: By default, Military and GA bridging is disabled. 

GDP Parameters 
Alerts > Actual GDP Parameters Available is highlighted in red when FSM receives Actual 
GDP Parameters through the ADL. First-time GDP Parameters, new GDP Parameters, and 
deleted GDP Parameters all trigger this Alert. Select Actual GDP Parameters Available to view 
the parameters that FSM takes from the FADT file and displays in a static GDT Setup window 
(see Figure 10-8). Tab navigation allows you to view all the parameters, although you cannot 
make changes to this window. If no Actual GDP Parameters exist, the text reads No Actual GDP 
Parameters. 

 
Figure 10-8: Actual GDP Parameter Display Window 

Alerts > Proposed GDP Parameters Available is highlighted in red when parameters for a 
Proposed GDP arrive through the ADL. Select Proposed GDP Parameters Available to view the 
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proposed parameters, which FSM takes from the FADT file and displays in a static GDP Setup 
window. Tab navigation allows you to view all the proposed GDP parameters, although you 
cannot make changes to this window. If no Proposed GDP Parameters exist, the text reads No 
Proposed GDP Parameters. 

GS Parameters 
Alerts > GS Parameters Active is highlighted in red when the FAA issues a Ground Stop and 
FSM receives its parameters through the ADL. First-time GS Parameters, new GS Parameters and 
deleted GS parameters all trigger this Alert. Select GS Parameters Available to view the 
parameters, which FSM takes from the FADT file and displays in a static GDP Setup window 
(see Figure 10-9). Tab navigation allows you to view all the GS parameters, although you cannot 
make changes to this window. If no GS Parameters exist, the text reads No GS Parameters. 

 
Figure 10-9: Actual GS Parameters Window 

Compression Parameters 
When FSM receives parameters for the compression function through the ADL, it triggers the 
Alerts > Compression Parameters Available. When Compression parameters arrive, 
Compression Parameters Available is highlighted in red for the corresponding airport. Select 
Compression Parameters Available to view the new parameters, which FSM takes from the 
FADT file and displays in a static GDP Setup window. Tab navigation allows you to view 
compression parameters, although you cannot make changes to this window. If no Compression 
Parameters exist, the text reads No Compression Parameters. 

Blanket Parameters 
When the FAA lifts or adds delay a ground delay program, FSM triggers the Alerts > Blanket 
Parameters Available. When FSM receives the message through the ADL to add or remove 
delay for all flights, it highlights the Blanket Parameters Available text in red. Select this menu 
option to view the new parameters, which FSM takes from the FADT file and displays in text 
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format in the Blanket Parameters window. If no Blanket Parameters exist, the text reads No 
Blanket Parameters. 

Parameters Block 
You can view the parameters block for a program by opening the static Parameter Display 
window from the Alerts menu on the Control Panel. From the Parameter Display window, select 
View> Parameters Block to see the parameter block for the program (see Figure 10-10). 

 

 

 

 
Figure 10-10: Parameters Block 

 

 

 

 

 

 

 

 

 

 

 

Note: For GDP programs with a Delay Assignment Mode of GAAP, the 
Parameters block includes Unassigned Slots information. 
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11 Monitoring EDCT Compliance 
Estimated Departure Clearance Time (EDCT) compliance impacts the success of a Ground Delay 
Program (GDP). Real-time monitoring of EDCTs is possible through both FSM and Real-Time 
FSA to identify problem areas as they occur, therefore reducing or eliminating EDCT compliance 
issues. This chapter introduces several options for monitoring EDCT compliance of a GDP. 

Using FSM to Monitor EDCT Compliance 
The FSM Control Panel contains 5 compliance flight lists:  

• CTA Compliance 

• Actual ETE vs. Original ETE Complíance 

• CTD Compliance 

• Spurious Flight Compliance 

• Cancel That Flew Compliance 

The functionality of compliance flight lists is identical to all other FSM Flight Lists. This chapter 
focuses on CTD compliance for monitoring EDCT compliance of a GDP. See Chapter 11 for 
more information on the other 4 compliance reports. 

To view a list of flights that had non-complaint EDCTs, select Reports > Compliance > CTD 
Compliance from the FSM Control Panel component. The CTD Compliance list includes all 
flights in a delay program that violate departure compliance. The default departure boundaries 
are: 

More than 5 minutes before their EDCT or more than 5 minutes after their EDCT. 
Any flight that has an ARTD of 5 minutes earlier or 5 minutes later than the most recent 
OrigEDCT appears in the Reports > Compliance > CTD Compliance list (see Figure 11-1). 

Note: Ensure that the airport for which you want to view the compliance report is 
active. If no airport is active, FSM displays an error message- “No current data 
set”. 

 
Figure 11-1: Accessing the CTD Compliance List 

When you open the CTD Compliance list, FSM does not display the CTD (or EDCT) field by 
default. The flights’ ACID, ETD, and ETA appear by default. The ETD has a prefix “A”, which 
indicates that the flights’ ETD is the Actual time of departure (see Figure 11-2). The total count 
of all CTD non-compliant flights appears in the lower left-hand portion of the CTD Compliance 
window. The CTD Compliance window automatically updates when FSM receives a new ADL. 
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Figure 11-2: CTD Compliance Window 

Viewing a Single Flight 
You can access more information on a single flight in two ways from the CTD Compliance 
window. Right-click on a single flight row or use the View menu. Right-click on a flight and 
select either Flight Info or Flight details for more information on the selected flight (see Figure 
11-3), or click on a single flight to highlight the entire row and then select File > Flight Info or 
Flight Details to access the same information. 

 
Figure 11-3: Accessing Flight Information 

Adding ADL Fields 
Adding ADL fields in the CTD Compliance Report is the same as adding fields to the Flight List. 
For more information see Chapter 6: Viewing Flight Information. 

Column Positioning 
Column positioning in the CTD Compliance Report is the same as column positioning in the 
Flight List. For more information see Chapter 6: Viewing Flight Information. 
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Sorting Information in the CTD Compliance List 
Sorting Information in the CTD Compliance Report is the same as sorting information in the 
Flight List. For more information see Chapter 6: Viewing Flight Information. 

Multi-level Sorting 
Multi-level sorting in the CTD Compliance Report is the same as multi-level sorting in the Flight 
List. For more information see Chapter 6: Viewing Flight Information. 

Compliance List Menu 
The menu bar in the Flight List component contains four options: File, View, Flight List and 
Help. The functionality of compliance flight lists is identical to all other FSM Flight Lists. 

1. File Menu 

• File > Save as – Saves the Compliance List to a text file, which you can open 
later and use again. 

• File > Print – Prints the Compliance List information viewed on the screen. 

• File > Close – Closes the Compliance list window. 
2. View Menu 

• View > Rename window – Displays the Rename Window dialog box and 
allows you to change the title bar name. 

• View > Select Data Columns – Allows you to add or delete ADL data fields 
to the Flight List. 

• View > Group Flights – Allows you to group ADL data fields to the Flight 
List in ascending or descending order. 

• View > Sort Flights – Allows you to sort ADL data fields to the Flight List 
in ascending or descending order. 

• View > Apply Filter – Allows you to apply a filter to the data fields in the 
Flight List. 

• View > Clear Filter – Allows you to clear a filter from the data fields in the 
Flight List. 

• View > Flight Info – Opens the Flight Info window. 

• View > Flight Detail – Opens the Flight Detail window. 
3. Flight List Menu 

• Flight List > Set Time – Sets the time for the Flight List component in 
Historical mode only. 

• Flight List > Search by Call sign – Opens the Search by Call sign window. 
4. Help Menu 

• Help > CTD Compliance – Accesses the web-based on-line help for CTD 
Compliance. 
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Confirming an EDCT 
The ETMS Tools > EDCT Commands > EDCT Check option is available from the Control 
Panel and displays an unfilled EDCT Check dialog box. To confirm a flight’s EDCT, type in the 
flight’s call sign, its Origin and Destination Airport, and then click Send. In addition to using the 
ETMS Tools menu, right-clicking on a single flight icon in the Time Line or flight row in any 
FSM Flight List window opens a pop-up window that allows you to select EDCT Check to 
display the EDCT Check dialog box. The right-click method automatically populates the flight 
information (see Figure 11-4). Click Send to submit the request to ETMS. ETMS then sends a 
response with the flight’s current EDCT. 

 
Figure 11-4: EDCT Check Dialog Box 

Adjusting an EDCT 
If you are an ATCSCC specialist and you select the ETMS Tools > EDCT Command > EDCT 
Check option from the main Control Panel, you can adjust the control times for individual flights. 
This command displays an unfilled EDCT Update dialog box. You must type in the flight’s call 
sign, Origin and Destination Airport, IGTD, and updated control times. You can also update 
EDCTs through the ECR component, see Chapter 12 for more details. 
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In addition to using the ETMS Tools menu, right-clicking on a single flight in the Time Line or 
Flight List window displays a pop-up menu that allows you to select EDCT Update to open the 
EDCT Update dialog box. The right-click method automatically populates the flight’s 
information, requiring you to fill in only the new control times for the flight (see Figure 11-5). 
Click Send to submit the update to ETMS. ETMS then sends a response confirming the fight’s 
new EDCT, which appears in the next ADL. 

 
Figure 11-5: EDCT Update Dialog Box 
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12 EDCT Change Request (ECR) 
The EDCT Change Request (ECR) tool is part of the FAA's CDM Ground Delay Program 
Enhancements (GDPE) effort. ECR has been operational at the FAA's ATCSCC since April 
2002. ECR displays current flight information using real-time data culled from CDM participants 
and aggregated by the Hub site. It allows you to change Estimated Departure Clearance Times 
(EDCTs) for GDP controlled flights and keep traffic flowing as smoothly as possible. 

Prior to the ETMS 7.9 release, only the ATCSCC had access to ECR. With the release of 7.9, 
ECR is now available for all CDM participants, although non-ATCSCC user functionality is 
limited to the use of the SCS request option. Only ATCSCC users can access the Limited, and 
Manual EDCT UPDATE selections. The Unlimited option is available only to ATCSCC and the 
FAA Field facilities. ECR grays out these options for all other users. 

The ECR component allows you to search for a flight, view current flight information, model 
suggested update times for flights, and display options for updating control times. The ECR title 
bar displays the Airport, date, ADL time, and monitor mode (see Figure 12-1). 

 
Figure 12-1: ECR Component 
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ECR Menu Bar 
The ECR menu bar contains three options: File, View, and Help. 

1. File menu: 

• File > Close – Closes the ECR component. 

2. View menu: 

• View > Rename Window – Displays the Rename Window dialog box that 
allows you to change the component name of the title bar. Enter the desired 
component name then click OK to change the title bar heading. Click Cancel 
to close the Rename Window dialog box without making any changes. 

3. Help menu: 

• Help > ECR - Accesses the web-based on-line help for the ECR component. 

Opening ECR 
You can use three methods to open ECR – namely two menu options from the Control Panel and 
the third option from the Time Line. 

1. Ensure that the correct Dataset is active before opening ECR. 
2. Click ECR from the Control Panel. Figure 12-2 displays the ECR component 

being opened for ATL. 

 
Figure 12-2: Opening ECR from the Control Panel 

3. Select Utilities > ECR from the Control Panel. 
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4. Right-click on a flight icon in the Time Line and select ECR from the pop-
up menu (see Figure 12-3). The ACID, ORIG, and flight information 
automatically display in the ECR component when you open it from the 
Time Line. 

 
Figure 12-3: Opening ECR from the Time Line 

Locating a Flight 
To begin updating an EDCT, enter a flight ACID in the ECR window. Verify that both the three-
letter airport identifier (Airport) and the last ADL Update time (ADL Update) for the correct 
airport appear in purple text, as shown in Figure 12-4. You can use two methods to find a flight in 
ECR: 

1. Open ECR from the Time Line by right-clicking a flight icon and selecting 
the ECR option. ECR automatically finds flight information and populates 
the appropriate fields in the ECR component. 
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2. Enter a flight’s aircraft identifier in ACID and click Find Flight. 

 
Figure 12-4:  Updating an EDCT using ECR 
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Viewing Flight Information 
After ECR finds a flight, the current information appears under the Flight Information section. 
The table below illustrates the fields listed in the current data section. 

Current Data 
IGTD Initial gate time of departure IGTA Initial gate time of arrival 

CTD Current control time of departure CTA Current control time of arrival 

ETD Estimated time of departure ETA Estimated time of arrival 

ETE Estimated time en route 

ERTD Earliest runway time of departure ERTA Earliest runway time of arrival 

Updating an EDCT for a Flight 
After finding and displaying the flight’s current information, enter the flight’s new Earliest 
EDCT in the Find Flight section of the ECR component. 

1. Type the earliest EDCT to which the flight can comply in Earliest EDCT. 
2. Select one of the five options listed in ECR Reason as the general reason for 

the EDCT update; either: 

• ACFT_OPR: aircraft operator; default selection 

• Equip: equipment 

• TMI:  traffic management initiative 

• Wx: weather change 

• Other: Reason not previously listed 

3. Click Apply Model to populate the Update Criteria section and to model 
different update parameters based on the new Earliest EDCT data. 

Update Criteria 
E_CTD New earliest CTD requested CTA Range Interval between the New 

Earliest CTA and the sum of 
the New Earliest CTA and 
Maximum Additional Delay 

4. Select the desired update option (SCS Request, Unlimited, Limited, or 
Manual). FSM selects the SCS radio button by default (customers other than 
the ATCSCC only have the SCS request as an option). 
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5. Click Send Request to send the request to the Hub site (see Error! 
Reference source not found.). 

 
Figure 12-5: EDCT Update 

Update Options 
There are four options for updating an EDCT using ECR: SCS Request, Unlimited, Limited, and 
Manual. Only the SCS Request option is available for all users. The Limited, and Manual 
options are for ATCSCC use only. The Unlimited option is available only to ATCSCC and the 
FAA Field facilities. 
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• SCS Request – The ECR tool sends a Slot Credit Substitution (SCS) request 
via a Simplified Subs Packet to ETMS, using the window reflected in the 
CTA range. FSM selects the SCS Request option by default. 

Note: You can use SCS only when you request a later EDCT. If the New Earliest 
EDCT is before the current CTD, FSM grays out the SCS radio button. 

• Unlimited – The ECR tool shows the EDCT, CTA, and the delay past the 
New Earliest CTA for the optimal EDCT update for between the New 
Earliest CTA and the last CTA of the program (Field and ATCSCC use 
only). 

• Limited – The ECR tool shows the EDCT, CTA and delay past the New 
Earliest CTA for the optimal EDCT update within the CTA range (ATCSCC 
use only). 

• Manual – You can input an EDCT in the space provided (DD/ hhmm) and 
the ECR tool calculates the CTA by adding the flight’s ETE (ATCSCC use 
only). 

Viewing SCS Response 
After requesting a Slot Credit Substitution (SCS), the hub site sends back a response . If the SCS 
request is successful, the response is a slot list of the flights affected including new control times 
and control types (see Figure 12-6). 

 
Figure 12-6: SCS Response 

Control Types Associated with ECR 
Control Type Control Time Change Origin 
ECR SCS Request submitted by the ATCSCC 

SCS SCS Request submitted by all customers other than 
ATCSCC (airline user or general aviation customers) 

UPD ATCSCC EDCT update (Changes made by Unlimited, 
Limited, or Manual options) 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


  EDCT Change Request (ECR) 

Version 7.9 12-8 

BRG Bridged up to accommodate an SCS request 
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13 Revising/Extending a Ground Delay Program 
Once a Ground Delay Program (GDP) is already in place, the conditions that originally 
necessitated the GDP may change. The weather may improve or get worse, a runway may shut 
down or its’ configuration change, the AAR may increase or decrease, or the demand may have 
changed since the original program was issued. When these cases arise, you may find it necessary 
to revise the original program. 

Getting Current Demand and Weather Information 
Before you revise, you want to ensure you have the most current ADL. From the FSM Control 
Panel component, select ETMS Tools > ADL Request. Enter the three-character airport ID in 
the ETMS ADL Request Dialog box and click Send, as shown in Figure 13-1. FSM sends the 
request immediately to ETMS and all live mode windows for that airport update when FSM 
receives the new ADL. 

 
Figure 13-1: ETMS ADL Request and ETMS ADL Request Dialog Box 

You also want to ensure you have the most recent weather information. Select ETMS Tools > 
Weather Request from the Control Panel. ETMS Weather is the option directly above the ADL 
Request (see Figure 13-1). Enter the three-character airport ID (for multiple airport weather 
reports, enter airport identifiers separated by spaces or commas) in the ETMS Weather Dialog 
box (see Figure 13-2). FSM sends the request immediately to ETMS and the current METAR and 
TAF appear in a text window on your screen. 

 
Figure 13-2: ETMS ADL Request and ETMS ADL Request Dialog Box 

Deciding When to Revise a Program 
There are several tools available to help you decide if a revision is necessary. The Live Time Line 
and Bar Graph components allow you to visually compare the airports capacity (AAR) vs. its 
demand. If the Time Line shows a large number of delayed flights (solid triangles) or cancelled 
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flights (solid squares) and/or the Bar Graph shows that demand is under or over the AAR for 
certain hours, a revision helps to reallocate the slots. When a revision is necessary, the FSM 
Power Run Tab in the GDT Setup component is helpful for analyzing different options (see 
Chapter 8 for more information on how to use Power Run). 

Revising a GDP 
You can change a number of parameters during a revision to meet the change of conditions at the 
airport being monitored. For example, you may need to revise any one or combination of the 
following parameters: you may need to increase/decrease the AAR, increase/decrease the number 
of centers involved, expanded/reduced the distance range of the GDP, revise from a GAAP GDP 
into a normal GDP, or extend the length of the program. To change any of the program 
parameters, open the airport in GDT mode. To load the current parameters select File > Load 
Actual Parameters > Ground Delay Program in the GDT Setup component. Ensure that, when 
issuing a revision that the Last Revision End time on the General Tab is filled in and the Initial 
GDP checkbox is unchecked. . 

Modifying the AAR 
Select the AAR Tab in the GDT Setup component. The current AAR appears for the hours of the 
current program. To increase/decrease the AAR, use either the Fill method or change each hour 
manually. To review the AAR Tab, see Chapter 3: Understanding Components. 

Reducing/Expanding the Scope 
You can reduce or expand the scope with Tier and Distance based GDPs. Select the Tier/Dist 
Tab, and select either Exempt By Tier or Distance. If you prefer to use the Tier based GDP, you 
can select a new center group or manually add or delete centers by selecting the center 
checkboxes. Newly selected centers are now included (receive departure delay) in the program. If 
you release a center from program delay, the flight originating from that center runs through the 
release delay algorithm. FSM adjusts distance based programs based on the distance radius. You 
can expand the distance range to capture more airports in the program or decrease the distance 
radius to release delay on previously delayed airports. 
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Extending the Program 
To extend the program, change the Duration time from the General Tab or click and drag the 
End Time slide bar to adjust the duration. You can extend the program without changing any 
other parameters or you can extend the program in conjunction with any other number of 
parameter modifications, as shown in Figure 13-3. 

 
Figure 13-3: Modifying the Program Duration 
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Revising a GAAP GDP 
To revise a program from a GAAP GDP to a normal GDP, change the Delay Assignment Mode 
on the General tab from GAAP to DAS.  Click Select next to Schd/User Exemtions to open the 
Exempt Scheduled window to exempt scheduled or user groups from departure delay during the 
revision as needed.    

 
Figure 13-4: Sched/User Exemptions 
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Sending a Proposed Parameters Advisory 
After modifying the parameters of the GDP and if the modeled results are favorable, it is 
recommended that you send out a Proposed Advisory. A Proposed GDP revision is a program 
suggested by the FAA, but not immediately implemented. Click Run from the GDT Setup panel 
to open the GDP Coversheet. Review the parameters and then click Advisory. Fill out the 
Advisory window Remarks section and ensure that you select the Proposed radio button (see 
Figure 13-5). Click Send to distribute the proposed parameters to all FSM users. A Proposed 
GDP revision allows NAS users enough time to comment on the proposed parameters even 
though they may change before the FAA implements an actual program. 

 
Figure 13-5: GDP Advisory Window 
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Suspend Airline Substitutions and Slot Credit Substitutions 
Now you are ready to issue the revised GDP but before issuing the revision, you need to suspend 
the acceptance of airline substitutions and Slot Credit Substitutions (SCS) messages temporarily. 
From the FSM Control Panel, select the ETMS Tools > ECDT Commands > EDCT Sub Off 
option to turn substitutions off, as shown in Figure 13-6. Enter the three-character airport ID into 
the EDCT SubOff dialog box and click Send to suspend substitutions for that airport. Airlines’ 
substitution or SCS messages are no longer accepted after FSM sends the SubOff message to 
ETMS. 

 
Figure 13-6: Turn Subs OFF 

Issuing the Revision 
Once you have determined the program parameters for an Actual GDP and you have turned off 
the substitutions, there are two steps to enact the program and send the parameters out through the 
ADL. ETMS does not send program parameters for an Actual program through the ADL until it 
receives both the program parameters (through an Advisory) and a matching FADT list 
(Autosend) with flight control times.  

Click Run from the GDT Setup component to open the GDP Coversheet with the revised 
parameters. Send the Advisory and click Autosend from the Coversheet to implement the 
revision. 
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If you leave SUBS turned ON when you click Autosend from a coversheet during a 
compression, revision, or extension, you receive an FSM warning message that instructs you to 
“Turn SUBS OFF, reload and remodel the program…” (see Figure 13-7). Click OK to clear the 
FSM warning and then turn SUBS OFF before reloading and remodeling the program. Wait for 
SUBS OFF to be reflected successfully before clicking Autosend again. 

 
Figure 13-7: SUBS OFF Warning 

Although it is recommended that you turn SUBS OFF during any revision, you can bypass the 
warning message by clicking Ignore from the message box. Click Ignore to clear the FSM 
warning and FSM automatically continues with the Autosend process even though SUBS are ON. 

Completing a revision is similar to sending an initial GDP, see Chapter 9 for more detail. 

Example Revision 
The section below is an example of how to revise a GDP with a GAAP Delay Assignment Mode 
to a DAS Delay Assignment Mode. If you change Delay Assignment Mode to DAS, all 
unassigned slots are removed from the program and from the ADL and FADT. 

To revise a GDP with a GAAP Delay Assignment Mode 

1. Click Open Data Set. 

The Open Data Set window appears. 

2. Select the airport for which you want to revise the GDP with a GAAP Delay 
Assignment Mode. 

3. Click OK. 

The Time Line and Bar Graph components for the airport appear. 

4. Click GDT Setup. 

The GDT components for the airport appear. Select File > Load Actual 
Parameters > Ground Delay Program to load the current parameters for 
the airport. Ensure that, when issuing a revision that Initial GDP in 
unchecked and the Last Revision End time is entered correctly on the 
General Tab.  This is done by default. 

5. Select DAS from the Delay Assignment Mode. 

 
6. Make any additional changes to the program that are needed. 

Note: If  you change the Delay Assignment Mode to DAS from GAAP, 
all unassigned slots are removed from the FADT, ADL, and from the FSM 
components. 
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7. Select the Power Run you want FSM to use for this GDP. 
8. Click Model. 

The red border in the GDT Setup Panel disappears and the GDT components 
reflect the modeled GDP. 

9. If the program appears to deal with the traffic flow in the manner you want, 
click Run to generate the Coversheet. 

10. Carefully examine each section of the Coversheet.  If the data is correct, 
select the General checkbox and the Tier/Dist checkbox. 

11. Click Autosend on the Coversheet to send the parameters to the Hub site.  
12. Click Advisory on the Coversheet. 

      The Advisory window appears. 

13. Select either Proposed or Actual. 
14. Modify the Respond By time if Proposed was selected. 
15. Modify the Valid Until time if Proposed was selected. 
16. Select the Reason for the GDP revision. 
17. Enter the Explanation and any Comments as needed. 
18. Click Send. 
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14 Issuing a Compression 
At certain times during a GDP, you may find it favorable to run a Compression. The Compression 
function exchanges delayed flights with open slots to lessen the delay on those flights. 
Compression attempts to fill all available arrival slots with flights that, although delayed from 
their OETA, can still arrive at the available slot time. Compression tries to place flights from the 
same airline that created the slot in the new arrival slot, however, if this is not possible, it uses 
other airlines’ flights to fill the arrival slots. A pure Compression can be beneficial to the 
performance of a GDP when there is limited pop-up traffic and non-compliance issues with 
flights in the stack hours. 

Suspend Airline Substitutions and Slot Credit Substitutions 
Before opening up GDT mode to issue a Compression, you need to suspend, temporarily, the 
acceptance of airline substitutions and Slot Credit Substitutions (SCS) messages. From the FSM 
Control Panel, select the ETMS Tools > EDCT Commands > EDCT Sub Off option to turn 
substitutions off. Enter the three-character airport ID into the EDCT SUB OFF dialog box and 
click Send to suspend substitutions for that airport. Airlines substitution or SCS messages are no 
longer accepted by ETMS after FSM sends the EDCT Sub Off message to ETMS (see Figure 
14-1). 

 
Figure 14-1: Turn Subs OFF  

Open GDT Mode 
Open Ground Delay Tools (GDT) mode by selecting a GDP monitored airport and then clicking 
GDT Setup from the Control Panel. The four default GDT components automatically appear for 
the selected airport. To perform the Compression function, select the Program Type > 
Compression option from the FSM GDT Setup component. 

Note: The GDT Data Graph is blank and displays “Power Run Not 
Available” when you select the Program Type Compression. 
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When you select the Program Type Compression, the General tab is the only tab available for 
entering parameters, as shown in Figure 14-2. 

 
Figure 14-2: Compression Setup 
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Entering Parameters 
On the General Tab, adjust the time range by clicking and dragging the pointers on the Start and 
End time lines or by entering a new time (ddhhmm) in the textboxes. When you select the 
Compress To End checkbox, the end time and duration fields remain empty. Compress to End 
indicates that FSM includes all flights with control times in the Compression. When you deselect 
Compress to End, FSM automatically fills in the current End time and duration. The Slot Hold 
Override functionality is available during Compression. Click Select to review the slots held (see 
Figure 14-3).  

 
Figure 14-3: Compression GDT Setup Panel 

For more information on the GDT Setup Panel, see Chapter 3 Understanding Components. 

Issuing the Compression 
Once you turn off the substitutions and you model the Compression, there are two steps to enact 
the Compression and send the parameters out through the ADL. Volpe does not send 
Compression parameters for an Actual program through the ADL until it receives both the 
Autosend FADT List with flight control times and the matching program parameters (through an 
Advisory). Not until it receives both sets of parameters does it send the program parameters and 
control times through the ADL and the program implemented. 

Note: Compressions will ignore all unassigned slots if the GDP has a 
Delay Assignment Mode of GAAP. 
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Run to Generate the Compression Coversheet 
Click Run after you complete your Compression setup and model it from the GDT Setup 
component. Clicking Run saves the parameters to a file specified in FSM’s configuration file and 
causes the Compression Coversheet to appear on the screen. Clicking Run also generates two 
coversheet reports, a FADT and Analysis Report, which you can view by selecting View > 
FADT or View>Analysis Report from the Coversheet. 

Note: If you modeled the Compression or there is enough information that you 
do not need to complete a new model, the red border around the GDT Setup 
Panel does not appear and Run is enabled. If you change any significant 
parameter in the GDT Setup component, you must click Model first, and then 
click Run. 

The Compression Coversheet contains all the Compression parameters data. After reviewing the 
Compression parameters, you need to send both Autosend FADT control times and an Advisory 
from the Compression Coversheet to implement an actual Compression (see Figure 14-4). 

 
Figure 14-4: Compression Coversheet 

Reviewing the program parameters is important before issuing the Compression. For more 
information about the Compression Coversheet, see Chapter 3 Understanding Components. 
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Issuing a Compression through Autosend 
Click Autosend from the Compression Coversheet to send the FADT file to all users, including 
airlines. 

Note: If you select Advisory or Autosend more than 15 minutes after switching 
to GDT Setup, FSM warns you to return to the GDT Setup component and click 
Reload before continuing with the Compression. This retrieves the most recent 
data from an updated ADL. 

If SUBS are ON when you click Autosend from a coversheet during a compression, revision, or 
extension, you receive the following FSM warning message (see Figure 14-5 Error! Reference 
source not found.). 

 
Figure 14-5: SUBS OFF Warning 

Click OK to clear the FSM warning and then turn SUBS OFF before reloading and remodeling 
the program. Wait for FSM to reflect SUBS OFF successfully before clicking Autosend again. 

Although it is recommended that you turn SUBS OFF during any revision, you can bypass the 
warning message by clicking Ignore on the message box. FSM automatically continues with the 
Autosend process even though SUBS are ON. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Issuing a Compression 

Version 7.9 14-6 

Send the Advisory 
To compose either an Actual or Proposed Compression Advisory, click Advisory from the 
Compression Coversheet and the Compression Advisory window appears (Figure 14-6). This 
window contains all the Compression parameters, which you set and some fields in the Remarks 
sections that you must fill out before sending an Advisory. 

 
Figure 14-6: Compression Advisory Window 

For more information about the Advisory component, see Chapter 3 Understanding Components. 
You must fill out the remarks section before sending an Advisory. You must select either 
Proposed or Actual to send the appropriate Advisory. 

Once you have completed the Compression Advisory, click Send and FSM emails the program 
parameters to all parties involved in the program, including the Volpe Hub. A checkmark appears 
next to the Send button on the Advisory window and next to the Advisory button on the 

Compression Coversheet to indicate that you sent the advisory.  

If the parameters are for a Proposed Advisory, Volpe sends out the parameters immediately in the 
next ADL. If the parameters are for an Actual Advisory, Volpe ensures that it has received the 
associated FADT file (Autosend) with flight control times for the program before sending any 
parameters through the ADL. 

When you click Close, FSM takes no action from the Compression Advisory window. 

Coversheet Reports 
FSM creates three Coversheet reports: 
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• FADT report 
• Analysis report 
• Carrier Statistics report 

For more information on these reports, see Chapter 19: Understanding and Using FSM Reports. 
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15 Deciding When to Use a Compression or Revision 
After the FAA issues an initial GDP, the airport’s demand and/or capacity fluctuate and a 
Compression or Revision may be necessary to control the traffic flow into the airport. Monitor the 
GDP delivery (see Chapter 11) to determine if demand continues to exceed capacity and decide 
whether a Compression or Revision may be necessary. 

Deciding When to Use a Compression 
Compression may be the best operation when you do not want to extend the GDP or change the 
AAR and a large number of cancelled flights with slots ahead of operational flights occur in the 
stack hours. The Stack hours are the stack of flights after the end time of the GDP. You can easily 
identify the number of cancelled flights in a stack hour by looking at the FSM Bar Graph. Select 
the View > Show Cancellations checkbox on the Bar Graph to view all cancelled flights. Rolling 
your mouse over the cyan colored flights displays a tool tip with the number of cancelled flights 
for that hour. Figure 15-1 illustrates numerous cancelled flights ahead of operational flights in the 
stack hours (2300-0100). 

 
Figure 15-1: Stacked Hours 

You can also get a quick visual idea of where the cancelled flights (squares) and delayed flights 
(triangles) are from the FSM Time Line. If a large number of squares appear throughout the 
program time, issuing a compression is helpful for reallocating operational flights to the slots held 
by the cancelled flights. 

Running Compression with End Time of 9999 decreases delay on the operational flights and 
moves the cancelled flights to the end of the program. Compression can reduce both the total 
delay and average delay of a GDP. For more information on Issuing a Compression, see Chapter 
14: Issuing a Compression. 
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Deciding When to use a Revision 
Use a Revision when you want to extend the End Time, change the program’s AAR, or change 
the scope of the program. In cases where you do not want to modify the program parameters but 
several pop-up flights exist, a Revision may be the most favorable option. A Revision captures 
the pop-up flights in the system and assigns them control times, where as a Compression only 
captures controlled flights already included in the current GDP. 

Note:  The guidelines mentioned above are not procedures; see the FSM 
Handbook for procedural guidelines. 
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16 Airborne Holding and Blanket Programs 
Using Airborne Holding 
Traffic management specialists use Airborne Holding to determine the necessity of a GDP. In 
certain situations, putting delay on flights en route may be a better option than delaying flights on 
the ground. The airborne holding algorithm in FSM produces the amount of expected airborne 
holding delay, defined as ASLOT - ETA, which would result from running a program. 

To run the Airborne Holding algorithm, select the Program Type Airborne Holding option from 
the GDT Setup component. Selecting the Airborne Holding option enables only the General and 
AAR tabs. Using the two tabs, you need to fill out the parameters of the air traffic scenario you 
want to model. The only input parameters for Airborne Holding are the General tab’s Start and 
End times and the AAR tab parameters. 

Selecting General Tab Parameters 
From the General Tab, specify the Start and End times of the program. All other fields are 
disabled, as shown in Figure 16-1. 

 
Figure 16-1: Airborne Holding General Tab 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Airborne Holding and Blanket Programs 

Version 7.9 16-2 

AAR Tab Modifications 
Click on the AAR tab to enter the reduced AAR for that airport on which to base your Airborne 
Holding Model. 

 
Figure 16-2: Airborne Holding AAR Tab 

For more information on the AAR tab, see Chapter 3: Understanding Components. 

Airborne Holding Reports 
Running the Airborne Holding algorithm generates two reports: Airborne Holding Flight List and 
Carrier Statistics. The Airborne Holding Flight List appears automatically when the Program 
Type Airborne Holding is Run, as shown in Figure 16-3. 
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Airborne Holding Flight List 

The Flight List contains information for all flights that meet the operation parameters. The Flight 
List includes ASLOT, which is the arrival slot the flights use, and ASLOT – ETA, which is the 
amount of expected airborne holding delay. For more information on the Flight List Format, See 
Chapter 6 Viewing Flight Information. 

 
Figure 16-3: Airborne Holding Flight List 
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Carrier Statistics 
The Carrier Statistics Based on ETA After GDP (Airborne Holding) displays specific delay 
information for each carrier’s flights. The Carrier Statistics report is arranged in several columns 
for easy access to important information. The Carrier Statistics report appears automatically when 
you run the Program Type Airborne Holding, as shown in Figure 16-4. 

 
Figure 16-4: Airborne Holding Carrier Statistics 

For more information on the Carrier Statistics report, see Chapter 19:Understanding and Using 
FSM Reports. 

Using a Blanket Program 
You can use the Blanket program to revise any GDP. Before you revise, ensure you have the 
most current ADL and weather information. From the Control Panel, select ETMS Tools > ADL 
Request or Weather Request (see Chapter 13: Revising a GDP for more information). Use the 
Blanket program to add or subtract a fixed number of minutes to or from an FAA-imposed delay. 
Do not use Blanket in conjunction with a GS. You should use a Blanket program only if you do 
not need to adjust the airport’s AAR. 

Select Program Type of Blanket from the GDP Setup component’s General tab, as shown in 
Figure 16-5. Each ground-delayed flight has an associated slot time. Use this IGTA-based slot 
time to determine whether to include a flight in the Blanket program. The slot time is adjusted by 
the requested minutes of delay. Should the airline-delayed flight’s position be earlier than the new 
slot time, the program moves the airline-delayed flight to the newly assigned slot time. The 
program moves the open slots due to the delay and cancellation accordingly. 
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When you use the Blanket Program, only the General and Tier/Dist tabs are available for entering 
parameters. The two tabs are almost identical to other program types with the exception of the 
additional Adjust Delay feature on the General tab. 

 
Figure 16-5: Blanket Delay Program Type 

For more information on the GDT Setup component, see Chapter 3: Understanding Components. 
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Blanket Coversheet 
To view the effect that the entered parameters have on operations; click Run on the GDT Setup 
component. The Run option generates the Blanket Coversheet. To view the analysis of the 
generated Blanket delay, select View > Analysis in the opened Blanket Coversheet window, as 
shown in Figure 16-6. 

 
Figure 16-6: Blanket Coversheet 
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Sending a Proposed Parameters Advisory 
After specifying the Blanket parameters and if the modeled results are favorable, it is 
recommended that you send out a Proposed Advisory. A Proposed Blanket revision is a program 
suggested by the FAA, but not immediately implemented. Click Run from the GDT Setup to 
generate the Blanket Coversheet. Review the parameters and then click Advisory to open the 
Blanket Advisory window (see Figure 16-7). 
Enter the reason for the revision and the time when you will turn subs off in Advisory window 
Remarks section and select Proposed. Click Send to distribute the proposed parameters to all 
FSM users. A Proposed Blanket revision allows NAS users enough time to comment on the 
proposed parameters even though they may change before the FAA implements an actual 
program. 

 
Figure 16-7: Blanket Advisory 
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Suspend Airline Substitutions and Slot Credit Substitutions 
Before issuing the Blanket program, you need to suspend the acceptance of airline substitutions 
and Slot Credit Substitutions (SCS) messages temporarily. From the FSM Control Panel, select 
the ETMS Tools > EDCT Commands > EDCT Command >EDCT SubOff sub menu option 
to turn all substitutions off. Enter the three-character airport ID into the EDCT SubOff dialog box 
and click Send to suspend substitutions for that airport. Airline substitution or SCS messages are 
no longer accepted after FSM sends the Sub Off message to ETMS. 

 
Figure 16-8: Turn Subs OFF and ECDT Sub Off Dialog Box 

Issue a Blanket Program 
Implementing a Blanket program is very similar to sending out a GDP Program or Revising a 
GDP program. Once you are satisfied with the Blanket parameters and you have turned 
substitutions off, there are two steps to enact the program and send the parameters out through the 
ADL. Volpe does not send out the program parameters for an Actual program through the ADL 
until the Hub site receives both the program parameters (through an Advisory) and a matching 
FADT list (Autosend) with flight control times. Only when Volpe receives both sets of 
parameters does it send the program parameters and control times through the ADL at which 
point it implements the program. 

Select Run from the GDT Setup Component to open the Blanket Coversheet with the revised 
parameters. Send both the Advisory and Autosend from the Coversheet to implement the 
Blanket revision. For more information on sending an Advisory and Autosend from the 
Coversheet, see Chapter 9: Issuing an Initial Ground Delay Program. 

Note: Blanket programs ignore all unassigned slots if the GDP has a 
Delay Assignment Mode of GAAP.From the Coversheet, click Autosend. 

FSM sends the program parameters and the EDCT portion of the FADT file to the Hub site when 
you click Autosend. However, the Hub site does not include this information in the incoming 
ADLs until the Hub site receives a matching Advisory as well. 

To send an Actual Advisory (i.e., to match a FADT file sent for an actual program), click 
Advisory from the Coversheet. This brings up the Blanket Advisory window. FSM selects 
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Proposed by default when you first open the Advisory window, therefore you must select Actual. 
The actual Blanket Advisory window requires that you fill out the Reason before sending it. 

 
Figure 16-9: Actual Advisory 
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17 Issuing a Ground Stop 
Unlike ground delay programs, which delay flights because of a reduced AAR, the GS 
Immediate, and GS Future function prevents flights from departure until further notice. In FSM, 
the GDT Setup Component is identical for all Traffic initiatives, with active tabs and fields 
differentiating among program types. The GS Modifications tab is active for both types of 
Ground Stop (GS) programs. During a Ground Stop, ETD is checked against the Start  time and 
End time to determine whether to include the flight in the GS. (In a GDP, times are checked 
against a flight’s ETA). Flights included in the GS program are assigned a new ETD one minute 
after the GS End time. The flight’s new ETAs are assigned based on the flights’ Original ETE. 
For example, if the GS period is 1320-1419, flights with an ETD between 1320 and 1419 have a 
new ETD of 1420. The new ETA is the New ETD + Orig. ETE. 

There are two types of GS programs: 

• GS Immediate – GS Immediate issues the program immediately and you 
should use Exempt By Departure Status during this program type. 

• GS Future – Issue this GS for a specific time in the future and you should 
use Exempt By Departure Time should be used during this program type.  

Selecting the Parameters 
Open any monitored airport in Ground Delay Tools (GDT) mode by clicking GDT Setup on the 
Control Panel component. If an airport is not active when you click GDT Setup, an FSM error 
message indicates “No current data set” selected. When the four GDT components open, select 
the Program Type GS Immediate or GS Future from the GDT Setup component. 
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Figure 17-1: GDT Mode Display 

Once you select the appropriate Program Type, you are ready to set the necessary parameters 
through each of the tabs of the GDT Setup component. 
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General Tab Parameters 
In the General Tab, you can adjust the Program Time, the Arrival Fix, Aircraft Type, and 
Carriers you want to include in the GS  program time (see Figure 17-2) by clicking and dragging 
the pointers on the Start and End time lines or by entering a new time (ddhhmm) in the 
textboxes. If you do not indicate changes for Arrival Fix, Aircraft Type, or Carrier, the default is 
set to include All. 

 
Figure 17-2: GDT Setup General Tab 

AAR Tab Parameters 
Under the AAR tab, select the desired AAR for the airport (see Figure 17-3). While a GS 
program is not based on the AAR, this section is available for specialists to view and evaluate 
whether or not to issue a GS. Set the target AAR values under this tab to efficiently monitor 
capacity vs. demand. Clicking ADL AAR restores the AAR values to their original state. 

Note: If you select GS Immediate as the Program Type, the start time 
defaults to the current time minus 10 minutes. So if the current time is 
1841Z, the default start time is 1831Z. If you selected GS Future as the 
Program Type, you can enter the date and time when the GS will begin. 
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Figure 17-3: GDT Setup AAR Tab 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Issuing a Ground Stop 

Version 7.9 17-5 

Tier/Dist Tab 
Click on the Tier/Dist tab to select the facilities and airports included in the GS. GSs are always 
Tier based; therefore Distance is not a valid exemption criterion. The Tier panel contains three 
sections where you can modify parameters: Centers, Airports, and Flights (see Figure 17-4). 

 
Figure 17-4: GDT Setup GS Tier/Dist Tab 

Note: GS Immediate should be based on Departure Status and GS Future should 
be based on Time. 
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GS Modifications Tab 

Using the GS Modifications tab you can specify additional centers or airports to run in the GS 
(see Figure 17-5). The GS parameters set in this tab can have GS start and stop times that differ 
from the main GS. All other parameters in the GS program remain the same. You can edit or 
delete the text added to this field. 

 
Figure 17-5: GDT Setup GS Modifications Tab 

After you enter the GS Modification parameters, click Add to add the parameters to the program. 
The modification appears in the table. To change an existing modification, highlight the 
modification line from the table. This enters the parameters in the textboxes where you can adjust 
the information and click Modify to change it. To remove a modification from the table, highlight 
the modification line and click Delete. For more information on the GS Modifications tab, see 
Chapter 3: Understanding Components. 

Power Run Tab 

Before actually running the GS, you may want to review the parameters you set to ensure they are 
best for your program. This allows you to take advantage of several analysis tools embedded in 
FSM. 

Use the Power Run tab in the GDT Setup component as an analysis tool. There are three GS 
Power Run operations, which analyze the effects/results of any program: 

• GS Center Group 

• GS Time Period 

• GS Center Group & Time Period 
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You can select these options from the dropdown menu that appears next to Power Run By. Use 
the Power Run function to determine whether you need to modify the parameters. When you 
generate any Power Run, FSM automatically saves the Power Run to a file. 

 
Figure 17-6: GDT Setup GS Power Run Tab 
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To view a scenario, select an option from the Power Run By dropdown menu and click Model. 
Model displays the effects of the GS parameters and how traffic at the airport would be affected if 
you used these parameters for an actual program in all GDT components. Review the program 
statistics in the Data Graph. 

 
Figure 17-7: Power Run Data Graph by GS Center Group  
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To preview the effects of a Power Run scenario, move the black line on the Data Graph 
component to other options displayed on the x-axis. This is discussed in more detail below in the 
Data Graph Component section. To view the same information in the table format, select View > 
Data Table from the GDT Setup component. 

Note: After you click Model, the Setup Panel no longer contains a red border; 
this indicates that all components reflect the information in the GDT Setup Panel. 

 
Figure 17-8: Power Run Data Table by GS Center Group 

Generating a GS Coversheet 
Run the GS program once you set the parameters and you are ready to implement the GS. Click 
Run on the GDT Setup component. This saves the parameters to a specified FSM configuration 
file and the GS Coversheet appears on the screen.  

Note: GS programs ignore all unassigned slots if the GDP has a Delay 
Assignment Mode of GAAP.Clicking Run generates three reports: 

• FADT report 

• Analysis report 

• Carrier Statistics report 

You can view all reports by selecting View > FADT, View>Analysis Report, or View>Carrier 
Statistics from the Coversheet component. You can also view the Carrier Statistics by selecting 
Report > Carrier Statistics from the main Control Panel component. See Chapter 19: 
Understanding and Using FSM Reports for more information. 
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GS Coversheet 
The GS Coversheet contains all program parameter data for you to review before sending the GS 
program. You send the GS out from the GS Coversheet (see Figure 17-9). 

 
Figure 17-9: Ground Stop Coversheet 

For more information on the GS Coversheet, see chapter 3: Understanding Components. 

Once you review the GS Coversheet and checkmark all checkboxes, send out an Advisory and 
Autosend the GS to the Hub site. 

Sending an Advisory 
To compose either an Actual or Proposed GS Advisory, click Advisory from the GS Coversheet. 
The GS Advisory window appears (see Error! Reference source not found.). This window 
contains all the GS parameters to send to all participants and a separate Remarks section that you 
must fill out before sending the Advisory. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Issuing a Ground Stop 

Version 7.9 17-11 

 
Figure 17-10: Send a GS Advisory 

For more information on the Advisory component, see chapter 3 Understanding Components. 

Once you complete the GS Advisory, click Send to email the program parameters to all parties 
involved in the program, including the Hub site. A checkmark appears next to the Send button on 
the Advisory window and next to the Advisory button on the GS Coversheet to indicate that you 

sent the advisory.  

If the parameters are for a Proposed Advisory, the Hub site sends out the parameters immediately 
in the next ADL. When FSM sends parameters for an Actual Advisory, the Hub site ensures that 
it has received the associated FADT file with flight control times for the program before sending 
any parameters through the ADL. 

When you click Close, FSM takes no action from the GS Advisory window. 

Click AutoSend from the GS Coversheet to send the FADT List to both the Hub and Airlines.  

When you click Close, FSM takes no action from the GS Coversheet window. 

Re-Opening the Coversheet 
If you want to review previous Coversheets for the airport or if you accidentally closed the 
Coversheet before sending out the advisory, you can re-open it for review or to continue sending 
out the program. See Chapter 9: Issuing an Initial Ground Delay Program for more information. 
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Example of Issuing an Actual GS 
An Actual GS is a program that the FAA is going to implement; they have gathered user 
comments and are ready to enact the program. If you are preparing an Actual GS, you need to 
send a FADT file through the Autosend function. 

The Hub site does not send program parameters for an Actual program through the ADL until it 
receives both the program parameters (through an Advisory) and a matching FADT list with 
flight control times. Once Volpe receives both of these, it sends the program parameters and 
control times through the ADL to all FSM users and implements the program. 

To send a Ground Stop 

The advisory contains the program parameters for the Hub site to send through the ADL. 

1. Click Open Data Set. 
2. The Open Data Set window appears. 
3. Select the airport for which you want to issue the GS. 
4. Click OK. 
5. The Time Line and Bar Graph components for the airport appear. 
6. Click GDT Setup. 
7. The GDT components for the airport appear. 
8. Select Immediate or Future GS for the Program Type. 
9. Enter the GS parameters on the various GDT Setup Panel tabs. 
10. Click Model. 
11. The red border in the GDT Setup Panel disappears and all the GDT 

components reflect the modeled GAAP GDP. 
12. If the program appears to deal with the traffic flow in the manner you want, 

click Run to generate the Coversheet. 
13. The Coversheet window appears. 
14. Carefully examine each section of the Coversheet. If the data is correct, 

select the General checkbox and the Tier/Dist checkbox. 
15. Click Advisory to complete the advisory for the actual program. 
16. The GS Advisory window appears (See Re-Opening the Coversheet 

If you want to review previous Coversheets for the airport or if you accidentally closed the 
Coversheet before sending out the advisory, you can re-open it for review or to continue sending 
out the program. See Chapter 9: Issuing an Initial Ground Delay Program for more information. 

17.  on page 11). 
18. Complete the fields required in the GS Advisory window. 
19. Select Actual on the GS Advisory. 
20. Click Send and close the Advisory window. 
21. Click Autosend on the Coversheet to send the FADT to the Hub site and 

CDM participants.  
The FADT file is still forwarded to Autosend at the ETMS terminal so that 
you can re-send the file if there is a problem with the initial transmission. 
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The Hub site does not send out any actual program information through the 
ADL unless there is an Actual Advisory with parameters matching the 
FADT. 
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Note: If you click Advisory or Autosend more than 15 minutes after switching 
to GDT Setup, FSM warns you to return to Monitor Live mode and get the most 
recent data from an updated ADL before continuing with the GS. 

 
Viewing GS Controlled Flights 
To monitor controlled flights, view the Bar Graph and Time Line in Monitor Live mode. You can 
identify GS flights by looking for yellow flights in the Bar Graph and the Time Line (see Figure 
17-9). In the Bar Graph, move the cursor over the yellow bar and a pop-up appears indicating the 
number of GS controlled flights in that hour. 

 
Figure 17-11: Live Mode 
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Double-click on a bar in the Bar Graph to open the Flight List component. When all colors appear 
on the Bar Graph, the Flight List contains all flights, both GS and other flights. Select the View > 
Show Legend checkbox to open the color legend. Uncheck all color options with the exception of 
yellow GS Flights. Then click on the hour bar that has only GS flights displayed; this opens a 
Flight List containing only GS flights. 

 
Figure 17-12: GS Flight list for 1 Hour Bar 

There are certain default values of Flight List information. When you first open a Flight List, the 
default information appears. This default information is adjustable. For more information on the 
Flight List component, see chapter 6: Viewing Flight Information. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Issuing a Ground Stop 

Version 7.9 17-16 

Query Manager Flight List 
The Query Manager already contains a built-in filter for GS flights. To get a list of GS flights at 
any open airport, select the AND Ground_Stopped Filter and then click Flight List or select 
View > Flight List from the Query Manager component. 

 
Figure 17-13: Query Manager Component 

When you are monitoring more than one airport, clicking Flight List opens the Set Data Set 
window, showing all open airports. Select the Data Mode/Airport and click OK to view that 
airport’s GS Flight List (see Figure 17-14). Click Cancel to exit the Set Data Set window without 
opening a Flight List. 

 
Figure 17-14: Set Data Set Selection window 

Opening a Flight List from the Query Manger lists all the flights that are GS at the specified 
airport unless otherwise defined by a customized CONSTRAINT, whereas accessing a Flight List 
from the Bar Graph only displays a list of flights for the selected hour. For more information on 
how to use the Query Manager component, see Chapter 20. 
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Figure 17-15: Query Manager Flight List 
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18 Other Ground Stop Functions 
Once a Ground Stop (GS) is in place, the conditions that originally necessitated the Ground Delay 
Program (GDP) may change. This chapter covers additional GS features that you use when 
conditions demand modifications to an existing GS: 

• Purging a GS 

• Reducing the Scope of a GS 

• Extending a GS 

• Moving from a GS to a GDP 

Purging a GS 
From the Purge Coversheet, click Purge to purge any control times from the ETMS system. 
Purge works the same as the Autosend function to send new operation parameters and 
cancellation messages to the Hub site for inclusion in the ADLs.  

Note: The Hub site waits for an Advisory for the cancelled GDP before sending 
the new parameters. 

Finish the GS cancellation by clicking Advisory and sending a Purge advisory. 

Viewing Flight Information before Purging a Program 
When you model a purge for a GS program, ETMS sets the minimum notification time to the 
value of the minimum notification time for flights in a ground stop. FSM determines a minimum 
notification time for controlled flights in a taxi status. If a controlled flight is in a taxi status, 
without regard to the type of control, then FSM sets the minimum notification time to the value of 
the minimum notification time for flights in a taxi status. 

ETMS models a new estimated departure time based on the flight’s control departure time and the 
minimum notification time based on the following criteria: 

• If the flight is active or completed, ETMS sets the ETD to the actual 
departure time. 

• If the CTD of the flight is within the minimum notification time from the 
current time, the estimated departure time remains set to the CTD. 

• If the CTD of the flight is greater than the minimum notification time plus 
the current time, then ETMS calculates a candidate ETD selected from the 
following values in order of priority: 

1. Earliest Runway Departure Time 
2. Earliest Runway Arrival Time minus the Estimated Time Enroute 
3. Original Estimated Departure Time 
4. Initial Gate Departure Time plus the taxi time for the flight 
• If this candidate time is greater than the current time plus the minimum 

notification time, then ETMS sets the ETD to this candidate time. 
• If the candidate time is less than the current time plus the minimum 

notification time, then ETMS sets the ETD to the current time plus the 
minimum notification time. 
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To purge a GS 
The Purge option requires no user input. 

1. Click Purge. All the tabs in the setup panel are disabled. 

2. Click Model. 

3. The red border in the GDT Setup Panel disappears and all the GDT 
components reflect the modeled purge. 

4. If the program appears to deal with the traffic flow in the manner you want, 
click Run to generate the GS CNX Coversheet. 

5. The Coversheet window appears. 

 
Figure 18-1: GS CNX Coversheet 

The information included in the Purge Coversheet is pre-defined and you cannot change 
it. Information on the Purge Coversheet includes: General Parameters and Program 
Results. For more information on the Coversheet component, see chapter 3: 
Understanding Components. 

6. After you review the information in the General section, select the General 
checkbox. 

7. From the CNX Coversheet, click Purge to purge any control times from the 
ETMS system. Purge works the same as the Autosend function to send new 
operation parameters and cancellation messages to the Hub site for inclusion 
in the ADLs. 

8. Click Advisory to finish the GS cancellation and send a Purge advisory to all 
users. 
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Reducing the Scope of a Ground Stop 
To reduce the scope of an existing GS you must open GDT mode and purge the current GS for all 
flights and then issue another Immediate GS with the reduced scope. 

Note: Before Purging a Ground Stop, communication with all operators is 
encouraged to notify them that another Immediate GS program will be 
implemented shortly after the Purge. 

Ensure the GS airport that you want to modify is active before clicking GDT Setup on the 
Control Panel component. This opens the four default GDT components for the selected airport. 
Select Program Type > Purge from the GDT Setup component and click Model then Run to 
purge the existing GS (see Figure 18-2). The Purge Program type requires no parameter 
modifications; therefore all tabs are disabled. 

 
Figure 18-2: GS Purge 
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Clicking Run to Purge/CNX the current GS program opens the GS CNX Coversheet (see Figure 
18-3). The information included in the Purge Coversheet is pre-defined and you cannot change it. 
See chapter 18 for more information on GS Purge Coversheet information. 

 
Figure 18-3: GS CNX Coversheet 

From the Purge Coversheet, click Purge to purge any control times from the ETMS system. 
Purge works the same as the Autosend function to send new operation parameters and 
cancellation messages to the Hub site for inclusion in the ADLs. 

Finish the GS purge/cancellation by clicking Advisory to send a GS CNX Advisory. 

Note: The Hub site waits for a cancelled GS Advisory before sending the 
new parameters. 
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Once you send both the Purge command and the GS Purge Advisory from the GS Purge 
Coversheet, it is important to wait for the Purge to appear in the next ADL before issuing the 
revised GS. View the airport in Monitored Live mode to ensure that the GS has been purged. 

 
Figure 18-4: GDP Purged 

Once the Purge appears in FSM, it is now safe to issue a GS Immediate with the reduced scope 
parameters in GDT Mode. Fill in the GS parameters as needed. Once you make the GS parameter 
inputs, click Reload or Model on the GDT Setup component to view the delay statistics for the 
new scenario and make adjustments if necessary. Once you are ready to issue the GS Immediate, 
click Run from the GDT Setup component to open the GS Immediate Coversheet. From the GS 
Immediate Coversheet, send both the Autosend and Advisory to implement the new GS. See 
Chapter 17 for more detail on how to issue a GS. 

Extending a Ground Stop 
To extend an existing GS, ensure the Ground Stopped airport you want to modify is active before 
clicking GDT Setup on the Control Panel component. This opens the four default GDT 
components for the selected airport. Select GS Immediate from the Program Type dropdown 
menu and then select File > Load Actual Parameters > Ground Stop, as shown in Figure 18-5. 
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After FSM loads the actual parameters, adjust the parameters and extend the GS Time as 
necessary. Click Model to view the Delay Statistics in the Data Graph and make any adjustments 
as needed. 

 
Figure 18-5: Load Actual Parameters > Ground Stop 

Run the GS program once you modify the parameters and you are ready to implement the GS. 
Click Run on the GDT Setup component. This saves the parameters to a file specified in FSM’s 
configuration file and opens a GS Coversheet. Clicking Run generates three reports: 

• FADT report 

• Analysis report 

• Carrier Statistics report 

You can view these reports by selecting View > FADT, View>Analysis Report, or 
View>Carrier Statistics from the Coversheet. You can also view the Carrier Statistics by 
selecting Report > Carrier Statistics from the main Control Panel component. For more 
information on these reports, see chapter 19: Understanding and Using FSM Reports. 
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GS Coversheet 
The GS Coversheet contains all the operation’s parameter data. Send the GS out from the GS 
Coversheet. 

 
Figure 18-6: GS Immediate Coversheet 

Once you complete the GS Coversheet and checkmark all checkboxes, send out an Autosend and 
send a proposed Advisory if time permits (see Figure 18-6). 

Suspend Airline Substitutions and Slot Credit Substitutions  
Before sending a revised GS and after response time has expired from the proposed advisory, 
select ETMS Tools > EDCT Commands > EDCT Sub OFF from the Control Panel component 
to turn substitutions off.Send GS 
On the GDT Setup component, select Program Type GS Immediate and select File > Load 
Proposed Parameters > Ground Stop.  If proposed parameters are unavailable, load actual 
parameters and adjust as needed. Click Model then Run from the GDT Setup component to open 
the GS Immediate Coversheet. From the GS Immediate Coversheet, click Autosend to send the 
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FADT. Click Advisory on the GS Immediate Coversheet to open the Advisory window. Enter the 
reason for the GS revision and ensure that you select Actual before clicking Send. After you send 
both Autosend and an actual Advisory, close the Coversheet and return to view the airport in 
Monitored Live mode. See Chapter 17: Issuing a Ground Stop for more detail on how to issue a 
GS. 

 

Moving from a GS to a GDP 
When issuing a GDP at an airport that already has a GS in place, open GDT mode for the airport 
and select GDP RBS++ Program Type. Select Exempt Flights by Departure Status (rather than 
by Time) on the GDT Setup component’s Tier/Dist tab. Exempting flights by departure status is 
necessary to capture flights affected by the GS. 

 
Figure 18-7: Tier/Dist Tab set up for moving from at GS to a GDP 
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Suspend Airline Substitutions and Slot Credit Substitutions 
When moving from a GS to a GDP, you need to suspend, temporarily, the acceptance of airline 
substitutions and Slot Credit Substitutions (SCS) messages. From the FSM Control Panel, select 
the ETMS Tools > ECDT Commands > EDCT Sub Off option to turn substitutions off, as 
shown in Figure 18-8. Enter the three-character airport ID into the EDCT SubOff dialog box and 
click Send to suspend substitutions for that airport. Airlines’ substitution or SCS messages are no 
longer accepted after FSM sends the SubOff message to ETMS. 

 
Figure 18-8: Turn Subs OFF 

Issuing a GDP 
Once you have determined the program parameters for an Actual GDP and you have turned off 
the substitutions, you must perform two steps to enact the program and send the parameters out 
through the ADL. Volpe does not send program parameters for an Actual program through the 
ADL until it receives both the program parameters (through an Advisory) and a matching FADT 
list (Autosend) with flight control times. 

Click Run from the GDT Setup component to open the GDP Coversheet with the revised 
parameters. Send both the Advisory and Autosend from the Coversheet to implement the 
revision. 
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If SUBS are turned ON when you click Autosend from a coversheet during a compression, 
revision, or extension, you receive an FSM warning message that instructs you to “Turn SUBS 
OFF, reload and remodel the program…” (see Figure 18-9). Click OK to clear the FSM warning 
and then turn SUBS OFF before reloading and remodeling the program. Wait for SUBS OFF to 
be reflected successfully before clicking Autosend again. 

 
Figure 18-9: SUBS OFF Warning 

Although it is recommended that you turn SUBS OFF during any revision, you can bypass the 
warning message by clicking Ignore from the message box. This clears the FSM warning. FSM 
automatically continues with the Autosend process even though SUBS are ON. 

See Chapter 9 for more information on issuing a GDP. 
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19 Understanding and Using FSM Reports 
FSM makes several different reports available to you. These reports give you information about 
counts, compliance, surface delay, priority flights, time out delay, time out cancel, slot hold, sub 
opportunities, slot list, analysis, FADT, and carrier statistics. You can use these reports to better 
understand how traffic reacts to programs that are in place and determine when to make 
adjustments to programs. 

Counts Reports 
Counts reports give you the option to check the flights that make up arrival and/or departure 
demand for each hour. You can open all Count Lists from the FSM Control Panel component. 
There are 8 count list reports: 

• By Demand 

• By Center 

• By Aircraft Type 

• By Aircraft Class 

• By Arrival Fix 

• By Departure Fix 

• By User 

• By Unassigned Slot 

To view a demand count for a particular monitored airport, first select the airport to view the 
demand count that you want to view, and then select Reports > Counts > [By report type]. If 
you have not selected an airport, FSM displays an error message that indicates “No Current Data 
Set” is selected (see Figure 19-1).  

 
Figure 19-1: Count List By Demand 

Viewing the Count List 
After selecting the type of demand count, a Count List window appears. The type of Count List 
appears in parentheses in the Count List window’s title bar. The three-letter airport code, Date, 

 Note: Count Lists in GDT Mode only show counts for arriving flights. 
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ADL Time FSM generated the list, and display mode appear in the title bar as well as above the 
Count List columns. 

FSM arranges each count list in 15-minute intervals with totals for each hour based on the FSM 
Time Line component. NRP (National Route Plans) counts appear below the total count for each 
hour. An NRP is a flight that files for a more direct route, but is considered to be a preferred route 
(as designated by the FAA). In Monitor Mode, counts appear based on a flight’s ETA by FSM 
default. You can view Count Lists based on the Count List Display menu: by ETA, BETA, IGTA 
- Taxi, OCTA, CTA, EFTA, Departure, and Arrival/Departure, as shown in Figure 19-2. 

 
Figure 19-2: Count List Display Data 

To increase the size of any Count List window, drag the edge of the window with your mouse. 
When the information contained in the window is too large for the window, you can scroll 
through the data. 

Count List Menu 
The Count Lists (with the exception of Departure Fix) each have four menus: File, View, Display 
and Help. 

1. File Menu 

• File > Save as – Saves the Count List to a file so that you can open it later in 
a text file. 

• File > Print – Sends the Count List to a printer so that you can view a hard 
copy of the Count List. 

• File > Close – Closes and quits the Count List component without taking any 
action. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Understanding and Using FSM Reports 

Version 7.9 19-3 

2. View Menu  

• View > Freeze Data – Freezes the count list data at the time you select the 
option, otherwise the Count List updates with each new ADL. 

3. Display Menu 

• Display > ETA – Displays counts based on the flights’ Estimated Time of 
Arrival. 

• Display > BETA – Displays counts based on the flights’ Beginning 
Estimated Wheel Time of Arrival. 

• Display > IGTA – Taxi – Displays counts based on the flights’ Initial 
Estimated Gate Time Arrival – Taxi. 

• Display > OCTA – Displays counts based on the flights’ Original Control 
Time of Arrival. 

• Display > CTA – Displays counts based on the flights’ Control Time of 
Arrival. 

• Display > EAFT – Displays counts based on the flights’ Estimated Fixed 
Time of Arrival. 

• Display > Departure – Displays counts based on the Departure flights. 

• Display > Arrival/Departure – Displays counts based on Arrival and 
Departure flights. 

4. Help Menu 

• Help > Counts – Accesses the web-based on-line help for the Count Lists. 

Count List by Demand 
The By Demand Count List displays arrival demand in 15-minute interval flight counts 
and totals the flight count for each hour. You can use this report to perform a quick check 
of the arrival demands in each hour (see Figure 19-3). 

Note: The Counts by Departure Fix and Counts by Unassigned Slots do 
not have a Display Menu. 
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Figure 19-3: Counts by Demand 

Counts by Centers 
The By Centers Count List provides flight counts according to departure centers. There 
are 20 centers for this particular display (Figure 19-4). If the three-letters “ZZZ” appear, 
they represent any center that is not part of the other 20. Again, in Monitored Live mode, 
FSM bases these counts on flights’ ETA times as displayed in the FSM Time Line. 
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Figure 19-4: Counts by Centers 

Counts by Aircraft Type 
The By Aircraft Type Count List displays a count list based on the aircraft type. FSM classifies 
Aircraft Types according to the aircraft type as specified by the manufacturer (Propeller, Turbo, 
Jet, and Unknown). 

The Count List By Aircraft Type report contains the following information: 

• Date – ADL day and time 

• Time – 15 minute time bins 

• Aircraft Types (P, T, J, U) 

• Total – Total types for each time bin, hour, and NRP 

The data are arranged in the following manner: 

• Block for each hour in the ADL 

• Counts by each 15 min bin 

• Sum of types in each hour 

• NRP count 
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Figure 19-5: Counts by Aircraft Type 

Counts by Aircraft Class 
The By Aircraft Class Count List provides flight counts according to the aircraft weight. This 
Count List incorporates the following classifications for aircraft weight: Small, Large, Heavy, and 
Unknown. 

The Count List By Aircraft Class report contains the following information: 

• Date – ADL day and time 

• Time – 15 minute time bins 

• Aircraft Classes (S, L, H, U) 

• Total – Total classes for each time bin, hour, and NRP 

The data are arranged in the following manner: 

• Block for each hour in the ADL 

• Counts by each 15 min bin 

• Sum of types in each hour 

• NRP count 
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Figure 19-6: Counts by Aircraft Class 

Counts by Arrival Fix 
The By Arrival Fix Count List provides flight counts according to the arrival fix each flight is 
arriving at for the monitored airport. Arrival fix names for each airport vary. FSM automatically 
generates the correct Arrival Fix names for the monitored airports and uses them in the Count List 
headings. 

The Count List By Arrival Fix report contains the following information: 

• Date – ADL day and time 

• Time – 15 minute time bins 

• Arrival Fixes  

• Total – Total fixes for each time bin, hour, and NRP 

The data are arranged in the following manner: 

• Block for each hour in the ADL 

• Counts by each 15 min bin 

• Sum of fixes in each hour 

• NRP count 
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Figure 19-7: Counts by Arrival Fix 

Counts by Departure Fix 
The By Departure Fix Count List provides flight counts according to the departure fix each flight 
is arriving at for the monitored airport. Departure fix names for each airport vary. FSM 
automatically generates the top 11 departure fixes for the monitored airport and uses them in the 
Count List headings. If the departure fix is other than these 11 or is unknown, the flight appears 
under the “Other” column. 

The Count List By Departure Fix report contains the following information: 

• Date – ADL day and time 

• Time – 15 minute time bins 

• Departure Fixes 

• Total – Total fixes for each time bin, hour, and NRP 

The data are arranged in the following manner: 

• Block for each hour in the ADL 

• Counts by each 15 min bin 

• Sum of fixes in each hour 

• NRP count 
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Figure 19-8: Counts by Departure Fix 

Counts by User 
The Arrival Count List By User provides a flight count according to the classification of the 
aircraft (Figure 19-9). The Arrival Count List by User classifies flights according to their function 
in the NAS. There are 7 types of users in FSM: 

• C – Air Carriers 

• T – Air Taxi 

• F – Freight/Cargo Carriers 

• M – Military 

• G – General Aviation 

• O – Other – This class includes flights that do not belong to one of the five 
categories listed above. 

• U – Unknown – This category is for flights which may fall into a user 
category, but the classification of which is not known in FSM 
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Figure 19-9: Counts by User 

The Count List By User report contains the following information: 

• Date – ADL day and time 

• Time – 15 minute time bins 

• Users – F, C, G, M, T, O, U 

• Total – Total fixes for each time bin, hour, and NRP 

The data are arranged in the following manner: 

• Block for each hour in the ADL 

• Counts by each 15 min bin 

• Sum of Users in each hour 
• NRP count 

By Unassigned Slot 
The unassigned slot report is very similar to the count list report. The title bar for the report 
shows the report icon, and “Count List (Unassigned Slot): [three letter airport identifier] [ADL 
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Date YYYY/MMM/DD/] [ADL Time HH:MMZ] [Mode: Live/Hist] : [Frozen (if you select it)]”. 
The report does not have a Display menu item. 

The Count List By Unassigned Slot report contains the following information: 

• Date – ADL day and time 

• Time – 15 minute time bins and Total 

• Unassigned Slots – number of unassigned slots per time bin 

The data are arranged in the following manner: 

• Block for each hour in the ADL 

• Counts by each 15 min bin 

• Sum of slots in each hour – Total number of Unassigned slots for the hour. 

 
Figure 19-10: Count List (By Unassigned Slot) Report 

Compliance Flight Lists 
When any flight becomes noncompliant, FSM generates a flight list that includes these flights. 
You can access the compliance reports from the Reports > Compliance >[Report Name] option 
from the Control Panel component. There are five possible compliance reports: 

• By CTD 

• By ETE 

• By CTA 
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• Spurious Flight 

• Cancelled That Flew Compliance 

For example, if you select Reports > Compliance> By CTA, all flights that have noncompliant 
CTAs appear with the FltAlarm CC checkboxes checked. This report also contains non-compliant 
alarm columns. If the flight has additional alarms (non-compliant) associated with it, those alarm 
checkboxes also appear checkmarked. Figure 19-11 is an example of CTA Compliance Alarm 
Flight List. 

 
Figure 19-11: CTA Compliance Alarm Report 

To view the Compliance alarm columns on the generated report, select the alarms from the 
Add/Remove Columns window. If a flight is non-compliant, the checkbox under the Alarm type 
is selected. The Compliance Alarm columns are defined below: 

1. CC – These flights violated their CTA Compliance. Flights arriving more than 5 minutes 
before or more than 5 minutes after their Control Time of Arrival (CTA). 

2. EC – These flights violated their CTD Compliance. The departure boundaries are more 
than 5 minutes before or more than 5 minutes after their estimated departure clearance 
time. Any flight, which has an ARTD of 5 minutes earlier or 5 minutes later than the 
most recent EDCT, appears in the CTD Compliance report. 

3. EA – These flights violated the Actual ETE vs. Original ETE alarm. FSM generates this 
Alarm when the difference between the ETE estimated by ETMS and actual flight time is 

Note: Alarm Flight Lists include only those flights arriving at the selected 
airport. 
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greater than a specified value, but the flight status is not “cancelled.” The default value is 
15 minutes. ETMS estimates ETE using OCTA - OCTD. ETMS calculates actual flight 
time using ARTA -ARTD. 

4. SF - This alarm detects the cancellation of a false flight used to ignite a substitution 
stream. Flights submitted as SI cancellations with no corresponding entries in the OAG 
trigger the Spurious Flights Alarm. 

5. CF – This alarm detects any flights that were cancelled but later flew without the flight 
being reinstated properly.  

The By CTD Compliance Report 
The By CTD Compliance report checks for flights which violate departure compliance in a delay 
program. The default departure boundaries are more than 5 minutes before or more than 5 
minutes after their estimated departure clearance time. Any flight that has an ARTD of 5 minutes 
earlier or 5 minutes later than the most recent OrigEDCT is included in the By CTD Compliance 
report, as shown in Figure 19-12. 

 
Figure 19-12: CTD Compliance 

The By ETE Compliance Report 
The By ETE Compliance report compares the Actual ETE vs. Original ETE. FSM includes flights 
in the By ETE Compliance report when the difference between the ETE estimated by ETMS and 
actual flight time is greater than a specified value, but the flight status is not “cancelled.” The 
default value is 15 minutes. ETMS estimates ETE using OCTA - OCTD. ETMS calculates actual 
flight time using ARTA - ARTD. The actual flight time format is very similar to Figure 19-12. 
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The By CTA Compliance Report 
The By CTA Compliance reports check for flights which violate arrival compliance in a delay 
program,. By default, flights that violate arrival compliance are defined as those flights arriving 
more than 5 minutes before or more than 5 minutes after their Control Time of Arrival. If ETMS 
detects any of the specified conditions, the flight is included in the By CTA Compliance Flight 
List, as shown in Figure 19-13. 

 
Figure 19-13: CTA Compliance 

The Spurious Flight Compliance Report 
The Spurious Flight Compliance report detects the cancellation of false flights used to ignite a 
substitution stream. Flights submitted as FX cancellations with no corresponding entries in the 
OAG are included in the Spurious Flight List. 

The Cancel But Flew Compliance Report 
The Cancel But Flew Compliance report included any flight that was cancelled and later flew. 

 

Surface Delay Report 
The Surface Delay Report indicates the ground delay imposed on flights and contains departure 
information for both arriving and departing flights. To view a Surface Delay Report, select the 
monitored airport for which you want to view the report and then select Reports > Surface 
Delay from the FSM Control Panel component. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Understanding and Using FSM Reports 

Version 7.9 19-15 

 
Figure 19-14: Surface Delay Report 

The displayed information defaults to arrival data. To view departure data select View > 
Departure Data. The Surface Delay Report then displays both arrival and departure data. To 
alternate information in the report you can check or uncheck the arrival or departure boxes. 

Surface Delay Report Menu 
Many of the menu items are the same as for the Flight List component. For more information on 
the Flight List component, see Chapter 6: Viewing Flight Information. 

• File 
o Save As 
o Print 
o Close 

• View 
o Rename Window 
o Arrival Data – Toggles Arrival data off and on. 
o Departure Data – Toggles Departure data off and on. 
o Add/Remove Columns 
o Group Flights 
o Sort Flights 
o Apply Filter 
o Clear Filter 

• Flight List 
o Set Time 
o Search By Callsign 
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• Help 
o Surface Delay – General information about this report 

Priority Flight Report 
This report identifies "priority" flights. It is similar to a Flight List, but only lists those flights 
tagged as Lifeguard (LFG) or Diversion Recovery (DVT) flights. To view a Priority Flight 
Report, select the monitored airport for which you want to view the report and then select 
Reports > Priority Flights from the Control Panel component. Any flights that have the LFG or 
DVT checkboxes marked appear on the Priority Report. 

Priority Report Menu 
Many of the menu items are the same as for the Flight List component. For more information on 
the Flight List component, see Chapter 6: Viewing Flight Information. 

• File 
o Save As 
o Print 
o Close 

• View 
o Rename Window 
o Arrival Data – Toggles Arrival data off and on. 
o Departure Data – Toggles Departure data off and on. 
o Add/Remove Columns 
o Group Flights 
o Sort Flights 
o Apply Filter 
o Clear Filter 

• Flight List 
o Set Time 
o Search By Callsign 

• Help 
o Priority – General information about this report 
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Figure 19-15: Priority Report 

Time Out Delay Report 
The Time Out Delay Report provides a quick picture of flights that are contributing to the Time 
Out delay problem. The report is in the same format as FSM Flight Lists and includes all flights 
with a delay status of ‘TOD'. To view the Time Out Delay report, select an airport being 
monitored and then select Reports > Time out Delay from the FSM Control Panel component. 
The Time Out Delay report flight list shows all flights that have triggered the TOD alarm with the 
TOD checkbox selected (see Figure 19-16). 
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Figure 19-16: Time Out Delay (TOD)  Report Flight List 
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The displayed information defaults to arrival data. To view departure data, select View > 
Departure Data. 

 
Figure 19-17: TOD Delay Report with Departure Data 

The Time Out Delay report displays both arrival and departure data. To alternate information in 
the report you can check or uncheck the arrival or departure boxes. 

Time Out Delay Report Menu 
Many of the menu items are the same as for the Flight List component. For more information on 
the Flight List component, see Chapter 6: Viewing Flight Information. 

• File 
o Save As 
o Print 
o Close 

• View 
o Rename Window 
o Arrival Data – Toggles Arrival data off and on. 
o Departure Data – Toggles Departure data off and on. 
o Add/Remove Columns 
o Group Flights 
o Sort Flights 
o Apply Filter 
o Clear Filter 

• Flight List 
o Set Time 
o Search By Callsign 

• Help 
o Time Out – General information about this report 

Time Out Cancel Report 
The Time Out Cancel Report provides a quick picture of flights, from your operation, which are 
contributing to the Time Out cancel problem. The report is in the same format as FSM Flight 
Lists and includes all flights with a cancellation status of Time Out Cancelled (ToCnx). To view 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Understanding and Using FSM Reports 

Version 7.9 19-20 

the Time Out Cancel report, select a monitored airport and then select Reports > Time Out 
Cancel from the Control Panel component. The Time Out Cancel report shows all flights that 
have triggered the ToCnx alarm and the ToCnx checkboxes are selected for all flights included in 
the report. The Time Out Cancelled report format is identical to the Time Out Delayed report as 
shown in Figure 19-16. 

The displayed information defaults to arrival data. Select the View > Departure Data checkbox 
to view Departure Data in the Flight List. The Time Out Cancel Report then displays both arrival 
and departure data. To alternate information in the report you can check or uncheck the arrival or 
departure boxes. 

Time Out Cancel Report Menu 
Many of the menu items are the same as for the Flight List component. For more information on 
the Flight List component, see Chapter 6: Viewing Flight Information. 

• File 
o Save As 
o Print 
o Close 

• View 
o Rename Window 
o Arrival Data – Toggles Arrival data off and on. 
o Departure Data – Toggles Departure data off and on. 
o Add/Remove Columns 
o Group Flights 
o Sort Flights 
o Apply Filter 
o Clear Filter 

• Flight List 
o Set Time 
o Search By Callsign 

• Help 
o Time Out Cancel – General information about this report 

Slot Hold Report 
The Slot Hold Report lists all currently held slots. This report is similar to an FSM Flight List, but 
only lists those flights whose slot hold flag is set to ‘Y’ as shown in Figure 19-18. To view a Slot 
Hold Report, select the monitored airport for which you want to view the report and then select 
Reports > Slot Hold in the Control Panel component. 

 
Figure 19-18: Slot Hold Report  
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The displayed information defaults to arrival data. To view departure data, select View > 
Departure Data checkbox in the dropdown menu. The Slot Hold Report then displays both 
arrival and departure data. To alternate information in the report you can check or uncheck the 
arrival or departure boxes. 

Slot Hold Report Menu 
Many of the menu items are the same as for the Flight List component. For more information on 
the Flight List component, see Chapter 6: Viewing Flight Information. 

• File 
o Save As 
o Print 
o Close 

• View 
o Rename Window 
o Arrival Data – Toggles Arrival data off and on. 
o Departure Data – Toggles Departure data off and on. 
o Add/Remove Columns 
o Group Flights 
o Sort Flights 
o Apply Filter 
o Clear Filter 

• Flight List 
o Set Time 
o Search By Callsign 

• Help 
o Slot Hold – General information about this report 

Sub Opportunities Report 
You can access the Sub Opportunities Report from the Control Panel by selecting Reports > Sub 
Opportunities. This report assists airlines and general aviation customers in identifying subbing 
opportunities. 
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Figure 19-19: Sub Opportunities Report 

Sub Opportunities Report Menu 
Many of the menu items are the same as for the Flight List component. For more information on 
the Flight List component, see Chapter 6: Viewing Flight Information. 

• File 
o Save As 
o Print 
o Close 

• View 
o Rename Window 
o Arrival Data – Toggles Arrival data off and on. 
o Departure Data – Toggles Departure data off and on. 
o Add/Remove Columns 
o Group Flights 
o Sort Flights 
o Apply Filter 
o Clear Filter 

• Flight List 
o Set Time 
o Search By Callsign 

• Help 
o Sub Opportunities – General information about this report 
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Slot List 
Select Reports > Slot List to view this report. The Slot List report generates the second part of 
the FADT List that FSM generates after a program runs. Included in the Slot List are the Aircraft 
Identification number (ACID), assigned slot time (ASLOT), departure center (DEP), controlled 
time of departure (CTD), controlled time of arrival (CTA), aircraft type (TYPE), exemption status 
(EX), cancellation status (CX), slot hold status (SH), earliest runway time of arrival (ERTA), and 
initial gate time of departure (IGTD). 

 
Figure 19-20: Reports > Slot List 

Slot List Report Menu 

• File 
o Save As – Saves the list as a file so that you can access it later. 
o Print – Prints the report. 
o Close – Closes the report window. 

• View 
o Freeze Data – When selected, this keeps the slot list from updating 

with the next ADL. 

• Slot List 
o Search – Allows you to search for a specific string of data. 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Understanding and Using FSM Reports 

Version 7.9 19-24 

• Help 
o Slot List – General information about this report. 

Understanding Coversheet Reports 
FSM creates three Coversheet reports: 

• FADT report 

• Analysis report 

• Carrier Statistics report 

FADT Report 
FSM generates FADT reports when you Run any TMI operation. A FADT reports contains 
program parameters and delay statistics for that TMI operation. To review the FADT file, select 
View > FADT Report from the TMI Coversheet and the FADT Report window appears 
displaying the program information (see Figure 19-21). 

 
Figure 19-21: FADT Report 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


Understanding and Using FSM Reports 

Version 7.9 19-25 

Analysis Report 
To evaluate the effects of a TMI after the program runs, select View > Analysis Report from the 
Coversheet of any program. (FSM generates the Coversheet when you click Run from a GDT 
Setup Panel after setting the desired parameters). FSM automatically opens the spreadsheet 
application you have indicated in your configuration files to display the Analysis Report. 

 
Figure 19-22: Analysis Report 

The Analysis Report contains information pertinent to the TMI program that just ran: 

• Detailed slot information for individual airlines 

• Delay statistics for before and after the operation  

• Arrival and departure information for individual flights 

The report contains two sections. One section reflects changes that occur as a result of RBS; the 
other section reflects changes that occur as a result of Compression. 
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Carrier Statistics Report 
FSM generates Carrier Statistics when you Run any TMI operation. The Carrier Statistics report 
contains delay statistics for all carriers with flights that operate at that particular airport. To view 
the Carrier Statistics, select View > Carrier Statistics from the Compression Coversheet or 
select Reports > Carrier Statistics from the Control Panel. Ensure that the desired airport is 
active to review the correct airport’s carrier statistics when selecting Carrier Statistics from the 
Control Panel (see Figure 19-23). 

 
Figure 19-23: Carrier Statistics Report 

FSM calculates only flights with assigned arrival slots in the report metrics. That is, flights with a 
Control Time of Arrival (CTA) appear in carrier statistics. If a carrier operates at the airport, but 
has no flights with a CTA, the Carrier Statistics report displays “0” or “N/A” in those rows. You 
can choose the type of delay to view in the report by selecting a Delay Type of either ATC or 
ABS at the top of the report. FSM selects the ATC delay type by default. ABS Delay is the 
absolute delay on a flight, including FAA and airline delay imposed on the flights. FSM 
calculates Absolute delay using Max (0, ETA - [IGTA - Taxi]). ATC Delay is the delay imposed 
only by the FAA on flights and FSM calculates it using Max (0, CTA - BETA). 

The report displays delay statistics for all carriers that operate at an airport. Carriers with no 
presence at the monitored airport do not appear in the Carrier Statistics. 

Note: View > Carrier Statistics report is not available from a Coversheet 
that you opened from a file. 

The following information appears in the Carrier Statistics Report: 

• Carrier Name: The airline to which the delay data corresponds. 

• CDM MBR: Indicates if the carrier is a CDM member (Y/N). 

• # Flights Affected – Total/Non_Exempt/Exempt/CNX 
o Total: Total number of flights for the specified time period. 
o Non-Exempt: Number of the total flights that are Non-Exempt 

(included) in the program. 
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o Exempt: Number of the total flights that are Exempt (receive no 
delay) from the program. 

o CNX: Number of the total flights that are canceled (CNX). 

• On Time %: Percentage of flights that arrive within 15 minutes of their ETA. 

• Delay - Total/Total%/Avg/AffAvg: 
o Total: Total minutes of delay for each airline. 
o Total %: Percentage of delay attributed to the airline. FSM derives 

this value by dividing the total delay minutes for an airline by the 
total delay minutes for all airlines combined. 

o Avg: Average Delay minutes on a carrier's total number of flights. 
o Aff Avg: Average Delay minutes for the carrier's flights affected by 

a program. 

• Delay - Max/Min: 
o Max: Shows Maximum delay amount that a carrier's flights could 

receive. 
o Min: Minimum delay amount that a carrier's flights could receive. 

• % Delay / % Traffic: Indicates the delay equity for a carrier at an airport. A 
value of "1" in this column means that a carrier's delay is perfectly equitable. 
A value greater than "1" indicates a carrier receives worse than average 
delay. A value less than "1" indicates that a carrier receives less than average 
delay. 

The bottom of the reports gives the same statistics for Scheduled/Non-Scheduled flights. 

Carrier Statistics Menu Options 

• File Menu 
o File > Save as – Saves the Carrier Statistics report as a .txt file in a 

directory that you specify. 
o File > Print – Prints the Carrier Statistics report viewed on your 

screen. 
o File > Close – Closes the Carrier Statistics report. 

• View Menu 
o View > Freeze Data – When you select the Freeze Data checkbox, 

the carrier statistics report does not dynamically update with every 
ADL. FSM selects the Freeze Data checkbox by default. 

• Help Menu 
o Help > Carrier Statistics – Accesses the web-based on-line help for 

Carrier Statistics. 
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20 Using Query Manager 
The Query Manager in FSM is a useful tool for retrieving data from FSM that does not already 
appear in one of the reports mentioned in chapter 19: Understanding and Using FSM reports. You 
can use this tool to build your own ad-hoc reports. The Query Manager has built-in filters and 
filters that you can define (user defined filters). This chapter discusses both types of filters and 
how to use them. 

Built-in Filters 
Built-in Filters are pre-defined, read-only filters designed from criteria that are frequently used 
for viewing flight information. 

Double-click on the BUILT_IN Built-in Filters folder or click on the Expand/Collapse icon to 
view/hide all contents in the folder. When you expand the Built-in Filters folder, you see a 
number of filters from which to choose. You can continue to drill down to view more detail by 
double-clicking on the folders or by clicking on their respective Expand/Collapse icons. 

 
Figure 20-1: Query Manager Built-In Filters 

The AND filters list consists of filters that FSM compares to find a match in the data set. For an 
object to match an AND filter, all the filters in the list must be true. An OR filter consists of a list 
of filters that FSM compares to find matching flights in the data set. For an object to match an OR 
filter at least one of the filters in the list must be true. A CONSTRAINT is an attribute, operator, 
or value. FSM uses the red AND, the blue OR, and the green CONSTRAINT coloring as a visual 
aide to distinguish between the three different types of filter options. 

The AND, OR, and CONSTRAINT filters have the ability to create new filters by 
copying/pasting a built-in filter selection directly into the USER User Defined Filters folder. The 
Built-in Filters option buttons remain grayed because they are read-only filters. You cannot edit 
or delete a Built-in Filter for the same reason. 
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User Defined Filters 
User Defined Filters are active filters you create and customize based on your Flight List needs. 
There are two methods of creating user-defined filters: 

1. Adding a New Filter 
2. Editing a Built-in filter 

Creating a New User Defined Filter 
If you find that the existing filters do not give you the information you need, you can create a new 
filter. 

To create a new User Defined Filter 

1. Select the User Defined Filters folder (see Figure 20-2). 

 
Figure 20-2: User Defined Filters 

2. Click Add. 

The Add Filter dialog box appears. 

 
Figure 20-3: Add Filter Dialog Box 
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3. You can select one of three filter types: OR List, AND List, and Constraint. 
4. In Filter name, you can give your filter a unique name. 
5. Click OK. 

FSM adds the new filter under the User Defined Filters folder. 

 
Figure 20-4: New User Defined Filter 

For information on creating Constraint filters, see "To create Constraint filters" in this chapter. 
For information on how to add additional filters and constraints to AND and OR filters, see the 
"To add additional filters or constraints to user defined filters" section in this chapter. 

To add additional filters and constraints to User Defined Filter 

Once you create a new AND or an OR filter, you can add additional filters and constraints to 
them. There are two ways to add additional filters and constraints: 

• Use the copy and paste functionality to add existing Built-in or User Defined 
filters to the User Defined filter. 

• Highlight the filter to which you want to add filters and constraints and use 
the steps in “To create a new User Defined filter” above to add the filter or 
constraint. 
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This section shows how to use the copy and paste method. 

1. Select the Filter that you want to add to the User Defined Filter. 

 
Figure 20-5: Built-In Filter 

2. Select Edit> Copy. 
3. Select the User Defined Filter to which you want to add the filter. 

 
Figure 20-6: User Defined Filter 

4. Select Edit > Paste. 
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The Filter appears below the User Defined Filter. 

 
Figure 20-7: Filter Added to User Defined Filter 

To create user defined Constraint filters 

1. From the Query Manager window, click Add. 
2. Enter a Filter name. 
3. Select Constraint from the Add Filter dialog box. 

 
Figure 20-8: Add Filter Window 

4. Click OK. 
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The Edit Constraint window appears. 

 
Figure 20-9: Edit Constraint Window 

5. Select an attribute from the Attributes windowpane. This automatically 
populates the Operators windowpane with the available options based on 
your attribute selection. 

 
Figure 20-10: Edit Constraint Window 

6. Select one of the Operators listed. 
7. Select one of the Pre-defined Values. 

Note: From the Edit Constraint window you must define your constraint 
by selecting a value from each of the three windowpanes (one value per 
window): Attributes, Operators and Pre-defined Values. 

Note: Some Pre-defined Values and User Values may automatically 
populate as a result of the selection made in the Attributes windowpane. 
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8. Enter a value in the User Value text-field if no options appear in the Pre-
defined Values windowpane. 

 
Figure 20-11: Edit Constraint Window with User Value 

9. Click OK to complete the Constraint definition. 

FSM adds the new CONSTRAINT filter under the User Defined Filters. The 
CONSTRAINT appears with the new filter name including the three values 
chosen from the Edit Constraints component in brackets. 

 
Figure 20-12: Query Manager with User Defined Constraint 
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To edit an existing CONSTRAINT 
You can edit only User Defined Constraints; you cannot amend additional filters to an existing 
CONSTRAINT. The Add button is disabled when an existing CONSTRAINT is highlighted. 

1. Click Edit. 

The Edit Constraint window appears. 

 
Figure 20-13: Edit Constraint Window 

2. Select the new value from Attributes, Operators, Pre-defined Values, or enter 
a new User Value. 

 
Figure 20-14: Edit Constraint Window with New User Value 

3. Click OK to complete the new Constraint definition. 
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FSM changes the Constraint accordingly. 

 
Figure 20-15: Query Manager with edited User Defined Constraint 

To delete a User Defined Filter 
You can permanently remove user defined filters. 

1. Select the filter you want to delete. 
2. Click Delete. 
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To view User Defined Filter information 
You can select the collapse/expand icon next to the filter name or double-click the folder to 
view/hide filter information (see Figure 20-16). 

 
Figure 20-16: User Constraint Added 

Query Manager Flight List 
Access the Query Manager component by clicking Query Manager from the Control Panel. 
When you want to see flights that meet certain criteria, you can generate a Flight List from the 
Query Manager component. Select any one of the Built-in or User-defined Filters. Click Flight 
List or select View > Flight List from the Query Manager component. 

Note: If you do not have a data set (airport) selected, FSM displays a “No Active 
Data Sets” error message. 
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The generated Flight List contains only those flights that meet the selected criteria. The Query 
Manager already contains a built-in filter for GS flights. To get a list of GS flights at any open 
airport, select the AND Ground_Stopped Filter. Click Flight List or select View > Flight List 
from the Query Manager component. 

 
Figure 20-17: Query Manager Component 

When you are monitoring more than one airport, clicking Flight List opens the Set Data Set 
window, showing all open airports. Select the Data Mode/Airport and click OK to view that 
airport’s GS Flight List (see Figure 20-18). Click Cancel to exit the Set Data Set window without 
opening a Flight List. 

 
Figure 20-18: Set Data Set Selection window 
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Opening the Flight List from the Query Manger lists all the flights that are GS at the specified 
airport unless otherwise defined by a customized CONSTRAINT, whereas accessing a Flight List 
from the Bar Graph only displays a list of flights for the selected hour. 

 
Figure 20-19: Query Manager Flight List 
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Appendix A: Flight Status 
The flight Status appears in the Flight Information Window. Flight Status can be one of the 
following: 

• Normal - Flight is flying as expected. 
• FX Canceled - Generated when an airline sends an FX cancellation message. 
• NAS Canceled - A NAS Cancellation received through an RZ message. A flight 

cancellation message that arrives from somewhere in the NAS system other than the 
AOC in charge of the flight. 

• RS Canceled - an OAG cancellation. 
• RM - The flight has been removed from the ETMS database. 
• RZ - A NAS flight plan cancellation message. 
• Timeout Canceled - A timeout cancellation. ETMS cancels the flight because its EDT 

has passed and the flight has not taken off. ETMS determines the necessary lag time 
between the EDT and the current time before cancelling the flight. The amount of time 
depends upon whether ETMS received any information for the flight (e.g. flight plan). 

• DV Canceled - This flight has been diverted to a new arrival airport. 
• ID Canceled - The flight’s ID has been changed. In this case, the old flight and ID is 

cancelled and a new flight with a new ID is created. 
• Airline Delayed (ALD) – A carrier delayed this flight by either an FC Message (create 

new flights) or and FM Message (modify flights). 
• In Program - Delayed because of inclusion in a Ground Delay Program. 
• Ground Stopped - Delayed because of inclusion in a Ground Stop Program. 
• FA Delayed - A new flight was created in the database after a GDP went into effect. 

Because this flight has not received any GDP delay, an FA Delay is put on the new pop-
up flight. 

• Timeout Delayed (TOD)- A flight’s ETD passed without the flight actually taking off. 
ETMS bumps the ETD time to account for possible unreported delay. Once the Time Out 
Delay goes into effect, ETMS determines the length of time to wait until registering the 
flight as TO Canceled. 

In Ground Delay Tools Mode, an exemption status appears in the Flight Information Window. 
Exemption status appears above the Flight Status in the Flight Information Window. Exemption 
status refers to the flight’s inclusion in a Ground Delay Operation and is one of the following: 

• Excluded by Aircraft Type - The program did not include aircraft of this type. 
• Excluded by Arrival Fix - The program did not include this arrival fix. 
• Excluded by Arrival Time - The flight’s ETA did not fall within the program time 

limits. 
• Excluded by Departure Time (GS Only) - The flight is cancelled or the ETD is before 

the start time or after the end time. 
• Exempted by Departing Center - The program did not include this flight’s center. 
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• Exempted by Distance - The flight is exempted because the departure airport is outside 
the distance specified by the program. 

• Exempted by Departing Airport - This airport was specifically exempted from the 
program. 

• Exempted by Specific Flight - This flight was specifically excluded from the program. 
• Exempted by Departure Status - The ETD prefix is either A or E. 
• Exempted by Departure Time - The flight’s Revised EDCT (or Ptime) comes before 

the Current Time + Now_Plus. 
• Excluded and Exempted - Because of program parameters, this flight met excluded and 

exempted status criteria. This status includes flights which do not fly within the time 
period of a GDP and which meet exemption criteria. 

• Not Exempted - This flight is eligible for inclusion in the program. 

When a flight triggers one of FSM's alarms, FSM generates a list of flights that have triggered an 
alarm. Flights trigger alarms are triggered when they do not comply with certain operations’ 
criteria. Flights trigger alarms for the following reasons: 

• CC - Flights arriving more than 5 minutes before or more than 5 minutes after their 
Control Time of Arrival. 

• CF - Flights that were cancelled but later flew without the flight being reinstated 
properly. 

• EA - The actual flight time is greater than a specified value, but the flight status is not 
cancelled. The default value is 15 minutes. 

• EC - The departure boundaries are more than 5 minutes before or more than 5 minutes 
after their estimated departure clearance time. 

• SF - Spurious Flights or flights submitted as SI cancellations with no corresponding 
entries in the OAD. 

The term alerts refers to areas in which the traffic demand is projected to exceed a pre-defined 
capacity threshold. The following are flight Alerts: 

• Alerts > FADT Parameters Available – This alert does not actually give you program 
parameters. Rather, you can view a listing of all the FADTs generated during that day. 
FADTs are reports generated when a GDP, GS, +/- Delay or Compression operation runs. 

• Alerts > SCS Bridge This alert turns red in color when there is a new SCS update. 
Selecting SCS Bridge displays the current subbing status and may contain the following 
keywords: 

− SUBS: Indicates whether all substitutions are enabled (ON) or disabled 
(OFF) 
− SCS: Indicates whether slot credit substitutions for all operators are enabled 
(ON) or disabled (OFF) 
− BRIDGING: Indicates whether bridging subs are disabled (OFF) for a 
particular operator (airline name, GA, or MILITARY). If bridging is off for an 

Note: FSM does not always list the FADTs in chronological order. 
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airline, any flight whose MAJOR field or carrier code (from ACID) matches the 
airline name is not used for an SCS bridge. If bridging is enabled for an operator, 
no line appears, in other words, the only allowed value for this keyword is OFF. 

• Alerts > Actual GDP Parameters Available – This alert turns red in color when FSM 
receives Actual GDP Parameters through the ADL. First-time GDP Parameters, new 
GDP Parameters and deleted GDP Parameters all trigger this Alert. Select Actual GDP 
Params Updated to view the parameters in the GDP Parameter Display panel, which is 
similar to the GDP Setup Panel. From the GDP Parameter Display panel, you can save 
the parameters or close the panel. 

• Alerts > Proposed GDP Parameters Available - This alert turns red when parameters 
for a Proposed GDP arrive through the ADL. Select Proposed GDP Parameters to view 
the new parameters. 

• Alerts > GS Parameters Available – This alert turns red in color when the FAA issues a 
GS and FSM receives its parameters through the ADL. First-time GS Parameters, new 
GS Parameters and deleted GS parameters all trigger this Alert. Select GS Parameters to 
view the parameters in the GS Parameter Display panel, which is similar to the GS Setup 
Panel. From the GS Parameter Display panel, you may save the parameters to a file or 
close the window. 

• Alerts > Compression Parameters Available – When FSM receives parameters for the 
compression function through the ADL, it triggers this alert. When Compression 
parameters arrive, Compression Parameters turn red in the Alert menu. Click the red text 
to view the new parameters. 

• Alerts > Blanket Parameters Available – FSM applies this alert to all flights that are 
part of a specific GDP. 
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Appendix B: FSM 7.8 Algorithms 
 
This section illustrates FSM Algorithms in detailed flow chart format.  The FSM Algorithms include 
Rationing By Schedule (RBS++), Compression, “+/- Delay”, Ground Stop, Purge, and Airborne Holding.  
In addition, the Compression Algorithm calls on four subset algorithms: Intra-airline Compression, Inter-
airline Compression (Substitution), Compress Flight, and Move Up a Flight.  Sub-section contains a list 
of common terms used throughout the FSM Algorithms.  Sub-sections B.3- C.3 include each FSM 
Algorithm’s flow chart. 
 
B.1 Common Terms 
 

Auto-Delay Algorithm: 
This is the set up for Compression, which takes into account the Earliest Runway Time of Arrival 
(ERTA). 
 

Effective AAR: 
AAR minus GA Factor. 
 
ETE: 
ETE = max ((ETA – ETD), (CTA – CTD)) if configured to use Max ETE.   
ETE = ETA – ETD if configured to use ETE. 
 
Excluded Flight: 
A flight that does not meets the criteria of being included in a GDP.  These criteria include factors such as 
the flights IGTA – taxi being outside the program start/end time, affix, and removal status.  
 
Exclude_and_Exempted Flight: 
A flight whose ETA is later than the program start time, is excluded from the program, and meets 
program exemption criteria such as exempt airport, departure time, or status. 
 
Exempt Flight:  
Airborne Flights, departing within Now Plus parameter, specific spatial constraints and any flight that 
meets the criteria of an “exempt flight” within the algorithm.  An exempt flight’s ETD will not receive 
delay.  Exempt flights receive first priority during RBS++.   
 
Floor_Time: 
The Floor_Time of an open slot is the ETA of its associated flight, or 9999 if its associated flight is 
cancelled. This results in open slots associated with canceled flights being processed first. 
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Non-Exempt Flight: (2 types) 
• Previously Controlled:  Have second priority behind exempt flights during RBS++. These flights 

are ordered by their ASLOT. 
• Non-previously Controlled:  Have third priority during RBS++.  These flights are ordered by 

IGTA, but may have to sort by ASLOT. 
 
Open_Slot: 
An open slot is created when a flight is canceled or delayed, so all open slots have one and only one 
associated flight.  This is an association that never changes.  An open slot due to delay (at least one of the 
delay flags is set in the flight record) is created if its associated flight’s ETA is later than where the open 
slot will be displayed on the time line, which is at either (1) Wheel_Arrival_Time if the flight doesn’t 
have a slot, or (2) its slot time if the flight has a slot. 
 
Plus_Time: 
Value entered by the FSM user when implementing a GDP.  The Plus_Time determines the buffer past 
the data time in which flights will not be delayed.  This is to insure that flights that are already boarding 
are not issued a delay. 
 
Slot_Hold: 
Slot_Hold is a status that is applied to an Open_Slot so that it is not filled by the compression process.  A 
NAS user normally holds slots when they intend to use a slot but have not yet determined which specific 
flight will be moved to fill that slot.  A slot can also be held by ETMS when a flight is timeout or NAS 
canceled.   
 
Slot_Time: 
The time position of airport capacity allocated to a NAS user, this is the time that the users flight should 
target for its arrival.  The Slot_Time is used to create the Slot Identification, which is a combination of the 
arrival airport, the slot time, and a suffix to differentiate multiple slots issues for the same minute.  
 
Virtual slot time: 
Based on 15-minute effective AAR.  The smallest slot time increment is one minute. 
 
Wheel_Arrival_Time: 
The arrival time used for rationing airport capacity.  The IGTA is set by ETMS based on the first 
information received for that flight.  The IGTA will be set to SGTA, LGTA, or PGTA depending on 
which is the first value receive by ETMS.  IGTA is then adjusted for taxi-in time to determine the 
Wheel_Arrival_Time.  
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B.2  Rationing by Schedule (RBS++) Algorithm 
                       For “Ground Delay Program (GDP)” 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  Step 1 
 
 
 
 
 
 
 
  

This function requires the following input parameters: 
a.  Start_Time = t0 
b.  End_Time = t1 
c.  Data_Time 
d.  Included_AFIX 
e.  Included Aircraft Type 
f.  Included Carrier 
g. Delay_Ceiling 
h. GDP Operation (RBS++ for this writing) 
i.  AAR Values (for each 15 minutes time period) 
j.  GA_Factor (per hour) 
k.  Options for flight exemption from the departure end - by Departure_Time or by  
    Departure_Status.  Plus_Time in minutes indicates how many minutes from the data 
    time should be used for this exemption; if exempt by departure status, Plus_Time 
    is set to zero. 
l.  Option for ground stopped (GS) flight exemption - whether to exempt GS flights by 
    their departing status or not.  

Note: This option is unnecessary if user have already selected “exempt by 
status” in item (k).  

m. Specific_Flight_Exemption. 
n.  Specific Departure Airport Exemption. 
o.  Facilities (departing centers and airports) involved. 
p.  Last GDP Ending Time. 
q.  Carriers/GA flights whose slot holding status is to be overridden. 

Find all arrival flights included in the program. 

Set Wheel_Arrival_Time = IGTA - taxi.  IF the IGTA of the flight has no value, use the 
following fields in the listed order: 

• SGTA – taxi 
• LGTA – taxi 
• PGTA – taxi 
• BETA (ETMS ETA) 
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Set Wheel_Departure_Time = IGTD - taxi.  If the IGTD of the flight has no value, use the 
following fields in the listed order: 

• SGTD + taxi 
• LGTD + taxi 
• PGTD + taxi 
• BETD (ETMS ETD) 

It has arrived AND: 
• Its ETA is earlier than t0. 
• This it not the first program of the day. 

Its Wheel_Arrival_Time is outside of the specified 
program time frame (from t0 through t1). This rule has 
2 exceptions:  

• Its ETA is within the specified program time. 
• It has a slot ID and its ETA is later than t0. 

Its Wheel_ Arrival_Time is within the specified 
program time frame, but the flight is active and its ETA 
is earlier than t0, and this is the first program of the day. 

It is not an Exclude_and_Exempted flight: defined as a 
flight whose ETA is later than t0, AND is excluded 
because of the above criteria (a-e), it is then exempted 
from Step 2 below. 

a. 

b. 

c. 

d. 

A flight is NOT included in 
the program if one or more 
of the conditions (a-e) are 
true AND f is not true. 

It has been removed. 

Its AFIX, Aircraft type, or major carrier does  
not fit specified criteria (input item (d), (e),  
and (f)). 

e. 

f. 
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Step 2 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 3 
 

 
 
 

                                                   
1 Earliest_Cta is a temporary value for each flight to indicate the earliest time the flight’s new Controlled Time of 
Arrival (CTA) can be. 

Use the exemption criteria specified by the user to determine if an included flight is exempted 
from this program. Each of the following exemption criteria (a - e) is checked against the 
included flight. 

Specific Departure Airport (input item (n)). 
a. 

Departure_Time or Status  (input item (k), (l)).  
IF exempt by departure status is selected (input item (k)), 
the flight is exempted when the flight’s ETD has a prefix of 
‘A’ or ‘E’. 
ELSE (exempt by departure time is selected (input item 
(k)); 

• IF exempt GS flights by departing status (input 
item (l)), then the flight is exempted when its 
CTL_TYPE is “GS”, and its ETD has a prefix letter 
of ‘A’ or ‘E’; 

• IF the flight is still not exempted at this point, 
check its departure time: 

o IF CTD exists, set t = CTD;  
ELSE Set t = Wheel_Departure_Time; 

o The flight is exempted when t is less than 
(earlier than) Data_Time (input item (c)) + 
Plus_Time (input item (l)). 

 

b. 

Specific flight (input item (m)). c. 

Source facilities (input item (o)). d. 

Schedule Arrival Time - IF a flight is scheduled to arrive 
before the GDP start time, but is delayed into the GDP time 
frame, this flight shall be exempted to avoid double penalty. 
Wheel_Arrival_Time is used as the scheduled arrival time 
if the flight is not controlled, otherwise CTA is used. 

e. 

Create 3 sorted queues (Q1, Q2, & Q3) and assign an Earliest_Cta1 value for each of the included 
flights. 

IF any specified 
exemption criteria 
(a - e) is true, THEN 
the flight is exempt 
from the program. 
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2 Q1 is sorted by ETA to maintain the current flight arrival order.  
 

Set ETE  

Exempt_q2(ordered by the ETA of these flights). This queue contains the Exempted 
flights and the Exclude_and_Exempted flights. 

• For Exempted Flights: Set its Earliest_Cta = ETA if the flight has a Slot ID;  
ELSE set its Earliest_Cta = Min (ETA, Wheel_Arrival_Time). 

• For Exclude_and_Exempted flights: Set its Earliest_Cta = ETA 

Q1. 

Non_Exempt_GDP_q (ordered by the Slot_Time of these flights). 
 This queue contains two kinds of flights: 

• The Non-Exempted flights with a slot ID.  One exemption: if this is a Slot 
Created Substitution (SCS) flight (indicated by the fact that none of the Delay 
Status flags of GDP, GS, and FA is set in the flight record), which means the 
slot ID was created by carriers in the SCS process, then this flight will be 
contained in Q3 (see page 9). 

• The included flight without a CTA but with an ETA before specified “last 
GDP ending time” (the flight “pop-up” in the previous program time frame), 
assign a virtual Slot_Time to this kind of flight at its ETA for sorting purpose. 

Q2. 

Calculate the Earliest_Cta for each flight in this queue (Q2).  

IF the flight is checked against “Departure_Status exemption” instead of 
“Departure_Time exemption” (input item (k), then Set the Earliest_Departure_Time = 
Data Time;  
ELSE Set the Earliest_Departure_Time = Data_Time + Plus_Time. 
 

a. 

b. 
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Step 4 
 
 
 
 
 

                                                   
4 Earliest_Departure_Time = Data_Time for the GS flight whose exemption status is checked against 
Departure_Status and  Data_Time + Plus_Time for all other flights. 
5 Q3 uses CTA for ordering Slot Credit Substitution (SCS) flights, use Wheel_Arrival_Time for all other flights in 
Q3. 

IF the Earliest_Departure_Time4 is later than BETD of the flight, Set Earliest_Cta = 
[Earliest_Departure_Time + ETE];  
ELSE Set Earliest_Cta = Wheel_Arrival_Time.  
 

Non_Exempt_Non_GDP_q (ordered by the Wheel_Arrival_Time of these flights with 
exceptions) 5. This queue contains all the included flights that are not in Q1 or Q2. 

Calculate the Earliest_Departure_Time for each flight in this queue.  

IF the flight is checked against “Departure_Status exemption” instead of 
“Departure_Time exemption” (input item (k), THEN Set the Earliest_Departure_Time 
= Data_Time;  
ELSE Set the Earliest_Departure _Time = Data_Time + Plus_Time. 

IF the Earliest_Departure_Time is later than BETD of the flight, THEN set 
Earliest_Cta to (Earliest_Departure_Time + ETE);  
ELSE Set Earliest_Cta = Wheel_Arrival_Time. 
 

Modify the slot holding status based on user input (input item (q)). 

Q3. c. 
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Step 5 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 
 
 

 
 
 

Step 6 
 
 
 
 

 
 

                                                   
6 See “+/- Delay” Algorithm (page 5) 
7 The two statements contained in this box are necessary since ETA of some flights is modified by this step 
of delay releasing.. 

For every flight in the system, change the Slot Hold flag from ‘Y’ to ‘-’ if its parent carrier or the 
flight itself is to be overridden. 

Release all delay for some of the exempted flights. 

Create a Release_Delay_q to contain flights that are exempted because reasons 1-4 are all true. 
1 It is specifically exempted (input item (m)) OR 

It is coming from a specifically exempted Departure airport (input item (n)) OR It is not 
coming from a facility involved (input item (o)). 

2 It has a slot ID. 
3 It is not canceled. 
4 Its CTD is later than current Data_Time. 

  

Release all delays from the flights in the Release_Delay_q by running them through the “+/- 
Delay” Algorithm6 with adjust minutes set to -999, and Plus_Time set to 0 minutes. 

For each flight in Release_Delay_q, Set Earliest_Cta = ETA. 
Re-sort the Exempt_q (Q1).7 

Create Virtual slots. 
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Step 7 
 
 

 
 
 
 

 
 

 
. 

 
 

 
  

 
   . 

 
 

 
   
 
 
 
 

                                                   
8 The effective AAR calculation only applies to the hours in the GDP period. For the hours outside of the GDP 
period, effective AAR = specified AAR. 

For each 15-minute in the specified program time, derive the effective Airport Arrival Rate 
(AAR) based on the AAR and GA factor (input item (i), (j)).  The GA factor is distributed 
evenly into the four 15-minute periods of an hour. The effective AAR equals to AAR minus 
GA factor (e.g., AAR = 8 and GA factor = 1, then the effective AAR = 8 - 1 = 7.) 8 

Based on the effective AAR, creates virtual slots and uniquely labels them by their time 
position and a postfix letter; e.g., 1820A, 1830B…etc.  The postfix letter is used to 
distinguish multiple slots at the same time position.  Initially mark all slots available. 

Assign slots to flights in sequence of Q1, Q2, and Q3 (a, b, and c). 

Process the flights in the Exempt_q (Q1). Follow steps (i-ii). 
i. Get a flight from the queue and assign the available slot that is closest, but 

not earlier than, the Earliest_Cta of the flight to the flight. 
ii. Once a slot is assigned to a flight, mark it unavailable.   

Process the flights in the Non_Exempt_GDP_q (Q2).  Follow the same steps (i-ii) 
as in (a). 

a. 

b. 

Process the flights in the Non_Exempt_Non_GDP_q (Q3).  Follow the same steps 
(i-ii) as in (a). c. 
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Step 8 
 
 
 
 
 
 
 
 
 

Loop A 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
End Loop A 
 
 
 
 
 
 

Assign OCTA/CTA to the flights (the OCTA is assigned only once for a flight, if a flight already 
has a OCTA value, then this process will only apply to CTA). 

Process the flights in the Exempt_q (Q1). Do Loop A. a. 

IF the flight is an Exclude_and_Exempted flight, do not process it, 
throw away the associated slot and remove this flight from the 
Exempt_q and move to the next flight in the queue.  If not, then go to 
(ii). 

Set its CTA = slot time. 

IF the flight never had a CTA, set its CTD = ETD;  
Else: 

• IF the flight is not activated, also set its CTD = ETD; 
ELSE the flight’s CTD remains the same as before. 

ii. 

iii. 

i. 

Process the flights in the Non_Exempt_GDP_q (Q2) and 
Non_Exempt_Non_GDP_q (Q3). Do Loop B. 

b. 

IF there are no more flights in the Exempt_q (Q1), THEN break out 
of Loop A. 

iv. 
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Loop B  
(For each flight in queue Q2 and Q3). 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
End Loop B 
 

Step 9 
 
 
 

                                                   
9 The Earliest_Depart_Time is defined as the data time for the GS flight whose exemption status is checked against 
departure status, and [data time + Plus_Time] for all other flights. 

Calculate its ETE. 

IF (Slot_Time - BETA) is greater than specified Delay Ceiling (input 
item (g)), set New_Slot_Time = BETA + Delay Ceiling.  Modify the 
slot ID to New_Slot_Time.  Set Slot_Time = New_Slot_Time. Set 
CTA = New_Slot_Time  
 

ii. 

Back calculate New_EDCT = Slot_Time - ETE.  If  
New_EDCT is earlier than Earliest_Departure_Time,  
set New_EDCT = Earliest_Departure_Time.9 

Set EDCT = New_EDCT; Set CTA = Slot_Time. iv. 

Set ETD = EDCT; Set ETA = CTA. v. 

Adjust all the open slots associated with the included flight (Auto-Delay Algorithm).  Do Loop C. 

IF there are no more flights in the Non_Exempt_GDP_q (Q2) and 
Non_Exempt_Non_GDP_q (Q3), THEN break out of Loop B. vi. 

i. 

iii. 
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Loop C 
(For each flight in Q1, Q2, and Q3). 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

                                                   
10 In revised GDP, the flight may be unable to move all the way up to its slot time. 

IF the flight is cancelled, update its associated open slot’s position to the flight’s CTA, go 
back to the top of Loop C and process the next flight.  ELSE, go to (c). b. 

If the flight is from Exempt_q (Q1) (the flight is exempted), go through steps (i and ii). 
ELSE, go to (c). 

i. IF the flight has a slot time earlier than its ETA, THEN create a delayed open slot 
and position it at the flight’s slot time. 

ii. IF the flight has a slot time later than or equal to its 
ETA, THEN remove its associated open slot (if any). 

c. 

IF the flight is not from Exempt_q (Q1) (the flight is not exempted), go through steps (i - 
ii).  Else, go to d. 

i. Set Earliest_Az = Earliest_Arrival_Time 
ii. IF the flight’s slot time is earlier than its Earliest_Az,  

AND its ETA is earlier than its Earliest_Az THEN do  
steps( I and II).  
ELSE, go to (iii). 
I. Set ETA = Earliest_Az. 
II. Create/Update its associated open slot’s positioning at its slot time.  

iii. If the flight’s slot time is earlier than its ETA (in revise GDP, the flight my be 
unable to move all the way up to its slot time), THEN do III. 
I. Create an open slot for the flight. The created slot is located at the flight’s 

slot. 

d. 

Set Earliest_Arrival_Time = 
i. ERTA; if ERTA is not provided then use: 

ii. LRTA; if LRTA is not provided then use: 
iii. LGTA – 10 minutes; if LGTA is not provided then use 
iv. IGTA – 10 minutes. 

a. 
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End Loop C  

 

Step 10 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
End of RBS++ Algorithm 

 
 
 
 
 

                                                   
11 See Compression Algorithm (page 5 ) 

Run Compression 

Run Compression (See Compression Algorithm10) with the following parameters (1 - 5). 
1 Start_Time = GDP start time. 
2 End_Time = GDP end time. 
3 Slot holding carrier override = None (already considered in GDP algorithm Step 4).  
4 Window_Parameter = 0. 
5 Data_Time = GDP Data_Time. 

a.  

IF there are no more flights in Q1, Q2, or Q3, THEN break out of Loop C. 
e.. 

To Top of 
Loop C 

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Rationing by Schedule (RBS++) Algorithm 

Version 7.8 B-14 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 This page intentionally left blank

PDF created with pdfFactory trial version www.pdffactory.com

http://www.pdffactory.com


 Compression Algorithm 

Version 7.8 B-15 

 
 

B.3 Compression Algorithm 
              (“Prioritize Member”) 

 
 
 
 
 
 
Step 1 

  
 
   
 
 
Step 2 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

After passing the above 3 conditions, check if its associated flight is cancelled and 
the slot-hold flag is on, which makes the open slot not eligible. Otherwise the open 
Slot is eligible.  

This Function requires the following input parameters: 
a. Start_Time = t0 
b. End_Time = t1 
c. Slot_Holding_Carrier_Override(s) 
d. Window_Parameter (default = 0) 
e. Data_Time 
f. Minimum_Move_Up_Time 
 

Modify the slot holding status based on user input (input item (c)).  
 

IF a flights parent carrier or the flight itself is optioned to be overridden, THEN 
change the Slot_Hold_Flag from ‘Y’ to ‘-’ for every flight in the system. 

Find all eligible open slots for Compression. (for both pure compression 
operation and compression with RBS++) An eligibility check of an open slot 
is as follows; All conditions (a-c) must be met: 

a Time of Slot_Time is between t0 and t1. 
b Its associated flight has a slot ID (the Open_Slot is displayed in a solid 

color). 
c Its associated flight is not a pop-up flight (Ctl_Type = FA). 
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Step 3 
 
 
 
Step 4 
 
 

  
 
 
 
 
 
 
 
 
 
 
Step 5 
 

 
 

Set Wheel_Arrival_Time = IGTA - taxi. IF the IGTA of the flight has no value, use 
the following fields in the listed order below: 

• SGTA – taxi 
• LGTA – taxi 
• PGTA – taxi 
• BETA (ETMS ETA) 

Put these open slots in an Open_Slot_queue (Osq) from Step 2; sorted in reverse 
order by their Floor_Time. 

Find all arrival flights eligible for Compression. A flight is eligible if all conditions 
(a-f) are met. 

a It is not canceled. 
b It has a slot ID. 
c It is not a pop-up flight (Ctl_TYPE = FA). 
d Its ETA is later than or equal to t0. 
e It is not active 
f Its ETD is later than or equal to the Earliest_Departure_Time of all flights. 

• For pure compression – The Earliest_Departure_Time is Data _Time + 
30 minutes. 

• For Compression within RBS++ - The Earliest-Departure_Time is 
calculated in RBS++ algorithm Step 3 (b) (i.e. If the flight is checked 
against "departure status exemption" instead of "departure time 
exemption" (input item (k) in RBS++ algorithm), set the 
Earliest_Departure_Time = Data_Time; ELSE set the 
Earliest_Departure_Time = Data_Time + Plus_Time.) 

 

Put the eligible flights in a flight queue (Fq), sorted by their ETA. 
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Step 6 
 

 
 
Loop 1 – for each Open_Slot in the Osq. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Loop 1.1 
 
  
 
 
 

                                                   
12 See “Inter-airline Compression (for one open slot)” (page 5) 

From Loop 
1.1 (c or e) 

Set the Floor_Time for the open slot in case its associated flight has moved. 

IF the Floor_Time for the open slot is earlier then the current position of the open 
slot, remove the Open_Slot and go back to the top of Loop 1 and process the next open 
slot. ELSE, go to c. 

a. 

b. 

Create a Temporary_Flight_Queue (TFq) that contains all eligible flights in Fq. c. 

d. 

Run Inter-airline compression11 using flights in the TFq.  The run will move only the 
first qualified flight in the TFq. 

True False 

Do Loop 1.2, Page 24 

Run the Compression Algorithm, do Loop 1 below. 

IF the flight associated with this open slot is a “former pop-up” (FA_Delay flag is set) OR 
the flight is removed. 

a. 
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Loop 1.1.1 
 
 
 
  

 

 

Loop 1.1.1.1 
   

 
   
 
 
 
 
 
  

                                                   
13 See “Inter-airline Compression (for one open slot)” (page 5) From Loop 

1.1(e) 

Decrement Minimum_Move_Up_Time by 1 minute. 

Run Inter-airline Compression.12 

Break out of Loop 1.1 and go to 
Loop 1(e), Page 25. 

True False 

False 

To top of 
Loop 1.1. 

True 

False 

False 
True 

True 

IF a flight is moved, check the current position of the Open_Slot, if it is later than or equal 
to the Floor_Time OR if it is later than or equal to t1. 

If no flights have been moved due to the Inter-airline compression, which means no flight 
can be moved with configured Minimum_Move_Up_Time, then do Loop 1.1.1. 

IF Minimum_Move_Up_Time is less than or equal to 0.  

If no flight is moved 

To Loop 1.1 
(d). 

b. 

c. 
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End Loop 1.1.1.1 
           
End Loop 1.1.1 
 
   
 
  
 
 
 
 
 
 
 
 
End Loop 1.1 
 
Loop 1.2 (from Loop 1 (d.)) 

 
 
  
 
 
 
 
  
 
 
 
 
 
 

                                                   
14 See “Intra-airline Compression (Substitution) Algorithm (for one open slot)” (page 5) 
15 See “Inter-airline Compression (for one open slot)” (page 5)  

False 

To Loop 1 (e). 

Run Intra-airline Compression13 using flights in the TFq.  The run will exhaust the 
TFq and move as many flights as possible. 

Reset the Minimum_Move_Up_Time to its original (configured) value. 

Check the current position of the Open_Slot, IF it is later than or equal to the 
Floor_Time OR IF it is later than or equal to t1, THEN break out of Loop 1.1 and go 
to Loop 1 (e). 

True 

False 

True 

From Loop 
1.1.1 To Top of 

Loop 1.1 

IF any flight is moved due to Intra-Airline Compression, check the Slot_Time of the 
open slot, IF it is later than or equal to the Floor_Time or t1. 

Run Inter-airline Compression14  using flights in the TFq.  The run will only move the 
first qualified flight in the TFq. 

IF any flight is moved, check the Slot_Time of the Open_Slot, IF it is later than or 
equal to the Floor_Time or t1. 

a. 

b. 

c. 

d. 
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End Loop 1.2 

 
Loop 1 cont. 

 
 
 
 
 
 
 
 
 
 
 
End Loop 1 

 
Step 7 
 
 
 
 

 

False 

IF the Slot_Time of the Open_Slot is later than or equal to the Floor_Time, THEN 
remove the slot. ELSE, go to f. e.  

IF the associated flight of the Open_Slot is canceled, modify the ETA of this canceled 
flight to where its open slot’s Slot_Time is. f.  

Validate the open slots because of the possible movement of its associated flight.  Go 
through Loop 2.   

False 

True 

Up to top of 
Loop 1.2 

Go to the top of Loop 1, (Page 22) 

True False 

IF no flights have been moved due to the intra-airline and inter-airline compression, 
which means no flight can be moved with configured Minimum_Move_Up_Time, 
THEN Decrement Minimum_Move_Up_Time by 1 minute. 

IF the Minimum_Move_Up_Time is equal to 0, reset the 
Minimum_Move_Up_Time to its original (configured) value. 

From Loop 
1.1(e) or Loop 
1.2 

IF there are no more open slots in the Osq. g.  
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Loop  2- for each Open_Slot in the system 
 
 

 
 
 
 
 
 
 
 
End Loop 2 
 
 
End of Compression Algorithm (“Prioritize Member”)

False 

IF its associated flight is cancelled, check the next Open_Slot.  
ELSE, go to b. 

IF the Slot_Time of the Open_Slot is later than its associated flight’s ETA, THEN 
remove the Open_Slot. 

a.  

b.  

IF there are no more open slots in the system c.  
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B.3.1 Intra-airline Compression Algorithm  
                          (For one open slot) 

 
 
 
 
 
 
 
 
 
 
 
 
Loop A – for each flight in the TFq, say Flt. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This Function requires the following input parameters: 
a. An Open_Slot  
b. A flight record (Open_Flt), which is associated with Open_Slot. 
c. The flight queue (TFq) containing all eligible flights for Substitution. 
d. Earliest_Departure_Time. For pure compression, the value of this 

field equals to Data Time + 30 minutes; For compression within 
RBS++, the value of this field is calculated in RBS++ algorithm Step 
3(b). 

e. Window_Parameter 
f. Minimum_Move_Up_Time 
 

 

IF Flt does not belong to the same parent airline as Open_Flt, THEN go back to the 
top of Loop A. b. 

IF Flt is a GA/military flight, a “former pop-up” or is removed, THEN go back to the 
top of Loop A. c. 

If the Open_Flt is a GA/Military flight, a former pop-up flight, or is removed, then break 
out of this function (intra-airline compression does not apply to open slots associated with 
those flights).   

Set ETE 

Set Earliest_Arrival_Time = 
i. ERTA; if ERTA is not provided then use: 

ii. LRTA; if LRTA is not provided then use: 
iii. LGTA – 10 minutes; if LGTA is not provided then use; 
iv. IGTA – 10 minutes 

a. 
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End Loop A 
 
End Intra-Airline Compression Algorithm

                                                   
16 d_time is potentially where flight ends up. 
17 o_time is where flight is at. 
18 See Move Up a Flight Algorithm (page 5). 

IF the ETA of flt is earlier than the current position of Open_Slot or is later than the 
Floor_Time of Open_Slot, THEN go back to the top of Loop A. d. 

Set Bottom_Time = the Slot_Time of Open_Slot + Window_Parameter. 
e. 

f. 

Derive the Earliest_Eta for the flight: Do steps (i-iii). 
i. Set Earliest_Eta = Earliest_Arrival_Time 
ii. Set Earliest_Etd = Earliest_Arrival_Time - ETE 
iii. IF Earliest_Etd is earlier than Earliest_Departure_Time, THEN Earliest_Eta = 

Earliest_Depart + ETE. 

g. 

If o_time minus d_time is greater than or equal Minimum_Move_Up_Time, then move 
Flt up from o_time to d_time.  (See Move Up a Flight Algorithm17); remove this flight 
from the TFq, so it will not be processed again for the same Open_Slot. 

h. 

To top of 
Loop A 

IF Earliest_Eta is later than the Bottom_Time, THEN go back to the top of Loop A.   
ELSE it is possible to move Flt up. Do (i-ii) below. 

i. Set d_time = max (Earliest_Eta of Flt, the Slot_Time of Open_Slot).15 

ii. Set o_time = ETA of flight.16 
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B.3.2    Inter-airline Compression Algorithm 

              (“Prioritize Member” for one open slot) 
 
 
 
 
 
 
 
 
 
Loop B 
 

Step 1 
 
 
 
 
 

 
Step 2 
 
 

 
 

 
 
End Loop B 
 
End of Inter-airline Compression Algorithm 

                                                   
19 See “Compress Flight Algorithm” (page 5) 
20 See “Compress Flight Algorithm” (page 5)  

This function requires the following input parameters: 
a. An Open_Slot.  
b. A flight record (Open_Flt), which is associated with Open_Slot. 
c. The flight queue (TFq) containing all eligible flights for Compression.  
d. Window_Parameter. 

Run Compress Flight Algorithm18 with member-only option.  The run will move only 
the first qualified flight in the TFq.  If a flight is moved due to this member-only 
compression, return. 

Run Compress_Flight Algorithm19  with non member-only option.  
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B.3.3 Compress Flight Algorithm 
 

        
This function requires the following input parameters: 
a. An Open_Slot. 
b. A flight record (Open_Flt), which is associated with Open_Slot. 
c. The flight queue (TFq) containing all eligible flights for Compression. 
d. Option_Flag of “member-only” or “non-member-only”. 
e. Earliest_Departure_Time.  For pure compression, the value of this field equals to Data_Time + 30 

minutes; For compression within RBS++, the value of this field is calculated in RBS++ algorithm 
Step 3(b). 

f. Window_Parameter. 
g. Minimum_Move_Up_Time. 
 
 
Loop C 
For each flight in the flight queue, say Flt. 
 
 
 
 
  
 
  
 
 
 
                
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

True 

b. 

Set ETE IF configured to use MAX_ETE,  
ELSE set ETE = ETA-ETD.   

False 

IF any one condition (i-iv) is true, THEN go back to top of Loop C.  ALL must be 
FALSE to go to d.   

i. IF the option flag is “member-only” and the Flt does not belong to a CDM 
Member carrier. 

ii. IF the option flag is “non-member-only” and Flt belongs to a CDM member. 
iii. IF Open_Flt is not a former pop-up, AND is not a removed flight, AND Flt 

belongs to the same parent airline as Open_Flt. 
iv. IF the ETA of Flt is earlier than the Slot_Time of Open_Slot OR is later than the 

Floor_Time of the Open_Slot. 

a. 

From  
Loop C 
(g or f). 

Set Earliest Arrival Time = 
i. ERTA; if ERTA is not provided then use: 

ii. LRTA; if LRTA is not provided then use: 
iii. LGTA – 10 minutes; if LGTA is not provided then use; 
iv. IGTA – 10 minutes 

c. 
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End Loop C 
End Compress Flight Algorithm 
 

                                                   
21 See “Move Up a Flight Algorithm (page 5) 

True 

False 

Set Bottom_Time = the Slot_Time of Open_Slot + Window_Parameter. 

Derive the Earliest_Eta for Flt: 
i. Set Earlist Eta = Earliest_Arrival_Time 
ii. Set Earliest_Etd = Earliest_Arrival Time - ETE 

iii. IF Earliest_Etd is earlier than Earliest_Depart_Time, THEN Earliest_Eta = 
Earliest_Departure_Time + ETE. 

d. 

e. 

IF Earliest_Eta is later than the Bottom_Time, THEN go back to the top of Loop C.   
ELSE it is possible to move Flt up: 

i. Set d_time = max (Earliest_Eta of Flt, the Slot_Time of Open_Slot) 
ii. Set o_time = ETA of Flt. 

f. 

To top of 
Loop C 

IF o_time is earlier than or equal to Minimum_Move_Up_Time. 
 

g. 

THEN move Flt up from o_time to d_time (see Move Up a Flight Algorithm20). Remove 
Flt from TFq so it will not be processed for this Open_Slot again.   
 

h. 
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B.3.4   Move Up a Flight Algorithm 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
End Move Up a Flight Algorithm 
 
 
 
 
 

This function requires the following input parameters: 
a. flight record (Flt), which is to be swapped with an open slot. 
b. Open_Slot. 
c. A flight record (Open_Flt), which is associated with Open_Slot. 
d. The time from where the flt is moving (ot). 
e. The time to where the flt is moving (dt). 

 

a. 

b. 

c. 

IF Flt and Open_Flt is the same, THEN return immediately. 
ELSE: 

IF the Slot_Time of Flt is later than the Slot_Time of the Open_Flt, THEN follow steps 
(i-vi): 

i. Swap the slot ID (and thus the Slot_Time) between Open_Flt and Flt. Set CTA 
of Flt = new slot time of Flt; Set CTA of Open_Flt = new slot time of Open_Flt. 

ii. Based on the their new CTA, derive the new CTD (CTA – ETE), set CTD of the 
Flt = new CTD of the Flt; Set CTD of the Open_Flt = new CTD of the 
Open_Flt if the Open_Flt is not active AND new CTD is later than the CTD of 
Open_Flt. 

iii. Set ETD and ETA of Flt = new CTD and CTA of Flt. 
iv. Set the Slot_Time of Open_Slot = CTA of the Open_Flt. 
v. IF ETD of Flt is earlier than its BETD, set ETD = BETD, and set CTD = BETD. 
vi. Set ETA of Flt = CTA of Flt. 

IF the Slot_Time of Flt is earlier than the Slot_Time of the Open_Flt, THEN follow 
steps (i-iii): 

i. Modify the ETA of Flt to dt. 
ii. Derive the ETD of Flt using ETA - ETE. 
iii. IF ETD of Flt is earlier than its BETD, set ETD = BETD, and derive ETA = 

(new) ETD + ETE 

RETURN 
d. 
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B.4 “+/- Delay” Algorithm 
 

 
 
 
 
 
 
 
 
 
 

Step 1 
 
 
 
 
 
 
 
 

Step 2 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note that the “program” in the following text refers to “+/- Delay” program. This function requires the 
following input parameters: 
a.  Start time = t0 
b.  End time = t1 
c.  Data_Time 
d.  Included AFIX 
e.  Included Aircraft Type 
f.   Included Major Carrier 
g. Adjusted minutes (A_Min) 
h. Plus_Time in minutes indicate how many minutes within the data time should be used  
    for departure exemption 
i.  Specific flight exemption 
j.  Specific airports exemption 
k. Facilities (centers/airports) involved 

Use the exemption criteria specified by the user to determine if an included flight is 
exempted from this program.  
 

Find all arrival flights included in the program.  A flight is included IF all three criteria (i-
iii) below are true: 

i. Its AFIX, Aircraft Type, and Major Carrier fit specified criteria. 
ii. It has a slot ID 
iii. Its ETA is within the specified program time (from t0 through t1) 

 

Set Wheel_Departure_Time = IGTD - taxi. IF the IGTD of the flight has no value, use the 
following fields in the listed order: 

• SGTD + taxi 
• LGTD + taxi 
• PGTD + taxi 
• BETD (ETMS ETD) 
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Step 3 
 
 
 
 
Loop 1 
Process each flight in the Non-Exempt_q. 
 
 
 
 
 
 

From 
Loop 1(f) 

Set Wheel_Arrival_Time = IGTA - taxi. IF the IGTA of the flight has no value, use the following 
fields in the listed order: 

• SGTA – taxi 
• LGTA – taxi 
• PGTA – taxi 
• BETA (ETMS ETA) 

 

Adjust delays to the flights in the Non_Exempt_q.  Go through Loop 1. 
 

Get a flight from the Non_Exempt_q. 

Each exemption criteria below (a-e) are checked against the flight: 
a Specific source airport (input item (j)). 
b Departure time- IF CTD is valid, set t = CTD;  

ELSE set t = Wheel_Departure_Time; the flight is exempted when t is less than (earlier 
than) Data_Time (input item (c)) + Plus_Time (input item (h)). 

c Specific flight (input item (i)). 
d Source facilities (input item (k)). 
e Schedule Arrival – IF a flight is scheduled to arrive before the t0, but is delayed into the 

“+/-” time frame, this flight should be exempted to avoid double penalty.  
Wheel_Arrival_Time is used as the scheduled arrival time if the flight is not controlled; 
ELSE, CTA is used. 

Add the flight in the Non_Exempt_q if it is not exempted. 
 

a. 
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22 A flight is active if its ETD has a prefix letter of “A” or “E”. 

d. 

b. 

c. 

True 

Calculate its ETE IF configured to use MAX_ETE,  
ELSE, set ETE = ETA – ETD. 

Get the slot time of this flight. 

New_Slot_Time = Slot_Time + A_Min 

Modify the slot ID based on 
New_Slot_tTme 

Set CTA = New_Slot_Time. 

Back calculate the EDCT, set 
New_EDCT = CTA - ETE. 

IF the flight is not active21, THEN set 
EDCT = New_EDCT. 

New_Slot_Time = Slot_Time -abs(A_Min). 

Set Earliest_Az = Earliest_Arrival_Time. 

IF Earliest_Az is later than ETA, set  
Earliest_Az = ETA 

IF New_Slot_Time is earlier than  
Earliest_Az, THEN set New_Slot_Time = 
Earliest_Az. 

Back calculate the New_EDCT =  
New_Slot_Time - ETE. 

False e. IF A_Min is positive: 

To top of 
 Loop 1 

Set Earliest Arrival Time = 
i. ERTA; if ERTA is not provided then use: 

ii. LRTA; if LRTA is not provided then use: 
iii. LGTA – 10 minutes; if LGTA is not provided then use; 
iv. IGTA – 10 minutes 
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End IF  
        
 
   
End Loop 1 

Step 4 
 
 
 
 
 
 
End “+/- Delay” Algorithm 

                                                   
23 A flight is active if its ETD has a prefix letter “A” or “E”. 

False 

To top of 
 Loop 1 

f. 

IF New_EDCT is earlier than the “Data_ 
Time + Plus_Time (input item (h))”, THEN 
set New_EDCT = “Data_Time + 
Plus_Time”; Set New_Slot_Time =  
“Data_Time + Plus_Time + ETE. 

Modify the slot ID based on 
New_Slot_Time. 

IF the flight is not active22, THEN set 
EDCT = New_EDCT. 

Set CTA = New_Slot_Time 

IF ETA is earlier than CTA, set ETA = 
CTA; set ETD = New_EDCT. 

Adjust associated open slot of the flight based on the flights’ new slot time position. 
 

IF ETA is earlier than CTA, set ETA = 
CTA; Set ETD = New_EDCT. 

IF there are no more flights in the Non_Exempt_q 

From Loop 1(d) 
True 

True 
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B.5 Ground Stop Algorithm 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 1 
 
 
 
 
 

Step 2 
 
 
 
 
 
 
 

                                                   
24 The current panel selection is the first for Ground Stop parameters. 
25 The difference lies in the default setting of the above parameters. 

Note: The “program in the following text refers only to “Ground Stop” 
program. 

This function requires the following input parameters: 
 
a. One or more Ground Stop Statements, each contains the following parameters:23 

 1.  Start time = t0 
 2.  End time = t1 
 3.  Involved facilities - centers and/or airports 

b. Included AFIX 
c. Included Aircraft Type 
d. Included Major Carrier 
e. Target AAR (for each 15 minute time period) 
f. Plus_Time in minutes indicate how many minutes within the data time should be used for 

departure exemption 
g. Specific flights exemption 
h. Specific airports exemption 
i. Data_Time 
j. Option of Immediate/Future Ground Stop is intended.24 
 

Put all the input Ground Stop Statements into a statement-queue, sort the queue 
by t1 (End Time) of the Ground Stop Statement. 

Process each flight record in the system, Do Loop 1. 
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Loop 1 
For each flight in the system 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Loop 2 
For each Ground Stop 
Statement in the statement-queue 
 
 
 

 
 
 
 
 
 
 
 
 

From   
Loop 2(e). 

False 

Determine if the flight is included.  A flight is included if conditions (i & ii) below are 
both met. 

i. It is not cancelled. 
ii. Its AFIX, Aircraft type, and Major Carrier fit specified criteria. 

a. 

Further check this flight against inclusion and exemption criteria specified in this 
particular ground stop statement.   

b. 

True 

Set Wheel_Arrival_Time = IGTA – taxi.  If the IGTA of the flight has no value, use 
the following fields in the listed order: 

• SGTA – taxi 
• LGTA – taxi 
• PGTA – taxi 
• BETA (ETMS ETA) 

 

c. 

Set Wheel_Departure_Time = IGTD + taxi.  If the IGTD of the flight has no value, 
use the following fields in the listed order: 

• SGTD + taxi 
• LGTD + taxi 
• PGTD + taxi 
• BETD (ETMS ETD) 

 

d. 

a. 

The flight is excluded from this ground stop statement if its ETD is not within the 
specified time frame (between t0 and t1). b. 

IF the flight is included. 
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End Loop 2 
 
End Loop 1 
 

Step 3 
 
 
 
 

                                                   
26 The flight is exempted when t is less than (earlier than) Data Time (input item (i)) + Plus_Time (input item (f)).  
27 Because the Ground Stop statements are sorted by its t1 (Step 1), the flight will always get the latest new_ETD if 
more than one statement includes this flight. 

To Top of 
Loop 2 

Assign CTA and ETA to the flights that were added to the flight-queue in Step 2. 
 

The flight is exempted from this ground stop statement if any of the below conditions 
(i-v) are met. 

i. Specific Departure airport (input item (a.3)). 
ii. Departure time. 25 

I. IF  CTD exists, THEN set t = CTD 
ELSE set t = Wheel_Departure_Time 

iii. Specific flight (input item (g)). 
iv. Source facilities (input item (a.3). 
v. Schedule Arrival –  

I. IF a flight is scheduled to arrive before t0, but is delayed into the 
Ground Stop time frame, this flight shall be exempted to avoid double 
penalty.  Wheel_Arrival_Time is used as the scheduled arrival time if 
the flight is not controlled; 
ELSE, CTA is used. 

c. 

d. 
IF the flight is not excluded or exempted, THEN set New_ETD = (t1 + 1min)26 AND 
put the non-exempted flight in a flight queue. 

False 

True 

e. IF this flight is the last flight in the queue. 
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Loop 3 
For each flight in the Flight_Queue. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
End Loop 3 
 
End of Ground Stop Algorithm 
 
 

                                                   
28 A flight is active if its ETD has a prefix letter of ‘A’ or ‘E’. 

Calculate its ETE IF configured to use MAX_ETE,  
ELSE set ETE = ETA-ETD. 

 

Set CTA = ETA = New_ETD + ETE. 
 

Set ETD = New_ETD. 
 

a. 

b. 

c. 

d. 

Modify the slot ID based on CTA. 

 
e. 

f. 
False 

 IF this flight is the last flight in the queue. 

 

If the flight was never controlled, Set EDCT = New_ETD.  ELSE IF the flight is not 
active27, Set EDCT = New_ETD 
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a. 

C.2 Purge Algorithm 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 1  
 
 
 
 
 

Step 2 
 
  
 
 
 
 
 
  
  
 

Step 3  
 
  
 
 
 
 
 

The Purge Algorithm is used by FSM to model the cancellation of a Traffic Management Initiative.  
The ECDT > Purge command is sent to ETMS for implementation.  ETMS then uses the same logic for 
the Actual purge. 
 
This function requires the following input parameters: 
 

a. MIN_NOTIF_AFTER_EDCT_PURGE = 45 minutes. 
 

Note: The MIN_NOTIF of 45 minutes is configured in both FSM and ETMS to 
match each other. 45 minutes is the average minimum time an airline needs to 
get a flight ready for takeoff after a program is cancelled. 

 
b. Use_Time 
c. Actual_Depature_Time 

 
 

IF the flight is active or completed, THEN set ETD = Actual_Depature_Time and do 
NOT Purge. Otherwise, do Step 2. 

IF CTD is less than or equal to (now + minimum notification time), THEN do Step 2(a). 
ELSE do Step 3. 

• Do NOT change ETD/ETA  
• Remove control times (CTD, CTA, CTL_ELEM, etc.) 

IF CTD is greater than or equal to (now + MIN_NOTIF_AFTER_EDCT_PURGE THEN do 
Step 3(a & b).  
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a. 

b. 

 
 
 
 
 
 
 
 
 
 
 
 
 
  
  
 
 
 
 

   Step 4 
 
 
 
 
 

Note: Flights that only have OAG data will have already been time-out cancelled, 
as those are based on the SGTD, not the ETD. 

 
 
End of Purge Algorithm 
 
             

                                                   
 

• Remove control times (CTD, CTA, CTL_ELEM, etc.) 
• SET a variable, Use_Time, to the first available of: 

o ERTD 
o (ERTA – ETE) 
o OETD 
o (IGTD + taxi) 

 IF Use_Time is greater than (now + minimum notification time) THEN Set 
ETD = Use_Time.  Otherwise Set ETD = 
MIN_NOTIF_AFTER_EDCT_PURGE. 

Base the time-out delay clock on the new ETD.  That is, a flight will start to time-out delay 
after the new ETD, and will be time-out cancelled 90 minutes after that time.  
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b. 

C.3 Airborne Holding Algorithm 
  

 
 
 
 
 
 
 
 
 
 
 
 

Note: All Operations outlines below are performed on flights of the target airport. 
 

Step 1  
 
 
 
 
 

 
 
 
 
 
 
 
 
  
 
 
 

This function requires the following input parameters: 
 

a. Airport.  The Airport object that the algorithm will be applied to. 
b. Data Time = dt.    
c. Start Time = t0. 
d. End Time = t1. 
e. AAR Values (for each 15 minutes time period). 
f. GA_Factor (per hour or for each 15 minutes time period). 
g. Taxi (Default 10 minutes). 
h. Time field to be used.  (BY_ETA, BY_BETA, BY_WHEEL_AZ, BY_OCTA, BY_CTA, 

BY_EAFT) 
 
 

Find all arrival flights included in the program (included flight queue), 
For each arrival flight: 

Compute Wheel_Arrival_Time = IGTA - taxi.  If the IGTA of the 
flight has no value, use the following fields in the listed order: 

• SGTA - taxi 
• LGTA - taxi 
• PGTA - taxi 
• BETA 

a. 

Derive used time based on input parameter h.  Denote the time as Used_Tm. 
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Step 2  
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
  

Check if the flight is included in the program.  A flight is included in the 
program if its Used_Tm is in [t0, t1] and it is not a cancelled flight. c. 

Put all included flights into the included flight queue. d. 

Set ETA of the flights to the Used_Tm 

Sort the flights in the included flight queue according to their Used_Tm in 
ascending order. 

e. 

f. 

Assign a slot time to the flights in the included flight queue. 

Find the first flight in the included flight queue. a. 

Set the Last_Time to the ETA of the first flight. b. 

Set the Slot_Time of the first flight to the Last_Time. c. 
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End Airborne Holding Algorithm 
 
 
 
 
 
 
 
 
 
 
 
 
 

For each flight remaining in the included flight queue: 
i. Find the step size (interval between flights) according to 

Last_Time and the given AAR (input condition e). 
ii. Update last time using the step size (i.e. Increase last time by 

step size). 
iii. Let the ETA of the current flight be Curr_Eta. 
iv. If Curr_Eta <= Last_Time, set the Slot_Time of the flight to 

Last_Time. 
v. If Curr_Eta > Last_Time, set Last_Time to Curr_Eta and set 

the Slot_Time of the flight to Last_Time. 
vi. Go to step I for the next flight in the queue. 

 

d. 
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Appendix C: Glossary of Abbreviations 
III - Category III Flight (flight remark) 
AAL - American Airlines 
AAR - Airport Acceptance Rate 
ADC - Advise Customs (flight remark) 
Airborne Holding - A deterministic mathematical model used to calculate predicted airborne 
holding. 
AffAvgDelay - (Affective Average Delay) total delay divided by number of non-exempted 
flights, calculated after running a GDP. 
ALD - The carrier imposed a delay on the flight (delay status). 
ARTD /ARTA - Actual Runway Times (Departure/Arrival) 
ASD - Aircraft Situation Display 
ATA - Actual wheels-on Arrival Time 
ATCSCC - Air Traffic Command System Control Center 
ATD - Actual wheels-off Departure Time 
ATR-310 - Traffic Flow Management Integrated Product team 
ATL – Atlanta International Airport 
ATV - Altitude Reservation (flight remark) 
AUA-500 - Air Traffic Systems Development, Traffic/Flight Service Station 
BETD/BETA - Beginning Estimated Wheel Times 
BOS - General Edward L Logan International Airport in Boston 
CC – Alarm Status for flights arriving more than 5 minutes before or more than 5 minutes 
after their Control Time of Arrival 
CDM - Collaborative Decision Making 
CF – Alarm status for flights that were cancelled but later flew without the flight being 

reinstated properly. 
CNX – Cancelled Flight; Cancel  
COA - Continental Airlines 
CTA - Revised OrigCTA (Control Time of Arrival) after substitution/cancellation 
CTD – Control Time of Departure 
CTT - Collaborative Technology Testbed 
DCenter - Departure Center 
DEP - Departure Airport 
DP - Departure Procedure 
DTRSN - Departure Procedure Transition 
DV - The flight was cancelled and diverted to an alternate destination (cancel status). 
DVT - Diversion Recovery flight (flight remark) 
EA - The actual flight time is greater than a specified value, but the flight status is not 
cancelled. The default value is 15 minutes (alarm status). 
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EC - The departure boundaries are more than 5 minutes before or more than 5 minutes after 
their estimated departure clearance time (alarm status). 
ECR – EDCT Request Tool. 
EGF - American Eagle Airlines 
EPS - Airport Engineering Performance Standards 
ERTD/ERTA - Earliest Runway Times 
ETA - Updated Estimated (wheels-on) Arrival Time. Prefixes: P (proposed), E (estimated) 
ETD - Updated Estimated (wheels off) Departure time. Prefixes P (proposed), E (estimated) 
ETE - Estimate Time En Route in minutes 
ETMS - Enhanced Traffic Management System 
FAD - Fuel Advisory Delay 
FADT List - Generated after running a GDP. Contains information about all ground-delayed 
flights (all flights that have been issued an OrigEDCT). If a center or an airline has ground-
delayed flights, their call-signs, departure airports, PTimes, EDCTs and CTAs are given for 
each appropriate center and airline. 
FCA - Flow Constrained Area (flight remark) 
FSM - Flight Schedule Monitor 
FX - A CDM message used by the airlines to indicate a cancelled flight (cancel status). 
GCD - The Great Circle Distance (GCD), which is the distance between the departure airport 
and arrival airport. 
GDP - Ground Delay Program 
GDT - Ground Delay Tools 
GS- Ground Stop 
HITL - Human in the Loop 
IGTD/IGTA - Initial Estimated Gate Times 
LFG - Lifeguard Flight (flight remark) 
LGTD/LRTD/LRTA/LGTA - Airline Gate and Runway Times 
LTOD - Length of Time Out Delay 
MOA - Memorandum of Agreement/Military Operations Area 
NRP - National Route Program Flight (flight remark) 
OAG - Official Airline Guide 
OCTD/OCTA - Original Control Times 
OETD/ OETA - Original Estimated Wheel Times 
ORD - O’Hare International Airport in Chicago 
OOOI – OUT/OFF/ON/IN  - Time that the flight was out of the departure gate, off the 
departure runway, on the arrival runway, and in the arrival gate. 
PGTD/PGTA - Proposed Gate Times (Departure/Arrival) 
Power Run - A Tab in the GDT Setup component, which allows you to model various 
scenarios to help evaluate what parameters are most favorable. 
RBS - Ration By Schedule. A ground delay algorithm based on the OAG time. 
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RBS++ - An enhanced version of RBS which automatically performs compression. 
RM - The flight has been removed from the ETMS database (cancel status). 
RS - An internal ETMS message generated when a specialist takes an OAG flight out of the 
database (cancel status). 
RZ - A NAS flight plan cancellation message (cancel status). 
SGTD/SGTA - Scheduled Gate Times (Departure/Arrival) 
SCDT List - Contains flight delay information for the airport that has been issued a ground 
delay. Contains information such as flight’s call-sign, equipment type, departure airport, 
Ptime, etc. 
Schedule Accuracy - The sum of the absolute values of the difference of (actual departure 
time - estimated departure time) for each flight, divided by the number of valid flights. 
SCS - Slot Credit Substitution 
SF - Spurious Flights or flights submitted as SI cancellations with no corresponding entries in 
the OAD (alarm status). 
SFO - San Francisco International Airport 
Slot List - A modified FADT List. In addition to the information provided by the FADT list, 
the slot list includes the slot ID, flight class and information about exempted flights. 
Slot ID - A time slot assigned during ground delay, substitution/cancellation 
STAR - Standard Terminal Arrival Route 
STRSN - Standard Terminal Arrival Route Transition 
SWP - SWAP flight (flight remark) 
TO - The flight time out considered cancelled because no activation message has been 
received within a certain time of the predicted departure time (cancel status). 
TOD - Time Out Delay -the flight passed its ETD without taking off (delay status). 
UX – Cancelled flight due to an EDCT update by a traffic manager (cancel status). 
WXR - Severe Weather Route (flight remark) 
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