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I. Introduction

This document covers all the changes implemented for Java Flight Schedule Monitor (FSM) 7.8 since Java FSM 7.7.  The default monitor mode FSM user’s interface is illustrated below.
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Figure ‎I‑I: Flight Schedule Monitor 7.8

The FSM 7.8 User’s Guide is available as a complete reference for FSM functions not included in this document.  Selecting Help > FSM from the Control Panel displays FSM 7.8 online help.  The online help can also be accessed from any FSM component and displays the on-line help associated with that component.

II. Windows Management

One of the most noticeable changes to FSM 7.8 is windows management.  

1. All airports and their respective data modes currently opened by the FSM client are displayed as buttons on the Control Panel.  

2. The airport that is active, or in focus, on your screen is listed on the Control Panel next to Data set text.

The respective airport button is highlighted in orange (see Figure ‎II‑I).
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Figure ‎II‑I: Control Panel
Click an airport button from the Control Panel to display the opened airport components associated with the selected dataset. When an airport selection is made, all other opened airport components are hidden from view.  

3. Listed below are the various buttons that are available when an airport is opened in various data modes: 

· Live Date Mode –Airport’s three-letter identifier (i.e. ATL)
· GDT Data Mode – Airport’s three-letter identifier/G  (i.e. ATL /G)

· Historical Mode – Airport’s three-letter identifier/H (i.e. LGA/H)

· Historical Mode/GDT – Airport’s three-letter identifier/GH (i.e. LGA/GH)

Closing all components for a particular airport and mode will automatically remove the associated button from the Control Panel.

III. Changes to the Control Panel

In addition to the windows management buttons, there have been a few additional changes to the Control Panel:  

1. Under the ETMS Tools menu, the text to modify or reset the Airport Arrival Rate (AAR) and the Airport Departure Rate (ADR) has changed from ADL Arrival Rate and ADL Departure Rate to ADL AAR and ADL ADR. 
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Figure ‎III‑I: ETMS Tools > ADL AAR/ADR

2. An ECR (EDCT Change Request) button has been added to the control panel to access the ECR tool; the ECR tool will be discussed in more detail below.

3. A SUBS ON/OFF indicator has been added to the end of the text at the bottom of the Control Panel.  The subs indicator is related only to the active dataset.  The SUBS OFF indicator is displayed in red.  For example, as seen in Figure ‎III‑I, SUBS: ALL ON indicates that BOS currently has all subs on.  If substitutions are turned off temporarily by the ATCSCC, the sub indicator displays ALL OFF in red.  When ALL OFF is displayed, the Hub site will reject all substitution messages, including SCS requests for flights arriving at that airport.

Sub Opportunities Report

There is a new Sub Opportunities Report that can be accessed from the Control Panel Reports Menu; Reports > Sub Opportunities.  This report has been created to assist airlines and general aviation customers to identify subbing opportunities.  
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Figure ‎III‑II: Sub Opportunities Report

IV. Demand Graph Changes

Time Increment Buttons

The default time increment to display capacity versus demand information is set to 60 minutes.  To view the same information in 15-minute or 30-minute time increments, click the associated button below the Bar Graph main menu options.  The Bar Graph updates automatically (see Figure ‎IV‑I). 
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Figure ‎IV‑I: Bar Graph Time Increment Buttons

Arrival and Departure Flow Rates

The Arrival Flow Rate and the Departure Flow rate have been added to the Bar Graph display.  The flow rates operate independently of the time-bin convention, enabling users to visualize arrival and departure demand as dynamic flow rates.  A white line represents the Arrival Flow Rate and a cyan line represents the Departure Flow Rate. To view the Departure Flow Rate or to turn off the Arrival Flow Rate, select/deselect the appropriate checkboxes from the Bar Graph View menu (see Figure ‎IV‑II). By default, the Arrival Flow Rate is displayed.
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Figure ‎IV‑II: Bar Graph Flow Rates

Distance Tab

1. The Distance tab colors all flights within a certain distance of the airport.

2. The Distance tab displays all flight distances in red and allows the user to view distance ranges of up to 2,400 miles in 200-mile increments, as well as flights arriving from distances greater than or equal to 2,400 miles.  The default distance displayed is 200 miles.

3. The color legend, which can be accessed by pressing Ctrl + L on your keyboard or selecting View > Show Legend from the Bar Graph menu, allows the user to select the desired distance to display.  The checkbox selection format in the distance tab legend has changed from version 7.7.  FSM 7.8 now uses a radio button format that will only allow you to select one distance selection at a time (see Figure ‎IV‑III).  
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Figure ‎IV‑III: Distance tab in Bar Graph Display

4. To view a flight count for the distance selected in any hour, roll your mouse over any bar within the Bar Graph, the respective number of flights will appear for the colored flights.  

V. US Map in Monitor Mode

The US Map comprises 48 contiguous states of the USA, along with an overlay of all the U.S. and Canadian centers.  Airports currently monitored by the server are labeled by a unique three-letter identifier (U.S. airports) and four-letter identifier (Canadian airports). Each airport currently being monitored is represented by a colored dot.  The color of the dot indicates the airport’s status.

Green – no Traffic Management Initiative (TMI) for the airport

Red – a Ground Delay Program (GDP) or Ground Stop (GS) in effect

Yellow – a proposed GDP or GS

Blue – a GDP or GS has been terminated

Map Zoom Functionality

The zoom options have changed slightly with FSM 7.8.

1. Right-click anywhere within the US Map for map focus options: Default Zoom and Undo Zoom.

a. The Default Zoom command will take you back to the Maps default zoom setting.  

b. The Undo Zoom command will undo your last zoom command, same as using the X quick key.  

2. Right click on the GDT Map for the same zoom options.

Only one instance of the US MAP can be opened.

To open the US Map component from the Control Panel, users may use one of the following methods:

· Press the US Map button in the menu.

· Select View > Status Map from the Control Panel
· Use the keyboard shortcut Ctrl + M when the Control Panel is in focus 

Viewing Airport Parameters

From the US Map, you can now view the scope of an airport’s TMI parameters. 

Select the airport that has either proposed or active parameters in place to textually display the airport program date, time, type, and the start and end time.  

Click anywhere on the map to return to the map’s normal display mode.  

In addition to displaying the airport’s program text in white, left-clicking an airport graphically displays the scope of the parameters.  The maroon overlay and red airports indicates area and airports included in the airport’s TMI.

For example, Figure ‎V‑I shows IAD with a 1425 nautical miles (NM) distance-based program displayed on the Monitor mode map.  
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Figure ‎V‑I: US Map TMI Parameter Display

VI. Query Manager 

The Query Manager component enables you to query flights and create a Flight List that contains only flights that meet selected criteria.  To view the Query Manager component:

· Press the Show Query Manager button.

· Select Utilities > Query Manager from the Control Panel Component.

There has been a Flight List button added to the Query Manager.  To view a filter flights list follow the steps below.

1. Select one of the filters from either the Built-In Filters or the User-defined Filters (see Figure ‎VI‑I).
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Figure ‎VI‑I: Query Manager

2. Press the Flight List button to open the Set Data Set window (see Figure ‎VI‑II).   Any airport that is opened in the FSM client appears in the Set Data Set window. 
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Figure ‎VI‑II: Choose Dataset

3. Select the airport data you wish to view in the flight list.

4. Press OK to view the filtered flight list. 

VII. GDT Mode Changes

An addition to the GDT Setup panel is the substitution status display. There is a SUBS ON/OFF indicator to the right of the Program Type selection box. When SUBS are turned OFF, the text is displayed in red.    

Model Progress Bar

When modeling a TMI, the process can take several seconds to generate each scenario based on the power run selection.  When FSM is modeling a power run, a real-time progress bar shows the type of power run in the title bar and the status of the modeling progress (see Figure ‎VII‑I).
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Figure ‎VII‑I: Modeling Progress Bar

Autosend Inhibited when SUBS are Turned ON during Revisions (ATCSCC Only)

While in GDT Mode, the Autosend process is inhibited during a GDP compression, revision, or extension if SUBS have not been turned OFF.  

When SUBS are left ON when the Autosend button is pressed from the GDP coversheet an FSM Message that instructs you to turn SUBS OFF, reload and remodel the program before Autosend can be transmitted (see Figure ‎VII‑II). 
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Figure ‎VII‑II: FSM Warning

1. Press OK to close the window. 

2. To turn SUBS OFF, go to ETMS Tools from the Control Panel menu bar, click EDCT Commands > EDCT SUB OFF.
3. Reload and remodel the program.
TMI Parameter Review
FSM 7.8 displays the GDT Setup panel in static form. The static Parameter Display allows you to view and evaluate an airport’s TMI parameters. The static display is for viewing purposes only and will not allow modifications. To model changes go to GDT mode and load actual parameters. 
How to View Actual Parameters

1. From the Control Panel, Select Alerts and then the Actual or Proposed Parameters Available option. For example, Figure ‎VII‑III displays Actual GDP Parameters available for MDW.  This will display a static form of the airport’s GDT Setup panel. 

[image: image14.png]Fle View Reports

Mlrts | ETWS Tools_Utities_ Window_Help

[sham penbtos

Connected Servers: |

IVE MDWY

No Proposed GDP Parameters
No GS Parameters

No COMP Parameters

No BLANKET Parameters

se] e e

FD_MGR) Dataset:LIVEMDW SUBS: ALLON

~=lolx|





Figure ‎VII‑III: Actual Parameters Available 

2. The title bar of the static display shows “Parameter Display” and then lists the airport ID, date, and ADL time.  All the airport’s TMI parameters will be displayed in static form.  Click on the available tabs to view all the airports TMI parameter information. 
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Figure ‎VII‑IV: Static Parameter Display
VIII. EDCT Change Request (ECR)

The EDCT Change Request (ECR) tool can now be accessed directly from the FSM Control Panel.  Prior to the ETMS 7.8 release, only the ATCSCC had access to ECR.  With the release of 7.8, ECR is now available for NAS users as well.  User functionality is limited with only the ability to use the SCS request option.  Unlimited, Limited, and Manual EDCT UPDATE selections are only available for ATCSCC users and will be grayed out for all other users.  Use ECR to change information for controlled arrivals. Flight data is updated approximately every 5 minutes with every new ADL. 

The ECR component allows the user to search for a flight, view current flight information, model suggested update times for flights, and display user options for updating control times.  The ECR title bar displays the Airport, date, ADL time, and monitor mode (see Figure ‎VIII‑I).
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Figure ‎VIII‑I: ECR Component

ECR Menu Bar

The ECR menu bar contains three options: File, View, and Help.
File menu:

File > Save as - Saves ECR as a .txt file in a directory that you specify.  This feature is not yet implemented and therefore no information is saved.

File > Print - Prints the active ECR currently displayed on your monitor. 

File > Close - Closes the ECR component.

View menu:

View > Freeze Data – Checking the Freeze Data selection box will prevent further ADL updates for the ECR component.  By default, the checkbox is not selected.  

Help menu:

Help > ECR - Accesses the web-based on-line help for the ECR component. 

Opening ECR

There are three methods to open ECR, namely two menu options from the Control Panel and the third option from the Time Line. 

1. Click the ECR button from the Control Panel. Ensure that the correct Dataset is active before opening ECR.  For example Figure ‎VIII‑II displays the ECR component being opened for ATL.  
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Figure ‎VIII‑II: Opening ECR from the Control Panel

2. Select Utilities > ECR from the Control Panel.

3. Right-click on a flight icon in the Time Line and select ECR from the popup menu (see Figure ‎VIII‑III).  The ACID, ORIG, and flight information will automatically display in the ECR component when opened from the Time Line.
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Figure ‎VIII‑III: Opening ECR from the Time Line

Locating a Flight

To begin updating an EDCT, you must enter a flight in the ECR window.  Verify that both the three-letter airport identifier (Airport) and the last ADL Update time (ADL Update) for the correct airport are displayed in purple text.

1. Open ECR from the Time Line and ECR will automatically Find Flight information and populate the appropriate ECR fields.

2. Manually enter a flight’s aircraft identifier in the ACID Field provided and press Find Flight.  
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Viewing Flight Information

After a flight has been found, the current information is displayed under the Flight Information section. 

	Current Data 

	IGTD
	Initial gate time of departure
	IGTA
	Initial gate time of arrival

	CTD
	Current control time of departure
	CTA
	Current control time of arrival

	ETD
	Estimated time of departure
	ETA
	Estimated time of arrival

	ETE
	Estimated time en route

	ERTD
	Earliest runway time of departure
	ERTA
	Earliest runway time of arrival


Updating an EDCT for a Flight

After finding and displaying the flight’s current information, enter the flight’s new Earliest EDCT in the Find Flight section of ECR.

1. Type the earliest EDCT to which the flight can comply in the Earliest EDCT field.

2. Select one of the five options listed in ECR Reason as the general reason for the EDCT update; either:

· ACFT_OPR: aircraft operator; default selection

· Equip: equipment

· TMI:  traffic management initiative

· Wx: weather change

· Other: Reason not previously listed

3. Click Apply Model button to populate the Update Criteria section and to model different update parameters based on the new Earliest EDCT data.  

	Update Criteria

	E_CTD
	New earliest CTD requested
	CTA Range
	Interval between the New Earliest CTA and the sum of the New Earliest CTA and Maximum Additional Delay


4. Select the desired update option (SCS Request, Unlimited, Limited, or Manual). The SCS radio button option is selected by default (customers other than the ATCSCC will only have the SCS request as an option).

5. Click Send Request button to send the request to the Hub site (see Error! Reference source not found.).
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Figure ‎VIII‑IV: EDCT Update

Update Options

There are four options for updating an EDCT using ECR: SCS Request, Unlimited, Limited, and Manual.  Only the SCS Request option is available for all users.  The Unlimited, Limited, and Manual options are for ATCSCC use only.

· SCS Request: The ECR tool sends a Slot Credit Substitution (SCS) request via a Simplified Subs Packet to ETMS, using the window reflected in the CTA range.  SCS allows the assignment of a slot to a flight when the user does not own a slot at that time to sub the flight into.  The SCS Request option is selected by default.

Note:  SCS can only be used when a later EDCT is requested.  If the New Earliest EDCT is before the current CTD, the SCS radio button will be grayed out. 

· Unlimited: The ECR tool shows the EDCT, CTA, and the delay past the New Earliest CTA for the optimal EDCT update for between the New Earliest CTA and the last CTA of the program (ATCSCC Use only).

· Limited: The ECR tool shows the EDCT, CTA and delay past the New Earliest CTA for the optimal EDCT update within the CTA range (ATCSCC Use only).

· Manual: The user can input an EDCT in the space provided (DD/ hhmm) and the ECR tool calculates the CTA by adding the flight’s ETE (ATCSCC Use only).
Viewing SCS Response

After requesting a Slot Credit Substitution (SCS), a response will be sent back from the Hub site.  If the SCS request was successful, the response is a slot list of the flight affected (See Figure ‎VIII‑V), including new control times and control types.  
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Figure ‎VIII‑V: SCS Response

Control Types Associated with ECR

	Control Type
	Control Time Change Origin

	ECR
	SCS Request submitted by the ATCSCC

	SCS
	SCS Request submitted by all customers other than ATCSCC (airline user or general aviation customers)

	UPD
	ATCSCC EDCT update (Changes made by Unlimited, Limited, or Manual options)

	BRG
	Bridged up to accommodate an SCS request
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