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Introduction

This document covers all the changes implemented for Java Flight Schedule Monitor (FSM) 7.9 since Java FSM 7.8.  The default monitor mode FSM user’s interface is illustrated below.
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Figure 1: Flight Schedule Monitor 7.9
The FSM 7.9 User’s Guide is available as a complete reference for FSM functions not included in this document.  Selecting Help > FSM from the Control Panel displays FSM 7.9 online help.  The online help can also be accessed from any FSM component and displays the online help associated with that component.

GDP with GAAP Overview

When arrival demand at an airport exceeds its capacity, the ATCSCC may impose a Ground Delay Program (GDP).  Arrival slots are allocated to flights scheduled to land within the period of the GDP that are in the Aggregate Demand List (ADL) at the time the program is run.  Flights that are not known about at the time of program implementation, also known as pop-ups, receive a Delay Assignment (DAS) delay, formerly known as FA delay, which varies depending on the arrival time.  DAS is the default delay assignment mode for a GDP.  The DAS mode is appropriate when demand has already met or exceeded capacity of an airport.  

Some airports do not fit the traditional GDP model as stated above.  There are situations where known demand may not exceed the current capacity, but it is believed that unknown demand due to pop-up traffic will meet or near capacity.  In this case, there are an insufficient number of flights to fully utilize the capacity when a program is initially issued and therefore not every arrival slot is assigned to a flight during a GDP with DAS.  This can occur at airports that serve large numbers of General Aviation (GA) flights.  

To support the ability to issue a GDP for an airport when demand is less than capacity, a new delay assignment mode, General Aviation Airport Program (GAAP), has been added to the GDP setup panel.

How a GDP with Delay Assignment Mode GAAP works   
During a GDP with GAAP delay assignment, the number of slots is determined using the user-entered Airport Arrival Rate (AAR).  FSM allocates slots to known flights utilizing established processes except that any unassigned slot is preserved.  The Aggregate Demand List (ADL) includes the unassigned slots for all FSM users to monitor the availability of the slots using the Bar Graph, Time Line, and Unassigned Slots report. As a pop-up flight becomes known, it is assigned to one of the unassigned slots by ETMS processing.  As each unassigned slot is utilized, the slot will be removed from the list of unassigned slots and the updated slot status will be propagated via the next ADL.  If there is no unassigned slot available within the delay limit set by the specialist, then the flight will receive a Control Time of Arrival (CTA) that equals the flight’s original Estimated Time of Arrival (ETA) plus the delay limit.  The delay limit is the maximum number of minutes a pop-up flight may be delayed during a GDP in GAAP mode.  Therefore, any flight that cannot be accommodated with an unassigned slot receives the same delay limit.    

Note: The term “unassigned slot” describes a slot to which no flight is currently assigned.  This should not be confused with the term “open slot” which describes a slot held by a flight but which is eligible for compression due to the delay or cancellation status of the flight.
Changes to the GDT Setup Panel

To begin implementation of a GDP, you must enter the parameters to be used for the GDP. This is done in the GDT Setup Panel. If you are in Monitor Mode, click GDT Setup from the Control Panel to open the monitored airport in ground delay tools mode (see Figure 2).  The main parameters can be adjusted from the GDT Setup panel located in the upper right-hand corner of the display.
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Figure 2: GDT Mode Default View 
The changes to the GDT Setup Panel are found at the bottom of the General Tab.  There are three new parameter input fields, the Sched/User Exemptions selection button, the Delay Assignment Mode drop-down selection, and the Delay Limit field.
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Figure 3: GDP Setup Panel

Sched/User Exemptions

FSM now allows you to exempt flights based on Schedule Status or User Type during a GDP, GS, or +/- Delay. Click Sched/User Exemptions to open the Exempt Scheduled  window and select your exemption criteria (see Figure 4) The options are listed below:

· S – Schedule Status
· C – Air Carrier
· F – Freight/Cargo Carrier
· G – General Aviation
· M- Military
· T – Air Taxi
· O - Other

For example, to exempt all flights with a scheduled time, select the S – Schedule Status checkbox in the Exempt Scheduled window (see Figure 4).  Click OK to continue. An S appears in the Sched/User Exemptions field on the GDT Setup Panel indicating that all flights which have a scheduled time when the program is issued or revised are exempt from departure delay (see Figure 5).  
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Figure 4: Exempt Scheduled Window
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Figure 5: GDP Setup with Scheduled Flights Exempt

Delay Assignment Mode

The Delay Assignment Mode option determines how pop-up traffic is handled during a GDP. There are two Delay Assignment Mode options to select from: 

1. DAS: Delay Assignment, formerly known as FA delay, is the default selection and is to be used for scenarios where demand has exceeded airport capacity.  When DAS is selected there are no unassigned slots preserved and the Delay Limit field is grayed out.  Pop-up traffic is assigned DAS delay based on the average delay of the 15-minute time bin of the flight’s ETA. 

2. GAAP:  General Aviation Airport Program is the delay mode option that should be used during a GDP event when current demand does not meet airport capacity but projected pop-up traffic is expected to meet or exceed capacity.  During a GDP in GAAP mode, FSM creates unassigned slots for any leftover capacity that cannot be allocated to known flights. As a pop-up flight becomes known, the Hub site assigns the flight to the closest unassigned slot that is at or after its ETA plus the delay limit time. The Hub site then propagates this information in the next ADL.

Delay Limit

The Delay Limit field is the maximum number of minutes a pop-up flight may be delayed during a GDP in GAAP mode.  If there are no unassigned slots available within a pop-up flight’s ETA plus the delay limit time, the flight receives a CTA that equals the sum of its ETA and the Delay Limit parameter.  All pop-up traffic that cannot be accommodated by an unassigned slot receives the same minutes of ATC delay.  The default delay limit is 60 minutes.

Note: The GAAP Delay Limit field is only available when the Delay Assignment Mode GAAP is selected.
GDP Coversheet Additions
The GDP Coversheet contains all the GDT Setup Panel data (see Figure 6). The Coversheet should be reviewed to ensure that the GDP parameters are accurately set before you send the program out.  In conjunction with the new GDP with GAAP functionality, the GDP Cover Sheet contains several new parameters to review, Delay Assignment Mode, Delay Limit, Sched/User Exemptions, and the Unassigned Slot counts in the scrolling area of the GDP Cover Sheet window. 

New Coversheet Parameters

· Delay Assignment Mode: Pop-up delay type being implemented, DAS or GAAP. 

· Delay Limit: Maximum delay value (in minutes) a pop-up flight can be assigned during a GDP using GAAP delay assignment mode.  The default GAAP delay limit is 60 minutes.  If the Delay Assignment parameter is DAS, this field reads N/A. 

· Sched/User Exemptions:  The User Group or Schedule Status group type exempt from program departure delays.  
Scrolling Window Statistic

· Unassigned Slots: Number of unassigned slots that are within each 15-minute increment during the GDP.  
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Figure 6: GDP Coversheet
Note: Sched/User Exemption criteria can also be selected fro Ground Stops and Blanket events. 
New Control Type

If a flight is controlled, that is has a CTD/CTA, it has a control type (CTL_TYPE).  The CTL_TYPE indicates the specific source of the flight’s most current CTD/CTA.  In support of GAAP GDPs there is a new control type of GAAP. A GAAP control type represents a pop-up flight that has been allocated an unassigned slot.  If a pop-up flight is not given an unassigned slot and is subsequently given the delay limit during a GDP in GAAP mode, the CTL_TYPE equals FA. The possible values for CTL_TYPE sources are listed below in Table 1. 

Table 1: CTL_TYPE Sources

	GS
	Ground Stop

	GDP
	Ground Delay Program

	ECR
	ATCSCC SCS, Limited, or Unlimited update

	COMP
	Compression

	FA
	Delay Assignment

	BLKT
	Blanket (+/-) Program

	SUB
	Regular substitution message

	SCS
	Non-ATCSCC Slot Credit Substitution message

	BRG
	Bridge Created to handle a slot credit substitution request

	UPD
	ETMS “EDCT UPDATE” command or manual ECR update

	GAAP
	Unassigned Slot allocated


Viewing a GDP with GAAP

When there is a GDP in GAAP mode issued, the FSM Time Line and Bar Graph now display unassigned slots.  In addition, FSM has a new report called Unassigned Slots, which displays the distribution of unassigned slots for the duration of the GDP.
Time Line

The FSM Time Line now displays unassigned slots as white diamonds with a black outline during a GDP with GAAP (see Figure 6).  Each white diamond represents an unassigned slot time that is available for pop-up flight allocation. 
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Figure 7: FSM Time Line with Unassigned Slots Displayed

Bar Graph
In FSM Bar Graph you can view the unassigned slots during a GDP with GAAP by selecting View > Show Unassigned Slots from the Bar Graph menu (see Figure 7).  This displays unassigned slots in white at the top of the demand bars.  Showing unassigned slots in the Bar Graph is only available when Color By Arrival Status is displayed.  Unassigned Slots are not displayed by default. 
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Figure 8: FSM Demand Graph with Unassigned Slots Displayed

Unassigned Slots Report
To view a list of unassigned slots that are available during a GDP with Delay Assignment mode set to GAAP, select Reports > Counts > By Unassigned Slot from the FSM Control panel. This report shows the number of unassigned slots for each 15-minute time bin for the duration of the GDP.  If there is not a GDP with GAAP implemented for the airport for which you requested an Unassigned Slots report, FSM displays an unassigned slot list with null values for unassigned slots. 
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Figure 9: Count List By Unassigned Slot
Closing Data Sets

Closing all components for a particular airport and mode will automatically remove the associated button from the Control Panel.  There are two methods that will close all associated components with the open data set.  

1. Selecting File > Close Group from any open component.  Selecting File > Close closes the single component only.

2. Right-clicking and airport shortcut button from the Control Panel and then selecting Close Group. 
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Figure 10: Close Group
Note:  If both Live and GDT dataset are open for the same airport, closing the Live dataset also closes the GDT dataset.  

Demand Graph Changes

Arrival and Departure Flow Rates

The Arrival Flow Rate and the Departure Flow rate have been added to the Bar Graph display.  The flow rates operate independently of the time-bin convention, enabling users to visualize arrival and departure demand as dynamic flow rates.  A gray line represents the Arrival Flow Rate and a cyan line represents the Departure Flow Rate. To view the Departure Flow Rate or to turn off the Arrival Flow Rate, select/deselect the appropriate checkboxes from the Bar Graph View menu (see Figure 11). By default, the Arrival Flow Rate is displayed.
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Figure 11: Bar Graph Flow Rates
Flight Lists 

FSM generates Flight Lists automatically when it performs certain functions. You can generate one for a specific group of flights that you select. Flight Lists allow you to view what flights contribute to the arrival demand at an airport and how many flights fall into specific categories. You can open an FSM Flight List in a variety of ways from all FSM modes and several FSM components. You can obtain Flight Lists from the Bar Graph, Time Line, Status Map, Open Data Set, Query Manager, and GDT Setup components.

The way FSM generates a Flight List differs depending upon the type of information you need.

Note: Report Flight Lists vary in the initial default information displayed, but the functionality described below is the same. 

When you want to see only flights that meet certain criteria, you can generate a Flight List from the Query Manager component. From a Flight List, you can also select a single flight and view the Flight Info or Flight Details for that flight by right-clicking on the selected flight, or by highlighting the flight and using the View menu options. All Flight Lists are dynamic and are updated along with every ADL update.

Add/Remove Columns

The Add/Remove window has been enhanced in version 7.9.  You can now add data fields (columns) to your flight list by groups.  There is also a new FSM Calculated field that allows you to create a User Defined calculation by adding or subtracting selected ADL data fields.
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Figure 12: Flight List
Adding Data Column information to a Flight List by Group
1. Select View > Add/Remove Columns from the Flight List component.

The Add/Remove Columns window appears showing all possible informational categories that you can view in FSM's Flight Lists. The categories correspond to the available data fields in the ADL, groups of available data fields, and calculations that you can specify. The data elements that currently appear in the Flight List, also appear in the Filed Displayed scroll box (see Figure 12).

2. Select any groups of data fields that you want to add from the By Group section of the window.

3. Click the bottom arrow button to move the groups to the Fields Displayed scroll box. Selecting a top level from the By Group section moves all data elements from that Group into the Fields Displayed scroll box (Figure 13).
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Figure 13: Add Column By Group

To Add Calculated Fields to your Flight List
User defined calculations can now be added to your Flight List.  
Specify the calculation you would like to add from the By Calculation section of the window.

1. Select View > Add/Remove Columns from the Flight List component.

The Add/Remove Columns window appears.

2. Under the FSM Calculated section of the window, select the first data field you want to use for your calculation from the first data filed dropdown box.

3. Select the type of calculation you would like performed from the second dropdown box: add (+) or subtract (-).

4. Select the second data field you want to use for your calculations. In Figure 14 the user has selected CTD – OCTD.

5. Click the bottom arrow button to move the calculation to the Fields Displayed scroll box.  Calculations are always listed as User Defined under the FIELD DESCRIPTION.
6. Click OK.

Note:  Multiple User Defined calculations can be added to the Flight List.
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Figure 14: Add/Remove Columns Window
All of the new fields and calculation appear in the Flight List window (Figure 15).
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Figure 15: New Fight List
EDCT Change Request (ECR)

The ECR component allows you to search for a flight, view current flight information, model suggested update times for flights, and display options for updating control times.  The ECR title bar displays the Airport, date, ADL time, and mode (see Figure 17).
Opening ECR from the Flight List 

You can now open the ECR component directly from any Flight List when flights are being controlled.  Right-click on a flight row within the Flight List and select ECR from the pop-up menu (see Figure 16). The ACID, ORIG, and flight information automatically display in the ECR component when you open it from the Flight List (see Figure 17).
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Figure 16: Opening ECR
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Figure 17: ECR Component
Freeze Data

The ECR component no longer has the ability to freeze data. The View > Freeze Data option has been removed from the ECR menu.  ECR information automatically updates with each new ADL received.

Rename Window

The ECR View menu has added the Rename window functionality.  This allows you to change the name of the ECR window for quick identification when the window is minimized in the task bar. 

View > Rename Window…- Displays the Rename Window dialog box and allows you to change the title bar name. Type in the desired name then click OK to change the title bar heading. Click Cancel to close the Rename Window dialog box without making any changes (see Figure 18).
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Figure 18: Rename Window Dialog
Locating a Flight

To begin updating an EDCT, you must enter a flight in the ECR window.  Verify that both the three-letter airport identifier (Airport) and the last ADL Update time (ADL Update) for the correct airport are displayed in purple text.

1. Open ECR from the Time Line or Flight List and ECR will automatically populate the appropriate ECR fields with the selected flight information.

2. Manually enter a flight’s aircraft identifier in the ACID Field  and click Find Flight.  
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Figure 19: ECR Find Flight
Often there can be more than one instance of an ACID in the flight data base.  If ECR finds more than one flight it displays a Select a Flight window asking you to select from multiple flights that satisfy your search conditions (Figure 19).  Click Next or Previous to scroll through the multiple flights. Click OK once you have identified the flight you are looking for and the flight’s information will populate the appropriate ECR fields.     

[image: image21.png]Multiple flights satisfy the search conditions.
Please Select One.

N28NP ueN TEB 251400 2511526

[ o [ roows || nen

2otz
P\cln o st em





Figure 20: Select A Flight window
Purge Configuration Change for Ground Stops
After a ground delay program or ground stop is purged, flights that were controlled must receive new departure times.  Flights require a certain amount of time to get ready and should not receive departure times that are sooner than the current time plus the time needed to prepare for departure. The current minimum notification time for a GDP PURGE is forty-five (45) minutes.  However, extensive analysis has shown that flights that are controlled by a ground stop can often be ready sooner. Therefore, the minimum notification time for a GS PURGE has decreased from forty-five (45) minutes to twenty (20) minutes.

The ground stop minimum notification time parameter change has been made by both Hub site processing and FSM algorithm logic.  When a TMI is purged, FSM determines the minimum notification time based on a flight’s control type and models the Purge accordingly. If the CTL_TYPE is GS, then the minimum notification time is twenty (20) minutes.  If the CTL_TYPE is a value other than GS, the minimum notification time is forty-five (45) minutes. 

Algorithm Change: Earliest CTD
As part of the current GDP processing, FSM makes use of an earliest CTD.  The Earliest CTD value is the earliest time that a CTD can be assigned to a flight.  In previous but limited instances, the earliest CTD occurs as early as the data time of the ADL used for modeling that GDP.  These cases create a problem due to the fact that FSM users will typically take as long as 5 to 10 minutes to complete the process of modeling and issuing a TFM initiative. Therefore, when CTDs are issued and control times are transmitted, several flights receive CTD times in the past thus immediately rendering them noncompliant.

To effectively prevent this scenario, FSM now computes flight CTDs using a configurable value to be used as a time buffer for GDPs and +/- Delay revisions.  The configurable parameter value for the ETMS 7.9 release is 20 minutes.  Therefore, no flight will receive a CTD earlier than the sum of ADL Data Time plus 20 minutes.  

ETMS Data Expanded to 24 hours

To facilitate longer duration GDPs with GAAP, the Schedule Database (SDB) now sends scheduled data to the Flight Database for flights departing 24 hours in advance of the current time.  Previously, this information was sent 15 hours in advance.   
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