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FSM Overview
1:   FSM Overview

Introduction
The amount of traffic in our National Airspace System (NAS) is expected to experience 
significant growth for the foreseeable future. The NAS is a static resource and the Federal 
Aviation Administration (FAA) needs to find a balance between the increase in traffic and 
available resources in the NAS. The FAA responded to this issue by developing Free 
Flight. Free Flight is an innovative concept designed to enhance NAS safety and 
efficiency by transitioning from a centralized command and control system to a distributed 
planning system.

Collaborative Decision Making (CDM) is one of the five core products in Free Flight 
Phase I. CDM is a joint government/industry initiative aimed at improving air traffic 
management through increased information exchange, common situational awareness, 
equitable resource allocation, and performance analysis.

Flight Schedule Monitor (FSM) was used in CDM's first major thrust, Ground Delay 
Program Enhancements, and the FAA has continued to use it since it went into Prototype 
Operations in January 1998. FSM fulfills the CDM goal of giving all users common 
situational awareness. FSM does this by displaying a current picture of air traffic demand 
at airport and airspace data sets using real-time data culled from CDM participant data and 
aggregated by TPC. Using this picture, air traffic specialists and airline operations centers 
alike make better decisions and keep traffic flowing as smoothly as possible.

When adverse conditions affect an Airport or Flow Constrained Area (FCA) data set, they 
also affect traffic flow. The data set cannot handle a normal amount of arriving aircraft 
which disturbs operations. One method the FAA uses to compensate for reduced capacity 
at a data set is to delay flights arriving at that constraint before these flights take off. This 
is known as a Ground Delay Program (GDP) for an airport or as an Airspace Flow 
Program (AFP) for an FCA. As part of CDM Prototype Operations, all FAA traffic 
management personnel use FSM to determine the necessity for a program and other traffic 
management initiatives (TMIs) and enact them.

FSM has been continuously enhanced since the early prototype capability to include better 
functionality and support for the ever-expanding user community. FSM was originally 
designed with C++ programming language. To better serve the CDM community, and to 
keep up with improving technology, FSM was completely rebuilt on the Java platform in 
the fall of 2003. The Java FSM architecture can support a large number of concurrent 
users at a single site. Java FSM can also greatly improve threading options and enhance 
file handling. Additional features include built-in cross-platform user interface support.

Today, traffic management specialists across the NAS and Canada, as well as over 40 
CDM participants use FSM to monitor and manage airport demand and capacity.

The FAA Air Traffic Control System Command Center (ATCSCC) uses FSM to:

• Monitor airports, FEAs, and FCAs - view the existing demand and constraints at these 
data sets
FSM User Guide, Version 9.00 1-1
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• Model and run traffic management initiatives, including Airspace Flow Programs 
(AFPs), airborne holding, GDPs, and Ground Stops (GS)

• Update EDCTs (Estimated Departure Clearance Time) through the use of EDCT 
Change Request (ECR)

Traffic Management Units use FSM on a daily basis in more than 80 FAA air traffic 
control (ATC) field facilities to monitor capacity and demand at over 50 airports.

Airline operations centers (AOCs) use FSM to:

• Monitor airports by viewing existing demand and constraints at these airports
• Analyze the impact of proposed TMIs on their operations
• Model flight cancellations
• Send Slot Credit Substitution (SCS) requests to the hub site through the ECR 

component

Purpose and Scope
FSM has two major purposes:

1. Monitoring airport and airspace Capacity/Demand Data
2. Managing Traffic Flow

FSM monitors flights arriving at and departing from an airport, or entering into and 
departing from an FEA/FCA, while tracking demand and capacity. When an imbalance 
exists, traffic management specialists analyze different combinations of GDPs, AFPs, 
airborne holding, etc. to determine the best way to fix the imbalance. Once the traffic 
management specialists determine an airport, FEA, or FCA needs a TMI, FSM sends out 
the parameters to the users and updates its own data accordingly. Airline operations users 
model the effects of the TMI and decide whether to alter their own operations.

FSM displays both Monitored Live (On-line) and Historical CDM data. Traffic 
management specialists use Live data to monitor the current situation at any airport. In 
Monitor Live data mode, FSM updates demand in the flight schedule display 
approximately every five minutes to keep the picture current. FSM users can examine 
historical data to replay a day's events and analyze the effects of all traffic management 
programs.

Limitations and Contacts
This document describes FSM as of Release 9.00. Because FSM is an evolving product, 
future enhancements (i.e., - modifications and additional functions) will be introduced into 
this guide as they become available.
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For information and/or technical assistance with FSM software, contact the following:

Conventions
Conventions are the same throughout all FSM components unless otherwise specified.

Government 
Personnel

Airline Personnel

TPC Hotline
(609) 485-9601

FSM Support 
(703) 234-0769
fsm_support@metronaviation.com

Table 1-1:  Keyboard and Mouse Conventions

Command What It Means
File > Open Choose the Open option from the File 

menu.
Click Click once with the left mouse button.
Ctrl + Click Press the Ctrl key while clicking with the 

left mouse button.
Double-Click Click twice with the left mouse button.
Checkmark Select the option with the left mouse 

button to make a checkmark appear in a 
checkbox.

Ctrl + A Press the Ctrl key while pressing the A key 
on your keyboard. Displays arrival data in 
the active component 

Ctrl + C Press the Ctrl key while pressing the C key 
on your keyboard. Command used to close 
a window or component.

Ctrl + D Press the Ctrl key while pressing the D key 
on your keyboard. Displays departure data 
in the active component.

Ctrl + F Press the Ctrl key while pressing the F key 
on your keyboard. Finds a particular flight 
by entering the flight’s call sign and origin 
airport.

Ctrl + L Press the Ctrl key while pressing the L key 
on your keyboard. Displays a color legend 
for the active component.

Ctrl + P Press the Ctrl key while pressing the P key 
on your keyboard. Prints the active 
component on your screen.
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Note:  All keyboard functions work the same in all components unless 
stated otherwise. If you use a particular keyboard command on a 
component where that option is not available, FSM makes no 
changes to the component. Ensure the component you want to 
submit is “active” when executing a command.

Common Terms Used in This Document
Component, Window, and Panel – The three terms are used interchangeably throughout 
this document. They refer to the active window on your screen.

Active – This document uses the term active in two different ways. First, if several 
windows are open, only one window can accept user input from either the mouse or 
keyboard - that window is active. Second, within the active window, only one action 
button, push button, or text entry field is active.

Dialog box - A window that allows the user to enter text and use buttons to make choices.

Checkbox – A picture of a square box (checked or not checked) is displayed on the 
screen. When you select the Checkbox, a checkmark is displayed in the box and the item 
associated to that checkbox is selected. You can select several checkboxes at a time.

Data Set – An airport, FEA, or FCA.

Radio button – A picture of an analog push button (a circle with or without a dot) is 
displayed on the screen. When you select a radio button, a dot fills in the circle. You can 
select exactly one radio button in a group of radio buttons at any time.

Aggregate Demand List (ADL) – When TPC receives updated flight schedules and other 
NAS information from participating CDM AOCs, TPC sends the information back to the 

Ctrl + R Press the Ctrl key while pressing the R key 
on your keyboard. Displays the Rename 
Window dialog box and allows you to 
change the title bar name of the active 
component on your screen.

Ctrl + S Press the Ctrl key while pressing the S key 
on your keyboard. Command used to save 
data.

Alt + F4 Press the Alt key while pressing the F4 
key on your keyboard. Shuts down the 
component that you are viewing.

F1 Press the F1 key on your keyboard to 
access the on-line help for the active 
component.

Table 1-1:  (Continued)Keyboard and Mouse Conventions

Command What It Means
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users in the form of an ADL. FSM uses the ADLs, which TPC updates approximately 
every five minutes, to process data and display the information. 

Airport Arrival Rate (AAR) – The number of arriving aircraft that an airport can 
accommodate during a certain period of time.

Airport Departure Rate (ADR) – The number of departing aircraft that an airport can 
accommodate during a certain period of time.

Airspace Flow Program (AFP) – A specific Traffic Management Initiative, which 
assigned delay (control times) to flights that are going through a specified FCA.

CDM (Collaborative Decision Making) – One of five core products in Free Flight Phase 
I, Collaborative Decision Making is a joint government/industry initiative with the goal of 
improving air traffic management through increased information sharing, common 
situational awareness, and equitable resource allocation.

DAS (Delay Assignment) – The default delay assignment mode, formerly known as FA 
delay. 

Delay – Defined as Estimated Time of Arrival (ETA) - (IGTA - taxi). IGTA is the initial 
gate time of arrival, and taxi (unless otherwise specified by the user in Ground Delay 
Tools (GDT) mode has a default value of 10 minutes.

GAAP (General Aviation Airport Program) – A delay assignment mode used during an 
AFP or GDP when current demand does not meet capacity but it is believed that unknown 
traffic will meet or near capacity. Unassigned slots are allocated for future pop-up 
demand. 

Ground Delay Operations – Any one of a number of ways to delay flights on the ground. 
This includes AFPs, GDPs, and GSs.

Ground Delay Program (GDP) – A specific Ground Delay Operation, which assigns 
delay (control times) to flights before departure.

Ground Stop (GS) – A specific Ground Delay Operation, which grounds (holds) flights 
for a specified amount of time at their departure airports.

EDCT Change Request (ECR) – Use the EDCT Change Request tool to view and update 
an arriving flight’s control times during a GDP.

Integrated Program Modeling (IPM) – IPM mode allows you to model and compare 
multiple TMIs, and to review their impact on other data sets.

Slot Credit Substitution (SCS) – A situation that commonly occurs during GDPs where 
an operator has a flight f0 with a slot at time t0, and flight f0 cannot use its slot because it 
is delayed or cancelled. In these situations, SCS provides a mechanism for an operator to 
substitute other operator’s flights to bridge the slot from an unusable time to a time that 
the operator can use to his/her advantage. SCS is an enhancement to the simplified 
substitution process implemented in ETMS 7.2.

Unified Delay Program (UDP) – A delay assignment mode used during a GDP or AFP to 
address the mix of scheduled and unscheduled (i.e., pop-ups) demand based on the 
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following parameters: number of reserved pop-ups , target delay multiplier, and delay 
limit. 
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2:   Understanding FSM Features

Introduction
This section provides a brief overview of the four FSM data modes: 

Monitored Live, Historical, Ground Delay Tools (GDT), and Integrated Program 
Modeling (IPM). Monitored Live mode allows you to monitor and display airport or 
airspace capacity and demand. Historical mode allows you to review past events through 
archived data and is an excellent way to conduct post analysis. GDT mode allows you to 
model and issue Traffic Management Initiatives (TMIs), such as Ground Delay Programs 
(GDPs), Airspace Flow Programs (AFPs), and Ground Stops (GSs). IPM mode allows you 
to model and compare multiple TMIs. The data mode (HIST, GDT, LIVE or IPM) is 
displayed in the title bar of each component (see Figure 2 - 1).

Figure 2 - 1 : Data Mode Displayed in Title Bar

For more detailed information on individual components, see Chapter 3: Understanding 
Components.

Understanding Monitored Live Mode
In Monitored Live mode, you can monitor airport/airspace capacity and demand 
information for flights in various FSM components. FSM updates demand data 
approximately every five minutes in Monitored Live mode, with every new Aggregate 
Demand List (ADL). FSM provides information that supports detailed flight data and 
various types of demand count lists.

When opening components from the Open Data Set component, the two default 
Monitored Live Mode components are:

• Bar Graph – Displays demand versus capacity of a specified data set
• Time Line – Displays how flights are distributed throughout each hour

These two components open by default if you do not change the Open With options in the 
Open Data Set component. You also can individually open the Time Line and Bar Graph 
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components from the Map component. You can access the Flight List component using 
the Open Data Set component as well, but it is not the default selection. See Chapter 4: 
Opening FSM for more information on how to open FSM components.

Figure 2 - 2 shows a possible Monitored Live mode windows management. In this 
example, the user selected BOS from the Open Data Set component. The two default 
components, Time Line and Bar Graph, display automatically when the user does not 
select any other components in the Open With selection box of the Open Data Set 
component.

Figure 2 - 2 : Monitor Mode (Live)

Understanding Historical Mode
Historical mode allows you to select any data set stored in a database. You can use this 
data to analyze scenarios or replay the day’s air traffic events. From the Open Data Set 
component with the Historical tab active, you can drill down to find the year, month, date, 
and data set of the desired information you want to view. Once you select the date and data 
set, FSM gives you the option of selecting a data time. See the Open Data Set component 
in Chapter 3: Understanding Components for more information. FSM displays Historical 
mode data in much the same way as the Monitored Live mode; however, the word HIST is 
displayed next to the ADL time stamp in each Historical mode component. In Historical 
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mode, you can view data in the same five-minute ADL increments in which it originally 
arrived. Click Update on the Control Panel component to update the data to the next 
historical ADL time (see Figure 2 - 3).

You must open the Historical mode data using the Open Data Set component. The two 
default Historical mode windows are:

1. Bar Graph component - Displays demand versus capacity of a specified data set

2. Time Line component - Displays flight distribution throughout each hour

These two components open by default if you do not change the Open With options in the 
Open Data Set component. You can access the Flight List component using Open Data Set 
as well, but that is not the default selection.

Figure 2 - 3 : Historical Mode

Understanding Ground Delay Tools
Although you primarily use Monitored Live mode to monitor a data set’s demand/capacity 
balance and flight information, you use GDT mode to help make air traffic management 
decisions and conduct analysis. You must first select a data set, either airport or airspace, 
in either Monitored Live mode or Historical mode to access GDT mode. Once you select a 
data set, click GDT Mode on the Control Panel component to open the data set in GDT 
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mode. Four default components initially display when you open GDT mode. For detailed 
information on the GDT components, see Chapter 3: Understanding Components.

Note: The GDT Bar Graph and Time Line display flight arrival 
information only. 

The GDT components look similar to Monitored Live mode, with the exception of the 
GDT Setup and GDT Data Graph components (see Figure 2 - 4). The four default 
components that display when you open GDT mode are:

1. GDT Setup – Displays the main TMI setup panel, where you enter the parameters.

2. Data Graph – Displays Power Run Statistics for modeled TMIs in graphical 
format.

3. GDT Map – Displays the Scope, including individual centers and airports for a 
modeled TMI.

4. Bar Graph – Displays demand versus capacity for the data set and any Impact 
elements you select.

Figure 2 - 4 : GDT Mode

Additional components available in GDT data mode:
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• Flight List component – Displays the Flight List of the selected data set.
• GDT Time Line component – Displays flight distribution throughout each hour.
• Demand By Center - Displays the number of Non-Exempt and Exempt flights per 

Center and Airport for the modeled TMI.

Understanding Integrated Program Modeling Mode
IPM mode allows you to model and compare multiple TMIs, and to review their impact on 
other data sets. IPM only provides modeling capabilities and does not allow you to send 
TMIs. Click IPM Mode on the Control Panel component to open IPM mode. Two default 
components, Scenario Manager and Multi Graph, initially display when you open IPM 
mode (see Figure 2 - 5). A third component, IPM Setup is opened from Scenario Manager. 
For detailed information on the IPM components, see Chapter 3: Integrated Program 
Modeling Components.

1. Scenario Manager – Combines FSM-implemented TMIs into one or more system-
wide views, referred to as scenarios. The scenarios allow you to compare 
programs’ effects on one another and to compare multiple strategies at one time.

2. Multi Graph – Consists of bar graphs for each data set in all scenarios. Provides 
consolidated metrics for all scenarios.

3. IPM Setup – Very similar to GDT Setup. The main difference is that you cannot 
run programs; you only can model programs.
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Figure 2 - 5 : IPM Mode

FSM Software Technical and Visual Cues
Java software needs a Java Runtime Environment (JRE) on your computer to execute. 
FSM 9.00 requires a JRE version 1.5.0_06 or higher. Without an available JRE for a given 
environment, it is impossible to run Java software. 

Text Fields Display Conventions
The graphical appearance of text fields is such that you can you can readily determine 
which fields are enabled or disabled, and editable or non-editable.

Note: The coloring convention described in this section does not apply 
to tables. Table fields will have a white background and black 
text even when they are not enabled or editable.

Each text field reflects the following two conditions:

1. Is the field editable or non-editable?

• If the field is editable, the background is white. If the field is non-editable, the 
background is gray. 
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2. Is the field enabled or disabled? 

• Enabled means the field is used in the program. Disabled means the field has 
no bearing on the program. If the field value is enabled, the font is black. If the 
field value is disabled, the font is gray.

The background color defines whether the field is editable or non-editable. The text color 
defines whether the field is enabled or disabled. The following matrix graphically displays 
the three possible presentations of a text field (see Figure 2 - 6):

Figure 2 - 6 : Three Possible Text Displays

Editable / Enabled fields (white background/black text) are used in the program and you 
can edit the values. An example is the Delay Limit (Minutes), Target Delay (Multiplier), 
and Program Start + fields for a GDP-UPD program (see A in Figure 2 - 7).

Non-Editable / Enabled fields (gray background/black text) are used in the program but 
you cannot edit the values. An example is the Earliest R-Slot ddhhmm field for a GDP-
UDP program (see B in Figure 2 - 7). As you change the minute value, the time changes. 
While you cannot directly edit the time (081580), the value changes based on your inputs; 
therefore, the field is non-editable (gray background) and the field is enabled (black text) 
as the field value is part of the program algorithm.

Non-Editable / Disabled fields (gray background/gray text) are not used for the program. 
For example, the bottom two rows of fields in the General Options wireframe do not apply 
to a GDP-UDP program; therefore, they have gray backgrounds with gray text (see C in 
Figure 2 - 7).

Figure 2 - 7 : Examples of Three Text Displays
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Windows Conventions
This section provides an overview of the FSM user interface. It describes the windows, the 
menu bars, tool bars, and other important features. Figure 2 - 8 shows the FSM Control 
Panel component. This panel is displayed for all FSM modes.

Figure 2 - 8 : Control Panel

Title Bar
The Title bar contains a control icon, window title, and Windows buttons.

Figure 2 - 9 : Title Bar

The control icon is displayed on the left side of the title bar. Click it to open the Control 
menu, which contains commands for positioning, resizing, minimizing, maximizing and 
closing the window. Double-clicking the control icon closes the window.

The window title describes the contents of the window. In the Title display you see the 
window name, airport three-letter identifier, date, ADL time and the data mode. Double-
clicking the window title area is the same as clicking the Window Maximize or Restore 
buttons.

Use the Window buttons located on the right side of the title bar to resize and close the 
window.

Menu Bar
The Menu bar, positioned directly below the title bar, displays the menu headings.

Table 2-1:  Window Buttons

Action Button Description
Minimize Reduces the window to its windows icon on the taskbar

Maximize Enlarges the window to fill the screen

Restore Returns the window to its last size and position

Close Closes the window
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Figure 2 - 10 : Menu Bar

The menus that are available depend on the window. Click a menu heading to open the 
menu and select a command. The arrows next to a command indicate another submenu for 
that command. Open the submenu by placing the mouse cursor over the menu command 
(see Figure 2 - 11).

Figure 2 - 11 : Submenu Structure

Toolbar
The docked toolbar is displayed directly under the menu bar (see Figure 2 - 12).

Figure 2 - 12 : Control Panel Toolbar

The toolbar contains shortcut buttons for frequently used commands. The commands that 
are available depend on the window. By default, the toolbar docks at the top of the 
window. You can undock it and move it to any location on your screen. Move the toolbar 
to your desired location by left-clicking the gray dots next to Open Data Set and 
dragging. When you move the toolbar, the window title displays Core. Close the 
undocked window to re-dock the toolbar to its original window.
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Figure 2 - 13 : Moved Toolbar
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Shortcut Buttons
All airports, FEAs, and FCAs, and their respective data modes, and all User Defined 
Groups currently opened by the FSM client are displayed as shortcut buttons on the 
Control Panel component.

The airport, FEA, FCA, or User Defined Group that is active, or in focus, on your screen is 
displayed on the Control Panel component. FSM highlights the active button in orange 
(see Figure 2 - 14).

Figure 2 - 14 : Control Panel

Listed below are the various buttons that are available when a data set is opened in various 
data modes: 

• Live Data Mode – Airport’s three-letter identifier (e.g., ATL), FEA/FCA name (e.g., 
FCAA01), or UDG name

• GDT Data Mode – Airport’s three-letter identifier/G (e.g., ATL/G), or FEA/FCA 
name/G (e.g., FCAA01/G)

• Historical Mode – Airport’s three-letter identifier/H (e.g., IAD/H), FEA/FCA name/
H (e.g., FCAA01/H), or UDG Name/H

• Historical Mode/GDT – Airport’s three-letter identifier/GH (e.g., LGA/GH), or FEA/
FCA name/GH (e.g., FCAA01/GH)

• IPM Mode – The IPM button always is located to the far left of the shortcut button 
bar. Only one IPM button is displayed regardless of the number of scenarios or 
elements within the scenarios.

Hovering the cursor over a shortcut button on the Control Panel displays a tool tip that 
describes the data set in more detail. GDT tool tips display the airport, year/month/day, 
and GDT for the hovered-over data set button (see Figure 2 - 15). Historical mode displays 
the dataset, year/month/day/ airport or FEA/FCA/ADL time, and HIST for the data set 
button. 

If the tool tip is not displayed when you hover over the dataset button, click your mouse 
anywhere in the Control Panel. Note that the dataset button does not have to be selected in 
order to display the tool tip.
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Figure 2 - 15 Tool Tip When Hovering Over ATL/G

Tabs
Tabs are displayed on most FSM components. Selecting a tab makes that tab active. The 
tab that is active is highlighted. Tabs found in the Bar Graph and Time Line are for 
different display options. When you select a tab, the coloring option is displayed in the 
component.

For example, Figure 2 - 16 shows the Bar Graph with the coloring tab Status selected.

Figure 2 - 16 : Component Tabs

Windows Position and Resizing
When more than one window is open on your screen, a window must be active to use it. 
Activate the window by clicking anywhere on it. The title bar of an active window is blue, 
while the title bar of an inactive window is gray. 

Resizing windows allows you to view more windows on your screen at one time. To resize 
a window, position the cursor on any of the borders of the window until your cursor 
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changes to a double-sided arrow. When the double-sided arrow is displayed, click and 
drag in the direction of your choice. When placing your cursor over a corner, the double-
sided arrow is diagonal. This allows you to move two sides of the window at the same 
time.

Moving a Window
You can move around the windows in FSM to suit your needs. Left-click the title bar of 
the window and drag it to move it to a desired position on the screen.

Note: The cursor remains as the normal cursor and not a double-edged 
arrow.
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3:   Understanding Components

Monitored Live Mode Components
Use Monitored Live mode components to monitor airport and airspace capacity, and 
demand information. Demand data updates approximately every five minutes, with every 
new ADL, in live mode. This section familiarizes you with the main Monitored Live mode 
components:

• Control Panel
• Open Data Set
• Map
• Query Manager
• Bar Graph
• Time Line
• Element Display

Control Panel Component
The first component you see upon opening FSM is the Control Panel. The Control Panel 
component allows you to access all other FSM components for displaying, monitoring, 
and managing traffic flow at any data set. The Control Panel consists of the menu bar and 
seven buttons, the explanation for each of these buttons is displayed below. The menu 
items and buttons are enabled or disabled depending on the type of data set (Monitored 
Live, Historical, GDT) selected. When you open a data set, an associated button displays 
just above the Connected Servers information (the text beneath the Control Panel buttons 
that identifies the server to which FSM is connected). 

Figure 3 - 1: Control Panel Component

Control Panel Menu Bar

The menu bar in the Control Panel component contains eight options: File, View, Reports, 
Alerts, TFMS Tools, Utilities, Window, and Help.

1. File Menu

• File > Open Data Set - Opens the Open Data Set component, which allows you 
to open an airport or airspace data set in both Live and Historical data modes.

• File > Load Adaptation - Loads a previously saved adaptation with your display 
preferences. For example, if on a regular basis you monitor ATL and CLT 
airports with the Time Line and Bar Graph components displayed, you can 
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save this configuration and select Load Adaptation to view the desired data in 
that format.

• File > Save Adaptation - Saves your current windows management for an 
airport. You can reopen this adaptation later using File > Load Adaptation.

Note: You cannot save an FEA or FCA to an Adaptation because they 
are dynamic datasets.

• File > Exit - Closes the Control Panel component and exits the FSM 
application.

2. View Menu

• View > Map - Opens the Map component to view airports and FEAs/FCAs 
currently being monitored by FSM. The Map component also shows when 
there is a TMI in place for any particular data set.

• View > GDT Mode - Opens the GDT Setup components for a selected data set.

• View > IPM Mode - Opens the Integrated Program Modeling (IPM) 
components.

• View > Flight List - Opens the Flight List for a selected data set.

3. Reports Menu

Under the Reports Menu, there are eight Counts Lists:

• Counts > By Demand - Displays arrival demand in 15-minute interval flight 
counts and totals the flight count for each hour. This is a quick way to check 
the arrival demand for each hour.

• Counts > By Center - Provides flight counts according to departure centers. 
There are 27 centers and “ZZZ,” which includes any center that is not part of 
the initial 27. Again, in Monitored Live mode, FSM bases these counts on 
flights’ ETA times, as displayed in the FSM Time Line.

• Counts > By Aircraft Category - Displays a count list based on the aircraft 
category. This Count List incorporates the same classifications for aircraft 
category as in the FSM Color By Aircraft Category option. TFMS classifies 
flights according to the aircraft type as specified by the flight plan or CDM 
message.

• Counts > By Aircraft Class - Provides flight counts according to the aircraft 
weight. This Count List incorporates the same classifications for aircraft 
weight as FSM’s Color By Aircraft Class menu option.

• Counts > By Arrival Fix - Provides flight counts according to the arrival fix at 
which each flight is arriving for the monitored airport. Arrival fix names for 
each airport vary. FSM automatically generates the correct Arrival Fix names 
for the monitored airport and uses them in the Count List headings.

Note: This report is not applicable to FEAs and FCAs.
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• Counts > By Departure Fix - Provides flight counts according to the departure 
fix for which each flight is departing from the monitored airport. Departure fix 
names for each airport vary. FSM automatically generates the top 11 departure 
fixes for the monitored airport and uses them in the Count List headings. If the 
departure fix is other than these 11 or is unknown, FSM lists the flight under 
the “Other” column.

Note: This report is not applicable to FEAs and FCAs.

• Counts > By User - Provides a flight count according to the classification of the 
aircraft. Counts By User classifies flights according to their function in the 
NAS. There are 7 user types:

-   C - Air Carriers

-   T - Air Taxi

-   F - Freight/Cargo Carriers

-   M - Military

-   G - General Aviation

-   O - Other - This class includes flights that do not belong to one of the five 
categories listed above. 

-   U - Unknown-This category is for flights which may fall into a user category, 
but the classification for them is not known by TFMS.

• Counts > By Unassigned Slot - Lists all unassigned slots for each 15, 30, and 60 
minute time-bin. This is a quick way to view the distribution of unassigned 
slots across many hours.

Under the Reports Menu, there are five Compliance reports:

• Compliance > By CTD - Flights included in a delay program that violate 
departure compliance. By default, flights that violate departure compliance are 
defined as flights departing more than five minutes before or five minutes after 
their Control Time of Departure (CTD). Any flight that has an Actual Runway 
Time of Departure (ARTD) of five minutes earlier or five minutes later than 
their CTD triggers the CTD Compliance Alarm.

• Compliance > By ETE - Difference between the Estimated Time En route 
(ETE) estimated by Traffic Flow Management System (FTMS) and actual 
flight time is greater than a specified value, but the flight status is not 
“cancelled.” 

• Compliance > By CTA - Flights included in a delay program that violate arrival 
compliance. By default, flights that violate arrival compliance are flights 
arriving more than five minutes before or five minutes after their CTA.

• Compliance > Spurious Flight - Flights submitted as FX Cancellations with no 
corresponding entries in the Official Airline Guide (OAG).
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• Compliance > Cancel That Flew - Flights submitted with a “Cancelled” status 
that flew at a later time within the program parameters.

When one of FSM's compliance alarms is triggered for a flight, FSM generates a list of 
flights that have triggered an alarm. Alarms are triggered in accordance with the reasons 
listed above. These reports update automatically with every ADL for all airports for which 
FSM collects data.

Note: For airports, flights arriving only at the active monitored airport 
are in these reports. For FEAs and FCAs, flights controlled only 
by the element being monitored are in these reports.

There are two Delay Histograms on the Reports menu:

• Delay Histograms> Program Delay - Program delay is the amount of delay that non-
cancelled, non-active, controlled flights receive due to a TMI. Program delay is 
calculated using Max (0, [CTA - BETA]). 

• Delay Histograms> Absolute Delay - Absolute delay is the total amount of delay 
that non-cancelled flights have received. This includes delays assigned by the 
National Airspace System (NAS), Air Traffic Control (ATC), and airline delay. 
Absolute delay is calculated using Max (0, [ETA - (IGTA - Taxi)]).

Note: For FEAs and FCAs, only flights controlled by the element being 
monitored are displayed in the Delay Histograms.

Under the Reports Menu, there are eight additional reports:

Note: For FEAs and FCAs, only flights controlled by the element being 
monitored are in these reports.

• Reports > Surface Delay - This report list can help determine which flights have 
been in Time Out Delay.

• Reports > Priority Flights - This report is similar to an FSM Flight List, but lists 
flights specifically tagged as Lifeguard (LFG) or Diversion Recovery (DVT) 
flights.

• Reports > Time Out Delay - This report quickly provides a picture for you of 
which flights from your operation are contributing to the Time Out delay 
problem. Easier access to this information should help you assess and resolve 
the problem. The format of this report is the same as the FSM Flight Lists 
which include all flights with a delay status marked as `TO’ (Time Out). In the 
Time Out Delayed Flight List, All the TOD column checkboxes are marked, 
indicating that all flights on the list are Time Out Delayed (see Figure 3 - 2).

Note: When you initially open a Flight List, you may need to reposition 
the ADL data columns for easier viewing.
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Figure 3 - 2: Time Out Delayed Flight List

• Reports > Time Out Cancel - This report quickly provides a picture of which 
flights from the operation are contributing to the Time Out Cancel problem. 
Easier access to this information should help you review and resolve the 
problem. This report is in the same format as the FSM Flight Lists and includes 
all flights with cancellation status of ‘TO.’

• Reports > Slot Hold - This report is similar to an FSM Flight List, but only lists 
flights with their slot hold flag set to Y.

• Reports > Sub Opportunities - Provides a flight list to assist airlines and general 
aviation customers in identifying subbing opportunities.

There are two Slot List reports:

• Reports > Slot List > By Carrier- Provides a slot list for a specified airport or an 
airline and its sub-carriers at a specified airport in the exact format that goes to 
the airlines.

• Reports > Slot List > By Center- Opens a Slot List By Center dialog that allows 
you to select available Centers to generate a slot list for the specified Centers.

• Reports > Carrier Statistics - Opens a report displaying delay statistics for all 
carriers with flights operating at the specified airport. Only flights with arrival 
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slots are calculated in the report metrics. That is, flights with a CTA are 
displayed in the carrier statistics. If a carrier operates at the airport, but has no 
flights with a CTA, the Carrier Statistics report displays “0” or “N/A” in those 
rows. You can select the type of delay to view in the report by clicking ABS 
Delay (absolute delay) or Program Delay (delay imposed only by the FAA) at 
the top of the report.

• Reports > Uncontrolled Drop Out - This report is similar to an FSM Flight List, 
but only lists flights that have rerouted out of the currently viewed data set. The 
flights in the Uncontrolled Drop Out report are colored salmon under the Time 
Line’s CNX/[DO] column.

For more information on Reports see Chapter 21: Understanding and Using FSM Reports.

4. Alerts Menu
FSM uses the Alerts option to notify you when new parameters are available for 
any data set you are currently monitoring. The Alerts menu option, data set, and 
associated parameters are highlighted in red when FSM receives new or unviewed 
parameters for airports or FCAs currently being monitored. The Alerts menu 
remains highlighted in red until you view all updated parameters or until you select 
Acknowledge All Alerts. Even if an Alert is no longer highlighted in red, the alert 
information opens as usual when you select the Alert.

Figure 3 - 3: Acknowledge All Alerts
FEAs cannot have an AFP issued for them, so the Alerts menu options for an FEA 
are disabled. If you monitor more than one data set, the Alerts information for the 
current data set is displayed below the menu list of the other data sets being 
monitored. If no parameters are available for a parameter type, the word NO 
displays next to the parameter type. 
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Note: If you select an airport with the letters GDP following the airport 
name in the Open Data Set window, the Control Panel Alerts 
menu is highlighted in red for that airport. Likewise, if you 
select a FCA with the letters AFP following the FCA name, the 
Control Panel Alerts menu is highlighted in red for that FCA.

• Alerts>Acknowledge All Alerts - A confirmation box displays notifying you 
that the red background coloring will be cleared from all Alerts, but the alerts 
information is still available for viewing. Click OK to close the confirmation 
box and remove the red background color from all active alerts. Clicking 
Cancel closes the confirmation box, but performs no action to the Alerts menu 
coloring.

Figure 3 - 4: Acknowledge All Alerts confirmation box

•  Alerts > FADT Parameters Available - This alert does not actually give you 
program parameters. However, you can view a listing of all the FADTs 
generated during each TMI, if available. FADTs are reports generated when 
you run a GDP, AFP, GS, Blanket or Compression operation. FSM lists FADTs 
in chronological order.

• Alerts > SCS Bridge - This alert indicates when a new substitution status update 
occurs. Selecting SCS Bridge displays the current subbing status and may 
contain the following keywords:

-   SUBS: Indicates whether all substitutions are enabled (ON) or disabled (OFF).

-   SCS: Indicates whether slot credit substitutions for all operators are enabled 
(ON) or disabled (OFF).

-   ADPT: Indicates whether adaptive compression is enabled (ON) or disabled 
(OFF).

-   BRIDGING: Indicates whether bridging subs are disabled (OFF) for a particular 
operator (airline name, GA, or MILITARY). If bridging is off for an airline, any 
flight which has a MAJOR field or carrier code (from ACID) that matches the 
airline name is not used for an SCS bridge. If bridging is enabled (ON) for an 
operator, no line displays, in other words, the only allowed value for this 
keyword is OFF.

• Alerts > Actual GDP Parameters - This alert occurs when FSM receives actual 
GDP Parameters through the ADL. First-time GDP Parameters, new GDP 
Parameters, and deleted GDP Parameters trigger this Alert. Select this to view 
these parameters in a static window.
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• Alerts > Actual AFP Parameters - This alert occurs when FSM receives actual 
AFP Parameters through the ADL. First-time AFP Parameters, new AFP 
Parameters, and deleted AFP Parameters trigger this Alert. Select this to view 
these parameters in a static window. 

• Alerts > Proposed GDP Parameters- This alert turns red when parameters for a 
Proposed GDP arrive through the ADL. Select this to view these parameters in 
a static window. 

• Alerts > Proposed AFP Parameters- This alert occurs when FSM receives 
proposed AFP parameters through the ADL. Select this to view these 
parameters in a static window.

• Alerts > Actual GS Parameters - This alert turns red when a Ground Stop (GS) 
is issued and FSM receives its parameters through the ADL. First-time GS 
Parameters, new GS Parameters and deleted GS parameters, all trigger this 
Alert. Select this to view the parameters in a static window.

• Alerts > Proposed GS Parameters-This alert turns red when FSM receives a 
proposed GS. Select this to view the parameters in a static window.

Note: GS parameters are not applicable to AFPs.

• Alerts > COMP Parameters - This alert turns red when FSM receives 
parameters for the compression function through the ADL. Select this to view 
the new parameters in a static window.

• Alerts > BLANKET Parameters - This alert turns red when FSM receives 
parameters for a Blanket function through the ADL. Select this to view the new 
parameters in a static window.

Note: Blanket parameters are not applicable to AFPs.

5.  TFMS Tools
The TFMS Tools dropdown menu contains seven core options: EDCT 
Commands, Command Line, Weather Request, ADL Request, ADL AAR/ADR, 
and Delete Proposed Parameters.

Note:  Only traffic management specialists at the Air Traffic Control 
Systems Command Center (ATCSCC) have access to the TFMS 
Tools menu. 

• TFMS Tools > EDCT Commands options:

-   > EDCT CHECK - Displays the current status of a single flight controlled by an 
EDCT program. When you issue this command, you get a one-line response 
showing the controlled departure time and whether the TFMS has issued a 
Control Time (CT) message to implement the control for this flight.
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-   > EDCT HOLD - Holds all slots in a GDP or AFP for all flights or only the 
flights belonging to a specified airline and its sub-carriers at a specified Airport 
or Airspace data set.

-   > EDCT LIST - Creates a report containing a list of all data sets currently 
controlled by EDCT programs.

-   > EDCT LOG - Creates a report of all EDCT files, cancellation messages, 
Simplified Substitution (SS) processing messages, and EDCT updates 
processed by the system in the order they were received. 

-   > EDCT PURGE - Purges EDCT flight controls for a specified Airport or 
Airspace data set or for all data sets.

-   > EDCT RELEASE - Releases all slots in a GDP or AFP for all flights or only 
the flights belonging to a specified airline and its sub-carriers at a specified data 
set.

-   > EDCT SCS OFF - Suspends slot credit substituting for flights controlled by 
EDCT programs at a specified data set or at all data sets. To allow slot credit 
processing after suspending slot credit substituting, you must activate 
processing with the EDCT SCS ON command.

-   > EDCT SCS ON - Allows slot credit substituting for flights controlled by EDCT 
programs at a specified data set or at all data sets. To prohibit slot credit 
substituting, you must suspend processing with the EDCT SCS OFF 
command.

-   > EDCT SHOW - Creates a report that contains detailed information on all 
flights controlled by EDCT programs for a specified data set, or for all data sets.

-   > EDCT SLIST - Provides a slot list (using the same format that goes to the 
airlines) for a specified airport or an airline and its sub-carriers at a specified 
data set.

-   > EDCT SUB OFF - Suspends Substitution processing (SI) messages for flights 
controlled by EDCT programs at a specified data set or at all data sets.

-   > EDCT SUB ON - Allows Substitution processing (SI) for any flights controlled 
by EDCT programs at a specified data set or at all data sets where substitution 
processing was previously suspended.

-   > EDCT AC OFF - Allows users to turn Adaptive Compression off by entering 
the airport or FCA name, or ALL into the dialog box. Only Computer System 
Analysts (CSA) at the ATCSCC can use this command.

-   > EDCT AC ON - Allows users to turn Adaptive Compression on by entering the 
airport, FCA name, or ALL into the dialog box. Only CSA at the ATCSCC can 
use this command.

-   > EDCT SUB SHOW - Generates a report that shows the status of simplified 
substitution processing (SS) messages for all data sets. 
FSM User Guide, Version 9.00 3-9



Understanding Components
-    > EDCT UPDATE - Allows you to update a controlled flight with new departure 
and arrival times. After you issue this command, you get a one-line response 
stating that the update was successful. 

-   > EDCT REMOVE - Allows you to remove flights from the TFMS database, as 
if they never existed. Using this command can eliminate a duplicate flight or 
remove a specific incorrect flight. Only CSA at the ATCSCC can use this 
command.

-   > EDCT RESTORE - Allows you to “undo” the effects of the Remove 
command. It allows some or all of the flights that you did not want to remove 
from the database to be restored. Only CSA at the ATCSCC can use this 
command.

-   > EDCT UNASSIGNED SLOTS - Allows you to request, by airport identifier, an 
updated unassigned slots list generated by the hub site.

• TFMS Tools > Command Line - Displays a dialog box which allows the user to 
enter any EDCT FAA commands. 

• TFMS Tools > Weather Request - Allows you to request current airport weather 
(METAR and TAF) for one or more airports (use the three letter airport 
identifiers separated by commas or spaces).

Note: Weather Request is not applicable to FCAs and FEAs.

• TFMS Tools > ADL Request - Allows you to request a new ADL generated 
from the hub site for a particular data set.

• TFMS Tools > ADL AAR/ADR > Modify AAR/ADR - Allows you to modify 
ADL Arrival Rates/ADL Departure Rates including the ability to assign 
several different Airport Arrival Rates (AARs)/Airport Departure Rates 
(ADRs) within the same hour (see Figure 3 - 5).

Figure 3 - 5: Modify AAR/ADR Window
In Monitored Live mode:
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-   Click Send to reset AAR/ADR values to the default setting and send the 
information to TFMS. The reset AAR/ADR is reflected in the next ADL 
update. 

-   Click Cancel to close the Reset AAR/ADR window without taking any actions.

-   Click Help to display a pop-up screen with additional information on the Send 
and Cancel buttons.

• TFMS Tools > ADL AAR/ADR > Reset AAR - Resets the Arrival Rate to the 
TFMS default arrival rate (see Figure 3 - 6).

• TFMS Tools > ADL AAR/ADR > Reset ADR - Resets the Departure Rate to the 
TFMS default departure rate.

Note: ADL ADR is not applicable to FCAs and FEAs since departure 
rates do not apply to airspace data sets.

Figure 3 - 6: Reset AAR Window

Note: When in Historical Mode, clicking Send resets the historical 
data to the first ADL update time. 

Reset AAR/ADR Window Menu items:

-   File > Print - Prints the AAR/ADR window data.

-   File > Close - Closes the Reset AAR/ADR window.

-   Help > Demand Rates - Opens the on-line help information specific to the 
modifying demand rates.

• TFMS Tools > Delete Proposed Parameters - Opens the Delete Proposed 
Parameters dialog box (see Figure 3 - 7). Select the airport or FCA for which 
you want to delete parameters from the For Data Set drop down menu.

Figure 3 - 7: Delete Proposed Parameters Window
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6. Utilities Menu

• Utilities > Query Manager - Opens the Query Manager component.

• Utilities > Search By Callsign - Opens the Search By Callsign window.

• Utilities > Model Program Rate > Specify - Opens the Specify Model Program 
Rate window allowing you to specify the Model Program Rate and the ability 
to model several different Program Rates within the same hour. You must 
select View > The Model Program Rate on the Bar Graph to view the modeled 
rate.

• Utilities > Model Program Rate > Reset - Resets the model Arrival Rate to equal 
the current ADL AAR.

• Utilities > Historical Pop-Up Demand - Opens the Display Historical Pop-Up 
window for the selected airport (see Figure 3 - 8). This view-only window 
displays the historical pop-up prediction currently included in the ADL. This 
window is available at anytime, regardless of whether or not a TMI is in place. 
For more detailed information, see Chapter 5: Historical Pop-Up Demand.

Note: Historical pop-up estimates are not available for FEAs/FCAs.

Figure 3 - 8: Display Historical Pop-Up Window

• Utilities > View File - This option allows you to view previously saved Analysis 
Reports, Coversheets, and Flight Data (see Figure 3 - 9).
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Figure 3 - 9: View File Window

• Utilities > Set Time - Allows you to set a specified time for Historical data sets 
only (see Figure 3 - 10). Disabled for all Monitored Live and GDT data sets.

Figure 3 - 10: Set Time Dialog Box

• Utilities > Update - Updates the active historical mode components with the 
next historical ADL file. Disabled for all Monitored Live and GDT data sets.

• Utilities > ECR - Opens the ECR component to update a controlled flight’s 
control times. Disabled for all Historical and GDT data sets.

Note: ECR is only available in Live mode for data sets with active 
TMIs.

7. Window Menu

• Window > Hide All Windows - Hides all open FSM components.

• Window > Hide All Iconified Windows - Hides all FSM iconified bars displayed 
in the Task bar.
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• Window > (airport, FCA, FEA, or User Defined Group (UDG) abbreviation) 
LIVE, (airport, FCA, FEA or UDG abbreviation) yyyy/mm/dd GDT, or (airport, 
FCA, FEA, or UDG abbreviation) yyyy/mm/dd HIST - Click the data mode and 
airport, FEA, FCA, or UDG selection to open the active components for that 
airport, FEA, FCA, or UDG. Each component displays under the Window 
menu. Select a checkbox to display and bring to the front of your monitor the 
subsequent airport component. Selections are consecutively numbered in the 
order they were opened.

8. Help Menu

• Help > FSM - Opens the FSM on-line help.

• Help > ADL Data Elements - Opens the ADL Data Elements page from the 
FSM on-line help.

• Help > Show Configuration - Displays current FSM configuration in use (see 
Figure 3 - 11).

Figure 3 - 11: Configuration Setting Window

• Help > About FSM - Displays information about the FSM version running 
including the FSM Version and Copyright Information - The version of FSM 
currently running (e.g., FSM 9.00), Metron Aviation, Inc. copyright notice, the 
software build date, and Product License information.

Control Panel Buttons

You can use the buttons from the Control Panel component to open other FSM 
components.
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• Open Data Set opens the Open Data Set component in which the user may select 
various operating modes and Available Airports or FEAs/FCAs. See Open Data Set 
component overview for more detail.

• Map opens the Map Component, which displays airports and regions currently being 
monitored and their status in their respective geographical locations. See Map 
Component for more detail.

• Search By Callsign opens the Search By Callsign component, which allows you to 
find a particular flight by entering the flight’s call sign and origin airport.

• GDT Mode opens four GDT components: GDT Setup, GDT Map, GDT Bar Graph, 
and GDT Data Graph components. An airport, FEA, or FCA must already be opened 
to enable the GDT Mode button. If there is no data set selected, clicking GDT Mode 
causes an error message to display by default. See Chapter 4: Opening FSM for 
detailed information on Ground Delay Tool Components.

• IPM Mode opens two IPM components: Scenario Manager and Multi Graph. See 
Chapter 3: Scenario Manager Component and Chapter 3: Multi Graph Component for 
detailed information.

• Update allows you to update the Time Line and Bar Graph with the next ADL update 
only in Historical Mode. You must open an airport, FEA, or FCA in Historical Mode 
to enable the Update button.

• ECR opens the ECR components. Use ECR to update EDCTs for flights arriving into a 
controlled airport or at a controlled FCA. The ECR button is enabled only if actual 
GS, GDP, or AFP parameters are in place for the active data set. See Chapter 14: 
EDCT Change Request (ECR)for detailed information on the ECR component 
functionality.

Note: The ECR option is enabled for Airports or FCAs only when an 
active TMI is in place.

Open Data Set Component
Clicking Open Data Set on the Control Panel opens the Open Data Set component. This 
component allows you to choose an FSM data mode and data set for monitoring and 
managing air traffic flow. A data mode is the type of data you want to use: historical or 
live. Live data is fed from TFMS to the FSM client on a real-time basis, while historical 
data is archived data that FSM can pull to allow you to review air traffic events in the past. 
A data set is the airport, FEA, or FCA and the components you would like to use to 
display.

• Monitored Live - Monitored Live mode provides a list of airports, FEAs, and FCAs 
currently monitored by the FSM server and readily available for viewing by the user. 
This data mode runs real-time data and receives ADL updates every five minutes 
while running FSM.

• Historical - This data mode uses historical data that has been stored by your FSM 
server database. Historical data is available for recall to analyze scenarios or replay a 
day’s air traffic events.
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• All Live - All Live provides a list of airports, FEAs, and FCAs that you can view (not 
currently being monitored by the server, but available).

• Active Historical - The Active Historical tab provides a list of historical data currently 
opened and monitored by the user.

Note: All times displayed in and used by FSM are Zulu times unless 
otherwise specified.

Figure 3 - 12: Open Data Set Component

Open Data Set Menu Bar

The Menu Bar in the Open Data Set component contains two options: File and Help.

• File > Close - Closes the Open Data Set component.
• Help > Open Data Set - Opens the on-line help for the Open Data Set component.

Sort Airports By Options

The Monitor Live and All Live tabs of the Open Data Set component allow selectable 
sorting of available airports by the following methods:

• Airport ID
• Controlling Center ID

The sorting options are displayed at the top of the Monitored Live and All Live tabs in the 
Sort Airports By: section.

When you select the Airport ID radio button, the Open Data Set component lists the 
Airport IDs sorted according to the alphabet. This means numbers are listed on top before 
the “A” airports. Sorting by Airport ID is the default when you first start FSM.
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When you select the Center ID radio button, the Open Data Set component lists the Center 
IDs in a tree structure with each node representing a specific Center ID. If an airport or 
airports within a Center ID has a program, the count and type (either Actual or Proposed) 
of program displays next to the Center ID. The Open Data Set component lists the Center 
IDs alphabetically in the following order:

1. US, Mexican, and European Centers (Centers starting with letter Z)

2. Canadian Centers (Centers starting with letter C)

By default, the Center ID trees are collapsed. The Airport ID displays alphabetically 
within its controlling Center ID when you expand a Center ID. Center IDs without any 
applicable airports are hidden.

Figure 3 - 13: Open Data Set Component Sorted By Center

Group By Options

The Group By section allows you to create User Defined Groups (UDGs). The default 
selection is Element Name which causes data sets to open by element (airport, FCA, 
FEA). If you select Custom Group, you can create your own UDG with components from 
various airports, FEAs, FCAs, and data modes. For more information, see Chapter 4: 
Opening FSM.
Open With Options

The Open With portion of the Open Data Set component contains four component options 
with which to open and view an airport, FEA, or FCA:

• Time Line - opens the Time Line component of the selected data set, displaying 
regular Time Line options for each data set.
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• Flight List - opens the Flight List component of the selected data set.
• Bar Graph - opens the Bar Graph component of the selected data set.
• ECR - opens the ECR component of the selected Monitored Live data set if a program 

is in place.

Note: ECR cannot be opened for an uncontrolled data set.

Select the components you want to open for a selected airport, FEA, or FCA by placing a 
checkmark in the associated checkbox of the Open With section (see Figure 3 - 14). If you 
do not make any changes in the Open With section, the Time Line and Bar Graph 
components for the selected airport, FEA, or FCA open by default. If you do make 
changes, you can return to the default settings by clicking Default.

Figure 3 - 14: Open With Component Selection

Open Data Set Tab Options

The Tab Options in the Open Data Set window consist of four tab selections, Monitored 
Live, All Live, Historical, and Active Historical.

1. Monitored Live Tab
The Monitored Live tab provides a list of airports, FEAs, and FCAs currently 
monitored by the FSM server and readily available for you to view. GDP 
Proposed, GDP Actual, GS Proposed, or GS Actual along with the program times 
are displayed next to airports with a TMI in place. AFP Actual or AFP Proposed 
along with the program times displays next to FCAs with an AFP in place. Select 
the desired data set by clicking the information in the scrolling area of the window. 
See Chapter 4: Opening FSM, for more information on using the Open Data Set 
component. In the following example, PHX airport, has a GDP in place, with the 
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Time Line and Bar Graph selected; this opens the Time Line and Bar Graph 
components for PHX in Monitored Live mode (see Figure 3 - 15).

Figure 3 - 15: Open Data Set - Monitored Live Tab

2. All Live Tab
The All Live tab provides a list of airports, FEAs, and FCAs that you can view. 
When you select an airport, FEA, or FCA data set from the All Live tab, it initially 
takes slightly longer to open than from the Monitored Live tab. When selected, the 
3-letter code for the airport, FEA, or FCA is highlighted in light purple.
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Figure 3 - 16: Open Data Set - All Live Tab

3. Historical Tab
This Historical Tab display provides you with the available historical data archived 
in FSM. You can select your historical data by drilling down from the server from 
which you want to pull data. FSM arranges the drill down order by 
Server>Year>Month>Day>Airport or FEA/FCA (see Figure 3 - 17). 
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Figure 3 - 17: Open Data Set - Historical Tab

Note: If the FSM Client is connected to two servers, both servers are 
displayed.

4. Active Historical Tab
The Active Historical tab provides a list of airports, FEAs, and FCAs currently 
open in Historical Mode. You can open additional components or toggle from one 
historical data set to another from this tab.
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Figure 3 - 18: Open Data Set - Active Historical Tab

Note: All times displayed in and used by FSM are Zulu times unless 
otherwise specified.

Open Data Set Buttons

The Open Data Set component has three action buttons that are active by default (Apply, 
OK, and Cancel). Two others button become active depending on what type of data set 
you are viewing (View Element) or whether you change the default settings in the Open 
With section (Default).

1. Apply keeps the Open Data Set component active in addition to opening the 
selected airport components.

2. OK closes the Open Data Set component when opening the selected airport 
components.

3. Cancel closes the Open Data Set component without making any selections.

Figure 3 - 19: Open Data Set Button Options
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4. Default returns the Open With selections to the default checked items- the Time 
Line and Bar Graph.

5. View Element allows you to see the data pertaining to an FEA or FCA that FSM 
receives from the broadcast message or ADL for that FEA or FCA.

Map Component
You can view the Map component by clicking Map on the Control Panel component. The 
Map displays North America with an overlay of all US and Canadian centers and an 
outline of the 48 contiguous states, Mexican states, and Canadian Provinces. Airports, 
FEAs, and FCAs currently being monitored by the server are displayed on the map. The 
map title bar shows the total number of monitored airports, FCAs, and FEAs.

For airports, the airport three-letter identifier (US) or four-letter identifier (Canada) and a 
colored dot indicating the status of each airport are displayed on the map. The number of 
airports, FEAs, and FCAs listed on the map are displayed in the title bar-monitored data 
sets: XX where XX is the number of airports currently monitored are displayed on the 
map (see Figure 3 - 20). The color of the airport dots tell you the current status of that 
airport. For more information on airport status (see Table 3-1).

For FEAs and FCAs, the map displays colored lateral bounds. The colors parallel the 
airport colors (see Table 3-2). If you left-click the bounds, the bounds turn white and the 
map displays the element name, and ADL time (if applicable). Left-clicking the bounds of 
a monitored FCA with an AFP causes the map to display the scope of the AFP.

You can view different projections of the map to see London, Canada, CONUS, Alaska or 
the Atlantic. Select View > Projections > [projection type] and the map redraws to show the 
projection you selected.

Table 3-1:  Airport Status

Color Status
Green No Traffic Management Initiatives (TMIs) are in effect for the airport.
Red An actual Ground Delay Program (GDP), and/or Ground Stop (GS) is in 

effect.
Yellow There is either a proposed GDP or GS, or there is a proposed GDP and 

an actual GS.

Table 3-2:  FEA/FCA Status

Color Status
Green No Traffic Management Initiatives (TMIs) are in effect for the airport.
Red An actual program is in effect.
Yellow There is either a proposed program.
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Figure 3 - 20: Map component

Map Zoom Capabilities

There are several different ways to zoom in or zoom out on the Map or GDT Map 
components.

1. Quick Key Method - Pressing Z on your keyboard incrementally zooms in to the 
center of your screen. Pressing U on your keyboard incrementally zooms out from 
the center of your screen. To move the center focus of your screen to another focal 
point or to zoom in on a particular airport, move the cursor to the desired location 
and press M on the keyboard. Quick key M moves the central focus of the map to 
the cursor location. To zoom in or out from that point, continue to use Z or U quick 
keys. In addition, pressing X on the keyboard undoes the last command (up to 25 
commands).

2. Drag and Drop Method - To zoom out, hold down the left mouse button and drag 
the cursor up and left. To zoom in, hold down the left mouse button and drag any 
direction, besides up and left, around the area you want to zoom in on.

3. Right Click Method - After using either method listed above, right-clicking the 
cursor anywhere within the Map component gives you two options: Default zoom 

Table 3-3:  Quick Key Commands

Quick Key Description
M Move
Z Zoom In
U Zoom Out
X Undo Move/Zoom
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and undo zoom. Default zoom returns the Map zoom to the initial zoom setting. 
Undo zoom, undoes the last zoom command - same as using the X quick key.

Note: The Drag and Drop Method is not precise, it is recommended 
that you use the Quick Key Method.

Viewing Parameters

From the Map, you can view the scope of an airport’s or FCA’s TMI parameters. Left-
click an airport or the boundary of an FCA that has either proposed or active parameters in 
place and FSM displays the parameters (see Figure 3 - 21). The maroon overlay and red 
airports indicate the area and airports included in the data set’s TMI. A colored boundary 
(red for actual programs, yellow for proposed programs) and red airports either partially or 
wholly within the boundary indicate an FCA with a TMI in place.

In addition to the graphical parameters display, a white data block with black text shows 
the airport ID, FEA name, or FCA name, date, ADL time, the type of program, the 
program time range, and for GS programs, non-exempt centers and/or airports. To return 
to the normal Map display, click the white airport circle or the FEA or FCA boundary. 

If multiple TMIs are in place at an airport or for an FCA, you can select the TMI for which 
you would like to see parameters. Left-clicking an airport or an FCA boundary causes a 
menu to open with the TMIs (Actual GDP, Actual GS, Proposed GDP, Actual AFP, 
Proposed AFP) listed by start time. Select the appropriate TMI from the list.

Figure 3 - 21: View Airport Parameters

Opening Components from the Map

You can access an airport’s Time Line, Bar Graph, Flight List, and ECR components 
directly from the Map. Left-click the airport; this turns the airport white in color and if the 
airport is running a TMI, the parameters are displayed on the Map, similar to the GDT 
Map display. Once you select an airport, right-click the airport to display the pop-up 
selection menu, which includes the zoom options described above. The pop-up menu also 
allows you to view the Time Line, Bar Graph, Flight List, or ECR component for the 
selected airport in Monitored Live mode only. For example, selecting Open Time Line 
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opens up the Time Line live component for the airport. For more information see Chapter 
4: Opening FSM.

Additionally, you can access an FEA or FCA’s Time Line, Bar Graph, Flight List, ECR, 
and Element Display components directly from the Map. Left-click the FEA or FCA 
boundary; this turns the boundary white in color and if the FCA is running a TMI, the 
parameters are displayed on the Map, similar to the GDT Map display. Once you select an 
FEA or FCA, right-click the boundary to display the pop-up selection menu, which 
includes the zoom options described above (see Figure 3 - 22). The pop-up menu also 
allows you to view the Time Line, Bar Graph, Flight List, ECR, or Element Display 
component for the selected FEA or FCA in Monitored Live mode only. 

Figure 3 - 22: Right- Click Component Selection

Map Menu Bar

The Map menu bar contains four options: File, View, Map and Help.

Figure 3 - 23: : Map Menu Bar

1. File Menu

• File > Save as - Saves the Map as a .jpg image in a directory that you specify.

• File > Print - Prints the active Map on the monitor.

• File > Close - Closes the Map component.

2. View Menu

• View > Rename Window - Displays the Rename Window dialog box and allows 
you to change the title bar name. Type in the desired name then click OK to 
change the title bar heading. Click Cancel to close the Rename Window dialog 
box without making any changes (see Figure 3 - 24).
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Figure 3 - 24: Rename Window Dialog Box

• View > Projection - You can use this to select from the following set of 
projection center points: Alaskan, Atlantic, Canada, CONUS, London. The 
default is CONUS. When you select a projection center point, the map redraws 
to center on that point.

3. Map Menu

• Map > Auto-Show - You can use this to select whether to see Monitored 
Airports, Monitored FEAs/FCAs, Unmonitored FEAs/FCAs, or FCAs with 
AFP on the map. The default is Monitored Airports, Monitored FEAs/FCAs 
and FCAs with AFP.

• Map > Zoom In - Allows you to enlarge the Map.

• Map > Zoom Out - Allows you to reduce the Map size.

• Map > Default Zoom - Returns the Map to the original default zoom.

4. Help Menu

• Help > Map- Opens the on-line help for the Map component.

Query Manager Component
You can view the Query Manager component by selecting Utilities > Query Manager from 
the Control Panel component. The Query Manager component enables you to query and 
filter flights to create a Flight List that contains flights that meet only your selected 
criteria.

Figure 3 - 25: Opening Query Manager Component
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The Query Manager component gives you the option of selecting between Built-in Filters 
or User Defined Filters (see Figure 3 - 26). 

Built-in Filters are pre-defined, read-only filters designed from criteria that are frequently 
used for viewing flight information. Double-click the BUILT_IN Built-in Filters folder or 
click the Expand/Collapse icon to view/hide all contents in the folder. When you expand 
the Built-in Filters folder, you see a number of filters from which to choose. You may 
continue to drill down to view more detail by double-clicking the folders or by clicking 
their respective Expand/Collapse icons.

The AND filters list consists of filters that FSM compares to find a match in the data set. 
An OR filter consists of a list of filters that FSM compares to find matching flights in the 
data set. A CONSTRAINT is an attribute, operator, or value. For more information on 
filters see Chapter 22: Using Query Manager.

User Defined Filters are active filters you create and customize based on your Flight List 
needs. There are two methods of creating user-defined filters: 

• Creating a New Filter
• Editing a Built-in filter

For more information on filters see Chapter 22: Using Query Manager.

Figure 3 - 26: Query Manager Component

To Open a Flight List

1. Select Utilities > Query Manager to open the Query Manager Component.
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The Query Manager window displays.

2. Select any one of the Built-in or User Defined Filters.

3. Click Flight List.

• If you are only monitoring one data set, the Flight List opens, in table format, 
with the information generated from the selected filter criteria.

• “No Active Data Sets” error messages pop-up if the FSM Client is not 
monitoring any airports.

• If you are monitoring more than one data set, the Set Data Set window displays 
(see Figure 3 - 27).

4. Select the desired data set for which you want to view the queried flight list.

5. Click OK to open the Flight List. See Chapter 6: Viewing Flight Information for 
detailed information on Flight Lists.

Figure 3 - 27: Set Data Set Window

Query Manager Menu Bar

The menu bar of the FSM Query Manager component contains four options: File, Edit, 
View, and Help.

1. File Menu

• File > Save - Saves the User Defined Filters into the user_filter.ini file. In the 
FSM Client ini file, you can specify the name and location of where the 
user_filter.ini file is stored. The saved filters are available every time you open 
a Query Manager.

• File > Close - Closes the Query Manager window - taking no action.

2. Edit Menu

• Edit > Cut - Deletes selected User Defined Filters from the Query Manager.

• Edit > Copy - Copies selected filters to the clipboard.
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• Edit > Paste - Pastes selected filters from the clipboard to the User Defined 
Filters folder.

• Edit > Create Filter - Opens the Create Filter component.

• Edit > Rename Filter - Allows you to edit the filter name.

3. View Menu

• View > Rename Window - Displays the Rename Window dialog box and allows 
you to change the component name in the title bar. Enter the desired 
component name then click OK to change the title bar heading. Click Cancel 
to close the Rename Window dialog box without making any changes (see 
Figure 3 - 28).

Figure 3 - 28: Rename Window Dialog Box

• View > Flight List - Displays the Flight list if the FSM client is monitoring only 
one airport, or the Set Data Set window when the FSM client is monitoring 
multiple airports. 

4. Help Menu

• Help > Query Manager - Opens the on-line help for the Query Manager 
Component.

Bar Graph Component
The Bar Graph component allows you to view the overall demand of the airport, FEA, or 
FCA you are monitoring. Airport demand consists of the total flights using the airport for 
arrivals and departures, by default only arrival demand is displayed. For FEAs and FCAs, 
FSM displays arrival demand on the Bar Graph by flight ENTRY time. Airspace data sets 
do not have departure data. Also, for FEAs and FCAs the following tabs do not apply and 
are disabled: Arr/Dep Status, Afix, and Dfix.

The FSM Bar Graph displays demand information as it is received through ADLs. There 
are 16 different color options to view this demand. The Status tab is the default view when 
you first open the Bar Graph component. The airport name, FEA name, or FCA name, 
date, last ADL update time, data mode and UDG name (if applicable) also are displayed in 
the Bar Graph title bar.
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Figure 3 - 29: Bar Graph Component

The Bar Graph component displays data according to which “Color” tab option you select. 
For example, the default color tab is Status, which displays the bars in the graph colored 
according to the percentage of flights that represent each respective arrival status. If half 
of the flights for one time period are scheduled to depart, while the other half are airborne 
(flight active), the bar for that hour is half red (flight active) and half lime green (departing 
[No EDCT]). If every flight for the hour has arrived, the bar for that hour is black.

The graph is dynamic and changes according to the information from each ADL update. 
Likewise, the graph automatically updates itself when you select a different “Color” tab. 
To view a flight count for any hour, place the cursor over any bar within the Bar Graph, 
the respective number/count displays for the bar the cursor is hovering over. If you place 
the cursor near the top of a bar, the total number of flights for that hour displays. You can 
use the same method to find out the Airport Arrival Rate (AAR). Place the cursor over the 
AAR and the rate displays. Double-clicking any bar displays a Flight List for flights 
contained in that hour bar. See Chapter 6: Viewing Flight Information for more detailed 
information on flight lists.

The Bar Graph also allows you to Generate a Flight List for specific color blocks 
displayed within a time bin. Right-click a selected time bin and select Open Flight List For 
and then select the desired color. For example, to view all the Active flights in a specific 
hour for SFO, right-click the desired time bin and select Open Flight List > Flight Active 
(see Figure 3 - 30). This opens a flight list for Active flights (colored red) in the specified 
hour.
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Note:  Selecting a color that has no flights associated with it opens an 
empty Flight List. If a color is deselected from the Bar Graph 
Legend, the color option is not displayed in the Open Flight List 
For selection criteria.

Figure 3 - 30: Open Flight List For

Bar Graph Legend

To view the color legend you can click the legend button (located next to the time bin 
buttons) or select the View > Show Legend checkbox from the Bar Graph’s menu. The 
Legend displays the color scheme for the color tab currently displayed and allows you to 
toggle the coloring options on and off by using the checkbox next to each color.
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Figure 3 - 31: Carrier Tab with Color Legend open

Bar Graph Menu Bar

The menu bar of the FSM Bar Graph component contains five options: File, View, Bar 
Graph, Display, and Help.

1. File Menu

• File > Save As - Saves the Bar Graph as a .jpg image to a directory you specify.

• File > Print - Prints the Bar Graph currently viewed on your screen.

• File > Close Group - Closes all the components associated with the open 
component. This function removes the airport, FEA, or FCA button from the 
Control Panel for the selected airport, FEA, or FCA and data mode.

• File > Close - Closes the Bar Graph component for that particular airport, FEA, 
or FCA.

2. View Menu - consists of 16 checkboxes and three additional menu items. Check 
the box to view the information and uncheck the box to hide the information.

• View > Rename Window - Displays the Rename Window dialog box that allows 
you to change the component name of the title bar. Enter the desired 
component name then click OK to change the title bar heading. Click Cancel 
to close the Rename Window dialog box without making any changes.

• View > Set Tabs Displayed - You can dynamically show and hide specific 
coloring schemes for the Bar Graph component.
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• View > Arrival Data - Displays all arrival data for the monitored airport, FEA, 
or FCA. The bars of the graph are solid only when you are viewing arrival data 
in FSM.

• View > Departure Data - Displays all departure data for the monitored airport. 
The bars of the graph appear hashed only when you view departure data in 
FSM (see Figure 3 - 32). When you view both arrival and departure data in 
FSM, you see two bars for each time increment. Bars that represent arrival data 
are solid, whereas bars that represent departure data are hashed.

Note:  FEAs and FCAs contain no departure information. 

Figure 3 - 32: Normal View with Arrival and Departure Data Displayed

• View > Stack Departures - Displays departing flights in the same bars as 
arriving flights, (see Figure 3 - 33). The bars on the graph become solid, with 
both arriving and departing flights included in the bar for their departure or 
arrival time. To differentiate between departing and arriving flights, use the 
Arrival/Departure tab to color your flights. Using Arrival/Departure displays 
(by default) arriving flights in green and departing flights in blue.
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Figure 3 - 33: Arrival and Departure Data displayed in stacked format

• View > Show Cancellations - Displays cancelled flights in the color cyan. 
Cancelled flights do not automatically display in the graph. Showing cancelled 
flights is useful to compare the original demand with the demand after the 
cancellations. To differentiate between cancelled and regular flights, use the 
Arrival Status tab to color your flights.

• View > Show Unassigned Slots - Displays all unassigned slots in the color white 
for a GAAP GDP or AFP.

• View > Show Legend - Displays the appropriate color legend associated with 
the tab option you are viewing. If you click the legend button on the Bar 
Graph, FSM dynamically selects the checkbox for Show Legend.

• View > Time Indicator - Displays an orange vertical line that remains fixed at 
the current time. Like the FSM Time Line, the Bar Graph Component also 
tracks time.

• View > Cumulative GDP/AFP Indicators -Displays a brown solid vertical line 
representing the cumulative start and end time for a GDP or AFP.

• View > Event GDP/AFP Indicators - Displays brown vertical dashed lines to 
indicate the start time and end time of a current GDP or AFP. The program 
time indicators are displayed when a program goes into effect at the monitored 
data set.
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Note:  If the cumulative time and the event time are the same, the solid 
brown line (cumulative time) will take precedence over the 
dashed brown line (event time).

• View > GS Indicators - Displays yellow vertical lines to indicate the start time 
and end time of a current GS. The GS time indicators are displayed when a GS 
goes into effect at the monitored airport.

• View > Arrival Flow Rate - Displays a thin, dark gray line that represents the 
arrival flow rate independently of the time-bin convention, enabling you to 
visualize arrivals as a dynamic flow rate.

• View > Departure Flow Rate - Displays a thin, cyan line that represents the 
departure flow rate independently of the time-bin convention, enabling you to 
visualize departures as a dynamic flow rate.

Note: FEA and FCAs have no departure information, therefore, the 
Departure Flow Rate is zero.

• View > ADL AAR Line - Displays a white horizontal line that runs through the 
graph representing the current Airport Arrival Rate (AAR) for the monitored 
airport or airspace data set. The ADL AAR (shown by default) is a fixed AAR 
sent by the FAA Air Traffic Control System Command Center (ATCSCC) to 
advise of the number of arriving aircraft a data set can accommodate at any 
given interval of time. The AAR changes according to the interval of time 
being displayed. For example, an AAR of 60 per hour = AAR of 15 per quarter 
hour. Only ATCSCC users can change the ADL AAR.

• View > ADL ADR Line - Displays a cyan horizontal line that runs through the 
graph. The line represents the Airport Departure Rate (ADR) for the monitored 
airport. The ADL ADR, (shown by default when Departures is checked), is a 
fixed value sent by the FAA ATCSCC to specify the number of departing 
aircraft an airport can accommodate at any given interval of time. The ADR 
also changes according to the time increment used in the graph display. For 
example, an ADR of 60 per hour is equal to an ADR of 15 every quarter hour.

Note: Not applicable for FEAs and FCAs.

• View > Model Program Rate - Displays a user-specified Program Rate as a 
dashed white line. You use the Model Program Rate for modeling and analysis; 
you can change this according to program needs.

• View > Time Increment > 15 Minutes, 30Minutes, 60 Minutes - Displays bar 
graph capacity and demand information based on the time-bin value selected. 
The default time increment is 60-minutes. If you click one of the time bin 
buttons on the Bar Graph, the same increment displays selected on the 
associated menu item.

• View > Hours Shown > 2/3/4/5/6/8/10/12/14/16/18/20/22/24/36 Hours - The 
default data display is 10 hours. You can specify the number of hours displayed 
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in the Bar Graph to see more or less flight data. For example, you may want to 
view the AAR in 15-minute increments, which is difficult to see on a graph 
with 10 hours’ worth of data. To change the number of hours in the graph, 
select View > Hours Shown > X Hours (X = number of hours). The graph 
automatically updates to show the number of hours specified.

3. Bar Graph Menu

• Bar Graph > Track Time - Makes the graph move as the time changes. When 
you track time in this way, the second bar on the graph is always the current 
time. When you uncheck the box, the bars do not move, but you can still use 
the Time Indicator to determine the current time on the graph.

• Bar Graph > Set Time - This option is enabled only while in Historical mode. 
Selecting this causes the Set Time dialog box to open. You can select the day 
and time for which you would like to view the historical data.

• Bar Graph > Model Program Rate > Specify - You must select View > Model 
Program Rate to see the Model Program Rate line (a dashed white line) on the 
Bar Graph. If the ADL AAR displays on the graph, the dashed line (for 
modeling) is hidden behind the solid white ADL line. You can adjust the 
Model Program Rate by:

-   Selecting Bar Graph > Model Program Rate > Specify. This option displays the 
Specify Model Program Rate window. Fill in the necessary information and the 
new Program Rate displays on the graph. See Chapter 7: Evaluating Airport and 
Airspace Conditions for more information on changing the Program Rate.

-   Dragging the white line in the graph to the desired Program Rate. The dashed 
line moves to the Program Rate specified. Only the portion of the line to the 
right of the cursor moves. Any portion of the line to the left of your cursor 
should remain in the same position as you drag the line to a new Program Rate.

• Bar Graph > Model Program Rate > Reset - Restores the Model Program Rate 
to its original value. The Model Program Rate no longer is displayed.

4. Display Menu - changes the data shown in the Bar Graph to show demand based 
on the following:

• Display > ETA - Estimated Time of Arrival (airport only)

• Display > BETA - Base Estimated Time of Arrival (airport only)

• Display > IGTA - Taxi - Initial Gate Time of Arrival (airport only)

• Display > OCTA - Original Controlled Time of Arrival

• Display > EAFT - Estimated Arrival Fix Time (airport only)

• Display > CTA - Controlled Time of Arrival

• Display > ENTRY - Estimated Element Entry Time (airspace only)

• Display > BENTRY - Based Element Entry Time (airspace only)
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• Display > OENTRY - Original Element Entry Time (airspace only)

To send a new AAR/ADR to TFMS, without issuing a TMI, use TFMS Tools > ADL AAR/
ADR > Modify AAR/ADR from the Control Panel and click Send.

5. Help Menu

• Help > Bar Graph - Opens the on-line help for the Bar Graph component.
Bar Graph Buttons

Figure 3 - 34: Bar Graph Buttons

There are eight buttons on the Bar Graph window:

• Save As - Saves the Bar Graph as a .jpg image in a directory that you specify.
• Print - Prints the Bar Graph that is currently on the screen.
• 15, 30, and 60 - Clicking the 15, 30, or 60 time-bin buttons displays bar graph capacity 

and demand information based on the time-bin value selected. The default time 
increment is 60-minutes

• Legend - Displays the color legend for the Bar Graph.
• Arrival Flow Rate - Displays the Arrival Flow Rate line on the Bar Graph.
• Cancellations - Displays cancelled flights on the Bar Graph.

Bar Graph Tab Options

The screen resolution determines the arrangement of the 8 default tabs in the Bar Graph. 
You have the option to color flights according to several variables available in FSM. The 
default tab setting colors flights according to their arrival Status; however FSM offers the 
flexibility to view flights according to different criteria. This allows for effective analysis 
of which flights make up the demand at a data set. Each of the 16 pre-defined color tabs of 
the Bar Graph window displays different information with a corresponding color scheme 
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and legend. The following table lists the default color settings for all 16 tabs (see Table 3-
4).

Table 3-4:  Bar Graph Coloring Tabs

Tab Option Bar Color Description
Status (Default View) Light Green Departing (No CTD)

Red Flight Active
Black Arrived
Brown Departing (EDCT Issued)
Dark Green Departing (Past EDT)
Yellow Ground Stopped
Cyan (optional) Cancelled
Blue (optional) Removed
Pink (optional) Priority
White (optional) Unassigned Slot
Orange Departing (CTD other 

Element)
Arrival/Departures Light Green Arriving

Blue Departing
Aircraft Category Light Green Turbo 

Red Jet
Black Propeller
Yellow Unknown

Aircraft Class Black Small
Light Green Large
Red Heavy
Yellow Super
White Unknown

Carrier Light Green Large
Red Heavy
Black Small
Yellow Unknown
Various Colors All Majors
Dark Gray Dynamic Top Carrier 1
Maroon Dynamic Top Carrier 2
Light Blue Dynamic Top Carrier 3
Sand Dynamic Top Carrier 4
White Single Airline (User 

input)
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AFIX Various Colors The Arrival Fixes 
associated with the 
monitored airport

DFIX Various Colors The Departure Fixes 
associated with the 
monitored airport

Exemption Black Flights excluded
Green Flights exempted
Red Flights not exempted

Users Blue Air Cargo
Magenta Carrier
Light Green General Aviation
Brown Military
Orange Air Taxi
Cyan Other
Red Unknown

Alarm Status Black Other flights (no alarm 
set)

Red Flight with alarm set
Centers Red All Centers
Distance Red Flights within the selected 

distance
Substitution Status Green Subbing flights

Red Non-subbing flights
CDM Participation Green Participant

Red Non-participant
Program Delay White Non controlled

Orange Controlled Other Element
Green 0-29 minutes
Blue 30-59 minutes
Cyan 60-89 minutes
Gray 90-119 minutes
Pink 120-149 minutes
Yellow 150-179 minutes
Maroon 180-209 minutes
Magenta 210-239 minutes
Red More than 240 minutes

Table 3-4:  (Continued)Bar Graph Coloring Tabs

Tab Option Bar Color Description
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Color Schemes Selection Component

You can control which tabs are displayed in the Bar Graph by using the new Color 
Schemes Selection component accessible from the Bar Graph's View menu. Select View > 
Set Tabs Displayed. You can dynamically show and hide specific coloring schemes for a 
single component. The Color Schemes Selection component displays currently selected 
color schemes when initially opened.

Figure 3 - 35: Color Schemes Selection Component

If the current tab is hidden, the default tab is the Status tab since it cannot be hidden. You 
can also set a group of coloring schemes as a user preference.

Control Type Orange Controlled by another 
Element

Purple Bridge
Pink GAAP
Green Not Controlled
Dark Green FAA
Red Flight Active
Yellow Ground Stop (GS)
Brown Program (GDP, AFP, etc.)
Light Blue NAS User (SUB)
Black Arrived
Cyan Cancelled

Table 3-4:  (Continued)Bar Graph Coloring Tabs

Tab Option Bar Color Description
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The Color Schemes Selection component has both an All and Default checkbox. Selecting 
All selects all color scheme checkboxes, with the exception of the Status and Default 
checkboxes. You can deselect all coloring schemes by removing the check from the All 
checkbox. This is similar to how the All checkbox works on the Status legend.

When the color schemes displayed are the same as the FSM configuration default, the 
Default checkbox is selected. Selecting Default resets the selections to the FSM 
configuration default display. This is similar to how the Default checkbox works on the 
Status legend.

Note: You cannot deselect the Status checkbox.

The Color Scheme Selection component has the following buttons:
• Set Global Preference
• OK
• Cancel

Clicking Set Global Preference displays an FSM information dialog that says, “Global 
preference set to [<List of coloring schemes separated by commas>]. These changes will 
not take effect until OK is clicked in the Color Scheme Selection window.” and has a 
Continue button. Clicking Continue closes the dialog and returns you to the Color 
Scheme Selection component. If you set a Global Preference, FSM updates all Bar Graph, 
and GDT Bar Graph components opened in the future with the selected coloring schemes. 
FSM retains Global color scheme preferences when you save an adaptation.

Note: Airspace data sets cannot be saved to adaptation files at this time.

Clicking OK closes the Color Schemes Selection component and changes the associated 
coloring scheme display. If you make a local change (you did not make a Global Change), 
FSM updates the current Bar Graph window. 

Clicking Cancel closes the Color Schemes Selection component and cancels any actions 
performed in this dialog. 

All changes to Bar Graph are displayed in the following modes:

• Live
• GDT
• Historical
• GDT Historical

AFIX and DFIX Coloring and Order

The Afix and Dfix tabs for the Bar Graph now include a way for you to configure the 
order and color of fixes. You can now change the order of fixes and select a color for each 
Afix and Dfix from the Afix and Dfix Legends. 

The Fix Order component gives you the ability to change the order of how the fixes are 
displayed. Clicking Fix Configuration on the Legend for the Afix or Dfix tab causes the 
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Fix Order component to open. The fix order defaults to the ordering of the fixes as 
specified in the ADL. 

Figure 3 - 36: Fix Order Component

The Fix Order component has a list box displaying the order of the fixes from top to 
bottom. The fixes are listed by name and color. Each fix has a down arrow. You use the 
down arrow to select a color. Clicking the down arrow next to a fix name causes a 
dropdown box with 20 colors listed to open. Select the color you want for the fix from the 
list. If you want to reorder the fixes, select the fix name from the list in the Fix Order box 
and click Up to move it toward the top of the list and Down to move it toward the bottom 
of the list.

Clicking Cancel closes the Fix Order component and cancels any actions performed in 
this dialog.

Clicking Default resets the fix values to their ADL order and default color.

Clicking OK closes the Fix Order component and applies all changes made in the dialog 
box. 

Note: The color and ordering you selected apply only to the selected 
element (Bar Graph you are currently working with).

Additionally, right-clicking a fix in the legend opens a pop-up box with 20 colors listed. 
Selecting a color from the pop-up box allocates the selected color for that fix. 
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Figure 3 - 37: Bar Graph with Right-click Color Menu

You can assign the same color to multiple Afixes or Dfixes.

You can save and recall the configurations for Afixes and Dfixes through user adaptations. 
At times, FSM cannot recall an adaptation because a fix might have changed its name, 
new fixes were added, or old fixes were removed. If that is the case, FSM reverts to 
automatically assigning the coloring.

You can configure Afixes and Dfixes on the following Bar Graph components: 

• Live Bar Graph
• GDT Bar Graph
• Historical Bar Graph
• GDT Historical Bar Graph

Time Line Component
The Time Line component is a timetable that displays airport, FEA, or FCA demand in 
one-minute hash marked increments in the hour columns (see Figure 3 - 38). The number 
of hours displayed is based on the size of your Time Line component. You can change the 
number of hours viewed on the screen at one time by dragging the edge of the window in 
or out to increase/decrease the window size. You can also use the scroll bar to scroll 
forward or backwards in time. You can resize the CNX & DO Flts (cancelled and drop out 
flights) column as well.

For Airport data sets, flights are displayed on the Time Line based on their ETA. For 
Airspace data sets, flights are displayed on the Time Line based on their ENTRY time into 
the FEA or FCA. 
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The large numbers at the top of each column represent the date/hour (e.g., 27/1600 
indicates that this display is for the 1600 hour for the 27th day of the month). Directly 
below the date/hour information is the AAR and/or ADR versus the demand (the number 
of flights projected to arrive) at the airport, FEA or FCA for the hour shown. For example, 
70/65 at the top of a column indicates that the AAR is 70 for that hour and 65 flights are 
expected to arrive within that hour. The ADR versus demand displays in parentheses when 
FSM displays departure data. For example, (60/40) indicates that 60 flights can depart the 
airport in that hour, but only 40 are projected to depart. The last data update time is 
highlighted in orange.
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Figure 3 - 38: Time Line Component 

In Monitor Live mode only, if there is an 11-minute gap between the ADL update time and 
your local machine time, the ADL Date and Time will turn red until the next update is 
received. Note that the components will remain active even though the data has expired.
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Figure 3 - 39: Red Text Warns that ADL Update Time is Behind

From the Time Line, you can view flights arriving and departing from a monitored airport. 
For Airspace data sets, only arrival data is available. In addition, open arrival slots, 
Unassigned Slots, cancellations, and drop outs can be viewed on the Time Line. The 
airport, FEA, or FCA, date, last ADL time, data mode, and UDG name (if applicable) are 
displayed in the Time Line title bar. The Time Line displays the Airport, FEA, or FCA 
being monitored, the date, the time, and the data display indicator directly above the color 
tabs.

Each flight arriving at the monitored airport or entering into the FEA, or FCA displays to 
the right of the minute hash marks, which correspond to the ETA or ENTRY of the flight, 
which ever is applicable. When you place your cursor over a flight, a pop-up window 
displays the flight’s ACID, Departure airport, arrival airport, ETD, and ETA (for airports) 
or ENTRY (for FEAs and FCAs) (see Figure 3 - 40).

Figure 3 - 40: Pop-up Flight information

Viewing Time Line Flight Information

Right-clicking a flight icon gives you five additional options for that flight: Flight Info, 
Flight Detail, EDCT Check, EDCT Update, and ECR.

• Selecting Flight Info displays the Flight Info component, which contains general ADL 
information for a flight including ACID, status, origin airport, destination airport, 
ETD, ENTRY, EXIT, ETA, ETE, Control Element, CTD, CTA, Delay Flags, Cancel 
Flags, and Drop Out information when applicable.

• Selecting Flight Detail displays more detailed flight information. The Flight Detail 
window contains all the ADL information for that flight.

• Selecting EDCT Check opens the EDCT Check dialog box giving ATCSCC specialists 
the ability to send a message to the Hubsite requesting the flight’s EDCT time. 

• Selecting EDCT Update opens the EDCT Command Line dialog box, which allows 
ATCSCC specialists to send an EDCT update request to the Hubsite.
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• Selecting the ECR option opens the ECR component for the selected flight. Opening 
ECR in this manner automatically fills the ACID, ORIG, and flight information into 
the ECR component for the flight.

Note: EDCT Check and EDCT Update are ATCSCC only options.

FSM displays cancelled flights and drop out flights under the CNX & DO Flts column. 
These flights have the same hover and right-click capabilities as all other flights. FSM 
keeps and displays flight data compiled by TPC, which includes data for up to 34 hours 
after the current time.

You can also access flight lists and flight counts (see Figure 3 - 41) from the Time Line 
component. For more information on viewing flight information in the Time Line, see 
Chapter 6: Viewing Flight Information.

Figure 3 - 41: Flight Count

Icons in the Time Line

• Airplane Icons represent flights arriving at or departing from the monitored airport, 
FEA, or FCA. Arriving flights face left while departing flights face right. Clicking an 
arrival flight icon highlights the flight by putting a yellow square around the icon. If 
the flight is delayed, the open arrival slot that resulted from its delay is also 
highlighted.

• A filled square icon displays only when a Program is in effect. The filled square 
represents an arrival slot left open by a cancelled flight. The arrival slot is open and 
available for use by other flights. Cancelled flights are displayed on the Time Line 
under the CNX heading, colored cyan, and are highlighted when you select their 
associated slot.

• An empty square icon also corresponds to a cancelled flight. However, this arrival slot 
is not associated with a Program. Clicking this icon highlights its associated cancelled 
flight, displayed under CNX in the Time Line.
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• A filled triangle icon displays only when a Program is in effect. The filled triangle 
indicates an open arrival slot due to a delayed flight. Clicking this icon also highlights 
the delayed flight associated with the open slot.

• An empty triangle icon also corresponds to a delayed flight. However, this arrival slot 
is not included within the Program. Clicking this icon also highlights the associated 
delayed flight.

• A white diamond represents an Unassigned Slot. No right- or left-click capabilities 
exist for this icon. It is simply a place holder during a GDP or AFP with GAAP until 
filled by a pop-up flight.

Note: You can find an explanation for any of the Time Line icons by 
selecting Help > Legend in the FSM Control Panel component.

Table 3-5:  Time Line Icons

Time Line Icon Description
Indicates the latest or current ADL file data update 
time in the Time Line component.

A flight arriving at the monitored airport by ETA 
(airport) or ENTRY (airspace) in the Time Line 
component and colored by the current color 
scheme.
A flight departed from the monitored airport by 
ETD in the Time Line component and colored by 
the current color scheme.
An open slot due to a cancelled flight, which is 
included in a GDP or AFP. It is positioned at its 
arrival slot time and colored by carrier.
An open slot due to a cancelled flight, which is not 
included in a GDP or AFP. It is positioned at its 
(IGTA-taxi) and colored by carrier.
An open slot due to a delayed flight that is included 
in the GDP or AFP. It is positioned at its arrival slot 
time and colored by carrier. The corresponding 
flight is positioned at a later time matching the 
ETA.
An open slot due to a delayed flight that is not 
included in the GDP or AFP. It is positioned at its 
(IGTA - taxi) and colored by carrier. The 
corresponding flight is positioned at a later time 
matching the ETA
An unassigned slot. These are displayed in the 
Monitored Live mode, Historical mode, and GDT 
mode time lines for GAAP GDPs.
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Time Line Buttons

There are three buttons on the Time Line window:

• Save - Saves the Time Line as a .jpg image in a directory that you specify.
• Print - Prints the Time Line that is currently on the screen.
• Legend - Displays the color legend for the Time Line.

Figure 3 - 42: Time Line Buttons

Time Line Menu Bar

The menu bar in the FSM Time Line component contains four options: File, View, Time 
Line, and Help.

1. File Menu

• File > Save As - Saves the Time Line as a .jpg image in a directory that you 
specify.

• File > Print - Prints the Time Line that is currently on the screen.

• File > Close Group - Closes all the components associated with the open 
component. This function removes the data set button from the Control Panel 
for the selected data set.

• File > Close - Closes the Time Line component for that particular airport, FEA, 
or FCA.

2. View Menu

• View > Rename Window - Displays the Rename Window dialog box and allows 
you to change the component name in the title bar. Enter the desired name then 
click OK to change the title bar heading. Click Cancel to close the Rename 
Window dialog box without making any changes.

Figure 3 - 43: Rename Window
There are ten additional display options under the View menu. For items with 
checkboxes, select the checkbox to view the information.

• View > Set Tabs Displayed - You can dynamically show and hide specific 
coloring schemes for the Time Line component.
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• View > Arrival Data - Displays all arrival data for that data set.

• View > Departure Data - Displays all departure data for that airport.

• View > Show CNX/DO - Displays all cancelled and drop out flights under the 
column marked CNX, to the right of the active flight information.

• View > Show Legend - Displays the appropriate color legend associated with 
the current view. If you click the legend button on the Time Line, FSM 
dynamically selects the checkbox for Show Legend.

• View > Open Slots in Carrier Color - Displays all open slots due to cancelled or 
delayed flights in the associated carriers color.

• View > Show Unassigned Slots - Displays all unassigned slots during a GAAP 
GDP or AFP.

• View > Auto Icons - Displays flights in the TSD icon format. This is the default 
Time Line view. The TSD format displays different icons based on the flight 
aircraft weight. When you select Auto Icons, the same icon is used to represent 
all aircraft weights).

• View > Flight Info - Displays the Flight Info window for a quick reference on 
the flight.

• View > Flight Detail - Displays the Flight Detail window for more in-depth 
information on the flight.

• View > Flight List - Displays the FSM Flight List.

Note: View > Arrival Data, Show CNX/DO, Open Slots in Carrier Color, 
Show Unassigned Slots, and Auto Icons checkboxes are selected 
by default.

3. Time Line Menu

Table 3-6:  Auto Icons

Auto Icon 
Enabled

Auto Icon 
Disabled

Description

Jumbo

Jet

Heavy

Prop (Includes Turbo and Piston)
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• Time Line > Track Time - Allows you to turn Track Time on and off. To force 
the Time Line component to update when the current hour changes, select 
Track Time. When the hour changes, the Time Line moves forward one hour. If 
you uncheck the Track Time box, you can scroll forward or back in time and at 
the next update time the Time Line does not return to the current time.

• Time Line > Set Time - This option is enabled only under Historical Data Mode 
and allows you to choose the time to view within a set of historical data.

• Time Line > Search By Callsign - Allows you to find a particular flight by 
entering the flight’s callsign and origin airport. The flight icon in the Time Line 
is highlighted with a white box.

Figure 3 - 44: Search By Call Sign

4. Display Menu

• Display > ETA - Display flights based on their Estimated Time of Arrival 
(ETA).

• Display > BETA - Displays flights based on their Base Estimated Time of 
Arrival (BETA). The BETA matches the ETA and is frozen when the flight 
becomes active or when the flight becomes controlled. 

• Display > IGTA - taxi - Displays flights based on their Initial Gate Time of 
Arrival (IGTA) minus taxi time (IGTA Wheel Time). The IGTA is based on the 
OAG times or flight plan times and never changes. Taxi time default is 10 
minutes, but you can change it in the GDT Control window.

• Display > OCTA - Displays flights based on their Original Controlled Times of 
Arrival (OCTA), Original ETA, OGTA Wheel Time, or ETA position, 
depending on the available information. For example, if the Original CTA is 
not available, FSM uses Original ETA and so on. This time never changes.

• Display > EAFT - Displays flights based on their Estimated Arrival Fix Time 
(EAFT), which is the time at which the flight crosses its designated arrival fix.

• Display > CTA - Displays flights based on their current Controlled Time of 
Arrival (CTA).

• Display > ENTRY - Displays flights based on their current Estimated Element 
Entry Time (Airspace data set only)

• Display > BENTRY - Displays flights based on their current Based Element 
Entry Time (Airspace data set only)
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• Display > OENTRY - Displays flights based on their current Original Element 
Entry Time (Airspace data set only)

5. Help Menu

• Help > Time Line - Opens the on-line help for the Time Line component.

• Help > Legend - Opens the on-line help for the Time Line icon legend. 
Time Line Color Tab Options

The eight default tabs are arranged in the Time Line based on the screen resolution. The 
following picture is based on Windows default settings.

Figure 3 - 45: Time Line Coloring Tabs

The default value colors the flights according to their arrival Status. FSM gives you the 
flexibility to view flights according to different criteria. This allows for effective analysis 
to determine which flights make up the demand at an airport, FEA, or FCA. There are 16 
pre-defined color tabs in the Time Line component. Each color tab option displays 
different information with a corresponding color scheme and legend.

Table 3-7:  Color Tab Options

Tab Option Color Display Options
Status (Default View): Priority, Removed, Ground Stopped, Dep (Past ETD), Dep (No 

CTD), Dep (CTD Issued), Dep (CTD Other Element), Flight 
Active, and Arrived

Arr/Dep Status: Arriving and Departing Flights (Not applicable to FEAs and 
FCAs)

Aircraft Category Propeller, Turbo, Jet, and Unknown
Aircraft Class Small, Large, Heavy, Super, and Unknown
Carrier Static list of predominant carriers and single carriers as specified 

by the user.
Afix Color by arrival fix for that airport (Not applicable to FEAs and 

FCAs)
Dfix Color by departure fix for that airport (Not applicable to FEAs 

and FCAs)
User Air Cargo, Carrier, G/A, Military, Air Taxi, Other, and Unknown
Exemption Flights excluded, exempted, and not exempted
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Color Schemes Selection Component

You can control which tabs are displayed in the Time Line by using the new Color 
Schemes Selection component accessible from the Time Line's View menu. Select View > 
Set Tabs Displayed. You can dynamically show and hide specific coloring schemes for a 
single component. The Color Schemes Selection component displays currently selected 
color schemes when initially opened.

User All, Freight/Cargo Carrier, Carrier, G/A, Military, Air Taxi, 
Other, and Unknown

Alarm Status Flights with alarm set, Other flights
Centers ZAB, ZAU, ZBW, ZDC, ZDV, ZFW, ZHU, ZID, ZJX, ZKC, 

ZLA, ZLC, ZMA, ZME, ZMP, ZNY, ZOA, ZOB, ZSE, ZTL, 
ZZZ and manual input. 
Note: Center options may change for Canadian airports.

Distance <200, <400, <600, <800, <1000, <1200, <1400, <1600, <1800, 
<2000, <2200, <2400, >=2400

Substitution Status Subbing Flights, Non-Subbing Flights
CDM Participation Participant, Non-participant
Program Delay Not Controlled, Controlled Other Element, 0-29 Minutes, 30-59 

Minutes, 60-89 Minutes, 90-119 Minutes, 120-149 Minutes, 
150-179 Minutes, 180-209 Minutes, 210-239 Minutes, More 
than 240 Minutes

Control Types Program (GDP/GS/AFP), TFMS, GAAP, FAA, NAS User, 
Bridge, Not Controlled, Flight Active, Arrived

Table 3-7:  (Continued)Color Tab Options

Tab Option Color Display Options
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Figure 3 - 46: Color Schemes Selection Component

If the current tab is hidden, the default tab is the Status tab since it cannot be hidden. You 
can also set a group of coloring schemes as a user preference.

The Color Schemes Selection component has both an All and Default checkbox. Selecting 
All selects all color scheme checkboxes, with the exception of the Status and Default 
checkboxes. You can deselect all coloring schemes by removing the check from the All 
checkbox. This is similar to how the All checkbox works on the Status legend.

When the color schemes displayed are the same as the FSM configuration default, the 
Default checkbox is selected. Selecting Default resets the selections to the FSM 
configuration default display. This is similar to how the Default checkbox works on the 
Status legend.

Note: You cannot deselect the Status checkbox.

The Color Scheme Selection component has the following buttons:
• Set Global Preference
• OK
• Cancel

Clicking Set Global Preference displays an FSM information dialog that says, “Global 
preference set to [<List of coloring schemes separated by commas>]. These changes will 
not take effect until OK is clicked in the Color Scheme Selection window.” and has a 
Continue button. Clicking Continue closes the dialog and returns you to the Color 
Scheme Selection component. If you set a Global Preference, FSM updates all Time Line, 
and GDT Time Line components opened in the future with the selected coloring schemes. 
FSM retains Global color scheme preferences when you save an adaptation.

Note: Airspace data sets cannot be saved to adaptation files at this time.
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Clicking OK closes the Color Schemes Selection component and changes the associated 
coloring scheme displays. If you make a local change (you did not make a Global 
Change), FSM updates the current Time Line window. 

Clicking Cancel closes the Color Schemes Selection component and cancels any actions 
performed in this dialog. 

All changes to Time Line are displayed in the following modes:

• Live
• GDT
• Historical
• GDT Historical

AFIX and DFIX Coloring and Order

The Afix and Dfix tabs for the Time Line now include a way for you to configure the order 
and color of fixes. You can now change the order of fixes and select a color for each Afix 
and Dfix from the Afix and Dfix Legends. 

The Fix Order component lets you change the order of how the fixes are displayed. 
Clicking Fix Configuration on the Legend for the Afix or Dfix tab causes the Fix Order 
component to open. The fix order defaults to the ordering of the fixes as specified in the 
ADL. 

Figure 3 - 47: Fix Order Component

The Fix Order component has a list box displaying the order of the fixes from top to 
bottom. The fixes are listed by name and color. Each fix has a down arrow. You use the 
down arrow to select a color. Clicking the down arrow next to a fix name opens a 
dropdown box listing 20 colors. Select the color you want for the fix from the list. If you 
want to reorder the fixes, select the fix name from the list in the Fix Order box and click 
Up to move it toward the top of the list and Down to move it toward the bottom of the list.

Clicking Cancel closes the Fix Order component and cancels any actions performed in 
this dialog.
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Clicking Default resets the fix values to their ADL order and default color.

Clicking OK closes the Fix Order component and applies all changes made in the dialog 
box. 

Note: The color and ordering you selected apply only to the selected 
element (Time Line you are currently working with).

Additionally, right-clicking a fix in the legend opens a pop-up box with 20 colors listed. 
Selecting a color from the pop-up box allocates the selected color for that fix. 

Figure 3 - 48: Time Line with Right-click Color Menu

You can assign the same color to multiple Afixes or Dfixes.

You can save and recall the configurations for Afixes and Dfixes through user adaptations. 
At times, FSM cannot recall an adaptation because a fix might have changed its name, 
new fixes were added, or old fixes were removed. If that is the case, FSM reverts to 
automatically assigning the coloring.

You can configure Afixes and Dfixes on the following Time Line components: 

• Live Time Line
• GDT Time Line
• Historical Time Line
• GDT Historical Time Line
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Element Display Component
The Element Display component allows users to view the characteristics that make up an 
FEA or FCA. It is a static display of the FEA or FCA’s parameters, that includes general 
information about the FEA or FCA and the primary filters used to include flights in the 
element. FSM is limited to displaying FEA or FCA information that TFMS sends through 
a Broadcast message (see Figure 3 - 49).

Figure 3 - 49: Element Display Component

Data displayed in the Element Display component

• Name - Name of Element
• Type - FEA or FCA
• Domain - Public, Private, Local, or Shared
• Sites Shared - Information that was manually entered by the TSD user.
• Reason - Reason entered for FEA/FCA
• Start/End Time - the Start and End times of the FEA/FCA [ddhhmm-ddhhmm] format
• Type - Line, Polygon, Circle, or NAS
• Floor/Ceiling - The minimum and maximum range for the FEA/FCA
• Direction - The Heading feature in TSD
• Speed - Not supported by FSM at this time
• Filters - Only primary filters are displayed

Note: Floor/Ceiling, Direction, and Speed fields are only applicable for 
Line, Circle, or Polygon.
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Accessing the Element Display component

You can access the Element Display component from two components.

1. Open Data Set

2. Control Panel
Open Data Set

To view the definition of any FSM eligible FEA or FCA from the Open Data Set, select 
the FEA/FCA from the Monitored Live or All Live tab and click View Element from the 
bottom right-hand corner. The element Display component opens for the selected FEA/
FCA.
Control Panel

If you are already monitoring an FEA/FCA, right-click the control element’s shortcut 
button located on the Control Panel. Selecting Open Element Display opens up the 
Element Display component for the selected FEA/FCA (see Figure 3 - 50).

Figure 3 - 50: Open Element Display from Shortcut Button

Note: FEA/FCA parameters can only be created, edited, or deleted 
through Traffic Situation Display (TSD).

Element Display Menu Bar

The Menu Bar in the Element Display component contains two options: File and Help.

1. File Menu

• File > Save As - Saves the Element Display as a .jpg image in a directory that 
you specify.

• File > Print - Prints the Element Display that is currently on the screen.

• File > Close - Closes the Element Display component for that particular airport, 
FEA, or FCA
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2. Help Menu

• Help > Time Line - Opens the on-line help for the Element Display component

Ground Delay Tools Components
Ground Delay Tools (GDT) Components aid users in looking at various operational or 
traffic scenarios. You can use modeling tools to analyze existing operations and previous 
days’ events. The actual running and issuing of Traffic Management Initiatives (TMIs) is 
not covered in this section. This section familiarizes you with all the GDT components:

• GDT Setup
• GDT Map
• GDT Bar Graph
• GDT Data Graph
• GDT Time Line (Optional)
• Demand by Center (Optional)
• GDT Coversheet & Advisory

You can open any monitored airport or FCA in Ground Delay Tools mode by selecting a 
monitored data set and then clicking GDT Mode on the Control Panel component. There 
are four default GDT components that open for the selected data set (see Figure 3 - 51). 
The GDT Setup and GDP Map component are interactive; any change in one dynamically 
reflects in the other component. Other GDT components reflect changes made to the GDT 
Setup and Map when you model the TMI. Adaptive Compression status displays on the 
GDT Setup Component in the SUBS indicator section.

Note: All GDT components are labeled GDT in the component title 
bar.
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Figure 3 - 51: GDT Default Components

GDT Setup Component
You use the GDT Setup component to issue and send TMIs. The GDT Setup component 
consists of a menu bar, six action buttons, Program Type selection box, SUBS Indicator, 
and three tabs that focus on different areas of information (see Figure 3 - 52). You must 
select the type of TMI you want to issue from the Program Type selection box:

1. GDP - DAS - The default Program Type for airports. This program runs the Ration 
By Schedule Algorithm plus Compression. Not available for FCAs.

2. GDP - GAAP - This program type is similar to GDP-DAS except it automatically 
sets the Delay Assignment Mode to GAAP.

3. GDP - UDP - This program type addresses the mix of scheduled and unscheduled 
(i.e., pop-ups) demand based on the following parameters: number of reserved 
pop-ups , target delay multiplier, and delay limit. 

4. Compress Flights - This program decreases delay on flights involved in an existing 
GDP or AFP. If there are a number of slots for cancelled flights in the stack hours, 
you can use compression to move these flights to a later slot without needing to 
extend the GDP or AFP.
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5. Compress Slots - This program adjusts the Unassigned Slots in the GAAP program 
without reallocating EDCTs to flights currently arriving.

6. Ground Stop - Unlike ground delay programs, which delay flights because of a 
reduced AAR, the Ground Stop function prevents flights from departing until 
further notice. Not available for FCAs.

7. Blanket - Run this program type to revise any ground delay operation. This option 
adds or subtracts a fixed number of minutes to or from FAA-imposed delay. You 
should not use Blanket in conjunction with a GS. Not available for FCAs.

8. Airborne Holding - Used by traffic management specialists to determine the 
necessity of a GDP. In certain situations, putting delay on flights en route may be a 
better option than delaying flights on the ground. The airborne holding algorithm 
in FSM produces the amount of expected airborne holding delay, defined as 
[ASLOT - ETA] that would result from running a program. Not available for 
FCAs.

9. Purge - Cancels a GDP or GS, releasing all delay on included flights. This program 
type requires no entry on any tab option.

10. AFP - DAS - Airspace Flow Program available only for airspace data sets. This 
program is used to control traffic flow through an FCA.

11. AFP - GAAP - Airspace Flow Program available only for airspace data sets. This 
program type automatically sets the Delay Assignment Mode to GAAP.

12. AFP - UDP - Airspace Flow Program available only for airspace data sets. This 
program type addresses the mix of scheduled and unscheduled (i.e., pop-ups) 
demand based on the following parameters: number of reserved pop-ups , target 
delay multiplier, and delay limit.

The GDT Setup component tab options and features change based on the Program Type 
selection. The three GDT Setup tabs are Parameters (default selection), Scope, and 
Modeling Options.

This section discusses the Setup Panel based on each tab option. Closing the GDT Setup 
component closes all the GDT components for the data set. The GDT Setup panel displays 
the substitution status and adaptive compression for the data set: SUBS: ALL ON, ALL 
OFF, SCS OFF/ADPT ON, SCS ON/ADPT OFF, SCS OFF/ADPT OFF, or ALL OFF.

Note: The Program Type Purge is not mentioned in any of the tab 
panels, since Purge requires no parameter modifications.
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Figure 3 - 52: GDT Setup Component

GDT Setup Panel Menu Bar

The menu bar in the GDT Setup component contains three options: File, View, and Help.

1. File Menu

• File > Load Proposed Parameters - Opens a secondary dropdown menu to 
select from specific parameter options:

-   > Airspace Flow Program - Loads the proposed AFP parameters.

-   > Ground Delay Program - Loads the proposed GDP parameters.
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-   > Ground Stop - Loads the proposed Ground Stop parameters.

-   > Blanket - Loads the proposed Blanket parameters.

-   > Compression - Loads the proposed Compression parameters.

• File > Load Actual Parameters - Opens a secondary dropdown menu to select 
from specific parameter options:

-   > Airspace Flow Program - Loads the actual AFP parameters.

-   > Ground Delay Program - Loads the actual GDP parameters.

-   > Ground Stop - Loads the actual Ground Stop parameters.

-   > Blanket - Loads the actual Blanket parameters.

-   > Compression - Loads the actual Compression parameters.

• File > Open Coversheet - Opens the Coversheet file explorer that contains all 
the Coversheet files. Select the coversheet you want to open and click Open. 
All coversheet files are named covr.xxx, where xxx is the airport three-letter 
identifier. The file names also include the Date and ADL time followed by the 
type of coversheet (GS, GDP, or CNX).

• Open IPM Mode Instance - Opens the Integrated Program Modeling (IPM) 
Mode with the GDT Setup’s element and its parameters copied to Scenario 1 in 
the Scenario Manager. This option only is enabled for IPM-supported program 
types. 

• File > Open Parameters File - Opens the PARAM_DIRECTORY File in file 
explorer. Select the parameters file and click Open to view the Parameters 
Files.

• File > Save As - Saves the GDT Setup component as a .jpg image to a directory 
of your choice.

• File > Close - Closes the Setup component and all the complimentary GDT 
components for that particular airport.

2. View Menu

• View > Rename Window - Displays the Rename Window dialog box and allows 
you to change the component name in the title bar. Enter the desired name then 
click OK to change the title bar heading. Click Cancel to close the Rename 
Window dialog box without making any changes.
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Figure 3 - 53: Rename Window Dialog Box
There are six additional display options under the View menu. If you close a 
component and want to reopen it, use the View menu options to select and reopen 
the desired component.

• View > GDT Data Graph - Displays the Data Graph component

• View > GDT Map - Displays the GDT Map component

• View > GDT Bar Graph - Displays the GDT Bar Graph component

• View > GDT Time Line - Displays the GDT Time Line component

• View > GDT Flight List - Displays the Flight List for the monitored airport, 
FEA, or FCA. The default Flight List includes ACID, DEST (Airspace data 
sets only), ETD, ENTRY (Airspace data sets only), ETA (Airport data sets 
only), CTD,CTA, CTL_ELEM (Airspace data sets only), ORIG, DCENTR, 
CYTL_TYPE (Airport data sets only), and ACENTR data elements.

• View > Show Demand - Displays the Demand by Center component.

3. Help Menu

• Help > GDT Setup - Opens the on-line help for the GDT Setup component.
GDT Setup Panel Buttons

The eight action buttons are Save (the button with the disk icon), GDT Map, Reload, 
Model, Run Proposed, Run Actual, SUB OFF, and Reset Parameters. These buttons 
are active when the feature is available.

• Clicking the Save button saves the GDT Setup component as a .jpg image to a 
directory of your choice.

• Clicking GDT Map opens the GDT Map.
• Clicking Reload causes FSM to load the latest ADL data into the GDT mode. You 

then can model the program using the latest data and make any adjustments you think 
are necessary.

• Clicking Model models and reflects your changes in all GDT components for analysis 
and review. After you make any modification to any portion of the GDT Setup 
component, which FSM indicates by highlighting the tab window area with a red 
border, the Model button becomes active. After clicking Model, your GDT Setup 
component also resets and the red border no longer is displayed until you make an 
additional change.
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• Clicking Run Proposed displays the Proposed coversheet, which then gives you the 
option to send a proposed Advisory or Autosend this initiative to TFMS.

• Clicking Run Actual displays the Actual coversheet, which then gives you the option 
to send an actual Advisory or Autosend this initiative to TFMS.

• Clicking SUB OFF turns off subbing for the TMI.
• Clicking Reset Parameters loads the most current ADL, clears any Impact elements 

of the modeled data, and returns the GDT settings to their defaults.
Parameters Tab

The Parameters Tab is active for all program types and is the default tab that opens when 
you open the GDT Setup component. Within this tab you can specify parameters including 
the program time, program rate, and general options for GAAP delay, Blanket delay, and 
Purge notifications. Options which are not features for certain program types are disabled.

You can edit Start and End time parameters in the Program Time Options section for all 
program types. 

• Start - Enter the date and time when the TMI should begin.
• End - Enter the date and time when the TMI should end.

The default End time for Ground Stops will adjust to 15 minute increments on the hour 
(00, 15, 30, and 45). All other programs will have a default end time on the 14, 29, 44, or 
59th minutes. The End time for Ground Stops will be a time increment that results in at 
least a one hour GS. For example, if the Ground Stop Start time is 1902, the default End 
time will be 2015. 

If you are using the slider to select the End time for a Ground Stop, the slider will adjust to 
15 minute increments on the hour. Using the slider to adjust the End time for all other 
programs will result in an End time on the 14th, 29th, 44th, and 59th minutes.You can 
populate the times in the text box to the right of the time field or use the slide bars, which 
automatically fill the time into the text box. 

The Purge Flights section of the GDT Setup component contains two checkboxes that 
allow you to purge flights before a revision start time and after a revision end time as 
appropriate for AFP/GDP revisions.

• Before Revision Start - This checkbox allows you to specify if control times should be 
purged off of flights between the revision start time and the cumulative start time. 
Before Revision Start is disabled if a GDP or AFP does not exist for a current data set, 
whether Blanket, Compression, and or GS on top of the GDP. The purge Before 
Revision Start is enabled only when the selected GDP/AFP start time is later than the 
existing program’s Cumulative Start Time. This option is dynamically enabled and 
disabled with the mouse release action on the slider bar.

Note: FSM will reset the Cumulative Start Time to the new (later) start 
time and determine which flights are no longer controlled due to 
the change.
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• After Revision End - This checkbox allows you to specify if control times should be 
purged off of the flights between the revision end time and the cumulative end time. 
After Revision End is disabled if a GDP or an AFP does not exist for the current data 
set, including Blanket, Compression, and or GS on top of the GDP. The purge After 
Revision End is enabled when the selected GDP/AFP end time is earlier than the 
existing program’s Cumulative End Time. This option is dynamically enabled and 
disabled with the mouse release action on the slider bar.

Note: FSM will reset the Cumulative End Time to the new (earlier) end 
time and determine which flights are no longer controlled due to 
the change.

• Compress to Last CTA - This functionality is available during an AFP (initial and 
revision), GDP (initial and revision), and Compression. When checked, all flights that 
have control times are eligible for compression. When unchecked, only flights with 
CTAs through the End time of the program are compressed.

• Data Time - This functionality is the ADL time on which you are modeling and 
analyzing your TMI. Set the time you want to use as the current time. You can set this 
time forward or back without changing the data. If you change the Data Time, a 
warning box displays letting you know the “Data Time changed from default,” and the 
time is highlighted in red. Changing the Data Time back to the default ADL time puts 
the Data text field back to normal. You cannot edit Data Time for an Airborne Holding 
program.

Note: The default ADL time always displays in the GDT Setup Title 
bar.

The Program Rate section is active for all Program Types except Compression, Ground 
Stop, Blanket, and Purge. The Program Rate table is oriented horizontally so that the hours 
are displayed across the top of the table. The hours shown in the program rate table range 
from one hour prior to the current time to 35 hours ahead of the current time. To view the 
hours across the table, use the horizontal scroll bar directly below the table.

There are three rates that can be adjusted: the Program Rate, Pop-Up rate, and Reserve 
rate. Each rate is represented by a row and is an option in the Fill dropdown menu.
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Figure 3 - 54: GDT Setup - Program Rate Section

Select a rate type from the Fill dropdown menu and fill in the associated rates by entering 
a rate in the With box, using the From Hour and Through Hour to select the time frame, 
and clicking Fill. 

There are additional features in the Program Rate section of the Parameters tab that are 
not included in the Modify Program Rate component:

• Load Times - Click to fill the From Hour and Through Hour fields to match the 
times set in the Program Time Options section. If you click Fill after entering the 
Program Rate and hours, FSM automatically fills in the appropriate hour columns. 

• Pop-up row - This row is only available for a DAS program. It is disabled and 
populated with dashes for all other programs. The Pop-up Factor accounts for 
potential “pop-up” flights. For example, if you change the Program Rate for a certain 
number of hours to 40 with a Pop-up Factor of 5, the Program Rate that FSM uses to 
run the GDP or AFP is 35. This leaves room for any unknown flights that show up in 
that hour because the actual capacity of the airport is 40. 

Note: The pop-up rate affects the resulting demand in the hour that you 
defined the pop-up rate.

• Reserve slots row - This rate is only available for Unified Delay Programs (UDP), that 
is, GDP-UDP and AFP-UDP. It is disabled and populated with dashed for all other 
programs. You can manually enter values or use existing historical demand predictions 
found in the Load Historical Pop-Up window. Use this row to create unassigned slots 
created for anticipated pop-ups.

Note: When you enter a value in a given hour, any unassigned slot that 
is eventually created is not necessarily in that hour.

• Historical Pop-Ups - Click to open the Load Historical Pop-Up window where you 
can select specific historical demand predictions which will be used for the TMI. This 
window is similar to the view-only window accessed via Utilities > Historical Pop-up 
Demand (for more detailed information, see Chapter 5: Historical Pop-Up Demand). 
However, you can adjust the values utilized while still having the predictions visible 
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for reference. High, Medium, and Low represent confidence levels for the values as 
listed in the ADL. Note that predictions fewer than ten per hour may include a decimal 
value. Predictions greater than ten per hour are represented by whole numbers.

To set the Reserve rate in the Historical Pop-Up window:

1. From the Program Type dropdown list, select GDP-UDP. The Historical Pop-Up 
button and the Reserve row will become enabled.

2. Click Historical Pop-Up. The Load Historical Pop-Up window opens.

3. Select the High, Medium, or Low radio button.

4. Click Fill With. The cells in the Load With row will be populated with the 
historical values for the selected confidence level (see Figure 3 - 55). Note that the 
Fill With functionality is not available for FCAs.

5. Click OK. The window closes and the rates are displayed in the Program Rate’s 
Reserve row.

Note: Even though you used the Fill With functionality, you can 
manually edit specific hours in the Programs Rates table or the 
Load Historical Pop-Up window. Changes made to the Program 
Rates table will be reflected in the Historical Pop-Up dialog 
box; likewise, changes made in the Historical Pop-Up dialog 
box will be reflected in the Program Rates table.

Figure 3 - 55: Load Historical Pop-Up

The menu bar contains two options: File and Help.

1. File

• Print - Prints the Load Historical Pop-Up window as displayed on your screen

• Close - Closes the window

2. Help - Opens online help specific to the Load Historical Pop-Up window

The window contains the following action buttons:

• OK – Click to save your changes and close the dialog box
FSM User Guide, Version 9.00 3-69



Understanding Components
• Cancel – Click to close the dialog box without saving your changes
• Help – Click to display a pop-up window with a brief description of the component

To set the Pop-Up Factor for a program from the GDT Setup component.

1. Select the Parameters tab on the GDT Setup component.

2. Select Pop-Up Factor from the Fill dropdown.

Figure 3 - 56: Program Rate Pop-Up Factor

3. Enter the number of Pop-Up slots you want FSM to create in With.

4. Enter the hours for this Pop-Up Factor in From Hour and Through Hour.

5. Click Fill. FSM enters the Pop-Up Factor specified into the appropriate hours.

Figure 3 - 57: Pop-Up Factor Filled

6. Select the number in the Pop-Up Factor column. FSM enables the Edit 15 button.

7. Click Edit 15.
The 15 Minute Pop-Up Factor window displays.
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Figure 3 - 58: 15 Minute Pop-Up Factor

8. Enter the Pop-Up Factor you want for each 15 minute increment of the selected 
hour.

9. Click OK. The edited Pop-Up Factor is highlighted green.

Figure 3 - 59: Pop-Up Factor Edited in 15 Minute Increments

10. Once you have entered all of the parameters for the new TMI, modeled the 
program and clicked Run, the Pop-Up Factor displays under the Program Rate on 
the coversheet.
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Figure 3 - 60: Pop-Up Factor Displays Under Program Rate

General Options Section

You may set the following parameters within the General Options section of the 
Parameters tab (see Figure 3 - 61):

Note: The fields are available based on the Program Type you select. 
For more detailed information, see Chapter 2: Text Fields 
Display Conventions.

Figure 3 - 61: General Options Section
• Delay Limit (Minutes) - Allows you to set the maximum amount of delay (in minutes) 

for pop-up flights controlled by a GDP - GAAP or GDP - UDP. The default Delay 
Limit is 180 minutes. If an ADL contains GDP parameters that include a Delay Limit, 
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that limit displays when you use the Load Parameters feature. Click Default to reset 
the values to the default times.

• Target Delay (Multiplier) – This parameter is used to compute pop ups’ additional 
delay as compared to other known traffic. More specifically, it is multiplied by the 
average delay found in the DAS Delay Table for the 15-minute time bin in which the 
flight wants to arrive (ETA). You can only update the Target Delay (Multiplier) for 
UDP programs.
For example, if flight A is a pop-up and wants to arrive at 1535, the TFMS Core will 
find the average delay for known flights in the 1530-1544 time bin and multiply that 
delay by the Target Delay (Multiplier). So if the average delay in that 15-minute time 
bin is 20 minutes and the Target Delay = 1.5, Flight A’s delay is calculated to be 20 x 
1.5 = 30 minutes and will receive a CTA of 1535 + 30 = 1605. 
This is not an editable field for DAS or GAAP programs. For DAS programs, the 
target delay multiplier is always 1.0 and cannot be edited. For GAAP programs, the 
target delay multiplier is not applicable as pop-up flights are assigned to unassigned 
slots or given the max additional delay. 
For UDP programs, the default value is 1.0. Use the arrows to select a new value or 
type a new value. As you adjust the number of minutes, the time will increase in the 
adjacent ddhhmm field. Valid values are 1.0 to 9.9. Click Default to return to the 
default value.

• Earliest R-Slot (Minutes) - This parameter is used internally within FSM to prevent 
allocating any reserved slots that are too close to the current time to be usable. From a 
system point of view, the only restriction on the Earliest R-Slot is that it be earlier than 
the end time of the GDP. 
Enter the Earliest R-Slot as a number of minutes that will be added to the start of the 
program being issued. 
For example, if you think the pop-up traffic for the first 2 hours (120 minutes) of your 
program has already materialized, you would not want to reserve slots for pop-up 
flights in those hours. In this example, with the Earliest R-Slot parameter, you can 
control when you want reserved slots to begin for pop-up flights by adding 120 
minutes to the Program Start.
Zero is the default value. Use the arrows to select a new value or type a new value. 
Click Default to reset the values to the default times.

• Adjust Delay (Minutes) - This parameter is available only when using the Blanket 
Program Type. You can use Blanket Adjust Delay to add or release a specified amount 
of time from selected criteria. You should only use Blanket during a GDP. For 
example, if you had a hole in the traffic flow, you could select centers, distance, fixes, 
or aircraft types and enter in a negative number to release some delay or release all 
delay by clicking Release. Release fills in the Adjust Delay text field with –999, 
which is equivalent to releasing all delay. Alternatively, you can add delay to the 
selected criteria by entering the amount of extra delay in minutes. Click Default to 
reset the values to the default times.
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• Purge Notification (Minutes) - These options are only available when a Purge 
program type is selected. You may change the values for modeling purposes; however, 
the default values will be used for the purge. To model the purge using different 
values, you may either enter the number of minutes in the fields, or use the spinner 
controls to change the values in five-minute increments. These values may not be 
negative. Click Default to reset the values to the default times.

Note: Changing Purge Notification (Minutes) values is for modeling 
only. The actual purge uses the default values.

• AFP Override - Gives priority to the current AFP over previously issued AFPs. FSM 
assigns control times based on the current modeled AFP and overrides any other 
control times that flights received due to previous AFPs. These control times do NOT 
override control times assigned due to airport based TMIs.

• Slot Hold Override - You can change parameters only for RBS++ and Compression. 
The Slot Hold Override field allows you to override an airline’s slot holding status by 
either typing an airline’s three-letter identifier directly in the text field next to Slot 
Hold Override or click Select to open the Select Slot Holding window (see Figure 3 - 
62). The Select Slot Holding window lists the airlines currently holding slots at the 
data set constraint and allows you to select which airline(s) to override. Select the box 
next to each airline to override its slot holding status and include the slot in 
compression. When you check a box, that airline’s slot hold status is ignored. Click 
Clear to remove entries.

Figure 3 - 62: Slot Holding Override Window
• Exempt AFPs - To minimize the number of changes to control time for flights that are 

controlled by a GDP and to minimize the change in the demand at the AFP, you may 
exempt AFP flights from GDP. Selected flights will be treated as previously controlled 
regardless of their AFP exemption status and given the first available airport arrival 
slot after their estimated arrival time, which is based on their current AFP EDCT and 
any airline submitted flight delays. FSM will make an effort not to change the assigned 
departure time (CTD) for the flight, subject to capacity constraints at the airport and 
any known flight delays. Click Clear to remove entries.
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You can select parameters for Arrival Fix, Aircraft Type, and Carrier for all program 
types except AFP - DAS, Compress Flights, and Airborne Holding in the Include Only 
Options section (see Figure 3 - 63). 

Figure 3 - 63: Include Only Options Section
• Arrival Fix - Use the dropdown menu to determine which Arrival Fixes to include in 

the operation. You can select ALL (default value) or one individual fix.
• Aircraft Type - Select ALL (default value), Jet Only, or Prop Only from the Aircraft 

Types dropdown menu to specify the aircraft types included in the operation.
• Carrier (Major) - Select ALL (default value) to include all carriers at that airport. If 

you want to include only a single airline, type the carrier’s 3-letter code into the text 
box. The application does not allow you to include only one carrier without including 
its sub-carriers. Likewise, you cannot include one sub-carrier. Typing a carrier code 
into this field always includes the major and its sub-carriers.

Scope Tab

The Scope tab is active for all Program Types except Airborne holding and Purge. The 
Scope tab has two types of exemption criteria for airports, Tier-based and Distance-based. 
In the Select By dropdown box, select either a Tier or Distance based initiative. FCAs can 
only issue tier-based AFPs, therefore, distance is not an option.
Scope Tab for Data Sets with Select By Tier Selected

When you select Select By Tier, the following panel is displayed. The panel contains four 
sections where you can modify parameters: Centers - Origin, Airports - Origin, Airports - 
Destination, and Flights. 
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Figure 3 - 64: GDT Setup - Scope Tab

Centers - Origin: You can select the centers you want to include in the program or select 
a Tier level from the Scope dropdown menu:

• Scope: Select a tier option from the dropdown menu. Selecting a Tier, automatically 
selects the associated centers. The total number of centers selected displays to the right 
of the Tier selection. Click Clear to erase all centers with checkmarks and return the 
included tier selection back to Manual.

• Manual Center Selection: Click the checkbox to select or deselect individual centers to 
include in the program.

Note: The recommended scope for AFP programs is ALL + Canada
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Airports - Origin: This section of the panel allows you to exempt and non-exempt 
airports:

• Exempt: You can exempt certain departure airports from a TMI. Enter the three or 
four-letter airport code to exempt that airport. Separate airports with a space or a 
comma. The maximum number of exempt airports you can enter is 24.

• Non-Exempt: You can include certain departure airports for a TMI that were not 
originally included based on the Center section criteria. Select Manual from the 
dropdown, then enter the three or four-letter airport code to include that airport. 
Separate airports with a space or a comma. The maximum number of non-exempt 
airports you can enter is 16.

Airports - Destination: This section of the panel is only for airspace datasets and is 
disabled for airport data sets.

• Exempt - You can exempt certain arrival airports from an AFP. Enter the three or four-
letter airport identifier to exempt flights that are arriving from that airport from 
departure delay. Separate airports with a space, comma, semi-colon, or colon. 

Flights: This section of the panel allows you to exempt, i.e., give no departure delay, to 
priority flights as well as select Exempt by Departure Status or time.

• Exempt Active Flights Only (By Status): Selecting this option gives exemption status 
only to active flights, therefore, all flights within the scope of the program that are not 
active are considered Non-Exempt. This option is selected by default when there is a 
Ground Stop in place.

• Exempt All Flights Departing Within ‘XX’ Minutes: When exempting flights based 
on departure time, you may adjust the time either manually by clicking in the field and 
typing in a value enter a value, or by using the spinner controls (the up/down arrows to 
the right of the field) to change the value in five-minute increments. This value must 
be greater than or equal to 0. Selecting this option will exempt all flights with ETDs 
within XX minutes of the Data Time. This option is selected by default when there is 
no Ground Stop in place. 

• Exempt Individual Flights: Enter a flight’s ACID to exempt priority flights.
Scope Tab for Airport Data Sets with Select By Distance Selected

When you select Select By Distance, the Distance panel is displayed (see Figure 3 - 65). 
The Distance panel contains four sections in which you can modify the parameters: 
Distance, Centers - Origin, Airports - Origin, and Flights.
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Figure 3 - 65: GDT Setup - Scope Tab Exempt By Distance

Distance: When the Distance Panel first displays, the default distance is 199 nautical 
miles. You can enter your distance range directly into the Distance text box or click and 
drag the sliding bar for the desired distance; this automatically fills in the distance. 
Remember, anything changed in the Setup panel is reflected in the GDT Map. You can 
change the distance range from the Setup panel and simultaneously view the range ring 
and what centers/airports are affected on the GDT Map.

Centers - Origin: You can enter centers to be Exempt (have higher priority than Non 
Exempt) or Non Exempt.

• Exempt: You can exempt certain centers from a TMI that were originally partially, or 
entirely, included based on the Distance criteria. Enter the three or four-letter center 
identifier to exempt a particular center. Separate multiple centers with a space or a 
comma. The maximum number of exempt centers you can enter is 36.

• Non-Exempt: You can include certain centers from a TMI that were not included 
originally based on the Distance criteria. Enter the three or four-letter center identifier 
to include a particular center. Separate multiple centers with a space or a comma. The 
maximum number of non-exempt centers you can enter is 16.
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Airports - Origin: This section of the panel allows you to include and/or exempt airports.

• Exempt: You can exempt certain departure airports from a TMI. Enter the three or 
four-letter airport code to exempt that airport. Separate multiple airports with a space 
or a comma. The maximum number of exempt airports you can enter is 24.

• Non-Exempt: You can include certain departure airports from a TMI that were not 
included originally based on the Distance criteria. Enter the three or four-letter airport 
code to include that airport. Separate multiple airports with a space or a comma. The 
maximum number of non-exempt airports you can enter is 16.

• Non-Exempt if Distance: Use this field to include Canadian airports. If you select a 
Canadian airport, FSM includes that airport if it falls within the selected distance 
parameter.

Flights: This section of the panel allows you to exempt, i.e., give no delay, to priority 
flights as well as select Exempt by Departure Status or Time.

• Exempt Active Flights Only (By Status): Selecting this option gives exemption status 
only to active flights, therefore, all flights within the scope of the program that are not 
active are considered Non-Exempt. This option is selected by default when there is a 
Ground Stop in place.

• Exempt All Flights Departing Within ‘XX’ Minutes: When exempting flights based 
on departure time, you may adjust the time either manually by clicking in the field and 
typing in a value enter a value, or by using the spinner controls (the up/down arrows to 
the right of the field) to change the value in five-minute increments. This value must 
be greater than or equal to 0. Selecting this option will exempt all flights with ETDs 
within XX minutes of the Data Time. This option is selected by default when there is 
no Ground Stop in place. 

• Exempt Individual Flights: Enter a flight’s ACID to exempt priority flights.
Modeling Options Tab

The Modeling Options tab is available for all program types with the exception of Purge. 
Once the parameters are set, you may want to determine which parameters run the best 
TMI. In this case, you can take advantage of FSM’s powerful analysis capabilities to view 
the results of the parameters you have selected before actually running the operation.

You can use the Modeling Options tab in the GDT Setup component as an analysis tool. 
There are four GDP, three AFP, three GS, one Compression, and one Blanket Power Run 
operations, which analyze the results for any program. You can select these options from 
the dropdown menu that displays next to Power Run By. You use the Power Run function 
to determine whether you need to modify the parameters. When any Power Run is 
generated, FSM automatically saves the Power Run to a file.

Once you have clicked Run on the GDT Setup component, you still have the option to 
analyze the parameters used. FSM generates a post-operation evaluation, called the 
Analysis Report, when you click Run. The Analysis Report is an option on the Reports 
menu in any delay operation Coversheet.
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To view a scenario, select the type of program to model in the Power Run By dropdown 
menu and click Model. Model displays the effects of potential operation parameters and 
how traffic at the airport would be affected by using these parameters for an actual 
program in all GDT components. Review the program statistics in the Data Graph. To 
preview the effects of running a Power Run scenario as an actual program, move the black 
line on the Data Graph component to other options displayed on the X-axis. This is 
discussed in more detail in the Data Graph Component Section.

With the exception of Power Run for Decision Time, you can preview the proposed 
parameters and their effect on the airport’s traffic.

Note: After you click Model, the Setup Panel no longer contains a red 
border, which indicates that all the components reflect the 
information in the GDT Setup component.

Power Run Options

The different options when using Power Run By describe what data is displayed on the X-
axis of the Data Graph and the headers in the Data Table (see Figure 3 - 66). The Program 
Type you select determines which options are displayed in the Power Run By dropdown 
menu. All GDP functions have “GDP” listed before the Power Run Type, all AFP 
functions have “AFP” listed before the Power Run Type, and all GS functions have “GS” 
listed before the Power Run Type.

Table 3-8:  Power Run Options by Program Type

Program Type Power Run By Options
GDP - DAS GDP Distance

GDP Data Time
GDP Data Time & Distance

GDP - GAAP GDP Distance
GDP Data Time
GDP Data Time & Distance

AFP - DAS AFP Percent Demand
AFP Percent Capacity
AFP Data Time

AFP - GAAP AFP Percent Demand
AFP Percent Capacity
AFP Data Time

Ground Stop GS Center Group

GS Time Period

GS Center Group & Time Period
Compress Flights Start Time
Blanket Minutes of Adjustment
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Figure 3 - 66: GDT Setup - Modeling Options Tab

Note: Distance variables are only editable when you model a Distance 
based Program.

Program Cancellation Time

Using the Program Cancellation Time, you can model unrecoverable delay assuming a 
program cancellation time other than the program start time. The field defaults to the 
program start time and uses the ddhhmm format. The Program Cancellation Time is 
available for all Power Runs for GDP and AFP program types, but not for GS, Blanket, 
and Compression program types. The Program Cancellation Time defaults to the 
Program's Start time in the GDT Setup Panel. If you change the Start Time, this 
automatically reflects in the Program Cancellation Time.
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A checkbox labeled Freeze Cancellation Time displays to the right of the Program 
Cancellation Time. By default the checkbox is unchecked. When checked, the Program 
Cancellation Time does not change with a newly entered Start Time or when FSM reloads 
a new ADL. 
GDP Power Run Options

• GDP Center Group: This option allows you to view the effect of the “proposed 
parameters” on the different center groups. The post-operation demand rate for each 
hour for a specific group of centers displays in the Data Graph. Other information 
displayed, includes average delay, number of affected flights, and total delay.

• GDP Data Time: From the Setup Panel, select GDP Data Time in the Power Run By 
dropdown menu. This option is available only for GDP program types. This option 
allows you to view the effects of the proposed GDP according to the time the GDP is 
issued. Using the display, you can determine how far in advance you need to issue the 
GDP. Any hour whose demand still exceeds the AAR is highlighted in red.

• Distance: From the GDT Setup component, select Distance from the Power Run By 
dropdown menu when modeling either a GDP or GS. This function shows you the 
effect of running a GDP or GS for various distance parameters. When Distance is 
selected from the Power Run By dropdown menu, three text fields become active in 
the Modeling Options tab: Start Distance, End Distance, and Step Size (distance 
increment). The default is set to start at 199 nautical miles and end at 2600 nautical 
miles with a step size of 200 nautical miles. You can manually enter your desired 
distance and increment range into the appropriate text fields.

• GDP Center Group & Data Time: From the GDT Setup component, select GDP Center 
Group & Data Time from the Power Run By dropdown menu. This option is available 
only for GDP program types. This function combines Power Run by Center Group and 
Power Run by Data Time. When you perform Power Run by Center Group & Data 
Time, you can view all available options to run a GDP using a particular center group 
at various data times.

• GDP Data Time & Distance: From the GDT Setup component, select GDP Data Time 
& Distance from the Power Run By dropdown menu. This option is available only for 
GDP program types. This function combines Power Run by Data Time and Power Run 
by Distance. When you perform Power Run by Center Group & Data Time, you can 
view all available options to run a GDP using a particular distance at various data 
times. Just as in the Distance set up, three text fields become active in the Modeling 
Options tab: Start Distance, End Distance, and Step Size (distance increment). The 
default is set to start at 199 nautical miles and end at 2600 nautical miles with a step 
size of 200 nautical miles. You can manually enter your desired distance and 
increment range into the appropriate text fields.

AFP Power Run Options

• AFP Data Time: This option allows you to view the effects of the modeled AFP 
according to the time the AFP is issued. Using the display, you can determine how far 
in advance you need to issue the AFP. 
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• AFP Percent Demand: This is the default option when you select an AFP RBS 
program type. An AFP Percent Demand Power Run has three fields: Min Percent 
Demand (%), Max Percent Demand (%), and Step Size. The default is set to start at 
Min Percent Demand of 50% and Max Percent Demand at 100% with a step size of 
10%. You can change the min and max percent demand and increment range to meet 
your needs. The AFP Percent Demand Power Run scenario analyzes alternatives by 
increasing/decreasing average demand for the indicated AFP start/end time. Moving 
the black vertical line in the Data Graph to adjust the percent of demand automatically 
adjusts the AFP AAR to meet the adjusted demand. 

• AFP Percent Capacity: This Power Run analyzes alternatives by increasing or 
decreasing the modeled AAR value for the indicated AFP Start and End times. An 
AFP Percent Capacity Power Run has three fields: Min Capacity Reduction (%), Max 
Capacity Reduction (%), and Step Size. The default value for Min Percent Capacity is 
50. The default for Max Percent Capacity is 100. The Step Size default is 10.

Ground Stop Power Run Options

• GS Center Group: This Power run allows you to see different statistics for all center 
groups. The Data Graph’s X-axis and the Data Table’s column header display the 
various center groups. This option is available only for GS program types.

• GS Time Period: From the GDT Setup component, select GS Time Period in the 
Power Run By dropdown menu. This option is available only for GS program types. 
This function shows you the effect of running a ground stop for various lengths of 
time. When you select GS Time Period, two text fields become active: Number of Start 
Times and Number of End Times. The default for both is set to 2, but you can manually 
enter in another value to meet your analysis needs.

Note: If you decide to run a GS for longer than one hour, FSM provides 
a warning message to ensure you want the ground stop to last for 
that duration.

• GS Center Group & Time Period: This Power Run allows you to see which 
combination of center groups and time periods put in the GS parameters would 
produce the best program. The Data Graph’s X-axis and the Data Table’s column 
headers show the various Time Periods and Center Group combinations. This option is 
available only for GS program types.

Compress Flights Power Run Option

• Start Time: This Power Run allows you to model a Compression based on Earliest 
Start Time, Latest Start Time, and Step Size. The Data Graph shows Average Delay 
Difference in addition to the usual statistics. Average Delay Difference is the 
difference in calculated average delay prior to and after the modeled program. It 
represents the reduction of delay benefit in minutes resulting from a later start time.

Blanket Power Run Option

• Minutes of Adjustment: This Power Run allows you to see alternatives by minutes of 
adjustment for a Blanket program. You must enter a Minimum Adjustment, Maximum 
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Adjustment, and Step Size for the program. Each of these values must be integers 
between -999 and 999.

Impact Modeling Options

You can view the impact of a TMI on up to five other elements while modeling a program 
on the current element. FSM applies the results of the model TMI to each matching flight 
instance found in the impact elements. Then, FSM updates specific flight data fields 
within each impact element based on values calculated for the model element.

Note: You cannot use impact modeling in Historical mode.

FSM does not allow modeling errors in Impact elements to prevent modeling for the 
Model element or the issuance of the TMI. If an error occurs in any of the Impact 
elements, it does not prevent you from modeling or submitting a program.

The Impact Modeling Options section of the Modeling Options tab displays a list of 
elements in the Available box that you can use for impact modeling. Use the arrow buttons 
to move the selected elements into and out of the Selected box. 
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Figure 3 - 67: Impact Modeling Options on Modeling Options Tab

The Available box is populated with elements from the list of monitored elements on the 
FSM server. The elements in the Available box are grouped by Currently Open data Sets, 
FEAs/FCAs, and Center. Any program information and update times associated with them 
are displayed next to the element name. FSM updates the program information and update 
times for each element when it receives new information from the ADL.

Once you place an element in the Selected box, the update time for it is frozen and does 
not update unless you click Reload. FSM updates all impact elements with the most 
current ADL data when you click Reload. 

When you click Reset Parameters on the GDT Setup Panel, any Impact Elements you 
selected in the Impact Modeling Options section remain. FSM clears the Impact elements 
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of the modeled data and displays the current ADL data on the GDT Bar Graph. The GDT 
Bar Graph displays the Model data set, but you can click the Impact element buttons to 
view each Impact element’s reset data.

The Impact Modeling Options section has two buttons labeled > and < that you use to 
move items between lists. Selecting an element and clicking > adds the element to the 
Selected box. When you select an element in the Selected box and click <, FSM removes 
the selected element from the Selected box.

GDT Map Component
The GDT Map component is one of four components that opens when you click GDT 
Mode on the Control Panel. The GDT Map component is similar to the display of the Map 
component in monitor mode, however the functionality is different. See the Map section 
above for more information. Selections made in the GDT Setup component are 
dynamically reflected in the GDT Map component. Airports the server is currently 
monitoring are displayed with the airports’ three-letter identifier and a colored dot 
indicating the GDT status of each airport. FCAs the server is currently monitoring are 
displayed with a colored boundary that indicates the AFP status of that FCA. The title bar 
displays the normal component labeling conventions. GDT displays at the end of the title 
bar label to indicate that you are looking at the Map in GDT mode. Adaptive compression 
status displays in the SUBS section.

When you initially open GDT mode, the GDT Setup component default on the Scope tab 
for airports has the exempt by tier with internal centers selected; therefore, the GDT map 
initially has only the airport’s Internal center selected. The Scope default for airspace data 
sets is ALL. When a center is included, it is colored with a maroon overlay and the 
airports that are within the centers are colored red (see Figure 3 - 68). A red airport 
indicates that a TMI includes that airport. A green colored airport indicates that the airport 
is exempt from delay.

Interactions between the GDT Setup component and the GDT Map for FCAs operate in 
the same manner as with Airport data sets. That is, only departure exemptions or non-
exemptions are shown in the red/green color scheme to minimize any confusion and to 
keep the same conventions between airport and airspace elements. To exempt an arrival 
facility, the airport identifier must be entered in the GDT Setup panel on the Scope tab. 
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Figure 3 - 68: GDT Map Component

The GDT Map operates somewhat differently than when in Monitor Mode. The Auto-
Show menu on the GDT Map is disabled for all data set types. This should reduce clutter 
on the Airport data sets and minimize confusion when modeling an Airspace data set. In 
addition, when modeling an airspace control element, the GDT Map only displays the 
FEA or FCA for the TMI being modeled and is colored white for easier viewing (see 
Figure 3 - 69).
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Figure 3 - 69: GDT Map Component-AFP FCA

The GDT Map component allows you to design a TMI visually by selecting/deselecting 
airports and/or centers. Selecting/Deselecting airports, centers, and adjusting the distance 
range interactively updates other GDT components.
GDT Map Zoom Capabilities

GDT Map contains the same zoom capabilities as the Map in Live mode, for more detail 
refer to Map Component section of this chapter.
Distance Based GDPs

When you select a distance based GDP in the GDT Setup component, a maroon colored 
“range ring” displays on the GDT Map component. The default distance is set to 199 
nautical miles. The range distance is indicated on the GDT Map just outside the top of the 
ring. In addition to adjusting the range from the GDT Setup component, you can alter the 
distance directly on the GDT Map. Put your cursor on the edge of the distance ring until 
the cursor turns into direction arrows, then hold down the left mouse button and drag and 
drop the edge of the ring to increase or decrease the distance. All airports within the range 
limit are included automatically into the program and colored red. To exclude an airport 
from within the distance range, just click the dot for that particular airport. Clicking an 
airport within the distance ring turns the dot to green and excludes that airport from 
program delay. Any additional airports you select are displayed in the GDP Setup 
component in the Airports: Non Exempt or Exempt field in the Scope tab. Likewise you 
can select/deselect centers to include in a program on the GDT Map. Clicking once on a 
center includes the center in the program. The color of the selected center changes to 
maroon and the airports within that center change color indicating that the program 
includes them as well. The selected center displays in the GDP Setup component in the 
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Centers: Non Exempt field in the Scope tab. ZTL in Figure 3 - 70 and Figure 3 - 71 is an 
example of a user selected non-exempt center.

Note: Clicking only once on a center that is already included within the 
program selection does not reflect any visual difference on the 
screen.

If you click twice on a selected center, that center is exempt from the program. The 
selected center turns to black and the airports within the center turn green to indicate that 
they are exempt from delay. The center selected displays in the GDP Setup component in 
the Centers: Exempt field in the Scope Tab. Figure 3 - 70 is an example of a user selected 
exempt center (ZAU). If you click a center a third time, the center selection returns to the 
distance based default selection.

Figure 3 - 70: GDT Map Setup

This map corresponds with the following GDT Map component setup.

Table 3-9:  Mouse Actions on the GDT Map

Mouse Action Description
Click Airport Toggle an airport from Exempt/Non-exempt
Click center once Includes Center in program
Click center twice Exempts center from program delay
Click center three times Default selection by distance
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Figure 3 - 71: GDT Setup Reflected GDT Map Component

Tier-Based GDPs

The initial default setting when you open GDT Mode components is an internal tier-based 
GDP. When you select a tier based GDP from the GDP Setup component, FSM colors all 
centers included in a TMI maroon on the map and colors all airports included red. For 
example, the next figure illustrates a SFO 1st Tier GDP with user selected airport, PHX, as 
an additional Non-Exempt airport. The method of selecting/deselecting airports and/or 
centers is the same as described above in the distance based GDP (see Figure 3 - 72).
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Figure 3 - 72: ATL 1st Tier Program

The GDT Map component (see Figure 3 - 72) corresponds with the following GDT setup 
component (see Figure 3 - 73). 
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Figure 3 - 73: GDT Setup Component ATL 1st Tier

GDT Map Menu Bar

The GDT Map component menu bar contains four options: File, View, Map, and Help. 
The menu selections are the same for the GDT Map as they are for the Monitor Live 
Map—see the Map Component section in this chapter for more information. The Auto-
Show menu on the GDT Map is disabled for all data set types. 

GDT Bar Graph Component
The GDT Bar Graph component is one of four components that opens when you click 
GDT Mode on the Control Panel component. The Bar Graph allows you to view arrival 
demand at the airport or FCA being monitored and compares actual data with proposed 
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parameters. By default, the GDT Bar Graph displays flights based on their ETAs for 
modeled Airport TMIs or ENTRY times for modeled Airspace TMIs.

Click Model on the GDT Setup component to view the modeled parameter results in the 
Bar Graph as well as the Data Graph component. The GDT Bar Graph menu and tab 
options are almost identical to the Monitored Live Bar Graph. Please review the Bar 
Graph Component section above for more detail. There are some minor differences in the 
GDT Bar Graph. In GDT mode, only arrival information displays, therefore, under the 
View menu no ADL ADR Line option is displayed.

Another difference between the Bar Graph and the GDT Bar Graph is that the GDT Bar 
Graph displays both solid and hashed bars. Solid bars represent the original data, while 
hashed bars represent modeled data (see Figure 3 - 74).

Figure 3 - 74: GDT Bar Graph

The last difference between the Bar Graph and the GDT Bar Graph are the Model and 
Impact element buttons.
Model and Impact Element Buttons

Once you click Model on GDT Setup for your program, any impact elements you 
specified in the GDT Setup component Modeling Options tab > Impact Modeling Options 
section are displayed as buttons on the GDT Bar Graph. The first button is always the 
Modeled element and is separated from the Impact element buttons by extra space. The 
buttons for the Model and Impact elements in the GDT Bar Graph are displayed to the 
right of the existing buttons.
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When you click an Impact element you want to view, a bar graph for that element 
displays. Any menu items that are available for the Model element's GDT Bar Graph are 
also available for the Impact element's Bar Graph with the exception of Model Program 
Rate which is enabled only for the Model element. The labeling of the buttons is similar to 
that of the data set buttons used on the FSM Control Panel. The selected button displays 
depressed.

If you are on a tab for one element and switch to another element, FSM maintains the tab 
view if possible. Otherwise, FSM returns the GDT Bar Graph to the Status tab in any 
situation where the tab you were on in another element does not exist. For example, if you 
are on an AFIX tab for an airport element and switch to an FCA element, the GDT Bar 
Graph view changes to the Status tab. Additionally, if you change the Bar Graph display 
for one of the Model or Impact elements, the changes for all of the elements in the GDT 
Bar Graph component (where applicable) are displayed.

GDT Data Graph Component
The GDT Data Graph component opens in front of the GDT Map when you click Reload 
or Model from the GDT Setup component. You have the option to review, or model your 
ground delay parameters before actually running the program or revising any parameters. 
Click Model on the GDT Setup component to view the initiative’s results with your 
current parameters in the Data Graph.

From the Modeling Options tab on the GDT Setup component, you can choose the type of 
data you want to view on the Data Graph’s X-axis. When you click Model, you can view 
the results of various scenarios. You have the option to change your parameters, analyze 
the program further, or, if satisfied with the result, run the program (see Figure 3 - 75).
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Figure 3 - 75: Data Graph Component

Selecting Different Scenarios

You can view all the available scenarios based on the Power Run selection from the GDT 
Setup component. For example, selecting Power Run By > GDP Center Group from the 
Modeling Options tab on the GDT Setup and then clicking Model, displays all the 
available tiers for the monitored airport on the Data Graph component’s X-axis. Your 
modeled scenario statistics are displayed in the Legend Table. Use your cursor to drag the 
black vertical line to a center group, or just move the cursor over the desired center group 
and click to move the line. The delay statistics to the right of the Data Graph reflect the 
line of scenario delineation. In addition, changing the center option automatically updates 
all GDT components to reflect the new parameters. The Data Graph component includes a 
roll-over feature. Rolling your cursor over any line in the Data Graph gives you the delay 
statistics for the colored line that reflects the results of the center group. From the Data 
Graph, it is easy to visualize what center groups give the best results. 
Delay Statistics

The Legend Table displays the delay statistics. By default the Legend Table displays when 
you open the Data Graph component. You can hide the legend by un-checking the View > 
Show Legend box from the Data Graph Menu. In the Legend Table, you can view a desired 
delay statistic several ways. Selecting the All checkbox selects and displays all the delay 
statistics. Selecting the Default checkbox displays the default delay statistics, which are 
Max Delay, Avg Delay, Max Air Hold, Avg Air Hold, and Delay Var. You can select/
deselect any of the delay statistic checkboxes that you want to view in the Data Graph. To 
view one delay statistic in more detail, select the desired radio button option, located to the 
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left of the checkboxes. The radio button option displays only one delay statistic at a time, 
but gives a more refined looked at the numbers. The Data Graph includes the following 
Delay Statistics:

• Total # Flts: The total number of flights included in the TMI (cancelled and exempt 
flights) for each particular power run scenario. Default color is pink.

• Affected Flts: The total number of flights included in and affected by the TMI for each 
particular power run scenario (non-exempt and non-cancelled flights only).

• Total Delay: The total amount of delay that would occur if you ran that particular 
scenario. Default color is maroon.

• Max Delay: The maximum amount of delay (in minutes) that any one flight would 
receive if you ran that particular scenario. Default color is white.

• Avg Delay: The average amount of delay (in minutes) flights would receive if you ran 
that particular scenario. Default color is black.

• Max Air Hold: The maximum amount of airborne holding delay (in minutes) that 
would be placed on any one flight if you ran that particular scenario. Default color is 
lavender.

• Avg Air Hold: The average amount of airborne holding (in minutes) that would be 
placed on flights if you ran that particular scenario. Default color is orange.

• Stack: The amount of flights that would be left in the “stack” hour following the end of 
the initiative if you ran that particular scenario. Default color is hunter green.

• Unrec Delay: Unrecoverable delay is the amount of delay that remains on flights even 
if you release the TMI right before the start time for the selected scenario. FSM 
determines this value by setting the time to the TMI start time and performing the 
release delay function. Default color is lime green.

• % Unrec: Percentage of Unrecoverable delay is a value that FSM calculates by taking 
the Unrecoverable Delay and dividing it by Total Delay (Unrecoverable Delay/Total 
Delay). This is the percentage of delay that remains even if you release all delay at the 
start time for the selected scenario. Default color is yellow.

• Delay Var: Delay Variability is the standard deviation of the carriers’ average delay. 
FSM determines this value by taking the average delay of all carriers to see if they are 
similar. If the average delay is similar for all carriers, the delay variability is a small 
value. Larger deviation, or increased dissimilarity of average delay for all carriers, 
results in larger delay variability values. Default color is red.

• EMA: The Equity Metric for Airlines (EMA) is a metric that indicates (as a whole) 
how equitable, or fair, the proposed initiative is for the airlines. Equity is determined 
by comparing the delay assigned in a proposed initiative to that which results if you 
use the airborne holding model. You must view any deviation from the airborne 
holding model as decreased equity. The values shown in this field are integers rounded 
from the calculated values. A value of 1 indicates that the initiative option results in 
delays that are exactly the same as those for airborne holding. A value from 2 to 8 
indicates an option that still exhibits good equity, though the one with the lower value 
is still preferred. A value from 9 to 16 indicates an option with increasingly significant 
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deviation from the standard. A value above 16 indicates an option with poor equity. 
Default color is cyan.

• EMF: The Equity Metric for Flights is a metric that indicates (as a whole) how 
equitable, or fair, the proposed initiative is for all the flights. Equity is determined by 
comparing the delay assigned in a proposed initiative to that which results from using 
the airborne holding model. You must view any deviation from the airborne holding 
model as decreasing equity. The values shown in this field are integers rounded from 
the calculated values. A value of 1 indicates that the initiative option results in delays 
that are exactly the same as those for airborne holding. A value from 2 to 8 indicates 
an option that still exhibits good equity, though the one with the lower value is still 
preferred. A value from 9 to 16 indicates an option with increasingly significant 
deviation from the standard. A value above 16 indicates an option with poor equity. 
Default color is blue.

• Avg Dly Diff: The difference in the calculated average delay prior to and after the 
program. This is always a negative number and FSM only calculates it for a 
Compression program. 

GDT Data Graph Menu

The menu bar in the GDT Data Graph component contains three options: File, View, and 
Help.

1. File Menu

• File > Save As - Saves the Data Graph as a.jpg image in a directory that you 
specify.

• File > Print - Prints the Data Graph that is currently active on your screen.

• File > Close - Closes the Data Graph component only.

2. View Menu

• View > Show Legend - By default the checkbox is selected and the color legend 
of the delay statistics is displayed. Deselect the checkbox to hide the legend 
and the delay statistics.

3. Help Menu

• Help > Data Graph - Opens the on-line help system.

Demand By Center Component
The GDT Demand by Center component provides you with an additional analysis tool to 
help with scope decision making for GDPs, AFPs, and Ground Stops. The Demand by 
Center component functionality is similar to that of the Data Graph, in that there is only 
data available for display after you model a TMI. After you model a TMI, click Show 
Demand on the Scope tab of the GDT Setup panel or select View > Show Demand from the 
Setup panel menu.

The Demand by Center component displays the scope of the modeled TMI and has three 
columns: Centers, Non-Exempt, and Exempt. All centers and the top five airports within 
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each center (based and ordered primarily by the number of Non-Exempt flights and then 
by the number of Exempt flights) are displayed under the Centers column. The number of 
Non-Exempt flights displays under the Non-Exempt column and the number of Exempt 
flights for each center or airport displays under the Exempt column. 

A red dot to the left of the center or airport identifier indicates that at least one Non-
Exempt flight is present within that center or airport. A green dot indicates that all flights 
are Exempt within that center or airport (see Figure 3 - 76).

Figure 3 - 76: Demand By Center

By default, the Centers are collapsed. Click the key icon next to the center identifier to 
expand the center and view the top five airports within each Center. If there are more than 
five airports with included flights in the selected Center an additional “Others” row 
combines the rest of the flights within the remaining airports. If a center does not contain 
any flights, that center’s airport list is empty.
Demand By Center Menu Bar

The Demand By Center menu bar contains two options, File and Help.

1.  File Menu

• File > Save as - Saves the Demand By Center window as a .jpg image in a 
directory that you specify. 

• File > Print - Prints the Demand By Center component that is currently active 
on your screen. 
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• File > Close - Closes the Demand By Center component only.

2. Help Menu

• Help > Center Demand - Opens the on-line help for the Demand By Center 
component.

GDT Time Line Component
The GDT Time Line component is an optional component in GDT Mode. To open the 
GDT Time line, select View > GDT Time Line from the GDT Setup component menu bar. 
The GDT Time Line displays flights based on their ETAs for modeled Airport TMIs or 
ENTRY times for modeled Airspace TMIs by default. The Time Line in GDT Mode is 
almost identical to the Time Line in Monitored Live mode. The title bar of the GDT Time 
Line has “GDT” after the ADL time.

There are two differences to the GDT Time Line that should be noted. First, GDT Mode 
uses only arrival data, the GDT Time Line displays only arriving flights where as the Live 
Time Line can display both arrival and departure data. The View > Departure Data option 
that displays in the Monitored Live Time Line is not an option in GDT Mode.

Second, there is an extra menu option, Display, available in the GDT Time Line. The 
Display menu contains nine radio button choices for viewing flights in the GDT Time 
Line component (see Figure 3 - 77).

Figure 3 - 77: GDT Time Line Component

You can display the flights in the Time Line based on various ADL arrival data fields. By 
default, the GDT Time Line displays based on ETA.
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GDT Time Line Menu Bar

The menu bar in the GDT Time Line component contains five options: File, View, Time 
Line, Display and Help.

1. File Menu - the GDT Time Line File menu is exactly the same as the Monitored 
Live Time Line File menu except that it has no Close Group option. See the Time 
Line Menu Bar section above for more information.

2. View Menu - the GDT Time Line View menu is exactly the same as the Monitored 
Live Time Line View menu except that it has different default selections. See the 
Time Line Menu Bar section above for more information.

Note: Show CNX/DO, Open Slots in Carrier Color, Show Unassigned 
Slots, and Auto Icons checkboxes are selected by default.

3. Time Line Menu - the GDT Time Line component Time Line menu is exactly the 
same as the Monitored Live Time Line component Time Line menu. See the Time 
Line Menu Bar section above for more information.

4. Display Menu

• Display > ETA - Display flights based on their Estimated Time of Arrival 
(ETA).

• Display > BETA - Displays flights based on their Base Estimated Time of 
Arrival (BETA). The BETA matches the ETA and is frozen when the flight 
becomes active or when the flight becomes controlled. 

• Display > IGTA - taxi - Displays flights based on their Initial Gate Time of 
Arrival (IGTA) minus taxi time (IGTA Wheel Time). The IGTA is based on the 
OAG times or flight plan times and never changes. Taxi time default is 10 
minutes, but you can change it in the GDT Control window.

• Display > OCTA - Displays flights based on their Original Controlled Times of 
Arrival (OCTA), Original ETA, OGTA Wheel Time, or ETA position, 
depending on the available information. For example, if the Original CTA is 
not available, FSM uses Original ETA and so on. This time never changes.

• Display > EAFT - Displays flights based on their Estimated Arrival Fix Time 
(EAFT), which is the time at which the flight crosses its designated arrival fix.

• Display > CTA - Displays flights based on their current Controlled Time of 
Arrival (CTA).

• Display > ENTRY - Displays flights based on their current Estimated Element 
Entry Time (Airspace data set only)

• Display > BENTRY - Displays flights based on their current Based Element 
Entry Time (Airspace data set only)

• Display > OENTRY - Displays flights based on their current Original Element 
Entry Time (Airspace data set only)
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5. Help Menu 

• Help > Time Line - Opens the on-line help for the GDT Time Line component.

• Help > Legend - Opens the on-line help for the Time Line icon legend. 

GDT Coversheet
Each GDT program generates a coversheet and advisory when you run the program. The 
GDT Coversheet displays the GDT parameters/text fields based on the program type you 
selected. In other words, the coversheet is dynamic in that it will only display TMI-
specific content. This section reviews the various components of a coversheet.
Coversheet Menu

There are four file menu options available on the GDT Coversheet: File, View, Resend, 
and Help.

1. File Menu

• File > Close - Closes the Coversheet window

2. View Menu

• View > FADT - Displays the FADT Report

• View > Analysis - Displays the Analysis Report in a spreadsheet file viewer

• View > Carrier Statistics - Displays the Carrier Statistic report

3. Resend Menu

Note: This menu is available only after you click Send Actual 
<Program Type> or Send Proposed <Program Type>.

• Resend > Resend Program - Starts the TFMS Autosend process to send the 
FADT file to the hub site and the coversheet file to NTML and remote copies 
the files. This option is available only for Actual TMIs. 

• Resend > Resend Advisory - Uses an existing advisory number (if available) 
and starts the TFMS Autosend process to send only the Advisory for the 
program. This option is available for all Proposed and Actual TMIs.

• Resend > Resend Program & Advisory - This starts the same process that starts 
when you click Send Actual <Program Type> for the first time on the 
Coversheet. This option is available only for Actual TMIs.

4. Help Menu

• Help > Coversheet - Opens the online help information about the FSM 
Coversheet.

Coversheet Tab

Right below the menu bar, is a tab with the name of the airport or FEA/FCA with either a 
red “X” or a green checkmark (see Figure 3 - 78). A red “X” is the default and indicates 
that the coversheet has not been reviewed. A green checkmark indicates that the Advisory/
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Causal Factors and Program Parameters have been selected, and the program is ready to 
be sent.

Figure 3 - 78: Tab Indicates if Coversheet has been Reviewed

Coversheet Heading

The heading below the tab lists the dataset name, program type, and whether the program 
is Actual or Proposed (see Figure 3 - 79). The format is [Dataset] / [Program Type] / 
[Actual or Proposed]. 

Figure 3 - 79: Dataset Information in Heading

Program Parameters Dropdown Menu

The Program Parameters dropdown menu has three options: View Weather, View Program 
Results, View Delay Assignments. Each window is opened as an overlay with a Close 
button. The coversheet is inactive until you close an overlay.

1. View Weather - Displays the current METAR and TAF in an overlay (see Figure 3 
- 80). This option is not available for FEA/FCAs. The coversheet is inactive until 
you click Close on the overlay.
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Figure 3 - 80: Weather Overlay

2. View Program Results - Displays Flight and Delay metrics for the program (see 
Figure 3 - 81). The coversheet is inactive until you click Close on the overlay.

Figure 3 - 81: Program Results Overlay
For more details on the metric fields, see Table 3-10.

Table 3-10: Program Results Fields

Field Name Description
Flight Metrics
Total Flights The total numbers of flights arriving at the monitored airport 

within the program start and end time.
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3. View Delay Assignments - Displays delay assignment metrics (see Figure 3 - 82). 
The coversheet is inactive until you click Close on the overlay.

Total Affected Flights Total number of flights included in the GDP operation 
(including cancelled flights) and the number of flights 
actually affected (non-exempt) by the GDP (excluding 
cancelled flights). (Max [0, CTA - BETA]) determines Any 
ATC Delay statistics.

Flights in Stack Number of flights pushed out (i.e., delayed past ) of the GDP 
or AFP period as a result of running the GDP.

Delay Metrics
Minimum Delay Before The minimum delay given to any one flight included in the 

parameters before you ran the program.
Minimum Delay After The minimum delay given to any one flight included in the 

parameters after you ran the program.
Minimum Delay Difference The difference in minutes of delay before and after the 

program is implemented.
Average Delay Before Total delay of flights in the GDP operation divided by the 

Total Affected Flights in the operation before you ran the 
program.

Average Delay After Total delay of flights in the GDP operation divided by the 
Total Affected Flights in the operation after you ran the 
program.

Average Delay Difference The difference in minutes of delay before and after the 
program is implemented.

Maximum Delay Before The longest delay assigned to any one flight in the GDP 
before you ran the program.

Maximum Delay After The longest delay assigned to any one flight in the GDP after 
you ran the program.

Maximum Delay Difference The difference in minutes of delay before and after the 
program is implemented.

Total Delay Before The sum of all delays resulting from this GDP operation in 
minutes before you ran the program. Determined by CTA - 
OETA.

Total Delay After The sum of all delays resulting from this GDP operation in 
minutes after you ran the program. Determined by CTA - 
OETA.

Total Delay Difference The difference in minutes of delay before and after the 
program is implemented.

Field Name Description
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Figure 3 - 82: Delay Assignment Overlay

For more details on the Delay Assignment fields, see Table 3-11.

Table 3-11: Delay Assignment Fields

Field Name Description
ETA: Day/Hour Time Estimated Day/Hour and Time of Arrival broken into 15-minute 

increments.
Delay: Avg/Tgt Average delay limit and target for each 15-minute increment.
Demand: Orig Number of arrival flights for each 15-minute increment before 

running the GDP.
Slots: Unassigned Number of unassigned slots for each 15-minute increment 

during a GAAP GDP.
Program Rate Qtrly. The Airport Arrival Rate set for each 15-minute increment after 

running the GDP.
Program Rate Hrly. The Airport Arrival Rate for each hour during the GDP.
Pop-Ups Qtrly. The Pop-Ups Rate set for each 15-minute increment after 

running the program.
Pop-Ups Hrly. The Pop-Ups Rate for each hour during the program.
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Summary Section

The Summary section is the first section and may include the following information 
depending on the parameters you specified in the GDT Setup component. Remember, the 
coversheet is dynamic so only relevant fields are displayed. 

Note: The following fields were previously defined in this chapter. For 
more details, see Chapter 3: GDT Setup Component.

• Program Time Options - the following information is pulled from the GDT Setup 
Parameters tab

• Start Time

• End Time

• Model Time

• Before Revision Start

• After Revision End 

• Compress to Last CTA
• Include Only Options - the following information is pulled from the GDT Setup 

Parameters tab

• Arrival Fix

• Aircraft Type

• Carrier (Major)
• Select By - the following information is pulled from the GDT Setup Scope tab

• Select By Distance / Tier

• Distance (nautical miles)
• Flights - the following information is pulled from the GDT Setup Scope tab

• Exempt Active Flights Only (By Status)
• Exempt All Flights Departing Within __ Minutes

Program Rate Section

The Program Rate Section is the second section and includes information as established in 
the specified GDT Setup sub section:

• Program Rate - Applicable Only to Included Flights - the following information is 
pulled from the GDT Setup Parameters tab

Reserved Qtrly. The Reserved set for each 15-minute increment after running the 
UDP.

Reserved Hrly. The Reserved Rate for each hour during the UDP.

Field Name Description
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The Program Rate table including Program, Pop-Up, and Reserve rates.

Options Section

• General Options - the following information is pulled from the GDT Setup Parameters 
tab

• Delay Limit (Minutes)

• Target Delay (Multiplier) DAS Delay

• Earliest R-Slot (Minutes) Program Start + 

• Adjust Delay (Minutes) 

• Purge Notification (Minutes) Taxied / GS / GDP/AFP

• AFP Override

• Slot Hold Override

Exempt AFPs

Centers - Origin

• Centers - Origin - the following information is pulled from the GDT Setup Scope tab

• Exempt

• Non-Exempt
Airports - Origin

• Airports - Origin - the following information is pulled from the GDT Setup Scope tab

• Exempt

• Non-Exempt

• Non-Exempt If Distance
Flights

• Flights - the following information is pulled from the GDT Setup Scope tab

Exempt Individual Flights

Advisory/Causal Factors Section

At the top of the section, the Advisory/Causal Factors dropdown menu has two options: 
Preview Advisory and Copy Impacting Condition (see Figure 3 - 83).

Figure 3 - 83: Advisory/Causal Factors Dropdown
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1. Preview Advisory - Opens the Advisory in text format. You must complete the 
Advisory/Causal Factors section and select the Advisory/Causal Factors 
checkbox before viewing the advisory.

2. Copy Impacting Condition - For future use.

You must also fill out the additional fields applicable to OpsNet for this section (see Table 
3-12). 

Note: When you make a revision to a TMI, FSM sets the Advisory/
Causal Factors values to those inherited from the applicable 
program.

Table 3-12: Advisory/Causal Factors Fields

The following fields are optional:

• Respond By - The time by which users must respond to a Proposed TMI. It is normally 
defined as the current time plus 30 minutes. That time is then rounded up to the next 
15-minute time increment. For example, if the current time is 1812, the Respond By 
time is 1845 (1812 + 30 = 1842. Round up to the nearest 15-minute increment is 
1845).

• Valid Until - The time at which the Advisory message expires. This is normally 
defined as the Respond By time plus 30 minutes and rounded up to the end of the hour. 

Field Name Description
Charge To
 Facility Type The facility to which to charge the delay (e.g., Terminal)
 ID Unique identifier for the facility (e.g., Center abbreviation, 

ZAB)
 Not Charged To FAA Identifies whether the delay should be charged to the FAA or 

not.
Impacting Condition
Category Type of issue responsible for the delay (Weather, Volume, etc.)
Cause Specific cause of delay (Fog, Compacted Demand, Air Show, 

etc.) related to the Category selected
Equipment
FAA Equipment Impacting Condition was attributable to FAA 

equipment
Non-FAA Equipment Impacting Condition was attributable to Non-FAA 

equipment
Scheduled Identifies that the Equipment Impacting Condition was due to a 

scheduled outage
Non-Scheduled Identifies that the Equipment Impacting Condition was due to a 

non-scheduled outage
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For example, if the Respond By time is 1845, the message is valid until 1959. The 
message could also expire at the same time the program ends.

• Probability of Extension - Likelihood a Ground Stop will be extended past its current 
end time (Ground Stop Advisory only). The default is Medium.

• Comments - This field is available for any additional comments about the program 
you feel are necessary.

Coversheet Buttons

There are two buttons at the bottom of the coversheet: Send Actual <Program Type> / 
Send Proposed <Program Type> and Close (see Figure 3 - 84).

• Send Actual <Program Type> / Send Proposed <Program Type> - Lists whether 
the program is Actual or Proposed and the program type. 
The format is Send <Actual or Proposed> <Program Type>. 
When you click Send Actual <Program Type> / Send Proposed <Program Type>, 
the FADT files are sent to TPC. The files are then distributed in the next ADL. 
Additionally, it emails the program parameters to all parties involved, including the 
Hub site. If the parameters are for a Proposed Advisory, the Hub site sends out the 
parameters immediately in the next ADL. When you send parameters for an Actual 
Advisory, the Hub site ensures that it has received the associated FADT file with flight 
control times for the program before sending any parameters through the ADL.

Note: The Send Actual <Program Type> / Send Proposed 
<Program Type> button is disabled for FEAs and for any user 
who is not authorized and configured to issue an AFP.

• Close - When you click Close, no action is taken from the GDP Coversheet window.

Figure 3 - 84: Dataset Information in Send Button 

Coversheet Examples

This section provides examples of coversheets.
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Figure 3 - 85: Completed Actual GDP Coversheet (Distance-based)
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Figure 3 - 86: Incompleted Actual GDP Coversheet (Tier-based)
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Figure 3 - 87: Completed Actual GS Coversheet (Yellow Border)
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Figure 3 - 88: Completed Actual Purge Coversheet (Red Border)
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Figure 3 - 89: Completed Actual Compress Slots Coversheet
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Figure 3 - 90: Completed Actual Blanket Coversheet
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Figure 3 - 91: Incomplete Actual AFP Coversheet
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Figure 3 - 92: Completed Actual GDP-UDP Coversheet
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Program Manager

The Program Manager displays after you click Send on the Coversheet/Advisory. The 
Coversheet component sends the Program Manager a list of actions to perform based on 
the type of TMI you sent. The Program Manager shows all of the parallel actions in each 
step, when the step is initiated. The component shows the status of each action as the 
Program Manager performs it.

If an action fails, a dialog displays asking if the Program Manager should perform further 
sequential actions, or stop the process. Other actions executing in parallel are not affected 
regardless of whether you decide to cancel the affected process.

An icon displays in front of each action that the Program Manager performs.

• Unsuccessful actions have a red “X” displayed in front of them
• Actions in progress have a pulsing purple arrow displayed in front of them
• Successfully completed actions have a green checkmark displayed in front of them.

Figure 3 - 93: Program Manager

You can see the details of the processes by selecting View > Details. Detailed messages are 
date/time stamped in the standard DD/HHMMSS format. The details allow you to 
troubleshoot in real time at what point the processing for an action failed. If the Program 
Manager retries an action, the retries are numbered.
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Figure 3 - 94: Program Manager with details

Actions that fail cause a dialog to open which gives the user three options:

• Retry Action - resubmits the request and executes the specified number of retries at 
intervals until the request succeeds or fails again.

• Skip & Continue - proceeds to the next sequential action without completing the 
specified action. This is only available when the action is one in a sequence of actions.

• Cancel - stops the entire send process and an Autosend Cancel Warning displays. 
FSM then activates the Resend menu options based on the type of TMI you are trying 
to send.

Figure 3 - 95: Action Failed dialog box

Cancelling the Program Manager

You have the option to cancel the Program Manager actions at anytime. Clicking Cancel 
at the bottom of the Program Manager stops the program transmission process (including 
the Autosend segments), but does not cancel sending any tasks that have already been sent 
or are in progress. A warning message displays, “Canceling the Program Manager while 
transmitting information may produce unexpected results. Do you still wish to cancel the 
Program Manager?” 
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Figure 3 - 96: Cancellation Message

If the program transmission process has been cancelled in the middle of sending certain 
types of information to the hub site, then the Send (or Purge) button is enabled and you 
can click Send/Purge again. Resend is not available for cancelled programs. The Resend 
menu on the Coversheet is enabled when the GDP_PARAM—or BLKT_PARAM, etc.— 
(for a Proposed TMI) is sent successfully, when the FADT (for an Actual GS/GDP/BLKT/
COMP) is sent successfully, or when the EDCT_COMMAND task (for Purge) is sent 
successfully.

Integrated Program Modeling Components
Integrated Program Modeling (IPM) allows you to model and compare multiple traffic 
management initiatives (TMIs), and to review their impact on other data sets. In the 
current FSM version, IPM provides modeling capabilities only; in other words, you 
cannot send TMIs.

The actual integrated program modeling of Traffic Management Initiatives (TMIs) is 
covered in Chapter 10: Using Integrated Program Modeling. This section familiarizes you 
with the IPM and IPM Setup components:

• IPM Scenario Manager
• IPM Multi Graph
• IPM Setup (opened from Scenario Manager)

• IPM Map

• IPM Bar Graph

• IPM Data Graph

• IPM Demand by Center (Optional)

• IPM Time Line (Optional)

• IPM Flight List (optional)

Opening IPM Mode
From the FSM Control Panel component, use one of the following methods to open IPM 
Mode:

• Click IPM Mode
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• Select View > IPM Mode
• Press Ctrl + I

Scenario Manager and Multi Graph are the two default components that are displayed 
when you open IPM mode (see Figure 3 - 97). Scenario Manager and Multi Graph are 
interactive; any change made in one is dynamically reflected in the other component. 

The IPM Setup and IPM Map components are interactive; any change made in one is 
dynamically reflected in the other component. Like GDT mode, when you model the 
scenarios, the other IPM Setup components reflect the changes made to the IPM Setup and 
Map.

Note: All IPM components are labeled IPM in the component title bar. 
IPM Setup components also include the Scenario number in the 
title bar. 

Figure 3 - 97: IPM Default Components

Scenario Manager Component
The IPM feature combines FSM-implemented TMIs into one or more system-wide views, 
referred to as scenarios. A scenario is a collection of data sets, program types, and 
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parameters for modeled and impact data sets. The scenarios allow you to compare 
programs’ effects on one another and to compare multiple strategies at one time.

The first step in using the IPM tool is to create one or more scenarios in the Scenario 
Manager component (see Figure 3 - 98). The creation of a scenario involves the selection 
of elements that are either going to be controlled through initiatives or may be impacted 
by those initiatives. For example, a GDP(s) may be included in a scenario because you 
want to see its impact on an FCA.
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Figure 3 - 98: Scenario Manager Component After Scenarios are Created

Scenario Manager Menu Bar

The menu bar in the Scenario Manager component contains three menus: File, View, and 
Help.
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1. File Menu

• File > Close - Closes the Scenario Manager window. 

2. View Menu

• View > IPM Multi Graph - Opens the Multi Graph component.

• View > Rename Window - Opens the Rename Window dialog box to change the 
component name in the title bar.

3. Help Menu

• Help > Scenario Manager - Opens the on-line help information specific to 
Scenario Manager.

• Help > Scenario Manager Tab - Opens the on-line help information specific to 
Scenario Manager tabs.

Scenario Manager Panel Buttons

The following action buttons are located below the Menu bar.

• Reload All - Loads the latest ADL data and models the data for all elements in all 
scenarios. This button is enabled only if there are elements present in any of the 
scenarios. Note that Reload All is run automatically each time an element is added to a 
scenario.

• Model All - Applies selected models to all elements in all scenarios. This button is 
enabled only if there are elements present in any of the scenarios. 

• Run Scenario - This button is for future use and is disabled at all times.
• SUB OFF - This button is for future use and is disabled at all times.
• Reset All Parameters - Loads the most current ADL, clears any elements of the 

modeled data, and returns the IPM settings to their defaults.
Scenario Manager Tabs

Scenario Manager consists of four tabs. The Scenario Setup tab provides a high-level view 
of all scenarios and is where you create scenarios. Scenario 1, Scenario 2, and Scenario 3 
provide a detailed view of the scenarios. 
Scenario Setup Tab

Available Box - The Available box lists all available Airport and FEA/FCA elements from 
the FSM server’s list of monitored live elements. The elements in the Available box are 
grouped by Currently Open Data Sets, FEAs/FCAs, and Center. The number of available 
FEAs/FCAs and Centers are listed in parenthesis. For example, Center (17 Airports) 
means there are 17 airports being monitored.

Any program information and update times associated with the element is displayed next 
to the element name. FSM updates the program information and update times for each 
element when it receives new information from the ADL.

Buttons - Five buttons are displayed to the left of each Scenario box. The following 
buttons are used to create the scenarios and manipulate their order within scenarios:
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• > Add Model - Adds selected elements as modeled elements to the specified scenario. 
Use the Shift or Ctrl keys to select and add multiple elements. The elements will be 
added to the bottom of the appropriate Airport or FEA/FCA list. 
The default TMI selection will be the underlying program type; otherwise, by default, 
the elements will be added as GDP-DAS or AFP-DAS.
You can add up to eight elements within each scenario. If you attempt to add more 
elements to a scenario than the maximum allows, an error message reading 
“Maximum number of elements in Scenario has been exceeded” is displayed. 
If you select an element that cannot model a GDP (e.g., Mexican elements) an error 
message reading, “[Element Name] can only be added as an Impact element” is 
displayed. The message also is displayed if you multi-selected elements and at least 
one of them cannot be added. In such a case, none of the selected elements will be 
added. 

• > Add Impact - Adds selected elements as impact elements to the specified scenario. 
Use the Shift or Ctrl keys to select and add multiple elements. An impact data set is 
defined as a data set for which you would like to view the effect of a modeled TMI. 
The added element will be added to the bottom of the appropriate Airport or FEA/FCA 
list. By default, elements will be added as Impact. 

• < Remove - Removes a selected element from a scenario. When you remove an 
element, you lose any associated parameters.

• Move Up - Moves up the position of a selected element. The order shown is the order 
the elements will be modeled. The button is disabled if no element is selected or if the 
selected element is in the top-most position. You cannot move the Airports and FEAs/
FCAs folders. 

• Move Down - Moves down the position of a selected element. The order shown is the 
order the elements will be modeled. The button is disabled if no element is selected or 
if the selected element is in the bottom-most position. You cannot move the Airports 
or FEAs/FCAs folders.

Scenario Box - There is a Scenario box for each scenario labeled Scenario 1, Scenario 2, 
and Scenario 3. Each Scenario box groups elements by Airports or FEAs/FCAs.

Click the dropdown arrow next to the scenario tab label to open a menu with two options: 

• Copy to - Copies the list of elements and all parameters in the source scenario to either 
of the other two scenarios. If an element already exists in the scenario, the copy 
function will replace its parameters in the destination scenario. A warning message 
reading “One or more elements already exits. Clicking Continue will replace 
parameters in the destination scenario” is displayed. Click Cancel (default) to clear the 
warning without making any changes.

• Clear Scenario - Removes all elements from the scenario. A warning message reading 
“Parameters of all elements in Scenario [n] will be lost” is displayed. Click Continue 
to clear the warning and clear all elements from the scenario. Click Cancel (default) to 
clear the warning without making any changes.
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Element Right-Click Menu Options - Right-click an element within a scenario to 
change the type of TMI or open IPM Setup. When you change the management option, the 
new program type is displayed parenthetically next to the element.

The following right-click menu options are available for airport elements:

• GDP - DAS - Changes to GDP-DAS program type
• GDP - GAAP - Changes to GDP-GAAP program type
• GDP - UDP - Changes to GDP-UDP program type
• Ground Stop - Changes to Ground Stop program type
• Purge - Changes to Purge program type
• Impact - Changes to Impact program type
• IPM Setup… - Opens the IPM Setup component

The following right-click menu options are available for airspace elements:

• AFP - DAS - Changes to AFP-DAS program type
• AFP - GAAP - Changes to AFP-GAAP program type
• AFP - UDP - Changes to AFP-UDP program type
• Purge - Changes to Purge program type
• Impact - Changes to Impact program type
• IPM Setup… - Opens the IPM Setup component

Hover your mouse cursor over an element within a scenario to display a tooltip containing 
the following information: Program Type, Scope, Start Time, End Time, Program Rate, 
and Pop-Up Factor. The tooltip is a summary of the information found on the Scenario 1, 
2, and 3 tabs.
Scenario Tabs

There are three scenario tabs that represent each scenario on the Scenario Setup tab. The 
scenario tab is disabled until the corresponding scenario is created. Once you create a 
scenario, the corresponding tab-label parenthetically lists the number of model elements 
and number of impact elements in the scenario. Scenario 1 (2/1) indicates that Scenario 1 
consists of two Model elements and one Impact element (see Figure 3 - 99). 
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Figure 3 - 99: Scenario 1 Tab Layout

Changing Segment Order

The tab is divided into segments that represent each element in the order they are 
displayed on the Scenario Setup tab. You can drag and drop a segment to change the order 
displayed on the tab. Any change will dynamically change the order on the Scenario setup 
tab and the Multi Graph component. The displayed order determines the order that the 
elements are modeled. 

Note: Airports are always modeled before FEAs/FCAs; therefore, you 
cannot move an FEA/FCA above an airport.

Element ID action button - Click to open IPM Setup. This button is disabled for Impact 
elements.

To the right of the Element ID button click the arrow to open the dropdown menu with the 
following options:

• IPM Setup… - Opens IPM Setup for the selected element. Opens with the ADL 
currently opened in the Scenario Manager. Note that ADLs are updated only when 
Reload All is selected or an additional element is added to a scenario. If the ADL is 
behind the current ADL, the Reload All button will be enabled. IPM Setup is disabled 
for Impact elements. Only one instance of IPM Setup can be opened at a time.
You cannot move the IPM Setup component; therefore, in order to return to Scenario 
Manager, you must close IPM Setup. 
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• Copy To - Copies the specific element and its parameters to all the scenarios or a 
specific scenario.

• Move To - Moves the specific element and its parameters to a specific scenario. 
• Load Proposed Parameters - Select to open a secondary dropdown menu to select from 

specific parameter options:

• > Airspace Flow Program - Loads the proposed AFP parameters. This option is 
not available for airports.

• > Ground Delay Program - Loads the proposed GDP parameters. This option is 
not available for FEAs/FCAs.

• > Ground Stop - Loads the proposed Ground Stop parameters. This option is 
not available for FEAs/FCAs.

• Load Actual Parameters - Opens a secondary dropdown menu to select from specific 
parameter options:

• > Airspace Flow Program - Loads the proposed AFP parameters.This option is 
not available for airports.

• > Ground Delay Program - Loads the proposed GDP parameters. This option is 
not available for FEAs/FCAs.

• > Ground Stop - Loads the proposed Ground Stop parameters. This option is 
not available for FEAs/FCAs.

• Open New GDT Mode Instance… - Opens a new instance of GDT Mode for the 
selected element, and copies all parameters to that GDT Mode. This option lets you 
run a program without having to re-enter all the information. All current restrictions on 
the number of GDT Modes allowed are enforced.
GDT Mode is opened with the ADL currently opened in the Scenario Manager. If the 
element’s ADL for the Scenario Manager is later than the current ADL time, the 
Reload button in GDT Mode will be enabled. 
This option is disabled for Impact elements.

• Delete Element - Removes the selected element from the scenario.

Program Type - Click the dropdown box arrow to select available TMI types for the 
element:

• GDP - DAS
• GDP - GAAP
• GDP - UDP
• Ground Stop
• Purge - This program type requires no input on any tab option. If Purge is selected, all 

selections except Impact/Model and Program Type are disabled. 
• AFP - DAS
• AFP - GAAP
• AFP - UDP
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Scope - The scope value is determined by the element’s scope in GDT Mode. If you want 
to change the scope, use IPM Setup.

• For a tier-based scope, the dropdown box will contain the available tier keywords for 
the selected element. 

• For distance-based scope, the dropdown box will contain [x]NM (nautical miles) 
where ‘x’ is an editable field. Use the spinners to adjust the scope in 100 nm 
increments.

Expand or Collapse Segment Arrow

• Click the down arrow toggle button to the left of the Model box to expand the 
segment. By default, Impact elements are collapsed and the Expand/Collapse button is 
disabled as Impact elements cannot be expanded.

• Click the up arrow toggle button to the left of the Model box to collapse the segment. 
By default, Model elements are expanded but you can collapse their presentation. 

Model or Impact - This dropdown box indicates whether the element is a modeled or 
impact TMI. Click the arrow to change the element to either Model or Impact.

Start - Enter the date and time when the TMI should begin.

End - Enter the date and time when the TMI should end.

Data Time - Displays ADL time on which you are modeling and analyzing your TMI. 
This is a read-only field in the current FSM version.

Subs - Indicates whether Subs are on or off. This is a read-only field in the current FSM 
version. 

Program Rate / Pop-Up / Reserve Grid - This is similar to the GDT Mode Program Rate 
/ Pop-Up / Reserve Grid. The primary difference is that you must manually change the PR, 
Pop-up, and Reserve values as the Fill between Hours option is not available. For Fill 
between Hours functionality, open the IPM Setup component and make your changes. 
Any updates will dynamically change the element’s corresponding segment in the Multi 
Graph component.

Multi Graph Component
The Multi Graph component has four tabs. Three tabs with stacked bar graphs for each 
element in the Scenarios 1,2 and 3, and a tab with consolidated metrics for all scenarios 
(see Figure 3 - 100).
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Figure 3 - 100: Multi Graph Component

Multi Graph Menu Bar

The menu bar of the FSM Multi Graph component contains five options: File, View, Bar 
Graph, Display, and Help.
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1. File Menu

• File > Save As - Saves the Multi Graph as a .jpg image to a directory you 
specify.

• File > Print - Prints the Multi Graph currently displayed on your screen.

• File > Close - Closes the Multi Graph component.

2. View Menu
The View Menu consists of 15 checkboxes and two additional menu items. Check 
the box to view the information and uncheck the box to hide the information.

• View > Rename Window - Displays the Rename Window dialog box used to 
change the component name in the title bar. Enter the desired component 
name, and click OK to change the title bar heading. Click Cancel to close the 
Rename Window dialog box without making any changes.

• View > Set Tabs Displayed - Dynamically shows and hides specific coloring 
schemes for the Bar Graph component. The selected scheme controls all of the 
bar graphs.

• View > Current Data - Replaces GDT Mode’s View > Arrival Data and View 
Departure Data options. The concept of viewing arrival and departure data is 
not possible in IPM Mode since you are simultaneously viewing both airspace 
and airport traffic.

• View > Show Cancellations - Displays cancelled flights in the color cyan. 
Cancelled flights are not automatically displayed in the graph. Showing 
cancelled flights is useful to compare the original demand with the demand 
after the cancellations. To differentiate between cancelled and regular flights, 
use the Arrival Status tab to color your flights.

• View > Show Unassigned Slots - Displays all unassigned slots in the color white 
for a GDP or AFP.

• View > Show Legend - Displays the appropriate color legend associated with 
the tab option you are viewing. If you click the legend button on the Bar 
Graph, FSM dynamically selects the checkbox for Show Legend.

• View > Time Indicator - Displays an orange vertical line that remains fixed at 
the current time. Like the FSM Time Line, the Bar Graph Component also 
tracks time.

• View > Cumulative GDP/AFP Indicators - Displays a brown solid vertical line 
representing the cumulative start and end time for a GDP or AFP.

• View > Event GDP/AFP Indicators - Displays a brown vertical dashed lines to 
indicate the start time and end time of a current GDP or AFP. The program 
time indicators are displayed automatically when a program goes into effect at 
the monitored data set. Note: If the cumulative time and the event time are the 
same, the solid brown line (cumulative time) will take precedence over the 
dashed brown line (event time).
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• View > GS Indicators - Displays a yellow vertical lines to indicate the start time 
and end time of a current GS. The GS time indicators are displayed 
automatically when a GS goes into effect at the monitored airport.

• View > Model Flow Rates - Displays a thin colored line that represents the 
model flow rate independently of the time-bin convention, enabling you to 
visualize arrivals and departures as a dynamic flow rate. The color of the thin 
line color unique to each scenario. Blue represents Scenario 1, Magenta 
represents Scenario 2, and Yellow represents Scenario 3.

• View > ADL AAR Line - Displays a white horizontal line that runs through the 
graph representing the current Airport Arrival Rate (AAR) for the monitored 
airport or airspace data set. The ADL AAR (shown by default) is a fixed AAR 
sent by the FAA Air Traffic Control System Command Center (ATCSCC) to 
advise of the number of arriving aircraft a data set can accommodate at any 
given interval of time. The AAR changes according to the interval of time 
being displayed. For example, an AAR of 60 per hour = AAR of 15 per quarter 
hour. Only ATCSCC users can change the ADL AAR.

• View > Model Program Rate - Displays a user-specified Program Rate as a 
dashed white line. You use the Model Program Rate for modeling and analysis; 
you can change this according to program needs.

• View > Time Increment>15 Minutes, 30Minutes, 60 Minutes - Displays a bar 
graph capacity and demand information based on the time-bin value selected. 
The default time increment is 60-minutes. If you click one of the time bin 
buttons on the Bar Graph, the same increment displays selected on the 
associated menu item.

• View > Hours Shown > 2/3/4/5/6/8/10/12/14/16/18/20/22/24/36 Hours - The 
default data display is 10 hours. You can specify the number of hours displayed 
in the Bar Graph to see more or less flight data. For example, you may want to 
view the AAR in 15-minute increments, which is difficult to see on a graph 
with 10 hours’ worth of data. To change the number of hours in the graph, 
select View > Hours Shown > X Hours (X = number of hours). The graph 
automatically updates to show the number of hours specified.

3. Bar Graph Menu

• Bar Graph > Track Time - Makes the graph move as the time changes. When 
you track time in this way, the second bar on the graph is always the current 
time. When you uncheck the box, the bars do not move, but you can still use 
the Time Indicator to determine the current time on the graph.

4. Display Menu

Display Menu changes the data shown in the Bar Graph to show demand based on 
the following display options. Selecting a display option means that the selected 
display option is applied across all scenario tab displays.
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• Display > ETA / ENTRY - Displays the Estimated Time of Arrival (ETA) for 
airport only, and Estimated Element Entry Time (ENTRY) for airspace only. 
This is the default display mode.

• Display > BETA / BENTRY - Displays the Base Estimated Time of Arrival 
(airport only) and Based Element Entry Time (airspace only).

• Display > OCTA - Displays the Original Controlled Time of Arrival.

• Display > CTA - Displays the Controlled Time of Arrival.

5. Help Menu

• Help > Multi Graph - Opens the on-line help for the Multi Graph component.
Multi Graph Panel Buttons

The eight buttons in the Multi Graph window are identical to the standard GDT Mode Bar 
Graph buttons. The behavior of the panel buttons differs from GDT mode in that any 
action affects all bar graphs in all scenarios. For example, if you click the Cancellations 
toggle button, cancelled flights are displayed on each bar graph in Scenario 1, Scenario 2, 
and Scenario 3. 

• Save As - Saves the Multi Graph as a .jpg image in a directory that you specify.
• Print - Prints the Multi Graph.
• 15, 30, and 60 - Clicking the 15, 30, or 60 time-bin buttons displays each Bar Graph’s 

capacity and demand information based on the time-bin value selected. The default 
time increment is 60-minutes.

• Legend - Displays the color legend on each Bar Graph. The same color legend will be 
applied to all Bar Graphs on the Multi Graph.

• Model Flow Rate - Displays the Model Flow Rate line for each Bar Graph.
• Cancellations - Displays the cancelled flights on each Bar Graph.

Multi Graph Tabs

There are four tabs: Scenario 1, Scenario 2, Scenario 3, and Metrics.
Scenario Tabs

There are three scenario tabs, one for each scenario created on the Scenario Setup tab.    
There is a one-on-one correspondence between the number of datasets in a scenario and 
the number of bar graphs displayed for each scenario. Once you create a scenario, the 
corresponding tab label parenthetically lists the number of models and number of impacts 
in the scenario. Scenario 1 (2/1) indicates that the scenario consists of two Model elements 
and one Impact element (see Figure 3 - 101).
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Figure 3 - 101: Number of Multi Graph’s Model/Impact Elements

Below the tabs, the Flow Rate Legend has a checkbox and color unique to each scenario. 
The flow rate option is disabled if the scenario does not have any elements.

The Flow Rate Legend allows you to display the flow rate of an element across the other 
scenarios. If an element is in multiple scenarios, the element’s associated flow rate is 
displayed on the scenario tab being displayed (see Figure 3 - 102).

Scenario flow rates are layered from top to bottom using the following precedence: 
Scenario 1, Scenario 2, and Scenario 3. For example, if Scenario 1 and Scenario 2 have the 
same flow rate, the line would be blue. If Scenario 2 and Scenario 3 had the same flow 
rate, the line would be magenta.

Figure 3 - 102: Multi Graph Flow Rate Legend for Multiple Scenarios

Bar Graph

Each Scenario tab displays a bar graph for each element in the scenario. Impact or Model 
is displayed to the right of the element name. The bar graphs are in the same order as they 
are displayed in the Scenario Manager. The bar graphs are the standard FSM bar graphs; 
however, there some differences to accommodate for the display of multiple bar graphs:
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• The horizontal bar at the bottom of the window simultaneously scrolls all elements.
• A single set of Color tabs (View > Set Tabs Displayed) controls all of the bar graphs.
• Only color options with a common legend are enabled.
• The Dynamic Carriers and Recalculate buttons found on the Carrier tab in GDT’s 

Bar Graph has been removed from the Multi Graph Carrier tab.
Metrics Tab

The Metrics grid contains expandable trees to simultaneously display consolidated 
statistics across all scenarios (see Figure 3 - 103). Use different combinations of the 
Grouping and Display options to analyze the data.

Figure 3 - 103: Metrics Tab

Grouping

Four Grouping options are displayed at the top of the Metrics tab. The selected grouping 
determines which statistics are displayed. 

If you click Resource, the following statistics are displayed:

• Average Delay
• Maximum Delay
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• Total Delay
• Total Flights
• Affected Flights
• Unrecoverable Delay
• % Unrecoverable Delay
• Delay Variance
• Immediate CTs Sent

If you click Arrival or Carrier, the following statistics are displayed:

• Maximum Delay
• Total Delay
• Total Flights
• Affected Flights

If you click Departure, the following statistics are displayed:

• Average Delay
• Maximum Delay
• Total Delay
• Total Flights
• Affected Flights
• Immediate CTs Sent

Display

Three Display options are displayed below the Grouping section. Not all Display options 
are available for all Groupings:

• Number of Elements (default 5) – Not available for Grouping by Carrier
• Number of Airlines (default 5) – Not available for Grouping by Arrival, Departure, or 

Resources)
• Number of CTs (default 10) – Not available for Grouping by Arrival or Carrier

Use the arrows to select the top number of Elements, Airlines, or CTs to be included in the 
metrics. For example, an Airline value of seven means that the statistics for the top seven 
airlines will be displayed for each scenario. All airlines that fall outside of the selected 
parameters will be grouped together as “All Others”. 

IPM Setup Components
The Integrated Program Modeling (IPM) Setup component allows you to review detailed 
statistics for an element’s modeled data. IPM Setup is very similar to GDT Setup. The 
main distinction is that you can only model programs in IPM. You cannot run and issue 
TMIs from IPM Setup. Changes made while in IPM Setup are reflected in the Scenario tab 
of the Scenario Manager component.

This section familiarizes you with the IPM Setup components:
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• IPM Setup
• IPM Map
• IPM Bar Graph
• IPM Data Graph
• IPM Time Line (Optional)
• IPM Demand by Center (Optional)
• IPM Flight List (see Chapter 6: Viewing Flight Information)

Opening IPM Setup

Unlike GDT Setup, only one instance of IPM Setup can be opened at one time. You must 
be in IPM Mode’s Scenario Manager component to open IPM Setup. Use one of the 
following three methods to open IPM Setup:

1. On the Scenario Setup tab, right-click an element in a Scenario box, and select 
IPM Setup... from the menu options (see Figure 3 - 104).

Figure 3 - 104: Right-click Element in Scenario Box to Open IPM Setup

2. On the Scenario 1, Scenario 2, or Scenario 3 tab, click the Element ID action 
button (see Figure 3 - 105). This button is disabled for Impact elements.
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Figure 3 - 105: Click Element Action Button to Open IPM Setup

3. On the Scenario 1, Scenario 2, or Scenario 3 tab, click the arrow located to the 
right of the Element ID action button. Select IPM Setup... from the dropdown 
menu (see Figure 3 - 106).

Figure 3 - 106: Right-click Element Drop-Down Arrow to Open IPM Setup

IPM Setup opens with the ADL currently opened in the Scenario Manager. Note that 
ADLs are updated only when Reload All is selected or when an additional element is 
added to a scenario. If the ADL is behind the current ADL, the Reload All button will be 
enabled. 

You cannot move the IPM Setup component; therefore, in order to return to Scenario 
Manager, you must close IPM Setup. 

Four default IPM components are opened for the selected data set (see Figure 3 - 107). 
The IPM Setup and IPM Map component are interactive; any change in one is 
dynamically reflected in the other component. Other IPM components reflect changes 
made to the IPM Setup and IPM Map when you model the TMI. 
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Note: All IPM components are labeled IPM in the component title bar. 
IPM Setup components also include the Scenario number in the 
title bar.

Figure 3 - 107: IPM Setup Default Components

IPM Setup Component Tabs
The IPM Setup window is similar to the GDT Setup window. It consists of a menu bar, 
seven action buttons, the Program Type selection box, SUBS Indicator, and three tabs that 
focus on different areas of information (see Figure 3 - 108). 
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Figure 3 - 108: IPM Setup Parameters Tab

Select the type of TMI you want to model from the Program Type selection box:

Airports have the following Program Types:

1. GDP - DAS - The default Program Type for airports. Not available for FCAs.
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2. GDP - GAAP - This program type is similar to GDP-DAS except it automatically 
sets the Delay Assignment Mode to GAAP.

3. GDP - UDP - This program type addresses the mix of scheduled and unscheduled 
(i.e., pop-ups) demand based on the following parameters: number of reserved 
pop-ups, target delay multiplier, and delay limit.

4. Ground Stop - Unlike ground delay programs, which delay flights because of a 
reduced AAR, the Ground Stop function prevents flights from departing until 
further notice. Not available for FCAs.

5. Purge - Cancels a GDP or GS, releasing all delay on included flights. 

FCAs/FEAs have the following Program Types:

1. AFP - DAS - Airspace Flow Program available only for airspace data sets. This 
program is used to control traffic flow through an FCA.

2. AFP - GAAP - Airspace Flow Program available only for airspace data sets. This 
program type automatically sets the Delay Assignment Mode to GAAP.

3. AFP - UDP - Airpspace Flow Program available only for airspace data sets. This 
program type addresses the mix of scheduled and unscheduled (i.e., pop-ups) 
demand based on the following parameters: number of reserved pop-ups, target 
delay multiplier, and delay limit.

4. Purge - Cancels a AFP, releasing all delay on included flights. 

Note: Blanket, Compress Flights, Compress Slots, and Airborne 
Holding program types are not available in IPM Setup.

The IPM Setup component tab options and features change based on the Program Type 
selection. The three IPM Setup tabs are Parameters (default selection), Scope, and 
Modeling Options.

This section discusses the IPM Setup component based on each tab option. Closing the 
IPM Setup component closes all the IPM components for the data set. The IPM Setup 
panel displays the substitution status the data set: SUBS: ALL ON, ALL OFF
IPM Setup Panel Menu Bar

The menu bar in the IPM Setup component contains three options: File, View, and Help.

1. File Menu

• File > Load Proposed Parameters - Opens a secondary dropdown menu to 
select from specific parameter options:

-   > Airspace Flow Program - Loads the proposed AFP parameters.

-   > Ground Delay Program - Loads the proposed GDP parameters.

-   > Ground Stop - Loads the proposed Ground Stop parameters.

• File > Load Actual Parameters - Opens a secondary dropdown menu to select 
from specific parameter options:
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-   > Airspace Flow Program - Loads the actual AFP parameters.

-   > Ground Delay Program - Loads the actual GDP parameters.

-   > Ground Stop - Loads the actual Ground Stop parameters.

• File > Open Parameters File - Opens the PARAM_DIRECTORY File in file 
explorer. Select the parameters file and click Open to view the Parameters 
Files.

• File > Save As - Not available in the current version.

• File > Close - Closes the IPM Setup component and all the complimentary IPM 
components for that particular element.

2. View Menu

• View > Rename Window - Displays the Rename Window dialog box and allows 
you to change the component name in the title bar. 

There are six additional display options under the View menu. If you close a 
component and want to reopen it, use the View menu options to select and reopen 
the desired component.

• View > IPM Data Graph - Displays the IPM Data Graph component

• View > IPM Map - Displays the IPM Map component

• View > IPM Bar Graph - Displays the IPM Bar Graph component

• View > IPM Time Line - Displays the IPM Time Line component

• View > IPM Flight List - Displays the Flight List for the monitored airport, 
FEA, or FCA.

• View > Show Demand - Displays the Demand by Center component.

3. Help Menu

• Help > IPM Setup - Opens the on-line help for the IPM Setup component.

• Help > IPM Setup Tab - Select to open the on-line help for the IPM Setup tabs 
(Parameters, Scope, and Modeling Options).

IPM Setup Panel Buttons

The seven action buttons are Save (the button with the disk icon), IPM Map, Multi Graph, 
Reload All, Model All, Close, and Reset Parameters. These buttons are active when the 
feature is available.

• The Save button is not available in the current version.
• Clicking IPM Map opens the IPM Map.
• Clicking Multi Graph opens the Multi Graph component.
• Clicking Reload All causes FSM to load the latest ADL data into the IPM mode. You 

then can model the program using the latest data and make any adjustments you think 
are necessary.
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• Clicking Model All models and updates your changes in all IPM components for 
analysis and review. After you make any modification to any portion of the IPM Setup 
component, which FSM indicates by highlighting the tab window area with a red 
border, the Model All button becomes active. After clicking Model All, your IPM 
Setup component also resets and the red border no longer is displayed until you make 
an additional change.

• Clicking Scenario Mgr closes all IPM Setup components. It does not close the 
Scenario Manager or Multi Graph components.

• Clicking Reset All Parameters loads the most current ADL, clears any elements of 
the modeled data, and returns the IPM settings to their defaults.

Note: The Run and Subs OFF buttons found in GDT Setup are not 
part of the current functionality of IPM Setup.

Parameters Tab

The Parameters tab is active for all program types and is the default tab that opens when 
you open the IPM Setup component. Within this tab you can specify parameters including 
the program time, program rate, and general options for GAAP delay and Purge 
notifications. Options which are not features for certain program types are disabled.

You can edit Start and End time parameters in the Program Time Options section for all 
program types. 

• Start - Enter the date and time when the TMI should begin.
• End - Enter the date and time when the TMI should end.

The default End time for Ground Stops will adjust to 15 minute increments on the hour 
(00, 15, 30, and 45). All other programs will have a default end time on the 14, 29, 44, or 
59th minutes. The End time for Ground Stops will be a time increment that results in at 
least a one hour GS. For example, if the Ground Stop Start time is 1902, the default End 
time will be 2015. 

If you are using the slider to select the End time for a Ground Stop, the slider will adjust to 
15 minute increments on the hour. Using the slider to adjust the End time for all other 
programs will result in an End time on the 14th, 29th, 44th, and 59th minutes.You can 
populate the times in the text box to the right of the time field or use the slide bars, which 
automatically fill the time into the text box. 

The Purge Flights section of the IPM Setup component contains two checkboxes that 
allow you to purge flights before a revision start time and after a revision end time as 
appropriate for AFP/GDP revisions.

• Before Revision Start - This checkbox allows you to specify if control times should be 
purged off of flights between the revision start time and the cumulative start time. 
Before Revision Start is disabled if a GDP or AFP does not exist for a current data set. 
The purge Before Revision Start is enabled only when the selected GDP/AFP start 
time is later than the existing program’s Cumulative Start Time. This option is 
dynamically enabled and disabled with the mouse release action on the slider bar.
FSM User Guide, Version 9.00 3-143



Understanding Components
Note: FSM will reset the Cumulative Start Time to the new (later) start 
time and determine which flights are no longer controlled due to 
the change.

• After Revision End - This checkbox allows you to specify if control times should be 
purged off of the flights between the revision end time and the cumulative end time. 
After Revision End is disabled if a GDP or an AFP does not exist for the current data 
set. The purge After Revision End is enabled when the selected GDP/AFP end time is 
earlier than the existing program’s Cumulative End Time. This option is dynamically 
enabled and disabled with the mouse release action on the slider bar.

Note: FSM will reset the Cumulative End Time to the new (earlier) end 
time and determine which flights are no longer controlled due to 
the change.

• Compress to Last CTA - This functionality is available during an AFP (initial and 
revision), GDP (initial and revision), and Compression. When checked, all flights that 
have control times are eligible for compression. When unchecked, only flights with 
CTAs through the End time of the program are compressed.

• Data Time - This functionality is the ADL time on which you are modeling and 
analyzing your TMI. Data Time is a read-only field in the current version of IPM 
Setup. The default ADL time always displays in the IPM Setup title bar.

The Program Rate section is active for all Program Types except Compression, Ground 
Stop, Blanket, and Purge. The Program Rate table is oriented horizontally so that the hours 
are displayed across the top of the table (see Figure 3 - 109). The hours shown in the 
program rate table, range from one hour prior to the current time to 35 hours ahead of the 
current time. To view the hours across the table, use the horizontal scroll bar directly 
below the table.

Figure 3 - 109: IPM Setup - Program Rate Section

There are three rates that can be adjusted: the Program Rate, Pop-Up rate, and Reserve 
rate. Each rate is represented by a row and is an option in the Fill dropdown menu.
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Select a rate type from the Fill dropdown menu and fill in the associated rates by entering 
a rate in the With box, using the From Hour and Through Hour to select the time frame, 
and clicking Fill.

There are additional features in the Program Rate section of the Parameters tab that are 
not included in the Modify Program Rate component:

• Load Times - Click to fill the From Hour and Through Hour fields to match the 
times set in the Program Time Options section. If you click Fill after entering the 
Program Rate and hours, FSM automatically fills in the appropriate hour columns. 

• Pop-up row - This row is only available for a DAS program. It is disabled and 
populated with dashed for all other programs. The Pop-up Factor accounts for 
potential “pop-up” flights. For example, if you change the Program Rate for a certain 
number of hours to 40 with a Pop-up Factor of 5, the Program Rate that FSM uses to 
run the GDP or AFP is 35. This leaves room for any unknown flights that show up in 
that hour because the actual capacity of the airport is 40. 

• Reserve slots row - This rate is only available for Unified Delay Programs, that is, 
GDP-UDP and AFP-UDP. It is disabled and populated with dashed for all other 
programs. You can manually enter values or use existing historical demand predictions 
found in the Load Historical Pop-Up window.

• Historical Pop-Ups - Click to open the Load Historical Pop-Up window where you 
can select specific historical demand predictions which will be used for the TMI. This 
window is similar to the view-only window accessed via Utilities > Historical Pop-up 
Demand (for more detailed information, see Chapter 5: Historical Pop-Up Demand). 
However, you can adjust the values utilized while still having the predictions visible 
for reference. High, Medium, and Low represent confidence levels for the values as 
listed in the ADL. Note that predictions fewer than ten per hour may include a decimal 
value. Predictions greater than ten per hour are represented by whole numbers.

To set the Reserve rate in the Historical Pop-Up window:

1. From the Program Type dropdown list, select GDP-UDP or AFP-UDP. The 
Historical Pop-Up button and the Reserve row will become enabled.

2. Click Historical Pop-Up. The Load Historical Pop-Up window opens.

3. Select the High, Medium, or Low radio button.

4. Click Fill With. The cells in the Load With row will be populated with the 
historical values for the selected confidence level (see Figure 3 - 110). Note that 
the Fill With functionality is not available for FCAs.

1. Click OK. The window closes and the rates are displayed in the Program Rate’s 
Reserve row.

Note: Even though you used the Fill With functionality, you can 
manually edit specific hours in the Programs Rates table or the 
Load Historical Pop-Up window. Changes made to the Program 
Rates table will be reflected in the Historical Pop-Up dialog 
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box; likewise, changes made in the Historical Pop-Up dialog 
box will be reflected in the Program Rates table.

Figure 3 - 110: Load Historical Pop-Up Window

The menu bar contains two options: File and Help.

1. File

• Print - Prints the Load Historical Pop-Up window as displayed on your screen

• Close - Closes the window

2. Help - Opens online help specific to the Load Historical Pop-Up window

The window contains the following action buttons:

• OK – Click to save your changes and close the dialog box
• Cancel – Click to close the dialog box without saving your changes
• Help – Click to display a pop-up window with a brief description of the component

To set the Pop-Up Factor for a program from the IPM Setup component.

1. Select the Parameters tab on the GDT Setup component.

2. Select Pop-Up Factor from the Fill dropdown (see Figure 3 - 111).

Figure 3 - 111: Program Rate Pop-Up Factor
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3. Enter the number of Pop-Up slots you want FSM to create in With.

4. Enter the hours for this Pop-Up Factor in From Hour and Through Hour.

5. Click Fill. FSM enters the Pop-Up Factor specified into the appropriate hours (see 
Figure 3 - 112). 

Figure 3 - 112: Pop-Up Factor Filled

6. Select the number in the Pop-Up Factor column. FSM enables the Edit 15 button.

7. Click Edit 15.
The 15 Minute Pop-Up Factor window displays.

8. Enter the Pop-Up Factor you want for each 15 minute increment of the selected 
hour.

9. Click OK. The edited Pop-Up Factor is highlighted green (see Figure 3 - 113).

Figure 3 - 113: Pop-Up Factor Edited in 15 Minutes Increments

You may set the following parameters within the General Options section of the 
Parameters tab:

Note: The fields are available based on the Program Type you select. 
For more detailed information, see Chapter 2: Text Fields 
Display Conventions.
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• Delay Limit (Minutes) - Allows you to set the amount of delay (in minutes) for flights 
controlled by a GDP - GAAP. The default Delay Limit is 180 minutes. If an ADL 
contains GDP parameters that include a Delay Limit, that limit displays when you use 
the Load Parameters feature. Click Default to reset the values to the default times.

• Target Delay (Multiplier) – This parameter is used to compute pop ups’ additional 
delay as compared to other flights. More specifically, it is multiplied by the average 
delay found in the DAS Delay Table for the 15-minute time bin in which the flight 
wants to arrive (ETA). 
For example, if flight A is a pop-up and wants to arrive at 1535, the TFMS Core will 
find the average delay for known flights in the 1530-1544 time bin and multiply that 
delay by the Target Delay (Multiplier). So if the average delay in that 15-minute time 
bin is 20 minutes and the Target Delay = 1.5, Flight A’s delay is calculated to be 20 x 
1.5 = 30 minutes and will receive a CTA of 1535 + 30 = 1605. 
This is not an editable field for DAS or GAAP programs. For DAS programs, the 
target delay multiplier is always 1.0 and cannot be edited. For GAAP programs, the 
target delay multiplier is not applicable as pop-up flights are assigned to unassigned 
slots or given the max additional delay. 
For UDP programs, the default value is 1.0. Use the arrows to select a new value or 
type a new value. As you adjust the number of minutes, the time will increase in the 
adjacent ddhhmm field. Valid values are 1.0 to 9.9. Click Default to return to the 
default value.

• Earliest R-Slot (Minutes) - This parameter is used internally within FSM to prevent 
allocating any reserved slots that are too close to the current time to be usable. From a 
system point of view, the only restriction on the Earliest R-Slot is that it be earlier than 
the end time of the GDP. 
Enter the Earliest R-Slot as a number of minutes that will be added to the TMI Start 
Time (Event Start Time). For example, if you think the pop-up traffic for the first 2 
hours of your program has already materialized, you would not want to reserve slots 
for pop-up flights in those hours. With the Earliest R-Slot parameter, you can control 
when you want reserved slots to begin for pop-up flights by adding 120 minutes to the 
Program Start.
Zero is the default value. Use the arrows to select a new value or type a new value. 
Click Default to reset the values to the default times.

• Adjust Delay (Minutes) - This parameter is available only when using the Blanket 
Program Type. You can use Blanket Adjust Delay to add or release a specified amount 
of time from selected criteria. You should only use Blanket during a GDP. For 
example, if you had a hole in the traffic flow, you could select centers, distance, fixes, 
or aircraft types and enter in a negative number to release some delay or release all 
delay by clicking Release. Release fills in the Adjust Delay text field with –999, 
which is equivalent to releasing all delay. Alternatively, you can add delay to the 
selected criteria by entering the amount of extra delay in minutes. Click Default to 
reset the values to the default times.

• Purge Notification (Minutes) - These options are only available when a Purge 
program type is selected. You may change the values for modeling purposes; however, 
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the default values will be used for the purge. To model the purge using different 
values, you may either enter the number of minutes in the fields, or use the spinner 
controls to change the values in five-minute increments. These values may not be 
negative. Click Default to reset the values to the default times.

Note: Changing Purge Notification (Minutes) values is for modeling 
only. The actual purge uses the default values.

• AFP Override - Gives priority to the current AFP over previously issued AFPs. FSM 
assigns control times based on the current modeled AFP and overrides any other 
control times that flights received due to previous AFPs. These control times do NOT 
override control times assigned due to airport based TMIs.

• Slot Hold Override - You can change parameters only for RBS++ and Compression. 
The Slot Hold Override field allows you to override an airline’s slot holding status by 
either typing an airline’s three-letter identifier directly in the text field next to Slot 
Hold Override or click Select to open the Select Slot Holding window (see Figure 3 - 
62). The Select Slot Holding window lists the airlines currently holding slots at the 
data set constraint and allows you to select which airline(s) to override. Select the box 
next to each airline to override its slot holding status and include the slot in 
compression. When you check a box, that airline’s slot hold status is ignored. Click 
Clear to remove entries.

• Exempt AFPs - To minimize the number of changes to control time for flights that are 
controlled by a GDP and to minimize the change in the demand at the AFP, you may 
exempt AFP flights from GDP. Selected flights will be treated as previously controlled 
regardless of their AFP exemption status and given the first available airport arrival 
slot after their estimated arrival time, which is based on their current AFP EDCT and 
any airline submitted flight delays. FSM will make an effort not too change the 
assigned departure time (CTD) for the flight, subject to capacity constraints at the 
airport and any known flight delays. Click Clear to remove entries.

You can select parameters for Arrival Fix, Aircraft Type, and Carrier for all program 
types except AFP - DAS, Compress Flights, and Airborne Holding in the Include Only 
Options section. 

• Arrival Fix - Use the dropdown menu to determine which Arrival Fixes to include in 
the operation. You can select ALL (default value) or one individual fix.

• Aircraft Type - Select ALL (default value), Jet Only, or Prop Only from the Aircraft 
Types dropdown menu to specify the aircraft types included in the operation.

• Carrier (Major) - Select ALL (default value) to include all carriers at that airport. If 
you want to include only a single airline, type the carrier’s 3-letter code into the text 
box. The application does not allow you to include only one carrier without including 
its sub-carriers. Likewise, you cannot include one sub-carrier. Typing a carrier code 
into this field always includes the major and its sub-carriers.

Scope Tab

In IPM Setup, the Scope tab is active for all Program Types except Purge. The Scope tab 
has two types of exemption criteria for airports, Tier-based and Distance-based. In the 
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Select By dropdown box, select either a Tier or Distance based initiative. FCAs can only 
issue tier-based AFPs; therefore, distance is not an option.
Scope Tab for Data Sets with Select By Tier Selected

When you select Select By Tier, the following panel is displayed (see Figure 3 - 114). The 
panel contains four sections where you can modify parameters: Centers - Origin, Airports 
- Origin, Airports - Destination, and Flights. 

Figure 3 - 114: IPM Setup - Exempt by Tier Scope Tab

Centers - Origin: You can select the centers you want to include in the program or select 
a Tier level from the Scope dropdown menu:

• Scope: Select a tier option from the dropdown menu. Selecting a Tier, automatically 
selects the associated centers. The total number of centers selected displays to the right 
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of the Tier selection. Click Clear to erase all centers with checkmarks and return the 
included tier selection back to Manual.

• Manual Center Selection: Click the checkbox to select or deselect individual centers to 
include in the program.

Note: The recommended scope for AFP programs is ALL + Canada

Airports - Origin: This section of the panel allows you to exempt and non-exempt 
airports:

• Exempt: You can exempt certain departure airports from a TMI. Enter the three or 
four-letter airport code to exempt that airport. Separate airports with a space or a 
comma. The maximum number of exempt airports you can enter is 24.

• Non-Exempt: You can include certain departure airports for a TMI that were not 
originally included based on the Center section criteria. Select Manual from the 
dropdown, then enter the three or four-letter airport code to include that airport. 
Separate airports with a space or a comma. The maximum number of non-exempt 
airports you can enter is 16.

Airports - Destination: This section of the panel is only for airspace datasets and is 
disabled for airport data sets.

• Exempt - You can exempt certain arrival airports from an AFP. Enter the three or four-
letter airport identifier to exempt flights that are arriving from that airport from 
departure delay. Separate airports with a space, comma, semi-colon, or colon. 

Flights: This section of the panel allows you to exempt, i.e., give no departure delay, to 
priority flights as well as select Exempt by Departure Status or time.

• Exempt Active Flights Only (By Status): Selecting this option gives exemption status 
only to active flights, therefore, all flights within the scope of the program that are not 
active are considered Non-Exempt. This option is selected by default when there is a 
Ground Stop in place.

• Exempt All Flights Departing Within ‘XX’ Minutes: When exempting flights based 
on departure time, you may adjust the time either manually by clicking in the field and 
typing in a value enter a value, or by using the spinner controls (the up/down arrows to 
the right of the field) to change the value in five-minute increments. This value must 
be greater than or equal to 0. Selecting this option will exempt all flights with ETDs 
within XX minutes of the Data Time. This option is selected by default when there is 
no Ground Stop in place. 

• Exempt Individual Flights: Enter a flight’s ACID to exempt priority flights.
Scope Tab for Airport Data Sets with Select By Distance Selected

When you select Select By Distance, the parameters for Distance are displayed. (see 
Figure 3 - 115). The Distance panel contains four sections in which you can modify the 
parameters: Distance, Centers - Origin, Airports - Origin, and Flights.
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Figure 3 - 115: IPM Setup - Scope Tab Exempt By Distance

Distance: When the Distance Panel first displays, the default distance is 199 nautical 
miles. You can enter your distance range directly into the Distance text box or click and 
drag the sliding bar for the desired distance; this automatically fills in the distance. 
Remember, anything changed in the Setup panel is reflected in the IPM Map. You can 
change the distance range from the Setup panel and simultaneously view the range ring 
and what centers/airports are affected on the IPM Map.

Centers - Origin: You can enter centers to be Exempt (have higher priority than Non-
Exempt) or Non Exempt.

• Exempt: You can exempt certain centers from a TMI that were originally partially, or 
entirely, included based on the Distance criteria. Enter the three or four-letter center 
identifier to exempt a particular center. Separate multiple centers with a space or a 
comma. The maximum number of exempt centers you can enter is 36.

• Non-Exempt: You can include certain centers from a TMI that were not included 
originally based on the Distance criteria. Enter the three or four-letter center identifier 
to include a particular center. Separate multiple centers with a space or a comma. The 
maximum number of non-exempt centers you can enter is 16.
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Airports - Origin: This section of the panel allows you to include and/or exempt airports.

• Exempt: You can exempt certain departure airports from a TMI. Enter the three or 
four-letter airport code to exempt that airport. Separate multiple airports with a space 
or a comma. The maximum number of exempt airports you can enter is 24.

• Non-Exempt: You can include certain departure airports from a TMI that were not 
included originally based on the Distance criteria. Enter the three or four-letter airport 
code to include that airport. Separate multiple airports with a space or a comma. The 
maximum number of non-exempt airports you can enter is 16.

• Non-Exempt if Distance: Use this field to include Canadian airports. If you select a 
Canadian airport, FSM includes that airport if it falls within the selected distance 
parameter.

Flights: This section of the panel allows you to exempt, i.e., give no delay, to priority 
flights as well as select Exempt by Departure Status or Time.

• Exempt Active Flights Only (By Status): Selecting this option gives exemption status 
only to active flights, therefore, all flights within the scope of the program that are not 
active are considered Non-Exempt. This option is selected by default when there is a 
Ground Stop in place.

• Exempt All Flights Departing Within ‘XX’ Minutes: When exempting flights based 
on departure time, you may adjust the time either manually by clicking in the field and 
typing in a value enter a value, or by using the spinner controls (the up/down arrows to 
the right of the field) to change the value in five-minute increments. This value must 
be greater than or equal to 0. Selecting this option will exempt all flights with ETDs 
within XX minutes of the Data Time. This option is selected by default when there is 
no Ground Stop in place. 

• Exempt Individual Flights: Enter a flight’s ACID to exempt priority flights.

IPM Map: Click this action button to bring the element’s IPM Map to the forefront.
Modeling Options Tab

The Modeling Options tab is available for all program types with the exception of Purge. 
Once the parameters are set, you may want to determine which parameters run the best 
TMI. In this case, you can take advantage of FSM’s powerful analysis capabilities to view 
the results of the parameters you have selected before actually running the operation.

You can use the Modeling Options tab in the IPM Setup component as an analysis tool. 
There are four GDP, three AFP, and three GS operations, which analyze the results for any 
program. You can select these options from the dropdown menu that displays next to 
Power Run By (see Table 3-13). You use the Power Run function to determine whether 
you need to modify the parameters. When any Power Run is generated, FSM 
automatically saves the Power Run to a file.

To view a scenario, select the type of program to model in the Power Run By dropdown 
menu and click Model All. Model displays the effects of potential operation parameters 
and how traffic at the airport would be affected by using these parameters for an actual 
program in all IPM components. Review the program statistics in the Data Graph. To 
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preview the effects of running a Power Run scenario as an actual program, move the black 
line on the Data Graph component to other options displayed on the X-axis. This is 
discussed in more detail in the Data Graph Component Section.

With the exception of Power Run for Decision Time, you can preview the proposed 
parameters and their effect on the airport’s traffic.

Note: After you click Model All, the Setup Panel no longer has a red 
border, indicating that all the components reflect the information 
in the IPM Setup component.

Power Run Options

The different options when using Power Run By describe what data is displayed on the X-
axis of the Data Graph and the headers in the Data Table. The Program Type you select 
determines which options are displayed in the Power Run By dropdown menu. All GDP 
functions have “GDP” listed before the Power Run Type, all AFP functions have “AFP” 
listed before the Power Run Type, and all GS functions have “GS” listed before the Power 
Run Type.

Table 3-13:  Power Run Options by Program Type

Program Type Power Run By Options
GDP - DAS GDP Distance/Center Group

GDP Data Time
GDP Distance/Center Group & Data Time 

GDP - GAAP GDP Distance/Center Group
GDP Data Time
GDP Distance/Center Group & Data Time

GDP - UDP GDP Distance/Center Group
G P Data Time
GDP Distance/Center Group & Data Time

AFP - DAS AFP Percent Demand
AFP Percent Capacity
AFP Data Time

AFP - GAAP AFP Percent Demand
AFP Percent Capacity
AFP Data Time

AFP - UDP AFP Percent Demand
AFP Percent Capacity
AFP Data Time

Ground Stop GS Center Group

GS Time Period

GS Center Group & Time Period
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Figure 3 - 116: IPM Setup - Modeling Options Tab

Note: Distance variables are only editable when you model a Distance 
based Program.

Program Cancellation Time

Using the Program Cancellation Time, you can model unrecoverable delay assuming a 
program cancellation time other than the program start time. The field defaults to the 
program start time and uses the ddhhmm format. The Program Cancellation Time is 
available for all Power Runs for GDP and AFP program types, but not for the GS program 
types. The Program Cancellation Time defaults to the Program's Start time in the IPM 
Setup panel. If you change the Start Time, it is dynamically reflected in the Program 
Cancellation Time.

A checkbox labeled Freeze Cancellation Time displays to the right of the Program 
Cancellation Time. By default the checkbox is unchecked. When checked, the Program 
Cancellation Time does not change with a newly entered Start Time or when FSM reloads 
a new ADL. 
GDP Power Run Options

• GDP Center Group: This option allows you to view the effect of the “proposed 
parameters” on the different center groups. The post-operation demand rate for each 
hour for a specific group of centers displays in the Data Graph. Other information 
displayed, includes average delay, number of affected flights, and total delay.

• GDP Data Time: Select GDP Data Time in the Power Run By dropdown menu. This 
option is available only for GDP program types. This option allows you to view the 
effects of the proposed GDP according to the time the GDP is issued. Using the 
display, you can determine how far in advance you need to issue the GDP. Any hour 
whose demand still exceeds the AAR is highlighted in red.
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• GDP Distance: Select GDP Distance from the Power Run By dropdown menu when 
modeling either a GDP or GS. This function shows you the effect of running a GDP or 
GS for various distance parameters. When GDP Distance is selected from the Power 
Run By dropdown menu, three text fields become active in the Modeling Options tab: 
Start Distance, End Distance, and Step Size (distance increment). The default is set to 
start at 199 nautical miles and end at 2600 nautical miles with a step size of 200 
nautical miles. You can manually enter your desired distance and increment range into 
the appropriate text fields.

• GDP Center Group & Data Time: Select GDP Center Group & Data Time from the 
Power Run By dropdown menu. This option is available only for GDP program types. 
This function combines Power Run by Center Group and Power Run by Data Time. 
When you perform Power Run by Center Group & Data Time, you can view all 
available options to run a GDP using a particular center group at various data times.

• GDP Data Time & Distance: Select GDP Data Time & Distance from the Power Run 
By dropdown menu. This option is available only for GDP program types. This 
function combines Power Run by Data Time and Power Run by Distance. When you 
perform Power Run by Center Group & Data Time, you can view all available options 
to run a GDP using a particular distance at various data times. Just as in the Distance 
set up, three text fields become active in the Modeling Options tab: Start Distance, 
End Distance, and Step Size (distance increment). The default is set to start at 199 
nautical miles and end at 2600 nautical miles with a step size of 200 nautical miles. 
You can manually enter your desired distance and increment range into the appropriate 
text fields.

AFP Power Run Options

• AFP Data Time: This option allows you to view the effects of the modeled AFP 
according to the time the AFP is issued. Using the display, you can determine how far 
in advance you need to issue the AFP. 

• AFP Percent Demand: This is the default option when you select an AFP RBS 
program type. An AFP Percent Demand Power Run has three fields: Min Percent 
Demand (%), Max Percent Demand (%), and Step Size. The default is set to start at 
Min Percent Demand of 50% and Max Percent Demand at 100% with a Step size of 
10%. You can change the min and max percent demand and increment range to meet 
your needs. The AFP Percent Demand Power Run scenario analyzes alternatives by 
increasing/decreasing average demand for the indicated AFP start/end time. Moving 
the black vertical line in the Data Graph to adjust the percent of demand automatically 
adjusts the AFP AAR to meet the adjusted demand. 

• AFP Percent Capacity: This Power Run analyzes alternatives by increasing or 
decreasing the modeled AAR value for the indicated AFP Start and End times. An 
AFP Percent Capacity Power Run has three fields: Min Capacity Reduction (%), Max 
Capacity Reduction (%), and Step Size. The default value for Min Percent Capacity is 
50. The default for Max Percent Capacity is 100. The Step Size default is 10.
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Ground Stop Power Run Options

• GS Center Group: This Power run allows you to see different statistics for all center 
groups. The Data Graph’s X-axis and the Data Table’s column header display the 
various center groups. This option is available only for GS program types.

• GS Time Period: Select GS Time Period from the Power Run By dropdown menu. 
This option is available only for GS program types. This function shows you the effect 
of running a ground stop for various lengths of time. When you select GS Time Period, 
two text fields become active: Number of Start Times and Number of End Times. The 
default for both is set to 2, but you can manually enter in another value to meet your 
analysis needs.

Note: If you decide to run a GS for longer than one hour, FSM provides 
a warning message to ensure you want the ground stop to last for 
that duration.

• GS Center Group & Time Period: This Power Run allows you to see which 
combination of center groups and time periods put in the GS parameters would 
produce the best program. The Data Graph’s X-axis and the Data Table’s column 
headers show the various Time Periods and Center Group combinations. This option is 
available only for GS program types.

IPM Map Component
The IPM Map component is the same as the GDT Map component. Selections made in the 
IPM Setup component are reflected dynamically in the IPM Map component. Airports that 
the server is currently monitoring are displayed with the airports’ three-letter identifier 
and a colored dot indicating the GDT status of each airport. FCAs that the server is 
currently monitoring are displayed with a colored boundary that indicates the AFP status 
of that FCA. The title bar displays the normal component labeling conventions. IPM is 
displayed in the title bar to indicate that you are looking at the Map in IPM mode. 
Adaptive compression status displays in the SUBS section.

The IPM Map component allows you to design a TMI visually by selecting/deselecting 
airports and/or centers. Selecting/Deselecting airports, centers, and adjusting the distance 
range interactively updates other IPM components.
IPM Map Zoom Capabilities

IPM Map contains the same zoom capabilities as the Map in Live mode, for more detail 
refer to Map Component section of this chapter.
Distance Based GDPs

When you select a distance based GDP in the IPM Setup component, a maroon colored 
“range ring” displays on the IPM Map component. The default distance is set to 199 
nautical miles. The range distance is indicated on the IPM Map just outside the top of the 
ring. In addition to adjusting the range from the IPM Setup component, you can alter the 
distance directly from the IPM Map. Put your cursor on the edge of the distance ring until 
FSM User Guide, Version 9.00 3-157



Understanding Components
the cursor turns into direction arrows, then hold down the left mouse button and drag and 
drop the edge of the ring to increase or decrease the distance. 

All airports within the range limit are included automatically into the program and colored 
red. To exclude an airport from within the distance range, just click the dot for that 
particular airport. Clicking an airport within the distance ring turns the dot to green and 
excludes that airport from program delay. 

Any additional airports you select are displayed in the IPM Setup component in the 
Airports: Non Exempt or Exempt field in the Scope tab. Likewise you can select/deselect 
centers to include in a program from the IPM Map. Clicking once on a center includes the 
center in the program. The color of the selected center changes to maroon and the airports 
within that center change color indicating that the program includes them as well. The 
selected center displays in the IPM Setup component in the Centers: Non Exempt field in 
the Scope tab. Clicking only once on a center that is already included within the program 
selection does not reflect any visual difference on the screen.

Tier-Based GDPs

The initial default setting when you open IPM Mode components is an internal tier-based 
GDP. When you select a tier based GDP from the GDP Setup component, FSM colors all 
centers included in a TMI maroon on the map and colors all airports included red. For 
example, the next figure illustrates a SFO 1st Tier GDP with user selected airport, PHX, as 
an additional Non-Exempt airport (see Figure 3 - 117). The method of selecting/
deselecting airports and/or centers is the same as described above in the distance based 
GDP.

Table 3-14:  Mouse Actions on the IPM Map

Mouse Action Description
Click Airport Toggle an airport from Exempt/Non-exempt
Click center once Includes Center in program
Click center twice Exempts center from program delay
Click center three times Default selection by distance
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Figure 3 - 117: SFO 1st Tier Program

The following IPM setup component corresponds with the IPM Map component (see 
Figure 3 - 118).
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Figure 3 - 118: IPM Setup Component ORD 1st Tier

IPM Map Menu Bar

The IPM Map component menu bar contains four options: File, View, Map, and Help. The 
menu selections are the same for the IPM Map as they are for the Monitor Live Map—see 
the Map Component section in this chapter for more information. The Auto-Show menu 
on the IPM Map is disabled for all data set types. 

IPM Bar Graph Component
The IPM Bar Graph component is one of the default components opened in IPM Setup. 
The Bar Graph allows you to view arrival demand at the airport or FCA being monitored 
and compares actual data with proposed parameters. By default, the IPM Bar Graph 
displays flights based on their ETAs for modeled Airport TMIs or ENTRY times for 
modeled Airspace TMIs.

Click Model All on the IPM Setup component to view the modeled parameter results in 
the Bar Graph as well as the Data Graph component. The IPM Bar Graph menu and tab 
options are almost identical to the GDT Bar Graph. Please review the Bar Graph 
Component section above for more detail. 
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Like the GDT Bar Graph, the IPM Bar Graph displays both solid and hashed bars. Solid 
bars represent the original data, while hashed bars represent modeled data (see Figure 3 - 
74).

Figure 3 - 119: IPM Bar Graph

Model and Impact Element Buttons

In GDT mode Model and Impact Element buttons are displayed on the GDT Bar Graph. 
These buttons do not exist on the IPM Bar Graph. Open the Multi Graph component to 
view the model and impact IPM Bar Graphs. 

IPM Data Graph Component
The IPM Data Graph component opens in front of the IPM Map when you click Reload 
All or Model All from the IPM Setup component. You have the option to review, or model 
your ground delay parameters before actually running the program or revising any 
parameters. Click Model All on the IPM Setup component to view the initiative’s results 
with your current parameters in the Data Graph.

From the Modeling Options tab on the IPM Setup component, you can choose the type of 
data you want to view on the Data Graph’s X-axis. When you click Model All, you can 
view the results of various scenarios. You have the option to change your parameters, and 
analyze the program further.
Selecting Different Scenarios

You can view all the available scenarios based on the Power Run selection from the IPM 
Setup component. For example, selecting Power Run By > GDP Center Group from the 
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Modeling Options tab on the IPM Setup and then clicking Model All, displays all the 
available tiers for the monitored airport on the Data Graph component’s X-axis. Your 
modeled scenario statistics are displayed in the Legend Table. Use your cursor to drag the 
black vertical line to a center group, or just move the cursor over the desired center group 
and click to move the line. The delay statistics to the right of the Data Graph reflect the 
line of scenario delineation. In addition, changing the center option automatically updates 
all IPM components to reflect the new parameters. The Data Graph component includes a 
roll-over feature. Rolling your cursor over any line in the Data Graph gives you the delay 
statistics for the colored line that reflects the results of the center group. From the Data 
Graph, it is easy to visualize what center groups give the best results. 
Delay Statistics

The Legend Table displays the delay statistics. By default the Legend Table displays when 
you open the Data Graph component. You can hide the legend by un-checking the View > 
Show Legend box from the Data Graph Menu. In the Legend Table, you can view a desired 
delay statistic several ways. Selecting the All checkbox selects and displays all the delay 
statistics. Selecting the Default checkbox displays the default delay statistics, which are 
Max Delay, Avg Delay, Max Air Hold, Avg Air Hold, and Delay Var. You can select/
deselect any of the delay statistic checkboxes that you want to view in the Data Graph. To 
view one delay statistic in more detail, select the desired radio button option, located to the 
left of the checkboxes. The radio button option displays only one delay statistic at a time, 
but gives a more refined looked at the numbers. The Data Graph includes the following 
Delay Statistics:

• Total # Flts: The total number of flights included in the TMI (cancelled and exempt 
flights) for each particular power run scenario. Default color is pink.

• Affected Flts: The total number of flights included in and affected by the TMI for each 
particular power run scenario (non-exempt and non-cancelled flights only).

• Total Delay: The total amount of delay that would occur if you ran that particular 
scenario. Default color is maroon.

• Max Delay: The maximum amount of delay (in minutes) that any one flight would 
receive if you ran that particular scenario. Default color is white.

• Avg Delay: The average amount of delay (in minutes) flights would receive if you ran 
that particular scenario. Default color is black.

• Max Air Hold: The maximum amount of airborne holding delay (in minutes) that 
would be placed on any one flight if you ran that particular scenario. Default color is 
lavender.

• Avg Air Hold: The average amount of airborne holding (in minutes) that would be 
placed on flights if you ran that particular scenario. Default color is orange.

• Stack: The amount of flights that would be left in the “stack” hour following the end of 
the initiative if you ran that particular scenario. Default color is hunter green.

• Unrec Delay: Unrecoverable delay is the amount of delay that remains on flights even 
if you release the TMI right before the start time for the selected scenario. FSM 
determines this value by setting the time to the TMI start time and performing the 
release delay function. Default color is lime green.
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• % Unrec: Percentage of Unrecoverable delay is a value that FSM calculates by taking 
the Unrecoverable Delay and dividing it by Total Delay (Unrecoverable Delay/Total 
Delay). This is the percentage of delay that remains even if you release all delay at the 
start time for the selected scenario. Default color is yellow.

• Delay Var: Delay Variability is the standard deviation of the carriers’ average delay. 
FSM determines this value by taking the average delay of all carriers to see if they are 
similar. If the average delay is similar for all carriers, the delay variability is a small 
value. Larger deviation, or increased dissimilarity of average delay for all carriers, 
results in larger delay variability values. Default color is red.

• EMA: The Equity Metric for Airlines (EMA) is a metric that indicates (as a whole) 
how equitable, or fair, the proposed initiative is for the airlines. Equity is determined 
by comparing the delay assigned in a proposed initiative to that which results if you 
use the airborne holding model. You must view any deviation from the airborne 
holding model as decreased equity. The values shown in this field are integers rounded 
from the calculated values. A value of 1 indicates that the initiative option results in 
delays that are exactly the same as those for airborne holding. A value from 2 to 8 
indicates an option that still exhibits good equity, though the one with the lower value 
is still preferred. A value from 9 to 16 indicates an option with increasingly significant 
deviation from the standard. A value above 16 indicates an option with poor equity. 
Default color is cyan.

• EMF: The Equity Metric for Flights is a metric that indicates (as a whole) how 
equitable, or fair, the proposed initiative is for all the flights. Equity is determined by 
comparing the delay assigned in a proposed initiative to that which results from using 
the airborne holding model. You must view any deviation from the airborne holding 
model as decreasing equity. The values shown in this field are integers rounded from 
the calculated values. A value of 1 indicates that the initiative option results in delays 
that are exactly the same as those for airborne holding. A value from 2 to 8 indicates 
an option that still exhibits good equity, though the one with the lower value is still 
preferred. A value from 9 to 16 indicates an option with increasingly significant 
deviation from the standard. A value above 16 indicates an option with poor equity. 
Default color is blue.

• Avg Dly Diff: The difference in the calculated average delay prior to and after the 
program. This is always a negative number and FSM only calculates it for a 
Compression program. 

IPM Data Graph Menu

The menu bar in the IPM Data Graph component contains three options: File, View, and 
Help.

1. File Menu

• File > Save As - Saves the Data Graph as a.jpg image in a directory that you 
specify.

• File > Print - Prints the Data Graph that is currently active on your screen.

• File > Close - Closes the Data Graph component only.
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2. View Menu

• View > Show Legend - By default the checkbox is selected and the color legend 
of the delay statistics is displayed. Deselect the checkbox to hide the legend 
and the delay statistics.

3. Help Menu

• Help > Data Graph - Opens the on-line help system.

IPM Demand By Center Component
The IPM Demand by Center component provides you with an additional analysis tool to 
help with scope decision making for GDPs, AFPs, and Ground Stops. The Demand by 
Center component functionality is similar to that of the Data Graph, in that there is only 
data available for display after you model a TMI. After you model a TMI, from the Scope 
tab of the IPM Setup component, click Show Demand or from the IPM Setup component, 
select View > Show Demand.

The Demand by Center component displays the scope of the modeled TMI and has three 
columns: Centers, Non-Exempt, and Exempt. All centers and the top five airports within 
each center (based and ordered primarily by the number of Non-Exempt flights and then 
by the number of Exempt flights) are displayed under the Centers column. The number of 
Non-Exempt flights displays under the Non-Exempt column and the number of Exempt 
flights for each center or airport displays under the Exempt column. 

A red dot to the left of the center or airport identifier indicates that at least one Non-
Exempt flight is present within that center or airport. A green dot indicates that all flights 
are Exempt within that center or airport (see Figure 3 - 120).
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Figure 3 - 120: Demand By Center

By default, the Centers are collapsed. Click the key icon next to the center identifier to 
expand the center and view the top five airports within each Center. If there are more than 
five airports with included flights in the selected Center an additional “Others” row 
combines the rest of the flights within the remaining airports. If a center does not contain 
any flights, that center’s airport list is empty.
Demand By Center Menu Bar

The Demand By Center menu bar contains two options, File and Help.

1.  File Menu

• File > Save as - Saves the Demand By Center window as a .jpg image in a 
directory that you specify. 

• File > Print - Prints the Demand By Center component that is currently active 
on your screen. 

• File > Close - Closes the Demand By Center component only.

2. Help Menu

• Help > Center Demand - Opens the on-line help for the Demand By Center 
component.
FSM User Guide, Version 9.00 3-165



Understanding Components
IPM Time Line Component 
The IPM Time Line component is an optional component in IPM Mode. To open the IPM 
Time line, select View > IPM Time Line from the IPM Setup component menu bar. 

The IPM Time Line Component is the same as the GDT Time Line Component with the 
exception that the title bar contains IPM and includes the Scenario number (see Figure 3 - 
121).

Figure 3 - 121: IPM Time Line Title Bar

IPM Time Line Menu Bar

The menu bar in the IPM Time Line component contains five options: File, View, Time 
Line, Display and Help.

1. File Menu

• File > Save as - Saves the IPM Time Line as a .jpg image in a directory that you 
specify. 

• File > Print - Prints the IPM Time Line component that is currently active on 
your screen. 

• File > Close - Closes the IPM Time Line component only.

2. View Menu

• View > Rename Window - Displays the Rename Window dialog box and allows 
you to change the component name in the title bar. Enter the desired name then 
click OK to change the title bar heading. Click Cancel to close the Rename 
Window dialog box without making any changes.

There are ten additional display options under the View menu. For items with 
checkboxes, select the checkbox to view the information.

• View > Set Tabs Displayed - You can dynamically show and hide specific 
coloring schemes for the Time Line component.

• View > Arrival Data - Displays all arrival data for that data set.

• View > Departure Data - Displays all departure data for that airport.
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• View > Show CNX/DO - Displays all cancelled and drop out flights under the 
column marked CNX, to the right of the active flight information.

• View > Show Legend - Displays the appropriate color legend associated with 
the current view. If you click the legend button on the Time Line, FSM 
dynamically selects the checkbox for Show Legend.

• View > Open Slots in Carrier Color - Displays all open slots due to cancelled or 
delayed flights in the associated carriers color.

• View > Show Unassigned Slots - Displays all unassigned slots during a GAAP 
GDP or AFP.

• View > Auto Icons - Displays flights in the TSD icon format. This is the default 
Time Line view. The TSD format displays different icons based on the flight 
aircraft weight. When you select Auto Icons, the same icon is used to represent 
all aircraft weights).

• View > Flight Info - Displays the Flight Info window for a quick reference on 
the flight.

• View > Flight Detail - Displays the Flight Detail window for more in-depth 
information on the flight.

• View > Flight List - Displays the FSM Flight List.

Note: View > Arrival Data, Show CNX/DO, Open Slots in Carrier Color, 
Show Unassigned Slots, and Auto Icons checkboxes are selected 
by default.

3. Time Line Menu

• Time Line > Track Time - Allows you to turn Track Time on and off. To force 
the Time Line component to update when the current hour changes, select 

Table 3-15:  Auto Icons

Auto Icon 
Enabled

Auto Icon 
Disabled

Description

Jumbo

Jet

Heavy

Prop (Includes Turbo and Piston)
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Track Time. When the hour changes, the Time Line moves forward one hour. 
If you uncheck the Track Time box, you can scroll forward or back in time and 
at the next update time the Time Line does not return to the current time.

• Time Line > Set Time - This option is enabled only under Historical Data Mode 
and allows you to choose the time to view within a set of historical data.

• Time Line > Search By Callsign - Allows you to find a particular flight by 
entering the flight’s callsign and origin airport. The flight icon in the Time 
Line is highlighted with a white box.

Figure 3 - 122: Search By Call Sign

4. Display Menu

• Display > ETA - Display flights based on their Estimated Time of Arrival 
(ETA).

• Display > BETA - Displays flights based on their Base Estimated Time of 
Arrival (BETA). The BETA matches the ETA and is frozen when the flight 
becomes active or when the flight becomes controlled. 

• Display > IGTA - taxi - Displays flights based on their Initial Gate Time of 
Arrival (IGTA) minus taxi time (IGTA Wheel Time). The IGTA is based on 
the OAG times or flight plan times and never changes. Taxi time default is 10 
minutes, but you can change it in the IPM Control window.

• Display > OCTA - Displays flights based on their Original Controlled Times of 
Arrival (OCTA), Original ETA, OGTA Wheel Time, or ETA position, 
depending on the available information. For example, if the Original CTA is 
not available, FSM uses Original ETA and so on. This time never changes.

• Display > EAFT - Displays flights based on their Estimated Arrival Fix Time 
(EAFT), which is the time at which the flight crosses its designated arrival fix.

• Display > CTA - Displays flights based on their current Controlled Time of 
Arrival (CTA).

• Display > ENTRY - Displays flights based on their current Estimated Element 
Entry Time (Airspace data set only)

• Display > BENTRY - Displays flights based on their current Based Element 
Entry Time (Airspace data set only)

• Display > OENTRY - Displays flights based on their current Original Element 
Entry Time (Airspace data set only)
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5. Help Menu 

• Help > Time Line - Opens the on-line help for the IPM Time Line component.

• Help > Legend - Opens the on-line help for the Time Line icon legend. 

IPM Flight List Component 
The IPM Flight List component is an optional component in IPM Mode that allows you to 
view the modeled results for multiple flights. To open the IPM Flight List, select View > 
Flight List from the IPM Setup component. 

The IPM Flight List component is the same as the GDT Flight List component with the 
exception that the title bar contains IPM and includes the Scenario number.

Figure 3 - 123 : IPM Flight List View

For more information on the Flight List component, see Chapter 6: Viewing Flight 
Information.
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4:   Opening FSM
The Control Panel component, shown below, is the first component displayed when you 
start the FSM application. You can open FSM in four different data modes:

1. Monitored Live – Monitor airports, FEAs, and FCAs in real-time.

2. Historical – View, recall or analyze previous airport, FEA, and FCA air traffic 
events.

3. GDT – Model, analyze, and/or create Traffic Management Initiatives (TMIs) for 
airports, FEAs, and FCAs depending on air traffic variables.

4. IPM – Model and compare multiple TMIs and review their impact on other data 
sets.

Figure 4 - 1 : Main Control Panel Component

Additionally, you can open various components from various data modes into a User 
Defined Group.

Opening a Data Set
Click Open Data Set on the Control Panel component to open the Open Data Set 
Component. The Open Data Set component displays four data tabs that you use to access 
both live and historical data. The four Tabs available in the Open Data Set components are 
listed below and shown in Figure 4 - 2:

1. Monitored Live – Provides a list of airports, FEAs, and FCAs currently monitored 
by the FSM server and readily available for viewing by the user. Live data mode 
runs real-time data and receives ADL updates approximately every five minutes.

2. All Live – Provides a list of airports, FEAs, and FCAs that can be viewed by the 
user (not on the server but will only take a minute to bring up).

3. Historical – Displays historical data that has been stored in a database. Historical 
data can be recalled to analyze scenarios or replay a day's air traffic events.

4. Active Historical – Provides a list of historical airport, FEA, and FCA data 
currently opened and monitored by the user.
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Figure 4 - 2 : Open Data Set Component

To open an airport, FEA, or FCA you must select a Data mode, a Data set, and select the 
display components from the Open With section to view the information.

• Data Mode – From the Open Data Set component you can open an airport, FEA, or 
FCA in either Live or Historical Data Modes. To open an airport, FEA, or FCA in Live 
Data Mode, use either the Monitored Live or All Live data tabs. To open an airport, 
FEA, or FCA in Historical Data Mode, use either the Historical or Active Historical (if 
you have already opened an airport, FEA, or FCA in historical mode) data tabs. Once 
you have selected a data mode, you can access GDT mode by clicking GDT Mode on 
the Control Panel.

• Data Set – The Data Set is the airport, FEA, or FCA you want to view. When opening 
an airport, FEA, or FCA in Historical data mode, you must select a date from the 
Historical tab’s menu structure and enter a time (optional).

• Display Components – From the Open With selection box you can open data sets in 
four components: Time Line, Flight List, Bar Graph, and ECR components. By 
default, both Time Line and Bar Graph components are selected.

Opening FSM in Monitored Live Mode
From the Open Data Set component, you can open FSM in Monitored Live mode. The 
Monitored Live tab is active when the Open Data Set component initially opens and 
provides a list of FEAs/FCAs and Airports currently monitored by the FSM server readily 
available for viewing.
To open a data set in Monitored Live mode

1. Click Open Data Set.
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2. Select the desired data set (FEA,FCA, or Airport) from the Monitored Live tab.

Note: If an airport currently has a GDP or GS in place, the Open Data 
Set component displays “GDP ACTUAL” or “GS ACTUAL” 
followed by the date and times of the TMI next to the airport. If 
an FEA or FCA currently has an AFP in place, the Open Data 
Set component displays “AFP ACTUAL” followed by the date 
and times next to the FEA or FCA name.

3. Select the components you want to view for the data set in the Open With panel.

4. Click Apply or OK to display the data set in the components that you selected in 
the Open With box. By default, FSM displays both Time Line and Bar Graph 
components if you do not change anything in the Open With component 
selections.

Note: Double-clicking an airport, FEA, or FCA or selecting the airport, 
FEA, or FCA and then clicking Apply leaves the Open Data Set 
component open. Selecting the airport, FEA, or FCA and then 
clicking OK opens the airport, FEA, or FCA in the selected 
components but closes the Open Data Set window.

Figure 4 - 3 shows ATL airport selected with the Time Line and Bar Graph 
components checkmarked in the Open With selection box. This opens the Time 
Line and Bar Graph components for ATL in Live data mode.

Figure 4 - 3 : Monitored Live Tab

Figure 4 - 4 shows FSM opened in Monitored Live mode for ATL.
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Figure 4 - 4 : ATL Monitored Live Mode

Using the Map to Open Components in Monitored Live
Click Map on the Control Panel component to view all the airports, FEAs, or FCAs 
currently being monitored on the Map (see Figure 4 - 5).

Figure 4 - 5 : Map Button

Figure 4 - 6 shows green FEAs, FCAs, and airports that indicate normal operations, while 
red FEAs, FCAs, and airports indicate that there is an actual TMI. Yellow indicates there 
is a proposed TMI for that constraint.
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Figure 4 - 6 : Map Component

To open a data set from the Map component

1. Click the airport, FEA boundary, or FCA boundary you want to open.
The selected airport, FEA, or FCA turns white and displays the three-letter airport 
ID, FEA name, or FCA name followed by the current ADL time (ddhhmm).

Figure 4 - 7 : Selected Airport turns White

Note: If you select an airport, FEA, or FCA with actual or proposed 
parameters in place, the parameters are displayed (see Figure 4 - 
7).

2. Right-click the selected airport, FEA, or FCA to display a pop-up menu.
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3. Select the desired component with which you want to view the airport, FEA, or 
FCA: Time Line, Bar Graph, Flight List, ECR, or Element Display (FEA and FCA 
only) component (see Figure 4 - 8). You can open only one component at a time 
from the Map.

Figure 4 - 8 : Opening Components from the Map

Note: From the Map component you can open Monitored Live mode 
components only.

Opening FSM in Historical Mode
The Historical tab on the Open Data Set component opens archived data that you can use 
to review and analyze past airport, FEA, or FCA events. The Open Data Set component 
defaults to the Monitored Live tab when you first open it. Click the Historical tab to view 
archived data. You can drill down to the desired data set by clicking the drill down icons 
or by double-clicking the file name.

Historical file structure is organized as follows: Server, Year, Month, Day, and data set.

Note: If the client connects to multiple servers, both servers are listed.
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Figure 4 - 9 : Historical Tab

The default settings for Historical mode are the same as in Monitored Live mode; Time 
Line and Bar Graph components appear to be selected by default for the selected Data set. 
The Flight List and ECR components do not open unless you select the corresponding 
checkboxes in the Open With selection box. Once you select the desired data set, you have 
the option to set the data set time before opening the data set. When you specify a data 
time, the components open the ADL data time closest to, but not after, the specified time.

Note: FSM displays in and uses Zulu times unless otherwise specified.

You can open the data set in several ways after you select the desired airport, FEA, or 
FCA components and data time. Double-clicking a desired airport, FEA, or FCA or 
clicking Apply opens the Historical mode data and leaves the Open Data Set component 
open. Clicking OK also opens the Historical mode data in FSM, but closes the Open Data 
Set component.

Begin Monitoring an Airport, FEA, or FCA
The All Live tab on the Open Data Set component provides a list of airports, FEAs, and 
FCAs that the server is not currently monitoring but are readily available for viewing (see 
Figure 4 - 10).
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Figure 4 - 10 : All Live Tab

To begin monitoring an airport, FEA, or FCA from the All Live tab

1. Click Open Data Set.

2. Select the All Live tab.

3. Select a data set.

4. Select the components you want to view for the data set in the Open With panel.

5. Click Apply or OK to open the data set.

Note: The All Live tab opens airports, FEAs, and FCAs in Live mode 
only. Opening an airport, FEA, or FCA from the All Live tab 
may take a few moments longer than opening one from the 
Monitored Live tab. An FSM information message may be 
displayed indicating that FSM takes a moment to collect the first 
set of data (see Figure 4 - 11).

Figure 4 - 11 : FSM information message
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6. Click OK to close the FSM information message. After opening an airport, FEA, 
or FCA from the All Live tab, FSM places the airport, FEA, or FCA on the 
Monitored Live tab.

Managing Historical Data
The Active Historical tab on the Open Data Set component provides a list of opened 
Historical data you are viewing and monitoring. The Active Historical tab has an empty 
display window unless you have already opened a data set from the Historical tab.

Figure 4 - 12 : Active Historical Tab

To open historical data

1. Click Open Data Set.

2. Select the Active Historical tab.

3. Select the desired data set.

4. Click Apply. This opens the airport with the components selected in the Open 
With selection box. The Active Historical tab opens airports, FEAs, and FCAs in 
Historical mode that you have already opened.

Opening FSM in GDT Mode
When you open GDT mode (see Figure 4 - 13), three GDT components open by default: 
GDT Setup, GDT Map, and GDT Bar Graph. You can open additional components, such 
as Flight List, Data Table, Demand by Center, and Time Line components, from the GDT 
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Setup component in GDT mode. See Chapter 3: Understanding Components for more 
detail.

Figure 4 - 13 : GDT Mode

To open a data set in GDT mode

Open FSM in GDT Mode to analyze air traffic management options and implement TMIs.

1. Select a data set that is open in either Live or Historical mode.

2. Click GDT Mode on the Control Panel component (see Figure 4 - 14). The GDT 
Setup panel, GDT Map, and GDT Bar Graph open.

Figure 4 - 14 : GDT Mode Button
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Opening Components from the Data Set Button
Each airport and airspace element displays a button on the FSM Control Panel when the 
data set is open in FSM. Left-clicking the button makes the data set the active data set 
within the session and right-clicking a button displays a menu. 

Right-clicking a data set button in live or historical mode opens a menu with the 
components listed below.

• Open Time Line
• Open Flight List
• Open Bar Graph
• Open ECR - enabled only for controlled, live data sets
• Open Element Display - enabled only for airspace data sets

Right-clicking a data set button in Ground Delay Tools (GDT) mode opens a menu with 
the components listed below. GDT mode includes Live GDT and Historical GDT modes.

• Open GDT Time Line
• Open GDT Flight List
• Open GDT Bar Graph
• Open GDT Map
• Open GDT Data Graph

Right-click menu options that do not pertain to the active data set are disabled. 

You can open multiple copies of the components listed below. Each click on one of these 
right-click menu items opens another copy of the component and associates it to the parent 
data set.

• Bar Graph
• Time Line
• Flight List
• Element Display

You can open only one instance of the following components.

• GDT Bar Graph
• GDT Time Line
• GDT Map
• GDT Flight List
• GDT Data Graph
• ECR 

Additional requests to open new instances of these already-open components brings the 
open component to the front, but does not open a new copy of it. 

Note: The right-click menu for User Defined Groups contains only a 
Rename User Defined Group and a Close Group menu item. The 
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Rename User Defined Group item opens the Rename User 
Defined Group component.

User Defined Groups
User Defined Groups (UDGs) allow you to create, rename, and save a custom data set 
grouping in FSM. You can include airport and airspace data set components in the UDG, 
although airspace components cannot be saved to adaptations at this time. You create 
UDGs from the Open Data Set component. There is no way to create UDGs automatically. 
You must create them manually in an FSM session (but you can then save them to an 
adaptation for future use). You can add elements from all four Open Data Set tabs to a 
UDG and select one or more elements per tab. You make multiple selections by using the 
Shift or CTL keys. There is no way to create a multiple selection across more than one tab 
at this time.

GDT components cannot be added to a UDG. GDT functionality applies only to standard 
TFMS data sets. You can open GDT mode from one of a UDG’s monitored elements, but 
the GDT Setup components are associated with the related airport/airspace element and 
not the UDG.

FSM monitors any element added to a UDG. Even if the actual airport or airspace data set 
is not open in the FSM session, the act of adding it to a UDG causes FSM to monitor that 
element. The element then counts towards the maximum number of monitored elements 
supported in the session. FSM continues to monitor an element as long as at least one 
component for that element is open in the session. The component could be in a UDG or a 
standard data set. This means that the element’s data set button may not always be 
displayed on the FSM Control Panel when the element is being monitored.

FSM does not limit the number of UDGs in a session. However, since the FSM Client 
configuration limits the number of monitored data sets per session, all UDGs can use only 
as many monitored data sets as are supported in the current session. FSM allows as many 
different combinations of those monitored elements as possible.

FSM Settings and User Defined Groups
Component display settings in TFMS data sets and UDGs are independently configurable. 
For example, enabling cancelled flights on an ATL Time Line does not affect a copy of 
the ATL Time Line in a UDG.

Session display settings, such as global or data set settings (for example, flight list column 
persistence), apply to all components including components contained in a UDG. The 
rules for the specific setting still apply. For example, for flight list column persistence, 
only the current Flight List and any Flight List opened after setting the global default will 
show the new default columns. Adding the flight list to a UDG does not change the way 
flight list column persistence functions.

Additionally, any changes to the Query Manager filter list are visible and available to all 
flight list instances, any changes to data set default settings are visible in all component 
instances, Color Scheme global preferences are visible in all component instances, and 
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AFIX and DFIX coloring configurations are visible in all component instances per 
element.

FSM Functionality and User Defined Groups
For UDGs, all FSM functionality is determined by the active window regardless of 
whether the component is assigned to a UDG or not. For example, if you select an 
historical component window in a UDG the “Update” functionality is enabled. Likewise, 
if you then select a controlled live component window in the same UDG, the “ECR” 
functionality is enabled and “Update” is disabled.

The Control Panel menu options are enabled or disabled based on the active component. 
UDGs do not display as an entry on the Alerts menu. Instead, when you select a 
component within a UDG, FSM updates the Alerts menu for that component’s TFMS data 
set. The Reports menu applies only to standard TFMS data sets. UDGs do not have their 
own reports. When you select a component within a UDG and make it active, that 
component updates the Reports menu and data. The TFMS Tools, Utilities, and ECR 
menus apply only to standard TFMS data sets. Any selection you make from the these 
menus applies to the related TFMS data set only and not the UDG.
To Create User Defined Groups

You create a new UDG from the Open Data Set component.

1. Select Custom Group in the Group By section.

Figure 4 - 15 : Open Data Set With Custom Group: Selected

2. Enter the group name into the Custom Group list. The UDG name must be at least 
one alphanumeric character long and no longer than six alphanumeric characters. 
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There are no restrictions on what letter and number combinations you use. You can 
use hyphens and underscores in UDG names but not spaces.

Figure 4 - 16 : Custom Group Name

Note: After creating a UDG, if you want to go back to opening 
components by airspace or airport ID, you need to select 
Element in the Group By section of the Open Data Set 
component.

UDG names are unique within an FSM session. If you try to create a new UDG 
with the same name as an existing UDG in that session, FSM adds the new 
components to the existing group.
The Custom Group field on the Open Data Set component lists the existing UDGs 
for the current session alphabetically.

Note: This list will not show saved UDGs in adaptation files.

3. Use the Open With checkboxes to select the element components that you want 
FSM to display in the selected UDG. For example, if you select ATL from the 
Monitored Live tab and select Flight List in the Open With section, then FSM 
adds the ATL Flight List to the UDG you selected from Custom Group.
FSM User Guide, Version 9.00 4-14



Opening FSM
Figure 4 - 17 : UDG With ATL Flight List

4. Once you have selected all of the components you want to include in your UDG, 
click OK or Apply.
If you click OK, FSM opens the components for the UDG, creates a data set button 
with the UDG name on the Control Panel, and closes Open Data Set. If you click 
Apply, FSM opens the components for the UDG, creates a data set button with the 
UDG name on the Control Panel, and Open Data Set remains available. Clicking 
Cancel causes FSM to close the Open Data Set component without creating the 
UDG. 

The name of the UDG displays in the title bar of each component in that UDG. The title 
bar format for live components is, <Component Name>: <ELEM> DD/HHMM LIVE 
[UDG] (e.g., Time Line: ATL 23/1519 LIVE [ATL_1]). The title bar format for historical 
components is, <Component Name>: <ELEM> YYYY/Mon/DD HHMM HIST [UDG] 
(e.g., Bar Graph: FCAA08 2006/Oct/19 0815 HIST [NY_CTR]).

The UDG data set button format and appearance is consistent with the airport and airspace 
data set buttons. UDG data set buttons use “/U” after the group name. 

The right-click menu for a UDG data set button has Rename User Defined Group and Close 
Group menu items. Rename User Defined Group allows you to change the name of the 
UDG. Close Group deletes the UDG and closes all components associated with it.
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FSM components are displayed at their configured locations when you add them to a 
UDG. This means that if you add six Bar Graphs to one UDG, all six Bar Graphs are 
displayed in the lower right corner of your screen. If you would like to have these 
components open in a particular arrangement, you can rearrange the display and save it to 
an adaptation file.
To Add Components to a User Defined Group

You can add components to an existing User Defined Group from Open Data Set. 

1. Select the name of the existing UDG from the Custom Group list.

2. Select one or more elements and one or more components for the selected 
elements.

3. Click OK or Apply. FSM opens the components and adds them to the UDG.
To Remove Components from a User Defined Group

You can also remove components from an existing UDG simply by closing each 
component instance you want to remove.
To Close or Delete a User Defined Group

You can delete an existing UDG by selecting Close Group from the right-click menu of 
the UDG's data set button, by closing all of its components individually, or by closing 
FSM. Deleting a UDG removes the group’s data set button from the FSM Control Panel, 
removes the group’s name from the Open Data Set Custom Group list, closes all 
components associated with the UDG, and removes the associated components from the 
Control Panel Window menu.

Closing components in one data set does not affect copies of that component in a different 
data set. In other words, FSM does not close UDG components when the related TFMS 
element data set is closed and vice versa. For example, if you have ATL open and have 
added ATL Time Line to a UDG, you can close the ATL data set without closing the ATL 
Time Line in the UDG. ATL remains monitored since it is still part of a UDG.
To Rename a User Defined Group

You can rename an existing UDG.

1. Right-click the data set button for the UDG on the Control Panel. 

2. Select Rename User Defined Group from the right-click menu. Rename User 
Defined Group opens the Rename User Defined Group component (see Figure 4 - 
18). 
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Figure 4 - 18 : Rename User Defined Group

3. Enter a new name for the group in Please enter a name for the group:.

4. Click OK. When you change the name of the UDG, that change is reflected in each 
title bar of the components contained within the UDG, the data set button for the 
UDG, the Custom Group list on the Open Data Set component and the Windows 
menu of the Control Panel (see Figure 4 - 19). 

Figure 4 - 19 : Renamed User Defined Group

Note: Click Cancel to exit the component without making any 
changes.

To Save a User Defined Group

You can save and retrieve saved UDGs through the FSM Adaptation functionality. 
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You save a UDG by saving the FSM session to an adaptation file.

Note: Only airport components are saved. This is a limitation of the 
existing FSM Adaptation functionality.

1. Select File > Save Adaptation from the Control Panel. The Save Adaptation File 
window displays.

Figure 4 - 20 : Save Adaptation File Window

2. Enter a name for the UDG file in File Name.
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Figure 4 - 21 

3. Click Save.

FSM saves the following attributes to the adaptation file:

• Component size
• Component location (within the FSM workspace)
• Component layering
• Component defaults (For example, Flight List column persistence)

FSM does not save component display settings (tabs, menu options, legend status, etc.) to 
the adaptation file.
To Load a UDG Adaptation File

Once you have saved the UDG to an adaptation file, you can retrieve it in a later session.

1. Select File > Load Adaptation from the Control Panel. The Load Adaptation File 
window displays.
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Figure 4 - 22 : Load Adaptation File Window

2. Select the adaptation file you want to view.

3. Click Open. FSM opens the UDG components and creates a data set button for the 
group on the Control Panel. Note that the data set button displays the name of the 
UDG, not the name of the adaptation file.
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Figure 4 - 23 : UDG Loaded into FSM from an Adaptation File

Note: FSM closes all open data sets before opening an adaptation file. 
This affects all TFMS elements and any UDGs in the session. 
FSM also purges all system preferences before opening an 
adaptation file. This means that any user-configured global 
preferences (like AFIX/DFIX coloring/order, Color Tabs and 
Flight List columns) are purged.

When an adaptation file is open, you can add new elements or components to the session. 
If you would like for these components to be available the next time you load the 
adaptation, you will need to save a new adaptation file (or overwrite the existing one) to 
add new components.
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5:   Viewing Demand
You already know that FSM displays flight information in several ways. But to make 
traffic management decisions, you must also be able to view the overall demand on an 
airport, FEA, or FCA. Airport demand is made up of the total flights using the airport for 
arrival and departure. FEA and FCA demand is made up of flights moving through the 
FEA or FCA. The main utilities to view total demand are the FSM Bar Graph components 
and Count List Reports. The FSM Bar Graphs constantly display demand information as 
FSM receives it through ADLs. The Count List Reports are broken down into seven 
different options, depending on your needs.

For GDP-UDP programs, there is future pop-up demand that can be reviewed. The main 
utility to view the historical pop-up demand is the Historical Pop-Up Demand component.

Bar Graphs
The Current Demand “stacks” its data according to the coloring tab currently displayed. 
For example, if the tab option opened is Status, the bars in the graph are colored according 
to the percentage of flights that represent each respective status. If half of the flights for 
one time period have not departed (light green), while the other half are in the air (red), the 
bar for that hour is half red/half green. If every flight for the hour has landed, the bar for 
that hour is black.

The graph is dynamic and changes according to the information in each ADL update. The 
graph also automatically updates itself when you choose a different color tab option.

Figure 5 - 1 : Bar Graph displaying Color by Status Tab
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In Monitor Live mode only, if there is an 11-minute gap between the ADL update time 
and your local machine time, the ADL Date and Time will turn red until the next update is 
received. Note that the components will remain active even though the data has expired.

Figure 5 - 2 : Red Text Warns that ADL Update Time is Behind

About the Display
There are 16 different coloring options to view the demand. When you first open a Bar 
Graph component, the Status tab is the default view. The component name, airport, FEA, 
or FCA, day, time, data mode and UDG name (when applicable) are displayed in the title 
bar. The airport, FEA, or FCA, date, and last ADL update time also are displayed just 
below the color tabs. Flight color is a feature in FSM that assists the user in distinguishing 
between the varying statuses of each displayed flight. You can select View>Arrival Flow 
Rate to see the arrival flow rate. This thin, gray line represents the airport, FEA, or FCA 
arrival flow independent of the time-bin convention. For more information on the Bar 
Graph component, see Chapter 3: Understanding Components.

Arrival vs. Departure Bars on the Graph
The Bar Graph defaults to arrival data in Monitored Live mode. When you are viewing 
arrival data in FSM, the bars on the graphs are solid. You can toggle both Arrival and 
Departure data on and off using the Arrival Data and Departure Data options from the Bar 
Graph View menu. To view Departure Data select View > Departure Data checkbox (see 
Figure 5 - 3).
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Figure 5 - 3 : Toggle Arrival and Departure Data on/off

When you select both the Arrival Data and Departure Data checkboxes from the View 
menu, the Bar Graph displays arrival and departure data simultaneously. When viewing 
both arrival and departure data, you see two bars for each time increment. Bars that 
represent arrival data are solid, while bars that represent departure data are hashed.

Note: Airspace data sets contain no departure information to display. 

Selecting View > Stack Departures stacks departure data on top of the arrival data. The 
Stack Departures option creates one bar on the graph for each time increment that 
represents the sum of both the arriving and departing flights. The departing flights are 
hashed while the arriving flights are solid in color, as shown in Figure 5 - 4 below.
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Figure 5 - 4 : Stacked Arrival/Departure Information

Original vs. Modeled Data Bars on the GDT Bar Graph
In GDT Mode the Bar Graph by default displays both solid and hashed bars. Solid bars 
represent the original data, while hashed bars represent modeled data. To view modeled 
data only, uncheck the View > Current Data checkbox.

Show Cancelled Flights
Cancelled flights are not displayed by default in the Bar Graph. To view cancelled flights, 
select the View > Show Cancellations checkbox. Cancelled flights are displayed in cyan at 
the top of each hour bar. Showing cancelled flights is useful to compare the original 
demand with the demand after cancellations. To hide cancelled flights, uncheck the View > 
Show Cancellations checkbox or click the Show Cancellations shortcut button.

Drop Out Flights
It is essential to understand the difference between cancelled flights that have their DO 
flag set to true and flights that have been rerouted and have their DO flag set to true. All 
cancelled flights that are included in an FCA also have their DO flag set to true. Rerouted 
flights have their DO flag set to true, but are not cancelled. Table 5-1 lists the differences 
between a cancelled flight and flight that has been rerouted out of an FCA.
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For an ATCSCC TMS it is important to view how many rerouted flights, or pure Drop 
Outs (DO), there are during an AFP if you are considering revising or compressing the 
program. The number of DO flights is indicated by the salmon colored flight icons under 
the CNX column of the Time Line. You can also open a Flight List and add the DO and 
CNX fields to the List and then sort by the DO field. 

Note: If an included flight is cancelled, has the DO flag, and has no 
control times during an AFP, this could indicate that the flight 
was first rerouted out of the AFP and then cancelled. The 

Table 5-1:  Cancelled and Drop Out Flights

Flag Set Description
Non-Controlled 
FCA

Cancelled (no longer 
operating)

The CNX flag is true 
(cancellation type is 
also set)
DO flag is set to true

The flight is treated as 
a normal CNX. If an 
AFP is run, the flight 
would receive an 
ASLOT for the 
cancelled flight.

Rerouted out of FCA, 
but still operating

DO flag is set to true Flight is no longer 
considered demand at 
the FCA. If an AFP is 
run, the flight would 
not receive an 
ASLOT for the 
reroute flight.

Controlled FCA Cancelled (no longer 
operating)

The CNX flag is true 
(cancellation type is 
also set)
DO flag is set to true

The flight retains its 
control times and can 
sub into its cancelled 
ASLOT. Cancelled 
ASLOT can also be 
utilized during a 
compression. 

Rerouted out of FCA, 
but still operating

DO flag is set to true The flight’s control 
times are dropped. 
Therefore, the flight’s 
previous ASLOT is 
not available for 
substitution or 
compression. 
Adaptive 
Compression 
compressed the flight 
to the end of the 
program before 
removing from the 
demand list.
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flight’s control times are removed and the DO flag is set when 
the flight is rerouted and then later cancelled, thus setting the 
CNX flag as well.

Show Unassigned Slots
Unassigned Slots are displayed by default in the Bar Graph. Unassigned Slots are 
displayed in white at the top of each hour bar. Unassigned Slots can only be viewed from 
the Arrival Status tab. To hide unassigned slots, uncheck the View > Show Unassigned 
Slots checkbox.

Show Legend
The Bar Graph Legend indicates the color key according to each respective flight status 
for each color tab. To view/hide the legend, click the legend button located to the right of 
the time-bin buttons or select View > Show Legend checkbox.

Changing the Time Increments Display
When the Bar Graph component opens, the default time increment to display capacity and 
demand information is 60-minutes. To view this information in 15-minute or 30-minute 
time increments, click the associated button from the Bar Graph (see Figure 5 - 5).

When you change the time increment on the Bar Graph, the demand numbers listed on the 
Y-axis of the graph change accordingly. For example, if the AAR of 32 displays for 60-
minute time increments, a 30-minute time increment for the same information displays an 
AAR of 16.
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Figure 5 - 5 : Time Increment Buttons

Tracking Time
Like the FSM Time Line, the Bar Graph component also tracks time. The Time Indicator 
is an orange vertical line that remains fixed at the current time. To show/hide the time 
indicator click the View > Time Indicator checkbox.

By default, the Bar Graph updates with each hour. Keeping the Bar Graph > Track Time 
checkbox checked moves the bar at the turn of each hour. When you do not check the box, 
the bars do not move, but the orange Time Indicator still displays the current time on the 
graph.

Track GDP/AFP/GS Hours
You can view the hours of a GDP, AFP, or GS in effect at the data set you are monitoring 
by using the Bar Graph. The Bar Graph has optional program indicators that work like the 
Time Indicator to show the start and end times of a current GDP, AFP, or Ground Stop. 
The GDP (AFP) Time indicators are colored brown and the GS Time indicators are 
colored yellow. The program time indicators are displayed automatically when a program 
goes into effect at the monitored data set. To view or remove the program indicators, 
select View > GDP/AFP Indicators or > GS Indicators.

Note: When you revise an existing program, the new start time displays 
as a vertical, brown, dotted line.
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Arrival/Departure Flow Rate
The flow rates operate independently of the time-bin convention, enabling users to 
visualize arrival and departure demand as dynamic flow rates. A gray line represents the 
Arrival Flow Rate and a cyan line represents the Departure Flow Rate. To view or remove 
the arrival or departure flow rate from the Bar Graph toggle the View > Arrival Flow Rate 
or View > Departure Flow Rate checkboxes. The Arrival Flow Rate is displayed by 
default.

Note: Departure Flow Rate is not applicable to Airspace data sets.

Show More/Less Hours
The FSM default displays 12 hours of data in the Bar Graph. You can specify the number 
of hours displayed in the bar graph to view more or less flight data. For example, you may 
want to view the demand in 15-minute time increments, which is difficult to see on a 
graph with 12 hours worth of data. To change the number of hours in the Bar Graph, select 
View > Hours Shown > X (where X = number of hours). The graph automatically updates 
itself to show the amount of hours you specify. Use the scroll bars at the bottom of the 
component to view more hours.

View the AAR and ADR
The white horizontal line that runs through the graph represents the Airport Arrival Rate 
(AAR) for the monitored data set. The ADL AAR, which displays by default, is a fixed 
AAR sent by the FAA Air Traffic Control System Command Center (ATCSCC) to advise 
of the number of arriving aircraft a data set can accommodate at any given interval of 
time. The AAR changes according to the interval of time displayed. For example, an AAR 
of 60 per hour is equal to an AAR of 15 per quarter hour. To toggle the ADL AAR Line 
on/off select the View > ADL AAR Line checkbox.

A cyan horizontal line runs through the Bar Graph representing the Airport Departure 
Rate (ADR) for the monitored airport. The ADL ADR is a fixed value sent by the FAA 
ATCSCC to specify the number of departing aircraft an airport can accommodate at any 
given interval of time (not available for FEAs and FCAs). FSM does not display the ADL 
ADR by default. To view the ADL ADR Line, select the View > ADL ADR Line checkbox. 
The ADR also changes according to the time increment used in the graph display. For 
example, an ADR of 60 per hour is equal to an ADR of 15 per quarter hour.

Note: Departure information is not available in GDT Mode; therefore, 
ADR options are removed from the GDT Bar Graph. Also, ADR 
is not applicable to FEAs and FCAs and is disabled on the Bar 
Graph for those data sets.

Viewing the Model Program Rate
The Model Program Rate is a dashed white line that represents the current program rate 
for a data set currently under a TMI or the Program Rate you enter in the Specify Model 
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Program Rate window. To toggle the Model Program Rate on/off select the View > Model 
Program Rate checkbox.

Changing the Program, Pop-Up, and Reserve Rates
Only ATCSCC users can change the actual ADL AAR or ADL ADR (the rate used in 
TPC ADLs which reflects real operational data). For ATCSCC users, see Chapter 3: 
Control Panel Component for details on how to modify AAR/ADR rates. Other users can 
model the effects of various Program Rates by using the Model function.

Before modeling the Program Rate, ensure that you select the View > Model Program Rate 
checkbox, otherwise your modeled rates are hidden from view. If the ADL AAR/ADR 
displays on the Bar Graph, the dashed line (for modeling) may be displayed in the same 
position as the ADL AAR.

Note: ADL ADR is not applicable to FEAs and FCAs and is therefore 
disabled.

There are two methods to change your modeled Program Rate:

1. Use your cursor to drag the dashed line in the graph to the desired rate. The dashed 
line moves to the Program Rate you specified. Only the portion of the line to the 
right of the cursor moves. Any portion of the line to the left of your cursor should 
remain in the same position as you drag the line to a new Program Rate. Moving 
the Program Rate from the graph also automatically fills in the Specify Model Pro-
gram Rate window.

2. Select Bar Graph > Model Program Rate > Specify. The Specify Model Program 
Rate window displays with the current Program, Pop-Up, and Reserve Rates filled 
in for any existing program. From the Fill dropdown menu, select Program Rate, 
Pop-Up Factor, or Reserve. In the With text box, enter the rate. In the From Hour 
and Through Hour dropdown menus, select the appropriate time. Click Fill and 
the new rates are displayed. Click OK to accept the changes and close the window. 
The new Program Rates are displayed on the Bar Graph. The Pop-Up and 
Reserved rates are not displayed on the Bar Graph.

Figure 5 - 6 : Specify Model Program Rate Window
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To restore the Model Program Rate to its original values, select Bar Graph > Model 
Program Rate > Reset. You can also click ADL AAR from the Specify Model Program 
Rate window to reset the rates to the current ADL value. The Model line should no longer 
be displayed behind the ADL AAR rates.

Demand Counts
Count Lists give you the option to check the flights that make up arrival and/or departure 
demand for each hour. You can open all Count Lists from the FSM Control Panel 
component. There are eight count list reports: 

• By Demand
• By Center
• By Aircraft Category
• By Aircraft Class
• By Arrival Fix
• By Departure Fix
• By User
• By Unassigned Slot

To view a demand count for a particular monitored airport, FEA, or FCA from the active 
data set select Reports > Counts > [By report type] (see Figure 5 - 7). If you have not 
selected a data set, FSM displays an error message that indicates “No Current Data Set” is 
selected. For more information on Count List reports see Chapter 21: Understanding and 
Using FSM Reports.
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Figure 5 - 7 : Count List By Demand

Historical Pop-Up Demand
Select Utilities > Historical Pop-up Demand to open the Display Historical Pop-Up 
window (see Figure 5 - 8). This view-only window displays the historical pop-up 
prediction currently included in the ADL. This window is available at anytime regardless 
of whether a TMI is in place or not. Note that predictions fewer than ten per hour may 
include a decimal value. Predictions greater than ten per hour are represented by whole 
numbers.

Figure 5 - 8 Display Historical Pop Up Window
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Each row represents an estimated confidence level of pop-up: High, Medium, and Low. 
The purpose of this is to give an idea of the historical distribution of pop-ups. For 
example, if traffic managers anticipate a typical pop-up day for the data set, they can view 
the values for the High confidence historical pop-up demand; conversely, if the traffic 
manager anticipates an unusual pop-up day, they can view the values for Low confidence. 

Note that the first hour (column) is one hour earlier than the ADL time. The value is 
always “0” since the hour is in the past; therefore, no prediction is necessary. 

The menu bar contains two options: File and Help.

1. File

• Print - Prints the Display Historical Pop-Up window as displayed on your 
screen

• Close - Closes the window

2. Help - Opens online help specific to the Display Historical Pop-Up window

There are two action buttons, Close and Help.

• Close - Click to close the window
• Help - Click to open a pop-up window with a brief description of the component
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6:   Viewing Flight Information
FSM allows you to monitor traffic flow arriving at and departing from an airport and 
flights through an FEA or FCA, using several different components. The most obvious 
sources to view general traffic flow are the FSM Time Line and Bar Graph components. In 
addition to viewing the overall traffic flow of an airport, FEA, or FCA, you can access 
individual flight information using FSM. This chapter describes various ways that FSM 
allows you to view general traffic flow and flight information when making traffic 
management and operational decisions.

The FSM Time Line and Bar Graph components open by default to the Status tab for the 
monitored data set. The Status tab shows flights colored by arrival status. To view 
departure information, select the Arr/Dep Status tab in Time Line and Bar Graph 
components. FSM displays arrival and departure information depending on whether you 
select the Arrival and/or Departure Data checkboxes from the View menu.

Note: Departure data is not available for Airspace data sets.

Roll-Over Events
The roll-over feature is active in the Monitored Live mode Time Line and Bar Graph 
components, and the GDT mode Data Graph component. Where available, rolling your 
cursor over various features, gives you additional pop-up information.

1. Time Line – Rolling your cursor over a flight icon, causes a pop-up window to 
display the flight’s ACID, ORIG, DEST, ETD, and ETA or ENTRY (see Figure 6 
- 1).

Figure 6 - 1 : Rollover Flight Icons in the Time Line Component

2. Bar Graph – To view a flight count for any hour, roll your cursor over any bar 
within the Bar Graph and the respective number of flights displays for the status 
color your cursor is over (see Figure 6 - 2). When you bring the cursor to the top of 
each column, the total number of flights for that column or hour displays in the Bar 
Graph. If you roll the cursor near the top of a bar, the total number of flights for 
that hour displays. You can use the same method to find the Airport Arrival Rate 
(AAR). Roll the cursor over the AAR line and the rate displays.
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Figure 6 - 2 : Bar Graph Count Rollover

3. GDT Data Graph – Rolling your cursor over any line in the Data Graph shows you 
the delay statistic count for the colored line. This line reflects the selected criteria 
of the scenario being monitored or modeled. Figure 6 - 3 illustrates the 1st tier 
option selected with all the corresponding delay statistics in the legend. The roll-
over shows a maximum delay of 210 minutes.
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Figure 6 - 3 : Data Graph Delay Statistic Rollover

Right-Click Capabilities
The right-click feature is active in Time Line, Map, Flight List, GDT Data Graph, and 
GDT Setup components.

1. Time Line – Right-clicking a flight icon in the Time Line shows you five 
additional options for that flight: Flight Info, Flight Detail, EDCT Check, EDCT 
Update, and ECR.

o
Figure 6 - 4 : Time Line Right-Click Feature

• Selecting Flight Info displays the Flight Info window (see Figure 6 - 5), which 
contains some general ADL information for a flight, including Flight ID, 
Aircraft Type, origin airport, destination airport, ETD, ENTRY (FEA, FCA 
only), EXIT (FEA, FCA only), ETE, ETA, Ctl Element, CTD, CTA, Delay 
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Flag, Cancel Flag, and DO indicator when applicable. Double-clicking a flight 
icon in the Time Line also opens the flight’s Flight Info window.

Figure 6 - 5 : Flight Info Window

• Selecting Flight Detail opens the Flight Detail window as shown in Figure 6 - 
6. The Flight Detail window contains all the ADL information for that flight. 

Figure 6 - 6 : Flight Detail Window
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• Selecting EDCT Check or EDCT Update opens the EDCT Check or EDCT 
Update windows. These EDCT widows allow you to check a flight’s EDCT or 
Update a flight’s EDCT.

 

Figure 6 - 7 : EDCT Check and Update Windows

Note: The EDCT Check and EDCT Update options are available only 
for specialists at the ATCSCC.

• Selecting ECR opens the EDCT Change Request (ECR) component. If the 
selected flight from the time is a controlled flight, the flight information 
automatically fills in the ECR window. Refer to Chapter 13 for more 
information.

2. Bar Graph – Right-clicking a bar within the Bar Graph component gives you a 
menu with the appropriate selections from the legend for that tab. When you select 
Open Flight List For and an option from the menu, FSM creates a flight list filtered 
to show the flights that meet those criteria. For tabs with dynamic legends (legend 
options that change when data changes) like the Carriers tab, the right-click menu 
reflects the options available at that moment on the legend.
FSM User Guide, Version 9.00 6-5



Viewing Flight Information
Note: Selecting an option that has no flights associated with it opens an 
empty flight list. If you uncheck a checkbox on the legend, that 
option will not be displayed in the right-click menu.

Figure 6 - 8 : Example of Bar Graph Right-Click Menu

3. Map – Right-clicking anywhere within the Map component gives you two options: 
Default Zoom or Undo Zoom. 

• Default Zoom takes you back to the initial or default zoom setting for the Map. 
Undo Zoom, undoes the last zoom command. The GDT Map right-click 
functionality is the same as the Map.

Figure 6 - 9 : GDT Map Right-Click Zoom Pop-Up Menu

• In addition, after you select an airport, FEA, or FCA on the Map, you can 
right-click the selected airport, FEA, or FCA to view more options to open the 
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airport in other components. You have the option of showing flights in the 
Time Line, Bar Graph, Flight List, or View Element (FEA, FCA only) 
components (see Figure 6 - 10). You can open only one component at a time 
from the Map component.

Figure 6 - 10 : Map Right-Click Selected Airport, FEA, or FCA

FSM Flight Coloring
Displaying information by flight color is a feature in FSM that assists the user in 
distinguishing between the varying statuses of multiple flights. Flight color options are 
displayed as tabs on the Time Line and Bar Graph components in all data modes. The 
following 16 coloring options are available in FSM:

1. Status

2. Arrival/Departure Status

3. Aircraft Category

4. Aircraft Class

5. Carrier

6. Arrival Fix

7. Departure Fix

8. Exemption

9. User

10. Alarm Status

11. Centers

12. Distance

13. Substitution Status
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14. CDM Participation

15. Program Delay

16. Control Type

The following sections provide a brief description of the 16 coloring options. For more 
information on tab options see Chapter 3: Understanding Components. The coloring 
schemes are documented based on FSM’s default settings. You can configure all coloring 
schemes. Within the components you can select View > Show Legend at any time to 
display the color legend associated with the active color tab (see Figure 6 - 11).

You can view cancelled flights and dropped out flights by selecting View > Show 
Cancellations. Cancelled flights are colored cyan, dropped out flights are colored salmon. 
The examples below show the Bar Graph component, but the Time Line component works 
in the same manner.

Figure 6 - 11 : Bar Graph with Legend

Color By Status
The Status tab colors flights in the Time Line and Bar Graph according to their arrival 
status at their destination airport, FEA, or FCA. To remove a color associated with a flight 
status in the Time Line or Bar Graph uncheck that status color checkbox in the component 
legend. The status data remains grayed-out until you select the checkbox again to restore 
the status color back to the graph.

Table 6-1 displays FSM default coloring for Status.
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Table 6-1: Status Tab Coloring

You can view the removed flights in the Bar Graph by Selecting View >Show 
Cancellations, clicking the legend button, and selecting Removed. The dark blue segment 
displays in the Bar Graph. You can deselect the other checkboxes to see the removed 
flights more clearly.

Note: If you do not select Removed after selecting View >Show 
Cancellations, the RM cancelled flights display cyan like all 
other cancelled flights.

Color By Arrival/Departure
The Arr/Dep Status tab allows you to quickly view flights that are arriving at the 
monitored airport versus flights that are departing the monitored airport. This tab is 
disabled for FEAs and FCAs. Arriving flights are colored light green while departing 
flights are blue.

Color By Aircraft Category
The Aircraft Category tab colors flights according to their equipment classification. Table 
6-2 displays FSM default coloring for Aircraft Category.

Flight Status Definition Default Color
Dep (No CTD) Flights waiting to take off without delay. No 

Estimated Departure Clearance Time issued.
Light Green

Dep (CTD Issued) Waiting to take off without delay. Estimated 
Departure Clearance Time issued.

Brown

Dep (Past ETD) Flights which have passed their Estimated Departure 
Time and remain on the ground.

Dark Green

Arrived Flights have arrived at their destination airport. Black
Flight Active Flights currently en route to their destination airport Red
Cancelled Flights that do not fly because they are cancelled. Cyan
Ground Stopped The flight is currently in a Ground Stop program. Yellow
Removed The ATCSCC CSA removed the flights. Blue
Priority Flights designated as Lifeguard (LFG) or Diversion 

Recovery (DVT) flight. This coloring applies only to 
flights that are not active and overrides all other 
colors when selected.

Pink

Unassigned Slots Unassigned slots allocated by TFMS during a 
GAAP GDP.

White

Dep (CTD Other 
Element)

Flights that are controlled by another Control 
Element and have not departed

Orange
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Table 6-2: Aircraft Category Coloring

Note: FSM colors flights based on their equipment types. FSM does 
not classify equipment types.

Color By Aircraft Class
The Aircraft Class tab colors flights according to their standardized weight class, 
determined by the FAA. Table 6-3 shows FSM default coloring for Aircraft Class.

Table 6-3: Aircraft Class Coloring

Color By Carrier
The Carrier tab colors flights by airline carrier. In the Carrier tab, select View > Show 
Legend to show the color assigned to each carrier.

Equipment Type Default Color
Propeller Black 
Turbo Green
Jet Red
Unknown White

Equipment Type Color
Small Black
Large Green
Heavy Red
Jumbo Yellow
Unknown White
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Figure 6 - 12 : Bar Graph Color by Carrier

Uncheck the carrier checkbox in the color legend if you do not want to view a particular 
carrier in the component. The carrier data remains grayed-out until you select the 
checkbox again to restore the carrier color back to the component.

Typing a single airline identifier into one of the Single Airline text boxes lets you view the 
flights of a major carrier without viewing its sub-carrier flights. Selecting All displays all 
listed carriers.

The list of static carriers displayed in the Carrier tab is based on the opened data set. See 
Table 6-4 for a list of static carriers and predefined colors for each country. For all FEA/
FCAs, regardless of their location, the US color scheme is displayed. For example, if you 
open a US airport or FEA/FCA, the Carrier tab displays the US scheme by default. If you 
open a Canadian airport, the Carrier tab displays the Canadian scheme by default. Note 
that the Carrier tab has replaced the Carrier_NC tab. If you open a Mexican airport, the 
Carrier tab displays the Mexican scheme by default. The static carriers are listed below 
with the predefined colors. 

Table 6-4: Static Carrier Coloring

US Defaults Canadian Defaults Mexican Defaults

Carrier Default 
Color Carrier Default 

Color Carrier Default 
Color

AAL Royal Blue AAL Orange AAL Royal Blue
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In addition, FSM dynamically determines a list of additional top majors displaying in the 
current data set being viewed. FSM calculates the top four dynamic carriers based on the 
total number of flights at the time of processing for that data set. If there are more than 
four dynamic carriers, FSM assigns the top four a dynamic carrier color and groups all 
others under the “Other” label. Based on the configuration file, a carrier must have at least 
five flights in the data set to qualify for the dynamic carrier coloring. If a data set has less 
than four dynamic carriers, FSM does not display the dynamic colors that it cannot assign. 
Similar to the static carriers display, FSM lists the dynamic carriers in alphabetical order 
beginning after USA.

Table 6-5: Dynamic Carrier Coloring

Figure 6 - 13 illustrates the Carrier tab for BOS. The four dynamic carriers for BOS when 
the data set was opened were BSY, EJA, KAP, and TRS. 

ASA Dark Green ACA Dark Green AMX Dark Green

COA Magenta CJA Royal Blue COA Magenta

DAL Light Green COA Brown DAL Light Green

DHL Pink GGN Light Green MXA Pink

FDX Orange GLR Pink CHP Orange

JBU Navy Blue JZA Red SER Navy Blue

NWA Brown PCO Magenta TAO Brown

SWA Light Orange SSV Light Orange UAL Red

UAL Red UAL Yellow USA Yellow

UPS Cyan WJA Cyan AIJ Cyan

USA Yellow

Carrier Default Color 
D1 Dark Gray
D2 Maroon
D3 Light Blue
D4 Sand

Table 6-4: Static Carrier Coloring

US Defaults Canadian Defaults Mexican Defaults

Carrier Default 
Color Carrier Default 

Color Carrier Default 
Color
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Figure 6 - 13 : Dynamic Carriers Display

If you are an airline user, when you select the Carrier tab, the FSM default color is for the 
flights of your carrier. Your carrier abbreviation displays in the Single Airline text box so 
that you immediately view your carrier's flights. For major carriers, the box next to the 
carrier name is selected and the carrier abbreviation displays in the Single Airline box. 
This allows you to differentiate between the major and any of your sub-carriers. Because 
of flight filtering, non-FAA operators cannot view any other carriers' flights. They can 
only view those flights belonging to their own major or sub-carriers. All other flights are 
colored black.

If you are an FAA user, the FSM default is to have all carriers selected for coloring. You 
can add additional carrier or sub-carrier codes in one of the Single Airline text boxes in 
the Carrier legend. When you select a major carrier to color, the major carrier and its sub-
carriers are all the color of its Major.
Recalculate Dynamic Carriers

FSM calculates dynamic carriers based on the total number of flights at the time of 
processing when you first open the Bar Graph. FSM does not update the dynamic list of 
carriers with each ADL update. Therefore, if you would like to get an updated dynamic 
carrier list for the Bar Graph, you must click Recalculate from the Carrier’s tab color 
legend. FSM updates the list of dynamic carriers based on the current data.

Color By Centers
The Centers tab allows you to quickly locate flights that departed from one or several 
centers. By default, FSM shows all centers. To color flights departing from a specific 
group of centers, you can either select a tier level from the legend’s dropdown menu or 
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you can select a center or group of centers. When you select one of the options from the 
dropdown menu, the centers not associated with that particular group are disabled, leaving 
only the selected centers colored in red. You can also enter a center in the Manual text 
box if it is not already a center choice. Selecting the All option in the dropdown menu 
restores all centers back to the graph. The figure below in an example of 1st Tier centers 
plus ATL selected for BOS.

Figure 6 - 14 : Bar Graph Colored by Centers

The All checkbox is selected by default. Uncheck All to deselect all the centers for the Bar 
Graph display. If you uncheck one center from the legend, FSM also unchecks All. 

Color by Arrival Fix
The Arrival Fix (AFIX) tab colors flights according to which arrival fix the flight is 
approaching for the arrival airport. Arrival Fix names vary for each airport. FSM 
automatically generates the monitored airport's arrival fix names and assigns a color to 
each fix in the legend. These colors are configurable as is the order in which the fixes are 
displayed. For more information on fix coloring and fix order, see Chapter 3: 
Understanding Components. For those flights with an unknown arrival fix, FSM assigns 
that fix a value of “Other.” This tab is disabled for FEAs and FCAs.

Note: All flights departing the monitored airport are colored as “Other” 
because their arrival fix is at another airport.

Color by Departure Fix
The Departure Fix (DFIX) tab colors flights according to which departure fix the flight 
has departed over at its origin airport. Departure fix names vary for each airport. FSM 
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automatically generates the monitored airport's top departure fix names and assigns a 
color to each fix in the legend. These colors are configurable as is the order in which the 
fixes are displayed. For more information on fix coloring and fix order, see Chapter 3: 
Understanding Components. For those flights with a departure fix that is other than the top 
departure fix names listed or that is unknown, FSM assigns that flight a value of 
“Other.”This tab is disabled for FEAs and FCAs.

Color by Exemption
The Exemption tab colors flights according to their exemption status in a TMI (see Table 
6-6). 

Color By User
The User tab colors flights according to their user status. User status describes the primary 
function of that flight. This information is sometimes masked from airline users because 
of flight filtering. For example, military flights are not listed as such. Table 6-7shows 
FSM default coloring for User status.

Table 6-7: User Coloring

Table 6-6: Color by Exemption Status

Color Exemption Status Description

Black Flts Excluded Flights that are not controlled 
by the element and not 
subject to EDCT compliance.

Green Flts Exempted Included flights that have a 
priority over Non Exempted 
flights of available arrival 
slots.

Red Flts Not Exempted Included flights that are 
subject to departure delay.

User Status Color
Air Cargo (F) Blue
Carrier (C) Magenta
General Aviation (G/A) Green
Military (M) Brown
Air Taxi (T) Orange
Other (O) Cyan
Unknown (U) Red
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Color by Alarm Status
The Alarm Status tab allows you to distinguish between compliant flights and those that 
have at least one non-compliant alarm set (CC, EC, EA, SP, and CF). Flights that have at 
least one non-compliant alarm triggered are colored in red; compliant flights are colored 
in black (see Table 6-8). 

Color by Distance
The Distance tab allows you to display flights based on their distance from the airport. By 
default, all flights are displayed in the Distance tab. You may select from 200-mile 
increments up to 2,400 miles from the airport or FEA/FCA. You may also choose to 
display flights with a distance greater than 2,400 miles. Flights that are within the selected 
distance are displayed in red.This tab is disabled for FEAs and FCAs.

Color by Substitution Status
The Substitution Status tab distinguishes between flights that may be substituted and those 
that may not. Flights that may have their slot substituted with that of another flight are 
colored in green. Flights that may not be substituted are colored in red (see Table 6-9). 

Color by CDM Participation
The CDM Participation tab colors flights based on whether they are CDM participants. 
CDM participants are colored in green while those that do not participate in CDM are 
colored in red (see Table 6-10). This information may be useful in determining how 
accurate the flight data is that you are viewing. 

Table 6-8: Alarm Status

Color Alarm Status

Red Flight with alarm set

Black Other flights (no alarm set)

Table 6-9: Color by Substitution Status

Color Program Delay

Green Subbing Flights

Red Non-Subbing Flights

Table 6-10: Color by CDM Participation

Color CDM Participation Status

Green Participant

Red Non-participant
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Color by Program Delay
The Program Delay tab colors flights based on the number of minutes that they are 
delayed by a program (see Table 6-11). Flights that are not controlled are colored in white. 
Flights controlled by an element other than the displayed element are colored orange.

Color by Control Type
The Control Type tab helps you monitor TMIs by showing you the control types that 
flights are receiving. For example, when flights receive a Control Type of DAS, formerly 
FA, during a GAAP GDP this is because there were no Unassigned Slots available and the 
flights were given CTAs equal to each flight’s ETA + Delay Limit. Monitoring the 
number of flights receiving a control type of DAS can help with decision making when 
considering if a revision, extension, or transition to a traditional GDP is needed. There are 
nine different control types displayed in the Control Type tab (see Table 6-12).

Table 6-12: Control Type Tab Coloring

Table 6-11: Color by Program Delay

Color Program Delay

White Not Controlled

Orange Controlled Other Element

Green 0-29 minutes

Blue 30-59 minutes

Cyan 60-89 minutes

Gray 90-119 minutes

Pink 120-149 minutes

Yellow 150-179 minutes

Maroon 180-209 minutes

Magenta 210-239 minutes

Red More than 240 minutes

Control Type Definition Color
TFMS-Others Flights that have a control type of DAS or RCTL. 

During a GAAP GDP, a DAS control type indicates 
that a pop-up flight was assigned the Delay Limit 
because there were no available Unassigned Slots. 

Orange

Bridge Flights that have a control type of BRG, ABRG and 
SBRG. Flights that were bridges due to a successful 
SCS request

Purple
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Viewing Information in the Time Line Component
From the Time Line, you can view flights arriving at and departing from the monitored 
airport, as well as open arrival slots, unassigned slots, cancellations and drop outs. The 
selected tab in the Time Line indicates the type of data displayed. The tab coloring options 
are the same as described above for the Bar Graph in Flight Coloring options. Directly 
above the tab options, the Time Line lists the airport, FEA, or FCA being monitored, as 
well as the date and ADL time as shown in Figure 6 - 15. For more information on the 
Time Line component, see Chapter 3: Understanding Components.

GAAP Flights that have a control type of GAAP, which 
means that the flight was pop-up flight that was 
given an Unassigned Slot during a GAAP GDP or 
AFP.

Pink

Not Controlled Flights that are not active AND not controlled. Green
FAA Flights that have a control type of UPD or ECR. 

Flights that have had a change in their control times 
due to an EDCT Update or SCS request (FAA 
initiated).

Dark Green

Flight Active Flights that are airborne. Red
Program (GDP/GS) Flights that have a control type of GDP, GS, AFP, 

COMP, or BLKT. Flights that are controlled by the 
Element you are currently viewing

Brown

NAS User Flights that have a control type of SUB or SCS. 
Flights that have had any change of control times 
due to an Airline or GA User substitution or a SCS 
request (airline initiated).

Light Blue

Arrived Flights that have already arrived at the monitored 
element coloring takes precedence over other 
control type coloring.

Black

TFMS-ADPT All flights affected by the TFMS Adaptive 
Compression process

Dark Blue

Control Type Definition Color
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Figure 6 - 15 : Time Line Component with Color Legend Displayed

The AAR and/or ADR (airport only) versus the demand on the airport, FEA, or FCA (the 
number of flights projected to arrive at an airport or enter into an FEA or FCA) for that 
hour displays directly below the date/hour information. The Airport Departure Rate versus 
demand displays in parentheses when you select View > Departure Data. For example, if 
the Time Line displayed (90/85), this would indicate that 90 is the Airport Departure Rate 
and 85 flights are projected to depart for that hour.

Each flight arriving at the monitored airport, FEA, or FCA displays beside the minute 
hash mark, which corresponds to the ETA or ENTRY time of the flight. Cancelled and 
dropped out flights are listed under the CNX & DO Flts column. You can show or hide 
icons for cancelled and dropped out flights by selecting View > Show Cancellations from 
the Time Line component. FSM keeps and displays flight data compiled by TPC, which 
includes data for up to 24 hours after the current time.

View Open Arrival Slots
To view open arrival slots that resulted from delayed or cancelled flights, select the View > 
Open Slots in Carrier Color checkbox from the Time Line. Slots are displayed on the Time 
Line as square (cancelled) or triangle (delayed) icons. 

Note: Airline users see only their own slots in the color that FSM 
designates for their airline. 

Any slot left open from another carrier's cancelled or delayed flight is colored black.

Time Line Flight Count
If you need to determine a flight count for a particular time span, you can use the Time 
Line to retrieve the information quickly.
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1. Select the hour number for the beginning time.

2. Press and hold Ctrl as you select the last hour number for the time span. This 
counts all flights in the selected area that are colored according to a “Color By” 
criterion.
A message box opens.

Note: You must select at least two minutes worth of flight data.

Figure 6 - 16 : Flight Count List

3. When you select a group of flights to count on the Time Line, FSM returns 
information about the count. This information includes the total number of flights, 
the time period and the equivalent AAR and/or ADR. FSM derives the AAR and 
ADR values using: AAR = (#flts/#minutes) x 60.

4. Click OK to close the message box.

Time Line Flight List
If you need to determine a flight list for a particular time span, you can use the Time Line 
to retrieve the list quickly.
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1. Select the first flight icon.

2. Press Shift as you select the last flight icon. This creates a flight list in the selected 
area that is colored according to a “Color By” criterion (see Figure 6 - 17).

Note: You must select at least two minutes worth of flight data.

The Flight List window opens.

Figure 6 - 17 : Flight List
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3. Select File > Close from the Flight List window to close the flight list.

Time Line Display Options
The Time Line gives you the option to display flights according to different flight data in 
Live, Historical, or GDT mode. When you choose different criteria to use in the FSM 
Flight display, your changes affect only the component you have selected to change. For a 
description of each menu option on the Time Line Display menu, see Chapter 3: 
Understanding Components.
To Change the Time Line Flight Display

To change the display in the Time Line, use the Display menu options. For a description 
of each menu item, see Chapter 3: Understanding Components. For example, you want to 
see all flights by their Controlled Time of Arrival (CTA) and colored by Carrier.

1. Select Display > CTA in the GDT Time Line component.

Figure 6 - 18 : GDT Time Line Display by CTA

2. Select the Carrier tab.
The Carrier tab shows all flights colored by Carrier and by their CTA.

3. Select Display > ETA to return the flight display to its default appearance.

Flight Lists
FSM generates Flight Lists automatically when it performs certain functions. You can 
generate one for a specific group of flights that you select. Flight Lists allow you to view 
what flights contribute to the arrival demand at an airport, or contribute to the demand in 
an FEA/FCA, and how many flights fall into specific categories. You can open an FSM 
Flight List in a variety of ways from all FSM modes and several FSM components. You 
can obtain Flight Lists from the Bar Graph, Time Line, Status Map, Open Data Set, Query 
Manager, and GDT Setup components.
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The way FSM generates a Flight List differs depending upon the type of information you 
need.

Note: Report Flight Lists vary in the initial default information 
displayed, but the functionality described below is the same. For 
more information on Report Lists, see Chapter 21: 
Understanding and Using FSM Reports.

When you want to see flights that meet only certain criteria, you can generate a Flight List 
from the Query Manager component. From a Flight List, you can also select a single flight 
and view the Flight Info or Flight Details for that flight by right-clicking the selected 
flight, or by highlighting the flight and using the View menu options (see Figure 6 - 19). 
All Flight Lists are dynamic and are updated along with every ADL update.

Figure 6 - 19 : Flight List

Flight List Filters
The Flight List display differs depending on how you open each Flight list. The data and 
filter information being passed by components generating each Flight List are displayed in 
the Current Info section on the Flight List. The Current Info section, located below the 
data set information, helps users identify what Data and Filter(s) are applied to the Flight 
List (see Table 6-13).

Table 6-13: Data and Filter Descriptions

Field Label Description 
Data Indicates what type of data displays in the Flight List. You cannot 

change the type of data displayed from the Flight List.
Filter(s) Indicates what filters are applied to the data. Filters are separated 

with either an AND or OR logical operator.
•AND displays between filters when an intersection of data is 
used. This means the flights in the list mach each of the filter 
criteria.
•OR displays between filters when a union of data is used. This 
means that each flight in the list meets at least one of the filter 
criteria. 
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Figure 6 - 20 : Flight List with Filters Displayed

To conserve space on the Flight List, you can turn off the Current Info display by selecting 
Flight List > Data/Filter Display. This collapses the Current Info section (see Figure 6 - 
21).

Figure 6 - 21 : Flight List with Current Info Display Turned Off
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Flight List Menu
The menu bar in the Flight List component contains four menu options: File, View, Flight 
List, and Help.

1. File Menu

• File > Save As - Saves the Flight List to a spreadsheet or text file, which can be 
opened later and used again.

• File > Print – Prints the Flight List information viewed on the monitor screen.

• File > Close Group – Closes the all the data set components associated with the 
Flight List component.

• File > Close - Closes the Flight List component.

2. View Menu

• View > Rename Window – Displays the Rename Window dialog box and 
allows you to change the title bar name.

• View > Add/Remove Columns – Allows you to add or delete ADL data fields as 
columns to the Flight List.

• View > Group Flights – Allows you to group ADL data fields to the Flight List 
in ascending or descending order.

• View > Sort Flights – Allows you to sort ADL data fields to the Flight List in 
ascending or descending order.

• View > Apply Filter – Allows you to apply a filter to the data fields in the Flight 
List component.

• View > Clear Filter – Allows you to clear a filter from the data fields in the 
Flight List component.

• View > Flight Info - Opens the Flight Info window.

• View > Flight Detail - Opens the Flight Detail window.

3. Flight List Menu

• Flight List > Freeze Data – When checked, prevents the Flight List from 
updating when new ADLs arrive.

• Data/Filter Display – When checked, displays the Current Info section with the 
Data and Filter information for the flight list.

• Flight List > Set Time – Sets the time for the Flight List component in 
Historical mode only.

• Flight List > Search By Callsign – Opens the Search by Callsign component.

4. Help Menu

• Help > Flight List – Opens on-line help for Flight Lists.
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Flight List Buttons
Three buttons are displayed on the Flight List component. Table 6-14 explains the purpose 
of each button.

Table 6-14: Flight List Buttons

Opening Flight Lists
You can open flight lists from multiple components in FSM. This section explains how to 
open Flight Lists from the following components:

• Open Data Set
• Bar Graph
• Time Line
• Map

To open a Flight List from the Open Data Set component

You can open Flight Lists directly from the Open Data Set component. For example, you 
want to see the flight list for ORD, as well as the Time Line and Bar Graph components, 
that FSM is currently monitoring.

1. Click Open Data Set from the Control Panel.

2. Select the ORD data set in the Monitored Live tab.

3. Select Flight List in the Open With section of the screen (Time Line and Bar 
Graph are selected by default).

4. Click Apply or OK.
The Time Line, Bar Graph, and current Flight List for ORD are displayed.

To open a Flight List from the Bar Graph component

You can open Flight Lists directly from the Bar Graph component. For example, you want 
to see a flight list for the Arrival Status of all flights, including cancelled flights, between 
the 1700 and 1800 hours for BOS.

1. Click Open Data Set from the Control Panel.

2. Select the BOS data set in the Monitored Live tab.
The Time Line and Bar Graph for BOS are displayed.

Button Purpose 
Saves the flight list to a spreadsheet or text file

Prints the flight list

Opens the Add/Remove Columns component
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3. Select View > Show Cancellations from the Bar Graph to include cancelled flights 
in the flight list.

4. Ensure the Bar Graph displays in 60 minute increments. If it is not, click 60.

Note: If the Bar Graph displays in 15 or 30 minute increments, clicking 
a bar gives you only the flights for that increment.

5. Double-click the bar between 1700 and 1800 to generate the Flight List (For more 
information on Bar Graphs, see Chapter 3: Understanding Components).

To open a Flight List from the Time Line component

See the Time Line Flight List section above for information on how to open a flight list 
from the Time Line.
To open a Flight List from the Map component

You can open Flight Lists for a monitored airport, FEA, or FCA directly from the Map 
component. For example, you want to view a flight list for FCA009.

1. Click Map on the Control Panel.

2. Select FCA009.
The boundary for the FCA turns white in color when selected. In addition to 
turning white, the FCA’s last ADL time also displays-day then time.

3. Right-click the FCA boundary to display a pop-up menu, which includes the zoom 
options as well as the options to view the Time Line, Bar Graph, or Flight List 
components for that FCA in Monitor Live mode.

4. Select Open Flight List to view the Flight List for FCA009.
The Flight List opens.

5. Select File > Close to close the Flight List window.

Flight List Format
Although there are many ways to generate an FSM Flight List, the lists are always in the 
same format (see Figure 6 - 22). Flight List characteristics include:

• Spreadsheet format – you can manage the lists in the same way you manage 
spreadsheets.

• You can resize the Flight List and scroll through it.
• The default sort order for an airport Flight List is by ETA.
• The Component information displays in the Flight List title bar: Three-letter airport 

code or FEA/FCA name, ADL day and time, mode in which the data was retrieved and 
User Defined Group name (if applicable).

• The number of flights contained in the list displays in the bottom left corner of the 
component.
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Figure 6 - 22 : Flight List

Selecting Flight List Information
There are certain default values for Flight List information categories (the default 
information is configurable). When you first open an airport Flight List, the following 
default information displays:

• ACID – The air carrier (AC) and aircraft identification number (ID). This is a three 
letter carrier code followed by the flight’s identification number. For example, 
UAL1234 indicates a United Airlines flight with ID number 1234. Airline users see 
only their own carrier and sub-carriers ACIDs; FSM masks all other flights.

• ETD – The flight’s Estimated Time of Departure
• ETA – The flight’s Estimated Time of Arrival
• DCENTER – The center from which the flight is departing
• ORIG – The airport at which the flight originated.
• AFIX – The Arrival Fixes associated with the monitored airport
• DFIX – The Departure Fixes associated with the monitored airport
• DEST – The Destination airport for the flight

When you first open an FEA/FCA Flight List, the following default information displays:

• ACID – The air carrier (AC) and aircraft identification number (ID). This is a three 
letter carrier code followed by the flight’s identification number. For example, 
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UAL1234 indicates a United Airlines flight with ID number 1234. Airline users see 
only their own carrier and sub-carriers ACIDs; FSM masks all other flights.

• ORIG – The airport at which the flight originated.
• DEST – The Destination airport for the flight
• ETD – The flight’s Estimated Time of Departure
• ENTRY – Current, best, estimated time of entry for a flight into an FEA or FCA 

considering all data sources
• CTL_ELEM – If a flight is controlled (i.e., has a CTD and CTA), this field indicates 

the constrained NAS element for which a ground delay program or ground stop was 
run. Currently, the CTL_ELEM can be an arrival airport, FEA, or FCA.

• DCENTER – The center from which the flight is departing
• ACENTER – The center where the flight is arriving

You can configure the information in the Flight List to suit your needs by using the Add/
Remove Columns window. The Add/Remove Columns window allows you to add 
columns by:

• Field – Allows you to select individual ADL data elements.
• Group – Allows you to select logical groups of ADL elements.
• FSM Calculated value – Allows you to select values that are the result of operations on 

times listed in the ADL.

You can also remove columns using the Add/Remove Columns window with the 
following exception:

• ACID

This section explains how to add, remove, and move columns on the flight list.
To add data column information to a Flight List

1. Select View > Add/Remove Columns from the Flight List component.
The Add/Remove Columns window opens showing all possible informational 
categories that you can view in FSM's Flight Lists. The categories correspond to 
the available data fields in the ADL, groups of available data fields, and 
calculations that you can specify. The data elements currently displayed in the 
Flight List, also are displayed in the Fields Displayed scroll box (see Figure 6 - 
23).

2. Select any data fields you want to add from the By Field section of the window.

3. Click the bottom arrow button to move the fields to the Fields Displayed scroll 
box.

4. Select any groups of data fields that you want to add from the By Group section of 
the window.

5. Click the bottom arrow button to move the groups to the Fields Displayed scroll 
box.
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6. Specify the calculation you would like to add from the By Calculation section of 
the window.

Figure 6 - 23 : Add/Remove Columns Window

7. Click the bottom arrow button to move the calculations to the Fields Displayed 
scroll box.

8. Click OK.
To add multiple calculations to a Flight List

1. Select View > Add/Remove Columns from the Flight List component.
The Add/Remove Columns window opens.

2. Select the data fields you want to use for first the calculation.

3. Click the bottom arrow button to move the category to the Fields Displayed scroll 
box.

4. Select the data fields you want to use for the next calculation.

5. Click the bottom arrow button to move the category to the Fields Displayed scroll 
box.

6. Continue adding calculations in this way until all of your calculations are 
displayed in the Shown Fields section of the window.

7. Click OK.
All of the calculations are displayed in the Flight List window.

To remove data column information from a Flight List

1. Select View > Add/Remove Columns from the Flight List component.
The Add/Remove Columns window opens. The data elements currently displayed 
in the Flight List, are in the Fields Displayed scroll box (see Figure 6 - 24).
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Figure 6 - 24 : Add/Remove Columns Window

2. To remove a shown data field, double-click the field you want to remove or select 
the field and click the top arrow button to move the data field back to the 
appropriate scroll box.

3. Click OK.
To rearrange columns in a Flight List

You can arrange the order in which your columns are displayed with two different 
methods. The easiest and most convenient method is to do it directly from the Flight List 
itself, by dragging and dropping the column header to the desired position in the list. The 
second method, discussed below, uses the Add/Remove Columns window.

1. Select View > Add/Remove Columns from the Flight List component.
The Add/Remove Columns window opens.

2. Select the ADL data field (column header) from the Fields Displayed scroll box.

3. Move it up or down the list using the Up or Down buttons located to the right of 
the Fields Displayed scroll box. Moving a data element to the top of the Add/
Remove Columns window positions the data element header to the left most 
column on the Flight List.

4. Once you move the data fields to the positions you want, click OK.
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Using the Global Default
To improve the process and speed of comparing multiple Flight Lists and decrease the 
amount of time required to modify the column display, FSM has a Global Default 
functionality. This provides the ability to save a set of columns to be used for all data sets 
throughout the application. The persistence settings are managed through the Add/
Remove Columns Dialog.

You can preserve the columns selected and the order in which they are displayed in the 
Fields Displayed section as a global setting so that all future Flight Lists open with the 
same display. Once you set a Global Default, the current Flight List and future Flight Lists 
display the same columns and positioning that you defined.

Note: Flight Lists generated using Reports are not affected by Flight 
List persistence settings. Report lists contain predefined 
elements relevant to the report.

If you are unsure what an opened Flight List’s settings are, open the Add/Remove 
Columns dialog and review the Current Default display. There are three options: System, 
Global, and Manual (see Table 6-15). 

Table 6-15: Flight List Settings  

To set a Global Default

1. Select View > Add/Remove Columns from the Flight List component.

2. Select any data fields you want to add from the By Field section of the window.

3. Click the right arrow button to move the fields to the Fields Displayed scroll box.

4. Select any data fields you want to remove from the Fields Displayed scroll box.

5. Click the left arrow button to move the fields to the By Field section.

6. Change the position of the columns in the Fields Displayed section as desired.

7. Click Set Global Default at the bottom left-hand corner of the Add/Remove 
Columns dialog, an FSM Information box pops up to inform you how FSM will set 
the Global default.

Current Default Description
System The system default set by FSM in the 

configuration file.
Global Global default you set for the current FSM 

session. 
Manual Indicates that the Flight List settings differ 

from both GLOBAL and SYSTEM 
defaults. 
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Figure 6 - 25 : Set Global Default Information Dialog

8. Click Continue, the FSM Information window no longer is displayed.

9. Click OK on the Add/Remove Column dialog to approve the changes and close the 
dialog.

FSM now applies the default to all flight lists that you open from that client for that 
session.

Note: A Global setting can be saved from session to session by saving 
an adaptation. If an adaptation is not saved, all Flight List 
columns reset to the System default when FSM is closed. 

To remove a Global Default

1. Select View > Add/Remove Columns from the Flight List component.

2. Click Clear Global Default from the Add/Remove Columns dialog, an FSM 
Information box pops up to inform you how FSM will remove the Global default.

Figure 6 - 26 : Remove Global Default Information Dialog

3. Click Continue, the FSM Information window no longer is displayed.

4. Click OK on the Add/Remove Column dialog. FSM restores the System default for 
all new Flight Lists.

Grouping Information in the Flight List
Once you create a Flight List, you can group the information according to your own needs. 
To group a flight list select View > Group Flights on the Flight List component. The Group 
window enables either individual or multi-level grouping of all data fields currently 
displayed in the Flight List.
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Figure 6 - 27 : Flight List Grouping Window

The Group window has the following buttons:

• Clear All – Erases all selections in the Group window. Clicking Apply or OK after 
clicking Clear All returns you to the default Flight List.

• Help – Displays information about the component version currently running in the 
Group window.

• Apply – Keeps the Group window open after FSM updates the flight list.
• OK – Closes the Group window after FSM updates the flight list.
• Cancel – Cancels any selections made, closes the Group window, and restores the 

default selections.

Figure 6 - 28 below, shows the flights grouped by ETA, then departure center, then origin 
airport. The Flight List displays in a split screen and FSM puts grouped flights into folders 
that you can expand for more detail. This grouped Flight List corresponds with the Group 
window parameters shown in Figure 6 - 27.
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Figure 6 - 28 : Flight List Grouped

To group flights by one data field

1. Select a data field in the Group By dropdown.

2. Select either Ascending or Descending.

3. Click OK or Apply in the Group window and the Flight List groups flights 
according to the parameters you set.

To group flights by multiple data fields

You can also group according to multiple categories in the Flight List. For example, you 
want to group your filtered airport Flight List by the Initial Gate Time of Arrival (IGTA), 
Airline, and Origin Airport (ORIG) respectively.

1. Select the IGTA data field in the Group By dropdown.

Note: You can specify time increments of 15, 30, and 60 minutes for 
data fields that are time based by selecting the corresponding 
radio buttons.

2. Select Ascending.

3. Select ORIG data field in the Then By dropdown.

4. Select Ascending.

5. After you select all the grouping parameters, click Apply or OK to generate the 
grouped Flight List.
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6. You can expand a group by double-clicking the group or clicking the expand/
collapse icon. Drilling down shows individual flights within each group set. The 
grouping parameters are displayed above the grouped flights section.

To remove grouping from a Flight List

You can easily return to the normal Flight List display.

1. Select View > Group Flights to access the Group Window. 

2. Click Clear All.

3. Click OK.

Sorting Information in the Flight List
Once you create a Flight List, you can sort the information and arrange it according to 
your own needs. You can sort the list one column category at a time by double-clicking 
the column heading. The arrow at the top of the column indicates that ascending or 
descending order for that category sorts the Flight List column.

To sort by multiple categories select View > Sort Flights from the Flight List component. 
The Sort window shows the data fields that are currently listed in the Flight List. The data 
fields correspond to the available data fields in the ADL. You can also sort multiple 
categories by pressing Ctrl on your keyboard and then selecting up to three categories in 
the flight list. The arrow at the top of the column indicates the ascending or descending 
order for that category and the size of the arrow indicates what level the sort is.

Figure 6 - 29 : Sort Window

The Sort Window has the following buttons:
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• Clear All - Erases all selections in the Sort window. Clicking Apply or OK after 
clicking Clear All returns you to the default Flight List.

• Help - Displays information about the component version currently running in the Sort 
window.

• Apply - Keeps the Sort window open after FSM updates the flight list.
• OK - Closes the Sort window after FSM updates the flight list.
• Cancel - Cancels any selections made and closes the Sort window.

Figure 6 - 30 shows flights sorted by DCENTER, then ACID, and then ETA. This sorted 
Flight List corresponds with the Sort window parameters shown in Figure 6 - 29.

Figure 6 - 30 : Sorted Flight List

Multi-Level Sorting
You can use the Sort window to sort a flight list by multiple data fields. For example, you 
want to sort your Flight List by Destination Center (DCENTER), Aircraft ID (ACID), and 
Estimated Time of Arrival (ETA) respectively.

1. Select View > Sort Flights from the Flight List component.
The Sort window opens.

2. Select the DCENTER data field in the Sort By dropdown menu.

3. Select Ascending.

4. Select the ACID data field in the Then By dropdown menu.
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5. Select Ascending.

6. Select the ETA data field in the Then By dropdown menu.

7. Select Ascending.

8. Click OK or Apply in the Sort window to generate the sorted Flight List.

Using the Apply Filters Window
The Apply Filter window displays a pre-determined list that allows you to arrange the data 
in the Flight List according to your selection. 

1. Select View > Apply Filter from the Flight List component.

Figure 6 - 31 Apply Filter Window

2. Select a filter option from the Apply Filter window.

3. Click OK. This applies the filter to the Flight List. For example, when you select 
the Arrived filter option, FSM arranges the data according to the arrived flights in 
the Flight List.

4. To cancel the applied filter and return to the original Flight List settings, select 
View > Clear Filter from the Flight List menu.

Exporting Flight List
To export Flight List to an Excel spreadsheet

1. From the Flight List window menu bar, select File > Save As. The Save Flight List 
As dialog box opens.

2. Enter a name in the File Name field. 

3. Microsoft Office Excel Worksheet (*.xls) is the default file type in the Files of 
Type dropdown menu. Click Save. 

The exported report is compatible with Microsoft Office Excel 2003 or later and Open 
Office 1.x or later.
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All time values are saved as native time/date fields; therefore, ADL fields that combine 
date/time with text are exported as multiple cells. The date/time portion of the field is 
saved in one cell and the text portion is saved in another. An example is ASLOT. In the 
following spreadsheet, ASLOT is represented in two columns, ASLOT and SlotTime.

Figure 6 - 32 . Exported Flight List

Viewing a Single Flight
You can view information for a single flight by:

• Searching By Callsign for the flight
• Viewing the Flight Information window
• Viewing the Flight Detail window

This section describes how to access and use each of these methods to obtain information 
on a specific flight.

Search By Callsign
You can use the Search By Callsign component when you know the call sign for the flight 
you want to view. In FSM, the uniqueness of a flight relies on the call sign, origin, and 
destination. In performing the search, if you enter only the call sign, leaving Origin blank, 
FSM finds all flights with that call sign regardless of the origin airport. 
To use Search By Callsign

1. Ensure you have a data set open.

2. From the Time Line or Flight List component select [Component Name] > Search 
By Callsign (or select Utilities > Search By Callsign from the Control Panel).
The Search By Callsign dialog box opens.
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Figure 6 - 33 : Search By Call sign Dialog Box

3. Enter the flight's Callsign and Origin Airport.

Note: The origin airport field is optional.

4. Click OK.
The Flight Info window for that flight opens or if more than one flight has the call 
sign you entered, a Flight List opens displaying all flights that match the callsign 
searched (Figure 6 - 34). 

Figure 6 - 34 : Duplicate Flight Warning

5. Right-click the flight in the Flight List and select either Flight Info or Flight Detail 
to view the selected flight’s information.

Using wildcards to search for a flight

You can use the * and ? wildcards to search for flights for which you have incomplete call 
sign or origin airport information. For example, you have call sign SWA13 but are 
missing the last two digits and the origin airport starts with a D.

1. Ensure you have an airport data set open.

2. From the Time Line component select Time Line > Search By Callsign (or select 
Utilities > Search By Callsign if the Time Line is not open).
The Search By Callsign dialog box opens.
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3. Enter the flight's Callsign and Origin Airport using the wildcards.

Note: The wildcard ‘?”stands in for one character (e.g., SWA1?? 
returns all SWA flights with two ID numbers). The wildcard ‘*’ 
stands for multiple characters (e.g., UAL* returns all UAL 
flights with any length ID number.

Figure 6 - 35 : Search by call Sign with wildcard

4. Click OK.
The Flight Info window for that flight opens. If more than one flight meets these 
criteria, a Flight List displays displaying all matching flights. The Flight List 
operates in the same way as any other Flight List.

5. Click Cancel on the Search By Callsign dialog box to exit the search.

Flight Info Window
You can access individual flight information by right-clicking any flight icon in the Time 
Line component or by right-clicking a single flight in a Flight List and selecting Flight 
Info from the pop-up menu (see Figure 6 - 36). The Flight Info window opens. The Flight 
Info window gives you some general ADL information for the selected flight. 

Figure 6 - 36 : Flight Information Window
FSM User Guide, Version 9.00 6-41



Viewing Flight Information
Flight Information Data

The Flight Info window contains the following information:

• ADL Date/Time – The date and time at which you are viewing the flight. In Monitored 
Live mode, this is always the current date and time.

• Status – Flight Status describes the current status of a flight. For example, a flight can 
be Delayed, In Program, or Unknown.

• Flight ID – The aircraft call sign (a combination of airline code and flight number). 
FSM filters this information for airline users.

• Aircraft Type – Indicated the type of aircraft.
• Orig – Origin airport of the flight, with the corresponding center in parentheses.
• Dest – Destination airport of the flight, with the corresponding center in parentheses.
• ETD – Most recent Estimated Departure Time for the flight.
• ENTRY – Estimated Element Entry Time. The estimated time when the flight will 

enter the FCA or FEA. This field is null if the flight does not fly through an FEA or 
FCA.

• EXIT – Estimated Element Exit Time. The estimated time when the flight will exit the 
FEA or FCA. This field is null if the flight does not fly through an FEA or FCA.

• ETE – When available, FSM gives the actual time en route for the flight. Otherwise, 
FSM gives an estimated time en route.

• ETA – Most recent Estimated Arrival Time for the flight.
• Ctl Element – If a flight is controlled (i.e., has a CTD and CTA), the CTL_ELEM 

indicates the constrained NAS element for which a ground delay program or ground 
stop was run. Currently, the CTL_ELEM can be an arrival airport, FEA, or FCA. This 
field is null if the flight is not controlled.

• CTD – The Control Time of Departure for the flight, if it has one.
• CTA – The Control Time of Arrival for the flight, if it has one.
• Delay – If the flight is delayed, one of the delay codes is highlighted. ALD indicates 

that the carrier imposed a delay on the flight. GDP indicates that the flight is delayed 
because of a ground delay program. AFP indicates that the flight is delayed because of 
an airspace flow program. DAS (formerly FAD) indicates that the flight is delayed 
because of pop-up flight(s) after the GDP was issued. GSD indicates that the flight is 
delayed because of a ground stop. TOD indicates the flight is delayed because its ETD 
timed out in TFMS (the number in parentheses next to this field indicates the length in 
minutes of the time out delay); the flight passed its ETD without taking off. 

• Cancel – If the flight is cancelled, one of the cancellation codes is highlighted. UX 
indicates that the flight was cancelled due to an EDCT update, which a traffic manager 
may use to cancel a flight. FX indicates that the flight was cancelled using an FX 
message, which is the CDM message used by the airlines to indicate a cancelled flight. 
RZ indicates that the flight was cancelled using an RZ message, which is a NAS flight 
plan cancellation message. RS indicates that the flight was cancelled using an RS 
message, which is an internal TFMS message generated when a specialist takes an 
OAG flight out of the database. TO indicates that TFMS considers the flight time out 
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cancelled because no activation message has been received within a certain time of the 
predicted departure time. The amount of time out delay displays in parentheses. DV 
indicates that the flight was cancelled and diverted to an alternate destination. RM 
indicates that the flight has been removed from the TFMS database. DO indicates that 
the flight was originally routed through an FEA/FCA, but has since changed its route 
so that it no longer travels through the FEA/FCA.

• DO – The DO flag displays Red if the flight has dropped out of an FEA/FCA.
Flight Info buttons

• Flight Detail – Clicking this button brings up the Flight Detail window. This window 
provides more detailed information for the flight.

Flight Info Menu

The menu bar in the Flight Info window contains three options: File, View, and Help.

1. File Menu

• File > Save As – Saves the flight information to a text file, which you can open 
later and use again.

• File > Print – Prints the flight information you see on the screen.

• File > Close – Closes the Flight Info window.

2. View Menu

• View > Flight Detail – Displays the Flight Detail window.

3. Help Menu

• Help > Flight Information – Opens the on-line help information for the Flight 
Info window.

Flight Detail Window
Use Flight Detail to obtain more detailed information for a specific flight than displays in 
the Flight Info window (see Figure 6 - 37). There are four ways to access the Flight Detail 
window:

1. Right-click any flight icon in the FSM Time Line and select Flight Detail.

2. Right-click a flight in any FSM Flight List and select Flight Detail.

3. Click Flight Detail from the Flight Information window.

4. Select View > Flight Detail in the Flight Information window.
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Figure 6 - 37 : Flight Details Window

Flight Detail ADL Data Elements

The Flight Details window contains the following information:

• Flight ID – The code that identifies the airline and flight number.
• Date/Time – The date and time at which you are viewing the flight. In Monitored Live 

mode, this is always the current date and time.
• Aircraft Type – Indicates the type of aircraft being used for the flight.
• AC_CAT – Indicates the equipment type: propeller, jet, turbo, or unknown.
• Class – The class to which the aircraft belongs. Classes are: heavy, large, or small.
• Major – The airline carrier that controls substitutions for the flight.
• CDM_Participant – Indicates whether the flight belongs to an airline that participates 

in the FAA's Collaborative Decision Making program.
• User – The user class to which the aircraft belongs. User Classes are: air carrier, air 

taxi, air cargo, military, general aviation, and other.
• Departure Information – This column contains the flights Departure information.
• GCD – This field indicates the Great Circle Distance (GCD), which is the distance 

between the origin airport and arrival airport.
• Arrival Information – This column contains the flights Arrival information.
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• ADL Element – This column indicates which ADL elements FSM used to derive the 
information in each column. For example, to display the flight's departure fix time, 
FSM uses the ADL element marked DFIX.

• Airport/Center – Includes the flights’ origin and destination Airport and Center 
(Airport/Center). This row also contains the flight’s GCD.

• Fix/Estimate – Departure Fix (DFIX), Estimated Departure Fix Time (EDFT), the 
arrival Fix (AFIX), and Estimated Arrival Fix Time (EAFT).

• Procedure – Departure Procedure (DP), Departure Procedure Transition (DTRSN), 
Standard Terminal Arrival Route (STAR) and Standard Transition (STRSN)

• Gate, Runway, ENTRY, EXIT, and En Route Times – This section of the Flight 
Details window displays estimated, controlled, scheduled, proposed, airline, and 
actual times for several fields that allow you to track the flight's progress from the 
departure gate and runway to the destination runway and gate. It also includes entry 
and exit times for flights traversing FEAs or FCAs. The information includes the 
various times given for:

-   ETD/ENTRY/EXIT/ETE/ETA – Estimated Wheel Times, Entry times and Exit 
times

Note: FSM displays the CTA under Entry if an airspace Element 
controls a flight. FSM displays CTA under Runway for all other 
instances.

-   CTD/CTA/CETE – Control Times

-   SGTD/SGTA – Scheduled Gate Times

-   PGTD/PGTA/PETE – Proposed Gate Times

-   LGTD/LRTD/LRTA/LGTA – Airline Gate and Runway Times

-   IGTD/IENTRY/IGTA – Initial Estimated Gate/Entry Times

-   ARTD/ARTA/ETE – Actual Runway Times

-   OUT/OFF/ON/IN – Time that the flight was out of the departure gate, off the 
departure runway, on the arrival runway, and in the arrival gate.

-   ERTD/EENTRY/ERTA – Earliest Runway/Entry Times

-   OETD/OENTRY/OETA/OETE – Original Estimated Wheel/Entry Times

-   BETD/BENTRY/BETA – Beginning Estimated Wheel/Entry Times

-   OCTD/OCTA – Original Control Times
• Ctl Exempt/ Ctl Type/ Ctl Element – Displays the type of controls on the flight 

resulting from a program.
• Slot ID/Slot Hold – The Slot ID is the currently assigned slot for the flight. Slot Hold 

indicates whether the slot is being held so that it is not used in compression. A “Y” 
indicates the slot is being held. A dash (-) indicates the slot is not being held.
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• Diversion Recovery (Div Recovery) – Indicates whether the flight is a diversion 
recovery leg of a previous flight.

• Delay Status (ALD GDP DAS (formerly FAD) GSD TOD) – Indicates the type of 
delay, if any, on a flight.

• LTOD – If a flight is time out delayed, the length of time out delay displays here.
• CNX Status (UX FX RZ RS TO DV RM) – Indicates the cancellation status of the 

flight. The codes indicate how or why the flight was cancelled.
• Remark (NRP LFG III ATV SWP DVT ADC FCA WXR) – These codes indicate 

important information about the flight. NRP is National Route Program flight. LFG is 
Lifeguard flight. III is Category III flight. ATV is Altitude reservation. SWP is SWAP 
flight. DVT is Diversion recovery flight. ADC is Advise customs. FCA is Flow 
Constrained Area. WXR is Severe weather route.

• Alarm Status (CC EC EA SF CF) – Indicates the type of alarm criteria, if any, that the 
flight meets.

• DO (Y N) – Indicates whether the flight has dropped out of the FEA/FCA. If the flight 
has dropped out the Y is colored red for easier viewing.

• Absolute Delay (Max [0, ETA - (IGTA - Taxi)]) – FSM calculates the Absolute Delay 
to include all types of delay on a flight. This includes FAA and airline-imposed delay 
due to traffic management initiatives, mechanical delays, etc. Please note that delay 
can be only a positive integer. Therefore, if the flight is running as scheduled or is 
early, Absolute Delay is a value of zero (0).

• Schedule Variation (ETA - [IGTA - Taxi]) – Schedule variation is almost identical to 
absolute delay with the exception that schedule variation can include negative values. 
A negative value in the Schedule Variation field indicates that the flight is running 
earlier than scheduled.

• ATC Delay (Max [0, CTA - BETA]) – ATC Delay includes only that delay that results 
from an FAA traffic management initiative and any action taken by the airline as a 
result of the traffic management initiative. This does not include airline-imposed 
delay, such as mechanical failures, crew delay, etc. ATC Delay can be only a positive 
integer. If the flight is running ahead of its schedule, ATC delay is a value of zero (0).

Note: For a description of each of the flight data fields contained in the 
Flight Details window. See ADL Data Format or select Help > 
ADL Data Elements from the FSM Control Panel component.

Flight Detail Menu

The menu bar in the Flight Detail component contains two options: File and Help.

1. File Menu

• File > Save As – Saves the Flight Detail to a text file, which you can open later 
and use again.

• File > Print – Prints the Flight Detail information you see on the screen.

• File > Close – Closes the Flight Detail window.
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2. Help Menu

• Help > Flight Details – Opens the on-line help for Flight Details information.

Viewing Problem Flights
In the air traffic community, operators need to identify which flights from their own 
operations may be contributing to delay and cancellation problems. Delays and 
cancellations, caused by Time Outs, occur when no activation message has been received 
within a certain time of the predicted departure time. Time Outs can be problematic when 
trying to manage air traffic. To help, FSM includes two reports for problem flights: Time 
Out Delay Report and Time Out Cancel Report. See Chapter 21: Understanding and Using 
FSM Reports for more information about these reports. You can group and sort Report 
Lists using the same methods described in the Flight List section. You can access all 
reports lists from the Reports menu on the Control Panel component.

Other Flight Reports
Flight reports in FSM are a good way to view a set of flights arriving at an airport that 
meet specific criteria. You can access the following reports from the Reports menu on the 
Control Panel component:

• Surface Delay Report
• Priority Flight Report
• Slot Hold Report
• Sub Opportunities Report

See Chapter 21: Understanding and Using FSM Reportsfor more information about these 
reports.

Compliance Flight Lists
When any flight becomes noncompliant, FSM generates a Flight List, called a compliance 
report, that includes these flights. You can access the compliance reports from the Reports 
> Compliance > option from the Control Panel component. There are five possible 
compliance reports:

• By CTD
• By ETE
• By CTA
• Spurious Flight
• Cancel That Flew

See Chapter 21: Understanding and Using FSM Reports for more information about these 
reports.
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Query Manager Flight Lists
The Query Manager component can query an element and generate a Flight List that 
contains only flights that meet certain criteria. You can access the Query Manger by 
selecting Utilities > Query Manager on the FSM Control Panel component. From the 
Query Manger, select any one of the Built-In or User Defined Filters then click Flight List 
or select View > Flight List.

Note: If you do not have a data set selected, FSM displays a “No 
Active Data Sets” error message.

The generated Flight List contains only those flights that meet the selected criteria. For 
more detail on how to view and use flight filters in Query Manager, see Chapter 22: Using 
Query Manager.
FSM User Guide, Version 9.00 6-48



Evaluating Airport and Airspace Conditions
7:   Evaluating Airport and Airspace Conditions
Decision support or modeling tools are functions in FSM that aid you in looking at various 
operational or traffic scenarios. You can use modeling tools to analyze existing operations 
and previous days' events. This chapter reviews some of the utilities in FSM specifically 
set up to help you model various air traffic scenarios. You can use these tools at any time 
during your FSM session.

Adverse weather or any other significant airport event can decrease the airport’s or 
airspace’s capacity, which lowers the AAR. When the arriving flight demand exceeds the 
AAR capacity, then you may need a Traffic Management Initiative (TMI).

FSM allows you to model different scenarios in Ground Delay Tools (GDT) mode to help 
you determine what type of TMI would be most effective. Either a Ground Delay 
Program, or Ground Stop, or in some cases more both may be necessary. Alternately, an 
Airspace Flow Program might be more effective.

Evaluating Demand Versus Capacity

Bar Graph
The Bar Graph serves as a quick look to see if demand exceeds the airport’s or airspace’s 
capacity. The arrival flow rate displays the demand independently of the time-bin 
conventions. Therefore, you can view where the fluctuations in demand are located within 
each hour. If there are several hours where demand is significantly greater than the AAR, 
you may need a TMI to control the traffic flow into the airport or airspace.

The Bar Graph component is colored according to the tab option currently in use. For 
example, if the Status tab is active, the bars in the graph are colored according to the 
percentage of flights that represent each respective arrival status. If half of the flights for 
one time period have not departed (light green), while the other half are in the air (red), the 
bar for that hour is half red and half green. If every flight for the hour has already landed, 
the bar for that hour is black. The Bar Graph is dynamic and changes according to the 
information in each ADL update. The Bar Graph also automatically updates itself when 
you choose a different tab option. See Chapter 3: Understanding Components for more 
information.

Time Line
The Time Line component is colored according to the tab option currently in use. You can 
view the default colors from the Time Line’s legend. See Chapter 3: Understanding 
Components for more information. At the top of each hour column in the Time Line, the 
AAR and expected demand are displayed for that hour. For example, 94/101 indicates that 
the AAR is 94 and the demand expected for that hour is 101 (see Figure 7 - 1). There are 
situations where demand exceeds capacity in one hour but the next hour has plenty of 
room to accommodate the spill over from the previous hour. In these instances, a TMI 
would be unlikely. Figure 7 - 1 shows an AAR of 94. At 1300z, the demand expected is 
112; therefore, the demand exceeds the capacity by 18 flights. At first glance this seems 
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excessive, but looking into the next hour, the expected demand is only 71. The airport can 
accommodate the 18 flights from the 1300z hour in the 1400z hour. A TMI is more likely 
when demand exceeds capacity for several hours.

Figure 7 - 1 : Time Line AAR vs. Demand counts

Deciding when a TMI is necessary is not always this simple, but the ATCSCC works 
closely with all participants through telcons to decide when a TMI is essential.

TMI Evaluation Using Carrier Statistics Report
When you run a TMI, FSM generates a Carrier Statistics report. You can view this report 
from the Control Panel component by selecting Reports > Carrier Statistics or from View > 
Carrier Statistics on any TMI Coversheet. Ensure the desired data set is active to review 
the correct carrier statistics. From the Carrier Statistics report you can view Program delay 
or ABS delay (total delay including airline delay). The Carrier Statistics report is based on 
a flight’s ETA and displays specific delay information for each carrier’s flights. The 
Carrier Statistics report is particularly helpful to airlines. Airlines can view how the TMI 
affects them.

Figure 7 - 2 is an example of the ATCSCC personnel view of the carrier statistic report. 
Airlines would only see their own callsign and any sub-carriers. For more information on 
the Carrier Statistics report, see Chapter 21: Understanding and Using FSM Reports.
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Figure 7 - 2 : Carrier Statistics

Modifying Program Rates
Modeling the Program Rate on the Bar Graph is helpful to visually determine how a 
lowered AAR affects the balance between capacity and demand. If demand exceeds the 
reduced AAR, then a TMI may be necessary.

Specify Model Program Rate
The Bar Graph > Model Program Rate > Specify allows you to change the Model Program 
Rate for a specific amount of time. You can set the Model Program Rate for up to 36 hours 
beyond the current time. The new Model Program Rate displays in the Bar Graphs. The 
Time Line only displays actual ADL AAR rates.

Changing the Rate
There are several ways to change the model Program Rate, Pop-Up Rate, and Reserve 
Rate using the Specify Model Program Rate window, including the ability to assign 
several different Program Rates within the same hour.

To modify rates, from the Fill dropdown menu, select Program Rate/Pop-Up Factor/
Reserve. Enter the new value in the With text box. Then, fill in the hours in the From 
Hour and Through Hour text boxes to reflect the duration of the new rate. Click Fill to 
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automatically fill those hours. This is a good option when you need to fill a block of hours 
with one rate.

To fill several hours, each with different rates, you can enter new values directly into the 
Element row cells next to the appropriate Time column cells that you want to change.

Figure 7 - 3 : Specify Model AAR Window and 15 Min AAR Dialog Box

To fill a single hour with multiple Program Rates, click the cell you want to modify and 
then click Edit 15 in the lower right-hand corner of the rates table or right-click an active 
cell in the Element row. The 15 Min Program Rate dialog box opens. 

This window allows you to assign Program Rates in 15-minute increments for that hour. 
For example, Figure 7 - 3 illustrates a Program Rate of 60, but for the first fifteen minutes 
the element can take 10 flights. Therefore, you need to assign an AAR of 17, 17, and 16 
for the other 15-minute time increments. You can assign any value in each 15-minute 
increment as long as the total equals the overall Program Rate for that hour. Click OK to 
change the 15-minute increments for that hour or Cancel to close the window. When an 
hour increment is not evenly distributed in the 15-minute increments, the cell is colored 
green.

After changing your Model Program Rate information, click OK from the Specify Model 
Program Rate window to reflect the changes in your local Bar Graph component.

View Model Program Rate
The dashed, white line represents the modeled Program Rate. To view the modeled 
Program Rate, you must select the View > Model Program Rate checkbox. In all FSM 
modes, the Model Program Rate initially displays in the same position as the ADL AAR in 
the Bar Graph. If the ADL AAR displays on the graph, the dashed line (for modeling) is 
hidden behind the white solid line. In addition to changing the model Program Rate from 
the Bar Graph > Model Program Rate > Specify feature, you can change the Program Rate 
by placing your cursor over the Program Rate line and dragging the model line to your 
desired model rate. 

Note: Only the portion of the line to the right of the cursor moves.
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Any portion of the line to the left of your cursor should remain in the same position as you 
drag the line to a new AAR. The Bar Graph component and the Specified Model Program 
Rate component dynamically synchronize; therefore when you alter an Program Rate 
from one component, the changes also are reflected in the other. For more information on 
Program Rate see Chapter 5: Viewing Demand.

Apply or Clear Program Rate Changes
After you enter new Program Rate information, there are three options available on the 
Specify Model Program Rate panel:

• OK – Applies the newly modeled Program Rate to the Bar Graph and closes the 
Specify Model Program Rate window.

• Cancel – Closes the Specify Model Program Rate window without taking any action.
• Help – Defines the function of the component.

Specify Model Program Rate Menu Options
1. File Menu

• File > Open – Opens previously saved Program Rate parameters.

• File > Save As – Saves the Program Rate parameters to a text file which you can 
open later and use again.

• File > Print – Prints the Specify Model Program Rate window.

• File > Close – Closes the Specify Model Program Rate window.

2. Help Menu

• Help > Demand Rates – Opens the on-line help for Specifying Program Rates.

Reset Program Rate Model Data
You can reset the Program Rate data to the original data in several ways during your FSM 
session. In the Bar Graph, you can select Bar Graph > Model Program Rate > Reset in the 
Monitored Live, Historical, or GDT mode. You can select Utilities > Model Program Rate 
> Reset from the Control Panel.

You can also reset the Program Rates from the Specify Program Rate window. Select Bar 
Graph > Model Program Rate > Specify and click ADL AAR to reset the Program Rates to 
the original values.

Manipulating Data Time

Set Time (Historical Mode)
When working in Historical Mode, you have the ability to specify the time you would like 
to view. You can specify the data time from the Open Data Set component when you first 
open an airport, FEA, or FCA in Historical Mode or at any time while you are in 
Historical Mode. To change the data time when viewing an airport, FEA, or FCA in 
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Historical Mode, select Bar Graph > Set Time. This feature is available only in Historical 
Mode. The Set time dialog box displays and allows you to specify the time at which to 
view the data (see Figure 7 - 4). Select the day from the dropdown box and enter the time 
in “hhmm” format.

Note: Time in FSM is always in Zulu time unless otherwise specified.

Click OK to update flights’ data to the closest to (but no later than) the entered time. Click 
Cancel to close the Set Time dialog box without changing the data time.

Figure 7 - 4 : Set Time Dialog Box

Modify Data Time (GDT Mode only)
You can select the Data Time from the Parameters tab on the GDT Setup component (see 
Figure 7 - 5). The data time allows you to change the data time without making any 
modifications to the data itself. If you wanted to model what might happen if the program 
was modeled and run an hour from the current time, you could set the Data Time to be an 
hour in the future. In the Data Time textbox, enter a time in “ddhhmm” format to change 
the time. Valid times are from 0000 - 2359. When you change the Data Time to a value 
other than the current time, the Data Time text box, as well as the GDT tab border, is 
highlighted in red.

Figure 7 - 5 : GDT Setup Component
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Update Data Time (Historical Mode Only)
You can only use Update on the Control Panel component when in Historical Mode. 
Click Update to receive the next historical ADL updates.

Remove and Restore Flights (CSA Only)

Remove Flights
You can remove flights from the TFMS database using FSM. You can use this feature to 
remove an airline that goes on strike, eliminate duplicate flights, or remove erroneous 
flights listed in the OAG. To remove a flight, ensure the airport, FEA, or FCA from which 
you want to remove the flight is active, and then select TFMS Tools > EDCT Commands > 
EDCT Remove from the Control Panel (see Figure 7 - 6). The EDCT Remove dialog box 
prompts you to type in the flight number and date. To remove the flights from the 
database, click Send. FSM prompts you to decide whether you really want to remove the 
flight. Click YES to remove the flight. Click NO to cancel the action. Click Cancel to 
close the dialog box without taking any action. Help defines and explains the Remove 
Flights feature.

Figure 7 - 6 : EDCT Remove Dialog Box

Restore Flights
To restore a flight, select TFMS Tools > EDCT Commands > EDCT Restore from the 
Control Panel, as shown in Figure 7 - 7. The EDCT Restore dialog box prompts you to 
type in the flight number and date. To restore the flight to the database, click Send. FSM 
prompts you to decide whether you really want to restore the flight. Click YES to restore 
the flight. Click NO to cancel the action. Click Cancel to close the dialog box without 
taking any action. Help defines and explains the Restore Flights feature.

Figure 7 - 7 : EDCT Restore Dialog Box
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8:   Modeling a Ground Delay Program
Due to unexpected events, such as bad weather at an airport, the FAA delays flights 
scheduled to arrive at the affected airport. The FAA examines flights to determine whether 
to include them in a Ground Delay Program (GDP) based on the time period of the 
operation. The FAA checks those flights eligible for inclusion in the operation against the 
various exemption criteria specified.

Generally, a GDP is necessary where arrival demand excessively surpasses the airport 
capacity. The AAR defines airport capacity for a GDP. You can raise the AAR rates, or 
lower them, due to weather, runway closures, or any other significant event by adjusting 
the Program Rate with a GDP. FSM helps determine what kind of program would be 
necessary to adequately control the traffic flow into the airport.

One important function of FSM GDT Mode is that it allows you to view “what-if” 
scenarios. That is, FSM analyzes the effects of a GDP operation using different 
parameters you set. FSM's analysis capabilities help you determine the best parameters for 
a GDP operation-that minimizes impact on air carrier operations and maximizes 
efficiency during adverse conditions. This chapter discusses modeling a GDP in GDT 
Mode.

You can use the GDT Setup Panel component to model, issue, and send GDPs. In addition 
to GDPs FSM can also model and run Airborne Holding, Ground Stops, Compressions, 
Blankets, and revisions.You can manage the TMI parameters from the GDT Setup Panel. 
When you model a GDP, you can use parameters that you specify or you can use proposed 
parameters.

Modeling a GDP Using Parameters You Specify
To model a GDP, you need to set the parameters you want to use for the GDP. You can do 
this by opening any monitored airport in GDT mode and selecting the GDP parameters. 
The parameters you can set are different depending on which program type you select, this 
chapter will discuss setting parameters for a GDP. For more information on what 
parameters are available for each program type, see Chapter 3: Understanding 
Components.
To model a GDP using parameters you specify

For example, you want to model a GDP - DAS program type for ATL.

1. Click Open Data Set.
The Open Data Set window opens.

2. Select ATL from the Airports Section on the Monitored Live tab.
If ATL is not available from the Monitored Live tab, select the airport from the All 
Live tab

3. Click Apply.
The Time Line and Bar Graph components for ATL are displayed.

4. Click GDT Mode from the main Control Panel.
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Note: If there is no active airport, the GDT Mode button is disabled. 

The GDT Setup Panel, GDT Bar Graph, and GDT Map are displayed, as shown in Figure 
8 - 1.

Note: All GDT components interact with one another; The GDT Setup 
and GDT Map dynamically reflect one another, whereas 
clicking Reload or Model on the GDT Setup panel reflects 
changes in all components.

Figure 8 - 1 : Initial Default GDT Display

5. Select GDP - UDP from the Program Type dropdown menu.

6. On the Parameters tab of the GDT Setup panel (see Figure 8 - 3), complete the 
Program Time Options section. For this example, enter the following:

• Start Time – 191940 (ddhhmm)

• End Time – 201114 (ddhhmm)

7. Enter the appropriate values for the program into the Program Rate section of the 
Parameters tab. For this example, enter a Program Rate of 55 (See Figure 8 - 3). 
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8. To enter the Reserve rate, click Historical Pop-Ups. The Load Historical Pop-Ups 
window open.

9. Click the Medium rado button and click Fill With. The Load With row is filled 
with the Medium predictions. 

10. Click OK to return to GDT Setup. The Reserve row is populated with the medium 
prediction values.

Note: For more detailed information on the Load Historical Pop-Up 
window, see Chapter 3: Parameters Tab.

Figure 8 - 2 Load Reserve Rate 

11. Complete the Delay Limit (Minutes), Target Delay (Multiplier), and Earliest R-
Slot fields or keep the default values. For information on these fields, see Chapter 
3: General Options Section.

12. Complete the Include Only Options section by selecting values for Arrival Fix, 
Aircraft Type, and Carrier or keep the default values of All (see Figure 8 - 3).
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Figure 8 - 3 : GDT Setup Parameters Tab

13. Click the Scope tab, and enter the appropriate values for the program. For this 
example, enter the following (see Figure 8 - 4):

• Select By – Distance

• Scope – 400 nm
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Figure 8 - 4 : Scope Selected by Distance

Note: Any changes you make to the GDT Map are dynamically 
reflected in the GDT Setup component’s Scope tab.

14. GDP Distance is selected by default on the Modeling Options tab.

15. Click Model.
FSM models the program using the parameters you provided. The red border 
inside the GDT Setup Panel no longer is displayed. FSM updates all GDT 
components with your parameters. You can use these components to determine 
how this program affects ATL.

16. If you want to load the latest ADL and model to analyze the data before issuing the 
program, click Reload.

Note: You can retrieve additional GDT components from the View 
menu on the GDT Setup panel.

Modeling a GDP Using Proposed Parameters
When the ATCSCC sends out proposed parameters for a GDP, you can model those 
parameters to determine how they affect your situation. This can help you to plan before 
the ATCSCC implements the actual GDP.

Note: You can use the same steps to model actual parameters except 
that you select File > Load Actual Parameters>[Program Type] 
from the GDT Setup panel.

To Model a GDP using proposed parameters

For example, the ATCSCC sends out proposed parameters for GDP - GAAP program type 
for ATL and you want to view the program.

1. Click Open Data Set.
The Open Data Set window displays.

2. Select ATL from the Monitored Live tab.
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3. Click Apply.
The Time Line and Bar Graph components for ATL are displayed.

4. Click GDT Mode from the main Control panel.
The GDT Setup Panel, GDT Data Graph, GDT Bar Graph, and GDT Map are 
displayed.

5. Select File > Load Proposed Parameters>Ground Delay Program.
FSM loads the proposed parameters into the GDT Setup Panel.

Note: You can only load parameters for the airport you are modeling.

6. Click Model or Reload if available.
FSM models the program using the loaded parameters. The red border inside the 
GDT Setup Panel no longer is displayed. FSM updates all GDT components with 
the proposed parameters. You can now determine how the program affects your 
operations.

Impact Modeling
You can use impact modeling in GDT mode to determine how a program you are 
modeling for one element affects other elements. Impact modeling gives you the ability to 
make adjustments to the TMI based on the impact of it other elements. For more 
information on the Modeling Options tab, see Chapter 3: Understanding Components.

FSM uses all of the same presentation logic and coloring for an Impact Element as for a 
Model Element with the following exceptions:

• When switching among different elements in the GDT Bar Graph, the display defaults 
to ETA for Airport data sets and ENTRY for Airspace data sets.

• When switching among different elements in the Bar Graph, the color by tab display 
remains the same.

• If a color by tab is not available for a data set, the tab defaults to Status. 
• When viewing the Afix tab for a model or impact element, FSM displays the Afixes 

for the selected Airport.

FSM maintains the GDT Bar Graph tabs and makes them available to all element graphs. 
Currently, there are six default tabs available for airport data sets and five default tabs 
available for airspace data sets. You can use the tabs where applicable, whether you are in 
the model or impact element bar graph. The impact elements display the current ADL data 
before modeling.

For example, if you model a GDP for EWR, you can model the impact of the GDP on 
JFK, LGA, BOS, and BED.

1. Select the Modeling Options tab from the GDT Setup component for the program 
you are modeling.
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2. From the Impact Modeling Options section, select the elements on which you want 
to model the impact of the TMI from the Available box.

Note: You can model the impact on up to five elements.

3. Click > to add the elements to the Selected box.

Figure 8 - 5 : Selected Impact Elements

4. Click Model.
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The GDT Bar Graph displays the model element and impact elements as buttons 
next to the button bar.

Figure 8 - 6 : GDT Bar Graph with both Model and Impact Elements

5. On the Bar Graph, click the appropriate button to view the impact of the TMI on 
the element you selected.

Note: The model element button displays first and is separated from 
the impact element buttons by a space.
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Figure 8 - 7 : GDT Bar Graph with Impact Element selected

6. Click Reset Parameters to clear the Impact elements of the modeled data and 
display the current ADL data on the GDT Bar Graph. 

7. You can remove or add impact elements by making change in the Modeling 
Options tab and clicking Model. Select the element you want to remove from the 
Selected box and click < to remove an element.

Modeling Analysis

Preview Your Work
After clicking Model or Reload on the GDT Setup component, all FSM GDT components 
change to reflect the modeled GDP. Viewing these components can help you decide if the 
GDP you have modeled is the best scenario for the traffic flow problems at an airport. All 
of the following components are based on an ATL modeled GDP program.
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GDT Time Line Component

To open the GDT Time Line, select View > Time Line from the GDT Setup component. 
You can preview the changes made in the Time Line as a result of running the GDP model 
(see Figure 8 - 8). A quick glance at the Time Line shows you the distribution of flights, 
the number of cancelled flights (squares) and the number of delayed flights (triangles).

Note: If you modeled a GDP with a GAAP delay limit, you would also 
see the number of Unassigned Slots (white diamonds).
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Figure 8 - 8 : GDT Time Line View
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GDT Bar Graph Component

The Bar Graph displays by default both solid and hashed bars. Solid bars represent the 
original data, while hashed bars represent modeled data. Uncheck View > Current Data 
from the GDT Bar Graph to view only modeled data. The modeled AAR line (dashed 
white line) is displayed by default when in GDT mode. The Bar Graph can indicate if the 
stack at the end of the program is a potential problem and allows you to view the overall 
impact of the program (see Figure 8 - 9).

Note: If you model a GDP with a GAAP delay limit, white sections of 
bars represent the Unassigned Slots.

Figure 8 - 9 : GDT Bar Graph View With Current Data Option Unchecked

For more information on the Bar Graph component, see Chapter 3: Understanding 
Components.

GDT Data Graph Component
The GDT Data Graph provides a visual statistical representation of the modeled GDP. The 
Power Run option that you ran is displayed on the X-axis (see Figure 8 - 10). Using your 
mouse, drag the black vertical line to the desired Power Run option or just click the mouse 
over the desired option to move the line. The delay statistics to the left of the Data Graph 
reflect the line of delineation of the scenario. Additionally, changing the Power Run 
option automatically updates all GDT components to reflect the new parameters. Rolling 
your mouse over any line in the Data Graph gives you the delay statistic count for the 
colored line that reflects the results of the option.
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Figure 8 - 10 : Data Graph View

For more information on the Data Graph component, see Chapter 3: Understanding 
Components.

GDT Map Component
The GDT Map component provides a visual representation of the modeled scope of the 
GDP. The burgundy highlighted areas indicate the scope of Non-Exempt flights. Airports 
that are colored red are Non-Exempt and Airports colored green are Exempt due to the 
scope of the modeled GDP. Clicking an Airport or Center will change the scope of the 
GDP and be reflected in the GDT Setup component.
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Figure 8 - 11 : GDT Map View

For more information on the GDT Map component, see Chapter 3: Understanding 
Components.

GDT Flight List Component
To open the GDT Flight List, select View > Flight List from the GDT Setup component. 
The GDT Flight List allows you to view the modeled results for multiple flights (see 
Figure 8 - 12).
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Figure 8 - 12 : GDT Flight List View

For more information on the GDT Flight List component, see Chapter 6: Viewing Flight 
Information.

GDT Demand By Center Component
To open the GDT Demand by Center, select View > Show Demand from the GDT Setup 
component or click Show Demand from the Scope tab on the GDT Setup component. 
The GDT Demand By Center component displays non-active, non-completed, and 
included flights that are Non-Exempt or Exempt by the modeled GDP (see Figure 8 - 13). 
Included flights are the combination of both Exempt and Non-Exempt flights included in 
the modeled GDP. The Demand by Center component lists all Centers and the top five 
airports, as defined by the number of included flights within each center for the modeled 
GDP. Click the key icon to the left of the Center coloring to expand the Center selection 
and display the airports. The Centers are ordered in descending order based on the number 
of Non-Exempt flights. The red colored Centers indicate that there is at least one Non-
Exempt flight within the Center. Using this component can help you make decisions on 
the scope of your GDP based on the number of Non-Exempt and Exempt flights.
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Figure 8 - 13 : Demand by Center View

For more information on the Demand by Center component, see Chapter 3: Understanding 
Components.

The Analysis Report
FSM generates the Analysis Report after you click Run Actual or Run Proposed from 
the GDT Setup component. To evaluate the effects of any delay operation, select View > 
Analysis Report from the Coversheet, as shown in Figure 8 - 14.
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Figure 8 - 14 : Coversheet
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FSM automatically opens the spreadsheet application that you have indicated in your 
configuration files to display the Analysis Report.

Figure 8 - 15 : Analysis Report for EWR GDP

The Analysis Report contains pertinent information for the Ground Delay Operation that 
has just run, including detailed slot information for individual airlines, delay statistics for 
before and after the operation, and arrival and departure information for individual flights 
(see Figure 8 - 15). The report contains two sections. One section reflects changes that 
occur as a result of RBS; the other section reflects changes that occur as a result of 
Compression. Included in the analysis are statistics for bridge-only carriers.

Reload the Data
If you have been developing a GDP for a while, you may have missed some incoming 
ADLs. Before sending out the final GDP parameters, you may want to update the data for 
your proposed TMI. To do this, click Reload on the GDT Setup component. The Reload 
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button is active only when the actual data time is more recent than the data available in 
GDT mode. Clicking Reload also models the GDP event.
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9:   Modeling an Airspace Flow Program
The foundation of the Airspace Flow Program (AFP) is the integration of the Flow 
Evaluation Area/Flow Control Area (FEA/FCA) function of the Traffic Situation Display 
(TSD) with FSM. Traffic Management Specialists, after consultation with the field Traffic 
Management Coordinators and customers, create an FEA or FCA in TSD. The FEA/FCA 
can be a polygon, a line, a sector, or a box. If the FEA/FCA is designated as ‘FSM-
eligible,’ TFMS begins to generate an Aggregate Demand List (ADL), containing detailed 
information about every flight expected to be part of that FEA/FCA for its duration and 
several hours afterwards.

When the demand in the FCA is projected to substantially exceed capacity, the National 
En Route Spacing Position (NESP) specialist at the ATCSCC can issue an AFP for the 
constrained resource. The process of issuing an AFP is similar to issuing a GDP for an 
airport.

Note: The ATCSCC can only issue an AFP for an FCA. An FEA must 
be converted to a FCA before an AFP can be issued.

This chapter discusses modeling an AFP in GDT Mode. You can use the GDT Setup Panel 
component to model, issue, and send AFPs. In addition to initial AFPs, FSM can also 
model and run Revisions, Compressions, and Purges to existing AFPs. When you model 
an AFP, you can use parameters that you specify or you can use proposed parameters.

Modeling an AFP Using Parameters You Specify
To model an AFP, you need to set the parameters you want to use for the AFP. You can do 
this by opening any monitored FCA in GDT mode and selecting the AFP parameters. The 
parameters you can set are different depending on which program type you select, this 
chapter will discuss setting parameters for an AFP. For more information on what 
parameters are available for each program type, see Chapter 3: Understanding 
Components.

1. Click Open Data Set.
The Open Data Set window displays.

2. Select an FCA from the FEAs/FCAs section on the Monitored Live tab.
If the FCA is not available from the Monitored Live tab, select the FCA from the 
All Live tab

3. Click Apply.
The Time Line and Bar Graph components for the FCA are displayed.

4. Click GDT Mode from the Control Panel.

Note: If there is no active FCA, the GDT Mode button is disabled. 

The GDT Setup Panel, GDT Data Graph, GDT Bar Graph, and GDT Map are displayed, 
as shown in Figure 9 - 1.
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Note: All GDT components interact with one another; The GDT Setup 
and GDT Map dynamically reflect one another, whereas 
clicking Reload or Model on the GDT Setup panel reflects 
changes in all components.

Figure 9 - 1 : Initial Default Display for AFP GDT Mode

5. Select AFP - DAS from the Program Type dropdown menu.

6. Enter the appropriate values for the AFP - DAS into the Parameters tab of the GDT 
Setup panel. For this example, enter the following:

• Start time– 190730 (ddhhmm)

Note: Start Time of the AFP should be the start time of the FCA or the 
most current ADL, whichever is latest.

• End time – 200443 (ddhhmm)

Note: End time of the AFP should be the end time of the FCA or the 
last minute of the available display in FSM.
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Figure 9 - 2 : GDT Setup Parameters Tab

7. Enter the appropriate values for the Program Rate into the Program Rate section of 
the GDT Setup panel. You can use the National En Route Spacing Position 
(NESP) Rate Guidelines document to help determine the appropriate Program 
Rate for the selected FCA. For this example, enter a Program Rate of 40 for the 
duration of the AFP and the stack hours after the end time of the AFP.
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8. Enter the appropriate values for the Pop-up Factor. Select Pop-Up Factor from the 
Fill field. For this example, enter a Pop-up Factor of 10.

Figure 9 - 3 : GDT Setup Panel Program Rate

Note: The program rate default for an airspace data set is zero. Ensure 
that the program rate is set high enough after the end of the 
program to account for the stack value.

9. Enter the appropriate values for the program into the Scope tab of the GDT Setup 
panel. For this example, enter the following in the Departure Facilities section:

• Scope – ALL

• Non-Exempt Airports – Add Canadian airports as necessary

10. Enter any Exempt Airports under the Arrival Facilities section. For this example, 
leave Exempt Airports blank.
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Figure 9 - 4 : GDT Setup Scope Tab

Note: Any changes you make to the GDT Map dynamically reflect in 
the GDT Setup component’s Scope tab.

11.  AFP Percent Demand is selected by default on the Modeling Options tab.

12. Click Model.
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FSM models the program using the parameters you provided. The red border 
inside the GDT Setup Panel no longer is displayed. FSM updates all GDT 
components with your parameters. You can use these components to determine 
how this program affects the airspace.

13. If you want to load the latest ADL and model to analyze the data before issuing the 
program, click Reload.

Note: You can retrieve additional GDT components from the View 
menu on the Setup panel.

Modeling an AFP Using Proposed Parameters
When the ATCSCC sends out proposed parameters for an AFP, you can model those 
parameters to determine how they affect your situation. This can help you to plan before 
the ATCSCC implements the actual AFP or when running a revision.

Note: You can use the same steps to model actual parameters except 
select File > Load Actual Parameters>Airspace Flow Program 
from the GDT Setup panel.

To Model an AFP using proposed parameters

For example, the ATCSCC sends out proposed parameters for AFP - GAAP program type 
for an FCA and you want to view it.

1. Click Open Data Set.
The Open Data Set window displays.

2. Select the FCA from the Monitored Live or All Live tab.

3. Click Apply.
The Time Line and Bar Graph components for the FCA are displayed.

4. Click GDT Mode from the main Control panel.
The GDT Setup Panel, GDT Data Graph, GDT Bar Graph, and GDT Map are 
displayed.

5. Select File > Load Proposed Parameters>Airspace Flow Program.
FSM loads the proposed AFP parameters into the GDT Setup Panel.

Note: You can only load parameters for the FCA you are modeling.

6. Click Model or Reload if available.
FSM models the program using the loaded parameters. The red border inside the 
GDT Setup Panel no longer is displayed. FSM updates all GDT components with 
the proposed parameters. You can now determine how the program affects your 
operations.
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Impact Modeling
You can use impact modeling in GDT mode to determine how a program you are 
modeling for one element affects other elements. Impact modeling gives you the ability to 
make adjustments to the TMI based on the impact of it other elements. For more 
information on the Modeling Options tab, see Chapter 3: Understanding Components.

FSM uses all of the same presentation logic and coloring for an Impact Element as for a 
Model Element with the following exceptions:

• When switching among different elements in the GDT Bar Graph, the display defaults 
to ETA for airport data sets and ENTRY for airspace data sets.

• When switching among different elements in the Bar Graph, the color by tab display 
remains the same.

• If a color by tab is not available for a data set, the tab defaults to Status. 
• When viewing the Afix tab for a model or impact element, FSM displays the Afixes 

for the selected airport.

FSM maintains the GDT Bar Graph tabs and makes them available to all element graphs. 
Currently, there are six default tabs available for airport data sets and five default tabs 
available for airspace data sets. You can use the tabs where applicable, whether you are in 
the model or impact element bar graph. The impact elements display the current ADL data 
before modeling.

For example, if you model a AFP for FCAMSP, you can model the impact of the AFP on 
JFK and LGA.

1. Select the Modeling Options tab from the GDT Setup component for the program 
you are modeling.

2. Select the elements on which you want to model the impact of the TMI from the 
Available box.

Note: You can model the impact on up to five elements.

3. Click > to add the elements to the Selected box.
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Figure 9 - 5 : Selected Impact Elements

4. Click Model.
The GDT Bar Graph displays the model element and impact elements as buttons 
next to the button bar.
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Figure 9 - 6 : GDT Bar Graph with both Model and Impact Elements

5. Click the appropriate button to view the impact of the TMI on the element you 
selected.

Note: The model element button displays first and is separated from 
the impact element buttons by a space.

Figure 9 - 7 : GDT Bar Graph with Impact Element selected

6. Click Reset Parameters to clear the Impact elements of the modeled data and 
display the current ADL data on the GDT Bar Graph. 

7. You can remove or add impact elements by making change in the Modeling 
Options tab and clicking Model. Select the element you want to remove from the 
Selected box and click < to remove an element.
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Figure 9 - 8 : GDT Setup Modeling Options Tab with Impact Element removed

Modeling Analysis

Preview Your Work
After clicking Model or Reload on the GDT Setup component, all FSM GDT components 
change to reflect the modeled AFP. Viewing these components can help you decide if the 
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AFP you have modeled is the best scenario for the traffic flow problems in the FCA. The 
following Data Graph component is an example of one of FSM’s decision support tools; 
see Chapter 8: Modeling Analysis to review all of the decision support tool components.

GDT Data Graph Component
The GDT Data Graph provides a visual statistical representation of the modeled AFP (see 
Figure 9 - 9). The Power Run option that you ran displays on the X-axis, by default the 
Percent of Demand. Using your mouse, drag the black vertical line to the desired Power 
Run option or just click the mouse over the desired option to move the line. The delay 
statistics to the right of the Data Graph reflect the line of delineation of the scenario. 
Additionally, changing the Percent of Demand black vertical line automatically adjusts the 
Program Rate and updates all GDT components to reflect the new selection. Rolling your 
mouse over any line in the Data Graph gives you the delay statistic count for the colored 
line that reflects the results of the option.

Note: The Program Rate entered reflects as a Percentage of the current 
demand in the Data Graph component. A 70% percent means 
that the modeled Program Rate reduces the current airspace 
demand by 30% for the AFP time frame.

Figure 9 - 9 : Modeled AFP: Data Graph View

For more information on the Data Graph component, see Chapter 3: Understanding 
Components.
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The Analysis Report
FSM generates the Analysis Report after you click Run Proposed or Run Actual from 
the GDT Setup component. To evaluate the effects of any delay operation, select View > 
Analysis from the Coversheet.
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Figure 9 - 10 : AFP Coversheet
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FSM automatically opens the spreadsheet application that you have indicated in your 
configuration files to display the Analysis Report.

Figure 9 - 11 : Analysis Report

The Analysis Report contains pertinent information for the AFP that has just run, 
including detailed slot information for individual airlines, delay statistics for before and 
after the operation, and arrival and departure information for individual flights (see Figure 
9 - 11). The report contains two sections. One section reflects changes that occur as a 
result of RBS; the other section reflects changes that occur as a result of Compression. 
Included in the analysis are statistics for bridge-only carriers.

Reload the Data
If you have been developing an AFP for a while, you may have missed some incoming 
ADLs. Before sending out the final AFP parameters, you may want to update the data. To 
do this, click Reload on the GDT Setup component. The Reload button is active only 
when the actual data time is more recent than the data loaded in GDT mode. Clicking 
Reload also models the AFP event.
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10:  Using Integrated Program Modeling
Integrated Program Modeling (IPM) allows you to model and compare multiple traffic 
management initiatives (TMIs), and to review their impact on other data sets. This version 
of IPM only provides modeling capabilities and does not allow you to send scenarios.

In FSM 8.70 you could model one program’s effect on multiple data sets. For example, 
you could analyze the effect of one Airspace Flow Program (AFP) on many airports. For 
more information, see Chapter 8: Impact Modeling.

As of FSM 8.80 you can model and compare multiple programs and their impact on other 
data sets. For example, you can model the effects of multiple GDPs on an FCA.

Note the following limitations:

• You cannot send programs (proposed or actual).

• You cannot alter Data Time.

• You cannot include multiple instances of an element in a scenario.

• You cannot run Blanket or Compression TMIs.

• You cannot model AFPs before airports TMIs.

• AFP exemptions within a GDP are limited to existing AFPs.

• You cannot model re-controls in a purge.

• There is no support for Historical IPM mode.

Building Scenarios
The first step in using the IPM tool is to create one or more scenarios in the Scenario 
Manager component. The creation of a scenario involves selecting the elements that are 
either going to be controlled through initiatives or may be impacted by those initiatives. In 
this example, GDPs are included in a scenario because you want to see their impact on an 
FCA.

To better understand the IPM Mode, review Chapter 3: Integrated Program Modeling 
Components prior to creating the scenarios.

1. From the FSM Control Panel component, click IPM Mode. The IPM Mode 
(Scenario Manager and Multi Graph) opens. 

2. On the Scenario Setup tab > Available box in the Scenario Manager component, 
select the airport or airspace to be included in a scenario. 

3. For the scenario that you are building, click Add Model to add the element that 
you want to model, or click Add Impact to add the element that you want to 
review the impact of the modeled elements. As you move an element into a 
scenario, it is displayed in the corresponding Multi Graph tab. FSM highlights the 
Scenario Manager tabs with a red border to indicate that modifications have been 
made in Scenario Manager.
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Note: You can add up to eight elements within each scenario.

4. Repeat the previous two steps for each element. In this example, three scenarios 
are compared (see Figure 10 - 1). 

Figure 10 - 1 : Scenario Manager with Three Scenarios Created
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5. To change parameters, right-click the element in the Scenario box, and select IPM 
Setup (see Figure 10 - 2) or click the appropriate Scenario tab, and click the 
Element ID action button to open the IPM Setup component.

Figure 10 - 2 : Right-Click Menu Option to Open IPM Setup

Note: The IPM Setup (see Figure 10 - 3) component is very similar to 
GDT Setup. 
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Figure 10 - 3 :IPM Setup Component

6. Select the program type from the Program Type dropdown menu. This step is only 
necessary if you want a program type other than the one defined when you created 
the scenario.

Note: Compression and Blanket programs are not available in IPM.

7. On the Parameters tab of the IPM Setup panel, complete the Program Time 
Options section. For this example, enter the following:

• Start Time – 161415 (ddhhmm)

• End Time – 162114 (ddhhmm)

8. Enter the appropriate values for the program into the Program Rate section of the 
Parameters tab. 

9. Complete the Include Only Options section by selecting values for Arrival Fix, 
Aircraft Type, and Carrier.

10. Click the Scope tab, and enter the appropriate values for the program. For this 
example, enter the following:

• Select By – Distance
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• Scope – 400 nm

Note: Any changes you make to the IPM Map are dynamically 
reflected in the IPM Setup component’s Scope tab.

11. Click Scenario Mgr to close the IPM Setup components and return to the Scenario 
Manager component. Continue to change the parameters for each Model element 
in each scenario.

12. If you want to re-use an element in another scenario (for example, BWI and DCA 
are used in Scenario 1 and Scenario 2). Select the down arrow next to the Scenario 
label and select Copy to > Scenario 2 (see Figure 10 - 4). This copies the list of 
elements and all parameters to Scenario 2.

Figure 10 - 4 : Copy To Functionality

13. If you have been modeling a GDP for a while, you may have missed some 
incoming ADLs. Before modeling the GDP parameters, you may want to update 
the data for your proposed TMI. To do this, click Reload All on the IPM Setup 
component. The Reload All button is active only when the actual data time is more 
recent than the data available in IPM mode. Clicking Reload All also models all 
elements in all scenarios.

14. Click Model All to model all scenarios. Note the logic used to model the programs:

• Airports are modeled before FCA/FEAs.

• Elements are modeled in the order that they are listed.

• Impact data elements are processed after all TMIs are modeled.

• Each scenario is a separate optional operational solution, only one of which 
can be implemented. Each scenario is processed independently of other 
scenarios.

• All scenarios are modeled.

15. Click Reset All Parameters to clear any elements of the modeled data, and return 
the IPM settings to their defaults. You cannot reset just one element. To reset just 
one element without resetting the other elements, remove it and re-add it to the 
scenario by selecting the element, and clicking Remove.
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The previous steps reviewed changing parameters through the IPM Setup Component. An 
alternative method is to click the Scenario tab in the Scenario Manager component and 
update the Program Type, Program Rate, Scope, Start Time, and End Time fields 
directly on the Scenario tab. (see Figure 10 - 5).

Figure 10 - 5 : Changing Parameters on Scenario Tab

Using Modeled Data in a Program
If you want to run a program using the modeled parameters for an element:

1. Click the appropriate Scenario tab in Scenario Manager. From the Element Id 
dropdown menu, select Open New GDT Mode Instance (see Figure 10 - 6). This 
opens a new instance of GDT Mode and copies all the parameters to that GDT 
Mode. GDT Mode is opened with the ADL currently opened in the Scenario 
Manager. If the element’s ADL for the Scenario Manager is later than the current 
ADL time, click Reload All.
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Figure 10 - 6 : Open New GDT Mode Instance

2. Click Run to send the program.

Note: This may yield different results and metrics than your model.

Modeling Analysis

Preview Your Work
After clicking Model All or Reload All in the IPM Setup component, all IPM components 
are updated with the modeled GDPs. Viewing these components can help you determine 
the effect of the model GDPs on the impact data set. The IPM components are the same as 
what you view in GDT Mode. All of the following components are based on a BWI 
modeled GDP program.

IPM Multi Graph Component
The Multi Graph component provides a comparative view of the bar graphs of all the data 
sets in the scenario (see Figure 10 - 7). The functionality is the same as that found in GDT 
Mode Bar Graph; however, there are some menu option differences. See Chapter 3: 
Integrated Program Modeling Components for information on the menu differences.
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Figure 10 - 7 : IPM Multi Graph View
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IPM Metrics Tab
The Metrics grid is accessed on the IPM Multi Graph component. It contains expandable 
trees to simultaneously display consolidated statistics across all scenarios (see Figure 10 - 
8). Use different combinations of the Grouping and Display options to analyze the data. 

Figure 10 - 8 : IPM Metrics Tab Grouped by Resource
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IPM Time Line Component
To open the IPM Time Line, select View > IPM Time Line from the IPM Setup component. 
You can preview the changes made in the Time Line as a result of running the IPM model 
(see Figure 10 - 9). A quick glance at the Time Line shows you the distribution of flights, 
the number of cancelled flights (squares), and the number of delayed flights (triangles).

Figure 10 - 9 : IPM Time Line View

IPM Bar Graph Component 
By default, the IPM Bar Graph displays both solid and hashed bars. Solid bars represent 
the original data, while hashed bars represent modeled data. Uncheck View > Current Data 
from the IPM Bar Graph to view only modeled data. The modeled AAR line (dashed 
white line) is displayed by default when in IPM mode. The Bar Graph can indicate if the 
stack at the end of the program is a potential problem and allows you to view the overall 
impact of the program (see Figure 10 - 10).
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Figure 10 - 10 : IPM Bar Graph View With Current Data Option Unchecked

For more information on the IPM Bar Graph component, see Chapter 3: Understanding 
Components.

IPM Data Graph Component
The IPM Data Graph provides a visual statistical representation of the modeled GDP. The 
Power Run option that you ran is displayed on the X-axis (see Figure 10 - 11). Using your 
mouse, drag the black vertical line to the desired Power Run option or just click the mouse 
over the desired option to move the line. The delay statistics to the left of the Data Graph 
reflect the line of delineation of the scenario. Additionally, changing the Power Run 
option automatically updates all IPM components to reflect the new parameters. Rolling 
your mouse over any line in the Data Graph gives you the delay statistic count for the 
colored line that reflects the results of the option.
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Figure 10 - 11 : IPM Data Graph View

For more information on the IPM Data Graph component, see Chapter 3: Understanding 
Components.

IPM Map Component
The IPM Map component provides a visual representation of the modeled scope of the 
GDP (see Figure 10 - 12). The burgundy highlighted areas indicate the scope of Non-
Exempt flights. Airports that are colored red are Non-Exempt and Airports colored green 
are Exempt due to the scope of the modeled GDP. Clicking an Airport or Center will 
change the scope of the GDP and simultaneously update the IPM Setup component.
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Figure 10 - 12 : IPM Map View

For more information on the IPM Map component, see Chapter 3: Understanding 
Components.

IPM Flight List Component 
To open the IPM Flight List, select View > Flight List from the IPM Setup component. The 
IPM Flight List allows you to view the modeled results for multiple flights (see Figure 10 
- 13).
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Figure 10 - 13 : IPM Flight List View

For more information on the IPM Flight List component, see Chapter 6: Viewing Flight 
Information.

IPM Demand By Center Component 
To open the IPM Demand by Center, select View > Show Demand from the IPM Setup 
component or click Show Demand on the Scope tab. The IPM Demand By Center 
component displays non-active, non-completed, and included flights that are Non-Exempt 
or Exempt by the modeled GDP (see Figure 10 - 14). Included flights are the combination 
of both Exempt and Non-Exempt flights included in the modeled GDP. The Demand by 
Center component lists all Centers and the top five airports, as defined by the number of 
included flights within each center for the modeled GDP. Click the key icon to the left of 
the Center coloring to expand the Center selection and display the airports. The Centers 
are ordered in descending order based on the number of Non-Exempt flights. The red 
colored Centers indicate that there is at least one Non-Exempt flight within the Center. 
Using this component can help you make decisions on the scope of your GDP based on 
the number of Non-Exempt and Exempt flights.
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Figure 10 - 14 : Demand by Center View

For more information on the Demand by Center component, see Chapter 3: Understanding 
Components.
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11:  Issuing an Initial Program
This chapter assumes that you have already modeled your Ground Delay Program (GDP) 
or Airspace Flow Program (AFP) and you have decided that the modeled parameters are 
the best Traffic Management Initiative (TMI) to control the demand at the airport you are 
monitoring. See Chapter 8: Modeling a Ground Delay Program and Chapter 9: Modeling 
an Airspace Flow Program for more information on how to set and model your 
parameters.

GDP/AFP Coversheet
Click Run Proposed or Run Actual after you complete and model your GDP/AFP from 
the GDT Setup component. Clicking Run Proposed or Run Actual saves the parameters 
to a file specified in FSM’s configuration file and opens the GDP or AFP Coversheet. 
Clicking Run Proposed or Run Actual also generates three reports, the FADT, Analysis, 
and Carrier Statistics Reports. From the View menu, select FADT, Analysis, or Carrier 
Statistics. See Chapter 21: Understanding and Using FSM Reports for more information 
on reports.

Note:  If you modeled your program, the red border around the GDT 
Setup Panel no longer is displayed and the Run Proposed or 
Run Actual buttons are enabled. If you change any parameter in 
the GDT Setup component, you must click Model first, and then 
Run. Clicking Reload retrieves the most current ADL and 
models at the same time.

The GDP/AFP Coversheet contains all the GDP or AFP parameters from the GDT Setup 
panel and an Advisory/Causal Factors section that must be completed before the program 
is sent to the hub site. From the Program Parameters dropdown, select View Program 
Results to view flight and stack information. Select View Delay Assignment to view the 
program’s slot allocation and delay distribution. 

Figure 11 - 1 Coversheet View Options

Click Send Actual/Proposed GDP <Program Type> or Send Actual/Proposed AFP 
<Program Type> from the Coversheet to issue the GDP or AFP and send the Advisory/
Causal Factor, as shown in Figure 11 - 2.
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Figure 11 - 2 : AFP Coversheet
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For more information on the Coversheet component, see Chapter 3: Understanding 
Components.

Reviewing Program Parameters
Reviewing the program parameters is important before issuing the program. Ensure that 
the Program Parameters section on the Coversheet accurately reflects all of your inputs on 
the GDT Setup panel.

Creating an Advisory
Before sending a program, you must complete the Advisory/Causal Factors section of the 
Coversheet. The Respond By field is only available during a proposed event. You must 
complete all enabled fields before sending the program.

Figure 11 - 3 : Coversheet Advisory Section

Place a checkmark next to each section of the Coversheet after you have reviewed the 
parameters, facilities, and advisory/causal factors information. To review the Advisory 
text before sending the event, from the Advisory/Causal Factors dropdown, select 
Preview Advisory. 

Figure 11 - 4 Preview Advisory Option

This opens the program Advisory overlay in text format (see Figure 11 - 5).

For more information on the Advisory/Causal Factors section of the Coversheet, see 
Chapter 3: Understanding Components
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Figure 11 - 5 : Advisory Preview

To send the Program and Advisory click Send Actual/Proposed <Program Type> 
located at the bottom of the Coversheet. 

When you click Send Actual <Program Type>, the FSM client interfaces with TFMS 
Autosend Server and sends the web coversheet XML file to NTML and the FADT file to 
the hub site. The Autosend Server also invokes TFMS E-mail and sends the Advisory to 
the specified address list. TFMS E-mail puts the ATCSCC position number and phone 
number in the Advisory signature line.

When you click Send Proposed <Program Type>, only the proposed parameters and 
Advisory is sent.

Click Close and no action is taken from the Coversheet window.

Program Manager
Clicking Send Actual/Proposed <Program Type> activates the Autosend process and 
opens the Program Manager dialog which displays the status window and progress bar at 
the bottom of the window (see Figure 11 - 6). The Program Manager performs a list of 
actions based on the type of program sent - proposed or actual. Some actions specify the 
next action to perform sequentially upon completion of the first action. If an action fails, a 
dialog is displayed asking if further sequential action should be performed or if the 
process should be stopped.
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Figure 11 - 6 : Program Manager

For more information on the Program Manager see Chapter 3: Understanding 
Components.

Note:  If you click Send Actual/Proposed <Program Type> more 
than 15 minutes after modeling your program, it is 
recommended that you close your Coversheet and Reload to get 
the most recent data from an updated ADL before continuing 
with the program operation.

Resending Coversheet Information
If your program parameters, advisory, or EDCTs were not properly sent the first time, you 
can select information you would like to resend from the Coversheet. If the Coversheet is 
not already open, open the Coversheet from the GDT Setup panel. Select File > Open 
Coversheet. This opens a file selection window for the Reports directory. You should see 
all Coversheets generated for that airport.

Note: The Coversheet files are saved in the reports directory until you 
choose to delete them.

FSM generates Coversheet files when you run a new or revised GDP, AFP, GS, 
Compression, or Blanket. FSM also generates Coversheets when you purge (cancel) a 
program. You can differentiate among the Coversheet files by looking at the last few 
letters in the file name:

• GDP indicates a GDP Coversheet.
• AFP indicates an AFP Coversheet.
• GS indicates a Ground Stop Coversheet.
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• COMP indicates a Compression Coversheet.
• BLKT indicates a Blanket Coversheet.
• Purge indicates a CNX Coversheet.

FSM names a typical Coversheet file by: 

• Type of file (for Coversheets, it is always fsmc)
• Airport or FCA
• 2-character date (just the day)
• Time generated (HHMMSS)
• Rate used
• Type of Coversheet (gdp, afp, gs, comp, blkt, purge)
• Scope included

For example, a file named “fsmc.SFO.28150808.3030.GDPNew.ALL” indicates a New 
GDP (first GDP of the day) Coversheet generated for SFO airport on the 28th at 1508Z 
with a 30 rate that includes all centers in the program.

Once you find the appropriate Coversheet file, click the file name to select it and click 
Open. The Coversheet opens in FSM exactly as it appeared the first time FSM generated 
it

Note: Even though you can open an old Coversheet, enough time may 
have passed that it would be better to generate a new program 
and Coversheet.

The Resend menu contains four options: Resend Program, Resend Parameters, Resend 
Advisory, and Resend Program & Advisory (see Figure 11 - 7).

Note: The Resend menu options are only available after Send Actual/
Proposed <Program Type> has been initially clicked on the 
Coversheet.

Figure 11 - 7 : Coversheet Resend Menu Options

Below is a description of the Resend menu options and when they are available. 
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• Resend Program: Invokes the TFMS Autosend process to send the FADT file to the 
hub site and the Coversheet file to NTML, as well as remote copies the files. This 
option is only available for Actual GDPs and AFPs.

• Resend Advisory: Uses an existing advisory number (if available) and invokes the 
TFMS Autosend process to send only the Advisory for the program. This is available 
for all Proposed and Actual TMIs.

• Resend Program and Advisory: This is the same process as clicking the initial Send 
button from the Coversheet and is only available for Actual Programs.

Purging a Program
To purge (cancel) and release all delay on flights included in a program, use the Purge 
function from the GDT Setup Component. The Purge option requires no user input; 
however, for modeling purposes only you can change Purge Notification (Minutes) for 
Taxied, GS, or GDP/AFP (see Figure 11 - 8). 

Figure 11 - 8 : Purge Notifications (Minutes) Values

Note: Changing Purge Notification (Minutes) values is for modeling 
only. The actual purge uses the default values.

Click Model and review the Bar Graph to ensure the demand versus capacity are 
acceptable after running the purge algorithm and then click Run Actual/Proposed to 
generate the CNX Coversheet (See Figure 11 - 9).
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Figure 11 - 9 : Purge Coversheet
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After you review the information, select the Program Parameters checkbox. The 
Advisory/Causal Factors section of the Purge Coversheet must be completed before you 
proceed. For more information on the Coversheet component, see Chapter 3: GDT 
Coversheet.

Purge Coversheet
From the Purge Coversheet, click Send Actual Purge to purge any control times from the 
TFMS system. Purge works the same as the Send Actual <Program Type> function from 
other Coversheets as far as sending new operation parameters, advisory, and cancellation 
messages to the Hub site for inclusion in the ADLs.

Viewing Flight Information before Purging a Program
When you model a purge for a program, TFMS sets the minimum notification time to the 
value of the minimum notification time for flights in a program. For the controlled flights 
affected by the purge, FSM determines the minimum notification time based on the type 
of control and taxi status of the flight. If a controlled flight is in a taxi status, without 
regard to the type of control, then FSM sets the minimum notification time to the value of 
the minimum notification time for flights in a taxi status.

TFMS models a new estimated departure time based on the flight’s control departure time 
and the minimum notification time based on the following criteria:

• If the flight is active or completed, TFMS sets the ETD to the actual departure time.
• If the CTD of the flight is within the minimum notification time from the current time, 

the estimated departure time remains set to the CTD.
• If the CTD of the flight is greater than the minimum notification time plus the current 

time, then TFMS calculates a candidate ETD selected from the following values in 
order of priority:

1. Earliest Runway Departure Time

2. Earliest Runway Arrival Time minus the Estimated Time En route

3. Original Estimated Departure Time

4. Initial Gate Departure Time plus the taxi time for the flight
• If this candidate time is greater than the current time plus the minimum notification 

time, then TFMS sets the ETD to this candidate time.
• If the candidate time is less than the current time plus the minimum notification time, 

then TFMS sets the ETD to the current time plus the minimum notification time.

Issuing a GDP Example
The section below is an example of how to issue a General Aviation Airport Program 
(GAAP) GDP. When the known demand does not exceed the capacity at an airport but you 
think that the unknown demand will exceed capacity, you can use a GDP with a Delay 
Assignment Mode of GAAP to control traffic flow into the airport. This situation usually 
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occurs at airports that serve large numbers of General Aviation (GA) flights. The GAAP 
was designed for this situation. As usual, known flights receive a slot, but TFMS also 
generates unassigned slots for unknown demand. As flights become known, TFMS assigns 
them to one of the open slots or gives them DAS delay. The DAS delay time also differs in 
that it is one set value for all flights. No flight at a GAAP airport receives a delay longer 
than the maximum delay limit entered by the user. 
To issue a GAAP GDP

1. Click Open Data Set.
The Open Data Set window is displayed.

2. Select the airport for which you want to issue the GAAP GDP.

3. Click OK.
The Time Line and Bar Graph components for the airport are displayed.

4. Click GDT Mode on the Control Panel.
The GDT components for the airport are displayed.

5. Select GDP - GAAP for the Program Type.

6. Select the appropriate values for the Program Time section of the Parameters tab 
on the GDT Setup Panel.

7. Enter the appropriate Program Rate and Pop-Up Factor for the GAAP GDP in the 
Program Rate section.

8. Enter the GAAP Delay Limit appropriate for the GAAP GDP. The default value is 
180.

9. Select any Slot Hold Override that is necessary for the GAAP GDP.

10. Select any Exempt AFPs that you want to try to keep the AFP flight’s CTD equal 
or close to their current CTD.

11. Set the Scope for the GAAP GDP on the Scope tab. It is recommended to issue an 
ALL program for GAAP GDPs.

12. Select the Power Run you want FSM from the Modeling Options tab to use for this 
GAAP GDP.

13. Click Model.
The red border in the GDT Setup Panel no longer is displayed and all the GDT 
components reflect the modeled GAAP GDP.

14. If the program seems to deal with the traffic flow in the manner you want, click 
Run Actual to generate the Coversheet.
The Coversheet window is displayed.

15. Carefully examine each section of the Coversheet. If the data is correct, select the 
Program Parameters checkbox.

16. Complete the Advisory/Causal Factors section of the coversheet.
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17. Modify the Respond By time if Proposed was selected.

18. Modify the Valid Until time as necessary.

19. Select the Category for the GAAP GDP.

20. Select the Cause.

21. Select the Advisory/Causal Factors checkbox.

22. Click Send Actual GDP - GAAP. 
The Program Manager window opens and activates the Autosend process.

The unassigned slots for the GAAP GDP are displayed in the Time Line and Bar Graph 
components for the airport, an Unassigned slots block is displayed in the ADL, and an 
UNASSIGNED_SLOTS block is displayed in the FADT.
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12:  Monitoring Program Delivery

Introduction
When a Ground Delay Program (GDP) or Airspace Flow Program (AFP) is in effect, you 
want to monitor the progress of the program to ensure the program is affecting NAS 
operations in the intended manner. You also want to ensure that flights included in the 
program are complying with the program parameters. FSM generates various reports and 
statistics for monitoring a program’s progress. 

Monitoring Delivery Using the Time Line and Bar Graph

Time Line Component
During a program, it is easy to view the Time Line to get a general idea of how evenly the 
flights are distributed throughout an hour and of how many cancelled or delayed flights 
are in the program. Filled triangles represent delayed flights and are displayed on the Time 
Line only when a GDP or AFP is in effect. The filled triangle indicates an open arrival slot 
due to a delayed flight. TFMS leaves the arrival slot open and makes it available for use by 
other flights. Clicking this icon also highlights the associated delayed flight.

The filled square icon is displayed only when a GDP or AFP is in effect and represents an 
arrival slot left open by a cancelled flight. Cancelled flights are displayed in cyan on the 
Time Line under the CNX heading and are highlighted when you click their associated 
slot. If there are numerous open slots, or solid triangles and squares, you may need to use 
a compression or revision to use the empty slots (see Figure 12 - 1).

The white diamond icon is displayed on the Time Line when a GDP with a GAAP delay 
assignment is in place. This icon represents Unassigned Slots. As pop-up flights become 
known, TFMS assigns them to one of the unassigned slots or gives them a DAS (formerly 
FA) delay equal to the delay limit.

Flights that have dropped out (DO) of an AFP but are still operating (rerouted out of the 
FCA) are displayed in salmon under the CNX/[DO] heading.

Bar Graph Component
During a program, use the Bar Graph component to view the distribution of flights, within 
each hour. To view how flights are distributed in smaller time increments, click the 15 or 
30-minute bin selection buttons located below the Bar Graph menu bar. The default time 
increment is set to 60 minutes. In addition to viewing the flight distribution, you can view 
how many cancelled flights and unassigned slots are in the program. Select the Show 
Cancellation shortcut button to display the cancelled flights (cyan) on the Bar Graph. 
During a GAAP GDP it may be useful to select the Control Type tab to monitor how your 
GAAP GDP is performing (see Figure 12 - 1). Click the Color Legend shortcut button to 
view what the colors represent.
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Note: AFP DO flights are not displayed in the Bar Graph because they 
are not considered demand or potential demand.

Figure 12 - 1 : Bar Graph displayed by Control Type for a GDP

White sections are displayed on the bars when a GDP or AFP with a GAAP delay 
assignment is in place. These sections represent Unassigned Slots. As pop-up flights 
become known, TFMS assigns them to one of the unassigned slots or gives them a DAS 
delay equal to the Delay Limit.

Flight List Component
During a program, use the Flight List component to view specific information for flights. 
For example, the Flight List can be useful to view what Control Element flights are 
controlled by when there are multiple AFPs and GDPs in place. Figure 12 - 2 displays a 
Flight List for an AFP grouped by Control Element (CTL_ELEM).
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Figure 12 - 2 : Flight List Grouped by Control Element
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Monitoring Effects on NAS Users
You can open several reports from the Reports menu on the Control Panel component. 
You can use these reports to monitor the effects of the selected program on NAS users.

Surface Delay Report
Select Reports> Surface Delay to generate a report that indicates the ground delay imposed 
on flights. The report contains departure information for both arriving at the control 
element. See Chapter 6: Flight Lists for more information on Flight Lists.

Priority Flight List
Select Reports > Priority Flights to view this report. This report identifies priority flights. 
It is similar to an FSM Flight List, but lists only those flights tagged as Lifeguard (LFG) or 
Diversion Recovery (DVT) flights.

Time Out Delay List
Select Reports > Time Out Delay to view this report. The Time Out Delay Report quickly 
provides a picture of which flights are contributing to the Time Out delay problem. The 
report is in the same format as FSM Flight Lists and includes all flights whose delay status 
is `TOD.'

Time Out Cancel List
Select Reports > Time Out Cancel to view this report. The Time Out Cancel Report 
provides a picture of which flights are contributing to the Time Out cancel problem. The 
report is in the same format as FSM Flight Lists and includes all flights whose 
cancellation status is `TO.'

Slot Hold
Select Reports > Slot Hold to view this report. This report generates a flight list of all 
flights that are currently holding their cancelled slots.

Sub Opportunities (Airline and General Aviation Users Only)
Select Reports > Sub Opportunities to view this report. This report generates a flight list to 
assist airlines and general aviation customers in identifying subbing opportunities. Two 
columns, ERTA-CTA for Airport data sets or EENTRY - CTA for Airspace data set and 
SchedVar, help illustrate the most eligible flights to be subbed (see Figure 12 - 3).
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Figure 12 - 3 : Sub Opportunities Report

Slot List
You can view the Slot List for airlines or centers with the following two Slot List reports:

• By Carrier
• By Center

Slot List By Carrier

Select Reports > Slot List > By Carrier to view this report. The Slot List report generates 
the second part of the FADT List that FSM generates after a program runs. Included in the 
Slot List are the Aircraft Identification number (ACID), assigned slot time (ASLOT), 
departure center (DEP), arrival center (ARR), controlled time of departure (CTD), 
controlled time of arrival (CTA), aircraft type (TYPE), exemption status (EX), 
cancellation status (CX), slot hold status (SH), earliest runway time of arrival (ERTA), and 
initial gate time of departure (IGTD) (see Figure 12 - 4).
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Figure 12 - 4 : Reports > Slot List > By Carrier

Slot List by Center

Select Reports > Slot List > By Center to view this report. This report allows any field 
facilities to recreate a slot list should the list normally transmitted by the TFMS not be 
received. The report is based on the current ADL. FSM allows the user to select a center’s 
(or centers’) report to view. Users can select US and Canadian Centers.
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To generate a Slot List By Center report

1. From the main Control Panel select Reports > Slot List > By Center. The Slot List 
By Center dialog box opens (see Figure 12 - 5).

Figure 12 - 5 : Slot List by Center

2. Select the Centers to be included in the report and click OK. Clicking Clear All 
erases all selections in the Slot List By Center dialog box. Clicking OK after you 
click Clear All returns you to the Time Line window. Clicking Cancel closes the 
Slot List By Center dialog box without taking any action.

3. The data fields and menu options in the Slot List by Center report are the same as 
the Slot List by Carrier report. Note that the Slot List by Center report title is B6 
List Report (see Figure 12 - 6).
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Figure 12 - 6 : Reports > Slot List > By Center

Carrier Statistics
Select Reports > Carrier Statistics to view this report. The report shows delay statistics for 
all carriers with flights that operate at that particular control element. FSM calculates 
flights only with assigned slots in the report metrics. That is, flights with a Control Time 
of Arrival (CTA) are displayed in carrier statistics. If a carrier has no flights with a CTA, 
the Carrier Statistics report displays “0” or “N/A” in those rows. You can choose the type 
of delay to view in the report by selecting the Delay Type of Program or ABS at the top 
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right of the report. FSM selects the ATC delay type by default. ABS Delay is the absolute 
delay on flights, including FAA and airline delay imposed on the flights. FSM calculates 
absolute delay using Max (0, ETA - [IGTA - Taxi]). Program Delay is the delay imposed 
due to a TMI on flights. FSM calculates it using [Max (0, CTA - BETA)] for a GDP or 
[Max (0, CTA - BENTRY)] for an AFP. Any time a flight’s CTA is updated, the Program 
Delay is recalculated.

The report displays delay statistics for all carriers that operate at an airport or that are 
flying through the selected FCA. Carriers with no presence at the control element do not 
show up in the Carrier Statistics report (see Figure 12 - 7).

 

Figure 12 - 7 : Carrier Statistics

For more information on the Carrier Statistics Report, see Chapter 21: Carrier Statistics 
Report.

Monitoring Flight Counts
FSM generates Flight Count reports for monitored data sets currently in a program. Under 
the Reports > Counts > menu option on the main Control Panel there are eight count 
reports:

• By Demand
• By Center
FSM User Guide, Version 9.00 12-9



Monitoring Program Delivery
• By Aircraft Category
• By Aircraft Class
• By Arrival Fix (Airport Data Set only)
• By Departure Fix (Airport Data Set only)
• By User
• By Unassigned Slot

See Chapter 21: Understanding and Using FSM Reports for more information on Flight 
Counts.

Monitoring Flight Compliance
FSM generates Compliance List reports for monitored data sets currently in a program. 
Under the Reports > Compliance > menu option on the main Control Panel you find five 
compliance reports:

• By CTD
• By ETE
• By CTA
• Spurious Flight
• Cancel That Flew

See Chapter 21: Understanding and Using FSM Reports for more information on 
Compliance Reports.

FSM updates the compliance reports automatically with every ADL for all Airport and 
Airspace data sets for which FSM collects data. Compliance reports include only those 
flights arriving at the currently monitored data set. The list you generate is for the data set 
that you were last viewing, therefore ensure that the desired data set is active before 
selecting the Compliance report. The Compliance reports is displayed in the same format 
as all FSM Flight Lists, see Chapter 6: Viewing Flight Information for more information 
on Flight Lists.

Monitoring Delay Histograms
FSM generates two delay histograms for monitored data sets currently in a program. 
Under the Reports > Delay Histograms > menu option on the main Control Panel you find 
two delay histograms:

• Program Delay
• Absolute Delay

The Program delay histogram displays the amount of delay that non-cancelled, non-active, 
controlled flights have received due to a Traffic Management Initiative. Program delay is 
calculated using Max (0, [CTA - BETA]) for a GDP or Max (0, [CTA - BENTRY]) for an 
AFP, therefore any time a flight's CTA is updated the Program delay is recalculated. 
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The Absolute delay histogram displays the total amount of delay that non-cancelled flights 
have received. This includes delays assigned by the National Airspace System (NAS) and 
Air Traffic Control (ATC) as well as airline delay. Absolute delay is calculated using Max 
(0, [ETA - (IGTA - Taxi)]) for a GDP or Max (0, [ENTRY - IENTRY]) for an AFP, 
therefore any time a flight's ETA or ENTRY time is updated the absolute delay is 
recalculated.

See Chapter 21: Understanding and Using FSM Reports for more information on Delay 
Histograms.

Monitoring Program Parameters
You can find the program parameter alerts for all monitored data sets under the Alerts 
menu on the Control Panel component. All monitored data sets are listed in alphabetical 
order under the Alerts menu. When TFMS updates an data set’s parameters, the Alerts 
menu is highlighted in red as well as the monitored data set and its corresponding updated 
parameters. Figure 12 - 8 shows FCAA01 data set active with FADT Parameters, SCS 
Bridge parameters, and Actual AFP Parameters updated. DFW also has updated 
parameters. Once you read the updated parameters, the parameter color returns to its 
original state. FSM lists the parameters of the data set currently active on the main Alerts 
menu. Clicking the other data sets activates a pop-up box that displays the parameters for 
the selected data set. If you select another data set, the Alerts menu changes accordingly.

[
Figure 12 - 8 : Alerts Menu
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FADT Parameters Updated
The Alerts > FADT Parameters Available menu option is highlighted in red when there is a 
new FADT. FADTs are reports generated when you run a GDP, AFP, GS, Blanket, or a 
Compression operation. Selecting FADT Parameters Available displays a pop-up window 
that lists the time the FADT was generated during the day for the selected airport in 
[ddhhmmss] format (see Figure 12 - 9). This option does not actually give you program 
parameters. 

Note: FSM does not always list the FADTs in chronological order.

Figure 12 - 9 : FADT Parameters Window

SCS Bridge
Alerts > SCS Bridge is highlighted red in color when there is a new SCS update. Selecting 
SCS Bridge displays the Substitution Flag Block window, which displays the current 
subbing status (see Figure 12 - 10). The Substitution Flag Block may contain the 
following keywords:

• SUBS: Indicates whether all substitutions are enabled (ON) or disabled (OFF)
• SCS: Indicates whether slot credit substitutions for all operators are enabled (ON) or 

disabled (OFF)
• ADPT: Indicates whether adaptive compression is enabled (ON) or disabled (OFF).
• BRIDGING: Indicates whether bridging subs are disabled (OFF) for a particular 

operator (Airline, GA, or Military). If bridging is off for an airline, any flight that has a 
MAJOR field or carrier code (from ACID) that matches the airline name is not used 
for an SCS bridge. If bridging is enabled for an operator, no line is displayed, that is, 
the only allowed value for this keyword is OFF.

Figure 12 - 10 : SCS Flag Block Window
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Note: By default, Military and GA bridging is disabled.

GDP or AFP Parameters
Alerts > Actual GDP/AFP Parameters Available is highlighted in red when FSM receives 
Actual GDP/AFP Parameters through the ADL. First-time Parameters, new Parameters, 
and deleted Parameters all trigger this Alert. Select Actual GDP/AFP Parameters Available 
to view the parameters that FSM takes from the FADT file and displays in a static GDT 
Setup window (see Figure 12 - 11). Tab navigation allows you to view all the parameters, 
although you cannot make changes to this window. If no Actual Parameters exist, the text 
reads No Actual GDP/AFP Parameters.
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Figure 12 - 11 : Actual GDP Parameter Display Window

Alerts > Proposed GDP/AFP Parameters Available is highlighted in red when parameters 
for a Proposed GDP or AFP arrive through the ADL. Select Proposed GDP/AFP 
Parameters Available to view the proposed parameters, which FSM takes from the FADT 
file and displays in a static GDT Setup window. Tab navigation allows you to view all the 
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proposed parameters, although you cannot make changes to this window. If no Proposed 
GDP or AFP Parameters exist, the text reads No Proposed GDP/AFP Parameters.

GS Parameters
Alerts > GS Parameters Active is highlighted in red when the FAA issues a Ground Stop 
and FSM receives its parameters through the ADL. First-time GS Parameters, new GS 
Parameters, and deleted GS Parameters all trigger this Alert. Select GS Parameters 
Available to view the parameters, which FSM takes from the FADT file and displays in a 
static GDP Setup window (see Figure 12 - 12). Tab navigation allows you to view all the 
GS Parameters, although you cannot make changes to this window. If no GS Parameters 
exist, the text reads No GS Parameters.

Figure 12 - 12 : Actual GS Parameters Window

Compression Parameters
When FSM receives parameters for the compression function through the ADL, it triggers 
the Alerts > COMP Parameters Available. When Compress Flights or Compress Slots 
Parameters arrive, COMP Parameters Available is highlighted in red for the corresponding 
airport. Select COMP Parameters Available to view the new parameters, which FSM takes 
from the FADT file and displays in a static GDT Setup window. Tab navigation allows 
you to view Compression Parameters, although you cannot make changes to this window. 
If no Compression Parameters exist, the text reads No COMP Parameters.
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Blanket Parameters
When the FAA lifts or adds delay to flights in a ground delay program, FSM triggers the 
Alerts > BLANKET Parameters Available. When FSM receives the message through the 
ADL to add or remove delay for all flights, it highlights the BLANKET Parameters 
Available text in red. Select this menu option to view the new parameters, which FSM 
takes from the FADT file and displays in text format in the Blanket Parameters window. If 
no Blanket Parameters exist, the text reads No BLANKET Parameters.

Parameters Block
You can view the parameters block for a program by opening the static Parameter Display 
window from the Alerts menu on the Control Panel. From the Parameter Display window, 
select View> Parameters Block to see the parameter block for the program (see Figure 12 - 
13).

Note: For programs with a Delay Assignment Mode of GAAP, the 
Parameters Block includes Unassigned Slots information.

Figure 12 - 13 : Parameters Block
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13:  Monitoring EDCT Compliance
Estimated Departure Clearance Time (EDCT) compliance impacts the success of a 
Ground Delay Program (GDP) or Airspace Flow Program (AFP). Real-time monitoring of 
EDCTs is possible through FSM to identify problem areas as they occur, therefore 
reducing EDCT compliance issues. This chapter introduces several options for monitoring 
EDCT compliance of a program.

The Reports menu on the FSM Control Panel contains five compliance flight lists: 

• CTD Compliance
• Actual ETE vs. Original ETE Compliance
• CTA Compliance
• Spurious Flight Compliance
• Cancel That Flew Compliance

The functionality of compliance flight lists is identical to all other FSM Flight Lists. This 
chapter focuses on CTD compliance for monitoring EDCT compliance of a program. See 
Chapter 21: Understanding and Using FSM Reports for more information on other 
compliance reports.

To view a list of flights that had non-complaint EDCTs, select Reports > Compliance > By 
CTD from the Control Panel component (see Figure 13 - 1). The CTD Compliance list 
includes all flights in a delay program that violate departure compliance. The default 
departure boundaries are:

More than five minutes before their EDCT or more than five minutes after their EDCT.

Any flight that has an ARTD of five minutes earlier or five minutes later than the most 
recent OrigEDCT is displayed in the Reports > Compliance > By CTD list.

Note: Ensure that the data set for which you want to view the 
compliance report is active. If no data set is active, FSM 
displays an error message- “No current data set”.
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Figure 13 - 1 : Accessing the CTD Compliance List

When you open the CTD Compliance list, FSM displays by default the flights’ ACID, 
ORIG, DEST, ETD, ETA, ARTD, ARTA, CTD, CTA, and ARTD-CTD are displayed. 
The ETD has a prefix “A”, which indicates that the flights’ ETD is the Actual time of 
departure (see Figure 13 - 2). The total count of all CTD non-compliant flights is 
displayed in the lower left-hand portion of the CTD Compliance window. The CTD 
Compliance window automatically updates when FSM receives a new ADL.
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Figure 13 - 2 : CTD Compliance Window

Viewing a Single Flight
You can access more information on a single flight in two ways from the CTD 
Compliance window. Right-click a single flight row or use the View menu. Right-click a 
flight and select either Flight Info or Flight details for more information on the selected 
flight (see Figure 13 - 3), or click a single flight to highlight the entire row and then select 
View > Flight Info or Flight Details to access the same information.

Figure 13 - 3 : Accessing Flight Information
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Select Flight Info and the Flight Info for the selected flight is displayed (see Figure 13 - 4).

Figure 13 - 4 : Flight Info for Selected Flight

Adding ADL Fields
Adding ADL fields in the CTD Compliance Report is the same as adding fields to the 
Flight List. For more information see Chapter 6: To add data column information to a 
Flight List.

Column Positioning
Column positioning in the CTD Compliance Report is the same as column positioning in 
the Flight List. For more information see Chapter 6: To rearrange columns in a Flight List.

Sorting Information in the CTD Compliance List
Sorting Information in the CTD Compliance Report is the same as sorting information in 
the Flight List. For more information see Chapter 6: Sorting Information in the Flight List.

Multi-Level Sorting
Multi-level sorting in the CTD Compliance Report is the same as multi-level sorting in the 
Flight List. For more information see Chapter 6: Multi-Level Sorting.

Compliance List Menu
The menu bar in the Flight List component contains four options: File, View, Flight List 
and Help. The functionality of compliance flight lists is identical to all other FSM Flight 
Lists.

1. File Menu
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• File > Save As – Saves the Compliance List to an Excel spreadsheet, which you 
can open later and use again.

• File > Print – Prints the Compliance List information viewed on the screen.

• File > Close – Closes the Compliance list window.

2. View Menu

• View > Rename Window – Displays the Rename Window dialog box and 
allows you to change the title bar name.

• View > Add/Remove Columns – Allows you to add or delete ADL data fields to 
the Flight List.

• View > Group Flights – Allows you to group ADL data fields to the Flight List 
in ascending or descending order.

• View > Sort Flights – Allows you to sort ADL data fields to the Flight List in 
ascending or descending order.

• View > Apply Filter – Allows you to apply a filter to the data fields in the Flight 
List.

• View > Clear Filter – Allows you to clear a filter from the data fields in the 
Flight List.

• View > Flight Info – Opens the Flight Info window.

• View > Flight Detail – Opens the Flight Detail window.

3. Flight List Menu

• Flight List > Set Time – Sets the time for the Flight List component in 
Historical mode only.

• Flight List > Search by Call sign – Opens the Search by Call sign window.

4. Help Menu

• Help > CTD Compliance – Accesses the web-based on-line help for the CTD 
Compliance Report.

Exporting Compliance List to an Excel Spreadsheet
1. From the Compliance window menu bar, select File > Save As. The Save Compli-

ance As dialog box opens.

2. Enter a name in the File Name field.

3. Microsoft Office Excel Worksheet (*.xls) is the default file type in the Files of 
Type dropdown menu. Click Save. 

4. The exported report is compatible with Microsoft Office Excel 2003 or later and 
Open Office 1.x or later. See Figure 13 - 5.
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Note:  All time values are saved as native time/date fields; therefore, 
ADL fields that combine date/time with text are exported as 
multiple cells. The date/time portion of the field is saved in one 
cell and the text portion is saved in another. For example, the 
ETD column becomes ETDprefix and ETD, the ETA column 
becomes ETAprefix and ETA, and the ASLOT column becomes 
ASLOT and SlotTime. See the highlighted text in the following 
figure.

Figure 13 - 5 : Exported Compliance List

Confirming an EDCT
The TFMS Tools > EDCT Commands > EDCT Check option is available from the Control 
Panel and displays an unfilled EDCT Check dialog box. To confirm a flight’s EDCT, type 
in the flight’s callsign, its Origin and Destination Airport, and then click Send. In addition 
to using the TFMS Tools menu, right-clicking on a single flight icon in the Time Line or 
flight row in any Flight List window opens a pop-up window that allows you to select 
EDCT Check to display the EDCT Check dialog box. The right-click method 
automatically populates the flight information (see Figure 13 - 6). Click Send to submit 
the request to TFMS. TFMS then sends a response with the flight’s current EDCT.
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Figure 13 - 6 : EDCT Check Dialog Box

Adjusting an EDCT
If you are an ATCSCC specialist and you select the TFMS Tools > EDCT Command > 
EDCT Check option from the main Control Panel, you can adjust the control times for 
individual flights. This command displays an unfilled EDCT Update dialog box. You 
must type in the flight’s callsign, Origin and Destination Airports. You can also update 
EDCTs through the ECR component, see Chapter 14: EDCT Change Request (ECR) for 
more details.

In addition to using the TFMS Tools menu, right-clicking a single flight in the Time Line 
or Flight List window displays a pop-up menu that allows you to select EDCT Update to 
open the EDCT Update dialog box. The right-click method automatically populates the 
flight’s information, requiring you to fill in only the new control times for the flight (see 
Figure 13 - 7). Click Send to submit the update to TFMS. TFMS then sends a response 
confirming the fight’s new EDCT, which is displayed in the next ADL.

Figure 13 - 7 : EDCT Update Dialog Box
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14:  EDCT Change Request (ECR)
The EDCT Change Request (ECR) tool is part of the FAA's CDM Ground Delay Program 
Enhancements (GDPE) effort. ECR has been operational at the FAA's ATCSCC since 
April 2002. ECR displays current flight information using real-time data culled from 
CDM participants and aggregated by the Hub site. It allows you to change Estimated 
Departure Clearance Times (EDCTs) for controlled flights and keep traffic flowing as 
smoothly as possible.

ECR is available for all CDM participants; however, access is based on the user type:

• NAS users can access only the SCS Update Option.
• Field users can access the SCS and Unlimited Update Options.
• ATCSCC users can access the SCS, Limited, Unlimited, and Manual Update Options.

Note: Unavailable options are hidden from the user.

The ECR component allows you to search for a flight, view current flight information, 
model suggested update times for flights, and display options for updating control times. 
The ECR title bar displays the data set, date, ADL time, and monitor mode (see Figure 14 
- 1).
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Figure 14 - 1 : Airport Data Set ECR Component

The functionality of ECR components for Airspace data sets is the same as for Airport 
data sets. The difference for an ECR component opened for an Airspace data set is that the 
ENTRY data replaces traditional airport arrival information in the Flight Information 
section. For example, instead of displaying ETA for a flight, the ENTRY time is 
displayed. ENTRY is the estimated time that the flight will enter the FCA. In addition to 
ENTRY information, the FCA_ETE data replaces the traditional ETE. The FCA_ETE is a 
flight’s Estimated Time En Route from departure to entry into the FCA (see Figure 14 - 2).
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Figure 14 - 2 : Airspace Data Set ECR Component

ECR Menu Bar
The ECR menu bar contains three options: File, View, and Help.

1. File menu

• File > Close – Closes the ECR component.

2. View menu

• View > Rename Window – Displays the Rename Window dialog box that 
allows you to change the component name of the title bar. Enter the desired 
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component name then click OK to change the title bar heading. Click Cancel 
to close the Rename Window dialog box without making any changes.

3. Help menu

• Help > ECR - Opens the on-line help for the ECR component.

Opening ECR
Use one of the following five methods to open ECR:

Note: Ensure that the correct Data Set is active.

1. Select the ECR checkbox in the Open With panel of the Open Data Set component 
and click Apply (see Figure 14 - 3).

Figure 14 - 3 : Select ECR from Open With Panel

2. Click ECR from the Control Panel (see Figure 14 - 4).
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Figure 14 - 4 : Opening ECR from the Control Panel

3. Select Utilities > ECR from the Control Panel (see Figure 14 - 5).

Figure 14 - 5 : Select ECR from Utilities Menu

4. Right-click a flight icon in the Time Line or a row in a Flight List and select ECR 
from the pop-up menu (see Figure 14 - 6). The ACID, ORIG, and flight 
information automatically display in the ECR component when you open it from 
the Time Line.

Figure 14 - 6 : Opening ECR from the Time Line
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5. Select an Airport or FCA on the Monitor Live map to turn it white, then right-click 
and select ECR from the pop-up menu.

Locating a Flight
To begin updating an EDCT, enter a flight ACID in the ECR window. Verify that your 
Airport/FCA identifier (Airport/FCA) and the last ADL Update time (ADL Update) for 
the correct data set are displayed in purple text, as shown in Figure 14 - 7. 

Note: You can open only one ECR component per data set.

Use one of the following two methods to find a flight in ECR:

1. Open ECR from the Time Line or Flight List by right-clicking a flight icon or 
flight row and selecting the ECR option. ECR automatically finds flight informa-
tion and populates the appropriate fields in the ECR component.

2. Enter a flight’s aircraft identifier in ACID and click Get Flight Data.
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Figure 14 - 7 : Updating an EDCT using ECR

Viewing Flight Information
After ECR finds a flight, the current information is displayed under the Flight Information 
section. The tables below illustrate the fields listed in the current data section for Airport 
and Airspace data sets.

Airport Data Set Current Flight Data
IGTD Initial gate time of departure IGTA Initial gate time of arrival
CTD Current control time of departure CTA Current control time of arrival
ETD Estimated time of departure ETA Estimated time of arrival
FSM User Guide, Version 9.00 14-7



EDCT Change Request (ECR)
Updating an EDCT for a Flight
After finding and displaying the flight’s current information, enter the flight’s new 
Earliest EDCT in the Find Flight section of the ECR component.

1. Enter the earliest EDCT to which the flight can comply in Earliest EDCT.

2. Click Apply Model at the bottom of the screen to populate the Current Flight Data 
section and to model different update parameters based on the new Earliest EDCT 
data. 

Note: If you need to reset the ECR to its default state, click Clear All.

3. Select the desired update option. For Limited CTA Range, select SCS or Limited. 
For Unlimited CTA Range, select Unlimited. You also can select Manual. FSM 
selects the SCS radio button by default when SCS is a valid option (NAS Users 
can access only the SCS Update Option, Field users can access the SCS and 
Unlimited Update Options, and ATCSCC users can access the SCS, Limited, 
Unlimited, and Manual Update Options).

Note: You can also set the ERTA. For more information see Chapter 
14: Adjusting the CTA Range.

4. Click Send Request to send the request to the Hub site. The ECR component is 
disabled while it waits for a response.

ETE Estimated time en route (departure to arrival)
ERTD Earliest runway time of departure ERTA Earliest runway time of arrival

Airspace Data Set Current Flight Data
IGTD Initial gate time of departure IENTRY Initial FCA ENTRY time
CTD Current control time of departure CTA Current control time of arrival at 

FCA
ETD Estimated time of departure ENTRY Estimated time of arrival at FCA
FCA_ETE Estimated time en route (departure to FCA 

entry)
ERTD Earliest runway time of departure EENTRY Earliest FCA ENTRY time

Update Options
CTA 
Range

Interval between the New 
Earliest CTA and the sum of 
the New Earliest CTA and 
Maximum Additional Delay

Max 
Additional 
Delay

The maximum additional 
amount of delay (in minutes)

CTD Current control time of 
departure

CTA Current control time of arrival 

E_CTA New earliest CTA requested
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5. Click Cancel to end the request, if you decide you no longer need the ECR. 
Clicking Cancel closes the ECR component.

6. Click Clear All to remove the information from the ECR component so that you 
can enter a different ACID. If a request is successful, FSM clears all of the ECR 
fields. If a request is unsuccessful, FSM clears all information except the Find 
Flight information.

Adjusting the CTA Range
You may manually adjust the CTA range for SCS and Limited Update Options. FSM 
sends the SCS and Limited CTA range parameters as entered in ECR to the hubsite. 
Adjusting the CTA range will change the Max Additional Delay from the default value. 

1. Find the Flight in ECR.

2. Enter the Earliest EDCT to the earliest EDCT to which the flight can comply and 
click Apply Model. FSM will calculate the Limited and Unlimited CTA range for 
the flight and the Earliest CTA (EDCT + ETE). 

3. If you would like to change the Limited CTA range, enter the new value in the 
Limited CTA Range field. The value may not be less than 30 minutes of Max 
Additional Delay. 

4. The Max Additional Delay is recalculated based on the CTA range value that you 
entered. If you need to reset the Max Additional Delay to its default value, click 
the Default Range button (See Figure 14 - 8). 
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Figure 14 - 8 : Manually Adjusting CTA Range for ECR

5. Click Apply Model again so FSM can recalculate the update options based on the 
newly specified Limited CTA range.

6. Select the desired update option (SCS, Limited, Unlimited, or Manual). FSM 
selects the SCS radio button by default when SCS is a valid option (NAS Users 
can access only the SCS Update Option, Field users can access the SCS and 
Unlimited Update Options, and ATCSCC users can access the SCS, Limited, 
Unlimited, and Manual Update Options).

7. Click Send Request to send the request to the Hubsite. The ECR component is 
disabled while it waits for a response. 
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Setting the ERTA
To set the flight’s ERTA using the ECR component, select the Update ERTA To 
checkbox. FSM determines the default selection of the ERTA based on whether or not the 
flight can be subbed. The following are the default possibilities:

• Flights that cannot be subbed - checkbox selected
• Flights that can subbed - checkbox not selected

Figure 14 - 9 : ECR with Update ERTA To Selected

ECR sets, or updates, the flight’s ERTA when Update ERTA To is selected and 
determines the ERTA according to the following formula (see Figure 14 - 9):
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(Earliest EDCT + (ETA-ETD))

This can result in an ERTA that is earlier than the CTA/ASLOT issued by ECR. Basically, 
the ERTA is set to the earliest potential arrival time based on the Earliest Departure time, 
even if the earliest arrival slot that ECR could identify for that flight is later. This ensures 
that FSM Compression, GDP/AFP Revisions, and Hubsite Bridging (for SCS and AC) can 
still provide delay relief to the flight should an earlier slot become available.

ECR sends a message to TFMS to update the ERTA when you select Update ERTA To 
and click Send. When you select the Unlimited, Limited or Manual update options and 
click Send, FSM uses the EDCT UPDATE message to set/update the flight’s ERTA. 
When you select the SCS update option and click Send, FSM sends an Update ERTA 
message using an EDCT UPDATE message to TFMS after FSM receives an accepted 
SCS message for the flights from the Hubsite.

Flight Placement for Limited and Unlimited Update Options
ECR uses a queue-based model where the arrival time of a flight is based on the ETA 
projected by the TFMS-Core. To determine a flight’s placement, projected demand is 
compared to the AAR. The flight is queued and modeled as arrived based on the capacity 
projected using the AAR. FSM creates pseudo slots (PSLOT) based on the current AAR. 
Note that the PSLOTs are used for internal modeling only and are not visible to the user.

When you select the Limited update option, FSM compares the current demand (based on 
flights’ ETAs) to the AAR to determine the best place for a flight between the new Earliest 
CTA and (New Earliest CTA + Max Additional Delay).

When determining Limited Option flight placement, FSM assigns the flight to a pseudo 
slot (PSLOT) within the CTA Range based on the following rules:

• The first available free PSLOT within Limited CTA Range; if no free PSLOT is found 
within the limited CTA Range, then;

• The flight is placed in the minute within the Limited CTA range where there are the 
least number of flights in the airborne-holding queue. 

When you select the Unlimited update option, FSM compares the current demand (based 
on flights’ ETAs) to the AAR to determine the best place for a flight between the new 
Earliest CTA and the end time of the program. 

When determining Unlimited Option flight placement, FSM assigns the flight to a pseudo 
slot (PSLOT) within the CTA Range based on the following rule: 

• The first available free PSLOT within Unlimited CTA Range is assigned. Note: The 
Unlimited option will always find a free PSLOT, even though that may cause the flight 
to incur substantial additional delay.

Note: The AAR is not automatically adjusted with the Program Rate. It 
is important to remember that the Limited and Unlimited update 
algorithms use the AAR and not the Program Rate; therefore, it 
is necessary to ensure that the AAR is set correctly.
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Update Options
There are four options for updating an EDCT using ECR: SCS, Unlimited, Limited, and 
Manual. NAS Users can access only the SCS Update Option, Field users can access the 
SCS and Unlimited Update Options, and ATCSCC users can access the SCS, Limited, 
Unlimited, and Manual Update Options.

• SCS – The ECR tool sends a Slot Credit Substitution (SCS) request via a Simplified 
Subs Packet to TFMS, using the window reflected in the CTA range. FSM selects the 
SCS Request option by default (all users).

Note: You can use SCS only when you request a later EDCT. If the 
New Earliest EDCT is before the current CTD, FSM grays out 
the SCS radio button.

• Unlimited – The ECR tool shows the EDCT, CTA, and the delay past the New Earliest 
CTA for the optimal EDCT update for between the New Earliest CTA and the last 
CTA of the program (Field and ATCSCC users only).

• Limited – The ECR tool shows the EDCT, CTA and delay past the New Earliest CTA 
for the optimal EDCT update within the CTA range (ATCSCC users only).

• Manual – The Manual field is automatically populated with the value you entered in 
the Earliest EDCT in the Find Flight section of the ECR component. Edit the flight’s 
EDCT in the space provided (DD/ hhmm) and the ECR tool calculates the CTA by 
adding the flight’s ETE or FCA_ETE (ATCSCC users only).

Viewing SCS Response
After requesting a Slot Credit Substitution (SCS), the Hub site sends back a response. If 
the SCS request is successful, the response is a slot list of the flights affected including 
new control times and control types (see Figure 14 - 10).

Figure 14 - 10 : SCS Response
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Control Types Associated with ECR
Control Type Control Time Change Origin

ECR SCS Request submitted by the ATCSCC
SCS SCS Request submitted by all customers other than 

ATCSCC (airline user or general aviation customers)
UPD ATCSCC EDCT update (Changes made by Unlimited, 

Limited, or Manual options)
BRG Bridged up to accommodate an SCS request
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15:  Revising/Extending a Ground Delay Program or 
Airspace Flow Program
Once a Ground Delay Program (GDP) or Airspace Flow Program (AFP) is already in 
place, the conditions that originally necessitated the program may change. The weather 
may improve or get worse, a runway may shut down or its configuration change, the AAR 
may increase or decrease, or the demand may have changed since the original program 
was issued. When these cases arise, you may find it necessary to revise the original 
program. 

Getting Current Demand and Weather Information
Before you revise, you want to ensure you have the most current ADL. From the FSM 
Control Panel component, select TFMS Tools > ADL Request. Enter the data set’s 
identifier in the TFMS ADL Request Dialog box and click Send. FSM sends the request 
immediately to TFMS and all live mode windows for that data set update when FSM 
receives the new ADL (see Figure 15 - 1).

Figure 15 - 1 : TFMS ADL Request and TFMS ADL Request Dialog Box

You also want to ensure you have the most recent weather information when monitoring 
an Airport data set. Select TFMS Tools > Weather Request from the Control Panel. TFMS 
Weather is the option directly above the ADL Request (see Figure 15 - 2). Enter the three-
character airport ID (for multiple airport weather reports, enter airport identifiers 
separated by spaces or commas) in the TFMS Weather dialog box (see Figure 15 - 2). 
FSM sends the request immediately to TFMS and the current METAR and TAF are 
displayed in a text window on your screen. Weather Request is not an option for Airspace 
data sets.

Figure 15 - 2 : TFMS Weather Request and TFMS Weather Request Dialog Box

Deciding When to Revise a Program
There are several tools available to help you decide if a revision is necessary. The Live 
Time Line and Bar Graph components allow you to visually compare the data sets 
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capacity (AAR) vs. its demand. If the Time Line shows a large number of delayed flights 
(solid triangles) or cancelled flights (solid squares) and/or the Bar Graph shows that 
demand is under or over the AAR for certain hours, a revision can help reallocate the slots. 
In addition to delayed or cancelled flights, monitoring the number of Drop Out flights 
shown under the Time Line CNX/[DO] column during an AFP can help determine if a 
revision is needed. When a revision is necessary, the FSM Modeling Options tab in the 
GDT Setup component is helpful for analyzing different options. For more information on 
how to use Power Run, see Chapter 8: GDT Data Graph Component.

Revising a GDP
You can change a number of parameters during a revision to meet the change of 
conditions at the data set monitored. For example, you may need to revise any one or 
combination of the following parameters: you may need to increase/decrease the AAR, 
increase/decrease the number of centers involved, expanded/reduced the distance range of 
the GDP, revise from a GAAP GDP into a normal GDP, or extend the length of the 
program. To change any of the program parameters, open the data set in GDT mode. To 
load the current parameters select File > Load Actual Parameters > Ground Delay Program 
in the GDT Setup component. 

Revising an AFP
Revising an AFP is similar to revising a GDP with a few additional parameters to be 
aware of. For example, you may need to revise any one or combination of the following 
parameters: you may need to increase/decrease the AAR, increase/decrease the number of 
departure centers involved, increase/decrease the number of arrival airports involved, 
revise from a GAAP AFP into a normal AFP, give priority to the revised AFP over 
existing AFPs, or extend the length of the program. To change any of the program 
parameters, open the data set in GDT mode. To load the current parameters select File > 
Load Actual Parameters > Airspace Flow Program in the GDT Setup component. If you 
want the revised AFP to take priority over other existing AFP control times, check the 
AFP Override checkbox.

Note: It is advised to use AFP Override in only extreme or crisis 
scenarios.

Extending the Program
To extend the length of the AFP or GDP, change the End time from the Parameters tab or 
click and drag the End time slide bar to adjust the duration. You can extend the program 
without changing any other parameters or you can extend the program in conjunction with 
any other number of parameter modifications, as shown in Figure 15 - 3.

Note: You can model an AFP past the End time of the underlying FCA, 
but Send Proposed/Actual <Program Type> is disabled from 
the Coversheet. To extend an AFP past the End time of the 
underlying FCA, the FCA must first be extended in TSD.
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Figure 15 - 3 : Modifying the Program Duration

Modifying the Program Rate
Select the Parameters Tab in the GDT Setup component. The current Program Rate is 
displayed for the hours of the current program. To increase/decrease the Program Rate, 
use either the Fill method or change each hour manually. For more information on the 
Parameters Tab, see Chapter 3: Understanding Components.

If a Pop-up Factor is being used, it is suggested to manually adjust the Program Rate to a 
higher rate for two hours past the Data time to compensate for the Pop-up Factor value 
entered. Typically, unknown demand has already materialized for the two hours past the 
Data time.

Reducing/Expanding the Scope of a GDP
You can reduce or expand the scope of your tier or distance-based GDP. Select the Scope 
tab on the GDT Setup panel, and select either Select By Tier or Distance. If you prefer to 
use the Tier based GDP, you can select a new center group or manually add or delete 
centers by selecting the center checkboxes. Newly selected centers are now non-exempt 
(receive departure delay) in the program. If you release a center from program delay, the 
flights originating from that center run through the release delay algorithm. FSM adjusts 
distance based programs based on the distance radius. You can expand the distance range 
to capture more airports in the program or decrease the distance radius to release delay on 
previously delayed airports.

Reducing/Expanding the Scope of an AFP
You can reduce or expand the scope of your tier-based AFP. Select the Scope tab on the 
GDT Setup panel. You can manually add or delete departure centers by selecting the 
center checkboxes. Newly selected centers are now non-exempt (receive departure delay) 
in the program. If you release a center from program delay, the flights originating from 
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that center runs through the release delay algorithm. In additional to departure facilities, 
arrival airports can be exempted. To exempt an arrival airport from departure delay, enter 
the airport ID in the Exempt Airports field in the Arrival Facilities section. Any flight 
arriving to an Exempt arrival airport is exempt from departure delay. 

Purging Flights Outside of the Revised Program Parameters
When you revise an existing AFP, GDP, or GS, you can purge flights outside of the new 
program time frame, thus removing them from the program’s control. The Purge Flights 
section on the Parameters tab of the GDT Setup panel allows you to purge flights that 
arrive before the new start time or after the new end time. This section is enabled when 
modeling an AFP or GDP revision, for an initial AFP/GDP and all other program types the 
Purge Flights options are disabled. 
To purge flights prior to the new Start time

1. Adjust your Start time in the GDT Setup panel’s Parameters tab 

2. Select Before Revision Start in the Purge Flights section. When this box is 
selected, FSM logic determines which flights are no longer controlled due to the 
change in the new event Start time entered in the GDT Setup panel. 

Note: The logic for which flights are included is unchanged; this new 
process simply means that when the time frame is reduced, FSM 
re-determines which flights are in the program.

3. Click Model.
The cumulative start time is displayed as a solid goal post in the Bar Graph. The 
new Start time of the program will be displayed as a dotted goal post once the 
revision is displayed in the ADL.

Note: By default the cumulative time indicators are enabled, but you 
have the option to toggle the display. Select View > Cumulative 
Indicators from the Bar Graph to turn the cumulative time 
indicators on/off.

4. If the program appears to meet your needs, click Run Proposed or Run Actual 
and submit the program. For more information, see Chapter 15: Issuing the 
Revision. Advisories are sent to all users to indicate that the time frame of the 
program has changed. The TFMS system notifies users of flights that are no longer 
controlled by the program.

To purge flights after to the new End time

1. Adjust your End time in the GDT Setup panel’s Parameters tab.

2. Select After Revision End in the Purge Flights section. When this box is selected, 
FSM logic determines which flights are no longer controlled due to the change in 
the new event End time entered in the GDT Setup panel. 
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Note: The logic for which flights are included is unchanged; this new 
process simply means that when the time frame is reduced, FSM 
re-determines which flights are in the program.

3. Click Model.
The cumulative end time is displayed as a solid goal post in the Bar Graph. The 
new end time of the program is displayed as a dotted goal post once the revision is 
displayed in the ADL.

Note: By default the cumulative time indicators are enabled, but you 
have the option to toggle the display. Select View > Cumulative 
Indicators from the Bar Graph to turn the cumulative time 
indicators on/off.

4. If the program meets your needs, click Run Proposed or Run Actual and submit 
the program. Advisories are sent to all users to indicate that the time frame of the 
program has changed. The TFMS system notifies users of flights that are no longer 
controlled by the program.

Revising a GAAP Program
To revise a program from a GAAP to a DAS, in GDT Setup, from the Parameters tab > 
Program Type dropdown menu, select GDP/AFP DAS. 

Sending a Proposed Program and Advisory
After modifying the parameters of the program and if the modeled results are favorable, it 
is recommended that you send out a Proposed Advisory. A Proposed program revision is a 
program suggested by the FAA, but not immediately implemented. Click Run Proposed 
from the GDT Setup panel to open the proposed program coversheet (see Figure 15 - 4). 
Review all parameters and place a checkmark next to each section of the coversheet you 
have reviewed. Before sending the Proposed program, the Advisory/Causal Factors 
section of the coversheet must be completed.
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Figure 15 - 4 : AFP Coversheet
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After you complete the Advisory/Causal Factors section, place a checkmark next to the 
Advisory/Causal Factors section of the Coversheet. To review the Advisory text before 
sending the proposed event, from the Advisory/Causal Factors dropdown, select Preview 
Advisory. 

Figure 15 - 5 Preview Advisory Option

This opens the Advisory in text format.

Note: The first line of the Advisory states that it is a Proposed revision 
(see Figure 15 - 6). 

Figure 15 - 6 : Proposed AFP Advisory Preview

Click Send Proposed AFP - DAS to distribute the proposed program parameters and 
Advisory to all FSM users. A Proposed program revision allows NAS users enough time 
to comment on the proposed parameters even though they may change before the FAA 
implements an actual program.
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Suspend Airline Substitutions and Slot Credit Substitutions
Now you are ready to issue the revised program but before issuing the revision, you need 
to suspend the acceptance of airline substitutions and Slot Credit Substitutions (SCS) 
messages temporarily. From the FSM Control Panel, select the TFMS Tools > EDCT 
Commands > EDCT Sub Off option to turn substitutions off or when in GDT mode click 
the SUB OFF button from the GDT Setup component, as shown in Figure 15 - 7. The data 
set identifier is already entered in the EDCT SubOff dialog box when opened from the 
GDT Setup component, otherwise enter the data set ID and click Send to suspend 
substitutions for that airport. Airlines’ substitution or SCS messages are no longer 
accepted after FSM sends the SubOff message to TFMS. 

Note: Ensure that the SUBS OFF indicator is displayed on the GDT 
Setup panel after you have sent the EDCT Sub Off message. If 
SUBS ON is displayed, click Reload to model the program with 
the most recent ADL. 

Figure 15 - 7 : Turn Subs OFF

Issuing the Revision
Once you have determined the program parameters for an Actual program, turned off 
substitutions, and reloaded the most current ADL you are ready to send your program 
revision. 

Click Run Actual from the GDT Setup component to open the program coversheet with 
the revised parameters. If substitutions are currently turned on for the selected data set, the 
Subs On Warning dialog box is displayed before the coversheet opens (see Figure 15 - 8). 
The warning gives you the opportunity to turn off substitutions without having to reload. 

Figure 15 - 8 : SUBS ON Warning

If you click Ignore, the Subs OFF warning closes and the coversheet opens. If you click 
Turn Subs OFF, the Subs OFF message is sent to the hubsite/TFM Processing Center 
(TPC), and an informational message is displayed (see Figure 15 - 9).   
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Figure 15 - 9 : FSM Modeling Information Message

Click Cancel to continue without waiting for FSM to automatically remodel the TMI. If 
you did not click Cancel, FSM remodels the TMI after the Subs Off message is returned 
by the TPC and the FSM Information message closes. SUBS: ALL OFF is then displayed 
on the GDT setup panel. 

Review the Coversheet parameters and program results, complete the Advisory section, 
and click Send Actual <Program Type> from the Coversheet to implement the revision.

Completing a revision is similar to sending an initial program. For more information, see 
Chapter 11: Issuing an Initial Program.

Exempt AFP Flights from GDP
When an airport goes into a GDP the GDP takes control of all arrivals at the airport within 
the duration of the program, including any flights currently controlled by AFPs. You have 
the option of exempting flights currently controlled by AFPs. When an AFP is selected as 
an Exempt AFP in the GDT Setup panel, the AFP-exempt flights in the GDP will be 
treated as previously controlled regardless of their AFP exemption status and given the 
first available airport arrival slot after their estimated arrival time, which is based on their 
current AFP EDCT and any airline submitted flight delays. FSM will make an effort not to 
change the assigned departure time (CTD) for the flight, subject to capacity constraints at 
the airport and any known flight delays. This minimizes the number of changes to control 
time for flights that are now controlled by the GDP, as well as to minimize the change in 
the demand at the AFP.

Exempting an AFP from a GDP
1. Go into GDT Mode for an airport that has AFP controlled flights.

2. Set up your desired GDP Parameters as normal (see Figure 15 - 10).
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Figure 15 - 10 : SYR GDP Parameters Selected

3. In the General Options of the Parameter tab on the GDT Setup component, click 
Select… located to the right of the Exempt AFPs field.

4. The Exempt AFPs dialog box opens, which displays information for each AFP 
controlling flights within the domain of the GDP (see Figure 15 - 11).

Figure 15 - 11 : Exempt AFPs Dialog Box
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See Table 15-1 for the information displayed in the Exempt AFPs dialog box. 
Table 15-1:  Exempt AFPs Dialog Information

5. To view a Flight List of all the AFP controlled flights arriving within your GDP 
parameters, click the Flight List button. Click OK to close the Flight List (see 
Figure 15 - 12).

Figure 15 - 12 : Exempt AFPs Flight List

6. To Exempt one or all AFPs listed, select the checkbox to the left of the FCA ID. 

7. Click OK to accept the Exempt AFP selection or click Cancel to close the dialog 
without accepting the selected AFP exemption. The selected AFP is then listed in 
the Exempt AFPs field on the GDT Setup Parameters tab (see Figure 15 - 13).

Header Label Description
FCA ID The name of the FCA on which the AFP is based.
AFP Controlled The total number of flights that would be controlled by the GDP whose 

current control element is the indicated AFP.
AFP Not 
Exempt

The subset of flights listed in AFP Controlled column that would not be 
exempted by the current GDP exemption criteria.

Avg Delay The current average delay for all flights listed in the AFP Not Exempt 
column. 

Max Delay The maximum delay for a flight listed in the AFP Not Exempt column. 
Flight List Clicking the button labeled with the AFP’s FCA ID displays a flight list 

with all the flights that will be controlled by the GDP.
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Figure 15 - 13 : AFP FCARG2 Entered in the Exempt AFPs Field

8. Click Reload or Model. 

9. Flights that were controlled by the selected AFP will now be controlled by the 
GDP control element, but will retain their previous EDCT (from the AFP) to the 
degree possible based on airport slot availability and airline submitted delay 
information. The CTA of the flight will be adjusted for the airport GDP. 

Example Revision
The section below is an example of how to revise a GDP with a GAAP Delay Assignment 
Mode to a DAS Delay Assignment Mode. If you change Delay Assignment Mode to DAS, 
all unassigned slots are removed from the program and from the ADL and FADT.
To revise a Program with a GAAP Delay Assignment Mode

1. Click Open Data Set.
The Open Data Set window opens.

2. Select the data set for which you want to revise the program with a GAAP Delay 
Assignment Mode.

3. Click OK.
The Time Line and Bar Graph components for the data set opens.

4. Click GDT Mode.
The GDT components for the data set open. Select File > Load Actual Parameters > 
Ground Delay Program to load the current parameters for the data set. 

5. Make any additional changes to the program that are needed.

6. Select the Power Run you want FSM to use for this program.

7. Click Model or Reload if available.
The red border in the GDT Setup Panel no longer is displayed and the GDT 
components reflect the modeled program.

8. If the program appears to deal with the traffic flow in the manner you want, click 
Run Actual to generate the coversheet.

9. Carefully examine each section of the coversheet. If the data is correct, select the 
Program Parameters checkbox.
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10. Complete the Advisory/Causal section of the coversheet.

11. Modify the Respond By time if Proposed was selected.

12. Modify the Valid Until time if necessary.

Note: The program inherits its Causal Factor information from the 
original program you are revising but you can modify some or 
all of the information.

13.  Select the Advisory/Causal Factors checkbox.

14. Click Send Actual GDP. The Program Manager opens and activates the Autosend 
process.
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16:  Issuing Compress Flight Program
At certain times during a GDP or AFP, you may find it favorable to run a Compression. 
The Compression function exchanges delayed flights with open slots to lessen the delay 
on flights. Compression attempts to fill all available slots with flights that, although 
delayed from their OETA or OENTRY, can still arrive at the available slot time. 
Compression tries to place flights from the same airline that created the slot in the new 
slot, however, if this is not possible, it uses other airlines’ flights to fill the arrival slots. A 
pure Compression can be beneficial to the performance of a program when there is limited 
pop-up traffic and non-compliance issues with flights in the stack hours.

In addition to the traditional Compression program, FSM has a background process called 
Adaptive Compression that automatically runs for GDPs and AFPs. Adaptive 
compression helps ensure that all slots are used. A background process at the TFMS Hub 
monitors a GDP or AFP for open slots, identifies those that are in danger of going unused, 
moves other flights earlier to take advantage of those slots, and consequently moves the 
open slots later. The benefits are higher utilization of the airport capacity, reduced delay 
for the flights operating to that airport, and reduced workload for the ATCSCC specialist.

The adaptive compression process:

• Identifies the slots that should be compressed
• Determines the flights that should be moved to use the slot
• Updates the databases with the changes
• Sends notification to the flight operators about the changes

For more information on Adaptive Compression, please review the TFMS Reference 
Manual.

The TFMS Hub performs Adaptive Compression processing and has little effect on FSM 
other than to:

• Display the status of whether Adaptive Compression is on or off for an Element.
• Provide a method through which an EDCT command can be sent from FSM to turn 

Adaptive Compression on or off.

Adaptive Compression in FSM
When there is an AFP or GDP in place, the subs indicator located on the FSM Control 
Panel and the GDT Setup panel indicates the status of Adaptive Compression. If Adaptive 
Compression is ON the display reads ADPT ON. If Adaptive Compression is OFF the 
display reads ADPT OFF. The status of Adaptive Compression is displayed in the 
Substitution Flag Block. Select Alerts > SCS Bridge for the selected Element and the 
Substitution Flag Block opens (See Figure 16 - 1).
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Figure 16 - 1 : Substitution Block

Note:  If there is no AFP/GDP in place, the Subs indicator does not 
display any Adaptive Compression status. 

Authorized FAA users will be able to turn Adaptive Compression on and off through 
EDCT commands. Select TFMS Tools > EDCT Commands > AC ON/OFF to turn Adaptive 
Compression at the TFMS Hub site on or off.

Suspending Airline Substitutions and Slot Credit Substitutions
Before issuing a Compression, you need to suspend, temporarily, the acceptance of airline 
substitutions and Slot Credit Substitutions (SCS) messages. From the FSM Control Panel, 
select the TFMS Tools > EDCT Commands > EDCT Sub Off option to turn substitutions 
off or when in GDT mode click the SUB OFF button from the GDT Setup component, as 
shown in Figure 16 - 2. The data set identifier is already entered in the EDCT SubOff 
dialog box when opened from the GDT Setup component, otherwise enter the data set ID 
and click Send to suspend substitutions for that airport. Airlines’ substitution or SCS 
messages are no longer accepted after FSM sends the SubOff message to TFMS. 

Ensure that the SUBS OFF indicator is displayed on the GDT Setup panel after you have 
sent the EDCT Sub Off message. If SUBS ON is displayed, click Reload to model the 
program with the most recent ADL.

Figure 16 - 2 : Turn Subs OFF

Opening GDT Mode
Open Ground Delay Tools (GDT) mode by selecting a monitored data set and then 
clicking GDT Mode from the Control Panel. The four default GDT components 
automatically open for the selected airport. To perform the Compression function, select 
the Program Type > Compress Flights option from the FSM GDT Setup component.
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When you select the Program Type Compress Flights, the Parameters and Modeling 
Options tabs are the only tabs available for entering parameters (see Figure 16 - 3).

Figure 16 - 3 : Compress Flights Setup

Entering Parameters
On the Parameters tab, adjust the time range by clicking and dragging the pointers on the 
Start and End time lines or by entering a new time (ddhhmm) in the textboxes. When you 
select the Compress to Last CTA checkbox, the end time and duration fields are disabled. 
Compress to Last CTA indicates that FSM includes all flights with control times in the 
Compression, even flights past the End time of the program. When Compress to Last CTA 
is unchecked, FSM automatically fills in the current End time and duration of the 
program. The Slot Hold Override functionality is available during Compression. Click 
Select to review the slots held (see Figure 16 - 4).

Figure 16 - 4 : Slot Hold Override

On the Modeling Options tab, you can adjust the Earliest Start Time, Latest Start Time, 
and Step Size parameters for the Power Run model statistics. 

For more information on the GDT Setup Panel, see Chapter 3: GDT Setup Component.
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Using Run to Generate the Compression Coversheet
Click Run Proposed or Run Actual after you turn subs off, complete your Compression 
setup, and model it from the GDT Setup component. 

If substitutions are currently turned on for the selected data set, the Subs On warning 
dialog box is displayed before the coversheet opens (see Figure 16 - 5). The warning gives 
you the opportunity to turn off substitutions without having to reload.

Figure 16 - 5 : Subs On Warning

If you click Ignore, the Subs OFF warning closes and the coversheet opens. If you click 
Turn Subs OFF, the Subs OFF message is sent to the hubsite/TFM Processing Center 
(TPC), and an informational message is displayed (see Figure 16 - 6). 

Figure 16 - 6 : FSM Modeling Information Message

Click Cancel to continue without waiting for FSM to automatically remodel the TMI. If 
you did not click Cancel, FSM remodels the TMI after the Subs Off message is returned 
by the TPC and the FSM Information message closes. SUBS: ALL OFF is then displayed 
on the GDT setup panel.

Clicking Run Proposed or Run Actual saves the coversheet parameters to a file 
specified in FSM’s configuration file and opens the Compression coversheet. Clicking 
Run Proposed or Run Actual also generates three reports, the FADT, Analysis, and 
Carrier Statistics Reports, which you can view by selecting View > FADT, Analysis, or 
Carrier Statistics from the coversheet menu. See Chapter 21: Understanding and Using 
FSM Reports for more information on reports.

The Compression coversheet contains all the Compression parameters data. After 
reviewing the Compression parameters, program results, and completing the Advisory 
section, click Send Actual Compression or Send Proposed Compression to 
implement the Compression and send the Advisory (see Figure 16 - 7).
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Figure 16 - 7 : Compression Coversheet
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Reviewing Program Parameters
Reviewing the program parameters is important before issuing the compression. Ensure 
that the Program Parameters section on the coversheet accurately reflects all of your 
inputs on the GDT Setup panel.

From the Program Parameters dropdown, select View Program Results to view flight and 
stack information. Select View Delay Assignment to view the program’s slot allocation and 
delay distribution. 

Creating the Advisory
Before sending a Compression, the Advisory/Causal Factors section of the coversheet 
must be completed. The Respond By field is only available during a proposed event.

Place a checkmark next to each section of the coversheet after you have reviewed the 
parameters, facilities, and advisory information. To review the Advisory text before 
sending the event, from the Advisory/Causal Factors dropdown, select Preview 
Advisory. 

Figure 16 - 8 Preview Advisory Option

This opens the Compression Advisory overlay in text format (see Figure 16 - 9).

Figure 16 - 9 : Compression Advisory Preview
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For more information about the Coversheet and Advisory component, see Chapter 3: GDT 
Coversheet.

Issuing the Compress Flight Program
To send the Compression and Advisory click Send Actual Compression or Send 
Proposed Compression located at the bottom of the coversheet. When you click Send 
Actual Compression, the FSM client interfaces with TFMS Autosend Server and sends 
the web coversheet XML file to NTML and the FADT file to the hub site. The Autosend 
Server also invokes TFMS E-mail and sends the Advisory to the specified address list. 
TFMS E-mail puts the ATCSCC position number and phone number in the Advisory 
signature line.

When you click Send Proposed Compression, only the proposed parameters and 
Advisory is sent. No new EDCTs are issued for a proposed Compression.

When you click Send Actual Compression or Send Proposed Compression the 
Program Manager window opens and displays the Autosend progress.

If SUBS are ON when you click Send Actual Compression or Send Proposed 
Compression from a coversheet during a compression, blanket, revision, or extension, 
you receive the following FSM warning message (see Figure 16 - 10). This message is 
displayed only if you chose to ignore the previously displayed Subs On Warning. Once the 
coversheet is opened, you must reload and remodel the program in order to turn subs off.

 
Figure 16 - 10 : SUBS OFF Warning

Click OK to clear the FSM warning and then turn SUBS OFF before reloading and 
remodeling the program. Wait for FSM to reflect SUBS OFF successfully before clicking 
Send Actual Compression or Send Proposed Compression again.

Although it is recommended that you turn SUBS OFF during any revision, you can bypass 
the warning message by clicking Ignore on the message box. FSM automatically 
continues with the Autosend process even though SUBS are ON.

When you click Close, FSM takes no action from the Compression coversheet.

GAAP GDP - Compress Slots Program Type
When a GAAP program is in place, FSM now provides the ability to adjust the 
Unassigned Slots in the GAAP program without reallocating EDCTs to flights currently 
arriving at the data set. Users can compress Unassigned Slots at GAAP programs by using 
the new Program Type, Compress Slots. 
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The Compress Slots program type offers no program options in the GDT Setup panel, but 
when modeled, FSM will recalculate the Unassigned Slots based on the program rate and 
the flights’ current positions based on their ETA (airport) or ENTRY (airspace). This 
ensures that pop-up traffic is assigned to Unassigned Slots that are appropriately based on 
the current capacity vs. demand at the data set.

When sending a Compress Slots program, no advisory is sent to users because flights’ 
EDCTs are not affected by this program. 

Compressing Unassigned Slots
A specialist may not want to adjust flights’ current EDCTs within a GAAP program, but 
would like to adjust the Unassigned Slots. In Figure 16 - 11, a Ground Stop has been put 
into place over a GAAP GDP. It is obvious that pop-up flights should not be assigned to 
the Unassigned Slots in the 2100 hour and the 2200 hour slots should be reserved for spill 
over flights from the 2100. 

Figure 16 - 11 : TEB GAAP GDP

1. Click GDT Mode on the FSM Control Panel.

2. From the GDT Setup component select Compress Flights from the Program Type 
dropdown. The Scope tab is disabled when Compress Flights is selected. 

3. Click Reload or Model to model the Compress Slots program.

4. View the modeled results in the GDT Bar Graph (see Figure 16 - 12).
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Figure 16 - 12 : Compress Slots Modeled 
In the modeled results there is no change to flights currently arriving to the data 
set, but the Unassigned Slots have been reallocated based on the current demand 
vs. capacity. Note there are no longer any Unassigned Slots in the 2100 or 2200 
hours. 

5. If you are satisfied with the modeled results, click Run Proposed or Run Actual. 
The Compression coversheet opens.

6. Select the Advisory/Causal Factors and Program Parameters checkboxes. The 
Advisory/Causal Factors section of the coversheet is disabled because no Advisory 
is sent for a Compress Slot program; however, you still need to select the 
Advisory/Causal Factor. The red “X” in the tab will changed to a green 
checkmark. 

7. Click Send Actual/Proposed Compression to replace the current pool of 
Unassigned Slots with the newly created Unassigned Slot list.
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17:  Deciding When to Use a Compression or Revision
After the FAA issues an initial GDP or AFP, the data set’s demand and/or capacity 
fluctuate and a Compression or Revision may be necessary to adjust the traffic flow. 
Monitor the data set’s delivery (see Chapter 12: Monitoring Program Delivery) to 
determine if demand continues to exceed capacity and decide whether a Compression or 
Revision may be necessary.

Deciding When to Revise or Compress a GDP
Use a Revision when you want to change the program parameters, such as Start or End 
time, Program Rate, or scope. A Revision reallocates flights to slots based on the entered 
parameters and sends new EDCTs to flights arriving to the airport within the revision’s 
time parameters. If the scope of the GDP is reduced, newly exempted flights still receive 
new EDCTs and are subject to departure compliance.

In cases where you do not want to modify the GDP parameters, either a Revision or 
Compression can be considered. If a GDP is over delivering and/or there are multiple pop-
up flights, then a Revision may be the best option. To view the number of pop-up flights in 
a GDP go to the Control Type tab on the Bar Graph or Time Line. Any flight with a 
control type (CTL_TYPE) of DAS is a pop-up flight and the color orange on the Control 
Type tab. A Revision captures the pop-up flights in the system and assigns them new slots 
based on the airport’s capacity. A Revision can reduce or increase the average delay of the 
program depending on the airport’s demand vs. capacity at the time of the Revision.

If a GDP is under delivering, you are not concerned about the extra demand due to pop-
ups, and there are a large number of cancelled or delayed flights with open slots ahead of 
operational flights. For example, if there are numerous cancelled flights before operational 
flights that are in the stack hour, a Compression could move the operational flights into the 
cancelled flights slots if Compress to Last CTA is checked. The Stack hours are the stack 
of flights after the end time of the GDP. You can easily identify the number of cancelled 
flights in a stack hour by looking at the FSM Bar Graph. Click the Cancellations shortcut 
button on the Bar Graph to view all cancelled flights. Rolling your mouse over the cyan 
colored flights displays a tool tip with the number of cancelled flights for that hour. Figure 
17 - 1 illustrates numerous cancelled flights ahead of operational flights in the stack hours.
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Figure 17 - 1 : Stacked Hours

You can also get a quick visual idea of where the cancelled flights (squares) and delayed 
flights (triangles) are from the FSM Time Line. If a large number of squares are displayed 
throughout the program time, issuing a compression is helpful for reallocating operational 
flights to the slots held by the cancelled flights. A revision will also do the same, but will 
also assign pop-up flights to arrival slots. A compression ignores all pop-up flights and 
only compression flights that were previously in the GDP.

Running a Compression with the Compress to Last CTA checkbox selected on the 
Parameters tab of the GDT Setup panel compresses every flight that has a control time, 
even if the flight is past the End time of the GDP (see Figure 17 - 2). Deselecting 
Compress to Last CTA compresses flights that have a CTA before the End time of the 
program. It is advised to use the Compress to Last CTA option when a GDP extension is 
not expected.
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Figure 17 - 2 : Compress to Last CTA

Compressions can decrease delay on operational flights and move cancelled flights to the 
end of the program. Compression can reduce, but cannot increase, both the total delay and 
average delay of a GDP. If there are no flights available to move into earlier times, a 
Compression does not yield any change. For more information on Issuing a Compression, 
see Chapter 16: Issuing Compress Flight Program.

Note: Flights can receive more delay during a Compression or 
Revision due to Airline submitted times. For example, if a 
flight’s earliest departure/arrival times submitted are later than 
its current control times, the flight can receive a later time if 
there is another available flight to move up into the delayed 
flight’s slot. 

Deciding When to Revise or Compress an AFP
Use a Revision when you want to change the program parameters, such as Start or End 
time, AAR, or scope. A Revision will reallocate flights to slots based on the entered 
parameters and sends new EDCTs to flights arriving to the FCA within the revision 
parameters. If the scope of the AFP is reduced, newly exempted flights still receive new 
EDCTs and are subject to departure compliance.

In cases where you do not want to modify the AFP parameters, either a Revision or 
Compression can be considered. If an AFP is over delivering due to pop-up traffic and/or 
if multiple Drop Out flights are causing the program to under deliver during all or part of 
the program, a revision is the best option to reallocate flights to slots and smooth out the 
FCA demand. To view the number of pop-up flights in the FCA go to the Control Type tab 
on the Bar Graph or Time Line. Any flight with a control type (CTL_TYPE) of DAS is a 
pop-up flight and colored orange on the Control Type tab. The number of drop out flights 
are displayed in salmon under the Time Line’s CNX header (see Figure 17 - 3).
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A Revision captures the pop-up flights in the system, creates slots based on the Program 
Rate, and allocates all known flights to slots. A Revision can reduce or increase the 
average delay of the program depending on the FCA’s demand vs. capacity.

Figure 17 - 3 : Multiple Pop-up and Drop Out Flights

Note: The guidelines mentioned above are not procedures.

Deciding When to Compress a GAAP
When a GAAP program is in place, you can adjust the Unassigned Slots in the GAAP 
program without reallocating EDCTs to flights currently arriving at the data set. Compress 
Unassigned Slots at GAAP programs by selecting Program Type Compress Slots.

The Compress Slots program type offers no program options in the GDT Setup panel, but 
when modeled, FSM recalculates the Unassigned Slots based on the program rate and the 
flights’ current positions based on their ETA (airport) or ENTRY (airspace). This ensures 
that pop-up traffic is assigned to Unassigned Slots that are appropriately based on the 
current capacity vs. demand at the data set.

Use the Compress Slots program when current demand does not exceed capacity and you 
want to realign unassigned slots around current demand. For example, when you do not 
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want to adjust flights’ current EDCTs within a GAAP program, but would like to adjust 
the Unassigned Slots. In the modeled results there is no change to flights currently arriving 
to the data set, but the Unassigned Slots have been reallocated based on the current 
demand vs. capacity (see Figure 17 - 4).

Figure 17 - 4 : Compressed Slots on GDP GAAP

Note that when sending a Compress Slots program, no advisory is sent to users because 
flights’ EDCTs are not affected by this program.
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18:  Airborne Holding and Blanket Programs

Using Airborne Holding
Traffic management specialists use Airborne Holding to determine the necessity of a 
GDP. Airborne Holding is not an option for Airspace data sets. In certain situations, 
putting delay on flights en route may be a better option than delaying flights on the 
ground. The airborne holding algorithm in FSM produces the amount of expected airborne 
holding delay, defined as ASLOT - ETA, which would result from running a program.

To run the Airborne Holding algorithm, select the Program Type Airborne Holding option 
from the GDT Setup component. Note that only the Parameters tab is enabled. Use the 
Parameters tab to complete the parameters of the air traffic scenario you want to model. 
The only input parameters for Airborne Holding are the Program Time Options (Start and 
End times) and the Program Rate (PR). 

Parameters Tab Modifications
In the Program Time Options section, specify the start and end times of the program. In 
the Program Rate section, enter the reduced Program Rate for the airport on which you 
want to base your Airborne Holding Model. Note that the Pop-Up and Reserve rows in the 
Program Rate table are filled with dashes as they are not applicable to Airborne Holding 
programs. In addition, the General Options and Include Only Options sections are 
disabled, as shown in Figure 18 - 1.
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Figure 18 - 1 : Airborne Holding Parameters Tab

For more information on the Parameters tab, see Chapter 3: Understanding Components.

Airborne Holding Reports
Click Model or Reload if available and then Run Proposed or Run Actual. Running the 
Airborne Holding algorithm generates two reports: Airborne Holding Flight List and 
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Carrier Statistics. The Airborne Holding Flight List and Carrier Statistics are displayed 
automatically when you run the Program Type Airborne Holding.

Airborne Holding Flight List
The Flight List contains information for all flights that meet the operation parameters. The 
Flight List includes ASLOT, which is the pseudo arrival slot the flights use, and ASLOT – 
ETA, which is the amount of expected airborne holding delay. The Flight List in Figure 18 
- 2 is sorted by ASLOT - ETA in descending order. For more information on the Flight 
List Format, see Chapter 6: Flight List Format.

Figure 18 - 2 : Airborne Holding Flight List

Carrier Statistics

The Carrier Statistics report displays specific delay information for each carrier’s flights, 
based on ETA after Airborne Holding. The Carrier Statistics report is arranged in several 
columns for easy access to important information. If the Average and Maximum delays 
are minimal for all carriers, then Airborne Holding could be a valid TMI option. The 
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Carrier Statistics report opens automatically when you run the Program Type Airborne 
Holding (see Figure 18 - 3).

Figure 18 - 3 : Airborne Holding Carrier Statistics

For more information on the Carrier Statistics report, see Chapter 21: Carrier Statistics 
Report.

Using a Blanket Program
You can use the Blanket program to revise any GDP. The Blanket Program Type is not an 
option for Airspace data sets. Before you revise, ensure you have the most current ADL 
and weather information. From the Control Panel, select TFMS Tools > ADL Request or 
Weather Request. For more information, see Chapter 15: Revising/Extending a Ground 
Delay Program or Airspace Flow Program. Use the Blanket program to add or subtract a 
fixed number of minutes to or from an FAA-imposed delay. Do not use Blanket in 
conjunction with a GS. You should use a Blanket program only if you do not need to 
adjust the airport’s AAR.

Select Program Type of Blanket from the GDT Setup panel’s Parameters tab. Each 
ground-delayed flight has an associated slot time. Use this IGTA-based slot time to 
determine whether to include a flight in the Blanket program. The slot times of included 
flights are adjusted by the minutes of delay entered in the Blanket Adjust Delay (Minutes) 
field, as shown in Figure 18 - 4. Should the airline-delayed flight’s position be earlier than 
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the new slot time, the program moves the airline-delayed flight to the newly assigned slot 
time. The program moves the open slots due to the delay and cancellation accordingly.

Figure 18 - 4 : Blanket Delay Program Type

When you use the Blanket Program, the Parameters, Scope, and Modeling Options tabs 
are available for entering parameters. The tabs are almost identical to other programs with 
the exception of the additional Blanket Adjust Delay feature on the Parameters tab.

For more information on the GDT Setup component, see Chapter 3: GDT Setup 
Component.

Blanket Coversheet
Click Run Proposed or Run Actual after you complete and model your Blanket program 
in the GDT Setup component. Clicking Run Proposed or Run Actual saves the 
parameters to a file specified in FSM’s configuration file and opens the Blanket 
coversheet (see Figure 18 - 5). 
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Figure 18 - 5 : Blanket Coversheet
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Clicking Run Proposed or Run Actual also generates three reports, the FADT, Analysis, 
and Carrier Statistics Reports, which you can view by selecting FADT, Analysis, or 
Carrier Statistics from the View menu (see Figure 18 - 6). For more information on 
reports, see Chapter 21: Understanding and Using FSM Reports.

Figure 18 - 6 : View FADT, Analysis, and Carrier Statistics Reports

Sending a Proposed Blanket and Advisory
After setting the parameters of the Blanket and if the modeled results are favorable, it is 
recommended that you send out a Proposed Advisory. A Proposed Blanket is a revision 
suggested by the FAA, but not immediately implemented. Click Run Proposed from the 
GDT Setup panel to open the Proposed Blanket coversheet. Review all parameters and 
place a checkmark next to each section of the Coversheet you have reviewed. 

After you complete the Advisory/Causal Factors section, place a checkmark next to the 
Advisory/Causal Factors section of the Coversheet. To review the Advisory text before 
sending the event, from the Advisory/Causal Factors dropdown, select Preview Advisory. 
This opens the Blanket Advisory in text format. 

Note: The first line of the Advisory states that it is a Proposed revision 
(see Figure 18 - 7).
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Figure 18 - 7 : Blanket Advisory Preview

Click Send Proposed Blanket to distribute the proposed GDP parameters and Advisory 
to all FSM users. A Proposed Blanket revision allows NAS users enough time to comment 
on the proposed parameters even though they may change before the FAA implements an 
actual program.

Suspending Airline Substitutions and Slot Credit Substitutions
Before issuing the Blanket program, you need to suspend the acceptance of airline 
substitutions and Slot Credit Substitutions (SCS) messages temporarily. From the FSM 
Control Panel, select the TFMS Tools > EDCT Commands > EDCT Sub Off option to turn 
substitutions off or when in GDT mode click the SUB OFF button from the GDT Setup 
component. 

The EDCT Sub Off dialog box opens with the data set identifier already entered in the 
Airport/FCA name or All field (see Figure 18 - 8). Click Send to suspend substitutions 
for that airport. Airlines’ substitution or SCS messages no longer are accepted after FSM 
sends the SubOff message to TFMS. 

Figure 18 - 8 : EDCT Sub Off Dialog Box
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Note: Ensure that the SUBS OFF indicator is displayed on the GDT 
Setup panel after you have sent the EDCT Sub Off message. If 
SUBS ON is displayed, click Reload to model the program with 
the most recent ADL. 

Issuing a Blanket Revision
Once you have determined the program parameters for an Actual Blanket, turned off 
substitutions, and reloaded the most current ADL you are ready to send your Blanket 
revision.

If substitutions are currently turned on for the selected data set, the Subs On Warning 
dialog box is displayed before the coversheet opens (see Figure 18 - 9). The warning gives 
you the opportunity to turn off substitutions without having to reload.

Figure 18 - 9 : Subs On Warning

If you click Ignore, the Subs OFF warning closes and the coversheet opens. If you click 
Turn Subs OFF, the Subs OFF message is sent to the hubsite/TFM Processing Center 
(TPC), and an informational message is displayed (see Figure 18 - 10). 

Figure 18 - 10 : FSM Modeling Information Message

Click Cancel to continue without waiting for FSM to automatically remodel the TMI. If 
you did not click Cancel, FSM remodels the TMI after the Subs Off message is returned 
by the TPC and the FSM Information message closes. SUBS: ALL OFF is then displayed 
on the GDT setup panel.

Click Run from the GDT Setup component to open the Blanket coversheet with the 
revised parameters. From the Program Parameters dropdown, select View Program 
Results to view flight and stack information. Select View Delay Assignment to view the 
program’s slot allocation and delay distribution. Review the coversheet parameters and 
program results, complete the Advisory section, and click Send Proposed Blanket or 
Send Actual Blanket from the Coversheet to implement the Blanket revision.
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Note: Blanket programs ignore all unassigned slots if the GDP has a 
Delay Assignment Mode of GAAP.

If you leave SUBS turned ON, when you click Send Proposed Blanket or Send Actual 
Blanket during a compression, blanket, revision, or extension, you receive an FSM 
warning message that instructs you to “Turn SUBS OFF, reload, and remodel the 
program.” (see Figure 18 - 11). This message is displayed only if you chose to ignore the 
previously displayed Subs On warning. Once the coversheet is opened, you must reload 
and remodel the program in order to turn subs off. 

Figure 18 - 11 : SUBS OFF Warning

Click OK to clear the FSM warning and then turn SUBS OFF before reloading and 
remodeling the program. Wait for SUBS OFF to be reflected successfully before clicking 
Autosend again. 

Although it is recommended that you turn SUBS OFF during any revision, you can bypass 
the warning message by clicking Ignore from the message box. Click Ignore to clear the 
FSM warning and FSM automatically continues with the Autosend process even though 
SUBS are ON.

Completing a Blanket revision is similar to sending an initial Program. For more detail, 
see Chapter 11: Issuing an Initial Program.
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19:  Issuing a Ground Stop
Unlike GDPs, which delay flights because of a reduced AAR, the Ground Stop function 
prevents flights from departure until one minute after the End time of the Ground Stop. In 
FSM, the GDT Setup Component is identical for all Traffic initiatives, with active tabs 
and fields differentiating among program types. During a GS, ETD is checked against the 
Start time and End time to determine whether to include the flight in the GS. (In a GDP, 
times are checked against a flight’s IGTA). Flights included in the GS program are 
assigned a new ETD one minute after the GS End time. The flight’s new ETAs are 
assigned based on the flight’s Original ETE. For example, if the GS period is 1320-1419, 
flights with an ETD between 1320 and 1419 have a new ETD of 1420. The new ETA is 
the New ETD + Orig. ETE.

Note:  GS programs are not applicable to Airspace data sets (FEAs and 
FCAs); therefore, they are not available for use for Airspace 
data sets.

Selecting the Parameters
Open any monitored airport in Ground Delay Tools (GDT) mode by clicking GDT Mode 
on the Control Panel component. When the four GDT components open, select the 
Program Type Ground Stop from the GDT Setup component.

Once you select the appropriate Program Type, you are ready to set the necessary 
parameters through each of the tabs of the GDT Setup component.

Parameters Tab
In the Parameters tab (see Figure 19 - 1), you can adjust the program time and include 
options. Change the Ground Stop (GS) program time by clicking and dragging the 
pointers on the Start and End time lines. The default End time for Ground Stops will 
adjust to 15-minute increments on the hour (00, 15, 30, and 45); conversely, all other 
programs have a default end time on the 14, 29, 44, or 59th minutes. The End time for 
Ground Stops will be a time increment that results in at least a one hour GS. For example, 
if the Ground Stop Start time is 1902, the default End time will be 2015. 

If you do not indicate changes for Arrival Fix, Aircraft Type, or Carrier (Major), the 
default is set to include All. 
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Figure 19 - 1 :GDT Setup Parameters Tab

Scope Tab
Click the Scope tab to select the facilities and airports included in the GS. Ground stops 
are always Tier-based; therefore, Select By Distance is not a valid exemption criterion. 
The Tier panel contains three sections where you can modify parameters: Centers, 
Airports-Origin, and Flights (see Figure 19 - 2).
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Figure 19 - 2 : GDT Setup GS Scope Tab

Modeling Options Tab
Before actually running the GS, you may want to review the parameters you set to ensure 
they are best for your program. This allows you to take advantage of several analysis tools 
embedded in FSM.
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Use the Modeling Options tab in the GDT Setup component as an analysis tool. There are 
three GS Power Run operations, which analyze the effects/results of any program:

• GS Center Group
• GS Time Period
• GS Center Group & Time Period

Select these options from the Power Run By drop down menu (see Figure 19 - 3). Use the 
Power Run function to determine whether you need to modify the parameters. 

Figure 19 - 3 : GDT Setup GS Power Run By Option

To view a scenario, select an option from the Power Run By dropdown menu and click 
Model. Model displays the effects of the GS parameters and how traffic at the airport 
would be affected if you used these parameters for an actual program in all GDT 
components. Review the program statistics in the Data Graph (see Figure 19 - 4).
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Figure 19 - 4 : Power Run Data Graph by GS Center Group 

To preview the effects of a Power Run scenario, move the black line on the Data Graph 
component to other options displayed on the x-axis. This is discussed in more detail below 
in the Data Graph Component section.

Note: After you click Model, the Setup Panel no longer contains a red 
border; this indicates that all components reflect the information 
in the GDT Setup Panel.

The Demand by Center component functionality is similar to that of the Data Graph, in 
that there is only data available for display after you model a TMI. After you model a 
TMI, click Show Demand on the Scope tab of the GDT Setup panel.

The Demand by Center component displays the scope of the modeled TMI and has three 
columns: Centers, Non-Exempt, and Exempt. All centers and the top five airports within 
each center (based and ordered primarily by the number of Non-Exempt flights and then 
by the number of Exempt flights) are displayed in the Centers column.

A red dot to the left of the center or airport identifier indicates that at least one Non-
Exempt flight is present within that center or airport. A green dot indicates that all flights 
are Exempt within that center or airport (see Figure 19 - 5).
FSM User Guide, Version 9.00 19-5



Issuing a Ground Stop
Figure 19 - 5 : Demand By Center

If there are more than five airports with included flights in the selected Center an 
additional “Others” row combines the rest of the flights within the remaining airports. If a 
center does not contain any flights, that center’s airport list is empty. For more 
information on Demand By Center, see Chapter 3: Demand By Center Component.

You can use the Impact Modeling Options to see how the GS affects other airports of 
interest. See Chapter 3: Understanding Components for more information.

Generating a GS Coversheet
Run the GS program once you set the parameters and you are ready to implement the GS. 
Click Run Proposed or Run Actual on the GDT Setup component. This saves the 
parameters to a specified FSM configuration file and the GS coversheet opens. Clicking 
Run Proposed or Run Actual or also generates three reports, the FADT, Analysis, and 
Carrier Statistics Reports, which you can view by selecting View > FADT, Analysis, or 
Carrier Statistics from the Coversheet menu. For more information on reports, see Chapter 
21: Understanding and Using FSM Reports. 

GS Coversheet
The GS coversheet contains all program parameter data for you to review before sending 
the GS program. You send the GS out from the GS coversheet (see Figure 19 - 6).
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Figure 19 - 6 : Ground Stop Coversheet

For more information on the GS coversheet, see Chapter 3: Understanding Components.
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Once you review the GS coversheet and checkmark all checkboxes, send out an Advisory 
and click Send Actual GS to send the GS to the Hub site.

Reviewing Program Parameters
Reviewing the parameters is important before issuing the GS. Ensure that the Program 
Parameters section accurately reflects all of the inputs on the GDT Setup panel.

Creating an Advisory
Before sending a GS, the Advisory/Causal Factors section (see Figure 19 - 7) of the 
coversheet must be completed. The Respond By field is only available during a proposed 
event. Select the Category, Cause and Equipment that are applicable to the situation. 
Select the Probability of Extension for the GS, by default, MEDIUM is selected. 

Figure 19 - 7 : Coversheet Advisory Section

Place a checkmark next to each section of the coversheet after you have reviewed the 
parameters, facilities, and advisory information. To review the Advisory text before 
sending the event, from the Advisory/Causal Factors dropdown menu, select Preview 
Advisory. This opens the GS Advisory overlay in text format (see Figure 19 - 8). Note 
that the coversheet is inactive until you click Close on the overlay.
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Figure 19 - 8 : GS Advisory Preview

To send the GS and Advisory, click Send Actual GS located at the bottom of the 
coversheet. The FSM client interfaces with TFMS Autosend Server and sends the web 
coversheet XML file to NTML and the FADT file to the Hub site. The Autosend Server 
also invokes TFMS E-mail and sends the Advisory to the specified address list. TFMS E-
mail puts the ATCSCC position number and phone number in the Advisory signature line.

When you click Send Proposed GS, only the proposed parameters and Advisory is sent.

When you click Send Proposed GS or Send Actual GS, the Program Manager window 
opens and displays the Autosend progress.

Click Close and no action is taken from the GDP coversheet window.

Program Manager
Clicking Send Proposed GS or Send Actual GS activates the Autosend process and 
opens the Program Manager dialog that displays that status window and progress bar at 
the bottom of the window (see Figure 19 - 9). The Program Manager performs a list of 
actions based on the type of GS sent: proposed or actual. Some actions specify the next 
action to perform sequentially upon completion of the first action. If an action fails, a 
dialog is displayed asking if further sequential action should be performed or the process 
stopped.
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Figure 19 - 9 : Program Manager

For more information on the Program Manager see Chapter 3: Understanding 
Components.

Note:  If you click Send Proposed GS or Send Actual GS more than 
15 minutes after modeling your program, it is recommended that 
you close your coversheet and Reload to get the most recent 
data from an updated ADL before continuing with the Ground 
Delay Operation.

Resending Coversheet Information
If your GS parameters or advisory was not properly sent the first time, you can select 
information you would like to resend from the coversheet. If the coversheet is not already 
open, open the coversheet from the GDT Setup panel. Select File > Open Coversheet. This 
opens a file selection window for the Reports directory. You should see all coversheets 
generated for that airport. See Chapter 11: Issuing an Initial Program for more information 
on resending information.

Example of Issuing an Actual GS
An Actual GS is a program that the FAA is going to implement; they have gathered user 
comments and are ready to enact the program. 
To send an Actual Ground Stop

1. Click Open Data Set. The Open Data Set window opens.

2. Select the airport for which you want to issue the GS.

3. Click OK. The Time Line and Bar Graph components for the airport open.
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4. Click GDT Mode on the Control Panel. The GDT components for the airport are 
displayed.

5. On the GDT Setup panel select Ground Stop for the Program Type.

6. Enter the GS parameters on the various GDT Setup Panel tabs.

7. Click Model. The red border outlining the GDT Setup Panel no longer is displayed 
and all the GDT components reflect the modeled Ground Stop.

8. If the program appears to deal with the traffic flow in the manner you want, click 
Run Actual to generate the coversheet. The Coversheet window opens.

9. Carefully examine each section of the coversheet. If the data is correct, select the 
Program Parameters checkboxe.

10. Select the Category for the Ground Stop.

11. Select the Cause related to the Category.

12. Select the Equipment causing the GS (if you selected Equipment from Cause).

13. Select the Probability for Extension for the Ground Stop.

14. Enter any Comments as needed.

15. Select the Advisory/Causal Factors checkbox. The red X on the tab will change to 
a green checkmark.

16. From the Advisory/Causal Factors dropdown menu, click Preview Advisory to 
review the GS Advisory.

17. Click Send Actual GS to issue the Ground Stop. The Program Manager window 
opens and activates the Autosend process. 

Viewing GS Controlled Flights
To monitor controlled flights, view the Bar Graph and Time Line in Monitor Live mode. 
You can identify GS flights by looking for yellow flights in the Bar Graph and the Time 
Line (see Figure 19 - 10). In the Bar Graph, move the cursor over the yellow bar and the 
number of GS controlled flights in that hour is displayed.
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Figure 19 - 10 : Live Mode

Double-click a bar in the Bar Graph to open the Flight List component. When all colors 
are displayed on the Bar Graph, the Flight List contains all flights, both GS and other 
flights. Click the color legend button to open the color legend. Uncheck all color options 
with the exception of yellow GS Flights. Then click the hour bar that has only GS flights 
displayed; this opens a Flight List containing only GS flights.
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Figure 19 - 11 : GS Flight list for 1 Hour Bar

There are certain default values of Flight List information. When you first open a Flight 
List, the default information is displayed. This default information is adjustable. For more 
information on the Flight List component, see Chapter 6: Viewing Flight Information.

Query Manager Flight List
The Query Manager already contains a built-in filter for GS flights. To get a list of GS 
flights at any open airport, select the AND Ground_Stopped Filter and then click Flight 
List or select View > Flight List from the Query Manager component (see Figure 19 - 12).
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Figure 19 - 12 : Query Manager Component

When you are monitoring more than one data set, clicking Flight List opens the Set Data 
Set window, showing all open data sets. Select the Data Set/Data Mode and click OK to 
view that airport’s GS Flight List (see Figure 19 - 13). Click Cancel to exit the Set Data 
Set window without opening a Flight List.

Figure 19 - 13 : Set Data Set Selection window

Opening a Flight List from the Query Manger lists all Ground Stopped flights that are at 
the specified airport, FEA, or FCA unless otherwise defined by a customized 
CONSTRAINT, whereas accessing a Flight List from the Bar Graph only displays a list of 
flights for the selected hour. For more information on how to use the Query Manager 
component, see Chapter 22: Using Query Manager.
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20:  Other Ground Stop Functions
Once a Ground Stop (GS) is in place, the conditions that originally necessitated the 
Ground Delay Program (GDP) may change. This chapter covers additional GS features 
that you use when conditions demand modifications to an existing GS:

• Purging a GS
• Reducing the Scope of a GS
• Extending a GS
• Moving from a GS to a GDP

Purging a GS
From the Purge coversheet, click Purge to purge any control times from the TFMS system 
and send the Purge Advisory. Purge works the same as the Autosend function to send new 
operation parameters and cancellation messages to the Hub site for inclusion in the ADLs. 

Viewing Flight Information before Purging a Program
When you model a purge for a GS program, TFMS sets the minimum notification time to 
the value of the minimum notification time for flights in a ground stop. FSM determines a 
minimum notification time for controlled flights in a taxi status. If a controlled flight is in 
a taxi status, without regard to the type of control, then FSM sets the minimum 
notification time to the value of the minimum notification time for flights in a taxi status.

TFMS models a new estimated departure time based on the flight’s control departure time 
and the minimum notification time based on the following criteria:

• If the flight is active or completed, TFMS sets the ETD to the actual departure time.
• If the CTD of the flight is within the minimum notification time from the current time, 

the estimated departure time remains set to the CTD.
• If the CTD of the flight is greater than the minimum notification time plus the current 

time, then TFMS calculates a candidate ETD selected from the following values in 
order of priority:

1. Earliest Runway Departure Time

2. Earliest Runway Arrival Time minus the Estimated Time En route

3. Original Estimated Departure Time

4. Initial Gate Departure Time plus the taxi time for the flight
• If this candidate time is greater than the current time plus the minimum notification 

time, then TFMS sets the ETD to this candidate time.
• If the candidate time is less than the current time plus the minimum notification time, 

then TFMS sets the ETD to the current time plus the minimum notification time.
To Purge a Ground Stop

The Purge option requires no user input.
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1. Select Purge from the Program Type dropdown. 

2. Even though no user input is required, for modeling purposes you can change 
Purge Notification (Minutes) for Taxied, GS or GDP/AFP (see Figure 20 - 1).

 
Figure 20 - 1 : Purge Notifications (Minutes) Values

Note: Changing Purge Notification (Minutes) values is for modeling 
only. The actual purge uses the default values.

3. Click Model. The red border in the GDT Setup Panel no longer is displayed and all 
the GDT components reflect the modeled purge.

4. If the program handles the traffic flow in the manner you want, click Run 
Proposed or Run Actual to generate the GS CNX coversheet. The Coversheet 
window is displayed (See Figure 20 - 2).
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Figure 20 - 2 : GS CNX Coversheet
For more information on the Coversheet component, see Chapter 3: Understanding 
Components.
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5. After you review the information, select the Program Parameters checkbox.

6. After completing the Advisory section of the coversheet, select the Advisory/
Causal Factors checkbox. 

7. From the CNX coversheet, click Send Proposed Purge or Send Actual Purge. 
If you click Send Proposed Purge, only the Purge Advisory is sent. If you click 
Send Actual Purge, all control times are purged from the TFMS system and the 
Actual Advisory is sent to all users. Purge works the same as the Autosend 
function to send new operation parameters and cancellation messages to the Hub 
site for inclusion in the ADLs.

Reducing the Scope of a Ground Stop
GDP processing enhancements now allow for you to reduce the scope of a Ground Stop. 
You no longer need to purge the current Ground Stop and reissue a new Ground Stop with 
a reduced scope. Reducing the scope can now be done as a simple Ground Stop revision. 
When the scope is reduced, FSM purges control times from any flight no longer included 
in Ground Stop and the TFMS system notifies all users of flights that are no longer 
controlled by the Ground Stop.

Fill in the GS parameters as needed. Once you make the GS parameter inputs, click 
Reload or Model on the GDT Setup component to view the delay statistics for the new 
scenario and make adjustments if necessary. Once you are ready to issue the GS, click 
Run Proposed or Run Actual from the GDT Setup component to open the GS 
coversheet. From the GS coversheet, send the Ground Stop and Advisory by clicking 
Send Proposed Purge or Send Actual Purge to implement the new GS. See Chapter 
19: Issuing a Ground Stop for more detail on how to issue a GS.

Extending a Ground Stop
To extend an existing GS, ensure the Ground Stopped airport you want to modify is active 
before clicking GDT Mode on the Control Panel component. This opens the four default 
GDT components for the selected airport. Select GS from the Program Type dropdown 
menu and then select File > Load Actual Parameters > Ground Stop (see Figure 20 - 3).

After FSM loads the actual parameters, adjust the parameters and extend the GS Time as 
necessary. Click Model to view the Delay Statistics in the Data Graph and make any 
adjustments as needed.
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Figure 20 - 3 : Load Actual Parameters > Ground Stop

Note: Before sending a revised GS, it is advised to suspend Airline 
substitutions and SCS. Click SUB OFF on the GDT Setup Panel 
to turn substitutions off.

Run the GS program once you modify the parameters and you are ready to implement the 
GS. Click Run Proposed or Run Actual on the GDT Setup component. This saves the 
parameters to a file specified in FSM’s configuration file and opens a GS coversheet. 
Clicking Run Proposed or Run Actual generates three reports:

• FADT report
• Analysis report
• Carrier Statistics report

You can view these reports by selecting View > FADT, View > Analysis, or View > Carrier 
Statistics from the coversheet. You can also view the Carrier Statistics by selecting Report 
> Carrier Statistics from the main Control Panel component. For more information on 
these reports, see Chapter 21: Understanding and Using FSM Reports.

GS Coversheet
The GS coversheet contains all the operation’s parameter data. Send the GS from the GS 
coversheet.
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Figure 20 - 4 : GS Coversheet
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Once you complete the GS coversheet and checkmark all checkboxes, click Send Actual 
GS to send the Ground Stop and Advisory (see Figure 20 - 4).

Moving from a GS to a GDP
When issuing a GDP at an airport that already has a GS in place, open GDT mode for the 
airport and from the Program Type dropdown, select GDP - DAS. Click the Scope tab and 
in the Flights section, select Exempt Active Flights Only (By Status) (see Figure 20 - 5).

Figure 20 - 5 : Scope Tab Set Up for Moving From a GS to a GDP

Suspending Airline Substitutions and Slot Credit Substitutions
When moving from a GS to a GDP, you need to suspend, temporarily, the acceptance of 
airline substitutions and Slot Credit Substitutions (SCS) messages. From the FSM Control 
Panel, select the TFMS Tools > EDCT Commands > EDCT Sub Off option or on the GDT 
Setup Panel click SUB OFF to turn substitutions off. The EDCT Sub Off dialog box opens 
with the three-character airport ID pre-filled, as shown in Figure 20 - 6. Click Send to 
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suspend substitutions for that airport. Airlines’ substitution or SCS messages are no longer 
accepted after FSM sends the SubOff message to TFMS.

Figure 20 - 6 : Turn Subs OFF

Note:  It is important to click Reload on the GDT Setup component 
after you have sent the EDCT Sub Off message and ensure the 
SUBS indicator reads ALL OFF. 

Issuing a GDP
Once you have determined the program parameters for an Actual GDP and you have 
turned off the substitutions and have modeled the program you are ready to send the 
program. Click Run Proposed or Run Actual from the GDT Setup component to open 
the GDP coversheet with the revised parameters. 

If substitutions are currently turned on for the selected data set, the Subs On Warning 
dialog box is displayed before the coversheet opens (see Figure 20 - 7). The warning gives 
you the opportunity to turn off substitutions without having to reload.

Figure 20 - 7 : Subs On Warning

If you click Ignore, the Subs OFF warning closes and the coversheet opens. If you click 
Turn Subs OFF, the Subs OFF message is sent to the hubsite/TFM Processing Center 
(TPC), and an informational message is displayed (see Figure 20 - 8). 

Figure 20 - 8 : FSM Modeling Information Message

Click Cancel to continue without waiting for FSM to automatically remodel the TMI. If 
you did not click Cancel, FSM remodels the TMI after the Subs Off message is returned 
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by the TPC and the FSM Information message closes. SUBS: ALL OFF is then displayed 
on the GDT setup panel.

Review each section of the coversheet and complete the Advisory. Click Send GS from 
the coversheet to implement the revision.

If SUBS are turned ON when you click Autosend from a coversheet during a 
compression, revision, or extension, you receive an FSM warning message that instructs 
you to “Turn SUBS OFF, reload, and remodel the program” (see Figure 20 - 9). This 
message is displayed only if you chose to ignore the previously displayed Subs On 
warning. Once the coversheet is opened, you must reload and remodel the program in 
order to turn subs off. Click OK to clear the FSM warning and then turn SUBS OFF before 
reloading and remodeling the program. Wait for SUBS OFF to be reflected successfully 
before clicking Send Actual GS or Send Proposed GS again.

Figure 20 - 9 : SUBS OFF Warning

Although it is recommended that you turn SUBS OFF during any revision, you can bypass 
the warning message by clicking Ignore from the message box. This clears the FSM 
warning. FSM automatically continues with the Send GS process even though SUBS are 
ON.

See Chapter 11: Issuing an Initial Program for more information on issuing a GDP.
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21:  Understanding and Using FSM Reports
FSM makes several different reports available to you. These reports give you information 
about counts, compliance, surface delay, priority flights, time out delay, time out cancel, 
slot hold, sub opportunities, analysis, FADT, and carrier statistics. You can use these 
reports to better understand how traffic reacts to programs that are in place and determine 
when to make adjustments to programs.

Counts Reports
Counts reports give you the option to check the flights that make up arrival and/or 
departure demand for each hour. You can open all Count Lists from the FSM Control 
Panel component. There are eight Count List reports:

• By Demand
• By Center
• By Aircraft Category
• By Aircraft Class
• By Arrival Fix (Airport only)
• By Departure Fix (Airport only)
• By User
• By Unassigned Slot

To view a demand count for a particular monitored airport, first select the airport you want 
to view, and then select Reports > Counts > [By report type]. If you have not selected a 
data set, the Counts are disabled.

Note: Count Lists in GDT Mode only show counts for arriving flights.

Viewing the Count List
After selecting the type of demand count, a Count List window opens. The type of Count 
List is displayed in parentheses in the Count List window’s title bar. The three-letter 
airport code or the FEA/FCA name, date, ADL time of the FSM generated list, and display 
mode are displayed in the title bar as well as above the Count List columns.

FSM arranges each count list in 15-minute intervals with totals for each hour based on the 
FSM Time Line component. NRP (National Route Program) counts are displayed below 
the total count for each hour. An NRP is a flight that files for a more direct route, but is 
considered to be a preferred route (as designated by the FAA). In Monitor Mode, counts 
are displayed based on a flight’s ETA by FSM default. You can view Count Lists for 
airports based on the Count List Display menu: by ETA, BETA, IGTA - Taxi, OCTA, 
EAFT, Departure, Arrival/Departure, and CTA as shown in Figure 21 - 1.
FSM User Guide, Version 9.00 21-1



Understanding and Using FSM Reports
Figure 21 - 1 : Count List Display Data-Airport

You can view Count Lists for FEAs and FCAs based on the Count List Display menu: by 
CTA, ENTRY, BENTRY, IENTRY, and OENTRY, as shown in Figure 21 - 2.
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Figure 21 - 2 :Count List Display Data-FEA/FCA

To increase the size of any Count List window, drag the edge of the window with your 
mouse. When the information contained in the window is too large for the window, you 
can scroll through the data.

Count List Menu
The Count Lists (with the exception of Departure Fix) each have four menus: File, View, 
Display and Help.

1. File Menu

• File > Save As – Saves the Count List to a file so that you can open it later in a 
text editor.

• File > Print – Sends the Count List to a printer so that you can view a hard copy 
of the Count List.

• File > Close – Closes and quits the Count List component without taking any 
action.

2. View Menu 

• View > Freeze Data – Freezes the Count List data at the time you select the 
option, otherwise the Count List updates with each new ADL.
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3. Display Menu

• Display > ETA – Displays counts based on the flights’ Estimated Time of 
Arrival. (Airport only)

• Display > BETA – Displays counts based on the flights’ Beginning Estimated 
Wheel Time of Arrival. (Airport only)

• Display > IGTA – Taxi – Displays counts based on the flights’ Initial Estimated 
Gate Time Arrival – Taxi. (Airport only)

• Display > OCTA – Displays counts based on the flights’ Original Control Time 
of Arrival. (Airport only)

• Display > EAFT – Displays counts based on the flights’ Estimated Fixed Time 
of Arrival. (Airport only)

• Display > Departure – Displays counts based on the Departure flights. (Airport 
only)

• Display > Arrival/Departure – Displays counts based on Arrival and Departure 
flights. (Airport only)

• Display > CTA – Displays counts based on the flights’ Control Time of Arrival.

• Display > ENTRY – Displays counts based on the flights’ Estimated Element 
Entry Time. (FEA and FCA only)

• Display > BENTRY – Displays counts based on the flights’ Based Element 
Entry Time. (FEA and FCA only)

• Display > IENTRY – Displays counts based on the flights’ Initial Element 
Entry Time. (FEA and FCA only)

• Display > OENTRY – Displays counts based on the flights’ Original Element 
Entry Time. (FEA and FCA only)

Note:  The Counts by Departure Fix and Counts by Unassigned Slots 
do not have a Display Menu.

4. Help Menu

• Help > Counts – Opens the on-line help for the Count Lists.

Count List by Demand
The By Demand Count List displays arrival demand in 15-minute intervals and totals the 
flight count for each hour. You can use this report to perform a quick check of the arrival 
demands in each hour (see Figure 21 - 3).
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Figure 21 - 3 : Counts by Demand

Counts by Centers
The By Centers Count List provides flight counts according to departure centers. There 
are 20 centers for this particular display (Figure 21 - 4). If the three-letters “ZZZ” are 
displayed, they represent any center that is not part of the other 20. Again, in Monitored 
Live mode, FSM bases these counts on flights’ ETA times for airports and ENTRY times 
for FEAs and FCAs as displayed in the FSM Time Line.
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Figure 21 - 4 : Counts by Centers

Counts by Aircraft Category
The By Aircraft Category Count List displays a count list based on the aircraft category. 
FSM classifies Aircraft Categories according to the aircraft category as specified by 
TFMS (Propeller, Turbo, Jet, and Unknown).

The Count List By Aircraft Category report contains the following information:

• Date – ADL day and time
• Time – 15-minute time bins
• Aircraft Categories (P, T, J, U)
• Total – Total for each time bin and for categories by hour and NRP flights.

Note: For airport data sets times are by ETA, for FEA and FCA data 
sets times are by ENTRY.

The Aircraft Category counts are arranged in the following manner:

• Block for each hour in the ADL
• Counts by each 15-minute bin
• Sum of categories in each hour
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• NRP flight count

Figure 21 - 5 : Counts by Aircraft Category

Counts by Aircraft Class
The By Aircraft Class Count List provides flight counts according to the aircraft weight. 
This Count List incorporates the following classifications for aircraft weight: Small, 
Large, Heavy, Jumbo, and Unknown.

Note: For airport data sets times are by ETA, for FEA and FCA data 
sets times are by ENTRY.

The Count List By Aircraft Class report contains the following information:

• Date – ADL day and time
• Time – 15-minute time bins
• Aircraft Classes (S, L, H, J, U)
• Total – Total for each time bin and for classes by hour and NRP flights.

The data are arranged in the following manner:

• Block for each hour in the ADL
• Counts by each 15-minute bin
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• Sum of classes in each hour
• NRP flight count

Figure 21 - 6 : Counts by Aircraft Class

Counts by Arrival Fix
The By Arrival Fix Count List provides flight counts according to the Arrival Fix each 
flight is arriving at for the monitored airport. Arrival Fix names for each airport vary. FSM 
automatically generates the correct Arrival Fix names for the monitored airports and uses 
them in the Count List headings.

Note: Times are displayed by ETA. Not applicable for FEA and FCA 
data sets and is therefore disabled.

The Count List By Arrival Fix report contains the following information:

• Date – ADL day and time
• Time – 15-minute time bins
• Arrival Fixes 
• Total – Total fix crossings for each time bin and for each fix, by hour and NRP flight.

The data are arranged in the following manner:
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• Block for each hour in the ADL
• Counts by each 15-minute bin
• Sum of fix crossings in each hour
• NRP flight count

Figure 21 - 7 : Counts by Arrival Fix

Counts by Departure Fix
The By Departure Fix Count List provides flight counts according to the departure fix 
each departing flight is passing over for the monitored airport. Departure fix names for 
each airport vary. FSM generates the departure fixes for the monitored airport from the 
ADL file and uses them in the Count List headings. If the departure fix is not specified in 
the ADL or is blank, the flight is displayed under the “Other” column.

Note: Times are displayed by ETD. Not applicable for FEA and FCA 
data sets and is therefore disabled.

The Count List By Departure Fix report contains the following information:

• Date – ADL day and time
• Time – 15-minute time bins
• Departure Fixes
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• Total – Total fix crossings for each time bin and for each fix, by hour and NRP flights

The data are arranged in the following manner:

• Block for each hour in the ADL
• Counts by each 15-minute bin
• Sum of fix crossings in each hour
• NRP flight count

Figure 21 - 8 : Counts by Departure Fix

Counts by User
The Arrival Count List By User provides a flight count according to the classification of 
the aircraft (Figure 21 - 9). The Arrival Count List by User classifies flights according to 
their function in the NAS. There are seven types of users in FSM:

• C – Air Carriers
• T – Air Taxi
• F – Freight/Cargo Carriers
• M – Military
• G – General Aviation
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• O – Other – This class includes flights that do not belong to one of the five categories 
listed above.

• U – Unknown – This category is for flights which may fall into a user category, but the 
classification is not known in FSM

Note: For airport data sets times are by ETA, for FEA and FCA data 
sets times are by ENTRY.

Figure 21 - 9 : Counts by User

The Count List By User report contains the following information:

• Date – ADL day and time
• Time – 15-minute time bins
• Users – F, C, G, M, T, O, U
• Total – Total for each time bin, and for user class, by hour and NRP flights

The data are arranged in the following manner:

• Block for each hour in the ADL
• Counts by each 15-minute bin
• Sum of Users in each hour
• NRP flight count
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Counts By Unassigned Slot
The unassigned slot report is very similar to the count list report (Figure 21 - 10). The title 
bar for the report shows the report icon, and “Count List (Unassigned Slot): [three letter 
airport identifier] [ADL Date YYYY/MMM/DD/] [ADL Time HH:MMZ] [Mode: Live/
Hist]: [Frozen (if you select it)]”. The report does not have a Display menu item.

Note: For airport data sets times are by ETA, for FEA and FCA data 
sets times are by ENTRY.

The Count List By Unassigned Slot report contains the following information:

• Date – ADL day and time
• Time – 15-minute time bins and Total
• Unassigned Slots – number of unassigned slots per time bin

The data are arranged in the following manner:

• Block for each hour in the ADL
• Counts by each 15-minute bin
• Sum of slots in each hour – Total number of Unassigned slots for the hour.

Figure 21 - 10 : Count By Unassigned Slot
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Compliance Flight Lists
When any flight becomes noncompliant, FSM generates a flight list that includes these 
flights. You can access the compliance reports from the Reports > Compliance >[Report 
Name] option from the Control Panel component. There are five possible compliance 
reports:

• By CTD
• By ETE
• By CTA
• Spurious Flight (Airport only)
• Cancel That Flew

For example, if you select Reports > Compliance > By CTA, all flights that have non-
compliant CTAs are displayed with the FltAlarm CC checkboxes checked. This report 
also contains non-compliant alarm columns. If the flight has additional alarms (non-
compliant) associated with it, those alarm checkboxes also are checkmarked. Figure 21 - 
11 is an example of CTA Compliance Alarm Flight List.

Note:  Alarm Flight Lists include only those flights arriving at the 
selected airport.

Figure 21 - 11 : CTA Compliance Alarm Report
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To view the Compliance alarm columns on the generated report, select the alarms from the 
Add/Remove Columns window. If a flight is non-compliant, the checkbox under the 
Alarm type is selected. The Compliance Alarm columns are defined below:

1. CC – These flights violated their CTA Compliance. Flights arriving more than five 
minutes before or more than five minutes after their Control Time of Arrival 
(CTA).

2. EC – These flights violated their CTD Compliance. The departure boundaries are 
more than five minutes before or more than five minutes after their estimated 
departure clearance time. Any flight, which has an ARTD of five minutes earlier 
or five minutes later than the most recent EDCT, is displayed in the CTD 
Compliance report.

3. EA – These flights violated the Actual ETE vs. Original ETE alarm. TFMS 
generates this Alarm when the difference between the ETE estimated by TFMS 
and actual flight time is greater than a specified value, but the flight status is not 
“cancelled.” The default value is 15 minutes. TFMS estimates ETE using OCTA - 
OCTD. TFMS calculates actual flight time using ARTA -ARTD.

4. SF – This alarm detects the cancellation of a false flight used to ignite a 
substitution stream. Flights submitted as FX cancellations with no corresponding 
entries in the OAG trigger the Spurious Flights Alarm.

5. CF – This alarm detects any flights that were cancelled but later flew without the 
flight being reinstated properly. 

By CTD Compliance Report
The By CTD Compliance report checks for flights which violate departure compliance in 
a delay program. The default departure boundaries are more than five minutes before or 
more than five minutes after their estimated departure clearance time. Any flight that has 
an ARTD of five minutes earlier or five minutes later than the most recent OrigEDCT is 
included in the By CTD Compliance report, as shown in Figure 21 - 12.
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Figure 21 - 12 : CTD Compliance

By ETE Compliance Report
The By ETE Compliance report compares the Actual ETE vs. Original ETE. FSM 
includes flights in the By ETE Compliance report when the difference between the ETE 
estimated by TFMS and actual flight time is greater than a specified value, but the flight 
status is not “cancelled.” The default value is 15 minutes. TFMS estimates ETE using 
OCTA - OCTD. TFMS calculates actual flight time using ARTA - ARTD.

By CTA Compliance Report
The By CTA Compliance reports check for flights which violate arrival compliance in a 
delay program. By default, flights that violate arrival compliance are defined as those 
flights arriving more than five minutes before or more than five minutes after their Control 
Time of Arrival. If TFMS detects any of the specified conditions, the flight is included in 
the By CTA Compliance Flight List, as shown in Figure 21 - 13.
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Figure 21 - 13 : CTA Compliance

Spurious Flight Compliance Report
The Spurious Flight Compliance report detects the cancellation of false flights used to 
ignite a substitution stream. Flights submitted as FX cancellations with no corresponding 
entries in the OAG are included in the Spurious Flight List.

Cancel That Flew Compliance Report
The Cancel That Flew Compliance report includes any flight that was cancelled and later 
flew.

Program Delay Histogram
You can access the Program Delay Histogram from the Reports > Delay Histograms menu 
on the Control Panel. Program delay is the amount of delay that non-cancelled, non-active, 
controlled flights have received due to a Traffic Management Initiative. Program delay is 
calculated using Max (0, [CTA - BETA]), therefore any time a flight's CTA is updated the 
Program delay is recalculated.

The title of the histogram is centered over the graph and reads “Program Delay Histogram: 
[APT] [ADL Date] [ADL Time]” for airports and “Program Delay [FEA/FCA] [ADL 
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Date] [ADL Time]” for FEAs and FCAs. The title bar of the Program Delay Histogram 
shows the status of the data:

• Live mode – Program Delay: [APT or FEA/FCA] dd/hhmm Live
• Frozen in Live Mode – TProgram Delay: [APT or FEA/FCA] dd/hhmm Live: Frozen
• Historical Mode – TProgram Delay: [APT or FEA/FCA] [yyyy]/[Mmm]/[dd] [hhmm] 

HIST
• Frozen in Historical Mode – Program Delay: [APT or FEA/FCA] [yyyy]/[Mmm]/[dd] 

[hhmm] HIST: Frozen

Note: Histograms are not available for GDT Mode.

The flight data displayed on the histogram is dynamic. Each time FSM receives an ADL 
for the airport, FEA, or FCA, data on the histogram updates.

The X-axis shows the Program Delay in minutes. Flights are grouped on the X-axis of the 
graph in 15-minute bins:

• The smallest bin is 0-14 minutes
• The largest bin is 150+ minutes

The Y-axis indicates the number of flights:

• The minimum value on the Y-axis is 0
• The maximum value on the Y-axis is calculated by FSM

The bars showing the distribution of flights are green. Each bar has a tool-tip which 
displays the total number of flights in that bin. Double-clicking a bar opens a Flight List 
for the flights represented by that bar.
Program Delay Histogram Menu

The Program Delay Histogram has three menus: File, Histogram, Help.

1. File Menu

• Save As – Saves the Program Delay Histogram as a .jpg image in a directory 
that you specify. The default location for saved images is 
…\fsm\data\default_user\reports, and the default file name is atc_delay.jpg.

• Print – Sends a .jpg image of the active Program Delay Histogram to a printer 
that you specify

• Close – Closes the Program Delay Histogram

2. Histogram Menu

• Freeze Data – When checked, prevents the Program Delay Histogram from 
updating when new ADLs arrive

3. Help Menu

• Histogram – Opens the on-line help for the Program Delay Histogram 
component
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Absolute Delay Histogram
You can access the Absolute Delay Histogram from the Reports > Delay Histograms menu 
on the Control Panel. Absolute delay is the total amount of delay that non-cancelled flights 
have received. This includes delays assigned by the NAS and ATC, as well as airline 
delay. Absolute delay is calculated using Max (0, [ETA - (IGTA - Taxi)]), therefore any 
time a flight's ETA is updated the absolute delay is recalculated. 

The title of the histogram is centered over the graph and reads “Absolute Delay 
Histogram: [APT or FEA/FCA] [ADL Date] [ADL Time].” The title bar displays the 
status of the data:

• Live mode – Absolute Delay: [AP or FEA/FCA] dd/hhmm Live
• Frozen in Live Mode – Absolute Delay: [APT or FEA/FCA] dd/hhmm Live: Frozen.
• Historical Mode – Absolute Delay: [APT or FEA/FCA] [yyyy]/[Mmm]/[dd] [hhmm] 

HIST
• Frozen in Historical Mode – Absolute Delay: [APT or FEA/FCA] [yyyy]/[Mmm]/[dd] 

[hhmm] HIST: Frozen

The flight data displayed on the histogram is dynamic. Each time FSM receives an ADL 
for the airport, FEA, or FCA, data on the histogram updates. You can freeze the data by 
selecting the Freeze Data on the Histogram menu.

The X-axis shows the Absolute Delay in minutes. FSM groups flights on the X-axis of the 
graph in 15-minute bins:

• The smallest bin is 0-14 minutes
• The largest bin is 360+ minutes

The Y-axis indicates the number of flights:

• The minimum value on the Y axis is 0
• The maximum value on the Y axis is calculated by FSM

The bars showing the distribution of flights are green. Each bar has a tool-tip which 
displays the total number of flights in that bin. Double-clicking a bar opens a Flight List 
for the flights represented by that bar.
Absolute Delay Histogram Menu

The Absolute Delay Histogram has three menus: File, Histogram, and Help.

1. File Menu

• Save As – Saves the Absolute Delay Histogram as a .jpg image in a directory 
that you specify. The default location for saved images is 
…\fsm\data\default_user\reports, and the default file name is 
absolute_delay.jpg.

• Print – Sends a .jpg image of the active Absolute Delay Histogram to a printer 
that you specify

• Close – Closes the Absolute Delay Histogram
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2. Histogram Menu

• Freeze Data – When checked, prevents the Absolute Delay Histogram from 
updating when new ADLs arrive

3. Help Menu

• Histogram – Opens the on-line help for the Absolute Delay Histogram 
component

Surface Delay Report
The Surface Delay Report indicates the ground delay imposed on flights and contains 
departure information for both arriving and departing flights. To view a Surface Delay 
Report, select the monitored airport, FEA, or FCA for which you want to view the report 
and then select Reports > Surface Delay from the FSM Control Panel component.

Figure 21 - 14 : Surface Delay Report

The displayed information defaults to arrival data. To view departure data select View > 
Departure Data. The Surface Delay Report then displays both arrival and departure data. 
To alternate information in the report you can check or uncheck the arrival or departure 
boxes.
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Surface Delay Report Menu
Many of the menu items for the Surface delay Report are the same as the Flight List 
component. The list below describes the menu items that are different for, or unique to, the 
Surface Delay Report; for more information on the Flight List component, see Chapter 6: 
Viewing Flight Information. There are four menus: File, View, Flight List, and Help.

1. File Menu

• Save As

• Print

• Close

2. View Menu

• Rename Window

• Arrival Data – Toggles Arrival data off and on.

• Departure Data – Toggles Departure data off and on.

• Add/Remove Columns

• Group Flights

• Sort Flights

• Apply Filter

• Clear Filter

• Flight Info

• Flight Detail

3. Flight List Menu

• Freeze Data

• Data/Filter Display

• Set Time

• Search By Callsign

4. Help Menu

• Surface Delay – General information about this report

Priority Flight Report
This report identifies "priority" flights. It is similar to a Flight List, but only lists those 
flights tagged as Lifeguard (LFG) or Diversion Recovery (DVT) flights. To view a 
Priority Flight Report, select the monitored airport, FEA, or FCA for which you want to 
view the report and then select Reports > Priority Flights from the Control Panel 
component. Any flights that have the LFG or DVT checkboxes marked are displayed on 
the Priority Report.
FSM User Guide, Version 9.00 21-20



Understanding and Using FSM Reports
Priority Report Menu
Many of the menu items for the Priority Report are the same as the Flight List component. 
The list below describes the menu items that are different for, or unique to, the Priority 
Report; for more information on the Flight List component, see Chapter 6: Viewing Flight 
Information. There are four menus: File, View, Flight List, and Help.

1. File Menu

• Save As

• Print

• Close

2. View Menu

• Rename Window

• Arrival Data – Toggles Arrival data off and on.

• Departure Data – Toggles Departure data off and on.

• Add/Remove Columns

• Group Flights

• Sort Flights

• Apply Filter

• Clear Filter

• Flight Info

• Flight Detail

3. Flight List Menu

• Freeze Data

• Data/Filter Display

• Set Time

• Search By Callsign

4. Help Menu

• Priority – General information about this report
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Figure 21 - 15 : Priority Report

Time Out Delay Report
The Time Out Delay Report provides a quick picture of flights that are contributing to the 
Time Out delay problem. The report is in the same format as FSM Flight Lists and 
includes all inactive (no E or A prefix to the ETD) flights with a delay status of ‘TOD'. To 
view the Time Out Delay Report, select an airport being monitored and then select 
Reports > Time out Delay from the FSM Control Panel component. The Time Out Delay 
report flight list shows all flights that have triggered the TOD alarm with the TOD 
checkbox selected (see Figure 21 - 16).
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Figure 21 - 16 : Time Out Delay (TOD) Report Flight List

The displayed information defaults to arrival data. To view departure data, select View > 
Departure Data (see Figure 21 - 17).

Figure 21 - 17 : TOD Delay Report with Departure Data

The Time Out Delay Report displays both arrival and departure data. To alternate 
information in the report you can check or uncheck the arrival or departure boxes.

Time Out Delay Report Menu
Many of the menu items for the Time Out Delay Report are the same as the Flight List 
component. The list below describes the menu items that are different for, or unique to, the 
Time Out Delay Report; for more information on the Flight List component, see Chapter 
6: Viewing Flight Information. There are four menus: File, View, Flight List, and Help.
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1. File Menu

• Save As

• Print

• Close

2. View Menu

• Rename Window

• Arrival Data – Toggles Arrival data off and on.

• Departure Data – Toggles Departure data off and on.

• Add/Remove Columns

• Group Flights

• Sort Flights

• Apply Filter

• Clear Filter

• Flight Info

• Flight Detail

3. Flight List Menu

• Freeze Data

• Data/Filter Display

• Set Time

• Search By Callsign

4. Help Menu

• Time Out – General information about this report

Time Out Cancel Report
The Time Out Cancel Report provides a quick picture of flights, from your operation, 
which are contributing to the Time Out cancel problem. The report is in the same format 
as FSM Flight Lists and includes all flights with a cancellation status of Time Out 
Cancelled (ToCnx). To view the Time Out Cancel report, select a monitored airport, FEA, 
or FCA and then select Reports > Time Out Cancel from the Control Panel component. 
The Time Out Cancel report shows all flights that have triggered the ToCnx alarm and the 
ToCnx checkboxes are selected for all flights included in the report. The Time Out 
Cancelled report format is identical to the Time Out Delayed report as shown in Figure 21 
- 16.

The displayed information defaults to arrival data. Select the View > Departure Data 
checkbox to view Departure Data in the Flight List. The Time Out Cancel Report then 
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displays both arrival and departure data. To alternate information in the report you can 
check or uncheck the arrival or departure boxes.

Time Out Cancel Report Menu
Many of the menu items for the Time Out Cancel Report are the same as for the Flight List 
component. The list below describes the menu items that are different for, or unique to, the 
Time Out cancel Report; for more information on the Flight List component, see Chapter 
6: Viewing Flight Information. There are four menus: File, View, Flight List, and Help.

1. File Menu

• Save As

• Print

• Close

2. View Menu

• Rename Window

• Arrival Data – Toggles Arrival data off and on.

• Departure Data – Toggles Departure data off and on.

• Add/Remove Columns

• Group Flights

• Sort Flights

• Apply Filter

• Clear Filter

• Flight Info

• Flight Detail

3. Flight List Menu

• Freeze Data

• Data/Filter Display

• Set Time

• Search By Callsign

4. Help Menu

• Time Out Cancel – General information about this report

Slot Hold Report
The Slot Hold Report lists cancelled flights that currently have their slots held. (see Figure 
21 - 18) This report is similar to an FSM Flight List, but only lists those flights whose slot 
hold flag is set to ‘Y.’ To view a Slot Hold Report, select the monitored airport for which 
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you want to view the report and then select Reports > Slot Hold in the Control Panel 
component.

Figure 21 - 18 : Slot Hold Report 

The displayed information defaults to arrival data. To view departure data, select View > 
Departure Data checkbox in the dropdown menu. The Slot Hold Report then displays both 
arrival and departure data. To alternate information in the report you can check or uncheck 
the arrival or departure boxes.

Slot Hold Report Menu
Many of the menu items for the Slot Hold Report are the same as for the Flight List 
component. The list below describes the menu items that are different for, or unique to, the 
Slot Hold Report; for more information on the Flight List component, see Chapter 6: 
Viewing Flight Information. There are four menus: File, View, Flight List, and Help.

1. File Menu

• Save As

• Print

• Close

2. View Menu
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• Rename Window

• Arrival Data – Toggles Arrival data off and on.

• Departure Data – Toggles Departure data off and on.

• Add/Remove Columns

• Group Flights

• Sort Flights

• Apply Filter

• Clear Filter

• Flight Info

• Flight Detail

3. Flight List Menu

• Freeze Data

• Data/Filter Display

• Set Time

• Search By Callsign

4. Help Menu

• Slot Hold – General information about this report

Sub Opportunities Report
You can access the Sub Opportunities Report from the Control Panel by selecting Reports 
> Sub Opportunities. This report assists airlines and general aviation customers in 
identifying subbing opportunities. If a flight’s ERTA is updated, the ERTA-CTA column 
will help identify if the flight can not meet its arrival slot time (see Figure 21 - 19).
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Figure 21 - 19 : Sub Opportunities Report

Sub Opportunities Report Menu
Many of the menu items for the Sub Opportunities Report are the same as for the Flight 
List component. The list below describes the menu items that are different for, or unique 
to, the Sub Opportunities Report; for more information on the Flight List component, see 
Chapter 6: Viewing Flight Information. There are four menus: File, View, Flight List, and 
Help.

1. File Menu

• Save As

• Print

• Close

2. View Menu

• Rename Window

• Arrival Data – Toggles Arrival data off and on.

• Departure Data – Toggles Departure data off and on.

• Add/Remove Columns

• Group Flights
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• Sort Flights

• Apply Filter

• Clear Filter

• Flight Info

• Flight Detail

3. Flight List Menu

• Freeze Data

• Data/Filter Display

• Set Time

• Search By Callsign

4. Help Menu

• Sub Opportunities – General information about this report

Slot List
You can view the Slot List for airlines or centers with the following two Slot List reports:

• By Carrier
• By Center

Slot List By Carrier
Select Reports > Slot List > By Carrier to view this report. The Slot List report generates 
the second part of the FADT List that FSM generates after a program runs. Included in the 
Slot List are the Aircraft Identification number (ACID), assigned slot time (ASLOT), 
departure center (DEP), arrival center (ARR), controlled time of departure (CTD), 
controlled time of arrival (CTA), aircraft type (TYPE), exemption status (EX), 
cancellation status (CX), slot hold status (SH), earliest runway time of arrival (ERTA), 
and initial gate time of departure (IGTD) (see Figure 21 - 20).
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Figure 21 - 20 : Reports > Slot List > By Carrier

Slot List By Center
Select Reports > Slot List > By Center to view this report. This report allows any field 
facilities to recreate a slot list should the list normally transmitted by the TFMS not be 
received. The report is based on the current ADL. FSM allows the user to select a center’s 
(or centers’) report to view. Users can select US and Canadian Centers.
To Generate a Slot List By Center report

1. From the main Control Panel select Reports > Slot List > By Center. The Slot List 
By Center dialog box opens (see Figure 21 - 21).
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Figure 21 - 21 : Slot List by Center

2. Select the Centers to be included in the report and click OK. Clicking Clear All 
erases all selections in the Slot List By Center dialog box. Clicking OK after you 
click Clear All returns you to the Time Line window. Clicking Cancel closes the 
Slot List By Center dialog box without taking any action.
Clicking OK opens the List Report. The data fields and menu options in the Slot 
List by Center report are the same as the Slot List by Carrier report. Note that the 
Slot List by Center report title is B6 List Report (see Figure 21 - 22).
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Figure 21 - 22 : Reports > Slot List > By Center

Slot List Report Menu
Slot List Report has four menus: File, View, Slot List, and Help.

1. File Menu

• Save As – Saves the list as a file so that you can access it later.

• Print – Prints the report.

• Close – Closes the report window.
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2. View Menu

• Freeze Data – When selected, this keeps the slot list from updating with the 
next ADL.

3. Slot List Menu

• Search – Allows you to search for a specific string of data.

4. Help Menu

• Slot List – General information about this report.

Uncontrolled Drop Out Report
You can use the Uncontrolled Drop Out report to view flights that have rerouted out of the 
currently viewed data set.

Figure 21 - 23 

The Uncontrolled Drop Out Report groups flights by Center. This report can help Centers, 
as well as NAS Users decipher what flights no longer are controlled by the currently 
viewed data set. 
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Uncontrolled Drop Out Report Menu
Many of the menu items for the Uncontrolled Drop Out Report are the same as the Flight 
List component. The list below defines only the menu items that are different for, or 
unique to, the Uncontrolled Drop Out Report; for more information on the Flight List 
component, see Chapter 6: Viewing Flight Information. There are four menus: File, View, 
Flight List, and Help.

1. File Menu

• Save As – Saves the list as a file so that you can access it later.

• Print – Prints the report.

• Close – Closes the report window.

2. View Menu

• Rename Window

• Arrival Data-Toggles arrival data off and on.

• Departure Data- Toggles departure data off and on.

• Add/Remove Columns

• Group Flights

• Sort Filters

• Apply Filter

• Clear Filter

• Flight Info

• Flight Detail

3. Flight List Menu

• Freeze Data

• Data/Filter Display

• Set Time

• Search By Callsign

4. Help Menu

• Uncontrolled Drop Out-General information about this report.

Understanding Coversheet Reports
FSM creates three Coversheet reports:

• FADT
• Analysis
• Carrier Statistics
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FADT Report
FSM generates FADT reports when you Run any TMI operation. A FADT reports 
contains program parameters and delay statistics for that TMI operation. To review the 
FADT file, select View > FADT Report from the TMI coversheet and the FADT Report 
window opens with the program information (see Figure 21 - 24).

Figure 21 - 24 : FADT Report

Analysis Report
To evaluate the effects of a TMI after the program runs, select View > Analysis from the 
coversheet of any program. (FSM generates the coversheet when you click Run from a 
GDT Setup Panel after setting the desired parameters). FSM automatically opens the 
spreadsheet application you have indicated in your configuration files to display the 
Analysis Report (see Figure 21 - 25).
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Figure 21 - 25 : Analysis Report

The Analysis Report contains information pertinent to the TMI program that just ran:

• Detailed slot information for individual airlines
• Delay statistics for before and after the operation 
• Arrival and departure information for individual flights

The report contains two sections. One section reflects changes that occur as a result of 
RBS; the other section reflects changes that occur as a result of Compression.

Carrier Statistics Report
FSM generates Carrier Statistics when you Run any TMI operation. The Carrier Statistics 
report contains delay statistics for all carriers with flights that operate at that particular 
airport. To view the Carrier Statistics, select View > Carrier Statistics from the 
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Compression coversheet or select Reports > Carrier Statistics from the Control Panel. 
Ensure that the desired airport is active to review the correct airport’s carrier statistics 
when selecting Carrier Statistics from the Control Panel (see Figure 21 - 26).

Figure 21 - 26 : Carrier Statistics Report

FSM calculates only flights with assigned arrival slots in the report metrics. That is, flights 
with a Control Time of Arrival (CTA) are displayed in carrier statistics. If a carrier 
operates at the airport, or travels through an FEA or FCA, but has no flights with a CTA, 
the Carrier Statistics report displays “0” or “N/A” in those rows. You can choose the type 
of delay to view in the report by selecting a Delay Type of either Program or ABS at the 
top of the report. FSM selects the Program delay type by default. ABS Delay is the 
absolute delay on a flight, including FAA and airline delay imposed on the flights. FSM 
calculates Absolute delay using Max (0, ETA - [IGTA - Taxi]). Program Delay is the delay 
imposed only by the FAA on flights and FSM calculates it using Max (0, CTA - BETA).

The report displays delay statistics for all carriers that operate at an airport or travel 
through an FEA or FCA. Carriers with no presence at the monitored airport, FEA, or FCA 
are not displayed in the Carrier Statistics.

Note:  View > Carrier Statistics report is not available from a 
coversheet that you opened from a file.

The following information is displayed in the Carrier Statistics Report:

• Carrier Name – The airline to which the delay data corresponds.
• CDM MBR – Indicates if the carrier is a CDM member (Y/N).
• # Flights Affected – Total/Non_Exempt/Exempt/CNX

-   Total: Total number of flights for the specified time period.
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-   Non-Exempt: Number of the total flights that are Non-Exempt (included) in the 
program.

-   Exempt: Number of the total flights that are Exempt (receive no delay) from the 
program.

-   CNX: Number of the total flights that are canceled (CNX).
• On Time% – Percentage of flights that arrive within 15 minutes of their ETA.
• Delay - Total/Total%/Avg/AffAvg –

-   Total: Total minutes of delay for each airline.

-   Total%: Percentage of delay attributed to the airline. FSM derives this value by 
dividing the total delay minutes for an airline by the total delay minutes for all 
airlines combined.

-   Avg: Average Delay minutes on a carrier's total number of flights.

-   Aff Avg: Average Delay minutes for the carrier's flights affected by a program.
• Delay - Max/Min –

-   Max: Shows Maximum delay amount that a carrier's flights could receive.

-   Min: Minimum delay amount that a carrier's flights could receive.
• % Delay /% Traffic – Indicates the delay equity for a carrier. A value of "1" in this 

column means that a carrier's delay is perfectly equitable. A value greater than "1" 
indicates a carrier receives worse than average delay. A value less than "1" indicates 
that a carrier receives less than average delay.

The bottom of the reports gives the same statistics for Scheduled/Non-Scheduled flights.
Carrier Statistics Menu Options

Carrier Statistics has three menus: File, View and Help.

1. File Menu

• File > Save As – Saves the Carrier Statistics report as a .txt file in a directory 
that you specify.

• File > Print – Prints the Carrier Statistics report viewed on your screen.

• File > Close – Closes the Carrier Statistics report.

2. View Menu

• View > Freeze Data – When you select the Freeze Data checkbox, the carrier 
statistics report does not dynamically update with every ADL. FSM selects the 
Freeze Data checkbox by default.

3. Help Menu

• Help > Carrier Statistics – Opens the on-line help for Carrier Statistics.
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22:  Using Query Manager
The Query Manager in FSM is a useful tool for retrieving data from FSM that is not 
already in one of the reports mentioned in Chapter 21: Understanding and Using FSM 
Reports. You can use this tool to build your own ad-hoc reports. Select Utilities > Query 
Manager from the Control Panel to access the Query Manager component. The Query 
Manager has built-in filters, user defined filters, and a Create Filter component that has 
predefined logical groupings. This chapter discusses these filters and how to use them.

Built-in Filters
Built-in Filters are pre-defined, read-only filters designed from criteria that are frequently 
used for viewing flight information.

Select Utilities > Query Manager from the Control Panel to access the Query Manager 
component. Double-click the BUILT_IN Built-in Filters folder or click the Expand/
Collapse icon to view/hide all contents in the folder (see Figure 22 - 1). When you expand 
the Built-in Filters folder, you see a number of filters from which to choose. You can 
continue to drill down to view more detail by double-clicking the folders or by clicking 
their respective Expand/Collapse icons.

Figure 22 - 1 : Query Manager Built-In Filters

The AND filters list consists of filters that FSM compares to find a match in the data set. 
For an object to match an AND filter, all the filters in the list must be true. An OR filter 
consists of a list of filters that FSM compares to find matching flights in the data set. For 
an object to match an OR filter at least one of the filters in the list must be true. A 
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CONSTRAINT is an attribute, operator, or value. FSM uses the red AND, the blue OR, 
and the green CONSTRAINT coloring as a visual aide to distinguish between the three 
different types of filter options.

The AND, OR, and CONSTRAINT filters have the ability to create new filters by 
copying/pasting a built-in filter selection directly into the USER User Defined Filters 
folder. The Built-in Filters option buttons remain grayed because they are read-only 
filters. You cannot edit or delete a Built-in Filter for the same reason.

User Defined Filters
User Defined Filters are active filters you create and customize based on your Flight List 
needs. There are two methods of creating user-defined filters:

1. Adding a New Filter

2. Editing a Built-in filter

Creating a New User Defined Filter
If you find that the existing filters do not give you the information you need, you can 
create a new filter.
To create a new User Defined Filter

1. Select Utilities > Query Manager from the Control Panel to access the Query 
Manager component. 

2. Select the User Defined Filters folder (see Figure 22 - 2).
FSM User Guide, Version 9.00 22-2



Using Query Manager
Figure 22 - 2 : User Defined Filters

3. Click Add.
The Add Filter dialog box opens.

Figure 22 - 3 : Add Filter Dialog Box

4. You can select one of three filter types: OR List, AND List, and Constraint.

5. In Filter name, you can give your filter a unique name.

6. Click OK.
FSM adds the new filter under the User Defined Filters folder.
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Figure 22 - 4 : New User Defined Filter

For information on creating Constraint filters, see “To create user defined Constraint 
filters”. For information on how to add additional filters and constraints to AND and OR 
filters, see the following section.
To add additional filters and constraints to User Defined Filter

Once you create a new AND or an OR filter, you can add additional filters and constraints 
to them. There are two ways to add additional filters and constraints:

• Use the copy and paste functionality to add existing Built-in or User Defined filters to 
the User Defined filter.

• Highlight the filter to which you want to add filters and constraints and use the steps in 
“To create a new User Defined filter” above starting with step 2 to add the filter or 
constraint.

This section shows how to use the copy and paste method.

1. Select the Filter that you want to add to the User Defined Filter.
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Figure 22 - 5 : Built-In Filter

2. Select Edit > Copy.

3. Select the User Defined Filter to which you want to add the filter.

Figure 22 - 6 : User Defined Filter
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4. Select Edit > Paste.
The Filter is displayed below the User Defined Filter.

Figure 22 - 7 : Filter Added to User Defined Filter

To create user defined Constraint filters

1. From the Query Manager window, click Add.

2. Enter a Filter name.

3. Select Constraint from the Add Filter dialog box.

Figure 22 - 8 : Add Filter Window

4. Click OK.
The Edit Constraint window opens.
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Figure 22 - 9 : Edit Constraint Window

Note:  From the Edit Constraint window you must define your 
constraint by selecting a value from each of the three 
windowpanes (one value per window): Attributes, Operators and 
Pre-defined Values.

5. Select an attribute from the Attributes windowpane. This automatically populates 
the Operators windowpane with the available options based on your attribute 
selection.

Figure 22 - 10 : Edit Constraint Window

6. Select one of the Operators listed.

7. Select one of the Pre-defined Values.
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Note:  Some Pre-defined Values and User Values may automatically 
populate as a result of the selection made in the Attributes 
windowpane.

8. Enter a value in the User Value text-field if no options are displayed in the Pre-
defined Values windowpane.

Figure 22 - 11 : Edit Constraint Window with User Value

9. Click OK to complete the Constraint definition.
FSM adds the new CONSTRAINT filter under the User Defined Filters. The 
CONSTRAINT is displayed with the new filter name including the three values 
chosen from the Edit Constraints component in brackets.
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Figure 22 - 12 : Query Manager with User Defined Constraint

To edit an existing CONSTRAINT

You can edit only User Defined Constraints; you cannot amend additional filters to an 
existing CONSTRAINT. The Add button is disabled when an existing CONSTRAINT is 
highlighted.

1. Click Edit.
The Edit Constraint window opens.

Figure 22 - 13 : Edit Constraint Window
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2. Select the new value from Attributes, Operators, Pre-defined Values, or enter a 
new User Value.

Figure 22 - 14 : Edit Constraint Window with New User Value

3. Click OK to complete the new Constraint definition.
FSM changes the Constraint accordingly.

Figure 22 - 15 : Query Manager with edited User Defined Constraint

To delete a User Defined Filter

You can permanently remove user defined filters.
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1. Select the filter you want to delete.

2. Click Delete.
To view User Defined Filter information

You can select the collapse/expand icon next to the filter name or double-click the folder 
to view/hide filter information (see Figure 22 - 16).

Figure 22 - 16 : User Constraint Added

Using the Create Filter Component
The Create Filter component allows you to create a filter based on a set of predefined 
logical groupings to search for flights within FSM. The filter it creates is just another type 
of User Defined Filter. It can be edited in the same as any other User Defined Filter using 
the methods outlined in the Chapter 22: User Defined Filters section. 

You can access the Create Filter component from the Query Manager by clicking Create 
Filter or by selecting Edit > Create Filter.
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Figure 22 - 17 : Create Filter Component

The Create Filter component has two panes. The left pane contains the logical groupings 
and the right pane has the associated settings for each logical grouping. 

If you change at least one element of a grouping, the label on the grouping in the left pane 
becomes bold. If you click Reset Group for a logical grouping, FSM removes the bold 
face.

In the Filter Name, you can enter a name for your filter. The Filter Name text field uses 
existing Query Manager name constraints. 

For the filters, FSM does not allow you to enter a non-alpha value in an alpha field. For 
example, entering a * character does nothing in alpha fields. Also, FSM does not allow 
you to enter a non-numeric value in a numeric field. For example, entering the letter A 
does nothing in numeric fields. All text fields accept the separators “,”, “;”, “:”, or space. 
Alphanumeric characters are valid for airport fields.

The following logical groupings are displayed in the Create Filter component:

• General – Selecting flight data for Arriving or Departing flights.
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• Arrival Times – Selecting flight data for flights that have any ADL arrival time that 
falls within a user specified time range.

• Departure Times – Selecting flight data for flights that have any ADL departure time 
that falls within a user specified time range.

• Flight Time – Selecting flight data for flights that have any ADL En Route time as 
well as FSM calculated times that fall within a user specified time range.

• Flight Status – Selecting flight data for flights that have any of the characteristics of 
the following current flight statuses: Departing No Estimated Departure Clearance 
Time (EDCT), EDCT Issued, Departing Past Estimated Time of Departure (ETD), 
Flight Canceled, Flight Arrived, Flight Active, Ground Stopped, and Flight Removed, 
or taxied.

• Origin – Selecting flight data for all flights that are departing from individual Centers 
and Airports.

• Destination – Selecting flight data for all flights that are arriving at individual Centers 
and Airports.

• Arrival Fix – Selecting flight data for all flights that have a user specified Arrival Fix, 
as well as allowing the user to select flights that have an Estimated Arrival Fix Time 
(EAFT) that falls within a user specified time range.

• Departure Fix – Selecting flight data for all flights that have a user specified Departure 
Fix as well as allowing the user to select flights that have an Estimated Departure Fix 
Time (EDFT) that falls within a user specified time range.

• NAS User – Selecting flight data for all flights that have a user specified MAJOR and/
or AC. 

• User – Selecting flight data for all flights that have a specified ADL USR type.
• Aircraft Information – Selecting flight data for all flights that have a user specified 

aircraft category and/or class.
• Delay Metrics – Selecting flight data for all flights that have FSM calculated delay 

metrics that fall within a user specified interval.
• Delay Information – Selecting flight data for all flights that have ADL Delay Flag(s) 

as specified by the user.
• CNX/DO Information – Selecting flight data for all flights that have any ADL 

Cancellation Flag, Drop Out Flag or RM Flag as specified by the user.
• Control Type -- Selecting flight data for all flights that have any ADL Control Type as 

specified by the user.
• CDM Participation – Selecting flight data for all flights that have a user specified 

CDM participation status.
• Remarks – Selecting flight data for all flights that have any ADL Remarks fields as 

specified by the user.
• Exemption Status – Selecting flight data for all flights that have ADL CTL_EXEMPT 

flag status as specified by the user.
• Alarm Status – Selecting flight data for all flights that have ADL Alarms fields as 

specified by the user.
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The “AND” operator applies to the logical groupings. In other words, the filter uses all 
user entered data or defaults for all selected logical groups to create the filter. If you want 
to avoid including a logical grouping for which you have added a value, you have to click 
Reset Group for that logical grouping to revert to the default. The label for the logical 
grouping should no longer is displayed in bold.

Create Filter Buttons
The Create Filter component has four buttons which allow you to reset a group, reset the 
whole filter, cancel the filter and create the filter. The four buttons are:

• Reset Group – clears all user entered data for the selected group.
• Reset All – clears all user entered data for that filter and resets the filter name to New 

Filter.
• Create – creates a new filter, includes all of the user entered data for that filter, checks 

the filter name format, and closes the Create Filter component.
• Cancel – closes the Create Filter component without creating the new filter.

Create Filter Menu Items
The Create Filter component has two menus, File and Help. The File menu has only a 
Close menu item. Selecting File > Close closes the Create Filter component. The Help 
menu has only a Create Filter menu item. Selecting Help > Create Filter opens the on-line 
help for the Create Filter component.

Creating and Saving a Filter
You can create a filter using the Create Filter component and save it to use for later 
sessions. The filter can have one logical grouping or a combination of several logical 
groupings. Once created, the new filter is displayed in Query Manager and in the Apply 
Filter function for all flight lists accessed after you create the new filter. When you create 
a filter using the Create Filter component, it is data set independent so you can use it to 
filter any data set in FSM.

1. Select Utilities > Query Manager to open the Query Manager component. The 
Query Manager opens.
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Figure 22 - 18 : Query Manager

2. Click Create Filter. The Create Filter component opens.
FSM User Guide, Version 9.00 22-15



Using Query Manager
Figure 22 - 19 : Create Filter Component

3. Enter a name in Filter Name. If you give the filter the same name as an existing 
filter, FSM appends a number (#) to the name. For example, if a filter named 
Arrivals already exists and you name your new filter Arrivals, FSM names the 
filter Arrivals(1). For this example, enter Arrivals.

Figure 22 - 20 : Filter Name

Note: You cannot leave the Filter Name blank, it must contain text or 
you receive an error message.

4. Select a logical grouping from the Filter Groups section. For this example, select 
Arrival Fix.
FSM User Guide, Version 9.00 22-16



Using Query Manager
5. For filters with text entry fields, enter the appropriate text for your filter. For this 
example, enter DALAS.

6. For filters with time entry fields, select an operator from the dropdown box and 
then enter the time for which you want to filter flights. FSM provides the following 
operators, =, <,>, =, =, Between, Not Between. For this example, select = and enter 
091900.

Figure 22 - 21 : Arrival Fix Logical Group

7. You can add an additional logical grouping by selecting it from the Filter Groups 
section. For this example, select Destination.

8. Uncheck All in the Arrival Center section.

9. Select ZTL and ZDC from the Arrival Center section. This causes FSM to filter 
the flight list to show all flights arriving at those centers. You can select All to 
include all centers or deselect All to remove all centers from consideration. If you 
do not select a Center, you need to enter an airport or airports in the Include or 
Exclude fields.

10. Enter BNA in Include. This causes FSM to filter the flight list for flights arriving 
at BNA. 

11. Enter BWI in Exclude. This causes FSM to filter out all flights arriving at BWI.
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Figure 22 - 22 : Destination Logical Grouping
If you want FSM to show all flights that match all criteria entered in the 
Destination filter, select the AND radio button.
If you want FSM to show all flights that match any one of the criteria entered in 
the Destination filter, select the OR radio button.

12. Select Arrival Time from the Filter Groups section. Select Between from the 
ETA dropdown box. For this example, enter 091830 in the first time entry field 
and 091930 in the second time entry field.
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Figure 22 - 23 : Arrival Time Logical Group

Note: For a time/date field with an All checkbox, selecting the 
checkbox clears out any entered time/date data in the same row.

13. Once you have entered all of the criteria for your filter, click Create. FSM creates 
the filter and adds it to the User Defined Filters in the Query Manager.
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Figure 22 - 24 : Arrivals Filter is Displayed in Query Manager

If you want to use this filter in later sessions, select File > Save from the Query Manager 
component. FSM saves filters created using Create Filter to the local FSM installation. 
These filters will not be available to users using other FSM installations.

Renaming a User Defined Filter
If you decide that the name you gave your filter is not descriptive enough, you can rename 
it.

1. Select the filter name in Query Manager.

2. Select Edit > Rename Filter. The filter name is displayed in an editable text area.
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Figure 22 - 25 : Editable Filter Name

3. Enter the new name for your filter.

4. Press Enter to save the new name.

Figure 22 - 26 : Filter is Renamed
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Deleting a Filter
If you no longer need a filter created using the Create Filter component, you can delete it 
using the same methods described in Chapter 22: User Defined Filters.

Query Manager Flight List
Access the Query Manager component by selecting Utilities > Query Manager from the 
Control Panel. When you want to see flights that meet certain criteria, you can generate a 
Flight List from the Query Manager component. Select any one of the Built-In or User 
Defined Filters. Click Flight List or select View > Flight List from the Query Manager 
component.

Note:  If you do not have a data set selected, FSM displays a “No 
Active Data Sets” error message.

The generated Flight List contains only those flights that meet the selected criteria. The 
Query Manager already contains a built-in filter for GS flights. To get a list of Departing 
CTD flights at any open data set, select the AND Departing-CTD Filter. Click Flight List 
or select View > Flight List from the Query Manager component.

Figure 22 - 27 : Query Manager Component

When you are monitoring more than one data set, clicking Flight List opens the Set Data 
Set window, showing all open data sets. Select the Data Mode/Data Set and click OK to 
view that airport’s GS Flight List (see Figure 22 - 28). Click Cancel to exit the Set Data 
Set window without opening a Flight List.
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Figure 22 - 28 : Set Data Set Selection window

Opening the Flight List from the Query Manger lists all the flights that are GS at the 
specified data set unless otherwise defined by a customized CONSTRAINT, whereas 
accessing a Flight List from the Bar Graph only displays a list of flights for the selected 
hour.

Figure 22 - 29 : Query Manager Flight List
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Appendix A:  Flight Status
The flight Status is displayed in the Flight Information window and can be one of the 
following:

• Normal - Flight is flying as expected.
• FX Cancelled - Generated when an airline sends an FX cancellation message.
• NAS Cancelled - A NAS Cancellation received through an RZ message. A flight 

cancellation message that arrives from somewhere in the NAS system other than the 
AOC in charge of the flight.

• RS Cancelled - an OAG cancellation.
• RM - The flight has been removed from the TFMS database.
• RZ - A NAS flight plan cancellation message.
• Timeout Cancelled - A timeout cancellation. TFMS cancels the flight because its 

EDT has passed and the flight has not taken off. TFMS determines the necessary lag 
time between the EDT and the current time before cancelling the flight. The amount of 
time depends upon whether TFMS received any information for the flight (e.g. flight 
plan).

• DV Cancelled - This flight has been diverted to a new arrival airport.
• ID Cancelled - The flight’s ID has been changed. In this case, the old flight and ID is 

cancelled and a new flight with a new ID is created.
• Airline Delayed (ALD) – A carrier delayed this flight by either an FC Message 

(create new flights) or and FM Message (modify flights).
• In Program - Delayed because of inclusion in a GDP or AFP.
• Ground Stopped - Delayed because of inclusion in a Ground Stop Program.
• Delay Assignment (DAS) - A new flight was created in the database after a GDP went 

into effect. Because this flight has not received any GDP delay, a DAS (formerly FA 
Delay) is put on the new pop-up flight.

• Timeout Delayed (TOD)- A flight’s ETD passed without the flight actually taking 
off. TFMS bumps the ETD time to account for possible unreported delay. Once the 
Time Out Delay goes into effect, TFMS determines the length of time to wait until 
registering the flight as TO Canceled.

• Drop Out - The flight dropped out of an FEA or FCA.

In Ground Delay Tools Mode, an exemption status is displayed in the Flight Information 
Window. Exemption status is displayed above the Flight Status in the Flight Information 
Window. Exemption status refers to the flight’s inclusion in a Ground Delay Operation 
and is one of the following:

• Excluded by Aircraft Type - The program did not include aircraft of this type.
• Excluded by Arrival Fix - The program did not include this arrival fix.
• Excluded by Arrival Time - The flight’s ETA did not fall within the program time 

limits.
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• Excluded by Departure Time (GS Only) - The flight is cancelled or the ETD is 
before the start time or after the end time.

• Exempted by Departing Center - The program did not include this flight’s center.
• Exempted by Distance - The flight is exempted because the departure airport is 

outside the distance specified by the program.
• Exempted by Departing Airport - This airport was specifically exempted from the 

program.
• Exempted by Specific Flight - This flight was specifically excluded from the 

program.
• Exempted by Departure Status - The ETD prefix is either A or E.
• Exempted by Departure Time - The flight’s Revised EDCT (or Ptime) comes before 

the Current Time + Now_Plus.
• Excluded and Exempted - Because of program parameters, this flight met excluded 

and exempted status criteria. This status includes flights which do not fly within the 
time period of a GDP and which meet exemption criteria.

• Not Exempted - This flight is eligible for inclusion in the program.

When a flight triggers one of FSM's alarms, FSM generates a list of flights that have 
triggered an alarm. Flights trigger alarms when they do not comply with certain 
operations’ criteria. Flights trigger alarms for the following reasons:

• CC - Flights arriving more than five minutes before or more than five minutes after 
their Control Time of Arrival.

• CF - Flights that were cancelled but later flew without the flight being reinstated 
properly.

• EA - The actual flight time is greater than a specified value, but the flight status is not 
cancelled. The default value is 15 minutes.

• EC - The departure boundaries are more than five minutes before or more than five 
minutes after their estimated departure clearance time.

• SF - Spurious Flights or flights submitted as SI cancellations with no corresponding 
entries in the OAD.

The term alerts refers to areas in which the traffic demand is projected to exceed a 
predefined capacity threshold. The following are flight Alerts:

• Alerts > FADT Parameters Available – This alert does not actually give you program 
parameters. Rather, you can view a listing of all the FADTs generated during that day. 
FADTs are reports generated when a GDP, AFP, GS, +/- Delay or Compression 
operation runs.

Note:  FSM does not always list the FADTs in chronological order.

• Alerts > SCS Bridge This alert turns red in color when there is a new SCS update. 
Selecting SCS Bridge displays the current subbing status and may contain the 
following keywords:
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-   SUBS: Indicates whether all substitutions are enabled (ON) or disabled (OFF)

-   SCS: Indicates whether slot credit substitutions for all operators are enabled 
(ON) or disabled (OFF)

-   ADPT: ON indicates that the TFMS Hub is running Adaptive Compression for 
this program.

-   BRIDGING: Indicates whether bridging subs are disabled (OFF) for a 
particular operator (airline name, GA, or MILITARY). If bridging is off for an 
airline, any flight whose MAJOR field or carrier code (from ACID) matches the 
airline name is not used for an SCS bridge. If bridging is enabled for an 
operator, no line is displayed, in other words, the only allowed value for this 
keyword is OFF.

• Alerts > Actual GDP Parameters Available – This alert turns red in color when FSM 
receives Actual GDP Parameters through the ADL. First-time GDP Parameters, new 
GDP Parameters and deleted GDP Parameters all trigger this Alert. Select Actual GDP 
Params Updated to view the parameters in the GDP Parameter Display panel, which is 
similar to the GDP Setup Panel. From the GDP Parameter Display panel, you can save 
the parameters or close the panel.

• Alerts>Actual AFP Parameters Available - This alert occurs when FSM receives actual 
AFP Parameters through the ADL. First-time AFP Parameters, new AFP Parameters, 
and deleted AFP Parameters trigger this Alert. Select this to view these parameters in a 
static window.

• Alerts > Proposed GDP Parameters Available - This alert turns red when parameters for 
a Proposed GDP arrive through the ADL. Select Proposed GDP Parameters to view 
the new parameters.

• Alerts > Proposed AFP Parameters Available - This alert occurs when FSM receives 
proposed AFP parameters through the ADL. Select this to view these parameters in a 
static window.

• Alerts > GS Parameters Available – This alert turns red in color when the FAA issues a 
GS and FSM receives its parameters through the ADL. First-time GS Parameters, new 
GS Parameters, and deleted GS parameters all trigger this Alert. Select GS Parameters 
to view the parameters in the GS Parameter Display panel, which is similar to the GS 
Setup Panel. From the GS Parameter Display panel, you may save the parameters to a 
file or close the window.

Note: GS parameters are not applicable to FCAs.

• Alerts > Compression Parameters Available – When FSM receives parameters for the 
compression function through the ADL, it triggers this alert. When Compression 
parameters arrive, Compression Parameters turn red in the Alert menu. Click the red 
text to view the new parameters.

• Alerts > Blanket Parameters Available – FSM applies this alert to all flights that are 
part of a specific GDP.

Note: Blanket parameters are not applicable to FCAs.
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Appendix B:  FSM Data Elements
The flight information listed below can be viewed in the Flight Detail window and 
corresponds with ADL flight information.

Flight Information

Flight ID Aircraft Identifier or callsign

Date ADL date

Time ADL Time

Aircraft Type Aircraft Type

AC_CAT Aircraft Category (Jet, Turbo, Prop)

Class Aircraft Weight Class (Jumbo, Heavy, Large, Small)

Major The carrier qualified to perform substitutions for the flight

CDM_Participant Y or N

User Air Carrier, Freight/Cargo, General Aviation, Military, Air Tax
Other.

Departure Information

DFIX Departure Fix

EFTD Estimated Departure Fix Time

DP Departure Procedure

DTRSN Departure Procedure Transition

Great Circle Distance

GCD The distance between the origin and the destination

Arrival Information

AFIX Arrival Fix

EAFT Estimated Arrival Fix Time

STAR Standard Terminal Arrival

STRSN Standard Terminal Arrival Transition
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Estimated Time Information

ETD Estimated Time of Departure:
The prefix indicates the status of the flights and the ETD is the 
estimated runway departure time considering all data sources. 
prefix and ETD are determined by separate logic.

The prefix values are, in increasing order of priority (that is, th
ADL will show the lowest prefix from this list that applies to a
flight whether or not that was the basis for the ETD:
S - The flight data is based solely on OAG data.
N - Early Intent Flights
P - Flight Plan
L - CDM Message (FM, FC)
T - Taxied
E - Extrapolated from active NAS message other than DZ; Flig
Airborne
A - Actual (DZ NAS message) or a CDM Participant provided 
time

ENTRY Current, best, estimated time of entry for a flight into an FEA o
FCA considering all data sources. This field is null if the flight 
not fly through an FEA or FCA.

EXIT Estimated Element Exit Time. The estimated time when the fli
will exit the FEA or FCA. This field is null if the flight does no
through an FEA or FCA.

ETE Estimated Time En Route

ETA Estimated Time of Arrival:
The prefix indicates the status of the flights and the ETA is the 
estimated runway arrival time considering all data sources. Th
prefix and ETA are determined by separate logic.

The prefix values are, in increasing order of priority (that is, th
ADL will show the lowest prefix from this list that applies to a
flight whether or not that was the basis for the ETA
E - TFMS Modeling
L - Airline
C - Controlled Time
A - Actual (AZ NAS message)

Other Flight Times

CTD/CTA Controlled Time of Departure/Arrival

CETE Controlled Estimated Time En Route
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SGTD/SGTA Scheduled Gate Time of Departure/Arrival (OAG)

PGTD/PGTA Proposed Gate Time of Departure/Arrival - Based on the NAS 
flight plan

PETE Proposed Estimated Time En Route

LRTD/LRTA Airline Runway Time of Departure/Arrival - Based on airline d
(CDM FM Messages)

LGTD/LGTA Airline Gate Time of Departure/Arrival - Based on airline data
(CDM FM Messages)

IGTD/IGTA Initial Gate Time of Departure/Arrival - Based on either OAG 
flight plan data, time never changes

IENTRY Initial Element Entry Time into an FEA/FCA

ARTD/ARTA Actual Runway Times of Departure/Arrival - Set by DZ/AZ N
messages.

OUT/OFF/ON/IN Actual airline flight times
OUT - Gate push back
OFF - Wheels up
ON - Wheels down
IN - At the gate

ERTD/ERTA Earliest Runway Time of Departure/Arrival - Based on airline 
submitted data as the earliest time a flight can depart or arrive.

EENTRY Earliest Element Entry Time

OETD/OETA Original Estimated Time of Departure/Arrival - Matches the E
ETA and then freezes when:
1. Flight becomes active
2. Flight becomes controlled
3. Flight becomes time-out delayed

OENTRY Original Element Entry Time

OETE Original Estimated Time En Route

BETD/BETA Based Estimated Time of Departure/Arrival - Matches the ETD
ETA and then freezes when:

1. Flight becomes active
2. Flight becomes controlled

BENTRY Based Element Entry Time

Other Flight Times
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FSM Data Elements

led 

 in 

P 

CS 

 GDP

ssued
OCTD/OCTA Original Controlled Time of Departure/Arrival - Initial control
times issued (never changes)

Flight Flags

Ctl Exempt Control Exempt Flag - Flight was exempt from departure delay
the most recent TMI event.

Ctl Type Control Type - The source of the control times most recently 
assigned to a flight:
GS -Ground Stop
AFP -Airspace Flow Program
GDP - Ground Delay Program (initial, revision, or extension)
COMP -Compression
DAS - Delay Assignment (formerly FA)
RCTL -Recontrolled (only for AFP flights)
BLKT -Blanket or +/- delay adjustment
SUB - Airline substitution message
SCS - Slot Credit Substitution submitted by a NAS user
ECR - Slot Credit Substitution submitted by an FAA user
ABRG - Control times assigned when creating a bridge for 
Adaptive Compression performed automatically by TFMS (AF
and GDP)
ADPT -Adaptive Compression
SBRG -Control times assigned when creating a bridge for an S
or ECR request (GDP and AFP)
UPD -EDCT Updated by an FAA user
GAAP - Unassigned slot assigned to a pop-up during a GAAP

Subbable Y or -

Ctl Element The constrained NAS element for which controlled times are i

Slot ID Assigned Slot Time (dd/hhmm)

Slot Hold Slot Hold flag - slot will not be used during compression

Div Recovery Diversion Recovery Flag - Flight was previously diverted
G - diverted while on the ground
A - diverted while airborne

Other Flight Times
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FSM Data Elements
Delay Status Red highlighted flag indicates:
ALD - Airline Delay
GDP - Delayed by CTD/CTA (airport)
AFP - Delayed by CTD/CTA (airspace) 
DAS (formerly FAD) - Pop-up flight after GDP issued
GSD - Delayed by Ground Stop
TOD - Time Out Delayed past the flights ETD

LTOD Length of Time Out Delay in minutes

CNX Status Cancellation status
UX - Update cancelled
FX - Airline cancelled
RZ - NAS cancelled
RS - OAG cancelled
TO - Time Out cancelled
DV - Diverted Flight
RM - Remove cancelled (CSA only function)

Remark Aircraft Remarks
NRP - National Route Program flight
LFG - Lifeguard or MEDVAC flight
III -     Minimizing CAT3 landing flight
ATV - Altitude Reservation
SWP - Swapping
DVT - Diversion Recovery flight
ADC - Advise Customs
FCA - Flow Constrained Area
WXR - Severe Weather Reroute

Alarm Alarm Status
CC - CTA non-compliance
EC - EDCT non-compliance
EA - ETE vs Actual Value
SF - Spurious Flight
CF - Cancelled but Flew

DO Drop Out, Y or -

Calculations

Absolute Delay Max (0, ETA - (IGTA - taxi))

Schedule Variation ETA - (IGTA - taxi)

Flight Flags
FSM User Guide, Version 9.00 B-5



FSM Data Elements

 this 
CT 
Program Delay Max (0, CTA - BETA)*
Note: Program Delay changes anytime a flight’s CTA changes,
includes airline substitutions and SCS messages and well as ED
updates. 

Calculations
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Glossary of Abbreviations
Appendix C:  Glossary of Abbreviations
• III – Category III Flight (flight remark)
• AAL – American Airlines
• AAR – Airport Acceptance Rate
• ADC – Advise Customs (flight remark)
• ADR – Airport Departure Rate
• ADPT – Adaptive Compression
• AETE – Actual Estimated Time En route
• Airborne Holding – A deterministic mathematical model used to calculate predicted 

airborne holding.
• AffAvgDelay – (Affective Average Delay) total delay divided by number of non-

exempted flights, calculated after running a GDP.
• AFP – Airspace Flow Program
• ALD – The carrier imposed a delay on the flight (delay status).
• ARTD /ARTA – Actual Runway Times (Departure/Arrival)
• ASD – Aircraft Situation Display
• ASLOT – Assigned Arrival Slot ID
• ATA – Actual wheels-on Arrival Time
• ATCSCC – Air Traffic Command System Control Center
• ATD – Actual wheels-off Departure Time
• ATR-310 – Traffic Flow Management Integrated Product team
• ATL – Atlanta International Airport
• ATV – Altitude Reservation (flight remark)
• AUA-500 – Air Traffic Systems Development, Traffic/Flight Service Station
• BENTRY – Based Element Entry Time
• BETD/BETA – Beginning Estimated Wheel Times
• BOS – General Edward L Logan International Airport in Boston
• CC – Alarm Status for flights arriving more than five minutes before or more than five 

minutes after their Control Time of Arrival
• CDM – Collaborative Decision Making
• CETE – Control Estimated Time En route
• CF – Alarm status for flights that were cancelled but later flew without the flight being 

reinstated properly.
• CNX – Cancelled Flight; Cancel 
• COA – Continental Airlines
• CR_TIME – Create Time
• CTA – Revised OrigCTA (Control Time of Arrival) after substitution/cancellation
• CTD – Control Time of Departure
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Glossary of Abbreviations
• CTL_ELEM – If a flight is controlled (i.e., has a CTD and CTA), this field indicates 
the constrained NAS element for which a ground delay program or ground stop was 
run. Currently, the CTL_ELEM can be an arrival airport, FEA, or FCA.

• CTT – Collaborative Technology Testbed
• DAS (formerly FAD) – Delay Assignment
• DCenter – Departure Center
• DEP – Departure Airport
• DO – Drop Out Flight
• DP – Departure Procedure
• DTRSN – Departure Procedure Transition
• DV – The flight was cancelled and diverted to an alternate destination (cancel status).
• DVT – Diversion Recovery flight (flight remark)
• EA – The actual flight time is greater than a specified value, but the flight status is not 

cancelled. The default value is 15 minutes (alarm status).
• EC – The departure boundaries are more than five minutes before or more than five 

minutes after their estimated departure clearance time (alarm status).
• ECR – EDCT Request Tool.
• EENTRY – Earliest Element Entry Time
• EGF – American Eagle Airlines
• ENTRY – Current, best, estimated time of entry for a flight into an FEA or FCA 

considering all data sources
• EPS – Airport Engineering Performance Standards
• ERTD/ERTA – Earliest Runway Times
• ETA – Updated Estimated (wheels-on) Arrival Time. Prefixes: P (proposed), E 

(estimated)
• ETD – Updated Estimated (wheels off) Departure time. Prefixes P (proposed), E 

(estimated)
• ETE – Estimate Time En Route in minutes
• EXIT – Estimated Element Exit Time
• FADT List – Generated after running a GDP. Contains information about all ground-

delayed flights (all flights that have been issued an OrigEDCT). If a center or an 
airline has ground-delayed flights, their call-signs, departure airports, PTimes, EDCTs 
and CTAs are given for each appropriate center and airline.

• FCA – Flow Constrained Area (flight remark)
• FEA – Flow Evaluation Area
• FSM – Flight Schedule Monitor
• FX – A CDM message used by the airlines to indicate a cancelled flight (cancel 

status).
• GCD – The Great Circle Distance (GCD), which is the distance between the departure 

airport and arrival airport.
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Glossary of Abbreviations
• GDP – Ground Delay Program
• GDT – Ground Delay Tools
• GS – Ground Stop
• HITL – Human in the Loop
• IENTRY – Initial Element Entry Time
• IPM – Integrated Program Modeling 
• IGTD/IGTA – Initial Estimated Gate Times
• LFG – Lifeguard Flight (flight remark)
• LGTD/LRTD/LRTA/LGTA – Airline Gate and Runway Times
• LTOD – Length of Time Out Delay
• MOA – Memorandum of Agreement/Military Operations Area
• NRP – National Route Program Flight (flight remark)
• OAG – Official Airline Guide
• OCTD/OCTA – Original Control Times
• OENTRY – Original Element Entry Time
• OETD/ OETA – Original Estimated Wheel Times
• OETE – Original Estimated Time En route
• ORD – O’Hare International Airport in Chicago
• OOOI – OUT/OFF/ON/IN – Time that the flight was out of the departure gate, off the 

departure runway, on the arrival runway, and in the arrival gate.
• PGTD/PGTA – Proposed Gate Times (Departure/Arrival)
• PETE – Filed Estimated Time En route
• Power Run – A Tab in the GDT Setup component, which allows you to model various 

scenarios to help evaluate what parameters are most favorable.
• RBS – Ration By Schedule. A ground delay algorithm based on the OAG time.
• RBS++ – An enhanced version of RBS which automatically performs compression.
• RM – The flight has been removed from the TFMS database (cancel status).
• RS – An internal TFMS message generated when a specialist takes an OAG flight out 

of the database (cancel status).
• RZ – A NAS flight plan cancellation message (cancel status).
• SCDT List – Contains flight delay information for the airport that has been issued a 

ground delay. Contains information such as flight’s call-sign, equipment type, 
departure airport, Ptime, etc.

• Schedule Accuracy – The sum of the absolute values of the difference of (actual 
departure time – estimated departure time) for each flight, divided by the number of 
valid flights.

• SCS – Slot Credit Substitution
• SF – Spurious Flights or flights submitted as SI cancellations with no corresponding 

entries in the OAD (alarm status).
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Glossary of Abbreviations
• SFO – San Francisco International Airport
• SGTD/SGTA – Scheduled Gate Times (Departure/Arrival)
• Slot ID – A time slot assigned during ground delay, substitution/cancellation
• Slot List – A modified FADT List. In addition to the information provided by the 

FADT list, the slot list includes the slot ID, flight class and information about 
exempted flights.

• STAR – Standard Terminal Arrival Route
• STRSN – Standard Terminal Arrival Route Transition
• SWP – SWAP flight (flight remark)
• TO – The flight time out considered cancelled because no activation message has been 

received within a certain time of the predicted departure time (cancel status).
• TOD – Time Out Delay -the flight passed its ETD without taking off (delay status).
• TFMS – Traffic Flow Management System
• UDG – User Defined Group from the Open Data Set component
• UX – Cancelled flight due to an EDCT update by a traffic manager (cancel status).
• WXR – Severe Weather Route (flight remark)
FSM User Guide, Version 9.00 C-4



Index
Airport and Airspace Conditions

Evaluating 1
Analysis Report 16
Index

A
Acronyms 4
Adaptive Compression 1
Add/Remove Columns

Add Data Column Information 29
Add Multiple Calculations 30
Global Default 32

Remove 33
Set 32

Rearrange Data Column Information 31
Remove Data Column Information 30

Advisory 107
AFP

Extend 1, 2
Get Weather Information 1
Send Proposed 5

Issuing 1
Advisory 3
Coversheet 1

Resend 5
Program Manager 4
Program Parameters 3

Model 1
Analysis Report 12
Data Graph 11
Proposed Parameters 6
Reload Data 14
User Specified Parameters 1

Purge
Outside of Revised Parameters 4

Purging 7
Reducing Scope 3
Revise 1, 2

Deciding When To 1
Get Weather Information 1
Issuing 8
Send Proposed 5

Suspend Substitutions and SCS 8
Airborne Holding 1

Using 1

B
Bar Graph

ADL AAR Line 8
ADL ADR Line 8
AFP Indicators 7
Arrival Flow Rate 8
Buttons 38
Changing Program Rate 9
Color By Aircraft Category 9
Color By Aircraft Class 10
Color By Alarm Status 16
Color By Arr/Dep 9
Color By Arrival Fix 14
Color By Carrier 10
Color By CDM Participation 16
Color By Centers 13
Color By Control Type 17
Color By Departure Fix 14
Color By Distance 16
Color By Exemption 15
Color By Program Delay 17
Color By Status 8
Color By Substitution Status 16
Color By User 15
Color Schemes Selection 41
Demand 1
Departure Flow Rate 8
Display 2

AAR 8
ADR 8
Arrival Bars 2
Cancelled Flights 4
Departure Bars 2
Hours Shown 8
Model Program Rate 8
Stack Departures 3
Time Increments 6
Time Indicator 7
Unassigned Slots 6

Dynamic Carrier Coloring 12
Fix Coloring 42
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Index
Fix Order 42
GDP Indicators 7
GDT 12
GDT Bar Graph

Display 4
GS Indicators 7
Hours Shown 8
IPM 160, 10
Legend 32, 6
Menu Bar 33
Model Program Rate 8
Recalculate Dynamic Carriers 13
Track Time 7

Bar Graphs
Tabs 38

Blanket 1
Using 4

C
Cancelled Flights

Bar Graph 4
Chapter 3 1
Common Terms 4
Component

Query Manager
Menu Bar 29
Open a Flight List 28

Components
Bar Graph 30, 42, 1

Buttons 38
Color Schemes Selection 41
Display 2
Fix Order 42
Legend 32
Menu Bar 33
Tabs 38

Control Panel 1
Buttons 14
Menu Bar 1

Coversheet 101
Advisory 107
Examples 109
Menu Bar 101
Program Manager 118

Demand By Center 97

Menu Bar 98
Element Display 58

Accessing 58, 59
Accessing From Control Panel 59
Accessing From Open Data Set 59
Data 58
Menu Bar 59

GDT Bar Graph 92, 160
GDT Data Graph 94

Delay Statistics 95
Menu Bar 97
Selecting Different Scenarios 95

GDT Map 86
Distance Based GDPs 88
Menu Bar 92
Tier Based GDPs 90
Zoom Capabilities 88

GDT Setup 61
Buttons 65
Menu Bar 63
Modeling Options Tab 79, 153
Parameters Tab 66
Scope Tab 75

GDT Time Line 99
Menu Bar 100

IPM Bar Graph 160, 10
IPM Data Graph 161, 11
IPM Demand By Center 164, 14
IPM Flight List 169, 13
IPM Map 157, 12
IPM Multi Graph 129, 7
IPM Scenario Manager 121
IPM Setup 136
IPM Time Line 166, 10
Map 23

Menu Bar 26
Opening Components With 25
Viewing Parameters 25
Zoom Capabilities 24

Monitored Live Mode 1
Open Data Set 15

Buttons 22
Group By 17
Menu Bar 16
Open With 17
Sort Airports By 16
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Index
Tabs 18
Query Manager 27
Time Line 44

Buttons 50
Color Scheme Selection 54
Fix Coloring 56
Fix Order 56
Flight Information 47
Icons 48
Menu Bar 50
Tabs 53

Compression
Adaptive 1
Issuing 1, 7

Advisory 6
Coversheet 4
GAAP GDP 7
GDT Mode 2
Parameters 3
Suspend Substitutions and SCS 2

Versus Revision 1
AFP 3
GDP 1

Contact Information 2
Control Panel 1

Buttons 14
Menu Bar 1

Conventions 3
Copy Impacting Condition 108
Count Lists 10
Coversheet 101

Advisory 107
AFP 1
Analysis Report 16, 12
Examples 109
GDP 1
Menu Bar 101
Program Manager 118
Resending 5

Custom Group. See User Defined Group

D
Data Graph

GDT 12
IPM 161, 11

Data Set
Opening

Monitored Live 2
Data Set Button

Opening Components From 11
Data Time

Historical Mode 7
Definitions 4
Demand By Center 97

GDT 15
IPM 164, 14
Menu Bar 98

Demand Counts 10
Demand Versus Capacity

Evaluating
Bar Graph 1
Time Line 1

E
Earliest R-Slot

Setting 73
ECR

Control Types 14
Earliest EDCT 8
EDCT Change Request 1
Locating Flight 6
Menu Bar 3
Opening 4
SCS Response

Viewing 13
Update Options 13
View Flight Information 7

EDCT Compliance
Adjusting 7
Confirming 4, 6
Monitoring 1

Adding ADL Fields 4
Column Positioning 4
Compliance List

Menu Bar 4
Exporting Compliance List to Excel 5
Single Flight 3

EDCT Remove
Remove Flights 7
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EDCT Restore
Restore Flights 7

Element Display 58
Accessing 58, 59
Accessing From Control Panel 59
Accessing From Open Data Set 59
Data 58
Menu Bar 59

F
Figure 3-13 21
Fix Coloring 42
Flight Detail Window

ADL Data Elements 44
ADL Information 1
Menu Bar 46

Flight Information
ADL 1
Bar Graph 7
Compliance Reports 47
Flight List

Buttons 26
Filters 23
Grouping Information 33
Menu 25
Opening 26
Sorting Information 36

Flight Reports 47
Query Manager 48
Search By Callsign 39
Time Line 7
Viewing 1

Color By Aircraft Category 9
Color By Aircraft Class 10
Color By Alarm Status 16
Color By Arr/Dep 9
Color By Arrival Fix 14
Color By Carrier 10
Color By CDM Participation 16
Color By Centers 13
Color By Control Type 17
Color By Departure Fix 14
Color By Distance 16
Color By Exemption 15
Color By Program Delay 17

Color By Status 8
Color By Substitution Status 16
Color By User 15
Coloring 7
Dynamic Carrier Coloring, Time Line

Dynamic Carrier Coloring 12
Flight Detail Window 43
Flight Info Window 41
Flight List 22
GDT Time Line 22
Open Arrival Slots 19
Problem Flights 47
Right-Click 3
Roll-Over 1
Single Flight 39
Time Line 18

Flight Count 19
Flight List 20

Flight Information Window
Flight Status 1

Flight List
Add/Remove Columns 29, 30, 31

Global Default 32
Apply Filters 38
Buttons 26
Exporting 38
Filters 23
Format 27
GDT 14
Grouping Information 33
IPM 169, 13
Menu 25
Opening 26

From Bar Graph 26
From Map 27
From Open Data Set 26
From Time Line 27

Selecting Information 28
Sorting Information 36

Multi-level 37
Flight Status 1
FSM

Opening 1
Data Set 1
Monitored Live 2
User Defined Groups 12
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Revise 5

Issuing 1
Advisory 3
Coversheet 1

Resend 5
Example 9
Program Manager 4
Program Parameters 3

Model
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Proposed Parameters 5
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Purge
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Purging 7
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GDT Data Graph 94

Delay Statistics 95
Menu Bar 97
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GDT Mode
Data Time

Modify 6

GDT Setup 61
Buttons 65
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Modeling Options 79, 153
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GDT Time Line 99
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Glossary 1
Ground Delay Tools

Components 60
Coversheet 101
Demand By Center 97
GDT Bar Graph 92, 160
GDT Data Graph 94
GDT Map 86
GDT Setup 61
GDT Time Line 99

Data Time
Modify 6

Ground Delay Tools Mode
Understanding 3

Ground Stop
GS

Issuing 1
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Extending 4
Issuing 1

Coversheet 6
Advisory 8
Parameters 8
Resending 10

Example 10
Query Manager 13

Moving to GDP From 7
Purging 1
Reducing Scope 4

GS Issuing
Parameters 1

H
Historical Mode
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Window 11
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Time Line 48
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Multi Graph 129, 7
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Map 23
Query Manager 27
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Components 1
Control Panel 1
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Monitoring
Airport 7
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Menu Bar 16
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