
31F1107-013-R0 

 
 
 
 
 
 
 
 
 
 

 

 

Route Management Tool  
(RMT) 

Version 1.50 

 

User's Guide 
 



 
 
 
 
 
 
 
 
 



  i 

 

                                                      TABLE OF CONTENTS 

INTRODUCTION ......................................................................................................................... 1 
WHAT IS RMT?............................................................................................................................ 1 

Web RMT.................................................................................................................................. 1 
RMT Version 1.50 .................................................................................................................... 1 

The CDR Tool ...................................................................................................................... 2 
The Playbook Tool ............................................................................................................... 2 
The NFDC Tool.................................................................................................................... 2 
The Route Options Generation (ROG) Tool ........................................................................ 2 
The Ad Hoc Reroutes Tool................................................................................................... 2 
The RMT Map...................................................................................................................... 3 

TEXT CONVENTIONS .................................................................................................................... 3 
TECHNICAL SUPPORT................................................................................................................... 5 

GETTING STARTED .................................................................................................................. 1 
DELETING PREVIOUS VERSIONS OF RMT.................................................................................... 1 
INSTALLING RMT ON WINDOWS/WINDOWS XP ......................................................................... 1 
INSTALLING RMT ON LINUX/UNIX ............................................................................................. 2 
UPDATING RMT SOFTWARE........................................................................................................ 3 
LOGGING ONTO RMT................................................................................................................... 3 
CLOSE RMT ................................................................................................................................. 3 
SYSTEM INFORMATION ................................................................................................................ 4 

RMT Server Information .......................................................................................................... 4 
Log Files .................................................................................................................................. 5 
About the Software ................................................................................................................... 6 

VIEW CHART DATES .................................................................................................................... 6 
DATABASE SUMMARY ................................................................................................................. 7 

CDR Tool Database Summary ................................................................................................. 7 
NFDC Database Summary....................................................................................................... 8 
Playbook Tool Database Summary .......................................................................................... 8 
Ad Hoc Reroutes Database Summary ...................................................................................... 9 

ONLINE HELP ............................................................................................................................... 9 
THE RMT DISPLAY.................................................................................................................. 11 

RMT FONTS ............................................................................................................................... 11 
ARRANGING WINDOWS IN RMT................................................................................................ 11 

TabFrame Display Layout ..................................................................................................... 11 
Tab Display Layout ................................................................................................................ 12 

RESIZING WINDOWS IN RMT..................................................................................................... 12 
Minimize................................................................................................................................. 12 
Maximize ................................................................................................................................ 13 
Custom Size ............................................................................................................................ 13 

SAVING THE RMT DISPLAY....................................................................................................... 13 
PERFORM A SEARCH ............................................................................................................. 15 

CHOOSE A TOOL......................................................................................................................... 15 
Searching the Operational or Staging Databases.................................................................. 15 
Searching in the Playbook Tool ............................................................................................. 16 



ii 

Searching in the NFDC Tool.................................................................................................. 17 
Searching in the Ad Hoc Reroutes Tool ................................................................................. 17 

ENTER SEARCH PARAMETERS ................................................................................................... 18 
Query Fields........................................................................................................................... 19 

Query Fields in the CDR Tool............................................................................................ 19 
Query Fields in the Playbook Tool..................................................................................... 21 
Query Fields in the NFDC Tool ......................................................................................... 22 

Preferred Routes Database .............................................................................................. 22 
Location Identifier Database........................................................................................... 23 
Airway Intersections Database ....................................................................................... 23 
Fixes Database ................................................................................................................ 24 
Airways Database ........................................................................................................... 24 
Navaids Database............................................................................................................ 24 
Airports Database............................................................................................................ 25 
Departure Procedures Database ...................................................................................... 25 
Standard Terminal Arrival Routes Database .................................................................. 25 

Query Fields in the Ad Hoc Reroutes Tool ........................................................................ 26 
WILDCARD CHARACTERS .......................................................................................................... 28 

Using the Asterisk as a Wildcard ........................................................................................... 28 
Using the Question Mark as a Wildcard................................................................................ 31 

“AND”, “OR” AND “NOT” LOGICAL OPERATORS ...................................................................... 31 
Use "Or" to Include Multiple Parameters in a Search .......................................................... 31 
Use "And" to Combine Multiple Parameters ......................................................................... 32 
Use "Not" to Exclude Routes.................................................................................................. 34 

CREATE AN ALIAS FOR A GROUP OF AIRPORTS OR ROUTE ELEMENTS ..................................... 36 
RUN THE SEARCH....................................................................................................................... 37 
CLEAR YOUR SEARCH ............................................................................................................... 37 
CANCEL YOUR SEARCH ............................................................................................................. 37 

VIEW SEARCH RESULTS ....................................................................................................... 39 
THE QUERY RESULTS TABLE..................................................................................................... 39 

Query Results in the CDR Tool .............................................................................................. 39 
Query Results in the Playbook Tool....................................................................................... 40 
Query Results in the NFDC Tool ........................................................................................... 41 

Query Results for Preferred Routes.................................................................................... 41 
Query Results for Location IDs.......................................................................................... 42 
Query Results for Airway Intersections ............................................................................. 42 
Query Results for Fixes ...................................................................................................... 42 
Query Results for Airways ................................................................................................. 42 
Query Results for Navaids.................................................................................................. 43 
Query Results for Airports ................................................................................................. 43 
Query Results for Departure Procedures ............................................................................ 43 
Query Results for Standard Terminal Arrival Routes ........................................................ 44 

Query Results in the Ad Hoc Reroutes Tool........................................................................... 44 
CUSTOMIZE THE QUERY RESULTS TABLE ................................................................................. 45 

Sort Records ........................................................................................................................... 45 
Change Column Order ........................................................................................................... 45 
Resize Columns ...................................................................................................................... 45 
Eliminate and Add Columns................................................................................................... 46 
Save Query Results Settings ................................................................................................... 46 

EXPORT QUERY RESULTS .......................................................................................................... 46 



  iii 

Selecting Records in the Query Results Table........................................................................ 47 
Send Query Results to the RMT Map ..................................................................................... 47 
Save Search Results................................................................................................................ 47 
Copy Search Results............................................................................................................... 47 
Print Search Results ............................................................................................................... 48 

COPY ROUTE STRINGS ............................................................................................................... 48 
REPORTS .................................................................................................................................... 49 

CDR TOOL REPORTS.................................................................................................................. 49 
Changes for Next Cycle Report.............................................................................................. 49 
Traversed Center Changes Report......................................................................................... 51 
Route Code Changes Report .................................................................................................. 53 
Warnings Report .................................................................................................................... 54 

PLAYBOOK CHANGES FOR NEXT CYCLE REPORT ..................................................................... 57 
AD HOC WARNINGS REPORT..................................................................................................... 58 

THE RMT MAP .......................................................................................................................... 59 
VIEW QUERY RESULTS ON THE MAP ......................................................................................... 59 

Remove Routes from the Map................................................................................................. 59 
Remove NAS Elements from the Map..................................................................................... 59 

VIEW PLAYBOOK PLAYS ON THE MAP....................................................................................... 60 
Remove Plays from the Map................................................................................................... 62 

MAP CUSTOMIZATION OPTIONS ................................................................................................ 62 
Map Display Options ............................................................................................................. 62 

Color and Label Preview Section ....................................................................................... 63 
Additional Layer Properties................................................................................................ 63 
ROG Map Layer ................................................................................................................. 64 
Display Latitude/Longitude Grid........................................................................................ 64 
Display Range Rings .......................................................................................................... 65 

Save Your Settings.................................................................................................................. 66 
Displaying Overlays............................................................................................................... 66 

Choosing Overlays (Layers) Using Display Options ......................................................... 67 
Using Show/Hide Overlays ................................................................................................ 68 
Filtering Overlays............................................................................................................... 68 
Display Single Overlay Elements....................................................................................... 70 
Display Miscellaneous Routes............................................................................................ 71 
Using Quick Keys............................................................................................................... 72 

Zooming In and Out on the RMT Map ................................................................................... 73 
SCROLLING ON THE MAP ........................................................................................................... 74 
CLEAR THE MAP ........................................................................................................................ 74 
RESET THE MAP ......................................................................................................................... 74 
PRINT THE MAP.......................................................................................................................... 74 
SAVE THE MAP........................................................................................................................... 74 

ROUTE OPTIONS GENERATION.......................................................................................... 75 
MAIN ROG TOOL WINDOW....................................................................................................... 75 

ROG Tool Buttons .................................................................................................................. 76 
FCA/Query Summary ............................................................................................................. 76 
Grouping Results Table.......................................................................................................... 78 
Grouping Summary ................................................................................................................ 78 
Matches Summary .................................................................................................................. 78 



iv 

ROG MAPPING CAPABILITIES.................................................................................................... 79 
FEA/FCA Map Settings.......................................................................................................... 79 
Flight List Map Settings ......................................................................................................... 79 

LOADING THE FEA/FCA DEFINITION AND FLIGHT LIST ........................................................... 80 
Using the Select ETMS FEA/Flight Info Window .................................................................. 80 

FINDING AND FILTERING REROUTE OPTIONS ............................................................................ 81 
Using the Find Options Window ............................................................................................ 82 

Available Route Types ....................................................................................................... 82 
Route Options Filters.......................................................................................................... 82 

Areas to Avoid/Go Through ........................................................................................... 83 
Run the Reroute Option Search.............................................................................................. 85 

GROUPING FLIGHTS ................................................................................................................... 85 
Using the Group Flights Window........................................................................................... 85 

ASSIGNING REROUTES ............................................................................................................... 87 
Using the Assign Reroutes Window ....................................................................................... 87 

TRACKING FLIGHT/REROUTE SELECTIONS USING FLIGHT SUMMARY...................................... 94 
Using the Flight Summary Window ....................................................................................... 94 
Submitting Early Intent Messages.......................................................................................... 95 

CREATING ROUTE GUIDANCE USING THE REROUTE PLANNER................................................. 97 
Using the Reroute Planner Window....................................................................................... 97 

CHANGE ROUTE RECORDS................................................................................................ 103 
VIEW ROUTE RECORD MODIFICATIONS .................................................................................. 103 

View the Local Modification History ................................................................................... 103 
CDR Local Modification History Records ....................................................................... 104 
Playbook Local Modification History .............................................................................. 104 

View Global Modifications................................................................................................... 105 
Customize the Modifications Section ................................................................................... 106 

Sort Records ..................................................................................................................... 106 
Change Column Order...................................................................................................... 106 
Resize Columns ................................................................................................................ 106 

GLOBAL MODIFICATIONS ........................................................................................................ 106 
Create a Global Modifications Entry................................................................................... 106 
Recalculate/Refresh the Global Modifications Table .......................................................... 108 
Update a Global Modification Entry ................................................................................... 109 
Delete a Global Modification Entry..................................................................................... 109 
Create a New Global Modification Entry ............................................................................ 109 
Perform a Global Modification............................................................................................ 110 

UPDATE CDR ROUTES............................................................................................................. 110 
Create New CDR Routes ...................................................................................................... 110 

Enter Route Parameters .................................................................................................... 111 
Check for Errors ............................................................................................................... 112 
Complete the New Route Record ..................................................................................... 112 

Modify Existing Routes ........................................................................................................ 113 
Check for Errors ............................................................................................................... 113 
Complete the Modification............................................................................................... 113 

Delete CDR Routes .............................................................................................................. 114 
Reinstate a Deleted Route .................................................................................................... 114 

UPDATE CDR ROUTES FROM A FILE........................................................................................ 115 
Import an ASCII File............................................................................................................ 115 

CDR Required ASCII Columns ....................................................................................... 115 



  v 

Define Loading Options ................................................................................................... 116 
Import a Stereo File ............................................................................................................. 117 

Obtaining a Stereo File from the Host.............................................................................. 117 
Updating a Stereo File Prior to Loading........................................................................... 118 
Import a Stereo File into RMT ......................................................................................... 119 
Define Loading Options ................................................................................................... 119 
Importing Stereo File Back Into Host............................................................................... 119 

Error Checking Your Imported File..................................................................................... 120 
Files Created During the Error Checking Process ............................................................ 120 

Edit Problem Routes ............................................................................................................ 121 
Fixing CDR Route Records.............................................................................................. 122 
Ignore Warnings ............................................................................................................... 123 
Reject Routes.................................................................................................................... 124 

File Creation and Naming ................................................................................................... 124 
CDR DATABASE LOADING REPORT ........................................................................................ 125 
UPDATE ADDITIONAL CDR INFORMATION ............................................................................. 126 

Load Additional Information from the Route Editor Window.............................................. 126 
Create a Comma-Delimited Loading File............................................................................ 127 

CDR ASSOCIATED PLAY INFORMATION.................................................................................. 127 
Load Associated Plays from a File ...................................................................................... 127 

UPDATE CDR COORDINATION REQUIRED FLAG OR NAVIGATION EQUIPMENT DESIGNATOR 129 
Load Coordination Required Flag from a File .................................................................... 129 
Load Navigation Equipment Designator from a File........................................................... 130 

UPDATE PLAYBOOK PLAYS ..................................................................................................... 131 
Create a New Play ............................................................................................................... 131 

Enter Play Parameters....................................................................................................... 132 
Draw an Impacted Area on the RMT Map ....................................................................... 133 
Update Play Segments ...................................................................................................... 134 
Complete the New Play .................................................................................................... 136 

Modify Existing Plays .......................................................................................................... 136 
Check for Errors ............................................................................................................... 137 
Complete the Modification............................................................................................... 138 

Delete a Play ........................................................................................................................ 138 
UPDATE AD HOC REROUTES ................................................................................................... 139 

Create New Ad Hoc Reroutes............................................................................................... 139 
Enter Route Parameters .................................................................................................... 139 
Check for Errors ............................................................................................................... 140 
Complete the New Route Record ..................................................................................... 141 

Modify Existing Routes ........................................................................................................ 141 
Check for Errors ............................................................................................................... 141 
Complete the Modification............................................................................................... 142 

Delete Ad Hoc Reroutes ....................................................................................................... 142 
APPENDING AD HOC REROUTES FROM A FILE......................................................................... 143 

Import an ASCII File............................................................................................................ 143 
Ad Hoc Required ASCII Columns ................................................................................... 143 

Error Checking Your Imported File..................................................................................... 144 
Files Created During the Error Checking Process ............................................................ 144 

Load Good Routes................................................................................................................ 145 
Edit Problem Routes ............................................................................................................ 146 

Fixing Ad Hoc Reroute Records ...................................................................................... 147 
Ignore Warnings ............................................................................................................... 147 



vi 

Reject Routes.................................................................................................................... 147 
Database Loading Report .................................................................................................... 148 

ATCSCC ADMINISTRATOR FUNCTIONS ........................................................................ 149 
SEND A BROADCAST MESSAGE ............................................................................................... 149 
CDR AND PLAYBOOK TOOL ADMINISTRATOR FUNCTIONS .................................................... 149 

Change Staging Verification ................................................................................................ 149 
CDR TOOL ADMINISTRATOR FUNCTIONS ............................................................................... 150 

Refresh Database Records ................................................................................................... 150 
Save Database Records........................................................................................................ 150 
Delete Database Records ..................................................................................................... 151 
Reload Database Records .................................................................................................... 152 
Copy Staging Databases to Operational Databases............................................................ 153 

Automatically Copy the Databases................................................................................... 153 
Manually Copy the Databases .......................................................................................... 153 

NFDC TOOL ADMINISTRATOR FUNCTIONS............................................................................. 154 
Update NFDC Reference Tables.......................................................................................... 154 

PLAYBOOK TOOL ADMINISTRATOR FUNCTIONS ..................................................................... 155 
Manage Playbook Categories .............................................................................................. 155 

ROG TOOL ADMINISTRATOR FUNCTIONS ............................................................................... 156 
Change Early Intent Status .................................................................................................. 156 

AD HOC REROUTES TOOL ADMINISTRATOR FUNCTIONS........................................................ 156 
Refresh Database Records ................................................................................................... 157 
Save Database Records........................................................................................................ 157 
Delete Database Records ..................................................................................................... 157 
Reload Database Records .................................................................................................... 157 

APPENDIX ................................................................................................................................ 159 
HARDWARE REQUIREMENTS ................................................................................................... 159 
RMT CLIENT CONFIGURATION FILES...................................................................................... 159 

RMT Aliases ......................................................................................................................... 159 
ERROR AND WARNING MESSAGES .......................................................................................... 160 

Warning Messages ............................................................................................................... 160 
Error Messages .................................................................................................................... 161 

INDEX ........................................................................................................................................ 163 
 



  vii 

                                                             TABLE OF FIGURES 

Figure 1: RMT Login Window........................................................................................................ 3 
Figure 2: RMT Server Message Window........................................................................................ 4 
Figure 3: Log File Viewer ............................................................................................................... 5 
Figure 4: Help > About RMT.......................................................................................................... 6 
Figure 5: Show Chart Dates ............................................................................................................ 7 
Figure 6: CDR Staging Database Summary Window ..................................................................... 7 
Figure 7: NFDC Database Summary Window................................................................................ 8 
Figure 8: Playbook Operational Database Summary Window........................................................ 8 
Figure 9: Ad Hoc Reroutes Database Summary Window............................................................... 9 
Figure 10: Online Help Display ...................................................................................................... 9 
Figure 11: TabFrame Display Layout ........................................................................................... 11 
Figure 12: Tab Display Layout...................................................................................................... 12 
Figure 13: Minimize RMT (Windows) ......................................................................................... 12 
Figure 14: Maximize RMT (Windows)......................................................................................... 13 
Figure 15: Tool Windows are Outlined in Red When Searching in the Staging Databases.......... 15 
Figure 16: Playbook Top-Level Query Results Table................................................................... 16 
Figure 17: View Play Window – Detailed Segment-Level Query Results ................................... 16 
Figure 18: NFDC Table Selection................................................................................................. 17 
Figure 19: Ad Hoc Reroutes Tool ................................................................................................. 18 
Figure 20: CDR Tool Query Fields ............................................................................................... 19 
Figure 21: PrefRoutes Query Fields .............................................................................................. 22 
Figure 22: Location Identifier Query Fields.................................................................................. 23 
Figure 23: Airway Intersections Query Fields .............................................................................. 23 
Figure 24: Fixes Query Fields ....................................................................................................... 24 
Figure 25: Airways Query Fields .................................................................................................. 24 
Figure 26: Navaids Query Fields................................................................................................... 25 
Figure 27: Airports Query Fields .................................................................................................. 25 
Figure 28: DPs Query Fields ......................................................................................................... 25 
Figure 29: STARs Query Fields .................................................................................................... 26 
Figure 30: Ad Hoc Reroutes Tool Query Fields............................................................................ 26 
Figure 31: Search Using O* in the NFDC PrefRoutes Destination/Arr Center Field ................... 29 
Figure 32: Search Using "* WISKE *" in the CDR Route String Field........................................ 29 
Figure 33: Search Using * in the Playbook Route String Field..................................................... 30 
Figure 34: Search Using * in the NFDC PrefRoutes Aircraft Types Field ................................... 30 
Figure 35: Search Using "ORDBOS??" in the Route Code Field ................................................. 31 
Figure 36: Search Using the "Or" Logic in the Origin/Dep Center Field ..................................... 32 
Figure 37: A Search with “PETTY” in the Route String .............................................................. 32 
Figure 38: A Search with "PETTY & MKG" in the Route String ................................................ 33 
Figure 39: Search Using “PETTY & MKE & CVG” in the Route String .................................... 33 
Figure 40: Warning When Using "&" Instead of “|” ..................................................................... 34 
Figure 41: Search Using the "Not" Logic in the Route Type Field............................................... 35 
Figure 42: Search for Routes in Staging Database to be Copied to Operational........................... 35 
Figure 43: Example Using NYMetro in the Origin Field.............................................................. 36 
Figure 44: Query Results in the CDR Tool ................................................................................... 39 
Figure 45: Moving the Dest Column Left ..................................................................................... 45 
Figure 46: Resizing Columns ........................................................................................................ 45 
Figure 47: Playbook Show/Hide Columns Options ...................................................................... 46 
Figure 48: Print Window for Windows XP Users ......................................................................... 48 
Figure 49: Changes for Next Cycle Report Window .................................................................... 49 



viii 

Figure 50: CDR Changes for Next Cycle Report .......................................................................... 50 
Figure 51: Traversed Center Changes for Next Cycle Report Window........................................ 51 
Figure 52: CDR Traversed Changes for Next Cycle Report ......................................................... 52 
Figure 53: Route Code Changes Report Window ......................................................................... 53 
Figure 54: CDR Route Code Changes Report............................................................................... 53 
Figure 55: Warnings Report Window ........................................................................................... 54 
Figure 56: Customize Warnings Report Window ......................................................................... 54 
Figure 57: Removed Warning Appears in Warnings in Database Section.................................... 55 
Figure 58: CDR Warnings Report ................................................................................................. 56 
Figure 59: Playbook Changes for Next Cycle Report ................................................................... 57 
Figure 60: Ad Hoc Warning Report .............................................................................................. 58 
Figure 61: Multiple Origin Airports in Playbook Route Segments............................................... 61 
Figure 62: Playbook Route Segments with Multiple Origin Airports on the RMT Map .............. 61 
Figure 63: Display Options Window............................................................................................. 62 
Figure 64: Latitude/Longitude Grid Settings ................................................................................ 64 
Figure 65: Add Range Rings Window .......................................................................................... 65 
Figure 66: Adding Range Rings from Display Options ................................................................ 66 
Figure 67: Checkboxes in the Display Options Window .............................................................. 67 
Figure 68: Show/Hide Map Overlays............................................................................................ 68 
Figure 69: Show/Hide Overlay Filters .......................................................................................... 69 
Figure 70: Show Overlay Elements Window................................................................................ 70 
Figure 71: Overlay Elements Displayed on the Map .................................................................... 71 
Figure 72: Miscellaneous Route String ......................................................................................... 71 
Figure 73: Show/Hide Quick Key Overlays Dialog...................................................................... 72 
Figure 74: Zoom-in View.............................................................................................................. 73 
Figure 75: ROG Main Window..................................................................................................... 76 
Figure 76: FEA/FCA Advisory Window ...................................................................................... 78 
Figure 77: ROG Map Settings Window (Default Settings)........................................................... 79 
Figure 78: Select ETMS FEA/FCA Info Window ........................................................................ 81 
Figure 79: Find Options Window.................................................................................................. 82 
Figure 80: Find Options Avoiding or Going through AFP FCAs ................................................. 83 
Figure 81: Areas to Avoid/Go Through Window.......................................................................... 84 
Figure 82:  Saved Areas to Avoid/Go Through............................................................................. 84 
Figure 83: Area Editor................................................................................................................... 85 
Figure 84: Group Flights Window (Default Settings) ................................................................... 86 
Figure 85: Group Flights Window with Three Grouping Criteria Selected .................................. 87 
Figure 86: Assign Reroutes Window with Reroute Options for PHX-EWR Flights .................... 88 
Figure 87: Assign Reroutes Window with Reroute Selected ........................................................ 92 
Figure 88: Reroute Editor.............................................................................................................. 93 
Figure 89: Flight Summary Window............................................................................................. 94 
Figure 90: EI Summary Dialog ..................................................................................................... 96 
Figure 91: Reroute Planner............................................................................................................ 98 
Figure 92: City Pairs with No Matches Found.............................................................................. 99 
Figure 93: City Pairs with CDR Matches Only............................................................................. 99 
Figure 94:  Show Plays from the Reroute Planner ...................................................................... 100 
Figure 95: Reroute Planner with Reroute Plan............................................................................ 101 
Figure 96: CDR Local Modifications Tab................................................................................... 104 
Figure 97: Global Modifications Tab .......................................................................................... 105 
Figure 98: Global Modifications Window - ATCSCC Administrator View............................... 107 
Figure 99: Global Modifications Window - Center Administrator View.................................... 107 
Figure 100: Recalculate/Refresh Global Modification Information............................................ 108 



  ix 

Figure 101: Global Modification Editor...................................................................................... 109 
Figure 102: Delete Global Modification Warning Message........................................................ 109 
Figure 103: Create New Record - CDR Route Editor Window .................................................. 110 
Figure 104: Modify an Existing Record – CDR Route Editor Window...................................... 113 
Figure 105: Deleting Multiple Routes......................................................................................... 114 
Figure 106: Delete Routes ........................................................................................................... 114 
Figure 107: Load DB From ASCII File ...................................................................................... 116 
Figure 108: Transfer file from Host to PC or Disk...................................................................... 118 
Figure 109: Using Word Processor Search and Replace Function to Update Stereo File........... 118 
Figure 110: Load DB From Stereo File Window........................................................................ 119 
Figure 111: File Statistics After First Phase................................................................................ 121 
Figure 112: CDR Route Editor.................................................................................................... 122 
Figure 113: Edited Route............................................................................................................. 123 
Figure 114: CDR Database Loading Report................................................................................ 125 
Figure 115: Update Additional Information from the CDR Route Editor Window.................... 126 
Figure 116: Load Associated Play Information from File........................................................... 127 
Figure 117: Associated Plays Loading Report ............................................................................ 128 
Figure 118: Associated Play Search ............................................................................................ 128 
Figure 119: Load Coordination Required Information from File................................................ 129 
Figure 120: Load NavEqp Information from File ....................................................................... 130 
Figure 121: Create New Play Window........................................................................................ 131 
Figure 122: Create New Play - Play Editor Window .................................................................. 131 
Figure 123: Create a New Play from an Existing Play................................................................ 132 
Figure 124: Impacted Area Window ........................................................................................... 134 
Figure 125: Origin Segment Editor ............................................................................................. 135 
Figure 126: Flight Filters Edit Window ...................................................................................... 135 
Figure 127: Modify an Existing Play - Play Editor Window ...................................................... 137 
Figure 128: Delete Play Window ................................................................................................ 138 
Figure 129: Create New Record – Ad Hoc Reroute Editor Window .......................................... 139 
Figure 130: Modify an Existing Record – Ad Hoc Reroute Editor Window .............................. 141 
Figure 131: Deleting Ad Hoc Reroutes ....................................................................................... 142 
Figure 132: Delete Ad Hoc Reroutes .......................................................................................... 143 
Figure 133: Load Ad Hoc Reroutes From ASCII File ................................................................ 144 
Figure 134: File Statistics After First Pass of Import .................................................................. 145 
Figure 135: Ad Hoc Reroute Editor ............................................................................................ 146 
Figure 136: Ad Hoc Reroutes Database Loading Report ............................................................ 148 
Figure 137: Broadcast a Message................................................................................................ 149 
Figure 138: Changing the Status of the CDR Staging Database ................................................. 150 
Figure 139: Save CDR Database Window .................................................................................. 151 
Figure 140: Delete CDR Staging Database Window .................................................................. 151 
Figure 141: Reload CDR Staging Database Window ................................................................. 152 
Figure 142: Copy Staging to Operational Database .................................................................... 153 
Figure 143: Update NFDC Tables............................................................................................... 154 
Figure 144: Playbook Manage Categories Window.................................................................... 155 
Figure 145: Create Playbook Category Window......................................................................... 155 
Figure 146: Playbook Rename Category Window...................................................................... 156 
Figure 147: Change Sub-Carrier EI Submission Status Window................................................ 156 
 





  1 

Introduction 
 

What is RMT? 
Metron Aviation, Inc. developed the Route Management Tool (RMT) to facilitate increased 
information exchange between Air Route Traffic Control Centers (ARTCC), the Air Traffic 
Control System Command Center (ATCSCC), and the airline user community.  RMT is a 
database query tool that allows users to view the centralized Coded Departure Routes (CDR) and 
National Playbook databases, related reference tables from the National Flight Data Center 
(NFDC) and user-defined ad hoc reroutes.   
 
RMT is available in two formats: web RMT and RMT version 1.50. 
 
Web RMT 
Web RMT, as the name implies, is a web-based query tool that allows users to view the 
Operational CDR databases, as well as preferred route (PrefRoute), location identifier (LocID) 
and airway intersection (AwyIntxn) information.  Web RMT is available through the FAA Air 
Traffic Control System Command Center's web site: http://www.fly.faa.gov.  Anyone can access 
the web RMT program in this way to search the databases and download the information to a file. 
 
Note that the National Playbook Routes are also available through the Operational Information 
System (OIS) on the ATCSCC web site.   
 
RMT Version 1.50 
Metron Aviation, Inc. greatly enhanced the web version of RMT to create the RMT client (RMT 
version 1.50).  RMT 1.50 is a software application that can be installed on most computers 
(Windows, Linux and UNIX versions are currently supported).  With RMT version 1.50, you can 
search for, modify and view coded departure routes, Playbook Plays, and nine reference tables 
from the NFDC.  A new feature that was introduced in RMT 1.40 is Route Options Generation 
(ROG).  The ROG flight-centric view allows you to find pre-coordinated reroute options (e.g., 
CDRs and Plays) for flights that avoid a constraint (Flow Evaluation Area (FEA) or Flow 
Constrained Area (FCA)).  The ROG constraint-centric view allows you to characterize the 
constraint and provides decision support for traffic managers for developing route guidance and 
reroute plans using Playbook Plays.  The ROG Tool was initially developed by the CDM Future 
Concept for Flow Management Sub-Team (FCT) as part of the Integrated Collaborative 
Rerouting (ICR) Concept.  RMT 1.50 allows customers to submit Early Intent (EI) messages for 
their flights to the Enhanced Traffic Management System (ETMS).  RMT 1.50 also allows data 
exchange between the ROG Reroute Planner and the Traffic Situation Display (TSD) Create 
Reroute Dialog. 
 
RMT contains six Tool windows for its users: 
 
(1) CDR Tool 
  
(2) Playbook Tool 
 
(3) NFDC Tool 
 
(4) Route Options Generation (ROG) Tool 
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(5) Ad Hoc Reroutes (AD HOC) Tool 
 
(6) RMT Map 
 
The CDR Tool 
The CDR Tool is a query window that allows users to access the coded departure routes (CDR) 
database.  Coded departure routes are alternate air traffic routings and refined coordination 
procedures designed to allow flights to depart as efficiently as possible when severe weather or 
air traffic congestion prevents using normal routes.   
 
The CDR Operational database contains CDRs that are valid for the current 56-day chart cycle.  
CDR administrators at each ARTCC are responsible for updating the CDR Staging database with 
the coded departure routes that originate from their center.  The ATCSCC administrator can 
modify any coded departure route in this database if necessary.  Airline users have view-only 
access to the staging database; they can view and download the routes for the next update in time 
to publish them internally.  On the published chart date, the staging database becomes the 
operational database for the next 56-day cycle.   
 
The Playbook Tool 
The Playbook Tool is a query window that allows users to access the National Playbook database.  
The National Playbook is a collection of Severe Weather Avoidance Plan (SWAP) routes.    
These routes are organized into groupings called ‘Plays’.  National Playbook routes are modified 
by the Playbook administrator at the ATCSCC in the Playbook staging database.  The Playbook 
database is updated every 56 days on the same cycle as the CDRs. 
 
The NFDC Tool 
The NFDC Tool is a query window that allows users to access nine NFDC reference tables 
including preferred routes, location identifiers, airway intersections, fixes, navaids, airways, 
airports, Departure Procedures (DPs), and Standard Terminal Arrival Procedures (STARs).  The 
NFDC table information in the database is updated every 56 days with information provided by 
the NFDC.  The NFDC Tool is provided strictly for your reference; information found in the 
NFDC Tool cannot be modified using RMT.  
 
The Route Options Generation (ROG) Tool 
ROG allows users to view information from both a flight-specific and a broader system-level 
constraint perspective.  The ROG flight-centric workspace provides users with the capability to 
identify pre-coordinated reroute options for specific flights that avoid an FEA or FCA and to send 
out Early Intent (EI) messages to ETMS for flights that do not have a filed flight plan.  The 
constraint-centric workspace allows users to characterize the constraint by providing enhanced 
flight list grouping and mapping capabilities.  ROG also provides decision-support to traffic 
managers through the Reroute Planner including the ability to exchange information with the 
TSD Create Reroute dialog. 
 
The Ad Hoc Reroutes Tool 
The Ad Hoc Reroutes Tool is a query window that allows users to access the ad hoc reroutes 
database.  Users (both FAA and Customers) can create and edit ad hoc reroutes in the database.  
Note that users can only view the ad hoc reroutes that they have created.  These routes can be 
used with ROG to find reroute options that avoid a constrained area.   
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The RMT Map 
The RMT Map displays routes and other information queried in the five RMT Tools listed above.  
The RMT Map contains a variety of optional overlays and customization tools for users. 
 

Text Conventions 
This document uses several conventions that you should be aware of while reading.  The 
following table explains the most common abbreviations and symbols used in this document. 
 
Abbreviations 
AD HOC Tool The specific Tool within RMT that searches the ad hoc reroutes 

database. 
AFP Airspace Flow Program 
AwyIntxn Airway Intersection 
ARTCC A United States Air Route Traffic Control Center.  Each ARTCC is 

responsible for controlling air traffic within a specific section of 
airspace.  There are 22 U.S. ARTCCs. 

ATCSCC The Federal Aviation Administration's Air Traffic Control System 
Command Center located in Herndon, Virginia. 

CCSD Common Constraint Situation Display 
CDR Database This refers to the centralized coded departure routes database (staging or 

operational).  Users search for coded departure routes through the RMT 
CDR Tool.  The RMT Map uses the CDR Database to display coded 
departure routes.   

CDR Tool The specific Tool within RMT that searches the coded departure routes 
database. 

CDR Coded Departure Route 
CoordReq Coordination Required Flag 
DP Departure Procedure 
EI Early Intent 
ETMS Enhanced Traffic Management System 
FAA Federal Aviation Administration 
FCA Flow Constrained Area 
FCT Future Concepts of Flow Management Sub-Team 
FEA Flow Evaluation Area 
ICR Integrated Collaborative Rerouting 
LocID Location Identifier 
NavEqp Navigation Equipment Designator 
NFDC Tables The set of database tables provided by the NFDC and used by the RMT 

NFDC Tool as a reference utility for its users. 
NFDC Tool The specific Tool within RMT that searches the NFDC reference tables.  

The NFDC tables currently available include preferred routes, location 
identifiers airway intersections, fixes, airways, navaids, airports, DPs, 
and STARs. 

NFDC National Flight Data Center 
OIS Operational Information System 
Playbook Database This refers to the centralized National Playbook database.  Users search 

for National Playbook routes through the RMT Playbook Tool.  The 
RMT Map uses the Playbook Database to display Playbook routes. 
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Playbook Tool The specific Tool within RMT that searches the Playbook database.   
Plays National Playbook Plays 
PrefRoute Preferred Route 
RMT Metron Aviation, Inc.'s Route Management Tool software, which 

contains the CDR Tool, Playbook Tool, NFDC Tool, ROG Tool, AD 
HOC Tool and the RMT Map.   

RMT Database This refers to the collection of databases available for query through the 
RMT Tool.  Databases include CDR, NFDC and Ad Hoc Reroutes 
information.  The Playbook database is maintained separately, but can be 
accessed through the RMT Playbook Tool.    

ROG Route Options Generation 
ROG Tool The specific Tool within RMT that finds route options around 

constrained areas. 
RMT Map The map Tool within RMT that displays various types of routing data on 

a U.S. map. 
STAR Standard Terminal Arrival Procedure 
SUA Special Use Airspace 
SWAP Severe Weather Avoidance Plan  
TSD Traffic Situation Display 
UserFile User File Flag (note that this field has been renamed Coordination 

Required or CoordReq) 
Symbols Used 
Ctrl The Ctrl (control) key on your computer keyboard 
+ When the '+' symbol appears, you need to perform two actions at once to 

complete a function.  For example, Shift + S indicates that you should 
press the Shift key and the S on your computer keyboard to perform a 
function. 

> The > is used to indicate a menu option.  For example, File > Print 
indicates that Print is an option under the RMT File menu. 

Ctrl-click Press the Ctrl (control) key on your keyboard while clicking on an item 
with your mouse. 

Shift-click Press the Shift key on your keyboard while clicking on an item with your 
mouse. 

& "And." An operator used in searches to include results with more than 
one parameter. 

| "Or." An operator used in searches to include results with more than one 
parameter. 

! "Not." An operator used in searches to exclude results with certain 
parameters. 

* Wildcard character replacing multiple characters in a search parameter. 
? Wildcard character replacing one character in a search parameter. 
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Technical Support 
To inquire about problems or information regarding RMT, contact: 
 
RMT Support  
(703) 234-0769 phone 
(703) 456-0132 fax 
rmt_support@metronaviation.com 
 
Metron Aviation, Inc. 
131 Elden Street, Suite 200 
Herndon, Virginia 20170 
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Getting Started 
At the time of installation, RMT users should receive a user name and password from Metron 
Aviation technical support.  At present, there are eight different types of RMT users with varying 
permissions: 
 

• The ATCSCC Administrator is the overall RMT administrator.  The administrator is 
permitted to modify the CDR and Playbook operational and staging databases at any 
time.  The administrator enters global modification information and loads the NFDC 
tables every 56 days on the chart date. 

• ARTCC Administrators modify the ARTCCs routes in the staging databases during the 
Active Period (CDRs from their center only). 

• The Playbook Administrator is permitted to modify the Playbook Plays in the Playbook 
staging database. 

• ATA-100 verifier users assist the ATCSCC administrator with CDR verification during 
the 5-day Verification Period. 

• ATCSCC users have view-only access to all routes and modifications in the staging and 
operational databases. 

• ARTCC users have view-only access to all routes and modifications in the staging and 
operational databases. 

• Airline users have view-only access to both the staging and operational databases. 
• Internet users have view-only access to the operational databases (RMT web version). 

 

Deleting Previous Versions of RMT 
Prior to installing RMT version 1.50, you should delete any instances of RMT that are currently 
on your machine.  An uninstall program was included as a part of the RMT 1.40 installation 
packages.  Navigate to the main RMT directory (by default, C:\Program Files\RMT1.40.  Double-
click on the uninstall.exe file.  This will remove any references in the registry and the RMT 
listing in the Start Panel.  Note that any files created after the initial installation, e.g. log files, will 
remain in the RMT 1.40 directory.  Remove these files by deleting the RMT 1.40 directory.  
Remember that if you have saved any query results or reports to the RMT directory, you should 
copy them to another directory at this time.   
 
Your local RMT 1.40 user configuration files should also be deleted.  The RMT 1.40 local 
configuration file is saved as rmt140_user_config.ini within the user home directory on 
Windows XP systems.  It is also called rmt140_user_config.ini in the home directory on UNIX 
systems. 
 
Another way to remove the program for Windows users is through the Control Panel – Add or 
Remove Programs option. 
 

Installing RMT on Windows/Windows XP 
Users can install RMT from the secure CDM Products Distribution download page on the 
Internet.  To install RMT from the Internet, contact RMT Support for the site address, username, 
and password.  
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Once connected to the RMT download site, enter the provided username and password to begin 
the RMT setup.  Airline users and ARTCC users each have their own installation packages.  The 
only difference is with the connections to the RMT server.   
 
1. Download the appropriate setup file to a temporary directory or the desktop.  Airlines should 

download setup_RMT150_airline_windows.exe.  Centers should download 
setup_RMT150_center_windows.exe. 

2. In the temporary directory, double-click on the setup file to begin the installation process. 
3. Follow the setup instructions. 
4. The default installation directory is C:\Program Files\RMT1.50_Airline or C:\Program 

Files\RMT1.50_Center.  You can use the default setting or specify another directory. 
5. Depending on your user type, double-click either the RMT150_Client_airline.exe or 

RMT150_Client_center.exe file to start RMT. 
6. To create a shortcut on your desktop, right-click on the RMT150_Client_airline.exe or 

RMT150_Client_center.exe files and select Create Shortcut from the pop-up menu.  Then 
click and drag the shortcut to a location on your desktop.  Once the shortcut is created, you 
can right-click on the shortcut, go to Properties, and select Change Icon to use the icon 
provided in the RMT installation directory. 

 

Installing RMT on Linux/Unix 
Linux/Unix users can install RMT from the Internet.  To install RMT from the Internet, contact 
RMT Support for the site address, username, and password.  
 
Once connected to the RMT download site, enter the provided username and password to begin 
the installation process.  
 
 For Linux users: 

1. Download the appropriate setup file to a temporary directory.  Airlines should download 
setup_RMT150_airline_linux.sh.  Centers should download 
setup_RMT150_center_linux.sh.  

2. In the temporary directory, type ./setup_RMT150_airline_linux.sh or 
./setup_RMT150_center_linux.sh to begin the installation process. 

3. Follow the setup instructions.  
4. Change to the installation directory.  
5. Type ./RMT150_Client_airline or ./RMT150_Client_center to run the program.  

 
For Other Unix users: 

1. Download the appropriate setup file to a temporary directory.  Airlines should download 
setup_RMT150_airline_unix.sh.  Centers should download 
setup_RMT150_center_unix.sh.  

2. In the temporary directory, type ./setup_RMT150_airline_unix.sh or 
./setup_RMT150_center_unix.sh to begin the installation process. 

3. Follow the setup instructions.  
4. Change to the installation directory.  
5. Install the JRE into a directory called ‘jre’ inside the installation directory. 
6. Type ./RMT150_Client_airline or ./RMT150_Client_center to run the program.  
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Updating RMT Software 
As new data files and new versions of RMT are released, you will want to update the software to 
ensure that you have all the current files.  An auto update program is included in the RMT 
installation package.  If you log in to RMT after new files have been made available, a window 
will prompt you to update RMT.  We recommend that you complete the process at that time.  
Click Yes to start the processing or No to continue your session without updating.  Note that the 
overlays for the RMT Map are updated with the latest NFDC data every 56 days on the chart 
date.  You will be prompted to perform the auto update at that time.  While the auto update 
program is running, you should see a DOS window and a progress window that shows the 
number of files being downloaded.  When the processing has finished, you will get a message 
stating that your auto update has completed successfully. 
 
To manually run the auto update program, double-click on the autoupdate.bat program in the 
main RMT directory (This may be necessary for trouble-shooting purposes).   
 

Logging onto RMT 
Your user name and password determine the level of access to the information contained in the 
RMT database(s).  Please note that all user names and passwords are case-sensitive. 
 
Once you start RMT, the RMT 1.50 Login window appears.  In the login window, enter your 
user name and password.  To save your user name and password information between RMT 
sessions, click Save.  This will save your login information to your local configuration file so that 
you do not have to type in the information every time you log in to the system. 
 
Click the Reset button to return to a previously saved user name and password.  You can remove 
incorrect information typed into the user name and password fields by clicking Clear.   
 

 
Figure 1: RMT Login Window 

 
After you have entered your log-in information, click OK.  The RMT program display should 
appear on your screen.  To close the login screen without logging on to RMT, click Cancel. 
 

Close RMT 
To close the RMT program, select File > Quit, click the X button in the upper right corner of the 
main RMT program window (Windows/NT/UNIX platforms), or type Ctrl + Q.  Note that the X 
button in the upper right corner of the RMT Map (TabFrame display mode) also closes the 
application. 
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System Information 
You can view specific system information at any time during your RMT session.  For example, 
you can view log files of your session, database registration information, and the software 
version.  This information is provided for your reference and to aid you in troubleshooting 
software problems. 
 
RMT Server Information 
When you first open the RMT program, a message box appears with database registration and 
status information.  You can access this window at any time by selecting Help > Show Server 
Information (Figure 2).   
 

 
Figure 2: RMT Server Message Window 

The RMT Server Message window gives you status information about the RMT databases to 
which you are connected.  This information is updated every time you open the window.  RMT 
database information includes: 

 
• Database Availability – The current status of the RMT database.  If the message states 

"ALL Available," then your connection to the database should be up and running.  The 
databases are updated every 56 days on the chart date.  During the database upload, RMT 
indicates that the staging to operational copy is in progress or the NFDC database is 
being loaded.  If logged into the system, you should close RMT and resume the 
application after the completion of the chart date processing.   

• Current Date - The current date when you are logging in to RMT. 
• Current Period - The CDR and Playbook databases are updated according to the 56-day 

chart cycle.  Within the chart cycle, there are three different periods:  Active, Verification 
and Quiet.  See further explanation of the chart cycle in “View Chart Dates” on page 6. 

• Staging Database Status - Verification flags indicate whether the routes in the CDR and 
Playbook staging databases have been verified or not verified.  The flags are set by the 
RMT ATCSCC administrator after the CDR/Playbook validation processing has been 
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completed by the ATCSCC administrator and the NFDC.   Once routes are verified, they 
do not change and will be copied to the operational database on the next chart date. 

• Time Status, Sub-Carrier EI Submission Status, FEA/FCA File Status, Registered 
Users (FAA Admin Users Only) - Administrator users have additional sections in the 
RMT Server Message window that provides server status information, EI sub-carrier 
submission status, FEA/FCA and flight list file status and a list of RMT users that are 
currently logged on to the system.  

 
Log Files 
Log files are created in the RMT log directory every time you open the software.  As you work in 
RMT, information about the session is saved to your system in Log Files.  For example, log files 
contain database connection data and data about the RMT session start and end.  Viewing log 
files of your session can be especially useful when troubleshooting problems. 
 
To view your log files, select Help > View Log Files.  The Log File Viewer window opens.  The 
Log File Viewer is divided into two panes.  In the left pane, you can view all the available 
RMTClient log files.  In the right pane, you can view the contents of the file. 
 
In the left pane, double-click any folder to view the log files within that folder.  Clicking a log file 
will highlight the file so that you can perform an action on that file.  You can use shift-click or 
Ctrl-click to select multiple files. 
 

• To view the contents of the log file, click the Open button.  The log file appears in the 
right-hand pane of the Log File Viewer. 

• To delete a file, select the file(s) to be deleted.  Once you select the desired files, click the 
Delete button.   

 

 
Figure 3: Log File Viewer 

Use the Search field to look for specific words or phrases within the file.  This can aid in quick 
troubleshooting.  To search the log file, type in the text you are looking for in the text field to the 
right of the search button and click Search. 
 
To close the log file text window, click Close. 
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About the Software 
Use Help > About to view basic information about the RMT software, including the current 
version number and user name. 
 

 
Figure 4: Help > About RMT 

 

View Chart Dates 
CDRs and Playbook Plays are stored in two separate databases: the operational database and the 
staging database.  The operational database remains valid and unchanged for a 56-day cycle and 
is updated on the scheduled chart date. 
 
ARTCC administrators use the staging databases to make changes for the next cycle.  The staging 
database begins as a replica of the operational database, but changes as route records are updated.  
Every 56 days, the staging database is copied over by the ATCSCC administrator and becomes 
the operational database.   
 
Within the 56-day chart cycle, the staging databases go through 3 periods: Active, Verification, 
and Quiet.  The Active period lasts 21 days and is the time during which center administrators 
actively make changes to the CDRs and the Playbook Administrator updates the Plays.  Once the 
route records are modified, FAA ATA-100 and the ATCSCC administrator must verify all 
records for accuracy during the 5-day Verification period.  Once the verification process is 
complete, the staging database remains frozen during a 30-day Quiet period.  The Quiet period 
gives airline users a chance to preview the new route records and meet any publication deadlines 
they have. 
 
You can view the 56-day cycle dates, including the chart dates on which a new operational 
database becomes effective and date ranges for the 3 periods of the staging database.  Select Help 
> Show Chart Dates to open the Chart Dates window (Figure 5). 
 



  7 

 
Figure 5: Show Chart Dates 

Dates in gray are those cycles that have already occurred.  Dates highlighted in yellow indicate 
the current chart period.  Dates in cyan indicate the current 56-day chart cycle.  Dates in white 
indicate future chart cycles. 
 

Database Summary 
You can obtain record counts from the various RMT database tables through the CDR, NFDC, 
Playbook and Ad Hoc Reroutes Tools. 
 
CDR Tool Database Summary 
You can easily get a count of the records in either the CDR staging or operational databases.  
Select Help > Database Summary from the CDR Tool.  The number of CDRs is listed along 
with their status:  new, modified, deleted or unchanged.  The number of active records, history 
records and global modifications is also provided.  

 

Figure 6: CDR Staging Database Summary Window 
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To close the summary window click Close. 
 
NFDC Database Summary 
You can easily get a count of the records in the NFDC reference tables.  Select Help > Database 
Summary from the NFDC Tool.  The number of records in each table appears along with date 
and time the table was updated. 
 

 
Figure 7: NFDC Database Summary Window 

 
Playbook Tool Database Summary 
You can easily get a count of the records in either the Playbook staging or operational databases.  
Select Help > Database Summary.  The number of active routes is listed along with their status:  
new, modified, deleted or unchanged.  The number of active records, history records and global 
modifications is also provided.  
 

 
Figure 8: Playbook Operational Database Summary Window 
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Ad Hoc Reroutes Database Summary 
You can easily get a count of the records in the ad hoc reroutes table.  Select Help > Database 
Summary.  The number of active and history records is listed.  Note that you can only see the 
count of the ad hoc reroutes created by your Ad Hoc Group.   
 

 
Figure 9: Ad Hoc Reroutes Database Summary Window 

 

Online Help 
While working in RMT you can access online help.  The online help allows you to search through 
the RMT User's Guide using your computer.  To access online help, select Help > User's Guide.  
A pop-up window displays folders that contain information for each chapter of the User's Guide.  
Double-click a folder to access the topics in that chapter or heading. Click a page to view the 
page online. 
 

 
Figure 10: Online Help Display  
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The RMT Display 
Each RMT Tool appears in a different tab or window, with Tool-specific menus and unique, 
customizable displays.  An overview of the RMT display is given in this chapter.  The individual 
Tool displays are described in their own chapters. 
 

RMT Fonts 
When you open RMT, the default font size is Medium.  To change the font size, select Settings > 
Fonts and click Small Font, Medium Font, or Large Font. 
 

Arranging Windows in RMT 
There are two ways to display the RMT Tools: TabFrame Display and Tab Display.   
 
TabFrame Display Layout  
The five RMT query Tools (CDR, NFDC, PLAYBOOK, ROG and AD HOC) are always shown 
as Tool tabs.  When you are in the TabFrame Display mode, the RMT Map appears in its own 
separate window.  You can resize and move the RMT Map separately from the main RMT 
window.  Select Window > TabFrame Display Layout to arrange the windows in this manner 
(TabFrame is the default display setting).  The TabFrame display replaced the MDI display mode 
from previous versions of RMT and allows for better window management with the additional 
tool windows now available in RMT 1.50.  Clicking anywhere on the main RMT window or the 
RMT Map brings the selected window to the foreground.  

 

Figure 11: TabFrame Display Layout 
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Tab Display Layout 
Choosing the Tab Display option causes the RMT Map window to appear as a tab alongside the 
query tool tabs in RMT.  Labeled tabs along the top of the windows facilitate movement between 
tools.  Select Window > Tab Display Layout to arrange the windows in this manner. 
 

 
Figure 12: Tab Display Layout 

 

Resizing Windows in RMT 
The icons for resizing the main RMT window and the RMT Map are located in the top right-hand 
corner of the main RMT program window or the RMT Map (TabFrame display mode) for both 
Windows and Linux users. 
 
Minimize 
To minimize the main RMT window or the RMT Map, you can click the minimize icon on the 
RMT program window.  
 

 
Figure 13: Minimize RMT (Windows) 
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Maximize 
To maximize RMT or the RMT Map, you can click the maximize icon on the RMT window.  
Click the same icon to return the RMT window or RMT Map window to its original size.  
 

 
Figure 14: Maximize RMT (Windows)  

Custom Size 
You can size the main RMT window and the RMT Map (TabFrame display mode), by placing the 
cursor on a window border.  When the cursor changes to a double arrow, click and drag the 
window border to the desired size.  
 

Saving the RMT Display  
Any changes you make to the Tool window arrangement will be saved between sessions.  So 
when you open RMT, the Tool windows will be arranged in the same manner as when you quit 
your most recent RMT session.  Also, any directory you define for saving searches or reports will 
be saved as the default directory for saving these files. 
 
If you make changes to the display in an individual Tool, the changes are not automatically saved.  
You may save your Tool changes to your local configuration file.  For example, you can save the 
column order in the Query Results tables, map overlays and colors, and default databases (staging 
or operational).  However, these changes must be made manually and individually for each Tool 
because you may want to save your settings for one Tool window but not another.  For more 
information on saving Tool window settings, see "Save Query Results Settings" on page 46. 
 
By default, the user configuration file is saved as rmt150_user_config.ini in your home directory 
on Windows XP systems.  Linux users can find their user configuration file in their home 
directory.   
 
To use the default user configuration settings, find the user configuration file with your personal 
settings.  Either delete this file or change its name.  Once this is done, the system will revert to 
using the default settings in the default user configuration file. 
 
To let others use your settings, simply copy your personal user configuration file and paste it into 
the home directory on another computer. 
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Perform a Search 
To view the information in RMT, you must first conduct a search in the appropriate RMT Tool 
window.   
 

Choose a Tool 
To begin a search, first select the appropriate Tool by clicking on the tab or use the Window 
menu to activate the tool window of interest and bring it to the foreground.   
 

• CDR Tool - The CDR Tool allows the user to query the centralized coded departure 
routes database.  Coded departure routes are alternate air traffic routings and refined 
coordination procedures designed to allow flights to depart as efficiently as possible 
when severe weather or air traffic congestion prevents using normal routes.   

• Playbook Tool - The Playbook Tool  allows the user to query the National Playbook 
database.  The National Playbook is a collection of Severe Weather Avoidance Plan 
(SWAP) routes.  These routes are organized into groupings called ‘Plays’.   

• NFDC Tool - The NFDC Tool contains a collection of tables with preferred routes, 
location identifiers, airway intersections, fixes, airways, navaids, airports, DPs, and 
STARs.  The tables are updated every 56 days with the information provided by the 
National Flight Data Center (NFDC). 

• Ad Hoc Reroutes Tool – The Ad Hoc Reroutes Tool allows the user to query on a 
centralized database of ad hoc reroutes entered by RMT users (both FAA and 
Customers).  Note that users can only see ad hoc reroutes that they have created. 

 
Searching the Operational or Staging Databases 
When you begin a search in the CDR or Playbook Tool, you must select either the Staging or 
Operational database by clicking the appropriate radio button in the top right Database Section 
of the screen.  The operational databases contain routing information that is valid for the current 
56-day chart cycle and generally does not change.  Users may view any upcoming changes made 
by the ARTCC or Playbook administrators for the next cycle in the staging databases.  
 
Note that when you search for routes in either of the staging databases, sections are outlined in 
red.  When you are in the operational databases, the tools are outlined in gray with blue text. 
 

 
Figure 15: Tool Windows are Outlined in Red When Searching in the Staging Databases 
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Searching in the Playbook Tool 
Several different types of information are associated with each Playbook Play; therefore two-
levels are required to display all the pertinent data.  General information about each Playbook 
Play is visible in the top-level Query Results table, e.g. Play Name, Play Category, Modification 
Date and Time, Origin (center names or airports), Destination (center names or airports), 
Facilities Included, Modification Flag and Route String. 
 

 
Figure 16: Playbook Top-Level Query Results Table 

More detailed route segment information can be viewed by selecting a Play in the table and 
double-clicking or pressing the View Play button to bring up the View Play window.  Playbook 
Play origin and destination segments can be shown on the RMT Map by pressing the Send to 
Map button from the View Play window.  Plays can also be saved by pressing the Save button or 
printed using the Print button.   

 

Figure 17: View Play Window – Detailed Segment-Level Query Results 
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Searching in the NFDC Tool 
The NFDC Tool contains several reference tables created from data provided by the National 
Flight Data Center.  It is important to note that the information in these tables is not updated 
through the RMT Tool.   
 
• Preferred Routes (PrefRoutes) - Preferred IFR Routes 
• Location Identifier (LocID) - Abbreviations or acronyms used to refer to airports, navaids, 

centers and other locations. 
• Airway Intersections (AwyIntxn) - Intersection points where airways cross each other.  

Note that this table includes only the unnamed, numbered fixes.  Named fixes (e.g. PETTY, 
WISKE) are not included in the table.   

• Fixes -  Named and numbered fixes 
• Airways - Airway codes 
• Navaids - Navigational Aids 
• Airports - Airport codes 
• DPs - Departure Procedures 
• STARs - Standard Terminal Arrival Routes 
 
To start your search, make sure you have chosen the correct NFDC table to search by clicking the 
appropriate table name in the NFDC Tables section of the NFDC Tool. For example, if you want 
to search Location Identifiers, make sure you click LocID in the NFDC Tables section. This will 
bring up the appropriate query fields for you to use in your search. 
 

 
Figure 18: NFDC Table Selection 

 
RMT replaces the DP and STAR names listed in the NFDC preferred route text file with the 
current DP and STAR name and number in the NFDC Tool display as part of the 56-day Chart 
Date processing.  For example, CINCE-STAR is replaced by CINCE6 and GATEWAY-DP is 
replaced by GATWY4 on all preferred routes. 
 
RMT also expands airport aliases and adds preferred routes to the database for all origin and 
destination airports defined by alias names.  For example, WAS is an alias for IAD, DCA and 
BWI airports.  For preferred routes with WAS listed in the origin field, three records are added to 
the database (one for IAD, DCA and BWI).  Another airport alias expanded into multiple records 
is CHI (ORD, MDW). 
 
Searching in the Ad Hoc Reroutes Tool 
The AD HOC Tool contains a centralized database of ad hoc reroutes entered by RMT users 
(both FAA and Customers).  It is important to note that you can only see ad hoc reroutes create by 
your Ad Hoc Group, e.g. US Airways users can view ad hoc reroutes created by US Airways or 
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US Airways Express but not by United.  The ad hoc reroutes may be helpful when used with the 
ROG capabilities to find reroute options for flights between city pairs that do not have pre-
coordinated reroute options (CDRs or Play segments).  Note there is only one ad hoc database 
and there is no differentiation between staging and operational ad hoc reroutes.  Each user is 
responsible for maintaining their set of routes.  A Warning Report updated every 56-day Chart 
Cycle is available to help with maintenance and route verification. 
 

 

Figure 19: Ad Hoc Reroutes Tool 

Enter Search Parameters 
In each Tool, there are several specific query fields.  Use the query fields to type in the 
parameters for your search.  A search parameter could be one of the elements along a route string 
(for example, an airport, airway, navaid or jet route) or information related to the record (e.g., the 
date the record was created or modified or any remarks associated with the record).   
 
If you do not enter any search parameters and select the Query button or press Enter, your search 
results will include every record in the database you are searching.  This can be a time-consuming 
process, as there are sometimes thousands of routes in a database. 
 
You must enter parameters in the query fields to perform a more specific search.  The query fields 
in each Tool are provided for your convenience.  You do not have to fill in every input field to 
perform a search.  You may find that there are some query fields that you rarely or never use 
when searching.  How general or specific the search is directly relates to the number of 
parameters you enter in the query fields.  The fewer query fields you fill in, the more general your 
search and vice versa.  
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Query Fields 
Each Tool has query fields specific to the type of search you are conducting.  To access 
information about the fields, place and hold your cursor over the text box of a particular field.  
Tool tips with information about the query field and the format to use when filling in that field 
will appear on your screen. 
 
Query Fields in the CDR Tool 

 
Figure 20: CDR Tool Query Fields 

 
The available query fields in the CDR Tool are: 
 
• Route Code - Enter the CDR route code: an 8-character route designator made up of the 3-

character departure airport code, 3-character arrival airport code, and a 2-character facility-
designated code. 

• Origin/Dep Center (Origin or Departure Center) – Enter either the 3 or 4-character airport 
or center code to identify the route’s point of origin (Canadian airports require the 4-character 
ICAO codes.  Anchorage, AK and Honolulu, HI require PANC and PHNL, respectively). 

• Destination/Arr Center (Destination or Arrival Center) - Enter either the 3 or 4-character 
code for the destination airport or the 3-character code for the arrival center. 

• Traversed Centers - Enter the 3-character code for a center through which the flight path 
traverses.  Note that multiple centers can be entered in this field.   

• Departure Fix - Enter a departure fix.  
• Mod Date/Time - Enter the date/time of the record's creation or last modification.  For 

example, enter ‘5/27/2006’ to display all routes created or modified on that date.  You may 
search for routes created during a range of dates using the greater than (>) and less than (<) 
symbols.  To include the date you have entered in your search, use "greater/less than or equal 
to" logic (>= or <=).  Dates must be entered in MM/DD/YYYY format (2-character month - 
2-character date - 4-character year).  Entering a time is optional, but must be entered in 
HH:MM:SS format (2-character hour: 2-character minute: 2-character seconds). 

• Route String - Enter an element of the route string (i.e. a fix, navaid or airport code). 
• Remarks - Use this field to perform a search based on any remarks entered about route 

changes or new record additions. 
• Warnings - Use this field to find any warning messages generated by RMT as the routes 

were entered into the tool by the ARTCC administrators.  These messages are provided to 
help with the route verification and to identify potential problems on the map.  Examples of 
different warning messages include WARNING_UNKNOWN_ELEMENT and 
WARNING_NO_COORDINATES.     

• ModFlag (Modification Flag) - A modification flag is used to indicate any changes made to 
the route record since the last chart date.  To view a route according to its modified status 
you can type D (Deleted record), M (Modified record), N (New record), or a hyphen (-) to 
see existing, unchanged records. 
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• Route Length - Use this field to query on the distance (in nautical miles) of the CDR route.  
The route length is calculated by the RMT trajectory maker and is provided as a reference, 
but should not be used for flight planning purposes.  Note that the distance is not shown if 
any information is missing or unknown along the route string.  This is a numeric field, so 
you can use the following logical operators <, >, <=, >=.   

• Coordination Required - This field was designed to allow the FAA to designate whether 
the CDR requires coordination when filed.  The possible values are  “Y” meaning Yes – 
coordination is required or “N” meaning No – coordination is not required.  This field was 
called “UserFile” in previous versions of RMT.  Note that this name change affects the 
underlying meaning of the data contained in the database.  All CDRs with UserFile=”Y” 
have been reset to CoordReq=”N” in conjunction with the RMT 1.50 release.  

• Nav Eqp – Use the navigation equipment designator field to quickly identify CDRs that 
require advanced navigation capabilities.  Values include 1- basic navigational routes, 2 – 
routes which begin and/or end with RNAV DPs and STARs, 3 - routes which contain Q-
route segments and/or pitch and catch points.  This field became effective on the Aug 3, 
2006 Chart Date.   

• Associated Play - RMT users may also query on the “Associated Play” query field.  If a 
CDR was designed to match a Playbook Play, the Play name will be listed in this field.  The 
CDR administrators at each ARTCC fill in the Associated Play names.   

• PlayModFlag – Use this field to search for the “Associated Play’s” modification flag from 
the Playbook table (M, N, D, -).  This will help ARTCC administrators identify CDR routes 
that may need to be changed because the Associated Playbook Play has changed.  This field 
will be updated by RMT as the Playbook database is modified.  Note that this field is only 
populated for CDRs with Associated Play information.   

• ModInit (Modifier's Initials) - This column is specific to FAA administrators and will 
appear as a blank field to any other user types.  To view routes modified by a particular 
person, type in their FAA-assigned initials.  These differ from the actual initials of the 
person's name. 

• ModUser (Modifier's User Type) - This column is specific to FAA administrators and will 
appear as a blank field to any other user types.  To view routes modified by a specific user 
type, type in the login name (i.e. admin_atcscc) that corresponds to that user type.  Note that 
different people can be logged in under the same user type.   
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Query Fields in the Playbook Tool 

 
Figure 23:  Playbook Tool Query Fields 

The following query fields are available in the Playbook Tool: 
 
• Play Name – Enter the Playbook Play Name. 
• Category – Enter a Playbook category, e.g. Airports, Airway Closures, East to West 

Transcon Routes, Regional Routes, and West to East Transcon Routes. 
• Facilities Included – Enter a 3-character center code for facilities/included or traversed. 
• Mod Date/Time - Enter the date/time of the Playbook Play's creation or last modification.  

For example, enter ‘1/19/2007’ to display all Plays created or modified on that date.  You 
may search for Plays created during a range of dates using the greater than (>) and less than 
(<) symbols.  To include the date you have entered in your search, use "greater/less than or 
equal to" logic (>= or <=).  Dates must be entered in MM/DD/YYYY format (2-character 
month - 2-character date - 4-character year).  Entering a time is optional, but must be entered 
in HH:MM:SS format (2-character hour: 2-character minute: 2-character seconds). 

• Origin/Dep Center (Origin or Departure Center) – Enter either the 3-character origin 
airport code or the 3-character code for the departure center. (Note that the 4-character ICAO 
codes are not used for airports in this Tool).   

• Route String – Enter an element of a Playbook segment route string (i.e. a fix, navaid, or jet 
route). 

• Destination/Arr Center (Destination or Arrival Center) – Enter the 3-character destination 
airport code or the 3-character code for the arrival center (Note that the 4-character ICAO 
codes are not used for airports in this Tool).   

• ModFlag – The Playbook modification flag is used to indicate any changes made to the Play 
since the last chart date.  To view a Play according to its modification status, you can type M 
(Modified record), N (New record), D (Deleted record), or a hyphen (-) to see existing, 
unchanged Plays. 
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Query Fields in the NFDC Tool   
Nine reference tables are currently provided in the NFDC Tool.  The specific query fields for 
each table are provided in the following paragraphs. 
 
Preferred Routes Database  
To search for FAA Preferred IFR Routes, choose the PrefRoutes table.  The available query fields 
for the PrefRoutes table are: 
 
• Origin/Dep Center (Origin or Departure Center) - Enter either the 3-character origin 

airport code or the 3-character code for the departure center. (Note that the 4-character ICAO 
codes are not used for airports in this Tool). 

• Destination/Arr Center (Destination or Arrival Center) - Enter the 3-character destination 
airport code or the 3-character code for the arrival center. (Note that the 4-character ICAO 
codes are not used for airports in this Tool). 

• Route Type - Enter the type of route.  The following codes are valid in the Type field: L 
(low altitude), H (high altitude), LSD (low altitude single direction), HSD (high altitude 
single direction), SLD (special low altitude directional), SHD (special high altitude 
directional), and TEC (tower en route control). 

• Area - RMT lists routes according to city pairs; however, not all preferred routes are limited 
to a particular city pair.  Many routes are valid for several origin and/or destination airports.  
To find routes that are valid in a geographic area, you can enter information in this field.  
Note that the data contained in this field may vary between records, so your search results 
may actually be broader than what appears in the Query Results table.  Useful entries for this 
field include city names and "metro" areas.  For example, entering "Cleveland Metro" should 
bring up routes that are valid at CLE, CGF, BKL, LNN, LPR, and possibly other nearby 
airports. 

• Route String - Enter an element of the route string (i.e. a fix, navaid, or airport code).  Note 
that the current DP and STAR numbers are now being used in the Route String field.   

• Altitude - Enter an altitude for the preferred route.  Altitudes are assumed to be in hundreds 
of feet.  For example, to find routes that utilize an altitude of 30,000 feet, you only need to 
enter "300." 

• Aircraft Types - Enter the type of aircraft that will utilize the route: prop, jet, or turbo. 
• Direction - This field denotes the direction in which the route is valid.  For example, some 

routes are only useable for northbound flights.  Note that the data contained in this field may 
vary between records.  For example, southbound routes may be denoted by "Southbound" or 
"Sbound."  It is probably more useful to include entire words in this field, such as "east" or 
"northeast."  You can also use the abbreviation for the direction (N, E, S, W) in conjunction 
with the word "bound" to find routes for a particular direction.  However, if you enter a single 
letter (i.e. "S"), all routes with the letter "S" in the "Direction" field will appear.  This 
includes routes that go south, west, and east. 

 

 
Figure 21: PrefRoutes Query Fields 
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Location Identifier Database  
In the NAS, airports, centers, and geographical locations are often referred to with abbreviations 
or acronyms.  The abbreviation is called a location identifier.  To search for a location identifier, 
choose the LocID table in the NFDC Tool.  The available query fields for the LocID table are: 
 
• Location ID - Enter the location identifier code.  
• Facility Name & Type - You can specify the name and/or type of location identifier for 

which you are searching.  For example, to search for vortacs, type "vortac" into this field.   
• City, State - Enter a city and/or state name to view all the facilities in that region. 
• FLTWO - Search for facilities with a flight watch station.  Type a "Y" into the field to find 

all facilities with a flight watch station.  Leave the field blank to search for facilities 
regardless of their association with a flight watch station. 

• Tie-in Facility - Enter the 3-character code for the tie-in flight service station associated with 
the location identifier for which you are searching. 

• Controlling Center - Enter the 3-character code for the controlling center of the location 
identifier. 

 

 
Figure 22: Location Identifier Query Fields 

 
Airway Intersections Database   
The Airway Intersections table includes only the unnamed, numbered fixes designated as “AWY 
INTXN” in the NFDC fix and airway tables.  The available query fields in the Airway 
Intersections table are: 
 
• Airways - Enter one or more airway codes (i.e. J66 & J15) to search for intersection points 

along the airway(s). 
• Center - Enter the 3-character code of the numbered fix's controlling center. 
 
Note that there could be more than two airways that intersect at a specified fix because the 
airways occur at different altitudes, etc. 
 

 
Figure 23: Airway Intersections Query Fields 
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Fixes Database 
To search for Fixes, choose the Fixes table.  The available query fields for the Fixes table are: 
 
• Fix Name - Enter the fix identifier. 
• State – Enter the state where the fix is located. 
• Category - Enter the fix category, values are military (mil) or civil fix (fix). 
• Center - Enter the 3-character code of the fix's controlling center. 
• Fix Use - Enter the fix use, e.g., ARTCC-BDRY, AWY-INTXN, COORDN-FIX, MIL-REP-

PT, MIL-WAYPOINT, REP-PT, TURN-PT, or WAYPOINT. 
• Pitch – Pitch flag, enter Y or N. 
• Catch – Catch flag, enter Y or N. 
• SUA - Special Use Airspace(SUA)/ATCAA flag, enter Y or N. 
• Extended Name – Enter the fix name. 
 

 
Figure 24: Fixes Query Fields 

Airways Database 
To search for Airways, choose the Airways table.  The available query fields for the Airways 
table are: 
 
• Airway - Enter the Airway name. 
• Minimum Altitude - Enter the minimum en route altitude. 
• Fix Name - Enter the airway point description or fix name. 
• Type - Enter the airway type (A-Alaska, H-Hawaii, or blank). 
• RNAV – RNAV indicator, enter R or blank. 
 

 
Figure 25: Airways Query Fields 

Navaids Database 
To search for Navaids, choose the Navaids table.  The available query fields for the Navaids table 
are: 
 
• Navaid Name - Enter the navaid name. 
• Type - Enter the navaid Facility Type.  For information on the available codes for this field, 

select Help > Show NFDC Codes and scroll to the Navaids - Type Codes section. 
• Center - Enter the 3-character code of the navaid's controlling center. 
• Class - Enter the Class code.  For information on the available codes for this field, select 

Help > Show NFDC Codes and scroll to the Navaids - Class Codes section. 
• Pitch - Pitch flag, enter Y or N. 
• Catch - Catch flag, enter Y or N. 
• SUA - Special Use Airspace(SUA)/ATCAA flag, enter Y or N 
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Figure 26: Navaids Query Fields 

Airports Database 
To search for Airports, choose the Airports table.  The available query fields for the Airports table 
are: 
 
• Airport - Enter the airport identifier. 
• Facility Name - Enter the airport facility name. 
• City - Enter the city where the airport is located. 
• State - Enter the state where the airport is located. 
• Center - Enter the 3-character code of the airport's controlling center. 
 

 
Figure 27: Airports Query Fields 

Departure Procedures Database 
To search for Departure Procedures (DPs), choose the DPs table.  The available query fields for 
the DPs table are: 
 
• DP - Enter the DP identifier. 
• Transition Number - Enter a transition number (assigned by RMT). 
• Transition Name - Enter the name assigned to the DP/transition you want to find. 
• Fix/Facility Type Code - Enter the Fix/Facility Type code.  For information on the available 

codes for this field, select Help > Show NFDC Codes and scroll to the DPs and STARs - 
Fix/Facility Type Codes section. 

• Fix Name - Enter the DP point description or fix name. 
• Extended Name – Enter the DP/transition name. 
 

 
Figure 28: DPs Query Fields 

Standard Terminal Arrival Routes Database 
To search for Standard Terminal Arrival Routes (STARs), choose the STARs table.  The 
available query fields for the STARs table are: 
 
• STAR - Enter the STAR identifier 
• Transition Number - Enter a transition number (assigned by RMT). 
• Transition Name - Enter the name assigned to the STAR/transition you want to find. 



26 

• Fix/Facility Type Code - Enter the Fix/Facility Type code.  For information on the available 
codes for this field, select Help > Show NFDC Codes and scroll to the DPs and STARs - 
Fix/Facility Type Codes section. 

• Fix Name - Enter the STAR point description or fix name. 
• Extended Name - Enter the STAR/Transition name. 
 

 
Figure 29: STARs Query Fields 

 
Query Fields in the Ad Hoc Reroutes Tool  
 

 
Figure 30: Ad Hoc Reroutes Tool Query Fields 

The available query fields in the AD HOC Tool are: 

• Name – Enter the ad hoc reroute name: unique name assigned by the creator of the route (30 
characters maximum, spaces are not allowed).  

• Origin/Dep Center - Enter either the 3 or 4-character origin airport code or the 3-character 
code for the departure center.  

• Dest/Arr Center - Enter the 3 or 4-character destination airport code or the 3-character code 
for the arrival center.  

• Traversed Centers - Enter the 3-character code for a center through which the flight path 
traverses.  Note that multiple centers can be entered in this field. 

• Departure Fix - Enter a departure fix. 
• Route Length - Use this field to query on the distance (in nautical miles) of the ad hoc 

reroute.  The route length is calculated by the RMT trajectory maker and is provided as a 
reference, but should not be used for flight planning purposes.  Note that the distance is not 
shown if any information is missing or unknown along the route string.  This is a numeric 
field, so you can use the following logical operators <, >, <=, >=. 

• Mod Date/Time - Enter the date/time of the ad hoc reroute's creation or last modification.  
For example, enter ‘10/19/2006’ to display all routes created or modified on that date.  You 
may search for routes created during a range of dates using the greater than (>) and less than 
(<) symbols.  To include the date you have entered in your search, use "greater/less than or 
equal to" logic (>= or <=).  Dates must be entered in MM/DD/YYYY format (2-character 
month - 2-character date - 4-character year).  Entering a time is optional, but must be entered 
in HH:MM:SS format (2-character hour: 2-character minute: 2-character seconds). 

• Route String - Enter an element of the route string (i.e. a fix, navaid, or airport code). 
• Remarks - Use this field to perform a search based on any remarks entered about route 

changes or new record additions. 
• Warnings - Use this field to find any warning messages generated by RMT as the routes 

were entered into the tool by users.  These messages are provided to help with the route 
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verification and to identify potential problems on the map.  Examples of different warning 
messages include WARNING_UNKNOWN_ELEMENT and 
WARNING_NO_COORDINATES. 

• Modlinit (Modifier's Initials) - To view routes modified by a particular person, type in their 
initials.  These may differ from the actual initials of the person's name.  

• ModUser (Modifier's User Type) – This query field is designed primarily for RMT 
administrators; other users will only see ad hoc reroutes that they have created.  To view 
routes modified by a specific user type, type in the login name (i.e. nwa, zny) that 
corresponds to that user.  Note that different people can be logged in under the same user 
name. 

• Ad Hoc Group – This query field is for RMT administrators only.  To view routes modified 
by a specific Ad Hoc Group, type in the login name (i.e. nwa, zny) that corresponds to that 
Ad Hoc Group. 
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Wildcard Characters 
A wildcard character is used to take the place of a specific character in a search parameter.  
Wildcards are good to use when you have only partial information or want to view routes whose 
parameters may share some characters in common.  Please note that wildcards do not work when 
entering center codes (i.e. ZDC).  You must always type the specific 3-character center code in 
your search parameters.  RMT recognizes the asterisk (*) and the question mark (?) as wildcard 
characters. 
 
Using the Asterisk as a Wildcard 
You can use the asterisk in a search field to broaden or narrow your search results, depending on 
the field.   
 
Many search fields require you to enter a specific code in order to obtain search results.  For 
example, you cannot simply enter "O" into the Origin or Destination fields because "O" is not 
recognized as an airport or center code.  You must type in the three-character code in order to 
conduct a search based on origin or destination.  In these types of fields, a single asterisk replaces 
an unlimited amount of characters in a search parameter.  When you use an asterisk in a search 
parameter, the search results include routes whose elements match the specific characters in the 
parameter plus any additional characters either before or after, depending on where you place the 
asterisk.  For example, to search for routes that arrive at any airport whose abbreviation begins 
with "O," type "O*" into the Dest/Arr Center search field.  The search will yield routes whose 
destination begins with an “O” (Figure 31).   
 
However, you can enter partial information in other search fields to achieve search results that 
contain any or all of the information you entered.  For example, if you enter "J1" in the Route 
String field, your search results will include any route records that include the element J1.  This 
would include not only route records with J1, but also J15, J18, J110, etc.  In these types of fields, 
you can use the asterisk to filter parameters.  For example, if you enter WISKE in the route string 
field, your search will yield all route records with an element matching WISKE, including 
WISKE2 if these elements exist.  To limit your search results to those route records with only 
WISKE in the route string, you can place asterisks on either end of the element name and put a 
blank space between the asterisk and any element characters (* WISKE *).  This tells the 
database that there should be no characters on either end of WISKE in any search results (Figure 
32).  Note that when searching for a specific element in Playbook route strings, additional queries 
may be necessary to find the element name in the beginning, middle and end of the Play 
segments, (WISKE * | * WISKE * | * WISKE)  see  
Figure 33. 
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Figure 31: Search Using O* in the NFDC PrefRoutes Destination/Arr Center Field 

 

 
Figure 32: Search Using "* WISKE *" in the CDR Route String Field 
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Figure 33: Search Using * in the Playbook Route String Field 

 
You can also use an asterisk to show records with information in the specified field, e.g. CDR 
Associated Play, NFDC Preferred Routes Area, Altitude and Aircraft Type.  This may be useful 
for searching in fields that are not always filled in (Figure 34).   
 

 

Figure 34: Search Using * in the NFDC PrefRoutes Aircraft Types Field 
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Using the Question Mark as a Wildcard 
A single question mark (?) replaces only one character in a search parameter.  If you do not know 
a letter in a parameter, you can replace it with a single question mark.  The search will yield those 
routes with parameters that match the specific characters you type in and have an additional 
character where the question mark appears.  If you want to replace more than one character in a 
parameter, you must type a single question mark for each character you are replacing.  For 
example, if you want to search for routes originating from ORD and arriving at BOS using a 
single field, use the route code field and insert "??" for the 2-character route designator at the end 
of the code  (Figure 35).  The question mark works best in specific code-based fields (i.e. Route 
Code, Origin/Dep Center, Destination/Arr Center, etc.). 
 

 
Figure 35: Search Using "ORDBOS??" in the Route Code Field 

“And”, “Or” and “Not” Logical Operators 
RMT uses the symbols &, |, and ! to represent the “and”, “or”, and “not” logical operators.  These 
symbols work in all five RMT search windows: CDR, NFDC, Playbook, ROG and AD HOC.  
Please note that the logical operators can be used in conjunction with one another and/or multiple 
times in a query field.  The logical operators are processed in order from left to right as they are 
listed in the query field.  
 
Use "Or" to Include Multiple Parameters in a Search   
Including multiple search parameters in any input field instructs RMT to search for routes that 
meet either parameter.  The search results display all routes with route information that matches 
either parameter typed into a single query field.  RMT recognizes the pipe ( | ) symbol to 
represent the "or" search shortcut.  The search results using this shortcut include only those routes 
that include the specified parameters. 
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Figure 36: Search Using the "Or" Logic in the Origin/Dep Center Field 

For example, in Figure 36, the user searched for routes that originated from PHL or BOS airports.  
Note that you can leave out the space between the pipe and the airport codes (PHL|BOS).  The 
search results include only those routes that originated at PHL or BOS. 
 
Use "And" to Combine Multiple Parameters   
The "and" logic is primarily used in the route string field.  Route strings are made up of the actual 
route elements, including navaids, jet routes, and fixes.  To search for routes that include all the 
multiple, different elements you specify, use RMT's "and" logic.  RMT recognizes the ampersand 
(&) as "and" in a search. 
 

 
Figure 37: A Search with “PETTY” in the Route String 
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In Figure 37 above, the user conducted a search for routes with only the fix PETTY entered in the 
route string.  Note that a variety of routes with different origins and destinations contain PETTY 
in the route string. 
 

 
Figure 38: A Search with "PETTY & MKG" in the Route String 

In Figure 38 above, the user searched for routes with PETTY and MKG to create a more specific 
search using the route string field.  Note that this has narrowed the query results.  
 

 
Figure 39: Search Using “PETTY & MKE & CVG” in the Route String 

In Figure 39 above, the user searched for route records with PETTY, MKE and CVG in the route 
string. This search is very specific.  
 
You cannot use the "and" logic in all query fields.  If you use "and" in a query field that does not 
utilize that logic, RMT will warn you that you have made an invalid entry.  Click OK to close the 
warning window and return to the RMT Tool in which you were working.  Remove the "&" from 
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the field to continue your search.  Most likely you have used "and" logic when you want to use 
"or" logic.   
 
For example, in Figure 40, the user wanted to search for CDRs arriving at BOS or PHL and used 
the "&" to indicate "and."  Note the warning that RMT gives.  You cannot find route records that 
have a destination of BOS and PHL because a route can only have one destination.  In this case, 
the user would want to search for routes with a destination of BOS or PHL.  The user would need 
to enter "BOS|PHL" to get the desired search results. 
 

 
Figure 40: Warning When Using "&" Instead of “|” 

 
Use "Not" to Exclude Routes  
Use RMT's "not" logic to exclude routes that include particular parameters.  RMT recognizes the 
exclamation mark (!) as the symbol for "not."  For example, you might want to search for routes 
out of a particular airport and know that you cannot use a particular fix out of the airport.  In this 
case, you would want to search for all routes out of the airport that do not use that particular fix.  
You can use the "not" logic multiple times in one search to narrow your search even further.  Just 
type in the parameters you want excluded from resulting routes, using an exclamation mark in 
between each element code. 
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Figure 41: Search Using the "Not" Logic in the Route Type Field 

In Figure 41, the user searched the NFDC Tool for all Preferred Routes that originate from ORD 
and are not high altitude routes (route type = H).   
 

 
Figure 42: Search for Routes in Staging Database to be Copied to Operational 

To search for routes in the staging database that will be copied to the operational database, you 
could perform a search using "!D" in the ModFlag field.  This would exclude routes that are 
marked for deletion and will not show up in the operational database in the next cycle. 
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Create an Alias for a Group of Airports or Route 
Elements 
A metropolitan area is often served by more than one airport.  To enable you to search for routes 
for all airports in a metropolitan area, RMT utilizes airport aliases, which serve as a shortcut to 
having to type in several airports in a search field.  For example, airports that serve the New York 
City metropolitan area are all included in the alias "NYMetro."  Currently, the "NYMetro" alias 
includes LGA, JFK, and EWR.  The “WAS” alias includes IAD, DCA, and BWI.  The “CHI” 
alias includes ORD and MDW.   
 
You can still use "or" and "not" logic in conjunction with the aliases.  For example, if you want to 
find flights departing from DCMetro airports with the exception of BWI, enter "DCMetro !BWI" 
in the Origin/Dep Center field.  The example in Figure 43 illustrates the airport alias logic in the 
Origin/Dep Center field and the “OR” logic in the Dest/Arr Center field.  The user is looking for 
routes that originate from any airport in the NY Metropolitan area and arrive at either BOS or 
PHL airports. 
 

 
Figure 43: Example Using NYMetro in the Origin Field 

Note that you may create your own set of aliases by editing the rmt_user_aliases.ini file in your 
home directory.  This file is shown in the Appendix.  For example, an airline user may routinely 
search for the subset of CDRs from their origin/destination city pairs.  You can also define an 
alias for multiple route elements that you search for often, e.g., GWELEMENTS:  TNV LOA.  
You could use the alias in the route string field in the CDR, NFDC, Playbook or AD HOC Tools 
to list routes containing ‘TNV LOA’.      
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Run the Search 
Once you enter your search criteria, press Enter on your keyboard or click the Query button on 
the appropriate RMT Tool to perform the search.  The Tool will search its database for those 
routes that match your parameters.  Once the search is completed, you will see the results in the 
Query Results table of the Tool. 
 

Clear Your Search 
To clear your search parameters and any query results, click the Clear button.  This should clear 
any information and allow you to start a new search.  You can use the Clear button before you run 
a search to clear all query fields.  This is useful when you decide not to run a search or decide you 
need entirely new search parameters.  However, only use the Clear button if you want to erase 
information in all your query fields.  The Clear button does not work to clear individual query 
fields. 
 

Cancel Your Search 
If a search is taking a long time to run, you may cancel the search at any time.  Click the Cancel 
button to interrupt the search and start a new search. 
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View Search Results 
The Query Results Table 
Once your search is complete, any records that match the search criteria will appear in the Query 
Results section of the RMT Tool in which you are working.  The Query Results section is a table 
listing the records.  Each record is listed on its own row, with several columns to separate specific 
information.   
 
Generally, the columns that appear in the Query Results table directly correspond with the Query 
Fields.  You can choose to show or hide specific columns, as well as change their size and the 
order in which they are displayed.  To read about these customization options, see page 45. 
 
Query Results in the CDR Tool  
 

 
Figure 44: Query Results in the CDR Tool 

You can view the following information columns in the CDR Tool Query Results table: 
 
• ModTime - The date and time the route record was created or modified. 
• RCode - The route code for the coded departure route.  The route code is an 8-character route 

designator that consists of the 3-character origin airport, 3-character destination airport, and 
2-character facility designation code.  

• Orig - The origin airport of the coded departure route. 
• Dest - The destination airport of the coded departure route. 
• Route String - The route elements (airports, navaids, fixes, jet routes) that make up the 

coded departure route. 
• CoordReq – The “Coordination Required Flag” indicating whether the CDR requires 

coordination when filed, values are Y for Yes - coordination is required or N for No - 
coordination is not required.  

• DepFix - The departure fix. 
• DCNTR - The departure center of the origin airport. 
• ACNTR - The arrival center of the destination airport. 
• TCNTRs - Any centers through which the CDR traverses.  Note that centers are listed 

alphabetically, not geographically along the route. 
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• ModFlag - A flag used to indicate any changes made to the route record since the last chart 
date. 'M' indicates a modified route.  'N' indicates a new route.  'D' indicates a deleted route.  
'-' indicates an unchanged route. 

• Length – The length of the CDR in nautical miles. 
• Remarks - Any remarks associated with the route record. 
• Warnings – Any warnings associated with the route record. 
• Play – An ”Associated Play” name from the Playbook table.   
• PlayModFlag – The “Associated Play’s” modification flag from the Playbook table (M, N, 

D, -).   
• NavEqp – The navigation equipment designator, values include 1- basic navigational routes, 

2 – routes which begin and/or end with RNAV DPs and STARs, 3 - routes which contain Q-
route segments and/or pitch and catch points.   

• ModInit - This field is specifically for FAA users.  The FAA-assigned initials of the person 
who modified the route record. 

• ModUser - This field is specifically for FAA users.  The user type of the person who 
modified the route record.   

 
Query Results in the Playbook Tool  
You can view the following information columns in the High-Level Playbook Query Results 
table:  
 
• ModTime - The date and time the Playbook record was created or modified. 
• Play Name - The Playbook Play name. 
• Category – The Playbook Category name, e.g. Airports, East to West Transcon Routes, 

South to Northeast Routes.   
• Impacted Area or Flow – The impacted area or flow for this Play. 
• Facilities Included – The facilities included or traversed by this Play. 
• Instructions – Any special instructions associated with this Play. 
• Remarks – Any remarks associated with this Play. 
• SPECIAL NOTE – Any special notes associated with this Play.  
• Last Update – The effective chart date for the last update to this Play.   
• ModFlag - A flag used to indicate any changes made to the Play record since the last chart 

date. 'M' indicates a modified Play.  'N' indicates a new Play.  'D' indicates a deleted Play.  '-' 
indicates an unchanged Play. 

• ModDescription – Any changes that have been made to this Play since the last chart date are 
listed in this field, e.g. new segments added, global name changes.  The Playbook 
administrator may also add comments further explaining any changes.  This field is used to 
create the Playbook ‘Changes for Next Cycle’ Report. 

 
Additional segment-level information for each Playbook Play can be viewed by selecting a Play 
in the Query Results table and double-clicking or by pressing the View Play button.  The general 
Play information, Impacted Area indicator (an IA indicating there is an Impacted Area appears to 
the immediate right of the Impacted Area or Flow field), plus the following detailed information 
is available on the View Play window.   
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For Non-split Plays, there is a section for origin segments called Play Routing at the bottom of the 
View Play window that includes the following information columns.   
 
• Orig – The origin (ARTCC or airport) of the Play segment. 
• Filters – Any filters associated with the Play segment. 
• Route – The origin segment route string. 
• Dest – The destination airport of the Play segment.  
• Remarks – Any remarks associated with this Play segment. 
• Start – The starting point for any different colored Play segments. 
• Color – The assigned color for the Play segment.  Note that the default color is brick red.   
 
For Split Plays, there is an additional Route to Destination Section at the bottom of the View Play 
window that contains similar information for the destination segments. 
 
To view or print the detailed segment-level Playbook Play information, press the Send to Map or 
Print button on the View Play or View Play History window.  Please note that one Play at a 
time can be printed in this manner. 
 
Query Results in the NFDC Tool  
Three reference tables are currently provided in the NFDC Tool.  The information columns found 
in the Query Results table for each are provided in the following paragraphs. 
 
Query Results for Preferred Routes  
When you perform a search using the NFDC Tool's PrefRoutes table, you can view the following 
columns: 
 
• Origin - The origin airport of the preferred route. 
• Route String - The route elements (airports, navaids, fixes, jet routes) that make up the 

preferred route.  Note that the current DP and STAR numbers are now being shown in the 
Route String field. 

• Destination - The destination airport of the preferred route. 
• Hours 1 - The effective times (GMT) for the route.  Effective times are those hours during 

which the route can be flown. 
• Hours 2 - The effective times (GMT) for the route.  Effective times are those hours during 

which the route can be flown. 
• Hours 3 - The effective times (GMT) for the route.  Effective times are those hours during 

which the route can be flown. 
• Type - Specifies the route type.  Route types are: L - low altitude; H - high altitude; LSD - 

low altitude single direction; HSD - high altitude single direction; SLD - special low altitude 
directional; SHD - special high altitude directional; TEC - tower en route control. 

• Area - The preferred route area description. 
• Altitude - The preferred route altitude description. 
• Aircraft - The aircraft types that can use this route are listed in this column. 
• Direction - The route direction limitations description. 
• Seq - Route identifier sequence number.  This is the number of preferred routes between a 

city pair. 
• DCNTR - The departure center for the preferred route. 
• ACNTR - The arrival center for the preferred route. 
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Query Results for Location IDs  
When you perform a search using the NFDC Tool's LocID table, you can view the following 
columns: 
 
• LocID - The 3-character location identifier code.  The location identifier can represent more 

than one facility. 
• Facility Name & Type - The facility name and type.  For example, facilities can be airports, 

navaids, or ILS.   
• Location - The city and state location of the facility. 
• FLTWO - Indicates whether the facility is a flight watch station indicator.  Y indicates "yes."  

A blank column indicates "no." 
• Tie-in Facility - The 3-character code for the tie-in flight service station associated with the 

location identifier. 
• Center - The 3-character code for the controlling center of the location identifier. 
 
Query Results for Airway Intersections  
You can view the following information columns in the AwyIntxns table: 
 
• Airways - The airways that intersect at the numbered fix. 
• Center - The controlling center of the fix. 
• Latitude - The latitude at which the airway intersection occurs. 
• Longitude - The longitude at which the airway intersection occurs. 
• Fix Name - The unnamed, numbered fix at which the airway intersection occurs. 
 
Query Results for Fixes 
When you perform a search using the NFDC Tool's Fixes table, you can view the following 
columns: 
 
• Fix Name – Fix identifier. 
• State - Name of the state where the fix is located. 
• Latitude - Geographical latitude of the fix. 
• Longitude - Geographical longitude of the fix. 
• Category – Military (mil) or civil fix (fix). 
• Center - The 3-character code of the fix's controlling center. 
• Fix Use – Fix use, e.g., ARTCC-BDRY, AWY-INTXN, COORDN-FIX, MIL-REP-PT, 

MIL-WAYPOINT, REP-PT, TURN-PT, or WAYPOINT. 
• Pitch - Pitch flag (Y or N). 
• Catch - Catch flag (Y or N). 
• SUA - SUA/ATCAA flag (Y or N). 
• Extended Name – Fix name. 
 
Query Results for Airways 
When you perform a search using the NFDC Tool's Airways table, you can view the following 
columns: 
 
• Airway - Airway identifier. 
• Latitude - Navaid or fix latitude. 
• Longitude - Navaid or fix longitude. 
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• Min Alt - Point to point minimum en route altitude. 
• Fix Name - Navaid facility or fix name. 
• Type – Airway type, A-Alaska, H-Hawaii, or blank. 
• RNAV – RNAV indicator, R or blank. 
• Seq - Sequence number. 
 
Query Results for Navaids 
When you perform a search using the NFDC Tool's Navaids table, you can view the following 
columns: 
 
• Navaid Name - Name of the navaid. 
• Latitude - Geographical latitude of the navaid. 
• Longitude - Geographical longitude of the navaid. 
• Type - Navaid facility type. 
• Center - Name of the navaid's controlling center. 
• Class - Alt code (H,L,T) and/or combination of class codes. 
• Pitch - Pitch flag (Y or N). 
• Catch - Catch flag (Y or N). 
• SUA - SUA/ATCAA flag (Y or N). 
 
Query Results for Airports 
When you perform a search using the NFDC Tool's Airports table, you can view the following 
columns: 
 
• Airport - Airport identifier. 
• Facility Name - Official facility name. 
• Latitude - Airport reference point latitude. 
• Longitude - Airport reference point longitude. 
• Elevation - Airport elevation (nearest foot MSL). 
• City - City where the airport is located. 
• State - State where the airport is located. 
• Center - Responsible ARTCC identifier. 
 
Query Results for Departure Procedures 
When you perform a search using the NFDC Tool's DPs table, you can view the following 
columns: 
 
• DP - Departure Procedure name. 
• Transition - Number of transitions (assigned by RMT). 
• Transition Name – FAA-assigned computer identifier assigned to the DP/transition 

displayed. 
• Latitude - Fix/Navaid/Airport Latitude. 
• Longitude - Fix/Navaid/Airport Longitude. 
• Type - Fix/Facility type code. 
• Fix Name - DP point description or fix name. 
• Extended Name - Name assigned to the DP/transition displayed. 
• Seq - Sequence number. 
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Query Results for Standard Terminal Arrival Routes 
When you perform a search using the NFDC Tool's STARs table, you can view the following 
columns: 
 
• STAR - STAR name. 
• Transition - Number of transitions (assigned by RMT). 
• Transition Name - FAA-assigned computer identifier assigned to the STAR/transition 

displayed. 
• Latitude - Fix/Navaid/Airport Latitude. 
• Longitude - Fix/Navaid/Airport Longitude. 
• Type - Fix/Facility type code. 
• Fix Name - Fix/Navaid/Airport identifier 
• Extended Name - Name assigned to the STAR/transition displayed. 
• Seq - Sequence number. 
 
Query Results in the Ad Hoc Reroutes Tool 
You can view the following information columns in the Ad Hoc Tool Query Results table: 
 
• ModTime - The date and time the ad hoc reroute record was created or modified. 
• Name - The ad hoc reroute name.  The name is unique and assigned by the creator of the 

route (30 characters maximum, spaces are not allowed).  
• Orig - The origin airport of the ad hoc reroute. 
• Dest - The destination airport of the ad hoc reroute. 
• Route String - The route elements (airports, navaids, fixes, jet routes) that make up the ad 

hoc reroute. 
• DepFix - The departure fix. 
• DCNTR - The departure center of the origin airport. 
• ACNTR - The arrival center of the destination airport. 
• TCNTRs - Any centers through which the ad hoc reroute traverses.  Note that centers are 

listed alphabetically, not geographically along the route. 
• Length – The length of the ad hoc reroute in nautical miles. 
• Remarks - Any remarks associated with the ad hoc reroute record. 
• Warnings – Any warnings associated with the ad hoc reroute record. 
• ModInit - The initials of the person who modified the ad hoc reroute record. 
• ModUser - The user type of the person who modified the ad hoc reroute record.  
• Ad Hoc Group – The Ad Hoc Group of the person who modified the ad hoc reroute record 

(RMT administrators only). 
• Ad Hoc ID – The unique Ad Hoc ID number assigned by RMT. 
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Customize the Query Results Table 
You can customize the Query Results table in any RMT Tool to suit your needs.  That is, you can 
choose which columns to display, column size and order, and how route records are sorted.  
 
Sort Records 
Double-click any column header to sort records in ascending order according to the column 
selected.   To view a descending sort of the same field, simply double-click on the column header 
again.  
 
You can sort according to three different columns simultaneously in this manner.  To sort records 
according to more than one column, sort from the least to most important column header.  For 
example, if route destination is the column by which you want your routes primarily sorted, sort 
that column after you have sorted any other column.  
 
Change Column Order  
To rearrange column order, simply click 
and drag the column header you wish to 
move to the desired location. The moved 
column will drop in place and the other 
columns move accordingly when you 
release the mouse. 
 
 

 
Figure 45: Moving the Dest Column Left   

 
Resize Columns  
To resize a column in the Query Results table, place your cursor on the line between two 
columns.  When the cursor becomes a double arrow, click and drag the border to the desired 
width.   
 

 
Figure 46: Resizing Columns 
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Eliminate and Add Columns 
 
To eliminate or add columns, select Settings > 
Show/Hide Columns.  This brings up the 
Show/Hide Columns window, which lists all 
the columns that you can display in the selected 
table (Figure 47).  Any column name with a 
checkmark in the box next to it will be 
displayed in the Query Results table.  To 
eliminate a column, click the box next to the 
column name in the Show/Hide Columns 
window to remove the checkmark.  Similarly, 
to add a column, click the box next to the 
column name in the Show/Hide Columns 
window to make a checkmark appear. 

 
Figure 47: Playbook Show/Hide Columns 

Options 

  
 
Save Query Results Settings 
Once you customize the Query Results table of any RMT Tool, you probably want to save those 
display settings for your next RMT session.  RMT allows you to manually save any modifications 
made to the Tool displays.  Select Settings > Save Settings.  This will save the display settings to 
your local configuration file so that the Tool will open in RMT exactly as you closed it. 
 
 

Export Query Results 
Query results can be exported to a number of formats.  You can send query results to the map to 
view a graphic display of the results.  You can export any records that appear in your query 
results table to a comma-delimited text file by either using the Save or Copy to Clipboard 
functions.  You can also send your search results to a printer by using the Print function.  Note 
that only the columns that appear in the Query Results table of an RMT Tool are saved, copied, or 
printed.  When exported, the columns will appear in the same order as they are displayed in the 
Query Results table.  Remember that you can customize the Query Results display so that the 
exported product appears as you want. 
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Selecting Records in the Query Results Table 
To export records from the Query Results table of any RMT Tool, you must select the records 
you wish to export. 
 
To select records, you can Ctrl-click on individual records, click and drag across a range of 
records, or click a single record and then shift-click another record to choose the entire range.  If 
you make a mistake when selecting records, click the Deselect All button to clear your selections 
and start over.  Likewise, if you decide during your selection process that you want to select all 
the records, click the Select All button in the Tool to highlight all the records.  Note that by 
default, if you do not select any records, all records will be selected. 
 
Any record(s) you select should be highlighted.   
 
Send Query Results to the RMT Map 
The RMT Map allows you to see graphical representations of coded departure routes, preferred 
routes, Playbook segments, ad hoc reroutes and NFDC reference information.  Note that you 
cannot view location identifiers on the map.  To view any records in the Query Results table of an 
RMT Tool on the RMT Map, you must first select the records to be displayed.  Click the Send to 
Map button.  Note that Playbook Play segments are sent to the map differently than CDRs.  To 
see the records on the map, click the title bar of the RMT Map window or select Window > 
RMT Map to bring the map window forward.  To learn more about the map display, see “The 
RMT Map” section on page 59. 
 
Save Search Results 
To save your search results as a text file, select the records you wish to save. 
 
Any record(s) you select should be highlighted.  Once you choose which records to save, select 
File > Save to File.  Choose the file name and location for your text file.  Because the file is 
simple, comma-delimited text, it is easy to export to another format, such as Microsoft Word or 
Excel.  Note that if a comma appears in a text field, RMT converts the comma to a period when it 
is written to the file.  This occurs in several fields in the NFDC reference tables, e.g. LocID table, 
“Facility Name & Type”, “City, State” fields.   
 
Note that the top-level Playbook query results are saved in this manner.  To save the detailed 
segment-level Playbook Play information, press the Save button on the View Play, View Play 
History or Play Editor windows. 
 
Copy Search Results  
To copy your search results and paste the results into another program select the records you wish 
to copy.   
 
Any record(s) you select should be highlighted.  Once you choose which records to copy, select 
File > Copy to Clipboard.  The copied records can then be pasted into another program.  Open 
the program you want to use to view the records.  In the new program, click Ctrl + V (Windows 
or NT) or select the program's paste function.  The paste function should work correctly in most 
text editing, word processing, or spreadsheet programs.  However, you may run into a program 
that does not display the copied and pasted text correctly. 
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Print Search Results 
To print your search results select the records you wish to print.   
 
Any record(s) you select should be highlighted.  Once you choose which routes to print, select 
File > Print.  Note that the printed columns are sized so that they fit all the column information, 
regardless of the column size in your Tool display.  To maximize the amount of information you 
print on a single page, Windows users can select the Properties button from the print window 
and select the Landscape option to print the records lengthwise on a page (Figure 48).  You can 
also choose to show or hide columns in the Query Results table to reduce the amount of printed 
information.  When the rows are longer than a printed page will allow, the information will 
continue on another page. 
 

 
Figure 48: Print Window for Windows XP Users 

 
Note that the top-level Playbook query results are printed in this manner.  To print the detailed 
segment-level Playbook Play information, press the Print button on the View Play, View Play 
History or Play Editor windows. 
 

Copy Route Strings  
Two options are available to copy route string information to other applications; Copy Route 
String, Copy Route String (ETMS Format).  These options are available in CDR, AD HOC, 
NFDC Preferred Routes, Playbook View Play windows, and the reroute options tables in ROG 
Assign Reroutes.  Right-click on the route string field in the desired route to bring up a pop-up 
menu.  The Copy Route String option copies the route with spaces.  Copy Route String (ETMS 
Format) copies the route string with dots between the elements.   
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Reports 
RMT provides several types of reports for users.  Note that all RMT reports have been converted 
to HTML format to improve readability and standardized to use GMT times.   
 

CDR Tool Reports 
 
Changes for Next Cycle Report 
The Changes for Next Cycle Report compares route records that appear in the staging database 
with those in the operational database and checks for differences in the route string.  Only those 
routes with changes to their route string will appear in the report.  Route records with changes to 
other fields (for example, changes to the remarks field) will not appear in the report.  You can 
compare all the routes in the database or just those routes associated with a particular center. 
 
To view route record modifications since the last chart date, use the CDR Tool report function.  
To view the route records that have been modified since the last chart cycle, select Reports > 
Changes for Next Cycle.  The Report - Changes for Next Cycle window appears (Figure 49). 
 

 
Figure 49: Changes for Next Cycle Report Window 

 
Use the Report window to specify parameters for your report.  Enter information about your 
report using the following fields, provided in the Report window: 
 

• Report Date - Enter the end date (MM/DD/YYYY) for which you want to see the 
changes.  The report will show route record modifications beginning from the last chart 
date up until the Report Date you specify in the Report Changes window.  The default 
date is the current date.  Click the Reset button to set the date to the default value, which 
is the current date.  Note that if you specify another date, processing the report may take 
longer. 
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• Select Centers - Select "All Centers" to see the route records modified by every center or 
select a particular center whose routes interest you.  You can only select one center if you 
do not use the "All Centers" option.  Note that route records are modified by their 
controlling (departure) center.   

• Center Type - Click Departure or Arrival to view modified route records according to 
either the centers from which they depart or arrive.  

 
Click OK to run the report.  RMT generates an HTML report that opens on your screen when the 
processing is completed.   
 

 
Figure 50: CDR Changes for Next Cycle Report  
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Header information includes the current, chart, and report date as well as the tool used to generate 
the report and which centers are included in the report.  The report also has a Routes Summary 
section that contains statistics about the number of new, deleted, and modified routes as well as 
the number of routes that did not change.  A Global Modifications Summary is provided that 
lists the number of routes affected by each global name change, e.g. STAR number changes.   
 
The route records in the report are grouped according to status: New, Deleted, and Modified 
records, and further sorted within these groups according to route code.  Four columns appear in 
the New Routes section for each record:  Route Code, New Route String, Departure Center, and 
Arrival Center.  Deleted Routes have the Route Code, Deleted Route String, Departure Center, 
and Arrival Center information. Modified route records will have columns listing the Route Code, 
Old Route String, New Route String, Departure, and Arrival Center.  . 
 
The report may be saved to a file by pressing the Save button, then specifying a file name.  The 
saved report is an HTML file that can be opened in a number of applications at a later time.  You 
can close the window without saving the report by pressing the Close button.   
 
Traversed Center Changes Report 
The Traversed Center Changes for Next Cycle Report is an extension of the Changes for Next 
Cycle Report described in the previous section.  This report was created as an additional tool to 
facilitate the CDR coordination process.   This report will be used primarily by ARTCC 
administrators during the CDR verification processing.  This report lists changes to the route 
string for all routes that traverse the specified center.    
 
To view route record modifications since the last chart date, use the CDR Tool report function.  
To view the route records that have been modified since the last chart cycle, select Reports > 
Traversed Center Changes.  The Report – Traversed Center Changes window appears 
(Figure 49).  Use the Report window to specify a Report Date and to select the center of interest.   
 

 
Figure 51: Traversed Center Changes for Next Cycle Report Window 

 
Click OK to run the report or Cancel to close the window without taking any action.  RMT 
generates an HTML report that opens on your screen when the processing is completed.   
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Figure 52: CDR Traversed Changes for Next Cycle Report 

 
The format for the report is the same as described above in the “Changes for Next Cycle Report” 
section.  The report may be saved to a file by pressing the Save button, then specifying a file 
name.  The saved report is an HTML file that can be opened in a number of applications at a later 
time 
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Route Code Changes Report 
The Route Code Changes Report lists CDRs where the route code has changed since the last 
cycle.  Users may view the report by selecting Reports > Route Code Changes.  Use the Report 
– Route Code Changes window to specify a Report Date and to select the center of interest.   
 

 

Figure 53: Route Code Changes Report Window 

The report lists the old route code, new route code, and the route string for all CDR route codes 
that have changed.  The departure center and arrival center for the modified routes is also listed.  
The report is first displayed on the screen and then may be saved to a file. 
 

 
Figure 54: CDR Route Code Changes Report 
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Warnings Report 
The Warnings Report allows FAA users to view warning messages associated with CDRs 
currently contained in the database (Reports > Warnings).  This report will be used to help with 
the CDR verification process.  You may view all warnings or those associated with routes from a 
specified departure center.  This report is highly customizable.  You may select the warning 
messages you are interested in viewing and the order of the report.   
 
To Customize the Warnings Report, select Reports > Warnings from the CDR Tool window.  
The Report – Warnings window appears. 

 

Figure 55: Warnings Report Window 

Click Modify in the Warnings section of the Report – Warnings window.  The Customize 
Warnings Report window appears. 
 

 
Figure 56: Customize Warnings Report Window 
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The warnings found in the database appear in the Warnings in Database section.  The warnings 
currently displaying in the report appear in the Warnings Selected for Report section.  The default 
is for all warnings to appear in the report. 
 
Select any warnings you want to remove from the report from the Warnings Selected for Report 
section.  Click the left pointing arrow button.  The specified warning moves to the Warnings in 
Database section.  Note that you can remove all warnings or include all warnings in the report 
using the double arrow buttons. 
 

 
Figure 57: Removed Warning Appears in Warnings in Database Section 

You can change the order in which the warnings appear in the report by selecting the warning you 
want to move in the Warnings Selected for Report section and clicking the up or down arrow in 
the Order in Report section.  Once you have customized the report to fit your needs, click OK.  
The Customize Warnings Report window closes and you return to the Report - Warnings 
window.  Click OK on the Report - Warnings window.  The Warning Report window appears 
with your selections displayed. 
 
A Warnings Summary section lists the total number of warnings and the number of routes with 
warning messages.  A section is provided for each type of warning with a detailed description of 
the problem for each route.  The report is first displayed on the screen and then may be saved to a 
file.   



56 

 
Figure 58: CDR Warnings Report 

 
Note that routes that are marked for deletion (ModFlag=D) are not included in the Warning 
Reports.   
 
A description of the warning messages that may appear in the report can be found using Help > 
Show Warning/Error Messages.   
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Playbook Changes for Next Cycle Report 
The Playbook Changes for Next Cycle Report compares staging and operational Plays and 
checks for differences in the origin and destination route string segments.  Note that the 
ModDescription column in the Query Results table also contains the detailed description of any 
Play route segment changes.  Plays with changes to other fields (for example, changes to the 
instructions field) will not appear in the report.  
 
The user only needs to specify a Report Date.  The report will show any Play modifications 
beginning on the last chart date through the specified date.  The default value is the current date.   
The Plays Summary section contains statistics about the number of new, deleted, modified, and 
unchanged Plays.  A Global Modifications Summary is provided that lists the Plays affected by 
each global name change, e.g. STAR number changes.  The report is first displayed on the screen 
and then may be saved to a file. 
  

 
Figure 59: Playbook Changes for Next Cycle Report 

 
Note that the Administrator may save the Playbook Changes Report in XML format in order to 
facilitate updates to the Playbook webpage.   
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Ad Hoc Warnings Report 
The Ad Hoc Reroutes Warnings Report is available for all users to view warning messages 
associated with their ad hoc reroutes currently contained in the database (Reports > Warnings).  
Note that this report only lists warnings for routes you have created and that are associated with 
your user group (for example, United cannot see US Airways routes and vice versa).  This report 
helps with the ad hoc verification process.  It is important to note that users are responsible for 
maintaining their own ad hoc reroutes.  The warning messages associated with the ad hoc reroutes 
will be updated as part of the 56-day chart date processing, but the users must update the 
DP/STAR numbers etc. on their routes.   
 
See the CDR Warnings Report section above (page 54) for specific details on creating and 
customizing the report.  The report contains a Warnings Summary section listing the total 
number of warnings and the number of ad hoc reroutes with warning messages.  A section is 
provided for each type of warning with a detailed description of the problem for each route.  The 
report is first displayed on the screen and then may be saved to a file.   
 
A description of the warning messages that may appear in the report can be found using Help > 
Show Warning/Error Messages.   
 

 
Figure 60: Ad Hoc Warning Report 
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The RMT Map 
The RMT Map is provided as a graphical reference to view NAS elements (e.g., airways, navaids, 
fixes, airway intersections, airports, DPs and STARs) and to view CDRs, NFDC preferred routes, 
Playbook Plays, and ad hoc reroutes.  The RMT Map has several customization features, 
including zoom options, overlays (or layers), and color preferences.  Note that multiple maps are 
not supported in this version of RMT.  The RMT Map also has a pop-up menu available when 
you right-click anywhere on the map.  This menu allows you access to several components 
including Add Range Rings, Show/Hide Overlays, etc., as well as allowing you to perform 
several common actions (Clear Routes, Reset Map, Reset Zoom, etc.).  
 

View Query Results on the Map 
Sending query results to the map for viewing is an option available in the CDR, AD HOC and 
NFDC Tools (except for LocIDs, you cannot send these results to the RMT Map).  When you 
complete a search in any of these Tools, the records that match your search criteria appear in the 
Query Results table of the Tool window.  In the Query Results table, select the record(s) you 
want to view on the RMT Map (see “Selecting Records in the Query Results Table” on page 47).  
The record(s) should be highlighted.  Click the Send to Map button on the Tool window.  Then 
click to the title bar of the RMT Map window or select Window > RMT Map to view the 
records.   
 
Note that some Canadian and Mexican data has been incorporated into the RMT Map Tool from 
the ETMS grid files.  Routes extending into Canada or Mexico are more complete than in 
previous versions.  Please note that a warning message will appear in the “Warnings” column in 
the Query Results table if any information is missing along the route string.   
 
Remove Routes from the Map 
You can remove routes from the map display either individually or all at once.  To remove a 
single route or a specific group of routes from the map display, either click a single route or Ctrl-
click multiple routes on the map display so that the desired routes are highlighted.  Press Delete 
on your computer keyboard.  The route(s) should disappear.  This works on any route displayed 
on the map, including CDRs, Playbook segments, preferred routes, ad hoc reroutes and user-
designed miscellaneous routes. 
 
To remove all routes displayed on your map, select View > Clear Routes or right-click on the 
map and select Clear Routes from the pop-up menu.  Your map display should clear all routes on 
the map, including coded departure routes, Playbook Plays, preferred routes, ad hoc reroutes, and 
user-designed miscellaneous routes. 
 
Remove NAS Elements from the Map 
To delete NAS elements from the RMT Map, you can choose to hide the overlay that includes the 
results on the map (see “Using Show/Hide Overlays” on page 68 for more information).  For 
example, if you send navaids to the map from the NFDC Tool you can remove them by hiding the 
navaids overlay on the Show/Hide Overlays window.  Note that an airway intersection is a type 
of “fix”.  To delete the airway intersections, you can choose to hide all the fixes on the map. 
 
Resending different elements of the same type replaces what is shown on the map.  For example, 
if you choose to view fixes for ZAB on the RMT Map and then choose to view fixes for ZDC on 
the RMT Map, RMT removes the fixes for ZAB and adds the fixes for ZDC to the RMT Map. 
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You can choose View > Reset Map to return the map to its default settings.  You can choose 
View > Clear Map to remove all overlays except the Country Map overlay on the RMT Map. 

 

View Playbook Plays on the Map 
Playbook Play segments are sent to the RMT Map in a different manner than CDRs.  General 
Play information is displayed in the top-level Query Results table on the Playbook Tool window.  
To see the detailed segment level routing information for each Play, select a Play in the Query 
Results table and then double-click or press the View Play button.  Playbook Play origin and 
destination segments can be shown on the RMT Map by pressing the Send to Map button from 
the View Play window. 
 
You may send the entire Play (all origin and destination segments) or selected Play segments to 
the RMT Map.  To send the entire Play, first verify that no segments are highlighted in either the 
origin or destination tables.  Press the Deselect All button to clear any segments that may be 
highlighted.  Click the Send to Map button on the View Play window.  Then click the title bar of 
the RMT Map window or select Window > RMT Map to view the Play segments.   
 
To send selected segment(s) to the map display, select the segment(s) you wish to view on the 
RMT Map (see “Selecting Records in the Query Results Table” on page 47).  The segments(s) 
should be highlighted.  Click the Send to Map button on the View Play window.  It is important 
to note the behavior when viewing split Plays, if you select an origin segment and do not specify 
a destination segment; all matching destination segments are displayed.  The segments match if 
the last element in the origin segment is the same as the first element in the destination segment.  
If you select only a destination segment, all corresponding origin segments are displayed.  
 
Please note that only one Playbook Play may be displayed on the RMT Map at a time.  The 
default color for Play segments is brick red.  The Playbook administrator may change the color 
(and specify a starting and ending point) for specific segments.  RMT users may not change the 
color of the Play segments.  The Playbook administrator may also choose to draw/define an 
impacted area associated with a Play.  When Play segments are sent to the map, the impacted area 
is also displayed.  FAA users take note that you can also send the Playbook history records to the 
map. 
 
Multiple origins and destinations are shown by dashed lines between the origin or destination 
airports and the corresponding route segment on the RMT Map.  In the example below (Figure 
61), the DFW EAST 1 Playbook Play contains several route segments with multiple origin 
airports.  This Play also has an associated Impacted Area. 
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Figure 61: Multiple Origin Airports in Playbook Route Segments 

 
Click the Send to Map button to display the selected segments on the RMT Map. 
 

 
Figure 62: Playbook Route Segments with Multiple Origin Airports on the RMT Map 
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Remove Plays from the Map 
Several options are available to remove the Playbook Play segments from the RMT Map.  To 
delete an entire Play, right-click on the map near the Play segments and select the Remove 
Playbook Play option at the bottom of the pop-up menu.  All Play segments and associated 
impacted areas should disappear from the map.   
 
To remove a single Play segment or a specific group of segments from the map display, either 
click a single segment or Ctrl-click multiple segments on the map display so that the desired 
segment s are highlighted.  Press Delete on your computer keyboard.   
 
To clear all routes (including any CDRs, preferred routes or ad hoc reroutes showing on the map), 
select View > Clear Routes or right-click on the map and select Clear Routes.  
 

Map Customization Options  
Users can customize the RMT Map to meet their specifications.  RMT provides various options to 
manipulate the map display.   
 
Map Display Options 
To change the color and line style of the available RMT Map overlays, select Settings > Display 
Options.  This opens the Display Options window.  
 

 
Figure 63: Display Options Window 
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Every overlay is made up of lines that denote borders or routes; this is the layer portion of the 
overlay.  You can also choose to label the overlay.  You can change both the layers and the labels 
of an overlay using the Display Options window.  
 
To change the display attributes of a map overlay, select an overlay from the Map Layer List in 
the upper left of the Display Options window.  Note that airway intersections are considered 
"fixes" on the map.  To change the way the map displays airway intersections, select the overlay 
named Fixes.  Once you select an overlay, you can choose from the listed attributes to change the 
overlay appearance.  You must choose options for each overlay individually.  
 
• Line/Object Width - Click the arrow to reveal a pull-down menu of available line thickness 

values.  Click the desired thickness to change the overlay graphic. 
• Label's Font - Click the arrow to reveal a pull-down menu of available fonts.  Click the 

desired font for the overlay label. 
• Font Style - Click the arrow to reveal a pull-down menu of available styles.  Click the 

desired font style for the overlay label. 
• Font Size - Click the arrow to reveal a pull-down menu of available font sizes.  Click the 

desired font size for the overlay label. 
 
Color and Label Preview Section 
• Layer Color – Displays the color you have chosen for the Layer. 
• Font Type/Color – Displays the color you have chosen for the font. 
• Color Selection Applies To – Select whether you want the color you choose to apply to the 

Layer Only, Labels Only, or Both.  Next click a color tab to reveal a palette of colors for the 
overlay graphics and labels.  There are several color palettes available: swatches, HSB, and 
RGB colors. Click the desired color for the graphic or label.  The Display Options window 
will preview the color for you.  Continue selecting colors until you find a desired color 
scheme for your overlay. 

 
To view how your settings will look on the map, click the checkboxes on the top of the Display 
Options window marked Layer and Layer’s Labels.  Then click Preview.  To return the overlay 
settings to their original default values, click Reset.  
 
Additional Layer Properties 
Depending on the type of layer you have selected in the Map Layer List, different properties 
appear in the Additional Layer Properties area on the lower right of the Display Options window. 
 
Geographic Boundaries (e.g., Centers, Sectors, AFP FCAs) 
• Brush Type – Select a solid brush or a transparent brush. 
• Brush Color – Select the color you want to use for the brush (this is a different way to set the 

Layer Color).  Note that this field is only enabled when you select solid for the Brush Type. 
• Line Type – Select whether you want solid or dashed lines appearing on the map. 
• Dash Pattern – Select the pattern of the dashed line you would like to appear on the map.  

Note that this field is enabled only if you select dashed for the Line Type. 
• Show Nodes – Check to show the boundary definition points. 
 
Routes (e.g. CDRs, Preferred Routes, Ad Hoc Reroutes) 
• Labels Spacing – Select the distance between labels in terms of the number of waypoints or 

nodes (default value is 4). 
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• Show Nodes – Check to show the waypoints or nodes along the route.  
 
NAS Elements (e.g., Fixes, Navaids) 
• Point Type – Select what shape and fill type you want for the points on the map. 
 
ROG Map Layer 
When you select the ROG Map Layer from the Map Layer List, you can change colors for the 
following ROG Map Layer properties: 
 
• Area Layer – Select the color for graphic overlay of any defined Areas to Avoid/Go Through 

(defined through the ROG Find Options – Areas to Avoid/Go Through window) 
• Area Label – Select the color for the Area label. 
• Arrival Airports – Select the color for the labels and symbols of the arrival airports on the 

FEA/FCA flight list. 
• Departure Airports – Select the color for the labels and symbols of the departure airports on 

the FEA/FCA flight list. 
• Arrival/Departure Airports – Select the color for the labels and symbols of the 

arrival/departure airports on the FEA/FCA flight list. 
• FEA/FCA Layer – Select the color for the graphic FEA/FCA overlay. 
• FEA/FCA Label – Select the color for the FEA/FCA label. 
 
Click on the color box next to the property you would like to change to bring up the Color 
selection dialog.  You can change the font/size of the Area and FEA/FCA Label properties in the 
Color and Label Preview section.   
 
You can specify which of these elements are turned on/off from the ROG Tool Settings > ROG 
Map Settings menu option.   
 
Display Latitude/Longitude Grid 
Using the Map Display Options window, you can place a grid of latitude and longitude lines over 
the map.  If you want to change the appearance of the latitude/longitude grid, first bring up the 
Display Options window using Settings > Display Options.  Select the Latitude Longitude 
Grid from the Map Layer list, and then press the Grid Settings button in the Additional Layer 
Properties area.  This brings up the Latitude/Longitude Grid Settings window.   
 

 
Figure 64: Latitude/Longitude Grid Settings 
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Use the Latitude/Longitude Grid Settings window to enter new values for the Start, End, and 
Spacing of latitude and longitude lines on the map.  Changing the values will compress or expand 
the grid overlay on the RMT Map.  Depending on the type of analysis you are conducting, a 
smaller or larger grid overlay could be more beneficial. 
 
Display Range Rings 
Range rings are a set of concentric circles that you can place on the map for reference purposes. 
You can adjust the settings for the range rings, including the latitude and longitude point for the 
center for the rings, spacing between each ring (nautical miles) and the number of rings.  There 
are two ways to add new range rings to the map, you can either use the menu that appears when 
you right-click anywhere on the map or select Range Rings in the Map Layer List of the Display 
Options component.   
 
From the right-click pop-up menu, click Add Range Rings.  The Add Range Rings window 
appears. 
 

 
Figure 65: Add Range Rings Window 

The default value for the range ring center matches the location where you right-clicked on the 
map.  However, you can change the center (latitude/longitude) values to whatever values you 
would like.  You can also change the ring spacing and enter a new value for the number of rings 
that appear from the center. 
 
To remove a set of range rings, right-click near the center of the rings you wish to remove and 
select Remove Range Rings from the resulting menu. 
  
Alternatively, you can select Settings > Display Options.  The Display Options window appears, 
and then scroll down the Map Layer List to Range Rings.  From here you can adjust the look of 
the rings including the color of the rings and of the labels. 
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Figure 66: Adding Range Rings from Display Options 

To get to the Add Range Rings window from the Display Options window, click Add in the 
Additional Layer Properties section of the window.  The Add Range Rings window appears. 
 
You can adjust the settings for the range rings, including the latitude and longitude point for the 
center for the rings, spacing between each ring (nautical miles) and the number of rings.  When 
you have entered all of the values for the rings in the Add Range Rings window, click OK.  Once 
you finish choosing colors, a font, etc. for the rings from the Display Options window, click OK.  
The Range Rings appear on the RMT Map. 
 
Any range rings currently displayed on the map are listed in the Range Rings section.  Select a set 
of range rings and then click Remove to remove them from the map display using the Display 
Options window.   
 
Save Your Settings 
Once you customize the RMT Map, you probably want to save those display settings for your 
next RMT session.  RMT allows you to manually save any modifications made to the Map 
display.  Select Settings > Save Settings.  This will save the display settings to your local 
configuration file so that the Map will open exactly as you closed it. 
 
Displaying Overlays 
Certain default overlays in the RMT Map Tool are selected such that they will appear on the map 
automatically.  These are the coded departure routes, Playbook Plays, preferred routes, ad hoc 
reroutes, and miscellaneous routes.  The routes are always chosen so that when you choose the 
Send to Map option from the various tool windows, your queried routes will actually be displayed 
on the map.   
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You can customize the appearance of the RMT Map by choosing additional overlays (layers).  
For example, you can view sector boundaries, bordering countries, fixes, and jet routes on the 
map.  As well, you can choose to display the layer with a graphic, a text label, or both.  There are 
several ways to display the overlays. 
 
Note that the eighteen ‘canned’ AFP FCAs have been added to the RMT Map.  Both the ‘classic 
canned’ from 2006 (FCAA01 – FCAA06, FCAA08) and the eleven defined in 2007 are available 
as overlays. 
 
Choosing Overlays (Layers) Using Display Options 
You can choose to display overlays at the same time you are choosing the appearance of your 
overlays in the Display Options window.  Select Settings > Display Options to open the Display 
Options window.  When you click an option in the Map Layer List, the checkboxes in the top 
right corner of the window show the current status of that layer.  The checkboxes indicate 
whether the layer is visible, or only the labels are visible.   
 

 
Figure 67: Checkboxes in the Display Options Window 

 
If the layer is marked as not visible, you can select Layer to display layer on the map.  Repeat the 
process for any layer you want to display.  Likewise, to remove any layer from the map, select the 
layer name in the Map Layer List and deselect the checkbox marked Layer.  To see what the map 
looks like with your custom layers, click Preview on the Display Options window.  When you are 
satisfied with the map appearance, click OK on the Display Options window to close the window 
and display the map with your custom layers. 
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Using Show/Hide Overlays 
Select View > Show/Hide Overlays or right-click on the map and select Show/Hide Overlays 
for a quick view of your overlay filtering options. The Show/Hide Overlays window appears 
with the subset of overlays that can be filtered and added to the map. 

 

Figure 68: Show/Hide Map Overlays 

To display an overlay, click the box under the Layer column next to the overlay name so that 
there is a checkmark in the box.  This will force the layer graphic to appear on the map when you 
click OK.  To view the labels in addition to the graphics make sure that the boxes under the 
Layer and Labels columns are both checked.  Likewise, to hide an overlay on the map, click the 
box next to the overlay name in the Layer column to uncheck it.  The overlay should disappear 
from the map. 
 
Once you check the desired overlays to display on the map, you can click Preview to see what 
your map will look like with the overlays.  You can then change any of your selections.  Click 
OK when you are satisfied with the results.   This will close the Show/Hide Overlays window and 
display your selected overlays on the map.  To close the window without taking any action, click 
Cancel. 
 
Filtering Overlays 
Using overlay filters, you dictate specific elements within the overlay to view on the map.  For 
example, when you choose to display fixes as an overlay, all fixes within the United States will 
appear on the map.  Using a filter, you can choose to display only specific fixes. 
 
Select View > Show/Hide Overlays to apply filters to your overlays.  The Show/Hide Overlays 
window appears (see Figure 68). 
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You should see a column titled UseFilters.  This column provides a text field in which you will 
type the specific filter values for an overlay.  To apply a filter to an overlay, first type the name of 
the specific overlay element(s) you wish to view.  For example, type PETTY and WISKE in the 
UseFilters column's text field on the Fixes row.  You can use a wildcard symbol (*) to enter non-
specific data points in the UseFilters text fields.  Note that each element must be separated by a 
space.  You must click the UseFilters checkbox to the left of the text field to actually apply the 
filters.  When this box is checked the RMT Map will only display the items you defined in the 
UseFilters text column.   
 

 
Figure 69: Show/Hide Overlay Filters 

When you type in filters, you must have the box next to the UseFilters column checked.  If the 
box is not checked, the map will show all the elements for that particular overlay.  You can keep 
the filters saved in the Show/Hide Overlays window, but choose when to display the filtered 
information by selecting or clearing the box next to UseFilters field for a specific overlay. 
 
To preview the map display with your filtered overlays, click the Preview button.  Once you 
choose which overlays to display with filters, click the OK button to close the window and return 
to the RMT Map. 
 
Note that warning messages have been added into the Map Tool that notifies you if an element is 
not found and can not be shown on the map.   
 
To save your filters for your next RMT session, select Settings > Save Settings.  This will save 
any filters typed in the Show/Hide Overlays window. 
 
To clear the filters you have entered for an overlay, click the filter with your mouse and click 
Delete on your keyboard.  
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Display Single Overlay Elements  
You can type in a group of different, specific overlay elements to view or delete on the map.  This 
provides a shortcut to typing in filter values separately for each type overlay element.  Using the 
Show Overlay Elements option, you type in a string of overlay elements to display on the map.  
The values can include elements from different overlays.  For example, if there is a specific set of 
centers, airports, and navaids you wish to view, use the Show Overlay Elements window to type 
the codes for the different overlay elements all at once. 
 
Click Ctrl+S or select Show Overlay Elements from the View menu or the pop-up menu that 
appears when you right-click on the map.  The Show Overlay Elements window appears (Figure 
70).  

 
Figure 70: Show Overlay Elements Window 

Type any specific fixes, airports, navaids, centers, jet or victor routes, tracons and AFP FCAs you 
want to see on the map into the Overlay Elements field.    Each element is independent of the 
others and should be separated by a space.  Any overlay entity that you choose to show will 
automatically show up in the Filters section of the Show/Hide Overlays window.   
 
Note that warning messages have been added into the Map Tool that notifies you if an element is 
not found and can not be shown on the map.   
 
Please note that you cannot use wildcard characters (*, ?) in the Overlay Elements field.  To 
differentiate between a navaid and airport code, you may prefix navaid codes with a plus symbol 
(+) and airport codes with an “at” symbol (@).  Otherwise, if a navaid and an airport share the 
same 3-character identifier, both will appear on the map.   
 
For example, in Figure 71, the user has entered "@ord j80 bos."  ORD is specifically identified as 
an airport by the "at" symbol (@).  However, notice that BOS appears on the map as both an 
airport and a navaid because the type is not specified.  You cannot currently enter U.S. State 
names, Canadian Provinces, Caribbean Islands or Mexican States using Show Overlay Elements.  
However, you can add these to the map using the Show/Hide Overlay elements window and the 
filters field contained within that window. 
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Figure 71: Overlay Elements Displayed on the Map 

 
Display Miscellaneous Routes 
You can define a custom or miscellaneous route and then display the route on the map.  Select 
Show Miscellaneous Routes from the map's View menu or from the menu that appears when 
you right-click on the map to bring up the Show Miscellaneous Routes window.  In the Route 
String field, type in any combination of elements that defines your route.  The elements should be 
in the order you want the route to appear from start to finish.  The RMT Map will connect the 
route elements graphically according to the order in which they are typed.  Once you have typed 
in your route, click Show to see the route on the map (Figure 72).  Note that partial route 
segments may be shown that begin at a navaid or fix. 

 

 
Figure 72: Miscellaneous Route String 

In Figure 72, one of the ZNY segment from the ‘NO J48 2’ Playbook Play is used to define a 
miscellaneous route.  Click on the miscellaneous route segment itself to show the navaids and 
fixes along the route string.  
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Using Quick Keys 
Several map overlays can be toggled on/off using the following shortcut or Quick Keys:   
 
• Jet Airways    J 
• Victor Airways   V 
• ARTCC Boundaries   A 
• ARTCC Sectors – High  H 
• ARTCC Sectors – Low  L 
• ARTCC Sectors – Superhigh S 
• ARTCC Sectors – Oceanic  O 
• Navaids – High   Shift F4 
• Navaids – Low   Shift F5 
• Navaids - Terminal   Shift F6 
• Fixes – Arrival   Shift F2 
• Fixes – Departure   Shift F3 
• Fixes – En route    Shift F8. 
 
For example, when using the jet airway Quick Key (J), all jet airways will be turned on/off.  To 
display specific elements use either the View > Show Overlay Elements or View > Show/Hide 
Overlays menu options.   
 
The labels for these overlays can be turned on/off through the View > Show/Hide Quick Key 
Overlays menu option or right-clicking anywhere on the map and selecting Show/Hide Quick 
Key Overlays.  This brings up the Show/Hide Quick Key Overlays window.  The labels are 
turned off by default and can be turned on by clicking the labels box in the appropriate row.  You 
can change the colors of the overlays through Settings > Display Options.  

 

Figure 73: Show/Hide Quick Key Overlays Dialog 
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Zooming In and Out on the RMT Map  
You can focus on specific areas of the map using the RMT Map's zoom feature.  To Zoom In, 
click on the map in the upper-left portion of the area you would like to see.  Using your mouse, 
click and drag down and to the right, creating a rectangle.  
 
Release the mouse when you have enclosed the desired area within the rectangle.  The area within 
your rectangle will be enlarged to the size of the RMT Map Tool window.  In Figure 74 the user 
has zoomed in near ORD and MDW airports. 
 

 
Figure 74: Zoom-in View 

To Zoom Out, simply reverse the process.  Click and drag up and to the left from the lower right 
corner of an area. 
 
Release the mouse to complete the zoom out process. The degree to which the map zooms out is 
proportional to the size of the rectangle you draw.  Larger rectangles will display a larger portion 
of the map in the map Tool window. 
 
To undo the last zoom action you performed, right-click anywhere on the map and click Undo 
Zoom from the menu.  Or select View > Undo Zoom. 
 
To redo the last undo zoom action you performed, right-click anywhere on the map and click 
Redo Zoom from the menu.  Or select View > Redo Zoom. 
 
To reset the map to its original size, right-click anywhere on the map and select Reset Zoom or 
select View > Reset Zoom.  
 
Several Quick Keys are also available for zooming in and out and moving the center of the map 
display: 
 
• Zoom Z 
• Unzoom U 
• Move M. 
 
Press Z, U, or M anywhere on the RMT Map to change your display.   
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Scrolling on the Map 
To scroll in any direction on the map, position the cursor on a start point.  Click with the middle 
mouse button and drag the mouse to an end point. Once you release the mouse, the map scrolls to 
the new location. You can also scroll on the map by simultaneously holding the right and left 
mouse buttons.  
 

Clear the Map 
To remove all overlays and routes and return your map to its original size, you can clear your 
map display(s).  Clearing the map will clear the map and return the display to its original setting, 
with no overlays.  To reset the map, select View > Clear Map or right-click on the map and 
select Clear Map from the pop-up menu. 
 

Reset the Map 
Select View > Reset Map or right-click on the map and select Reset Map from the pop-up menu 
to return your map display to its default settings. 
 

Print the Map 
To send the RMT Map in view to your local printer, select File > Print.  Any overlays such as 
center boundaries, fixes, routes that are displayed on the map will also be printed on the map.  
Only one Play can be printed at a time. 
 

Save the Map 
You can save your map display as a GIF or JPG image.  These images can be opened later in any 
program capable of displaying a graphics file.  To save your map image, select File > Save As 
GIF or File > Save As JPG.  Select the directory in which you want to save the file and enter a 
name for a file.  
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Route Options Generation 
The ROG Tool allows you to view information from both a flight-specific and a broader system-
level constraint perspective.  Using the ROG Tool's flight-centric workspace, you can identify 
pre-coordinated reroute options for specific flights that avoid an FEA or FCA.  ROG allows 
Customers to find reroute options and format them for submission to the system for their flights 
affected by an FEA/FCA.  Note that Customers are only able to see their own flights (i.e., NWA 
can only see NWA's flights).  Preferences are submitted as Early Intent (EI) messages to ETMS.  
The constraint-centric workspace allows you to characterize the constraint by providing enhanced 
flight list grouping and mapping capabilities.  ROG also allows traffic managers to identify 
reroute options for flights that do not submit EIs and provides decision-support for developing 
route guidance and building reroute plans using Playbook Plays.  The ROG Tool integrates with 
the RMT Map to display the relevant information, e.g. FEA/FCA definition, flights on the flight 
list, and available reroute options.   
 
You can use the ROG Tool to: 
 

• Examine FEA/FCAs and the associated dynamic flight lists 
• Find and filter reroute options that avoid FEA/FCAs for specific flights 
• Group flights to characterize and better understand the problem or constraint 
• Select (or assign) reroutes for flights on the flight list 
• Track the progress of flight/reroute selections and send EI messages 
• Create route guidance using the Reroute Planner (FAA traffic managers). 

 
Note that you can see public FEA/FCAs and shared FEAs with ‘_ICR’ in the name and the 
associated filtered flight lists (not including military or sensitive flights).  Shared FEA/FCAs are 
visible to users on the shared site list. 
 

Main ROG Tool Window 
The main ROG Tool window is divided into five areas:  the ROG Tool Bar, the FCA/Query 
Header area, the Grouping Results table, the Grouping Summary and the Matches Summary 
areas. 
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Figure 75: ROG Main Window 

 
These areas are described in detail in the sections below.   
 
ROG Tool Buttons 
The following buttons appear on the ROG Tool Bar: 
 
• Load FEA/FCA - allows you to load FEA/FCAs into the ROG Tool. 
• Find Options - allows you to find reroute options around the specified FEA/FCA. 
• Group Flights - allows you to group flights in several ways to better assist you in analyzing 

the flights in the FEA/FCA. 
• Assign Reroutes - allows you to examine and select (or assign) reroute options for specific 

flights. 
• Flight Summary - allows you to track the progress of flights/reroutes as they are assigned 

and send EI messages. 
• Reroute Planner (FAA only) – allows you to develop route guidance or reroute plans. 
 
Five (or six) buttons appear on the ROG Tool Bar depending on your user type.  Note that these 
functions can also be accessed through the File menu.  The capabilities are described in detail in 
the sections below.   
 
FCA/Query Summary 
The FCA/Query Summary area provides information on the FEA/FCA loaded into the tool and 
the latest query run.  The ADZ button displays the associated advisory (if one has been issued for 
the FEA/FCA).   
 

Grouping Results 
Table 

Grouping Summary 

FCA/Query 
Summary Area 

ROG Tool Bar 

Matches Summary 
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The FEA/FCA Summary line provides information about the FEA/FCA you loaded into the 
ROG Tool (see the “Loading the FEA/FCA Definition and Flight List” section on page 80).  Note 
that you must first load an FEA/FCA into the ROG Tool for these fields to appear/populate.  This 
area provides you with information on the following: 
 
• FEA/FCA Summary - Name of the FEA/FCA you loaded. 
• Data Time - Date and time you loaded the data (MM/DD/YY HH:MM). 
• Start Time – FEA/FCA start time (MM/DD/YY HH:MM). 
• End Time - FEA/FCA end time (MM/DD/YY HH:MM). 
• Alt - Altitude range controlled by the FEA/FCA. 
• AFP Status – FSM is displayed if the FEA/FCA is FSM-eligible. 
 
Note that all times listed are GMT. 
 
The Query Summary line provides information about the latest reroute option query you ran (see 
“Finding and Filtering Reroute Options” on page 81).  The following information is included: 
 
• Query Summary - Shows what types of routes you included in your query (CDRs, Plays, 

Preferred Routes, Ad Hoc Reroutes). 
• Filters - Shows what filters you applied in your query (Areas, NAS Elements, etc.) 
 
The ADZ button allows you to view the associated FEA/FCA advisories for the FEA/FCA 
definition and flight list currently loaded into the ROG Tool.  Note that the ADZ button does not 
appear until you have loaded an FEA/FCA into ROG.  RMT imports the FEA/FCA Advisories 
from the OIS Advisories database based on the FEA/FCA name.  If multiple advisories are 
available for an FEA/FCA, the last entered appears in the FEA/FCA Advisory dialog displayed 
by the ROG Tool.  If there are no advisories available for the FEA/FCA or if the OIS database is 
unavailable, you receive a warning message from RMT. 
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Figure 76: FEA/FCA Advisory Window 

 
Grouping Results Table 
The Grouping Results table includes a listing of all the flights affected by the FEA/FCA and 
arranges them according to how you group the flights.  This section works in a standard Windows 
tree format.  Note the default flight grouping is by city pair and you can group by up to three 
categories.   
 
You will see a row in the Grouping Results table for each flight grouping along with the flight 
count for that grouping.  Once a query has been run, the number of reroute options by route type 
for each grouping is also provided.   
 
Grouping Summary 
The Grouping Summary provides you with information about the current grouping criteria 
applied to the flight list and the number of groups for the criteria selected.  For example, “5 
DCNTR; City Pair” in the Grouping Results line means there are 5 different departure centers 
with flights on the flight list and the data is grouped first by departure center and then by city pair. 
 
Matches Summary 
The Matches Summary at the bottom left of the window shows the number of City Pairs and 
Flights in the FEA/FCA flight list.  The numbers in parentheses are the City Pairs and Flights that 
have matching reroute options that avoid the FEA/FCA.  Note that the number of matches in 
parenthesis will be zero until you run your query. 
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ROG Mapping Capabilities 
The ROG Tool integrates with the RMT Map to provide a graphical display of the relevant 
information, e.g. FEA/FCA definition, flights on the flight list, and available reroute options.  The 
ROG Map Settings window allows you to control how you view the information from the ROG 
Tool on the RMT Map. 
 
When you load an FEA or FCA into ROG, the FEA/FCA definition and the departure and arrival 
airports for the flights on the flight list are automatically sent to the RMT Map. 
 

 
Figure 77: ROG Map Settings Window (Default Settings) 

FEA/FCA Map Settings 
The FEA/FCA Map Settings area allows you to adjust how the FEA/FCA appears on the RMT 
Map.  When you select the FEA/FCA Layer checkbox, the layer containing the FEA/FCA 
appears on the RMT Map.  When you select the Label checkbox, the text label for the FEA/FCA 
appears on the RMT Map.  Note that if you uncheck the FEA/FCA Layer checkbox, the Label 
option will be disabled. 
 
Flight List Map Settings 
The Flight List Map Settings area allows you to determine which flight list options you want to 
see on the map.  When you select the Flights (Current Route) checkbox, the flight tracks for all 
flights on the flight list appear on the RMT Map.  Note that if a flight has been amended en route, 
the flown portion of the route (before the tailoring indicator, ./.) will be shown as a dashed line.  
When you select the Arrival Airports checkbox, the arrival airports for flights on the flight list 
appear on the RMT Map.  Note that the color of the Arrival Airports text matches the color of 
the arrival airports on the RMT Map.  The Arrival Airports checkbox also has a Flight Count 
associated with it.  Selecting this checkbox causes the arrival flight count for each arrival airport 
to appear on the map.  When you select the Departure Airports checkbox, the airports with 
departures on the flight list appear on the RMT Map.  Note that the color of the Departure 
Airports text matches the color of the Departure airports on the RMT Map.  The Departure 
Airports checkbox has a Flight Count associated with it.  Selecting this checkbox causes the 
departure flight count for each departure airport to appear on the map.  RMT automatically selects 
the Arrival & Departure Airports check box when you select both the Arrival Airports and 
Departure Airports checkboxes.  Note that the color of the Arrival & Departure Airports field 
matches the color of the Arrival and Departure airports on the RMT Map.  Note that the Flight 
Count fields will be disabled when the associated Airports checkbox is unchecked. 
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The selections you make appear immediately on the RMT Map as you make them.  To apply the 
current settings and close the window, click OK.  If you would like to change your default ROG 
map settings, click Save Settings.  This saves the information to your local configuration file.  If 
you click Cancel, the ROG Map Settings window closes without changing your ROG map 
settings. 
 
Colors for most of the settings can be changed using the Map Settings > Display Options.  For 
more information on how to use the Display Options window see the Map Customization 
Options and ROG Map Layer section of this guide (page 64). 
 

Loading the FEA/FCA Definition and Flight List 
You must first select a constraint of interest before you can perform reroute searches, assign 
reroutes, etc.  You can examine public FEA/FCAs and shared FEAs with ‘_ICR’ in the name that 
are active in the system.  Access to the shared FEAs is based on your user login and the shared 
sites list.  It is important to note that Customers can only see their own flights.  FAA users can see 
flights for all carriers (military and sensitive flights are NOT included).     
 
NAS Element – Airport type FEA/FCAs are not meaningful in ROG.  Airport FEA/FCAs are 
defined to include arrivals or departures to the specified airport.  ROG can not find options that 
avoid the airport for those flights.  Also note that NAS Element - SUA type FEA/FCAs are 
currently not supported in RMT (the latitude/longitude data is not available).  If there is an 
Airport or SUA FEA/FCA in the system, it will be grayed out in the list of FEA/FCAs.   
   
It is important to note that the flight lists loaded into ROG contain a snapshot of the flight list at 
the time it is loaded into ROG (Data Time listed in the FEA/FCA Summary line).  The FEA/FCA 
definitions and associated flight lists are updated every five minutes through a background 
process.  If you reload the constraint into RMT, you will get the latest updated file available at 
that time.   
 
Some FEA/FCAs may be very long in duration and could have thousands of flights on the 
associated flight lists (e.g., AFP FCAs).  Please be aware that it will take some time to process the 
larger flights lists as they are loaded into the ROG Tool and the RMT Map.        
 
Using the Select ETMS FEA/Flight Info Window 
To load an FEA/FCA definition and the associated flight list, click the Load FEA/FCA button in 
the ROG Tool Bar (or File > Load FEA/FCA).  This brings up the Select ETMS FEA/Flight 
Info window that shows a list of all active FEA/FCAs in the system (Figure 78).  Summary 
information about the FEA/FCA is provided in the window to help you select the constraint of 
interest: 
 

• Name - the name of the FEA/FCA. 
• Domain - PUBLIC or SHARED.   
• Type – FEA, FCA or EXPIRED. 
• Format - the type of FEA/FCA (i.e., polygon, line, circle, NAS Element). 
• AFP Status – FSM if the FEA/FCA is FSM-eligible or AFP if there is an active AFP. 

 
Note that if an FEA/FCA is pending (current time is prior to the FEA/FCA start time), the name 
is shown in italics.  The Show column contains a checkbox; select the checkboxes in the column 
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for any FEAs/FCAs you want to show on the RMT Map.  The active FEA/FCA count is also 
shown.   

 

Figure 78: Select ETMS FEA/FCA Info Window 

Click OK to load the selected FEA/FCA and close the window.  When your file begins loading, 
the Progress and Status fields reflect what is occurring with the upload.  When you click Refresh, 
ROG updates the list of available FEAs/FCAs and clears the checkboxes in the Show column.  
Click Cancel to quit the operation without starting the import.   
 
Once RMT has loaded the files successfully, the FEA/FCA Summary line on the main ROG 
window is filled in with the appropriate FEA/FCA information (Name, Data Time, Start Time, 
End Time, Altitude, AFP Status indicator).  Additionally, RMT populates the Grouping Results 
table with flights on the dynamic flight list.  Note that flights entering/exiting the FEA/FCA more 
than once are only listed once in ROG.  The entry time displayed is the earliest entry time; the 
exit time is the last exit time.     
 

Finding and Filtering Reroute Options 
You can use the Find Options component of the ROG Tool to find reroute options around the 
specified FEA/FCA for the flights on the flight list.  RMT searches several pre-coordinated route 
databases including Preferred Routes, CDRs, Playbook Plays, and the ad hoc reroutes (user-
defined).  The Find Options component provides various filtering capabilities to narrow the list of 
potential options for each flight (or city pair).  The route databases are then queried to bring up 
the flight and route option details to help make the reroute selections or assignments. 
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Using the Find Options Window 
To find and filter reroute options for your flights, click Find Options on the ROG Tool Bar (or 
File > Find Options).  The Find Options window appears. 
   

 
Figure 79: Find Options Window 

Available Route Types 
Select the databases you would like to search.  The available Route Types are: 
 
• Pref Routes - Preferred IFR routes. 
• CDRs - Coded departure routes. 
• Plays - Playbook Play segments. 
• Ad Hoc Reroutes – Ad hoc reroutes created by users (both FAA and Customers). 
 
Note that you can select multiple route types.  When you run your query, the database(s) selected 
will be filled in the Query Summary line on the main ROG window.  Note that the ROG Tool 
searches the operational route databases (routes effective for the current 56-day chart cycle).   
 
Route Options Filters 
If you would like to narrow the number of reroute options you receive from your query, select 
one (or more) of the Route Option Filters.   
 
You must select one filter from the left column (radio buttons).   
 
If you select Include all options that avoid FEA/FCA, ROG retrieves all options from the route 
types selected that avoid the constrained area.   
 
If you select Within: miles of FEA/FCA, you need to enter the number of nautical miles in the 
text box.  This returns all options that come within the specified number of miles of the 
constraint.  For example, if you enter 50 miles, ROG returns all routes that come within 50 miles 
or less of the FEA/FCA boundary.  Note that you will see a 50 nm transparent border around the 
constraint on the RMT Map.  Note that the maximum value for this parameter is 500 nm (RMT 
will reset any values greater than 500 entered into this field to 500.   
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If you select Max of: options closest to FEA/FCA, you need to enter the maximum number of 
routes per Route Type you want returned in the text box.  ROG will return (at most) the number 
of options you requested that are closest to the FEA/FCA boundary for each route type selected.  
In the example shown in Figure 79, ROG retrieves the 2 CDR and Play segments closest to the 
FEA/FCA boundary.  Note that there may not always be 2 options for each route type that avoid 
the FEA/FCA for each flight (or city pair). 
 
If you select Max of: shortest options, you need to enter the number of routes per Route Type 
you want returned in the text box.  ROG retrieves (at most) the number of options you requested 
that are the shortest and that avoid the borders of the FEA/FCA.  For example, if you enter 5 in 
the text box, ROG retrieves the 5 shortest routes that avoid the FEA/FCA for each route type 
selected.  Note that there may not always be 5 options for each route type that avoid the 
FEA/FCA for each flight (or city pair). 
 
You can use the filters in the right column as necessary based on the current situation, your 
business objectives and flights of interest.  All filters in the right column allow you to use the 
“and” (&), “or” (|) and “not” (!) logical operators to specify combinations of filters.   
 
If you select the Elements checkbox, you need to enter the NAS element identifier in the text 
field.  You can enter fixes, navaids, jet routes, etc. that are included or excluded from the route 
string of the reroute options.  In Figure 79, all options avoiding the FEA/FCA that do not include 
WISKE on the route string are retrieved (“! WISKE”).   
 
If you select the Centers checkbox, you need to enter the Center identifier (ZDC, ZAB, etc.) that 
the route options should avoid or go through.  In Figure 79, all options avoiding the FEA/FCA 
that go through both ZAU and ZMP are retrieved (“ZAU & ZMP”).   
 
If you select Sectors, you need to enter the sector identifier (ZTL20, ZDC50, etc.) that the route 
options should avoid or go through.  In Figure 79, all options avoiding the FEA/FCA that go 
through either ZLC41 or ZLC42 are retrieved (“ZLC41 | ZLC42”).   
 
Areas to Avoid/Go Through 
You can also find reroute options that avoid or go through an ‘Area’.  An area could be one of the 
eighteen static AFPs or you can define your own area based on the current situation.  For 
example, you may want to avoid a second area of thunderstorms or only show options going 
north of the constrained area.   
 

 
Figure 80: Find Options Avoiding or Going through AFP FCAs  
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For example, if you type FCAA02 in the Area(s) text field and click the Areas checkbox, only 
reroute options will be returned that go through FCAA02.  If you type “! FCAA05” (or NOT 
FCAA05) in the Areas text field, only options that avoid FCAA05 will be returned.   
 
To define your own Area, you need to click on the ellipsis (...) button after the Areas text field.  
The Areas to Avoid/Go Through window appears.  You can query for existing areas or create a 
new one if existing options do not meet your needs. 
 
 

 
Figure 81: Areas to Avoid/Go Through Window 

Enter a name (or part of the name) in the Area Name field.  Click Query with the Area Name 
field blank to show all areas saved in your local database.  Click Show to display any existing 
areas on the RMT Map. 
 

 

Figure 82:  Saved Areas to Avoid/Go Through 
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If you click New to create a new area, the Area Editor appears.  Give the area a name, and click 
the Map button to start drawing the area.   
 

 
Figure 83: Area Editor 

The Area Editor sends you to the RMT Map.  Click to set a starting point and then continue 
outlining your area with single clicks.  Once you have selected the final point, double-click to 
close the polygon.  This selects the area's coordinates from the map and sends them to the 
Coordinates field of the Area Editor.  Click OK to complete your area definition.  The new area 
appears in the List of Area(s) in Local DB section of the Areas to Avoid/ Go Through window.  
You can also Update or Delete the areas you have created in your local database.  Double-click 
the area name for the area (or areas) you want to use in your current reroute option query.  The 
Area(s) you selected will appear in the Areas text field on the Find Options window.  Click Close 
when you finish creating or editing Areas. 
 
Run the Reroute Option Search 
Once you have selected the route database(s) to search and finished entering any filtering criteria, 
click Query to begin the reroute option search.  Clear resets any data you have entered in the 
Find Options window and clears the Query Summary and Grouping Results table.  Reset returns 
the Find Options window to its default state.  Click Close to close the Find Options window 
without running a query.  You will see a Query Status bar at the bottom of the main ROG 
showing the status of your route option query.  Click Cancel to cancel your query. 
 
ROG lists the results of your query and filtering in the Grouping Results table and populates the 
Query Summary line with the route type information and any filters applied.  The reroute options 
found by route type are listed in the Grouping Summary area on the main ROG window.  Any 
centers, sectors, NAS Elements or area filter criteria are displayed on the map along with the 
potential reroute options.  
 

Grouping Flights 
The Group Flights component in the ROG Tool enables you to analyze the FEA/FCA, flight list 
and available reroute options.  You can group flights and reroute options by up to three 
categories.  The default flight grouping is by city pair. 
 
Using the Group Flights Window 
To group flights in the ROG Query Results table, click Group Flights (or File > Group Flights).  
Then select the first criterion by which you want to group the flights from the drop down box 
under Group By. 
 



86 

 
Figure 84: Group Flights Window (Default Settings) 

You can group the flight list by the following criteria: 
 

• City Pair - Origin and destination airport. 
• Orig - Origin airport. 
• Dest - Destination airport. 
• DCNTR - Departure center. 
• ACNTR - Arrival center. 
• Status – Flight status; note that this category is ordered by the progression of a flight, S 

(Scheduled), R (Historical replaced by assigned route), N (Early Intent), P (Proposed), T 
(Taxi), A (Active-ETD is actual Departure Time), and E (Active ETD is estimated 
Departure Time). 

• Airline - Airline code (note that GA flights beginning with N are listed in a ‘GA’ group). 
• Matches/No Matches - Flights that do or do not have reroute options that match the last 

query run. 
• Arrival Time Bin - 15, 30, or 60 minute arrival time bins.   
• Departure Time Bin - 15, 30, or 60 minute departure time bins. 
• Flight Stage Length - Length of flights in nautical miles (nm).  The default length. 

grouping is 500 nm.  Note that the flight stage length is estimated by the RMT trajectory 
maker.   

 
Select whether you want the results displayed in Ascending or Descending order.  If you have 
additional criteria by which you want to group the flights, select them from the two Then By 
fields and select whether you want them in Ascending or Descending order.   
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Figure 85: Group Flights Window with Three Grouping Criteria Selected 

 
Click Apply to see the results without closing the Group Flights window or OK to apply the 
grouping and close the window.  If you would like to change your default groupings settings, 
click Save Settings.  This saves the information to your local configuration file.  Note that if you 
click Reset, all groupings are reset to what has been saved to your local configuration file (city 
pair by default).  If you click Cancel, the Group Flights window closes without regrouping the 
flights in the Grouping Results table. 
 

Assigning Reroutes 
Once you have run a search to identify potential reroute options for your flights that avoid the 
constrained area, you can select (or assign) reroute options for specific flights using the ROG 
Tool's Assign Reroutes component.  This is part of the flight-centric ROG workspace that allows 
you to display detailed flight information along with pre-coordinated reroute options that avoid 
the FEA/FCA in both tabular and graphical format. 
 
Using the Assign Reroutes Window 
To begin selecting reroute options for flights, click Assign Reroutes from the ROG Tool Bar (or 
File > Assign Reroutes).  The Assign Reroutes window appears. 
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Figure 86: Assign Reroutes Window with Reroute Options for PHX-EWR Flights 

 
Note that the route databases that were included in your reroute option query are shown at the top 
of the Assign Reroutes window.  Route databases not included in the query are grayed out.  Note 
that you can show/hide tables that have been included in the current display by clicking the 
checkboxes. 
 
Select the city pair for which you want to reroute flights from the drop down box in the upper left 
hand corner of the window.  The flights on the FEA/FCA flight list for that city pair appear in the 
Flight(s) section.  Note that city pairs that do not have matches are designated in red in the drop-
down list.  The city pairs with at least one match are designated in black.  Once you have selected 
(or assigned) reroute options for all flights for a city pair, the city pair name is shown in green. 
 
The Assign Reroutes window is highly customizable.  Click the ellipsis (...) button next to the 
different route type table names to show/hide columns in the tables.  You can also move or resize 
columns as in other RMT tables.  Click Save Settings to save changes to your local configuration 
files.   
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The Flights table includes the following flight-specific information (default configuration) plus 
the Reroute Assignment Status (RS) indicator column: 
 

• ACID – Flight identifier. 
• Flt Status – Flight status; S (Scheduled), R (Historical replaced by assigned route), N 

(Early Intent), P (Proposed), T (Taxi), A (Active-ETD is actual Departure Time), and E 
(Active ETD is estimated Departure Time). 

• ETD – Estimated time of departure. 
• Entry – FEA/FCA first entry time. 
• Field 10 – Route string. 
• Length – Filed route length in nautical miles (calculated by the RMT trajectory maker). 
• ETE – Estimated time en route. 
• Actype - Aircraft type. 
• Alt - Filed altitude. 
• Spd - Filed speed. 
• TCNTRs - Traversed centers. 
• DCNTR - Departure center.  
• ACNTR - Arrival center. 

 
Several additional columns may be added through the Show/Hide Columns window (… button): 
 

• Orig – Origin airport. 
• Dest – Destination airport. 
• IGTD – Initial gate time of departure. 
• ETA – Estimated time of arrival. 
• Exit – FEA/FCA last exit time. 
• CTL Element – Control element. 
• CTD – Controlled time of departure. 
• CTA – Controlled time of arrival. 
• Fixes – Fixes in flight’s route. 
• Airways – Airways in flight’s route. 

 
You will see a table with route-specific information for each of the route types included in your 
reroute option query if there were matches of that type for the specified city pair.  The number of 
reroute options avoiding the FEA/FCA and the map display color is shown in the various table 
headers.  
 
The Preferred Routes table includes the following information for each option that avoids the 
FEA/FCA: 
 

• Name - Preferred route name (origin-destination-type-sequence number, RMT 
designated name). 

• Route String - Route elements (airports, navaids, fixes, jet routes) that make up the 
preferred route string. 

• Length – Preferred route length in nautical miles (calculated by the RMT trajectory 
maker). 

• Area - Preferred route area description. 
• Altitude - Preferred route altitude description. 
• Aircraft - Aircraft types that can use this route.  
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• Direction - Route direction limitations description. 
• TCNTRs - Traversed centers.  
• DCNTR - Departure center.  
• ACNTR - Arrival center.  

 
Optional columns include: 
 

• Orig – Origin airport. 
• Dest – Destination airport. 
• Hours1 - Effective times (GMT) for the route. 
• Hours2 - Effective times (GMT) for the route. 
• Hours3 - Effective times (GMT) for the route. 
• Type – Route type. 
• Seq - Route identifier sequence number.   

 
The CDR table includes the following information for each option that avoids the FEA/FCA: 
 

• RCode - CDR route code. 
• Route String - Route elements (airports, navaids, fixes, jet routes) that make up the CDR 

route string. 
• Length – CDR route length in nautical miles (calculated by the RMT trajectory maker). 
• CoordReq – The “Coordination Required Flag” indicating whether the CDR requires 

coordination when filed, values are Y for Yes - coordination is required or N for No - 
coordination is not required.  

• Play - Associated Play name. 
• DepFix - Departure fix. 
• TCNTRs - Traversed centers. 
• DCNTR - Departure center.  
• ACNTR - Arrival center.  
• NavEqp - Navigation equipment designator, values include 1- basic navigational routes, 

2 – routes which begin and/or end with RNAV DPs and STARs, 3 - routes which contain 
Q-route segments and/or pitch and catch points.   

• Warnings - Any warnings associated with the CDR. 
 
Optional columns include: 
 

• ModTime - Date and time the CDR was last updated (last Chart Date). 
• Orig – Origin airport. 
• Dest – Destination airport. 
• Remarks - Any remarks associated with the CDR. 

 
The Plays table includes the following information for each option that avoids the FEA/FCA: 
 

• Segment Name – Play segment name (Play name_orig-dest, RMT designated segment 
name). 

• Route String - Route elements (airports, navaids, fixes, jet routes) that make up the Play 
segment route string. 

• Length - Segment length in nautical miles (estimated by RMT and marked in red since 
Play segments are not defined end-to-end). 
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• Category - Playbook Category name, e.g. Airports, East to West Transcon Routes, South 
to Northeast Routes. 

• Impacted Area - Impacted area or flow for the Play. 
• Filters – Play segment filters. 
• TCNTRs - Traversed centers. 
• DCNTR - Departure center.  
• ACNTR - Arrival center.  
• Instructions - Any special instructions associated with the Play. 
• Remarks - Any remarks associated with the Play. 

 
Optional columns include: 
 

• Play Name – Playbook Play name. 
• Orig – Origin airport. 
• Dest – Destination airport. 
• Facilities Included - Facilities included or traversed by this Play. 
• Notes - Any special notes associated with this Play. 
• Comments - Any remarks associated with this Play. 

 
The Ad Hoc Reroutes table includes the following information for each option that avoids the 
FEA/FCA: 
 

• Name - Ad Hoc Reroute name. 
• Route String - Route elements (airports, navaids, fixes, jet routes) that make up the ad 

hoc reroute route string. 
• Length – Ad hoc reroute length in nautical miles (calculated by the RMT trajectory 

maker). 
• DepFix - Departure fix. 
• TCNTRs - Traversed centers.  
• DCNTR - Departure center.  
• ACNTR - Arrival center.  
• Warnings - Any warnings associated with the Reroute. 

 
Optional columns include: 
 

• ModTime - Date and time the ad hoc reroute was last updated. 
• Orig – Origin airport. 
• Dest – Destination airport. 
• Remarks - Any remarks associated with the ad hoc reroute. 
• ModInit - Initials of the person who modified the ad hoc reroute record. 
• ModUser - The user type of the person who modified the ad hoc reroute record.  

 
Select the flight (or flights) for which you want to assign the reroute.  You can use standard 
Windows Shift-click and Ctrl-click functionality to select multiple flights.  If you do not select a 
flight, then ROG assumes you want to assign the reroute to all of the flights for the selected city 
pair. 
   
The FEA/FCA definition, the flight’s current route (Field 10 route string) and the reroute options 
for the selected city pair are automatically sent to the RMT Map when you switch city pairs.  
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Note that if a flight has been amended en route, the flown portion of the route (before the 
tailoring indicator, ./.) will be shown as a dashed line.  Selecting a reroute option on the map 
displays the navaids, fixes and airports along the route string.  The associated row on the Assign 
Reroutes window is also highlighted for easier route selection.  If you would like to show a subset 
of reroute options on the map, select the routes of interest in the route tables, then click Send To 
Map. 

Select the reroute option you want to assign to the flight from the route tables and click Assign.  
The Reroute Assignment Status (RS) color changes to from yellow to green next to the flight.  
The information for the selected reroute appears in the Assigned Reroutes table.  Note that you 
can assign the same reroute option to all flights from the selected city pair at the same time, or 
you can select different reroutes for each flight. 
 

 
Figure 87: Assign Reroutes Window with Reroute Selected 

The Assigned Reroutes table includes the following information for each reroute option selected 
(or assigned) that avoids the FEA/FCA: 
 

• Reroute Name – Name of the selected reroute (e.g., CDR route code, Play segment 
name). 

• Reroute String - Route elements (airports, navaids, fixes, jet routes) that make up the 
reroute route string. 
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• Length – Reroute length in nautical miles (calculated by the RMT trajectory maker). 
• Diff Length – Difference between the reroute length and the original filed route length 

(reroute length – filed length). 
• ETE – Estimated time en route for the reroute (estimated by RMT). 
• Diff ETE – Difference between the reroute ETE and the original filed route ETE (reroute 

ETE – filed ETE as calculated by RMT). 
• Type – Route type of the selected reroute (e.g., CDR, Play, Preferred Route or Ad Hoc). 
• Alt – Reroute altitude. 
• Spd – Reroute speed. 
• ETD – Reroute estimated departure time. 

 
If a flight(s) does not have any pre-coordinated options that avoid the FEA/FCA, you can edit the 
filed route or create an ad hoc reroute for that flight.  You can also edit the assigned reroute 
information if necessary.  To edit the flight’s filed route, first highlight the flight record in the 
flights table and click Assign (you need to assign a reroute before you can edit it).  You will then 
see the flight’s filed information in the Assigned Reroutes table.  Note that the RMT-designated 
Reroute Name for a reroute created from the flight record is ACID_FLT.  If you change the 
altitude the Reroute Name changes to ACID_ALT, if you change the reroute string it becomes 
ACID_RTE, or ACID_COMB if both are changed.    
 
Once a reroute has been assigned to a flight, click the Edit button in the Assigned Reroutes 
section and the Reroute Editor appears.  From here you can manually adjust the flight or reroute 
option data.  You can edit the reroute name, filed altitude and reroute string.  Note that if the 
FEA/FCA has a floor and ceiling, you can file over or under the constraint.  RMT verifies that the 
new reroute avoids the constrained area and provides warning messages if there are problems 
with the reroute.  When you finish editing the reroute, click OK to accept the changes.   
 

 
Figure 88: Reroute Editor 

If the reroute selected is a Play segment, you may see ‘…’ in the route string field.  This indicates 
that part of the route may need to be filled in.  Fill in the missing piece of the route or remove the 
‘…’ if not applicable.  Also note that if the flight record is active and has been amended en route, 
you will see the tailoring indicator ‘./.’ in the route string. 
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Note that clicking Reset returns the reroute's data to its original values if you have changed them 
manually; clicking Cancel closes the editor without changing the reroute data.  
 
If you decide that the reroute option you have chosen is not the best for the flight, you can select 
the flight and click Unassign to remove the reroute from the flight.  You have to remove an 
existing assigned reroute from a flight first in order to assign a different reroute to the same flight.  
When you have finished selecting (or assigning) reroutes to flights, click Close.   
 

Tracking Flight/Reroute Selections Using Flight 
Summary 
You can use the Flight Summary component to track the progress of flights/reroutes as they are 
assigned.  The Flight Summary window provides a listing of all the flights you are permitted to 
see and shows which flights have reroutes selected for them and which do not.  Flights with the 
Reroute Assignment Status (RS) field colored yellow do not have a reroute assigned to them.  
Flights with the RS field colored Green have a reroute assigned to them.  Customers can submit 
EI messages directly from the Flight Summary window to ETMS.   
 
Using the Flight Summary Window 
To track flight/reroute selections, click Flight Summary (or File > Flight Summary).  The 
Flight Summary window appears.  The top section of the panel shows the same FCA/Query 
summary information as the main ROG panel.  The flight list shows all flights included in the 
current FEA/FCA flight list file.  The flight data can be sorted by double-clicking on one of the 
column headers, and you can resize and rearrange the columns just like the other RMT Tool tabs. 
 

 
Figure 89: Flight Summary Window 
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Select a flight and click Assign or double-click to assign a reroute.  This takes you to the 
Assigned Reroutes window for the specified flight.  Select a flight and click Unassign to remove 
an assigned reroute.  See the “Assigning Reroutes” section for more information.  Note that you 
can use standard Windows Shift +click and Ctrl +click functionality to select multiple flights at a 
time for the “Send to Map” or “Unassign” functionality.   
 
The bottom left corner of the Flights section shows you how many flights traverse the FEA/FCA 
and the number of flights for which you have assigned reroutes. 
 
Click Send To Map to view the selected flights and the assigned reroutes on the RMT Map.  
Note that you will see other elements on the map based on your default ROG map settings.  If you 
want to save your flight/reroute selections for later reference, click Save, navigate to the location 
where you want to save the file and enter a name for the file in the File Name field.  You can also 
print the information listed in the Flight Summary window by clicking Print.  When you are 
finished using the Flight Summary window, click Close. 
 
Submitting Early Intent Messages 
Customers can submit Early Intent (EI) messages to ETMS for their flights from the ROG Flight 
Summary window.  Note that this capability is only available to Customer users and submission 
is based on permissions defined in the airline_definitions.dat file (same file is used by the 
Common Constraint Situation Display (CCSD).  ROG provides error checking, ETMS 
submission status, and warning messages.  RMT formats the EI messages in standard CDM 
message format. 
 
ROG allows you to assign (or select) reroutes for all flights on the dynamic list, but only allows 
you to submit EI messages to ETMS for flights that do not have a filed flight plan.  This includes 
flights with flight status of S – Scheduled, R – Historical replaced by assigned, and N – Early 
Intent.  The Send EI button is enabled once you have assigned at least one reroute for your flights 
in the Assign Reroutes window.  Clicking Send EI displays the EI Summary dialog.     
 
To send EI messages to ETMS, click Send EI from the Flight Summary window.  If there are no 
flights/reroute assignments in the appropriate status, the following warning message appears  
“Flights with assigned reroutes have already filed flight plans – no EI messages sent to ETMS.”  
Otherwise, the EI Summary dialog appears. 
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Figure 90: EI Summary Dialog 

The EI Summary dialog has a table that includes one line for each flight/EI message sent to 
ETMS.  The table has six columns by default, but you can show/hide columns by clicking the 
ellipsis (...) button on the dialog.  The following are the default columns: 
 

• EI Status Indicator - Yellow (EI message not submitted), Green (EI message submitted 
successfully), Red (Problem with EI message submission) 

• ACID - Flight identifier. 
• Orig - Origin airport. 
• Dest - Destination airport. 
• ETD - Estimated time of departure. 
• ETMS Messages - Success message if EI was successfully submitted to ETMS, ETMS 

error message if the EI was not successfully submitted to ETMS. 
 
You can add the following columns from the Show/Hide Columns window (… button): 
 

• IGTD – Initial gate time of departure. 
• New Route – Route string being submitted to ETMS in the EI message. 
• New Alt – Altitude being submitted in the EI message. 
• New Spd – Speed being submitted in the EI message. 
• ETE - Estimated time en route. 
• Original Route – Original route string of the flight. 
• Original Alt – Original filed altitude of the flight. 
• Original Spd – Original speed of the flight.. 
• Actype – Aircraft type. 

 
A count of the EIs and their status appears in the lower left corner of the EI Summary dialog.  
When you click Send, RMT sends the EI messages to ETMS and saves the messages to a file.  
You can track the progress of the submission using the progress bar at the bottom of the EI 
Summary dialog.  The progress bar shows the EI messages sent and responses received from 
ETMS.  If all EI responses from ETMS are not received within 60 seconds, a warning message 
appears in the progress bar.  Once you've finished submitting EIs to ETMS, click Close at the 
bottom of the dialog. 
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Early Intent messages sent to ETMS are saved to a file automatically for troubleshooting 
purposes.  The files are saved in the “ei_files” directory one level below the main RMT program 
directory (note that the save directory name is a configurable parameter).  You can choose not to 
save the EI messages by unchecking the Save EI Files checkbox under the ROG Tool Settings 
menu.  Select Settings > Save Settings to permanently change the settings described above.   
 
The file contains the following information (standard CDM EI message format): 
 

• Message Type - Flight Plan (FP) 
• Call Sign 
• Aircraft Type 
• Airspeed 
• Departure Airport 
• Departure Time 
• Cruising Altitude 
• Route String/Estimated Time Enroute 
• Remarks (optional); separated by a vertical bar 

 

Creating Route Guidance Using the Reroute 
Planner 
The Reroute Planner is part of the ROG constraint-centric view that provides decision support to 
FAA Traffic Managers for developing route guidance and reroute plans.  The Reroute Planner 
includes a list of applicable Plays with flight counts and a measure of Play overlap.  The Reroute 
Planner also provides a list of flights/city pairs that do not have pre-coordinated options avoiding 
the FEA/FCA (note this includes Plays and CDRs only in the initial phase of development).  
ATCSCC users can now export reroute plan information to the TSD Create Reroute dialog 
through file exchange if they are using both applications on the same workstation.   
 
Using the Reroute Planner Window 
To examine the Play options applicable for the flight list being evaluated, click Reroute Planner 
(or File > Reroute Planner) on the ROG Tool Bar.  The Reroute Planner window appears. 
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Figure 91: Reroute Planner 

The FCA/Query Summary section at the top of the Reroute Planner window provides the 
FEA/FCA Summary and Query Summary information for reference.  See the “Main ROG Tool 
Window” section for more details. 
 
The Counts section shows you the number of flights and city pairs affected and the number of 
Plays with matching segments that avoid the FEA/FCA for flights on the flight list (Matching 
Plays).  If there are flights and city pairs which have no reroute options that avoid the FEA/FCA, 
they appear in the No Matches Found section.  To see which city pairs and flights had no 
matches, click List next to the No Matches Found section.  The No Matches Found window 
appears. 
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Figure 92: City Pairs with No Matches Found 

 
If any flights and city pairs do not have Play segments, but do have CDR options that avoid the 
FEA/FCA, then the CDR Matches Only section is populated.  To see which flights and city pairs 
have only CDR matches, click List in the CDR Matches Only section.  The CDR Matches Only 
window appears. 

 
Figure 93: City Pairs with CDR Matches Only 

The table lists the Plays with segments avoiding the FEA/FCA for the flights on the flight list. 
The Reroute Plan Components column shows you the applicable Play Names.  The Description 
column has the associated Play Category.  The number of flights covered by the Play is shown in 
the Remaining Flights column.  In the example shown in Figure 91, Play PXV has segments that 
avoid the FEA/FCA for 17 of the 37 flights on the flight list.  VUZ also covers 17 flights in this 
case.   
 
The Reroute Planner also calculates different statistics for each Play to provide a relative measure 
of the impact of applying that Play.  This may help with choosing specific Plays and developing 
route guidance or a reroute plan.  The Additional Distance column shows you the average 
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additional distance in nautical miles the covered flights would take if that Play was applied.  The 
Max Distance column shows you the maximum additional distance in nautical miles any of the 
covered flights would take if that Play were applied.  It is important to keep in mind that Play 
segment lengths are estimated (Play segments are not always defined end-to-end) and these 
statistics should be used to measure the relative differences between the Play options.  Note the 
statistics are highlighted in red in the table.  
 
You can show the Play segments avoiding the FEA/FCA for the flights on the flight list on the 
map by clicking the checkbox in the Show column.  Each Play will be displayed in a different 
color.  This shows you where each of the Plays selected would reroute the flights on the flight list. 

 

Figure 94:  Show Plays from the Reroute Planner 

Once you have decided which Plays to add to your reroute plan based on the current situation, the 
statistics and the map, click the corresponding checkboxes in the Add to Plan column.  The 
counts and Play names in the Reroute Plan line are updated with your selections.   
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Figure 95: Reroute Planner with Reroute Plan 

Note that the number of Remaining Flights changes based on which components are ‘added to the 
Plan’.  Once a Play has been selected, the remaining flights count for that Play goes to zero and 
the counts for the other Plays are adjusted.  This shows you how the Plays overlap and what 
additional Plays may provide reroute options for the remaining flights.  In Figure 95, three Plays 
are included in the reroute plan; BNA, MCI and PXV.  17 of the 37 flights on the FEA flight list 
were covered by this plan.  The 7 flights/6 city pairs without pre-coordinated options are listed in 
the No Matches Found section (Figure 92).  Note that clicking Send Plan to Map shows the 
Plays included in the reroute plan on the RMT Map.  This shows you what the final reroute plan 
would look like on the map.   
 
If you want to view this information later, click Save, navigate to the location where you want to 
save the file and enter a name for the file in the File Name field.  You can also print the 
information listed in the Reroute Planner window for later reference by clicking Print.  Once you 
are satisfied with your selections, click Close. 
 
ATCSCC users  may send the reroute plan information to the TSD Create Reroute dialog.  RMT 
and TSD will communicate initially through XML file exchange.  Note that the Send to TSD 
button only appears on workstations running both the RMT and TSD applications.  If you want to 
export information to the TSD, click Send to TSD.  An XML file is created containing the 
Origin, Destination and the Route String for each city pair covered by Plays that you selected for 
inclusion in the Reroute Plan.  Files created through RMT will be accessed through the RMT File 
button on the TSD Create Reroute dialog.  
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Change Route Records  
Flight routes do not remain static.  Individual routes may change or become obsolete; new routes 
could be created; and route element names could change.  Using RMT, FAA administrator users 
are able to modify coded departure routes using the CDR Tool.  The Playbook administrator at 
the ATCSCC is able to modify Playbook Plays.  Customers and FAA users can create and update 
ad hoc reroutes for their own use.   
 
All FAA users can view modifications made to the route records in the CDR and Playbook 
databases.  However, only ATCSCC and ARTCC administrators can actually change the route 
records.  Administrators have the ability to make necessary route modifications in the CDR and 
Playbook staging databases.  ARTCC administrators can only create, delete, or modify routes 
departing from their own center.  The ATCSCC administrator can create, delete, or modify any 
route, from any center if required during the verification process.   
 
If you are a CDR administrator, you can use the CDR Tool New, Update and Delete buttons to 
complete any route modifications.  You can also update your route records by importing a text 
file with all your routes into the staging database.  The CDR Tool reads both ASCII and Host 
Stereo files into the database. 
 
RMT recognizes two types of modifications to existing CDR and Play routes: local modifications 
and global modifications.  A local modification is a change that affects a single route record.  For 
example, the route string may change.  A global modification is a name change to a route element 
and can affect many routes.  For example, a STAR number could change, which affects any type 
of route using that STAR number. 
 

View Route Record Modifications 
Any FAA user can view the local and global modifications that have been made to a route (CDR 
or Play).   Viewing the modifications can be especially important, however, to ATCSCC and 
ARTCC administrators.  The global modifications display indicates which centers need to update 
their route records to reflect global name changes.   
 
Viewing a local modification shows the history of all changes made to a single route record.  
Viewing a global modification will show the old and new values for a route element as well as the 
centers and number of routes affected by a global name change.  The Playbook global 
modification panel shows if any Plays are affected by a global name change.  
 
View the Local Modification History 
To view the history of a CDR or Playbook Play, make sure that the Modifications section is 
displayed by selecting Modifications > Show Modifications.  You should see the Modifications 
section at the bottom of the tool window.  Click the Local Modifications tab. 
 
The data columns appearing in the Local Modifications panel match the column order and size 
from the Query Results table.  The settings are read from the user’s saved preferences in the local 
configuration file for each tool window.  Note that the modification time and modification flag 
will always be ‘turned on’ in the Local History panel.  Modification time may not be as critical 
for operational use, but it important for the history display.  For more information on the 
columns, see “The Query Results Table” on page 39. 
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CDR Local Modification History Records 
To view the CDR local modifications, you must first select the route record whose modification 
history you want to see.  Run a search in the CDR Tool for the desired record.  In the Query 
Results table of the CDR Tool, double-click the route record for which you want to view 
modification information.  The route record should be highlighted in the Query Results table and 
also appears in the Modifications section with a listing of all the modifications made to the route.  
Each modification is listed in its own row. 
 

 
Figure 96: CDR Local Modifications Tab 

 
Playbook Local Modification History 
Playbook local history is available for FAA users in both the operational and staging databases.  
The operational history lists only records that were effective for at least one 56-day chart cycle.  
The staging history includes a record for every change made to a Playbook Play.   
 
The same general Play information available in the Query Results table is shown in the Local 
Modifications tab.  Select a Play in the Local Modifications tab and click the View Play History 
button to see the segment-level details for that Play.  The historical Play information can be 
displayed on the RMT Map by clicking the Send to Map button, saved by clicking the Save 
button or printed by clicking the Print button on the View Play History window.   
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View Global Modifications 
Each center is responsible for ensuring that the global modifications (or global name changes) 
that affect routes they control are completed every 56-day cycle.  Administrators can see whether 
the center has completed modifying its affected routes in the global modifications tab.  See the 
“Global Modifications” section on page 106 for related information.  Note that if you are an 
ARTCC administrator, you will only see the column for your center.   
 
Make sure the Modifications section is visible.  Select Modifications > Show Modifications to 
see the Modifications section.  Click the Global Modifications tab in this section.  All the global 
modifications planned for the next cycle and future cycles are listed.   
 

 
Figure 97: Global Modifications Tab 

 
Each global modification is listed in its own row with several information columns.  The columns 
available in the Global Modifications tab are: 
 
• ID - Identification number automatically assigned to the modification based on the order the 

modifications are created. 
• Effective Date - Chart date on which the modification will go into effect. 
• Time - Global modification record "create" time, or, the date and time the global 

modification was entered into the system. 
• Init - FAA-assigned initials of the user who entered the global modification (FAA 

Administrators only).   
• ModUser - User type of the person who entered the global modification.  The user type will 

always be the administrator from the ATCSCC, ATA-100, or a specific center administrator. 
• Center – Center that entered the global modification.  With the exception of the ATCSCC, 

each center can only make changes to the routes they control.  If their changes affect other 
centers, the other centers must make changes to their own routes.  The administrator listed in 
this column can be the ATCSCC, ATA-100, or an FAA center. 

• OrigVal (Original Value) – Identifier of the route element before it was changed. 
• FinalVal (Final Value) – New identifier for the updated route element. 
• Remarks – Any remarks associated with the global modification. 
• Center Names - ARTCC users will see their center listed at the end of each global 

modification row.  The box color in the center column indicates whether the center is affected 
by the modification and whether the center has updated their affected routes.  Gray indicates 
that the center is not affected.  Green indicates that some center routes are affected, but have 
already been updated.  Red indicates that some center routes are affected and still need to be 
updated. 

 



106 

Customize the Modifications Section 
Local and global modifications are listed in rows with several columns of information.  You can 
change the appearance and order of the rows, as well as use the RMT sorting capabilities to 
customize your modifications display.  Note that if you do change the column appearance in the 
Modifications section, you cannot save the display changes between RMT sessions. 
 
Sort Records 
Double-click any column header to sort modifications in ascending order according to column 
selected.   To view a descending sort according to the same field, simply double-click on the 
column header again.  
 
Change Column Order  
To rearrange column order, simply click and drag the column header you wish to move to the 
desired location.  The moved column will drop in place and the other columns move to the right 
of the inserted column when you release the mouse.   
 
Resize Columns 
To resize a column, place your cursor on the line between two columns.  When the cursor 
becomes a double arrow, click and drag the border to the desired width. 
 

Global Modifications 
Global modifications (or global name changes) may affect many routes because they are an actual 
name change to a common route element.  Typically, these changes are DP or STAR number 
changes.  To view the current and future global modifications, select Modifications > Show 
Modifications in the CDR or Playbook Tool window.   
 
Typically, the ATCSCC administrator enters the global modification table entries based on a 
report sent from the NFDC at the beginning of each 56-day chart cycle.  ARTCC CDR 
administrators are also able to enter global modifications if necessary. 
 
Create a Global Modifications Entry 
To create a new entry in the Global Modifications table for all FAA users to see, select 
Modifications > Global Modification.  The Global Modification window appears.  There are 
four sections in the Global Modifications window: Effective Date, Changes, Action, and Status.   
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Figure 98: Global Modifications Window - 
ATCSCC Administrator View 

Figure 99: Global Modifications Window - 
Center Administrator View 

 

In the Effective Date section, you must put in the chart date for which you want the global 
modification to take effect.  The default date is the next chart date.  Note that you can enter global 
modifications for future chart cycles.  Click the triangle on the right of the Effective Chart Date 
field and a drop-down menu appears with the next 5 valid chart dates.  Click a chart date to select 
it as your Effective Chart Date.  To choose a chart date beyond the next 5 planned chart dates, 
simply type a valid chart date in the Effective Chart Date field. To view the valid chart dates, 
select Help > Show Chart Dates.  In this section, you must also type in your FAA-assigned 
initials in the User's Initials field. 
 
In the Changes section, type in the actual global modification name change that is to take place.  
Global modifications include route elements that are new, cancelled, or modified. You can also 
type in any remarks you feel necessary about the change in this section (e.g. NFDD number). 
 
• To enter a new route element, type NEW_ELEMENT in the Original Value field and the 

element name in the Final Value field.  Note that a green box will appear in the global mod 
row for a center if the new element is found in that center’s routes. 

• To enter a cancelled element, type in the element name in the Original Value field. Type 
CANC_ELEMENT in the Final Value field.  Note that a red box will appear in the global 
mod row for a center if the cancelled element is found in that center’s routes.  The center 
must modify or delete the affected routes as appropriate. 

• To enter a modified element, type the original value of the route element in the Original 
Value field. Type in the new value of the route element in the Final Value field.  For 
example, if STAR number ROKIT6 is to change to ROKIT7, the original value would be 
ROKIT6 and the final value would be ROKIT7.   

 
Please note that if you wish to enter a global modification for an airport, you must enter the 4 
character code to avoid potential confusion with navaids. 
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There are two options in the Actions section.  Checking Create global modification entry only 
will create an entry in the table and provide a count of the number of routes affected by center.  
Center administrators also have the option to Create entry and update your center, which will 
create an entry in the table and automatically update any of your center's routes affected by the 
change.  Other centers are still responsible for changing their own routes.  The ATCSCC 
administrator can update all the centers' routes affected by the global modification by checking 
Create Entry and Update Selected Centers. 
 
The Status section gives you instructions for filling in the Global Modifications window fields 
and informs you of the progress while counting or updating the necessary route records. 
 
Click OK to add the global modification entry or Cancel to exit the window without updating the 
table.   
 
A Global Modification Summary window appears with statistics including the number of routes 
affected and number of routes changed by departure center.  A new row will appear in the 
Modifications section with the information you entered in the Global Modifications window.   
 
If you chose to update routes, the ModFlag column for the affected routes will have an “M” to 
indicate that the route has been modified.  In the remarks field, all the routes that were just 
updated will have a default message with the old and new route element name and your user 
name.  Verify in the Modifications section that the status box under your center column for the 
new global modification entry is green. 
 
Recalculate/Refresh the Global Modifications Table 
In the Modifications section of the CDR Tool, the ATCSCC administrators can determine which 
centers are affected by a global modification by viewing the red, green and gray boxes under the 
centers' codes.  A red box indicates the global modification affects some of the center's routes, but 
the center has not updated their routes. A green box indicates that the global modification affects 
some of the center's routes and the center has updated their affected routes.  A gray box indicates 
that the center's routes are not affected by the global modification.  
 
The Recalculate feature causes RMT to go through all the routes and recalculate or update the 
boxes with the latest center status data.  Note that the global modification status is updated or 
recalculated automatically every time an ARTCC administrator updates their routes from an 
ASCII or Stereo file.   
 
The Refresh button allows the Global Modification status information to be refreshed at any 
time.  This could be helpful if several users have been updating their routes and changing the 
colors of the status boxes information simultaneously. 
 

 
Figure 100: Recalculate/Refresh Global Modification Information  
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Update a Global Modification Entry 
Administrator users have the ability to edit and delete global modifications that have not yet been 
applied at any centers.  This may be helpful if an entry was entered incorrectly (typo).  To update 
a global modification entry, select the global modification record you wish to update.  Then click 
the Update button.  A window pops up to ask if you really want to edit the global modification 
record.  Click OK to proceed with the update.  Click Cancel to cancel the action.  If you proceed 
with the update, the Global Modification Editor window opens.  In this window, fill in the 
change you wish to make and click OK to proceed with the change.  Clicking Cancel will close 
the window without taking any action.  
 

 
Figure 101: Global Modification Editor 

 
Delete a Global Modification Entry 
To delete a global modification entry, select the global modification record you wish to delete.  
Click the Delete button to delete the selected record.  A warning message will let you know 
which global modification is to be deleted and ask if you wish to proceed.  Click OK to delete the 
record.  Click Cancel to close the window without taking any action on the record. 
 

 
Figure 102: Delete Global Modification Warning Message 

 
Create a New Global Modification Entry 
The New button at the bottom of the Global Modifications tab brings up the Global Modifications 
window described above in the “Create a Global Modifications Entry” section on page 106.   
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Perform a Global Modification 
All routes from a particular departure center that are affected by a global name change can be 
updated at the same time through the Modifications section.   
 
Center administrators can display the Modifications section at the bottom of the CDR or 
Playbook Tool using the Modifications > Show Modifications menu option and clicking the 
Global Modifications tab.  The list of global name changes entered by the ATCSCC administrator 
should appear in the Modifications section.  If a red box appears in the center name column, click 
on the red box to apply the global modification to all the CDR routes from your center.  The 
Global Modification window appears, select the Update Selected Centers option after verifying 
that your center name appears in the drop-down box.  A Global Modification Summary window 
is displayed with statistics including the number of routes affected and number of routes changed 
by departure center.  After closing the summary dialog, verify in the Modifications section that 
the status box under your center column has changed to green.   
 
Note that NEW_ELEMENT and CANCELLED_ELEMENT global modifications can be counted 
but not applied using this update method. 
 

Update CDR Routes 
There are create, delete, and modify functions (New, Update, and Delete buttons) within the CDR 
Tool that allow administrators to work directly in RMT to make any route record modifications.  
The route modification functions are simple to use and especially useful when you have a few 
changes to make.  Administrators with especially numerous route record updates may want to use 
the option of updating routes from their own ASCII or Stereo file (see “Update CDR Routes from 
a File” on page 115). 
 
Create New CDR Routes 
To create a new route in the CDR Tool, click the New button.  This brings up the CDR Route 
Editor window.   
 

 
Figure 103: Create New Record - CDR Route Editor Window 
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Enter Route Parameters 
To create a new route, you must fill in all required fields.  The RMT application will fill in other 
fields left blank.  Note that you can tab through the list of editable fields in the Route Editor. 
 
When entering new data, you must adhere to the accepted format.  RMT will change all 
characters to upper case.  Spaces separate each element.  No leading zeros (0) are permitted.  For 
example, J12 is permitted but J012 is not for Victor or Jet routes.  STAR numbers must include a 
number character.  For example, SUNSS5 is permitted but SUNSS* is not.  Note that the letters 'I' 
and 'O' are not allowed in the seventh and eighth character position of the CDR route code. 
In the Origin, Destination, and Route String fields, you must enter the 4-character ICAO code for 
foreign cities and cities outside the continental U.S.  The 4-character ICAO code is inserted 
automatically for cities within the continental United States. 
 
Shortcut:  If you are creating a new route that is very similar to an existing route, you do not 
have to fill in all the input fields again.  Instead, use the CDR Tool to search for the similar 
existing route.  Click the route in the Query Results table so that it is highlighted.  Click the New 
button.  The Route Editor window appears with the input fields filled in with the existing route 
data.  Simply change the input fields you need to make the new route. 
 
CDR Parameters 

• Route Code (required) - Enter the CDR route code: an 8-character route designator 
made up of the 3-character departure airport code, 3-character arrival airport code, and a 
2-character facility-designated code.  Note that CDRs use the 2-character facility code at 
the end of the route code.  Also note that the letters 'I' and 'O' are not allowed in the 
seventh and eighth character position of the CDR route code. 

• Route String (required) - Enter the list of route elements (i.e. fixes and navaids) that 
make up the route. 

• Initials (required) – Note that you are required to enter your FAA-assigned initials to 
modify a route. 

• CoordReq (required)  – Enter “Y”-Yes or ‘”N”-No to designate whether the CDR 
requires coordination when filed.   

• Nav Eqp (required) – Enter the navigation equipment designator, 1- basic navigational 
routes, 2 – routes which begin and/or end with RNAV DPs and STARs, 3 - routes which 
contain Q-route segments and/or pitch and catch points.  This field became effective on 
the Aug 3, 2006 Chart Date. 

 
• Origin – Enter the 3 or 4-character airport code to identify the route’s point of origin 

(Canadian airports require the 4-character ICAO codes.  Anchorage, AK and Honolulu, 
HI require PANC and PHNL, respectively.).  Note that RMT will insert the origin from 
the route string into this field if it is left blank.   

• Destination - Enter the 3 or 4-character airport code to identify the route’s destination 
(Canadian airports require the 4-character ICAO codes.  Anchorage, AK and Honolulu, 
HI require PANC and PHNL, respectively.).  Note that RMT will insert the destination 
from the route string into this field if it is left blank. 

• Dep Fix (Departure Fix) - Enter the departure fix.  You may enter a hyphen (-) in this 
field if there is no real departure fix for the route.  Note that RMT will insert the first 
navaid or fix from the route string into this field if it is left blank.   

• Remarks - Use this field to enter any remarks about route changes or new record 
additions. 
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• Associated Play – Enter the Associated Playbook Play name if the CDR was designed to 
match a Play. 

 
RMT will fill in the Departure and Arrival Centers for the airports specified in the Origin and 
Destination fields if they are not filled in by the user.  Note that route Length and Traversed 
Centers are calculated by the RMT trajectory maker and are visible in the Route Editor but are 
not input by the user.   
 
To clear your input fields, click the Reset button.  Note that this will clear all the input fields. 
 
Check for Errors 
Once you fill in the input fields, click the Check button.  Any warnings or errors found are 
displayed in the Errors and Warnings section of the Route Editor window.  Read messages 
carefully to see if any changes are necessary in the input fields before completing the new route 
record.  Change the necessary input fields and click the Check button again.  Short descriptions of 
the warning/error messages are provided under Help > Show Warning/Error Messages.  A 
complete list is also provided in the Appendix.   
 
Note that some Canadian and Mexican location data has been incorporated into RMT (obtained 
from the ETMS grid files).  You may still find some airports, navaids, and fixes that are not yet 
included in the database.  A “WARNING_UNKNOWN_ELEMENT” message will appear 
stating that "The specified element was not found in any of the NFDC tables."  If the message is 
generated because of a Canadian element, you can ignore the message. 
 
The RMT route checking also includes a file with valid Canadian & Mexican element names that 
RMT does not have the corresponding latitude/longitude positional data for.  This will allow for 
significantly fewer warning messages for the ARTCC administrator as the routes are entered into 
RMT.  A warning message, “WARNING_NO_COORDINATES”, is provided in the “Warnings 
Field” that shows that there is missing data when the corresponding route is drawn on the map.   
 
Several warning message check the “flyability” of the route.  For example, a warning message is 
displayed if elements on the route string field are further than 600 miles apart.  Another warning 
message is displayed if an element appears more than once on a route string.       
 
The RMT 1.50 route checking capability has been enhanced to provide two new warning 
messages; DP/STAR transition problems and invalid airway intersections.  These warnings are 
listed in the CDR or Ad Hoc Warnings field or the Play route segment status field.   
 
Note that the “Warnings field” is used to create the Warnings Report that will be used by 
administrators during the Verification Period. 
 
Complete the New Route Record 
Once the route has been checked, you can click the OK button to complete the new route record.  
If you still have error or warning messages and want to proceed without changing the input fields, 
click the Ignore Warnings button.  This will create the new route record despite the presence of 
warnings. 
 
Once you have completed the process, the route record in the Query Results table will have an 
"N" in the ModFlag column to denote that a new record has been added. 
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Modify Existing Routes 
To update a route that already exists in the CDR database, first perform a search in the CDR Tool 
to find the route you want to modify.  Click the route record you want to modify in the Query 
Results table so that it is highlighted.  Click the Update button.  
 

 
Figure 104: Modify an Existing Record – CDR Route Editor Window 

 
The route record data appears in the Route Editor window.  Make the necessary changes to any of 
the input fields.  See a complete description of the input parameters in the “Enter Route 
Parameters” section on page 111. 
 
Check for Errors 
Once you fill in the input fields, the OK button will change to read Check.  Click the Check 
button to check your inputs.  Any problems are displayed in the Errors and Warnings section of 
the Route Editor window.  Read the messages carefully to see what changes you should make to 
the input fields before completing the modification.  Change the necessary input fields and click 
the Check button again.   
 
See “Check for Errors” on page 112 for a description of the RMT route checking capabilities. 
 
Complete the Modification 
Once the route has been checked, you can click the OK button to complete the modification.  If 
you still have error or warning messages and want to proceed without changing the input fields, 
click the Ignore Warnings button.  This will update the route record despite the presence of 
warnings. 
 
Once the modification is complete, the route record in the Query Results table will have an "M" 
in the ModFlag column to denote that the record has been changed. 
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Delete CDR Routes 
To delete a CDR, you must first perform a search in the CDR Tool to find the route(s) you want 
to delete.  Select the record(s) you want to delete in the Query Results table.  To select more than 
one route record, Ctrl-click multiple route records; click a route record and then shift-click 
another route record to select a range; or click and drag over a range of route records.   
 

 
Figure 105: Deleting Multiple Routes 

Once you select the route record(s) to delete, click the Delete button.  The Delete Records 
window appears.  In this window, you are asked if you really want to delete the selected route(s). 
 

 
Figure 106: Delete Routes 

To complete the deletion, enter your FAA-assigned initials into the Initials field.  Enter any 
remarks you feel necessary to give reasons for the deletion.  Click OK to complete the deletion. 
The record(s) you deleted will still be visible in the Query Results table, but the ModFlag column 
will contain a “D” to indicate that the route has been marked for deletion. 
 
If you decide you do not want to delete the route record(s), click Cancel in the Delete Records 
window.  The window will close and no action is taken on the selected route record(s).  
 
Reinstate a Deleted Route 
To reinstate a deleted route, perform a search in the CDR Tool to find the route you want to 
reinstate.  Click the route record you want to reinstate in the Query Results table so that it is 
highlighted.  Click the Update button.  
 
When reinstating a deleted route, you do not have to change the input fields.  However, you may 
want to enter some remarks in the Remarks input field.  The Reinstate Deleted Route window 
appears.  In this window, you are asked if you really want to reinstate the deleted route.  Note that 
you should see an “M” in the ModFlag column replacing the "D” for the reinstated route. 
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Update CDR Routes from a File 
The recommended method for updating CDRs is by importing the Host Stereo file into RMT to 
ensure that the host and RMT database are consistent.  Note that the option to update routes using 
a Stereo file is only available in the CDR Tool.   
 
Import an ASCII File  
An ASCII file can be created in any text editor but to import a file into the CDR database, it must 
follow specific guidelines.  
 
CDR Required ASCII Columns 
To import an ASCII file into CDR, insert a header line with the column names listed and the 
required columns.  You can put the required columns in any order.  Note that RMT automatically 
fills in the remaining fields (e.g. ACNTR, TCNTR, Length, ModTime and ModFlag).   
 
1. RCode (Route Code) - 8-character CDR route code with 3-character origin airport, 3-

character destination airport- and 2-character facility-designated code. 
2. Orig (Origin) - The 3 or 4-character origin airport code. (Canadian airports must be 4 

characters). 
3. Dest (Destination) - The 3 or 4-character destination airport code (Canadian airports must be 

4 characters). 
4. DepFix (Departure Fix) - Name of the departure fix for the route.  Enter a hyphen (-) if there 

is no real departure fix for the route.   
5. Route String - List of elements that make up the route. 
6. DCNTR (Departure Center) - 3-character code for the departure (controlling) center. 
 
Please note that the CDR CoordReq and Nav Eqp fields are required.  If you are entering a new 
CDR, the CDR Route Editor screen will appear and you will have to fill them in before you can 
continue with the loading process.  Values for the CoordReq flag are Y - the CDR requires 
coordination or N – the route does not require coordination when filed.  Values for the NavEqp 
field include 1- basic navigational routes, 2 – routes which begin and/or end with RNAV DPs and 
STARs, 3 - routes which contain Q-route segments and/or pitch and catch points.     
 
Select Modifications > Update from File > From ASCII File.  The Load DB From ASCII 
File window pops up.  In this window you need to specify the file to use for the import and the 
way in which the CDR Tool should import your file. 
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Figure 107: Load DB From ASCII File 

 
Define Loading Options  
The first step to loading routes from a file into the CDR database is to complete the fields in the 
Load DB From ASCII File window.  The fields you must fill in are listed below: 
 
• User's Initials - Enter your FAA-assigned initials in the User's Initials field.   
• File Name – Specify the location and file name of the file to import.  If you do not know the 

exact location of the file, use the Browse button to find the file.  
• Loading Information - This section describes the requirements for loading an ASCII file 

into the CDR database.  To view an example what your file should look like, click the 
Sample button. 

• Loading Mode - You must tell the CDR Tool how to compare your file with the 
information already in the database.  Your file may contain all the route records for your 
center, which overrides the information currently in the database and will delete any route 
records in the database that do not appear in your file.  Or your file may contain only a 
partial list of routes, which would prevent routes currently in the database from being 
deleted if they are not in your file.  Click the box next to the appropriate option.  The option 
that is checked defines the way in which your file is compared to the database. Please note 
that it is very important to choose the correct loading option when you are reading in routes 
from a file.  Routes can be unintentionally deleted if the wrong option is chosen! 

• Center Option – Your center name should be the default in the Center option section and 
appear in the Center Name field.  If it does not, select your 3-character center name from the 
pull-down menu.  

 
Click OK to import the file and Cancel to quit the operation without starting the import.  If you 
have failed to fill in all the fields in the window, you will get a pop-up warning message, which is 
reflected in the Status field.  When your file begins importing, the Progress field informs you of 
the import status. 
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Import a Stereo File 
RMT allows an ARTCC administrator to import CDRs directly from the Host Stereo files 
through the CDR Tool.  It is important to note that when you use this option, the CDR Tool 
assumes that this file contains all routes for your center.  Stereo file formats differ between 
ARTCCs.  The CDR Tool parses and reads the relevant information from the I and W lines in the 
file, other lines are discarded.  Several centers use special characters in the route string (e.g. *, +) 
to designate different things.  The Stereo files do not need to be modified; the CDR Tool strips 
these characters before the records are entered into the database. 
 
The CDR Tool compares the route codes and route strings in the Stereo file with those that are 
currently in the CDR database.  Route codes in the Stereo file that are not in the database are 
marked as new (ModFlag = N).  Those route codes that appear in the database but are not in the 
Stereo file are marked for deletion (ModFlag = D).  The route strings are compared for route 
codes that appear in the Stereo file and in the database.  Route codes with route strings that have 
not changed are marked with ModFlag = -, route strings that have been modified are given 
ModFlag = M.   
 
Also note that the process of reading in the Stereo file can be repeated as many times as 
necessary.  If problems are identified through the verification process, the Stereo file must 
currently be updated outside the RMT Tool.  The updated Stereo file can be read in again to make 
sure all the problems have been corrected.  This is important to ensure that the routes in the host 
match the RMT database.   
 
Please note that the CDR CoordReq and Nav Eqp fields are required.  If you are entering a new 
CDR from the host file, the CDR Route Editor screen will appear and you will have to fill them in 
before you can continue with the loading process.  Values for the CoordReq flag are Y – 
coordination is required or N – coordination is not required.  Values for the NavEqp field include 
1- basic navigational routes, 2 – routes which begin and/or end with RNAV DPs and STARs, 3 - 
routes which contain Q-route segments and/or pitch and catch points. 
 
Select Modifications > Update From File > From Stereo File.  The Load DB From Stereo 
File window pops up.  In this window you need to define the file to use for the import and the 
way in which the CDR Tool should import your file. 
 
Obtaining a Stereo File from the Host 
The first step to loading routes from a Stereo file into the CDR database is to obtain a copy of the 
Stereo file that will be updated for the chart date in question.  This can be done by Air Traffic or 
AOS (Automation) personnel.  This is done by a “file transfer” from the VM/CMS system.  In the 
example in Figure 108, the file named “CDRS 12-25-03 A!” is being received from the Host 
interface known as the Virtual Machine (VM) system and is being transferred to a disk with the 
name of “cdrs 12-25-03.txt”. 
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Figure 108: Transfer file from Host to PC or Disk 

Updating a Stereo File Prior to Loading 
Once the file has been received from the Host system, it can be opened using any word processor 
(MS Word, WordPerfect, WordPad, etc.) for editing.  You can then use the search and replace 
function to make the necessary changes.  Figure 109 shows an example of making a global 
modification in a Stereo File:  LZARD1 to LZARD2.  This allows you to check for all instances 
where the particular search subject occurs and replace them.   
 
Note that problems may occur if the search and replace changes the length of the line in the 
Stereo File. 
 

 
Figure 109: Using Word Processor Search and Replace Function to Update Stereo File 

Once the changes have been made to the Stereo file, you might want to save it with a name that 
identifies it with the upcoming system update (i.e., CDRS 12-25-03.txt).  Once it has been saved, 
it can be used to update the CDR database in RMT. 



  119 

Import a Stereo File into RMT 
ARTCC administrator users can update the CDR staging database using the text file created in the 
previous step from the CDR Tool Window within RMT. 
 
Select Modifications > Update from File > From Stereo File.  The Load DB From Stereo File 
window appears and allows you to select the file to use for the import. 
 

 
Figure 110: Load DB From Stereo File Window 

 
Define Loading Options  
The first step to loading routes from a file into the CDR database is to complete the fields in the 
Load DB From Stereo File window.  The fields you must fill in are listed below: 
 
• User's Initials - Enter your FAA-assigned initials in the User's Initials field.   
• File Name - Specify the location and file name of the file to import.  If you do not know the 

exact location of the file, use the Browse button to find the file. 
• Center Option - Your center name should be the default in the Center option section and 

appear in the Center Name field.  If it does not, select your 3-character center name from the 
pull-down menu.  

 
Click OK to import the file and Cancel to quit the operation without starting the import.  If you 
have failed to fill in all the fields in the window, you will get a pop-up warning message, which is 
reflected in the Status field.  When your file begins importing, the Progress field informs you of 
the import status. 
 
Note that when you import a Stereo file, the CDR Tool assumes that this file contains all routes 
for your center.  The CDR Tool will mark those routes that appear in the database, but not in your 
Stereo file, as "deleted."   
 
Importing Stereo File Back Into Host 
Once all of the routes have been loaded into the database, you can import the Stereo file back into 
the Host.  To learn how to load routes from the Stereo file into the CDR database, read the next 
few sections in this manual.  To import the Stereo file back into the Host, proceed with the 
following: 
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• If all of the routes were good on the first try, use the Stereo file to now go back and update 
the Host record for the next chart date.  Depending on local procedures, it may be necessary 
to submit an Adaptation Request to the local AOS office.   

• If all of the routes were not good and corrections had to be made to the file, it will be 
necessary to again revise the Stereo file that you started with to ensure that the RMT file and 
the Host file are identical.  You can use the word processor to revise those routes using the 
information from the upload attempts to the RMT.  Once you have completed the revisions, 
the file is ready to be imported back to the Host as the CDR file for the next update. 

 
Keep in mind that many facilities have cutoff dates for updates that are prior to the closing date of 
the RMT.  Users should update as early as possible to avoid possibly missing cutoffs. 
 
Error Checking Your Imported File 
RMT provides warning messages if problems are found during the validation process.  Certain 
warnings can be “ignored” and the routes can be entered into the database.  Other errors are more 
serious and the routes cannot be entered without modification.  A complete list of error and 
warning messages is available through Help > Show Warning/Error Messages.  A list is also 
provided in the Appendix.   
 
See previous description of the RMT error checking capabilities on page 112.   
 
Files Created During the Error Checking Process 
RMT creates four ASCII files during the error-checking process.  The routes in your file will be 
saved to one of the four files generated by RMT. 
 
1. Check - the word "check" is appended to your original file name and becomes a separate file 

(i.e. my_routes.txt.check).  This file contains all routes that you should look over before 
importing them into the database. 

2. Good - The word "good" is appended to your original file name and becomes a separate file 
(i.e. my_routes.txt.good).  The 'good' file contains all routes that were validated and are ready 
to be loaded into the database with no further changes. 

3. Loaded - The word "loaded" is appended to your original file name and becomes a separate 
file (i.e. my_routes.txt.loaded).  The 'loaded' file contains all routes that passed the error-
checking process and were loaded into the database.   

4. Reject - The word "reject" is appended to your original file name and becomes a separate file 
(i.e. my_routes.txt.reject).  The "reject" file contains all routes that you reject from the import 
process and decide to exclude from the database.  

 
These text files (ASCII) can be read into the tool at a later time using the Load DB from ASCII 
File option.  The “check” and “reject” files include the error/warning messages described below.  
These files can be used to identify problem route codes that may need to be changed in the host 
Stereo file.  You can find these files in the same directory as the original Stereo file that you are 
reading in to the RMT Tool.     
 
Once the import process is complete, a File Statistics window opens to tell you how many route 
records were good and how many records had potential problems.  From the File Statistics 
window, you can see into which group your route records are placed.   
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Figure 111: File Statistics After First Phase 

 
In Figure 111, the user completed the first phase of importing a Stereo file, the verification 
process.  You can see that 971 of the routes are good and ready to be loaded.  However, 157 
routes have potential problems that the user needs to check. 
 
Edit Problem Routes 
Once the CDR Tool completes the verification process, you can edit any problem routes.  Click 
the Edit Problem Routes button in the File Status window.  This brings up the CDR Tool Route 
Editor and allows you to make the necessary changes to each problem record. 
 
When you choose to edit routes in the CDR Tool, the Route Editor window pops up, see Figure 
112.  In this window you can modify the route record, ignore any warnings, or reject the route. 
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Figure 112: CDR Route Editor 

 
Fixing CDR Route Records 
When the Route Editor window opens, the fields are already filled in with the information for the 
first problem route.  In the Errors and Warnings section of the Route Editor window, you can 
view the specific problems found in the route.  Read the error/warning message and make the 
appropriate change to the route record by typing new information into one of the fields.  For the 
example in Figure 112, you see the “WARNING_GLOBALMOD_ORIGVAL” message.  
SUNSS5 was identified as having a global name change effective on the next chart date. Change 
SUNSS5  to SUNSS6 in the Route String field and click Check to review the route again.  In 
Figure 113, the warning message has changed to “WARNING_GLOBALMOD_FINALVAL”.  
This indicates that the global modification has been successfully applied to this route, but RMT 
does not yet contain the latitude/longitude information to correctly draw the route on the map.  
Click the Ignore Warnings button to continue, you should see Route okay with approved 
warnings in the Errors and Warnings section.  If the route has more than one problem listed in 
the Errors and Warnings section, you will need to make multiple corrections before you see that 
your route is okay.  Once you are satisfied with the results, click the OK button to go to the next 
problem route.  Click Reset to return the fields in the Route Editor window to their original 
values.  This will cause the original error/warning messages to appear.  Click Cancel to close the 
window without taking any action. 
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Figure 113: Edited Route 

 
Ignore Warnings 
At times the CDR Tool may indicate a problem with a route record when the record is actually 
valid.  Remember, the validation against the NFDC tables is provided to help prevent erroneous 
data from being entered into the database and facilitate the verification process.  This process is 
continually being enhanced; check your warning messages carefully.  In the Route Editor 
window, you can choose to ignore the messages in the Errors and Warnings section, which tells 
the CDR Tool to mark the route records as "good" and ready to load. 
 
To ignore the warnings for a single route, click Ignore Warnings in the Route Editor window.  
To ignore a specific warning that appears in many route records, click Ignore All Similar 
Warnings in the Route Editor window.  Note that if a record has more than one warning/error 
message, it will still appear in the Route Editor window for you to fix unless you have chosen to 
ignore all the different types of warnings/errors that appear in that route record.  
 
Please note that the Ignore All Similar Warnings processing has been modified.  Previously, 
you could choose to “Ignore All” token not found warnings.  Now “Ignore All Similar Warnings” 
ignores each instance of the specified element not found.  This will help to identify typos in the 
input files and will speed up the verification process.   
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Reject Routes 
You can choose to reject route records, which would prevent them from being loaded into the 
database.  To reject a single route, click Reject Route in the Route Editor window.  To reject all 
routes with a similar warning/error message, click Reject All Similar Routes.  Any rejected 
routes will be placed in a file marked ".reject."  For example, you could reject all routes missing a 
destination. 
 
Once you are finished editing and rejecting routes, the File Status window will appear again with 
the latest statistics about the route record groupings.  You can choose to Load Good Routes from 
this window or start the process over again if necessary.   
 
File Creation and Naming 
Note that the more file imports you perform, the more files are created.  For example, if you load 
good routes by opening the CDR Tool and importing the file my_routes.txt.good, the CDR Tool 
again creates four files for the ".good" file during import.  So you will see 
"my_routes.txt.good.good," " my_routes.txt.good.check," " my_routes.txt.good.loaded," and " 
my_routes.txt.good.rejects."  However, all the route records in a '.good' file should be ready for 
loading and should produce blank files for the other three appended names.  Be aware of the 
naming scheme and files created to make sure you are working with the appropriate file. 
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CDR Database Loading Report 
RMT generates a “Database Loading Report” for ARTCC administrators as routes are read into 
the CDR databases from a Stereo or ASCII file.  The report lists how many routes were 
loaded/rejected in the current session and lists any warnings/error messages found during the 
loading process.  This report also contains a summary of the routes entered by type (New, 
Modified, Deleted, or Unchanged) to help the administrator verify that the file was processed 
correctly.  The report is first displayed on the screen and then may be saved to a file. 
 

 
Figure 114: CDR Database Loading Report 
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Update Additional CDR Information 
Three important CDR characteristics are not contained in the host stereo files and must be 
updated directly through RMT:  the CDR/Associated Play name, Coordination Required Flag 
(CoordReq) and navigation equipment designator (Nav Eqp).  Two methods are provided to allow 
the ARTCC administrators to add the information to the CDR record.  The CDR Route Editor 
allows administrators to update one record at a time.  If many routes must be changed, updating 
from a comma-delimited file may be an easier method.  Please note that this information must 
only be entered once, it is retained during the RMT chart date processing and will not be 
overwritten the next time a stereo or ASCII file is imported into the tool.   
 
ARTCC administrators are required to fill in both the CoordReq and Nav Eqp fields for new 
CDRs.  It is recommended that the Associated Play information is also reviewed and entered into 
the database at that time. 
 
Load Additional Information from the Route Editor Window 
The CDR/Associated Play name, CoordReq Flag (Y or N) and Nav Eqp designator (1, 2 or 3) 
information can be added through the CDR Route Editor window.  The administrator may select a 
specific CDR in the Query Results table, press the Update button and type the information into 
the appropriate field on the Route Editor window.  See “Enter Route Parameters” on page 111.   
 

 
Figure 115: Update Additional Information from the CDR Route Editor Window 
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Create a Comma-Delimited Loading File 
The following steps can be used to create comma-delimited text files for loading Associated Play, 
CoordReq or NavEqp information into RMT:   
 

1. Perform a query in the CDR Tool to list the desired set of CDRs in the Query Results 
table.  For example, type "ZOB" into the Origin/Dep Center field, "ATL" in the Dest/Arr 
Center field and "ERLIN2 | FLCON1" in the Route String field to display a specific set 
of CDRs.   

2. Remove all fields except the CDR route code from the Query Results table using Settings 
> Show/Hide Columns.  Click to uncheck all column names except RCode. 

3. Create a file containing the displayed CDR route codes using the File > Save to File 
menu option. 

4. Open the saved file in Excel and add the new column (Associated Play, CoordReq or 
NavEqp).  Note that RMT will reject the file if it does not recognize the correct column 
header name in the Coordination Required (RCode, CoordReq) or NavEqp (RCode, 
NavEqp) loading file.   

5. Enter the appropriate Associated Play, CoordReq or NavEqp information for each CDR. 
6. Save the file in comma-delimited format (.csv) and then follow the steps described below 

to load into RMT. 
 

CDR Associated Play Information 
Several ARTCCs design CDRs to match Playbook Plays.  CDR/Playbook coordination fields 
have been added to the CDR database to facilitate the update process and allow Plays and CDRs 
to be updated in the same cycle.  The modification flag for the Associated Play is copied 
automatically by RMT from the Playbook table into the “PlayModFlag” field in the CDR table 
when the information is loaded from a file or through the CDR Route Editor.  The PlayModFlag 
field can be used to help identify CDRs that may need to be updated by CDR administrators and 
should be used in conjunction with the Playbook Changes for Next Cycle Report.   
 
Load Associated Plays from a File  
To update many CDRs at once, the Modifications > Update From File > Load Associated 
Plays option allows the administrator to read in the information from a comma-delimited text file.  
The CDR route code and associated Play name are verified as the file is read in to the database.   
 
You must first enter your FAA-assigned initials, and then click the Browse button to find the 
appropriate file.  Press the Sample button for further details and to see a sample file.   
 

 
Figure 116: Load Associated Play Information from File 
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An “Associated Play Loading Report” is generated that lists any warnings or errors found 
during processing.   
 

 

Figure 117: Associated Plays Loading Report 

To verify that the Play information was read into the database correctly, use a wildcard search ‘*’ 
in the Associated Play query field to bring up all CDRs with Associated Plays from your center. 
 

 

Figure 118: Associated Play Search 
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Update CDR Coordination Required Flag or 
Navigation Equipment Designator 
The CDR Coordination Required Flag was designed to allow the FAA administrators to designate 
whether the CDR requires coordination when being filed.  Values for this field are “Y” meaning 
Yes – coordination is required or “N” meaning No – coordination is not required.  This field was 
called “UserFile” in previous versions of RMT.  Note that this name change affects the 
underlying meaning of the data contained in the database.  All CDRs with UserFile=”Y” have 
been reset to CoordReq=”N” in conjunction with the RMT 1.50 release. 
 
The Navigation Equipment Designator (Nav Eqp) field allows users to quickly identify CDRs 
that require advanced navigation capabilities.  The values for the Nav Eqp field include 1- basic 
navigational routes, 2 – routes which begin and/or end with RNAV DPs and STARs, 3 - routes 
which contain Q-route segments and/or pitch and catch points.   
  
Load Coordination Required Flag from a File 
To update many CDRs at once, the Modifications > Update From File > Load Flags option 
allows the administrator to read in the Coordination Required flag information from a comma-
delimited text file.  The CDR route code and CoordReq flag (Y or N) are verified as the file is 
read in to the database.   
 
You must first enter your FAA-assigned initials, select a Flag Name (CoordReq in this case), 
then click the Browse button to find the appropriate file.  Press the Sample button for further 
details and to see a sample file.  Note that the file must include a header line with the two column 
names:  RCode, CoordReq (case-sensitive). 
 

 
Figure 119: Load Coordination Required Information from File 

 
A “CoordReq Loading Report” is generated that lists any warnings or errors found during 
processing.  Verify that the CoordReq information was read into the database correctly by 
searching for the updated CDRs, then checking for the correct value in the CoordReq field (Y or 
N). 
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Load Navigation Equipment Designator from a File  
To update many CDRs at once, the Modifications > Update From File > Load Flags option 
allows the administrator to read in the NavEqp designator from a comma-delimited text file.  The 
CDR route code and NavEqp designator (1,2 or 3) are verified as the file is read in to the 
database.   
 
You must first enter your FAA-assigned initials, select a Flag Name (NavEqp in this case), then 
click the Browse button to find the appropriate file.  Press the Sample button for further details 
and to see a sample file.  Note that the file must include a header line with the two column names:  
RCode, NavEqp (case-sensitive). 
   
 

 
Figure 120: Load NavEqp Information from File 

 
A “NavEqp Loading Report” is generated that lists any warnings or errors found during 
processing.  Verify that the Nav Eqp information was read into the database correctly by 
searching for the updated CDRs, then checking for the correct value in the NavEqp field (1, 2, or 
3). 
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Update Playbook Plays 
There are create, delete, and modify functions (New, Update and Delete buttons) within the 
Playbook Tool that allows the Playbook administrator to work directly in RMT to make any 
modifications.  Note that Playbook Plays are not updated through a file.   
 
Create a New Play 
In the Playbook Tool click the New button.  The Create New Play window appears, asking 
whether the new Play is a Split Play.   
 

 
Figure 121: Create New Play Window 

Click either the Yes button or the No button to continue.  This brings up the Play Editor window.   
 

 

Figure 122: Create New Play - Play Editor Window 
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Enter Play Parameters 
To create a new Play, you must fill in all required fields.  The RMT application will fill in other 
fields left blank.  Note that you can tab through the list of editable fields (Playbook Ctrl-tab). 
 
Shortcut:  If you are creating a new Play that is very similar to an existing Play, you do not have 
to fill in all the input fields again.  Instead, use the Playbook Tool to search for the similar 
existing Play.  Click the Play in the Query Results table so that it is highlighted.  Click the New 
button.  The Play Editor window appears with the input fields filled in with the existing Play data.  
Simply change the input fields you need to make the new Play. 
 

 
Figure 123: Create a New Play from an Existing Play 
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Playbook Parameters 
 

• Play Name (required) – The Playbook Play name. 
• Category (required) – The Playbook Category name, e.g. Airports, East to West 

Transcon Routes, South to Northeast Routes.  A category must be selected from the drop-
down list.  

• Facilities Included (required) – The facilities included or traversed by this Play. 
• Initials (required) – Note that you are required to enter your FAA-assigned initials to 

modify a Play.    
 
• Impacted Area or Flow – The impacted area or flow for this Play. 
• Instructions - Any special instructions associated with this Play. 
• Remarks - Any remarks associated with this Play. 
• Special Note - Any special notes associated with this Play.  
• Impacted Area – You may draw an impacted area associated with this Play.  See “Draw 

an Impacted Area on the RMT Map” section below. 
 
The ModTime and Last Update (effective chart date for the last update to this Play) fields are 
updated automatically by RMT.  The text ‘Play Created’ is placed in the Modification 
Description field, additional comments can be added for further clarification.  Note that any 
comments should end with a period ‘.’.  This field is used to create the Playbook Changes for 
Next Cycle Report. 
 
Draw an Impacted Area on the RMT Map 
The Playbook administrator may draw an impacted area associated with a Playbook Play to 
graphically show an area on the map.  Note that only one area can be defined per Play.   
 
To create an impacted area, select the Create button on the Impacted Area section at the top of 
the Play Editor window.  The fill and line colors should be selected first by choosing options from 
the pull-down menus.  The administrator may then define the impacted area by pointing and 
clicking to define the points of the polygon.  Many of the usual RMT Map functions such as 
zooming in and out, adding overlays and the Quick keys are available for reference. 
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Figure 124: Impacted Area Window 

An impacted area can be deleted from a Play definition using the Delete button on the Play Editor 
window. 
 
Update Play Segments 
The Playbook administrator can add/modify origin and destination segments by pressing the 
New/Update buttons in the ‘Play Routing’ and ‘Route to Destination’ sections of the Play Editor 
window.  This brings up the Segment Editor windows.  Please note that the Arrow buttons can 
be used to move segments up and down within the ‘Play Routing’ and ‘Route to Destination’ 
sections.   
 
Origin/Destination Segment Parameters 
 

• Origin – The origin (ARTCC or airport(s)) of the Play segment. 
• Destination – The destination airport(s) of the Play segment.  
• Route – The origin/destination segment route string. 
• Origin/Destination Segment Remarks – Any remarks associated with the segment 
• Start – The starting point for any different colored Play segments. 
• End – The ending point for any different colored Play segments.   
• Color – The assigned color for the Play segment.  Note that the default color is brick red.   

 
The segment color can be changed by choosing a “Start” or “End” point along the segment route 
string, then selecting a different color from the color drop-down box.   
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Figure 125: Origin Segment Editor 

Filters are removed from origin segments by pressing the Remove Filters button on the Origin 
Segment Editor.  Filters are assigned to origin segments by pressing the Set Filters button.  This 
brings up the Flight Filters window. 
 

 
Figure 126: Flight Filters Edit Window 

Note that the Filters field is limited to 100 characters.  If the combination of filters specified in 
the Flight Filters window exceeds the limit, a warning message appears and filters will be 
truncated unless action is taken. 
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Check for Errors 
Once you fill in the input fields in the Play Editor, Segment Editor and Flight Filters windows, 
the OK button will change to read Check.  Click the Check button to check your inputs.  
Problems that are identified on the Segment Editor and Flight Filters windows must be resolved 
before moving back to the main Play Editor window.  You will be notified of any problems with 
the top-level Playbook information through pop-up warning dialog boxes.  Change the necessary 
input fields and click the Check button again.   
 
Note that the ‘Play Routing’ and ‘Route to Destination’ segment sections contain a status field on 
the Play Editor window; this is similar to Warnings field in the CDRs.  Note that this field is only 
visible to the Playbook administrator.  Green signifies that there are no warnings associated with 
the segment; yellow indicates that there is a warning.  Warnings are displayed on the Errors and 
Warnings section of the Segment Editor and can be ‘Ignored’ as described in previous sections.   
 
Complete the New Play 
Once the Play has been checked, you can click the OK button to complete the new Play record.  
If you still have warning messages and want to proceed without changing the input fields, click 
the Ignore Warnings button.  This will create the new route record despite the presence of 
warnings. 
 
Once you have completed the process, the Play record in the Query Results table will have an "N" 
in the ModFlag column to denote that a new Play has been added. 
 
 
Modify Existing Plays 
To update a Play that already exists in the Playbook database, first perform a search in the 
Playbook Tool to find the Play you want to modify.  Click the Play you want to modify in the 
Query Results table so that it is highlighted.  Click the Update button.  
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Figure 127: Modify an Existing Play - Play Editor Window 

 
The Play data appears in the Play Editor window.  Make the necessary changes to any of the input 
fields.  See a complete description of the input parameters in the “Enter Play Parameters” section 
on page 132. 
 
Check for Errors 
Once you have modified the input fields in the Play Editor, Segment Editor and Flight Filters 
windows, the OK button will change to read Check.  Click the Check button to check your 
inputs.  Problems that are identified on the Segment Editor and Flight Filters windows must be 
resolved before moving back to the main Play Editor window.  You will be notified of any 
problems with the top-level Playbook information through pop-up warning dialog boxes.  Change 
the necessary input fields and click the Check button again.   
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Note that the ‘Play Routing’ and ‘Route to Destination’ segment sections contain a status field on 
the Play Editor window; this is similar to Warnings field in the CDRs.  Note that this field is only 
visible to the Playbook administrator.  Green signifies that there are no warnings associated with 
the segment; yellow indicates that there is a warning.  Warnings are displayed on the Errors and 
Warnings section of the Segment Editor and can be ‘Ignored’ as described in previous sections.   
 
Complete the Modification 
Once the Play has been checked, you can click the OK button to complete the modification.  If 
you still have error or warning messages and want to proceed without changing the input fields, 
click the Ignore Warnings button.  This will update the Play despite the presence of warnings. 
 
The ModTime and Last Update (effective chart date for the last update to this Play) fields are 
updated automatically by RMT.  Text is automatically placed in the Modification Description 
field is segments are modified or global modifications are applied.  This field is used to create the 
Playbook Changes for Next Cycle Report. 
 
Once the modification is complete, the Play in the Query Results table will have an "M" in the 
ModFlag column to denote that the Play has been changed. 
 
Delete a Play 
To delete a Play, you must first perform a search in the Playbook Tool to find the Play(s) you 
want to delete.  Select the record(s) you want to delete in the Query Results table, and then click 
the Delete button.   
 

 
Figure 128: Delete Play Window 

To complete the deletion, enter your FAA-assigned initials into the Initials field.  Note that the 
text “Play deleted” will be added to the ModDescription field for this Play.  Enter any additional 
comments in the Remarks field.  Click OK to complete the deletion.  
 
The Play(s) you deleted will still be visible in the Query Results table, but the ModFlag column 
will contain a “D” to indicate that the Play has been marked for deletion.   
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Update Ad Hoc Reroutes 
There are create, delete, and modify functions (New, Update, and Delete buttons) within the AD 
HOC Tool that allow you to work directly in RMT to make any route record modifications.  The 
route modification functions are simple to use and especially useful when you have a few changes 
to make. If you have many routes to update, you may want to append routes from a file (page 
143). It is important to note that you must maintain the ad hoc reroutes (e.g. update the DP/STAR 
numbers) on the routes that you add to the database.  RMT will update the warning messages 
associated with the ad hoc reroutes as part of the 56-day chart date processing.  You can see any 
associated warning messages for your routes in the Ad Hoc Warning Report (page 58). 
 
Create New Ad Hoc Reroutes 
To create a new route in the AD HOC Tool, click the New button.  This brings up the Ad Hoc 
Reroute Editor window.   
 

 
Figure 129: Create New Record – Ad Hoc Reroute Editor Window 

Enter Route Parameters 
To create a new route, you must fill in all required fields.  The RMT application will fill in other 
fields left blank.  Note that you can tab through the list of editable fields in the Reroute Editor. 
 
When entering new data, you must adhere to the accepted format.  RMT will change all 
characters to upper case.  Spaces separate each element.  No leading zeros (0) are permitted.  For 
example, J12 is permitted but J012 is not for Victor or Jet routes.  STAR numbers must include a 
number character.  For example, SUNSS5 is permitted but SUNSS* is not.  In the Origin, 
Destination, and Route String fields, you must enter the 4-character ICAO code for foreign cities 
and cities outside the continental U.S.  The 4-character ICAO code is inserted automatically for 
cities within the continental United States. 
 
Shortcut:  If you are creating a new route that is very similar to an existing route, you do not 
have to fill in all the input fields again.  Instead, use the AD HOC Tool to search for the similar 
existing route.  Click the route in the Query Results table so that it is highlighted.  Click the New 
button.  The Reroute Editor window appears with the input fields filled in with the existing route 
data.  Simply change the input fields you need to make the new route. 
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AD HOC Parameters 
• Name (required) - Enter the ad hoc reroute name: unique name assigned by the creator 

of the route (30 characters maximum, spaces are not allowed).  
• Route String (required) - Enter the list of route elements (i.e. fixes and navaids) that 

make up the route. 
• Initials (required) – Note that you are required to enter your initials to modify a route. 

 
• Origin – Enter the 3 or 4-character airport code to identify the route’s point of origin 

(Canadian airports require the 4-character ICAO codes.  Anchorage, AK and Honolulu, 
HI require PANC and PHNL, respectively.).  Note that RMT will insert the origin from 
the route string into this field if it is left blank.   

• Destination - Enter the 3 or 4-character airport code to identify the route’s destination 
(Canadian airports require the 4-character ICAO codes.  Anchorage, AK and Honolulu, 
HI require PANC and PHNL, respectively.).  Note that RMT will insert the destination 
from the route string into this field if it is left blank 

• Dep Fix (Departure Fix) - Enter the departure fix.  You may enter a hyphen (-) in this 
field if there is no real departure fix for the route.  Note that RMT will insert the first 
navaids or fix from the route string into this field if it is left blank.   

• Remarks - Use this field to enter any remarks about route changes or new record 
additions. 

 
RMT will fill in the Departure and Arrival Centers for the airports specified in the Origin and 
Destination fields if they are not filled in by the user.  Note that route Length and Traversed 
Centers are calculated by the RMT trajectory maker and are visible in the Reroute Editor but are 
not input by the user.   
 
To clear your input fields, click the Reset button.  Note that this will clear all the input fields. 
 
Check for Errors 
Once you fill in the input fields, click the Check button.  Any warnings or errors found are 
displayed in the Errors and Warnings section of the Reroute Editor window.  Read messages 
carefully to see if any changes are necessary in the input fields before completing the new route 
record.  Change the necessary input fields and click the Check button again.  Short descriptions of 
the warning/error messages are provided under Help > Show Warning/Error Messages.  A 
complete list is also provided in the Appendix.   
 
Note that some Canadian and Mexican location data has been incorporated into RMT (obtained 
from the ETMS grid files).  You may still find some airports, navaids, and fixes that are not yet 
included in the database.  A “WARNING_UNKNOWN_ELEMENT” message will appear 
stating that "The specified element was not found in any of the NFDC tables."  If the message is 
generated because of a Canadian element, you can ignore the message. 
 
The RMT route checking also includes a file with valid Canadian & Mexican element names that 
RMT does not have the corresponding latitude/longitude positional data for.  This will allow for 
significantly fewer warning messages as the routes are entered into RMT.  A warning message, 
“WARNING_NO_COORDINATES”, is provided in the “Warnings Field” that shows that there 
is missing data when the corresponding route is drawn on the map.   
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Several warning message check the “flyability” of the route.  For example, a warning message is 
displayed if elements on the route string field are further than 600 miles apart.  Another warning 
message is displayed if an element appears more than once on a route string.       
 
The RMT 1.50 route checking capability has been enhanced to provide two new warning 
messages; DP/STAR transition problems and invalid airway intersections.  These warnings are 
listed in the Ad Hoc Warnings field.   
 
Note that the “Warnings field” is used to create the Ad Hoc Warnings Report that will be used for 
ad hoc reroute database maintenance. 
 
Complete the New Route Record 
Once the route has been checked, you can click the OK button to complete the new route record.  
If you still have error or warning messages and want to proceed without changing the input fields, 
click the Ignore Warnings button.  This will create the new route record despite the presence of 
warnings. 
 
Modify Existing Routes 
To update a route that already exists in the ad hoc reroute database, first perform a search in the 
AD HOC Tool to find the route you want to modify.  Click the route record you want to modify 
in the Query Results table so that it is highlighted.  Click the Update button.  
 

 
Figure 130: Modify an Existing Record – Ad Hoc Reroute Editor Window 

The route record data appears in the Reroute Editor window.  Make the necessary changes to any 
of the input fields.  See a complete description of the input parameters in the “Enter Route 
Parameters” section on page 139. 
 
Check for Errors 
Once you fill in the input fields, the OK button will change to read Check.  Click the Check 
button to check your inputs.  Any problems are displayed in the Errors and Warnings section of 
the Reroute Editor window.  Read the messages carefully to see what changes you should make 
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to the input fields before completing the modification.  Change the necessary input fields and 
click the Check button again.   
 
See “Check for Errors” on page 112 for a description of the RMT route checking capabilities. 
 
Complete the Modification 
Once the route has been checked, you can click the OK button to complete the modification.  If 
you still have error or warning messages and want to proceed without changing the input fields, 
click the Ignore Warnings button.  This will update the route record despite the presence of 
warnings. 
 
Delete Ad Hoc Reroutes 
To delete an ad hoc reroute, you must first perform a search in the AD HOC Tool to find the 
route(s) you want to delete.  Select the record(s) you want to delete in the Query Results table.  
To select more than one route record, Ctrl-click multiple route records; click a route record and 
then shift-click another route record to select a range; or click and drag over a range of route 
records.   
 
You may want to delete all your ad hoc records in the database and reload based on the current 
chart date’s data.  First perform a query with all search parameters blank to display all your routes 
into the Query Results table.  Click Select All to highlight all the routes in the Query Results 
table.     
 

 
Figure 131: Deleting Ad Hoc Reroutes 

Once you select the route record(s) to delete, click the Delete button.  The Delete Records 
window appears.  In this window, you are asked if you really want to delete the selected route(s). 
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Figure 132: Delete Ad Hoc Reroutes 

To complete the deletion, enter your initials into the Initials field.  Click OK to complete the 
deletion. The record(s) you deleted are deleted immediately from the ad hoc reroutes table. 
 
If you decide you do not want to delete the route record(s), click Cancel in the Delete Records 
window.  The window will close and no action is taken on the selected route record(s).  
 

Appending Ad Hoc Reroutes from a File 
Ad hoc reroutes can be added to the database using a comma-delimited text file. 
 
Import an ASCII File 
An ASCII file can be created in any text editor but to import a file into the ad hoc reroute 
database, it must follow specific guidelines.  
 
Ad Hoc Required ASCII Columns 
To import an ASCII file into the AD HOC Tool, insert a header line with the column names listed 
and the required columns.  You can put the required columns in any order.  Note that RMT 
automatically fills in the remaining fields (e.g. DCNTR, ACNTR, TCNTR, DepFix, Length, and 
ModTime, ModInit, ModUser).   
 

1. Name - The ad hoc reroute name (30 characters maximum, spaces are not allowed). 
2. Orig (Origin) - The 3 or 4-character origin airport code. (Canadian airports must be 4 

characters). 
3. Dest (Destination) - The 3 or 4-character destination airport code (Canadian airports 

must be 4 characters).  
4. Route String - List of elements that make up the route. 

 
Select Modifications > Append Routes from File.  The Ad Hoc Load DB From ASCII File 
window pops up.  In this window you need to specify the file to use for the import. 
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Figure 133: Load Ad Hoc Reroutes From ASCII File 

 
Click OK to import the file and Cancel to quit the operation without starting the import.  When 
your file begins importing, the Progress field informs you of the import status. 
 
Error Checking Your Imported File 
RMT provides warning messages if problems are found during the validation process.  Certain 
warnings can be “ignored” and the routes can be entered into the database.  Other errors are more 
serious and the routes cannot be entered without modification.  A complete list of error and 
warning messages is available through Help > Show Warning/Error Messages.  A list is also 
provided in the Appendix.   
 
See previous description of the RMT error checking capabilities on page 112.   
 
Files Created During the Error Checking Process 
RMT creates four ASCII files during the error-checking process.  The routes in your file will be 
saved to one of the four files generated by RMT. 
 

1. Check - the word "check" is appended to your original file name and becomes a separate 
file (i.e. my_routes.txt.check).  This file contains all routes that you should look over 
before importing them into the database. 

2. Good - The word "good" is appended to your original file name and becomes a separate 
file (i.e. my_routes.txt.good).  The 'good' file contains all routes that were validated and 
are ready to be loaded into the database with no further changes. 

3. Loaded - The word "loaded" is appended to your original file name and becomes a 
separate file (i.e. my_routes.txt.loaded).  The 'loaded' file contains all routes that passed 
the error-checking process and were loaded into the database.   

4. Reject - The word "reject" is appended to your original file name and becomes a separate 
file (i.e. my_routes.txt.reject).  The "reject" file contains all routes that you reject from 
the import process and decide to exclude from the database.  

 
These text files (ASCII) can be read into the tool at a later time using the Modifications > 
Append Routes from File option.  The “check” and “reject” files include the error/warning 
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messages described below.  These files can be used to identify problem routes that may need to 
be changed in you ad hoc file.  You can find these files in the same directory as the original file 
that you are reading in to the RMT Tool.     
 
Once the import process is complete, a File Statistics window opens to tell you how many route 
records were good and how many records had potential problems.  From the File Statistics 
window, you can see into which group your route records are placed.   
 

 
Figure 134: File Statistics After First Pass of Import 

In Figure 134, the user completed the first phase of importing an ad hoc file, the verification 
process.  You can see that 108 of the routes are good and ready to be loaded.  However, 17 routes 
have potential problems that the user needs to check. 
 
Load Good Routes 
Once the AD HOC Tool completes the first phase of the import, you can load good routes into the 
database.  There are two ways to load your good routes into the database, depending on whether 
you wish to load the routes immediately or wait to load them at another time. 
 
• To load your good routes immediately, click Load Good Routes in the File Statistics 

window.  This will load your good routes immediately, giving you the import status and 
final statistics at the end of the import.  

• To wait and load your good routes at another time, close the File Statistics window.  At any 
other time you can choose Modifications > Append Routes From File in the AD HOC 
Tool.  Use the Browse button in the Ad Hoc Load DB From ASCII File window to locate 
the appropriate '.good' file.  This file contains only good routes that are ready to be loaded 
into the database. For example, if your original file was GW_ROUTES.txt, the file you will 
load will be GW_ROUTES.txt.good.  Complete the rest of the information in the Load DB 
From ASCII File window and click OK to perform the import.  At the end of the import, a 
File Statistics window pops up.  You should see all the routes marked as "good" in the File 
Statistics window.  Click Load Good Routes at the bottom of the File Statistics window.   
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Once you load your good routes, you should see the number of loaded routes listed as "Routes 
loaded in the database" in the File Status window.  These routes will now be in the ".loaded" file 
in the same directory as your original imported file.  The ".good" file should be empty. 
 
Edit Problem Routes 
Once the AD HOC Tool completes the verification process, you can edit any problem routes.  
There are two ways to edit problem routes, depending on whether you wish to edit the routes 
immediately or wait to edit them at another time. 
 
• If you wish to edit your routes immediately, click the Edit Problem Routes button in the 

File Status window.  This brings up the Ad Hoc Reroute Editor and allows you to make the 
necessary changes to each problem record. 

• To wait and edit the routes, close the File Status window by clicking Cancel.  When you 
wish to edit the routes, look for the appropriate file ending in ".check."  In the AD HOC 
Tool, select Modifications > Append Routes From File and select the .check file as the file 
to be loaded.  Fill in the appropriate information in the Ad Hoc Load DB From ASCII File 
window and click OK to run another loading pass.  The File Status window that results from 
this action should list all your routes as "Problem routes that need to be checked" and give 
details of the problems found in the route records.  From the File Status window, click Edit 
Problem Routes.  This brings up the Reroute Editor and allows you to make the necessary 
changes to the record. 

• If you wish to edit the route records directly in the file outside of the AD HOC Tool, you can 
open the ".check" file in any text editor.  For example, if you knew that there was a recurring 
typographical error, you could open the file in a text editor to conduct and Search and 
Replace action to fix the error.  You could then perform another loading pass in the AD 
HOC Tool using the edited file. 

 
When you choose to edit routes in the AD HOC Tool, the Ad Hoc Reroute Editor window pops 
up, see Figure 135.  In this window you can modify the route record, ignore any warnings, or 
reject the route.  
 

 
Figure 135: Ad Hoc Reroute Editor 
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Fixing Ad Hoc Reroute Records 
When the Reroute Editor window opens, the fields are already filled in with the information for 
the first problem route.  In the Errors and Warnings section of the Reroute Editor window, you 
can view the specific problems found in the route.  Read the error/warning message and make the 
appropriate change to the route record by typing new information into one of the fields.  For the 
example in Figure 135, you see the “WARNING_UNKNOWN_ELEMENT” message.  Change 
SHINE4 to SHINE5, then click Check again to recheck the route.  The warning message has 
changed to “Route is okay”.  If the route has more than one problem listed in the Errors and 
Warnings section, you will need to make multiple corrections before you see that your route is 
okay.  Once you are satisfied with the results, click the OK button to go to the next problem 
route.  Click Reset to return the fields in the Reroute Editor window to their original values.  This 
will cause the original error/warning messages to appear.  Click Cancel to close the window 
without taking any action. 
 
Ignore Warnings 
At times the AD HOC Tool may indicate a problem with a route record when the record is 
actually valid.  Remember, the validation against the NFDC tables is provided to help prevent 
erroneous data from being entered into the database and facilitate the verification process.  This 
process is continually being enhanced; check your warning messages carefully.  In the Reroute 
Editor window, you can choose to ignore the messages in the Errors and Warnings section, which 
tells the AD HOC Tool to mark the route records as "good" and ready to load. 
 
To ignore the warnings for a single route, click Ignore Warnings in the Reroute Editor window.  
To ignore a specific warning that appears in many route records, click Ignore All Similar 
Warnings in the Reroute Editor window.  Note that if a record has more than one warning/error 
message, it will still appear in the Reroute Editor window for you to fix unless you have chosen 
to ignore all the different types of warnings/errors that appear in that route record.  
 
Please note that the Ignore All Similar Warnings processing has been modified.  Previously, 
you could choose to “Ignore All” token not found warnings.  Now “Ignore All Similar Warnings” 
ignores each instance of the specified element not found.  This will help to identify typos in the 
input files and will speed up the verification process.   
 
Reject Routes 
You can choose to reject route records, which would prevent them from being loaded into the 
database.  To reject a single route, click Reject Route in the Reroute Editor window.  To reject 
all routes with a similar warning/error message, click Reject All Similar Routes.  Any rejected 
routes will be placed in a file marked ".reject."  For example, you could reject all routes missing a 
destination. 
 
Once you are finished editing and rejecting routes, the File Status window will appear again with 
the latest statistics about the route record groupings.  You can choose to Load Good Routes from 
this window or start the process over again if necessary.   
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Database Loading Report 
RMT generates an “Ad Hoc Reroutes Database Loading Report” for users as routes are read 
into the AD HOC Tool.  The report lists how many routes were loaded/rejected in the current 
session and lists any warnings/error messages found during the loading process.  This report also 
contains a summary of routes loaded to help the user verify that the file was processed correctly.  
The report is first displayed on the screen and then may be saved to a file. 
 

 
Figure 136: Ad Hoc Reroutes Database Loading Report 
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ATCSCC Administrator Functions 
There are certain functions that only the ATCSCC administrator can perform, e.g. sending 
messages through RMT to active users and updating the NFDC tables.  The administrator 
functions are all available from the Admin menu and are visible only to the ATCSCC 
administrators. 
 
Only the ATCSCC administrator can perform the functions listed in this chapter. 
 

Send a Broadcast Message 
Sending a message to RMT users is a useful way to distribute important information immediately.  
For example, the CDR or Playbook database may be offline for a certain time period while it is 
being updated.  Active users would need to know this information. 
 
The ATCSCC administrator can send RMT-related messages to all active RMT users by using the 
Broadcast Message function.  Active RMT users are those currently logged in to the system.  To 
broadcast a message, select Admin > Broadcast a Message.  The Broadcast Message window 
appears.  Type any text into the window for your message.  To send the message click OK.  To 
close the window without sending a message click Cancel. 
 

 
Figure 137: Broadcast a Message 

 

CDR and Playbook Tool Administrator Functions 
There are several administrator functions in the CDR and Playbook Tools that allow the 
ATCSCC administrator to make changes and manage the databases. 
 
Change Staging Verification  
The CDR and Playbook staging databases are either in a "verified" or "not verified" state, 
depending on whether the routes in the databases have been reviewed for errors or not.  As the 
ATCSCC administrator, you can change the status of the staging database in either the CDR or 
Playbook Tools.  To change the status of a database, make sure you are in the correct tool (CDR 
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or Playbook).  Select Admin > Change Staging Verification.  RMT displays a prompt window 
that informs you of the current status of the database and asks if you wish to change the status.  If 
you wish to change the status, click Yes.  To leave the status as is, click No. 
 

 
Figure 138: Changing the Status of the CDR Staging Database 

 

CDR Tool Administrator Functions 
Several administrator functions are available only in the CDR Tool window. 
 
Refresh Database Records 
The administrator can update (or refresh) the CDR warning messages as necessary.  To refresh 
the database, select Admin > Refresh Database.  Note this may take a while depending on how 
many CDRs are contained in the database. 
   
Save Database Records 
The ATCSCC administrator can save the CDR staging or operational database to a file outside of 
RMT.  This can be especially helpful if the database ever needs to be reloaded.  To save the 
database, first make sure you are in the CDR Tool window and have selected either the 
Operational or Staging database radio button.  Select Admin > Save Database and the Save 
Database window should appear.  Note that the window will be named according to the database 
you are saving.  For example, in, the window is labeled “Save CDR Staging Database” because 
the user is downloading all routes in the CDR staging database.  In this window, enter a file 
location and name for the saved database.  If you wish to save the global modifications in 
addition to the CDR routes in the database, check the Save Global Modifications checkbox and 
enter a file location and name for the saved global modifications.  Note that historical CDR 
records may be saved along with the current active records.   
 



  151 

 

Figure 139: Save CDR Database Window 

 
Delete Database Records 
If either the CDR staging or operational database needed to be reloaded for some reason, only the 
ATCSCC administrator can delete all the database records and perform the reload.  To delete all 
the route records in the CDR database, select Admin > Delete Database.  The Delete Database 
window appears.  Note that the window will be named according to the database you are deleting.  
You can delete the CDR routes and the associated global modifications by clicking in the 
appropriate checkbox (Figure 140).  To perform the deletion, click OK.  To close the window 
without deleting any records, click Cancel.  
 

 
Figure 140: Delete CDR Staging Database Window 
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Reload Database Records 
The CDR route databases and global modifications can be reloaded using an ASCII file created 
specifically to reload the database.  See the “Save Database Records” section on page 150. 
 
To reload the database, select Admin > Reload Database and the Reload Database window 
should appear (Figure 141).  In this window, enter the file location and name for the saved 
database text files. 
 

 
Figure 141: Reload CDR Staging Database Window 

 
Several options are provided for reloading the global modifications.  These options allow data 
saved from one tool (e.g. CDR) to be loaded into another tool (Playbook) without retyping the 
information. 
 
• Select the Reload CDR Database Global Modifications checkbox to load all the 

information from a saved global modification file (See “Save Database Records” section 
above).  Note that this file includes the status or color of the boxes for each center/Play that 
indicate if routes have been updated with the global mod.   

• Select the Reload Global Mod information only, not center/play columns checkbox to 
load only the general global modification information found on the left side of the Global 
Modifications tab.  The modifier’s initials, user type and modification time are preserved 
along with the name change information.  The database structure is slightly different in the 
CDR and Playbook databases.  This option allows the general global modification 
information to be read into the different tools in the appropriate format.  The status boxes are 
‘recalculated’ after the global modifications file is loaded into the database (See 
“Recalculate/Refresh the Global Modifications Table” on page 108).   

• Select the Reload and update user information checkbox to load only the OrigVal and 
FinalVal global name change information.  Your user initials, user type and the current 
modification time will replace the original information in the Global Modifications tab.   
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Copy Staging Databases to Operational Databases 
The staging databases are copied to the operational database every 56 days on the published chart 
date.  The ATCSCC administrator is the only user who can initiate the copy process.  The 
database copy can be set to occur automatically at 901Z on the chart date or can be manually 
overridden. 
 
Automatically Copy the Databases 
RMT contains a function to automatically copy the CDR staging databases to the operational 
databases every 56 days on the specified chart date.  The automatic copy is set to OFF by default.   
 
If the automatic copy function is off, you can turn it back on by selecting Admin > Change Auto 
Staging -> Op. A server message pops up to tell you that the automatic staging to operational 
database copy has been turned on. 
 
Manually Copy the Databases 
The ATCSCC administrator could theoretically copy the staging database to the operational 
database at any time (under normal circumstances this would only happen on the chart date).  
Once the automatic copy function is off, you can manually copy the data in the staging database 
to the operational database.  To perform the transfer, select Admin > Copy Staging -> 
Operational.  The Staging to Operational window pops up (Figure 142).  In freeze date field, 
type the date on which the route records were frozen for the current database transfer.  Any route 
records modified after the date you enter will not be transferred to the operational database.  By 
default, the freeze date is set to the day before the chart date. 
 

 
Figure 142: Copy Staging to Operational Database 

 
Once you enter the freeze date, click OK to perform the copy.  The copy progresses and pertinent 
status messages appear in the bottom of the window.  
 
To close the window without performing the transfer, click Cancel. 
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NFDC Tool Administrator Functions 
The National Flight Data Center (NFDC) regularly publishes data files with flight-related 
reference data.  This data is used to update much of the data used by the RMT program, including 
location and name information for airports, fixes, and navaids.  The information in the NFDC 
tables is also used to validate route elements entered by RMT users and display elements on the 
RMT Map. 
 
Only the ATCSCC administrator can update the NFDC reference tables. 
 
Update NFDC Reference Tables 
To update the NFDC database, select Admin > Update Database from CD.  The Load DB 
From File window appears (Figure 143).  Type in the location of the data files or use the Browse 
button to find the directory.  Click all of the information tables you want to update.  Any table 
option with a checked box next will be included in the update.   
 

 
Figure 143: Update NFDC Tables 

Reference table options include: 
• LocID  
• Fixes  
• Airways 
• Navaids 
• Airports  
• DPs 
• STARs 
• AwyIntxns 
• PrefRoutes 
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Once you have selected the desired table options, click OK to perform the update.  The bottom of 
the Load DB From File window will show specific loading progress messages as well as track the 
total progress of the update.  Pertinent status messages are displayed at the very bottom of the 
window.  Status messages include instructions on performing the update and warning messages. 
 

Playbook Tool Administrator Functions 
Playbook Plays are assigned to a category based on the type of Play.  Only the Playbook 
administrator can update the Playbook categories table and Playbook Plays.  Please note that the 
56-Day chart cycle processing for the Playbook database is done outside the RMT Tool.   
 
Manage Playbook Categories 
To update the Playbook categories table, select Admin > Manage Categories.  The Manage 
Categories window appears (Figure 144).  Buttons to perform the two available functions are 
shown on the left, a current list of category names is provided in a table on the right side of the 
window.  Category names are color coded by status (red designates staging Play categories, blue 
designates operational categories) for easy identification by the Playbook Administrator. 
 

 

Figure 144: Playbook Manage Categories Window 

To create a new Playbook category, click Create to bring up the Create Category window 
(Figure 145).  Type the name in the New Category field.  Please note that a new category name 
must be created using the Create function before it can be associated with a Play. See “Update 
Playbook Plays” on page 129. 
 

 
Figure 145: Create Playbook Category Window 
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To rename an existing category, select a category name from the table in the Manage Categories 
window and press the Rename button.  Type the new name of the category in the New Category 
field and click OK. 
 

 
Figure 146: Playbook Rename Category Window 

 
Note that Play categories can not be deleted through RMT. 
 

ROG Tool Administrator Functions 
One ROG specific administrator function is available in the ROG Tool window. 
 
Change Early Intent Status 
The Admin > Change Sub-Carrier EI Status menu option allows the RMT administrator to 
enable or disable the capability for carriers to submit EI messages for their sub-carriers.  Note that 
a similar parameter is set on the CCSD.  Select Admin > Change Staging Verification.  RMT 
displays a prompt window that informs you of the current status and asks if you wish to change 
the status.  If you wish to change the status, click Yes.  To leave the status as is, click No.   
 

 

Figure 147: Change Sub-Carrier EI Submission Status Window 

 

Ad Hoc Reroutes Tool Administrator Functions 
Several database administration functions are available to the RMT administrator in the Ad Hoc 
Reroutes Tool window. 
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Refresh Database Records 
The administrator updates (or refreshes) the ad hoc reroutes warning messages as part of the 56-
day Chart Date processing.  To refresh the database, select Admin > Refresh Database.  Note 
this may take a while depending on how many ad hoc reroutes are contained in the database. 
 
Save Database Records 
The ATCSCC administrator can save the ad hoc reroutes database to a file outside of RMT.  This 
can be especially helpful if the database ever needs to be reloaded.  To save the database, first 
make sure you are in the AD HOC Tool window.  Select Admin > Save Database and the Save 
Ad Hoc Reroutes Database window should appear.  In this window, enter a file location and name 
for the saved database.   
 
Delete Database Records 
If the ad hoc reroutes database needed to be reloaded for some reason, only the ATCSCC 
administrator can delete all the database records and perform the reload.  To delete all the route 
records in the ad hoc reroutes database, select Admin > Delete Database.  The Delete Database 
window appears.  To perform the deletion, click OK.  To close the window without deleting any 
records, click Cancel.  
 
Reload Database Records 
The ad hoc reroutes database can be reloaded using an ASCII file created specifically to reload 
the database.  See the “Save Database Records” section on page 157.  To reload the database, 
select Admin > Reload Database and the Reload Database window should appear.  In this 
window, enter the file location and name for the saved database text files. 
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Appendix 
This appendix contains hardware requirements, descriptions of the RMT configuration files and 
the Error and Warning messages found during route checking in the various tools.  
 

Hardware Requirements 
Your computer should meet the following requirements in order to run the RMT application: 
 
Memory - 128 Mb minimum.  256Mb recommended. 
Disk space - 160Mb. 
Ability to run Java Runtime Environment 1.5_0_11 or higher. 
 

RMT Client Configuration Files 
 
The main RMT client configurations files are found in the following directory:  C:\Program 
Files\RMT1.50\config.  Configuration files include the main client configuration file 
(rmt_client.ini) and the etmsrules.xml file that controls the parsing of the FEA/FCA definition 
files.  These two files should not be edited by the user.  Your local configuration file is found in 
your home directory.  Any settings saved from the RMT Tool windows are saved in your local 
file.   
 
RMT Aliases 
The standard RMT aliases can be found in the RMT client configuration file: 
 
QUERY_ALIASES 
{ 
 DCMETRO  IAD | DCA | BWI 
 NYMETRO  LGA | JFK | EWR | PHL 
 WAS   IAD | DCA | BWI 
 CHI   ORD | MDW 
} 
 
You may create aliases for searches you perform on a regular basis in the rmt_user_aliases.ini 
file located in your home directory.  See the “Create an Alias for a Group of Airports” section on 
page 36 for more information. 
 
# This is the RMT Aliases file. 
# 
# The '#' sign indicates a comment. 
# The ':' is required following the alias name 
# Additional aliases can be added using the following format: 
# Alias_Name: value 
# 
#UPSTATENY:  BUF | ROC 
#GWELEMENTS:  TNV LOA 
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Error and Warning Messages 
RMT provides some route validation and verification processing.  A complete list of warning and 
error messages generated by the tool as CDRs, Playbook Plays and ad hoc reroutes are entered 
into RMT are provided in the following sections.     
 
Warning Messages 
RMT provides user warning messages if problems are found during the validation process.  
Certain warnings can be “ignored” and the routes can be entered into the database. 
 
All users can see any warning messages associated with a route in the Warnings information 
column in the CDR Query Results table.  This field is used to create the Warnings Report that can 
help administrators in the validation process.  This field also helps to identify routes that contain 
elements that may be missing from the map.  This list can also be accessed through Help > Show 
Warning/Error Messages.  
 
WARNING_AIRWAY_ELEMENT The specified element was not found in the 

specified airway definition.  
WARNING_CDR_RCODE_IO The CDR Route Code should not have 'I' or 

'O' in positions 7 or 8.  
WARNING_DIFF_DFIX The element in the Departure Fix field was 

not found on the Route String.  
WARNING_DP_STAR_POSITION The specified element is a valid DP/STAR 

but was not found in the expected position in 
the Route String.  

WARNING_DUPLICATE_ELEMENT The specified element was found more than 
once on the Route String.  

WARNING_GLOBALMOD_FINALVAL The global name change specified will be 
effective on the next chart date. RMT does 
not currently contain the latitude/longitude 
data for the new element for the RMT Map.  

WARNING_GLOBAL_ORIGVAL There is a global name change for the 
specified element effective on the next chart 
date.  

WARNING_MISMATCH_ACNTR The Airport/Center information entered does 
not match what is currently in RMT.  

WARNING_NO_COORDINATES The specified element is a known element 
name, but no latitude/longitude information is 
available for the RMT Map.  

WARNING_NO_DFIX The departure fix is missing.  
WARNING_UNKNOWN_ARPT The specified airport was not found in the 

NFDC airports table.  
WARNING_UNKNOWN ELEMENT The specified route element was not found in 

any of the NFDC tables.  
WARNING_WAYPOINT_DISTANCE There are waypoints on the route that are 

further than 600 nautical miles apart.  
WARNING_INVALID_DPSTAR_TRANS The specified element is not a valid transition 

point for the specified DP or STAR. 
WARNING_INVALID_AWYINTXN The specified airways do not meet at a valid 

airway intersection point. 
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Error Messages 
RMT provides error messages to administrator users if problems are found as routes (CDRs, 
Plays or ad hoc reroutes) are entered into RMT through either the screen or loaded from a file.  
These errors must be resolved before the routes are allowed into the database.    
 
The list of potential error message is available for administrator users through Help > Show 
Warning/Error Messages. 
 
ERROR_CDR_BAD_RCODE Invalid CDR Route Code: Route Codes must 

be 8 characters in length.  
ERROR_CDR_DIFF_DEST Characters 4-6 of the Route Code do not 

match the 3-character destination airport 
code.  

ERROR_CDR_DIFF_ORIG Characters 1-3 of the Route Code do not 
match the 3-character origin airport code.  

ERROR_NO_COORDREQ The Coordination Required field must be 
filled in. 

ERROR_NO_NAVEQP The NavEqp field must be filled in. 
ERROR_STEREO_EXTRA_I_LINE A Route Code (I line) was found without a 

matching route string (W line) at the 
specified line.  

ERROR_STEREO_EXTRA_W_LINE A route string (W line) was found without a 
matching Route Code (I line) at the specified 
line.  

ERROR_STEREO_INCOMPLETE_ROUTE An incomplete route was found at the 
specified line. 

ERROR_STEREO_MISSING_PAREN The closing parenthesis ')' on the specified 
line is missing.  

ERROR_STEREO_NULL_ROUTE There is no route string information for the 
Route Code near the specified line  

ERROR_ASCII_FIELDS The number of fields in the ASCII file does 
not match what was expected by RMT.  

ERROR_FILE_PARSE There was an error parsing the file near the 
specified line number.  

ERROR_FILE_MISSING_RCODE The Route Code could not be extracted from 
the file.  

ERROR_DCNTR_PERMISSIONS The departure Center does not have 
permission to modify routes from the 
specified airport.  

ERROR_DIFF_OD_RSTRING The origin/destination parsed from the Route 
String does not match the origin/destination 
field.  

ERROR_DUPLICATE_RCODE The specified Route Code already exists in 
the database.  

ERROR_EMPTY_FIELD The specified field contains no information. 
ERROR_INVALID_CHAR An invalid character was found in the 

specified field. 
ERROR_INVALID_PLAYNAME The specified Associated Play Name was not 

found in the Playbook database.  
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ERROR_MISMATCH_DCNTR The airport/Center information does not 
match what is currently in RMT.  

ERROR_MISSING_PREFIX The specified airport is unknown to RMT, 
the 4-character ICAO airport code is missing. 

ERROR_NUM_CHARS_ORIG_FIELD The Origin field must be 3 or 4 characters in 
length (4 characters for intl cities).  

ERROR_NUM_CHARS_DEST_FIELD The Destination field must be 3 or 4 
characters in length (4 characters for intl 
cities). 

ERROR_NUM_CHARS_ORIG_RSTRING The origin parsed from the route string is not 
3 or 4 characters in length (4 characters for 
intl cities).  

ERROR_NUM_CHARS_DEST_RSTRING The destination parsed from the route string 
is not 3 or 4 characters in length (4 characters 
for intl cities).  

ERROR_TOO_MANY_CHARS Too many characters were entered for the 
specified input field.  

ERROR_UNKNOWN_ACNTR The responsible Center information is not 
currently contained in RMT for the specified 
airport.  

ERROR_UNKNOWN_DCNTR The responsible Center information is not 
currently contained in RMT for the specified 
airport.  
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